EtherMind Mesh SDK (beta): EtherMind Mesh Stack - General Concepts

EtherMind Mesh SDK (beta) 0.2.0
EtherMind Mesh Stack - General Concepts

Conventions

All exported header files are named as MS_*.h

  • The exported headers may in turn include other header files
  • applications need not be include these headers directly
  • All exported API functions are named as MS_*()
  • Similarly all data structures and macros are also prefixed with the name of the associated mesh module
  • Each module interface has following sub-categories: - Defines (Constants, Data Structures, etc.)
  • Error Codes (A few error codes maybe exposed by a module in addition to those defined in MS_error.h)
  • Events (Asynchronous responses and notifications provided by the module to application)
  • Callback (Callback function to be registered by application/calling module to be notified of asynchronous events)

Non-blocking Architecture

EtherMind Mesh Stack APIs are non-blocking in nature. When a calling process/task/application calls a BlueLitE Stack API, the stack initiates API processing and control returns back to the calling process/task/application. After API processing completes, the result is passed to application with a callback. This callback is also used to notify the application of asynchronous events.

Error Handling

All stack API return error codes as API_RESULT - a 2 byte format. The MSB refers to the module returning the error and LSB refers to specific error code in the module. All error codes are documented at Mesh Error Codes or header MS_error.h. (See Also: Error Codes Theory)

To lookup an error:

  • Retrieve the MSB and LSB of the error code
  • Tip: Print the error code in the format:
    printf ("0x%04X", error_code);
  • First lookup the module returning the error (MSB) first under Error Grouping or in header file MS_error.h
  • Then search for specific error code (LSB) under the specific module error code list
  • Example: If the error code is
    0x2312
    MSB 0x23 is under Protocols (0x20 - 0x3F) group module ACCESS_ERR_ID
  • Under ms_error_codes_module_hci errors, search for LSB 0x0012, which is ACCESS_PARAMETER_OUTSIDE_RANGE
Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Getting Started

Getting Started
  • md_mesh_build_doc_getting_started_mesh_concepts
  • md_mesh_build_doc_getting_started_mesh_architecture
  • md_mesh_build_doc_getting_started_mesh_provisioning
  • md_mesh_build_doc_getting_started_mesh_model
  • md_mesh_build_doc_getting_started_ethermind_stack_general_concepts
  • md_mesh_build_doc_getting_started_repository_structure
  • md_mesh_build_doc_getting_started_mesh_porting
  • md_mesh_build_doc_release_notes


EtherMind Mesh SDK (beta): Bluetooth Mesh - Architecture

Bluetooth Mesh - Architecture

Mesh System Architecture

This section will give an overview of Bluetooth Mesh Architecture, its layers and their responsibilities.

BLE Mesh Architecture Block Diagram

Mesh system is dependent on the functionalies exposed by Bluetooth Low Energy (BLE) Stack. This is depicted by a single block for BLE.

Bearer Layer

Mesh messages require an underlying communications system for their transmission and receipt. The bearer layer defines how mesh PDUs will be handled by a given communications system. At this time, two bearers are defined and these are called the Advertising Bearer and the GATT Bearer. The Advertising Bearer leverages Bluetooth LE's GAP advertising and scanning features to convey and receive mesh PDUs. The GATT Bearer allows a device which does not support the Advertising Bearer to communicate indirectly with nodes of a mesh network which do, using a protocol known as the Proxy Protocol. The Proxy Protocol is encapsulated within GATT operations involving specially defined GATT characteristics. A mesh Proxy node implements these GATT characteristics and supports the GATT bearer as well as the Advertising Bearer so that it can convert and relay messages between the two types of bearer.

Network Layer

The network layer defines the various message address types and a network message format which allows transport layer PDUs to be transported by the bearer layer. It can support multiple bearers, each of which may have multiple network interfaces, including the local interface which is used for communication between elements that are part of the same node. The network layer determines which network interface(s) to output messages over. An input filter is applied to messages arriving from the bearer layer, to determine whether or not they should be delivered to the network layer for further processing. Output messages are subject to an output filter to control whether or not they are dropped or delivered to the bearer layer. The Relay and Proxy features may be implemented by the network layer.

Lower Transport Layer

The lower transport layer takes PDUs from the upper transport layer and sends them to the lower transport layer on a peer device. Where required, it performs segmentation and reassembly of PDUs. For longer packets, which will not fit into a single Transport PDU, the lower transport layer will perform segmentation, splitting the PDU into multiple Transport PDUs. The receiving lower transport layer on the other device, will reassemble the segments into a single upper transport layer PDU and pass this up the stack.

Upper Transport Layer

The upper transport layer is responsible for the encryption, decryption and authentication of application data passing to and from the access layer. It also has responsibility for transport control messages, which are internally generated and sent between the upper transport layers on different peer nodes. These include messages related to friendship and heartbeats.

Access Layer

The access layer is responsible for defining how applications can make use of the upper transport layer. This includes:

  • Defining the format of application data.
  • Defining and controlling the encryption and decryption process which is performed in the upper transport layer.
  • Verifying that data received from the upper transport layer is for the right network and application, before forwarding the data up the stack.

Foundation Models

The foundation model layer is responsible for the implementation of those models concerned with the configuration and management of a mesh network.

Models

The model layer is concerned with the implementation of Models and as such, the implementation of behaviors, messages, states, state bindings and so on, as defined in one or more model specifications.


EtherMind Mesh SDK (beta): Bluetooth Mesh - Concepts

Bluetooth Mesh - Concepts

In the following sections we will define the terms and concepts using in Bluetooth Mesh technology.

Devices and Nodes

Devices which are part of a mesh network are called nodes and those which are not are called "unprovisioned devices". The process which transforms an unprovisioned device into a node is called "provisioning".

Provisioning is a secure procedure which results in an unprovisioned device possessing a series of encryption keys and being known to the Provisioner device, typically a tablet or smartphone. One of these keys is called the network key or NetKey for short.

Securely acquiring a NetKey through the provisioning process is a fundamental first step of Bluetooth Mesh technology.

Elements

Some nodes have multiple, constituent parts, each of which can be independently controlled. In Bluetooth mesh terminology, these parts are called elements.

Messages

When a node needs to query the status of other nodes or needs to control other nodes in some way, it sends a message of a suitable type. If a node needs to report its status to other nodes, it sends a message. All communication in the mesh network is "messageoriented" and many message types are defined, each with its own, unique opcode.

Messages fall within one of two broad categories; acknowledged or unacknowledged. Acknowledged messages require a response from nodes that receive them. The response serves two purposes: it confirms that the message it relates to was received, and it returns data relating to the message recipient to the message sender.

The sender of an acknowledged message may resend the message if it does not receive the expected response(s) and therefore, acknowledged messages must be idempotent. This means that the effect of a given acknowledged message, arriving at a node multiple times, will be the same as it had only been received once.

Unacknowledged messages do not require a response.

Addresses

Bluetooth mesh defines three types of addresses. Messages must be sent from and to an address.

A unicast address uniquely identifies a single element. Unicast addresses are assigned to devices during the provisioning process.

A virtual address is an address which may be assigned to one or more elements, spanning one or more nodes. It takes the form of a 128-bit UUID value with which any element can be associated and is much like a label. Virtual addresses will likely be preconfigured at the point of manufacture and be used for scenarios such as allowing the easy addressing of all meeting room projectors made by this manufacturer.

A group address is a multicast address which represents one or more elements. Group addresses are either defined by the Bluetooth Special Interest Group (SIG) and are known as SIG Fixed Group Addresses or are assigned dynamically. 4 SIG Fixed Group Addresses have been defined. These are named All-proxies, All-friends, All-relays and All-nodes.

It is expected that dynamic group addresses will be established by the user via a configuration application and that they will reflect the physical configuration of a building, such as defining group addresses which correspond to each room in the building.

Publish/Subscribe

The act of sending a message is known as publishing. Nodes are configured to select messages sent to specific addresses for processing, and this is known as subscribing.

Typically, messages are addressed to group or virtual addresses. Group and virtual address names will have readily understood meaning to the end user, making them easy and intuitive to use.

The use of group and virtual addresses with the publish/ subscribe communication model has an additional, substantial benefit in that removing, replacing or adding new nodes to the network does not require reconfiguration of other nodes.

State and Properties

Elements can be in various conditions and this is represented in Bluetooth mesh by the concept of state values. A state is a value of a certain type, contained within an element. As well as values, States also have associated behaviors and may not be reused in other contexts. As an example, consider a simple light which may either be on or off. Bluetooth mesh defines a state called Generic OnOff. The light would possess this state item and a value of On would correspond to and cause the light to be illuminated whereas a Generic OnOff state value of Off would reflect and cause the light to be switched off.

Properties are similar to states in that they contain values relating to an element. But they are significantly different to states in other ways. A property provides the context for interpreting a characteristic. To appreciate the significance and use of contexts as they relate to properties, consider for example, the characteristic Temperature 8, an 8-bit temperature state type which has a number of associated properties, including Present Indoor Ambient Temperature and Present Outdoor Ambient Temperature. These two properties allow a sensor to publish sensor readings in a way that allows a receiving client to determine the context the temperature value has, making better sense of its true meaning. Properties are organized into two categories: Manufacturer, which is a read-only category and Admin which allows read-write access.

Messages, States and Properties

Messages are the mechanism by which operations on the mesh are invoked. Formally, a given message type represents an operation on a state or collection of multiple state values. All messages are of three broad types, reflecting the types of operation which Bluetooth mesh supports. The shorthand for the three types is GET, SET and STATUS.

GET messages request the value of a given state from one or more nodes. A STATUS message is sent in response to a GET and contains the relevant state value. SET messages change the value of a given state. An acknowledged SET message will result in a STATUS message being returned in response to the SET message whereas an unacknowledged SET message requires no response.

STATUS messages are sent in response to GET messages, acknowledged SET messages or independently of other messages, perhaps driven by a timer running on the element sending the message, for example.

Specific states referenced by messages are inferred from the message opcode. Properties on the other hand, are referenced explicitly in generic property related messages using a 16-bit property ID.

State Transitions

Changes from one state to another are called state transitions. Transitions may be instantaneous or execute over a period of time called the transition time. A state transition is likely to have an effect on the application layer behavior of a node.

Bound States

Relationships may exist between states whereby a change in one triggers a change in the other. Such a relationship is called a state binding. One state may be bound to multiple other states.

For example, consider a light controlled by a dimmer switch. The light would possess the two states, Generic OnOff and Generic Level with each bound to the other. Reducing the brightness of the light until Generic Level has a value of zero (fully dimmed) results in Generic OnOff transitioning from On to Off.

Models

Models pull the preceding concepts together and define some or all of the functionality of an element as it relates to the mesh network. Three categories of model are recognized.

A server model defines a collection of states, state transitions, state bindings and messages which the element containing the model may send or receive. It also defines behaviors relating to messages, states and state transitions.

A client model does not define any states. Instead, it defines the messages which it may send or receive in order to GET, SET or acquire the STATUS of states defined in the corresponding server model.

Control models contain both a server model, allowing communication with other client models and a client model which allows communication with server models.

Provisioning

Provisioning is the process by which a device joins the mesh network and becomes a node. It involves several stages, results in various security keys being generated and is itself a secure process.

The provisioning process progresses through five steps and these are described next.

Beaconing

An unprovisioned device indicates its availability to be provisioned by using the <<Mesh beacon>="">> AD type in advertising packets. The user might need to start a new device advertising in this way by, for example, pressing a combination of buttons or holding down a button for a certain length of time.

Invitation

The Provisioner sends an invitation to the device to be provisioned, in the form of a Provisioning Invite PDU. The Beaconing device responds with information about itself in a Provisioning Capabilities PDU.

Exchanging Public Keys

The Provisioner and the device to be provisioned, exchange their public keys, which may be static or ephemeral, either directly or using an out-of-band (OOB) method.

Authentication

The device to be provisioned outputs a random, single or multi-digit number to the user in some form, using an action appropriate to its capabilities. For example, it might flash an LED several times. The user enters the digit(s) output by the new device into the Provisioner and a cryptographic exchange takes place between the two devices, involving the random number, to complete the authentication of each of the two devices to the other.

Distribution of the Provisioning Data

After authentication has successfully completed, a session key is derived by each of the two devices from their private keys and the exchanged, peer public keys. The session key is then used to secure the subsequent distribution of the data required to complete the provisioning process, including a security key known as the network key (NetKey). After provisioning has completed, the provisioned device possesses the network's NetKey, a mesh security parameter known as the IV Index and a Unicast Address, allocated by the Provisioner. It is now known as a node.

Features

All nodes can transmit and receive mesh messages but there are a number of optional features which a node may possess, giving it additional, special capabilities. There are four such optional features: the Relay, Proxy, Friend, and the Low Power features.

A node may support zero or more of these optional features and any supported feature may, at a point in time, be enabled or disabled.

Relay Nodes

Relaying is the mechanism by which a message can traverse the entire mesh network, making multiple "hops" between devices by being relayed. Nodes which support the Relay feature, known as Relay nodes, are able to retransmit received messages.

Low Power Nodes and Friend Nodes

Some types of node have a limited power source and need to conserve energy as much as possible. Furthermore, devices of this type may be predominantly concerned with sending messages but still have a need to occasionally receive messages.

Consider a temperature sensor which is powered by a small coin cell battery. It sends a temperature reading once per minute whenever the temperate is above or below configured upper and lower thresholds. If the temperature stays within those thresholds it sends no messages. These behaviors are easily implemented with no particular issues relating to power consumption arising.

However, the user is also able to send messages to the sensor which change the temperature threshold state values. This is a relatively rare event but the sensor must support it.

Nodes like the temperature sensor in the example may be designated Low Power nodes (LPNs) and a feature flag in the sensor's configuration data will designate the node as such.

LPNs work in tandem with another node, one which is not power-constrained (e.g. it has a permanent AC power source). This device is termed a Friend node. The Friend stores messages addressed to the LPN and delivers them to the LPN whenever the LPN polls the Friend node for "waiting messages". The LPN may poll the Friend relatively infrequently so that it can balance its need to conserve power with the timeliness with which it needs to receive and process configuration messages. When it does poll, all messages stored by the Friend are forwarded to the LPN, one after another, with a flag known as MD (More Data) indicating to the LPN whether there are further messages to be sent from the Friend node.

The relationship between the LPN and the Friend node is known as friendship. Friendship is key to allowing very power constrained nodes which need to receive messages, to function in a Bluetooth mesh network whilst continuing to operate in a power-efficient way.

Proxy Nodes

Proxy nodes allow Bluetooth LE devices that do not possess a Bluetooth mesh stack to interact with nodes in a mesh network.

Proxy nodes expose a GATT interface which Bluetooth LE devices may use to interact with a mesh network. A protocol called the Proxy Protocol, intended to be used with a connection-oriented bearer, such as GATT is defined. GATT devices read and write Proxy Protocol PDUs from within GATT characteristics implemented by the Proxy node. The Proxy node transforms these PDUs to/from mesh PDUs.

Node Configuration

Each node supports a standard set of configuration states which are implemented within the standard Configuration Server Model and accessed using the Configuration Client Model. Configuration State data is concerned with the node's capabilities and behavior within the mesh, independently of any specific application or device type behaviors.

For example, the features supported by a node, whether it is a Proxy node, a Relay node and so on, are indicated by Configuration Server states. The addresses to which a node has subscribed are stored in the Subscription List. The network and subnet keys indicating the networks the node is a member of are listed in the configuration block, as are the application keys held by the mode.

A series of configuration messages allow the Configuration Client Model and Configuration Server Model to support GET, SET and STATUS operations on the Configuration Server Model states.


EtherMind Mesh SDK (beta): Mesh Model

Mesh Model

Introduction

Models defines typical user scenario, associated states, messages (get, set, status) operate on defined states.

Model and Access Layer

Models registers themself with Acess Layer.

The following diagram illustrate the model hierarchy.

Model Hierarchy

Access Layer MSCs

Access Layer API Usage


EtherMind Mesh SDK (beta): MESH IP Porting

MESH IP Porting

1. What are the BLE{GAP} APIs that MESH stack expects from the below Platform/Stack ?

The following table depicts the mapping between the BLE functionality sepcific to the GAP Layer as defined in BT Specification and their corresponding calls to look for in a Bluetooth Low Energy SDK. Support for Advertising bearer is mandatory.

SL# |  | BLE Functionality | Generic BLE GAP API Calls needed from SDK | Notes (if any)
1 |  | Get Local ADDR | API to get the local BT Device Address |
2 |  | Add to WhiteList | API to add a BT Device Address to WhiteList | <Optional>Used only for provisioning scenarios, during Development Phase.
3 |  | ADV |  |
 | a | Start | API to start (Legacy)ADV |
 | b | Stop | API to stop (Legacy)ADV |
 | c | Update Data | API to update (Legacy)ADV Data |
4 |  | SCAN |  |
 | a | Start | API to start (Legacy)SCAN |
 | b | Stop | API to stop (Legacy)SCAN |
5 |  | ADV Reports | Pass on received ADV reports |
6 |  | Connection | API to Initiate LE Connection to Peer | Required only if GATT bearer to be used.

2. What are the BLE{GATT} APIs that MESH stack expects from the below Platform/Stack ?

The following table depicts the mapping between the BLE functionality sepcific to the GATT Layer as defined in BT Specification and their corresponding calls to look for in a Bluetooth Low Energy SDK. Support for GATT bearer is optional. These GATT interfaces are used for proxy feature and also during provisioning over GATT (if required).

SL# |  | BLE Functionality | Generic BLE GATT API Calls needed from SDK | Notes (if any)
1 |  | GATT Client |  |
 | a | Service Discovery | API to Discover all Peer GATT Services |
 | b | Char Discovery | API to Discover all Peer GATT Characteristics |
 | c | CCCD Write | API to write to Peer CCCD for HVI/HVN |
 | d | Write Command | API to send Write Without Response(WWR) |
 | e | Recv HVI/HVN | Pass on received HVI/HVN |
2 |  | GATT Server |  |
 | a | Service Presence | Have, add, enable or disable a service |
 | b | Char Presence | Have, add, enable or disable Characteristics |
 | c | Send HVI/HVN | API to send HVI/HVN when CCCD is configured |
 | d | Recv WWR | Pass on received WWR |

3. What are the Utility APIs that MESH stack expects from the below Platform/Stack ?

The following table depicts the list of Utility functionality Interfaces expected to be present in a Bluetooth Low Energy SDK which are to be used by the Mesh Stack.

SL# |  | Utility Functions | Generic API Calls needed from SDK | Notes (if any)
1 |  | Stack ON | API to Initialize/Start the BLE Stack/System | Interface to Initialize the Underlying BLE Stack
2 |  | Stack OFF | API to Kill/Power Off the BLE Stack/System | Interface to Shutdown the Underlying BLE Stack
3 |  | Timer | MilliSecond Granularity |
 | a | Start Timer | API to start a Timer | Interface to Start a Timer with MilliSecond Granularity
 | b | Stop Timer | API to stop a Timer | Interface to Stop a current running Timer
4 |  | Miscellaneous | Miscellaneous Requirements | Storage is required to store supported models/elements related information (publish/subscription list etc.).
 | a | Flash Write | API to write to Storage | Interface to fecilitate Flash/NVRAM Write etc.
 | b | Flash Read | API to read from Storage | Interface to fecilitate Flash/NVRAM Read etc.
 | c | Debug Support | Debug Support to divert logs to IO or File | (Optional) Divert Logs to CONSOLE/IO/File etc. Will help in debugging.
 | d | Serial Interface | Serial interface support over UART etc. | (Optional) Can be used for easy demonstration and also for simple test setup. This would help in creating a generic CommandLineInterace[CLI] over which Mesh Stack related commands can be issued.

Below is a example of a interface required from the platform to start a Timer[with Millisecond Granularity]:-

int util_start_timer
    (
        /* OUT */  timer_handle * handle,
        /* IN */   usigned int    timeout,
        /* IN */   void         * timer_callback_fn
    );

Below is a example of a interface required from the platform to write data to Flash/NVRAM :-

int flash_nvram_write
    (
        /* IN */ void          * flash_nvram_memory_identifier_handle,
        /* IN */ unsigned int    flash_nvram_addr,
        /* IN */ unsigned char * data_to_be_flahsed,
        /* IN */ unsigned int    len_of_data_to_br_flashed
     );

4. What are the BLE{Security} interfaces that MESH stack expects from the below Platform/Stack ?

The following table depicts the mapping between the BLE functionality sepcific to the Security Toolbox as defined in BT Specification and their corresponding calls to look for in a Bluetooth Low Energy SDK.

While it is possible to have some of these implementations in software, it is highly recommended that Bluetooth controller/platform provides Direct Function Call based interface for the listed security algorithms.

SL# |  | Security Functionality | Generic BLE Security Interfaces needed from SDK | Notes (if any)
1 |  | AES 128 | AES 128 |
 | a | AES 128 Encrypt | Interface to encrypt using AES 128 |
 | b | AES 128 Decrypt | Interface to decrypt using AES 128 | Both Encrypt and Decrypt could be the same interface, AES 128 Encrypt
2 |  | AES CMAC | AES CMAC Algorithm |
 | a | CMAC Generation | Interface for generating MAC of given Len |
 | b | CMAC Verification | Interface for verifying MAC of given Len | Both Generation and Verification can use the same Interface.
3 |  | AES CCM | AES CCM Algorithm |
 | a | CCM Encryption | Interface for encrypting plain text |
 | b | CCM Decryption | Interface for decrypting cipher text |
4 |  | ECDH | ECDH Algorithm |
 | a | P256 Keypair generate | Interface to get P256 Public Key |
 | b | DHKey generate | Interface to generate DHkey |
 | c | Set P256 Debug Keys | Interface to set P256 debug Key pairs | (Optional) Will help in debugging using Mesh Spec provided sample data and while decoding using Air-Sniffers
5 |  | Random Number Generator | Interface to generate N bytes of Random Number |

Below is a example of a interface required by the platform for AES CMAC, one of the security related functionalities :-

int sec_tbx_example_aes_128_cmac_gen_pl
    (
        /* IN */  unsigned char      * pdata,
        /* IN */  unsigned short int   datalen,
        /* IN */  unsigned char      * pkey,
        /* IN */  unsigned short int   maclen,
        /* OUT */ unsigned char      * pmac
    );


EtherMind Mesh SDK (beta): Mesh Provisioning

Mesh Provisioning

Introduction

Provisioning is the process of adding a new device to the network. During the provisioning process the new device is provided with information called provisioning data required for the device to join and operate in the network. The provisioning data contains a network key and an unique address. Device key is derived from the network key and is used for secure communication between the device (provisionee) and the configuring device (provisioner).

Provisioning procedure

The following diagrams illustrate the provisioning procedures for various OOB configuration.

Provisioning Procedure - No OOB
Provisioning Procedure - Input OOB
Provisioning Procedure - Output OOB

Provisioning state machine

Provisioner State Machine
Provisionee State Machine


EtherMind Mesh SDK (beta): Repository Structure

Repository Structure

EtherMind Mesh repository is organized as follows

  • mesh contains the source code and unit tests for the mesh stack
    • mesh/export/include contains the Mesh API headers for the mesh core stack library
    • mesh/private contains core Mesh implementation
    • mesh/build contains build scripts, makefile for Mesh implementation
    • mesh/export/lib contains libraries used by the mesh stack and examples
    • mesh/export/cli contains Console Interface based applications using the mesh stack
    • mesh/export/examples contains menu based example applications using the mesh stack


EtherMind Mesh SDK (beta): Release Notes (BLE Mesh)

Release Notes (BLE Mesh)

v0.2.0 (Beta)

Model APIs

  • Added APIs for various models (Generic, Light etc.)

v0.1.1 (Alpha)

Updated Mesh Porting Section

  • Added sections for GATT and Security interface requirements.
  • Edited GAP requirement section to make it more generic, by removing direct mapping with HCI specific interface, as in many environment the Mesh porting layer might have to be mapped to exposed GAP interface, as compared to direct HCI calls.

Corrected .chm view issue observed in some of the systems

  • Removed reference to embedded javascript in the generated html files causing this observation.


EtherMind Mesh SDK (beta): API Reference

API Reference
Here is a list of all modules:
[detail level 12345]
o ACCESS (Mesh Access Layer) | This section describes the interfaces & APIs offered by the EtherMind Mesh Access (ACCESS) module to the Application and other upper layers of the stack
| o API Definitions | This section describes the EtherMind Mesh Access Layer APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| o Defines | Describes defines for the module
| | \ Constants | Describes Constants defined by the module
| o Events | This section lists the Asynchronous Events notified to Application by the Module
| o Structures |
| \ Utility Macros | This section defines the utility macros for use by the application
o BEARER (Mesh Bearer Layer) | This section describes the interfaces & APIs offered by the EtherMind Mesh Bearer (BEARER) module to the Application and other upper layers of the stack
| o API Definitions | This section describes the EtherMind Mesh Bearer Layer APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| o Defines | Describes defines for the module
| | o Constants | Describes Constants defined by the module
| | \ Structures |
| \ Events | This section lists the Asynchronous Events notified to Application by the Module
| \ Utility Macros | Initialization and other Utility Macros offered by the module
o CONFIG (Mesh Configuration Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Configuration Model (CONFIG) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Config Model APIs
| | o Configuration Client API Definitions | This section describes the Configuration Client APIs
| | \ Configuration Server API Definitions | This section describes the Configuration Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| o Defines | Describes defines for the module
| | \ Constants | Describes Constants defined by the module
| | \ Status Codes | This section lists the Status Codes applicable at the Configuration Model
| o Events | This section lists the Asynchronous Events notified to Application by the Module
| o Structures |
| | \ Configuration Client Data Structures | This section describes the data structures for use in Configuration Client APIs
| \ Utility Macros | This section defines the utility macros for use by the application
o Fault Values | This section lists the Fault Values defined for Health Model
o GENERIC_BATTERY (Mesh Generic Battery Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Battery Model APIs
| | o Generic Battery Client API Definitions | This section describes the Generic Battery Client APIs
| | \ Generic Battery Server API Definitions | This section describes the Generic Battery Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o GENERIC_DEFAULT_TRANSITION_TIME (Mesh Generic Default Transition Time Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Default Transition Time Model APIs
| | o Generic Default Transition Time Client API Definitions | This section describes the Generic Default Transition Time Client APIs
| | \ Generic Default Transition Time Server API Definitions | This section describes the Generic Default Transition Time Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o GENERIC_LEVEL (Mesh Generic Level Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Level Model APIs
| | o Generic Level Client API Definitions | This section describes the Generic Level Client APIs
| | \ Generic Level Server API Definitions | This section describes the Generic Level Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o GENERIC_LOCATION (Mesh Generic Location Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Location Model APIs
| | o Generic Location Client API Definitions | This section describes the Generic Location Client APIs
| | \ Generic Location Server API Definitions | This section describes the Generic Location Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o GENERIC_ONOFF (Mesh Generic Onoff Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Onoff Model APIs
| | o Generic Onoff Client API Definitions | This section describes the Generic Onoff Client APIs
| | \ Generic Onoff Server API Definitions | This section describes the Generic Onoff Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o GENERIC_POWER_LEVEL (Mesh Generic Power Level Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Power Level Model APIs
| | o Generic Power Level Client API Definitions | This section describes the Generic Power Level Client APIs
| | \ Generic Power Level Server API Definitions | This section describes the Generic Power Level Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o GENERIC_POWER_ONOFF (Mesh Generic Power Onoff Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Power Onoff Model APIs
| | o Generic Power Onoff Client API Definitions | This section describes the Generic Power Onoff Client APIs
| | \ Generic Power Onoff Server API Definitions | This section describes the Generic Power Onoff Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o GENERIC_PROPERTY (Mesh Generic Property Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic Property Model (GENERIC_PROPERTY) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Generic Property Model APIs
| | o Generic Property Client API Definitions | This section describes the Generic Property Client APIs
| | \ Generic User Property Server API Definitions | This section describes the Generic User Property Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o HEALTH (Mesh Health Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Health Model (HEALTH) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Health Model APIs
| | \ Health Client API Definitions | This section describes the Health Client APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o Health Server Events | This section lists the Application Events defined for Health Server Model
o LIGHT_CTL (Mesh Light Ctl Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Light Ctl Model APIs
| | o Light Ctl Client API Definitions | This section describes the Light Ctl Client APIs
| | \ Light Ctl Server API Definitions | This section describes the Light Ctl Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o LIGHT_HSL (Mesh Light Hsl Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Light Hsl Model APIs
| | o Light Hsl Client API Definitions | This section describes the Light Hsl Client APIs
| | \ Light Hsl Server API Definitions | This section describes the Light Hsl Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o LIGHT_LC (Mesh Light Lc Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Light Lc Model APIs
| | o Light Lc Client API Definitions | This section describes the Light Lc Client APIs
| | \ Light Lc Server API Definitions | This section describes the Light Lc Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o LIGHT_LIGHTNESS (Mesh Light Lightness Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Light Lightness Model APIs
| | o Light Lightness Client API Definitions | This section describes the Light Lightness Client APIs
| | \ Light Lightness Server API Definitions | This section describes the Light Lightness Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o LIGHT_XYL (Mesh Light Xyl Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Light Xyl Model APIs
| | o Light Xyl Client API Definitions | This section describes the Light Xyl Client APIs
| | \ Light Xyl Server API Definitions | This section describes the Light Xyl Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o LTRANSPORT (Mesh Lower Transport Layer) | This section describes the interfaces & APIs offered by the EtherMind Mesh Lower Transport (LTRANSPORT) module to the Application and other upper layers of the stack
| o API Definitions | TCF (Transport Control Field) - Transport Field Value
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| o Defines | Describes defines for the module
| | o Constants | Describes Constants defined by the module
| | o Events | This section lists the Asynchronous Events notified to Application by the Module
| | \ Structures |
| \ Utility Macros | Initialization and other Utility Macros offered by the module
o MESH Common |
| o API Definitions |
| o Constants |
| o Defines |
| | o Common |
| | o Constants |
| | o Mesh Error Codes | This section contains all the error codes defined for Mesh stack and profiles
| | | o Defines |
| | | o Error Grouping |
| | | | o Core Modules (0x10 - 0x1F) | Error IDs for Mesh Core Modules (0x10 - 0x1F)
| | | | o Protocols (0x20 - 0x3F) | Error IDs for Mesh Protocol Modules (0x20 - 0x3F)
| | | | \ Specification Error Codes (0x00 - 0x0F) | Error IDs for Bluetooth Specification Defined Error Codes (0x00 - 0x0F)
| | | \ Mesh Result Codes |
| | \ Structures |
| \ Utility Macros |
o NETWORK (Mesh Network Layer) | This section describes the interfaces & APIs offered by the EtherMind Mesh Network (NETWORK) module to the Application and other upper layers of the stack
| o API Definitions | This section describes the EtherMind Mesh Network Layer APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| o Defines | Describes defines for the module
| | o Constants | Describes Constants defined by the module
| | | o Addressing | Describes five basic type of addresses, the Network Layer defines
| | | \ Proxy | Describes Network Layer Proxy Feature related defines
| | o Events | This section lists the Asynchronous Events notified to Application by the Module
| | o Proxy | Describes Network Layer Proxy Feature related defines
| | \ Structures |
| \ Utility Macros | Initialization and other Utility Macros offered by the module
o PROVISIONING (Mesh Provisioning Layer) | This section describes the interfaces & APIs offered by the EtherMind Mesh Provisioning module to the Application and other upper layers of the stack
| o API Definitions | This section describes the EtherMind Mesh Provisioning Layer APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| o Defines | Describes defines for the module
| | o Constants | Describes Constants defined by the module
| | | o ADV Transport Opcodes | Specification defined transport Opcodes for PB-ADV bearer
| | | o Control Constants | Control constants defined by the specification
| | | o Error Codes | Describes Error Codes defined by the specification
| | | \ GATT Transport Opcodes | Implementation specific transport Opcodes for PB-GATT bearer
| | o Events | This section lists the Asynchronous Events notified to Application by the Module
| | \ Structures |
| \ Utility Macros | Initialization and other Utility Macros offered by the module
o SCENE (Mesh Scene Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Scene Model (SCENE) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Scene Model APIs
| | o Scene Client API Definitions | This section describes the Scene Client APIs
| | \ Scene Server API Definitions | This section describes the Scene Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o SCHEDULER (Mesh Scheduler Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Scheduler Model APIs
| | o Scheduler Client API Definitions | This section describes the Scheduler Client APIs
| | \ Scheduler Server API Definitions | This section describes the Scheduler Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o SENSOR (Mesh Sensor Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Sensor Model APIs
| | o Sensor Client API Definitions | This section describes the Sensor Client APIs
| | \ Sensor Server API Definitions | This section describes the Sensor Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
o TIME (Mesh Time Model) | This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application
| o API Definitions | This section describes the EtherMind Mesh Time Model APIs
| | o Time Client API Definitions | This section describes the Time Client APIs
| | \ Time Server API Definitions | This section describes the Time Server APIs
| o Application Callback | This Section Describes the module Notification Callback interface offered to the application
| \ Structures |
\ TRANSPORT (Mesh Transport Layer) | This section describes the interfaces & APIs offered by the EtherMind Mesh Transport (TRANSPORT) module to the Application and other upper layers of the stack
o API Definitions | TCF (Transport Control Field) - Transport Field Value
o Application Callback | This Section Describes the module Notification Callback interface offered to the application
o Defines | Describes defines for the module
| o Constants | Describes Constants defined by the module
| o Events | This section lists the Asynchronous Events notified to Application by the Module
| \ Structures |
\ Utility Macros | Initialization and other Utility Macros offered by the module


EtherMind Mesh SDK (beta): ACCESS (Mesh Access Layer)

Modules | Typedefs
ACCESS (Mesh Access Layer)

This section describes the interfaces & APIs offered by the EtherMind Mesh Access (ACCESS) module to the Application and other upper layers of the stack. More...

Modules

API Definitions
This section describes the EtherMind Mesh Access Layer APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Defines
Describes defines for the module.
Events
This section lists the Asynchronous Events notified to Application by the Module.
Structures
Utility Macros
This section defines the utility macros for use by the application.

Typedefs

typedef UINT16 MS_ACCESS_MODEL_HANDLE
Access Model Handle.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Access (ACCESS) module to the Application and other upper layers of the stack.


EtherMind Mesh SDK (beta): API Definitions

Macros | Functions
API Definitions
ACCESS (Mesh Access Layer)

This section describes the EtherMind Mesh Access Layer APIs. More...

Macros

#define | MS_ENABLE_RELAY_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_RELAY)
Enable Relay Feature.
#define | MS_DISABLE_RELAY_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_RELAY)
Disable Relay Feature.
#define | MS_ENABLE_PROXY_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_PROXY)
Enable Proxy Feature.
#define | MS_DISABLE_PROXY_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_PROXY)
Disable Proxy Feature.
#define | MS_ENABLE_FRIEND_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_FRIEND)
Enable Friend Feature.
#define | MS_DISABLE_FRIEND_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_FRIEND)
Disable Friend Feature.
#define | MS_ENABLE_LPN_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_LPN)
Enable Low Power Feature.
#define | MS_DISABLE_LPN_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_LPN)
Disable Low Power Feature.

Functions

API_RESULT | MS_access_create_node (MS_ACCESS_NODE_ID *node_id)
Create a new node in the device. More...
API_RESULT | MS_access_register_element (MS_ACCESS_NODE_ID node_id, MS_ACCESS_ELEMENT_DESC *element, MS_ACCESS_ELEMENT_HANDLE *element_handle)
Register an element with the access layer. More...
API_RESULT | MS_access_register_model (MS_ACCESS_NODE_ID node_id, MS_ACCESS_MODEL *model, MS_ACCESS_MODEL_HANDLE *model_handle)
Register a model with the access layer. More...
API_RESULT | MS_access_get_element_handle (MS_NET_ADDR elem_addr, MS_ACCESS_ELEMENT_HANDLE *handle)
Get element handle. More...
API_RESULT | MS_access_get_model_handle (MS_ACCESS_ELEMENT_HANDLE elem_handle, MS_ACCESS_MODEL_ID model_id, MS_ACCESS_MODEL_HANDLE *handle)
Get model handle. More...
API_RESULT | MS_access_publish (MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len, UINT8 reliable)
API to publish access layer message. More...
API_RESULT | MS_access_reply (MS_ACCESS_MODEL_HANDLE *handle, MS_NET_ADDR saddr, MS_NET_ADDR daddr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT8 ttl, UINT32 opcode, UCHAR *data_param, UINT16 data_length)
API to reply to access layer message. More...
API_RESULT | MS_access_send_pdu (MS_NET_ADDR saddr, MS_NET_ADDR daddr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT8 ttl, UINT32 opcode, UCHAR *data_param, UINT16 data_length)
API to send Access PDUs. More...
API_RESULT | MS_access_get_composition_data (MS_BUFFER *buffer)
TBD: add function header.
API_RESULT | MS_access_cm_reset (void)
To reset a node. More...
API_RESULT | MS_access_cm_get_element_count (UINT8 *count)
To get the number of elements in local node. More...
API_RESULT | MS_access_cm_set_primary_unicast_address (MS_NET_ADDR addr)
To set primary unicast address. More...
API_RESULT | MS_access_cm_get_primary_unicast_address (MS_NET_ADDR *addr)
To get primary unicast address. More...
API_RESULT | MS_access_cm_set_default_ttl (UINT8 ttl)
To set default TTL. More...
API_RESULT | MS_access_cm_get_default_ttl (UINT8 *ttl)
To get default TTL. More...
API_RESULT | MS_access_cm_set_iv_index (UINT32 iv_index, UINT8 iv_update_flag)
To set IV Index. More...
API_RESULT | MS_access_cm_get_iv_index (UINT32 *iv_index, UINT8 *iv_update_flag)
To get IV Index. More...
API_RESULT | MS_access_cm_get_iv_index_by_ivi (UINT8 ivi, UINT32 *iv_index)
To get IV Index by IVI. More...
API_RESULT | MS_access_cm_set_features_field (UINT8 enable, UINT8 feature)
To enable/disable a feature. More...
API_RESULT | MS_access_cm_get_features_field (UINT8 *enable, UINT8 feature)
To get state of a feature. More...
API_RESULT | MS_access_cm_get_features (UINT8 *features)
To get state of all features. More...
API_RESULT | MS_access_cm_get_friendship_role (UINT8 *frnd_role)
To get friendship role of the node. More...
API_RESULT | MS_access_cm_set_friendship_role (UINT8 frnd_role)
To set friendship role of the node. More...
API_RESULT | MS_access_cm_add_device_key (UINT8 *dev_key, MS_NET_ADDR uaddr, UINT8 num_elements)
To add Device Key. More...
API_RESULT | MS_access_cm_get_device_key (UINT8 dev_key_index, UINT8 **dev_key)
To get Device Key. More...
API_RESULT | MS_access_cm_remove_all_device_keys (void)
To remove all Device Keys. More...
API_RESULT | MS_access_cm_get_prov_devices_list (MS_PROV_DEV_ENTRY *prov_dev_list, UINT16 *num_entries)
To get list of Provisioned Device List. More...
API_RESULT | MS_access_cm_get_device_key_handle (MS_NET_ADDR prim_elem_uaddr, MS_ACCESS_DEV_KEY_HANDLE *handle)
To get Device Key Handle. More...
API_RESULT | MS_access_cm_get_app_key (MS_APPKEY_HANDLE appkey_handle, UINT8 **app_key, UINT8 *aid)
To get AppKey. More...
API_RESULT | MS_access_cm_add_update_netkey (UINT16 netkey_index, UINT32 opcode, UINT8 *net_key)
To add/update NetKey. More...
API_RESULT | MS_access_cm_add_friend_sec_credential (MS_SUBNET_HANDLE subnet_handle, UINT16 friend_offset, MS_NET_ADDR lpn_addr, MS_NET_ADDR friend_addr, UINT16 lpn_counter, UINT16 friend_counter)
To add Security Credential of a LPN or the Friend. More...
API_RESULT | MS_access_cm_delete_friend_sec_credential (MS_SUBNET_HANDLE subnet_handle, UINT16 friend_index)
To delete the Security Credential of a LPN or the Friend. More...
API_RESULT | MS_access_cm_find_subnet (UINT16 netkey_index, MS_SUBNET_HANDLE *subnet_handle)
To find a Subnet associated with the NetKey. More...
API_RESULT | MS_access_cm_delete_netkey (MS_SUBNET_HANDLE subnet_handle)
To delete NetKey. More...
API_RESULT | MS_access_cm_get_netkey (MS_SUBNET_HANDLE subnet_handle, UINT8 *net_key)
To get NetKey. More...
API_RESULT | MS_access_cm_get_netkey_index_list (UINT16 *netkey_count, UINT16 *netkey_index_list)
To get list of all known NetKeys. More...
API_RESULT | MS_access_cm_lookup_nid (UINT8 nid, MS_SUBNET_HANDLE *subnet_handle, UINT8 *privacy_key, UINT8 *encrypt_key)
To search for NID. More...
API_RESULT | MS_access_cm_lookup_network_id (UINT8 *network_id, MS_SUBNET_HANDLE *subnet_handle, UINT8 *beacon_key, UINT8 *is_new_key)
To search for Network ID. More...
API_RESULT | MS_access_cm_lookup_aid (UINT8 aid, MS_APPKEY_HANDLE *appkey_handle, UINT8 *app_key)
To search for AID. More...
API_RESULT | MS_access_cm_set_prov_data (PROV_DATA_S *prov_data)
Set Provisioning Data. More...
API_RESULT | MS_access_cm_get_subnet_nid (MS_SUBNET_HANDLE handle, UINT8 *nid)
To get NID associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_privacy_key (MS_SUBNET_HANDLE handle, UINT8 *privacy_key)
To get Privacy Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_network_id (MS_SUBNET_HANDLE handle, UINT8 *network_id)
To get Network ID associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_beacon_key (MS_SUBNET_HANDLE handle, UINT8 *beacon_key)
To get Beacon Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_identity_key (MS_SUBNET_HANDLE handle, UINT8 *identity_key)
To get Identity Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_encryption_key (MS_SUBNET_HANDLE handle, UINT8 *encrypt_key)
To get Encryption Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_node_identity (MS_SUBNET_HANDLE subnet_handle, UINT8 *id_state)
To get Node Identity. More...
API_RESULT | MS_access_cm_set_node_identity (MS_SUBNET_HANDLE subnet_handle, UINT8 *id_state)
To set Node Identity. More...
API_RESULT | MS_access_cm_get_key_refresh_phase (MS_SUBNET_HANDLE subnet_handle, UINT8 *key_refresh_state)
To get Key Refresh Phase. More...
API_RESULT | MS_access_cm_set_key_refresh_phase (MS_SUBNET_HANDLE subnet_handle, UINT8 *key_refresh_state)
To set Key Refresh Phase. More...
API_RESULT | MS_access_cm_set_transmit_state (UINT8 tx_state_type, UINT8 tx_state)
To set Network/Relay Transmit state. More...
API_RESULT | MS_access_cm_get_transmit_state (UINT8 tx_state_type, UINT8 *tx_state)
To get Network/Relay Transmit state. More...
API_RESULT | MS_access_cm_add_appkey (MS_SUBNET_HANDLE subnet_handle, UINT16 appkey_index, UINT8 *app_key)
To add AppKey. More...
API_RESULT | MS_access_cm_update_delete_appkey (MS_SUBNET_HANDLE subnet_handle, UINT16 appkey_index, UINT32 opcode, UINT8 *app_key)
To update/delete AppKey. More...
API_RESULT | MS_access_cm_get_appkey_handle (MS_SUBNET_HANDLE subnet_handle, UINT16 appkey_index, UINT8 *app_key, MS_APPKEY_HANDLE *appkey_handle)
To get AppKey Handle for a given AppKey Index. More...
API_RESULT | MS_access_cm_get_appkey_index_list (MS_SUBNET_HANDLE subnet_handle, UINT16 *appkey_count, UINT16 *appkey_index_list)
To get list of all known AppKeys. More...
API_RESULT | MS_access_bind_model_app (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 appkey_index)
To bind a model with an AppKey. More...
API_RESULT | MS_access_unbind_model_app (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 appkey_index)
To unbind a model with an AppKey. More...
API_RESULT | MS_access_cm_get_model_app_list (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 *appkey_count, UINT16 *appkey_index_list)
To get list of all AppKeys associated with a model. More...
API_RESULT | MS_access_cm_set_model_publication (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_PUBLISH_INFO *publish_info)
To set Publication information associated with a model. More...
API_RESULT | MS_access_cm_get_model_publication (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_PUBLISH_INFO *publish_info)
To get Publication information associated with a model. More...
API_RESULT | MS_access_cm_add_model_subscription (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_ADDRESS *sub_addr)
To add an address to a model subscription list. More...
API_RESULT | MS_access_cm_delete_model_subscription (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_ADDRESS *sub_addr)
To delete an address to a model subscription list. More...
API_RESULT | MS_access_cm_delete_all_model_subscription (MS_ACCESS_MODEL_HANDLE model_handle)
To discard a model subscription list. More...
API_RESULT | MS_access_cm_get_model_subscription_list (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 *sub_addr_count, UINT16 *sub_addr_list)
To get list of subscription addresses of a model. More...
API_RESULT | MS_access_cm_get_all_model_subscription_list (UINT16 *sub_addr_count, UINT16 *sub_addr_list)
To get list of subscription addresses of all the models. More...
API_RESULT | MS_access_is_valid_element_address (MS_NET_ADDR addr)
To check if valid element address to receive a packet. More...
API_RESULT | MS_access_is_fixed_group_addr_to_be_processed (MS_NET_ADDR addr)
To check if Fixed Group Address in receive packet to be processed. More...
API_RESULT | MS_access_is_valid_subscription_address (MS_NET_ADDR addr)
To check if valid subscription address to receive a packet. More...

Detailed Description

This section describes the EtherMind Mesh Access Layer APIs.

Function Documentation

API_RESULT MS_access_create_node ( MS_ACCESS_NODE_ID * node_id )

Create a new node in the device.

Description
This routine creates a new node in the device. This can be used by the application to create extra nodes if required in addition to the default primary node.
Parameters
[out] node_id Identifier to reference the newly created node.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_register_element | ( | MS_ACCESS_NODE_ID | node_id,
 |  | MS_ACCESS_ELEMENT_DESC * | element,
 |  | MS_ACCESS_ELEMENT_HANDLE * | element_handle
 | ) |  |

Register an element with the access layer.

Description
This routine registers an element that can be populated with the models information to a specific node in the device identified by the node id.
Parameters
[in] | node_id | Node to which the element needs to be registered. This value is always 0 for the default node.
[in] | element | Pointer to the element descriptor that needs to be registered to the node.
[out] | element_handle | Identifier to reference the newly registered element.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_register_model | ( | MS_ACCESS_NODE_ID | node_id,
 |  | MS_ACCESS_MODEL * | model,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle
 | ) |  |

Register a model with the access layer.

Description
This routine registers a model associated with an element with the access layer.
Parameters
[in] | node_id | Node to which the model needs to be registered. This value is always 0 for the default node.
[in] | model | Pointer to the model descriptor that needs to be registered to the node.
[in,out] | model_handle | Model identifier associated with the model instance on successful registration. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_get_element_handle | ( | MS_NET_ADDR | elem_addr,
 |  | MS_ACCESS_ELEMENT_HANDLE * | handle
 | ) |  |

Get element handle.

Description
This routine searches for the element handle associated with specific element address.
Parameters
[in] | elem_addr | Address of the corresponding element.
[out] | handle | Element handle associated with the element address.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_get_model_handle | ( | MS_ACCESS_ELEMENT_HANDLE | elem_handle,
 |  | MS_ACCESS_MODEL_ID | model_id,
 |  | MS_ACCESS_MODEL_HANDLE * | handle
 | ) |  |

Get model handle.

Description
This routine searches for the model handle associated with specific model ID.
Parameters
[in] | elem_handle | Element Identifier associated with the Model.
[in] | model_id | Model Identifier for which the model handle to be searched.
[out] | handle | Model handle associated with model ID. If not found, handle will be set as NULL.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_publish | ( | MS_ACCESS_MODEL_HANDLE * | handle,
 |  | UINT32 | opcode,
 |  | UCHAR * | data_param,
 |  | UINT16 | data_len,
 |  | UINT8 | reliable
 | ) |  |

API to publish access layer message.

Description
This routine publishes Access Layer message to the publish address associated with the model.
Parameters
[in] | handle | Access Model Handle for which message to be sent.
[in] | opcode | Access Opcode
[in] | data_param | Data packet
[in] | data_len | Data packet length
[in] | reliable | MS_TRUE for reliable message. MS_FALSE otherwise.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_reply | ( | MS_ACCESS_MODEL_HANDLE * | handle,
 |  | MS_NET_ADDR | saddr,
 |  | MS_NET_ADDR | daddr,
 |  | MS_SUBNET_HANDLE | subnet_handle,
 |  | MS_APPKEY_HANDLE | appkey_handle,
 |  | UINT8 | ttl,
 |  | UINT32 | opcode,
 |  | UCHAR * | data_param,
 |  | UINT16 | data_length
 | ) |  |

API to reply to access layer message.

Description
This routine replies to Access Layer message.
Parameters
[in] | handle | Model Handle.
[in] | saddr | 16 bit Source Address.
[in] | daddr | 16 bit Destination Address.
[in] | subnet_handle | Subnet Handle.
[in] | appkey_handle | AppKey Handle.
[in] | ttl | Time to Live.
[in] | opcode | Access Opcode
[in] | data_param | Access parameter, based on the opcode
[in] | data_length | Access parameter length, based on the opcode
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_send_pdu | ( | MS_NET_ADDR | saddr,
 |  | MS_NET_ADDR | daddr,
 |  | MS_SUBNET_HANDLE | subnet_handle,
 |  | MS_APPKEY_HANDLE | appkey_handle,
 |  | UINT8 | ttl,
 |  | UINT32 | opcode,
 |  | UCHAR * | data_param,
 |  | UINT16 | data_length
 | ) |  |

API to send Access PDUs.

Description
This routine sends transport PDUs to peer device.
Parameters
[in] | saddr | 16 bit Source Address.
[in] | daddr | 16 bit Destination Address.
[in] | subnet_handle | Subnet Handle.
[in] | appkey_handle | AppKey Handle.
[in] | ttl | Time to Live.
[in] | opcode | Access Opcode
[in] | data_param | Access parameter, based on the opcode
[in] | data_length | Access parameter length, based on the opcode
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_reset ( void )

To reset a node.

Description
This routine resets a node (other than a Provisioner) and removes it from the network.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_element_count ( UINT8 * count )

To get the number of elements in local node.

Description
This routine retrieves the number of elements in local node.
Parameters
[out] count Number of elements
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_primary_unicast_address ( MS_NET_ADDR addr )

To set primary unicast address.

Description
This routine sets primary unicast address.
Parameters
[in] addr Primary Unicast Address to be set
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_primary_unicast_address ( MS_NET_ADDR * addr )

To get primary unicast address.

Description
This routine gets primary unicast address.
Parameters
[out] addr Memory location where Primary Unicast Address to be filled
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_default_ttl ( UINT8 ttl )

To set default TTL.

Description
This routine sets default TTL.
Parameters
[in] ttl Default TTL to be set
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_default_ttl ( UINT8 * ttl )

To get default TTL.

Description
This routine gets default TTL.
Parameters
[in] ttl Memory location where default TTL to be filled
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_iv_index | ( | UINT32 | iv_index,
 |  | UINT8 | iv_update_flag
 | ) |  |

To set IV Index.

Description
This routine sets IV Index.
Parameters
[in] | iv_index | IV Index to be set
[in] | iv_update_flag | IV Update Flag
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_iv_index | ( | UINT32 * | iv_index,
 |  | UINT8 * | iv_update_flag
 | ) |  |

To get IV Index.

Description
This routine gets IV Index.
Parameters
[out] | iv_index | Memory location where IV Index to be filled
[out] | iv_update_flag | Memory location where IV Update Flag to be filled
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_iv_index_by_ivi | ( | UINT8 | ivi,
 |  | UINT32 * | iv_index
 | ) |  |

To get IV Index by IVI.

Description
This routine gets IV Index based on the IVI in the received packet.
Parameters
[in] | ivi | Least Significant bit of the IV Index used in the nonce to authenticate and encrypt the Network PDU.
[out] | iv_index | Memory location where IV Index to be filled
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_features_field | ( | UINT8 | enable,
 |  | UINT8 | feature
 | ) |  |

To enable/disable a feature.

Description
This routine enables/disables a feature field.
Parameters
[in] | enable | Enable or Disable
[in] | feature | Relay, proxy, friend or Low Power
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_features_field | ( | UINT8 * | enable,
 |  | UINT8 | feature
 | ) |  |

To get state of a feature.

Description
This routine gets the state of a feature field.
Parameters
[out] | enable | Memory location where Enable or Disable status to be filled.
[in] | feature | Relay, proxy, friend or Low Power
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_features ( UINT8 * features )

To get state of all features.

Description
This routine gets the state of all features.
Parameters
[out] features State of Relay, proxy, friend and Low Power field
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_friendship_role ( UINT8 * frnd_role )

To get friendship role of the node.

Description
This routine gets the current friendship role of the node.
Parameters
[out] frnd_role Friend role
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_friendship_role ( UINT8 frnd_role )

To set friendship role of the node.

Description
This routine sets the current friendship role of the node.
Parameters
[out] frnd_role Friend role
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_add_device_key | ( | UINT8 * | dev_key,
 |  | MS_NET_ADDR | uaddr,
 |  | UINT8 | num_elements
 | ) |  |

To add Device Key.

Description
This routine adds Device Key entry, along with corresponding Primary Device Address and Number of elements.
Parameters
[in] | dev_key | Device Key to be added.
[in] | uaddr | Unicast Address of the first element.
[in] | num_elements | Number of elements.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_device_key | ( | UINT8 | dev_key_index,
 |  | UINT8 ** | dev_key
 | ) |  |

To get Device Key.

Description
This routine gets Device Key entry.
Parameters
[in] | dev_key_index | Device Key Index.
[out] | dev_key | Pointer to Device Key to be returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_remove_all_device_keys ( void )

To remove all Device Keys.

Description
This routine removes all Device Keys from table.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_prov_devices_list | ( | MS_PROV_DEV_ENTRY * | prov_dev_list,
 |  | UINT16 * | num_entries
 | ) |  |

To get list of Provisioned Device List.

Description
This routine returns list of Provisioned Devices from the Device Key Table.
Parameters
[in] | prov_dev_list | Provisioned Device List.
[in,out] | num_entries | Size of the Device Key List provided by the caller. This routine will return the number of entries in the Device Key Table.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_device_key_handle | ( | MS_NET_ADDR | prim_elem_uaddr,
 |  | MS_ACCESS_DEV_KEY_HANDLE * | handle
 | ) |  |

To get Device Key Handle.

Description
This routine returns Device Key Handle for a given Primary Element Address entry in Device Key Table.
Parameters
[in] | prim_elem_uaddr | Primary element address to be searched
[out] | handle | Device Key Table Handle, if match is found.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_app_key | ( | MS_APPKEY_HANDLE | appkey_handle,
 |  | UINT8 ** | app_key,
 |  | UINT8 * | aid
 | ) |  |

To get AppKey.

Description
This routine gets AppKey along with AID entry.
Parameters
[in] | appkey_handle | AppKey Handle.
[out] | app_key | Pointer to AppKey to be returned.
[out] | aid | Pointer to AID to be returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_add_update_netkey | ( | UINT16 | netkey_index,
 |  | UINT32 | opcode,
 |  | UINT8 * | net_key
 | ) |  |

To add/update NetKey.

Description
This routine adds/updates NetKey entry. Each NetKey is associated with a subnet.
Parameters
[in] | netkey_index | Identifies global Index of NetKey. A 12-bit value.
[in] | opcode | To identify Add or Update NetKey
[in] | net_key | Associated NetKey to be added/updated.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_add_friend_sec_credential | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT16 | friend_offset,
 |  | MS_NET_ADDR | lpn_addr,
 |  | MS_NET_ADDR | friend_addr,
 |  | UINT16 | lpn_counter,
 |  | UINT16 | friend_counter
 | ) |  |

To add Security Credential of a LPN or the Friend.

Description
This routine adds NID, privacy and encryption keys associated with a friendship.
Parameters
[in] | subnet_handle | Identifies associated subnet.
[in] | friend_offset | Friend Offset.
[in] | lpn_addr | Address of the LPN.
[in] | friend_addr | Address of the Friend.
[in] | lpn_counter | Number of Friend Request messages the LPN has sent.
[in] | friend_counter | Number of Friend Offer messages the Friend has sent.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_delete_friend_sec_credential | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT16 | friend_index
 | ) |  |

To delete the Security Credential of a LPN or the Friend.

Description
This routine deletes NID, privacy and encryption keys associated with a friendship.
Parameters
[in] | subnet_handle | Identifies associated subnet.
[in] | friend_index | Friend Index.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_find_subnet | ( | UINT16 | netkey_index,
 |  | MS_SUBNET_HANDLE * | subnet_handle
 | ) |  |

To find a Subnet associated with the NetKey.

Description
This routine finds a Subnet based on the NetKey entry. Each NetKey is associated with a subnet.
Parameters
[in] | netkey_index | Identifies global Index of NetKey, corresponding Subnet to be returned.
[out] | subnet_handle | Memory location to be filled with Subnet Handle, if search is successful.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_delete_netkey ( MS_SUBNET_HANDLE subnet_handle )

To delete NetKey.

Description
This routine deletes a NetKey entry. Each NetKey is associated with a subnet.
Parameters
[in] subnet_handle Handle of the Subnet for which NetKey to be deleted.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_netkey | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT8 * | net_key
 | ) |  |

To get NetKey.

Description
This routine fetches a NetKey entry. Each NetKey is associated with a subnet.
Parameters
[in] | subnet_handle | Handle of the Subnet for which NetKey to be deleted.
[out] | net_key | Netkey associated with the Subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_netkey_index_list | ( | UINT16 * | netkey_count,
 |  | UINT16 * | netkey_index_list
 | ) |  |

To get list of all known NetKeys.

Description
This routine returns a list of known NetKey Indices.
Parameters
[in,out] | netkey_count | Caller fills with maximum number of NetKey Indices that can be stored in 'netkey_index_list'. This function will update the value with how many NetKey Indices has been filled. If the number of available NetKey Indices is more than that can be returned, maximum possible Indices will be filled and an appropriate error values will inform the caller, there are more NetKey Indices (as an information).
[out] | netkey_index_list | Memory to be filled with the available NetKey Indices.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_lookup_nid | ( | UINT8 | nid,
 |  | MS_SUBNET_HANDLE * | subnet_handle,
 |  | UINT8 * | privacy_key,
 |  | UINT8 * | encrypt_key
 | ) |  |

To search for NID.

Description
This routine searches for matching NID in subnet table.
Parameters
[in] | nid | NID to be searched in all known subnets for match.
[in,out] | subnet_handle | Same NID can match with multiple subnets. Caller will fill this value to indicate from which subnet handle the search to be started. This function will return the subnet handle, where the match is found (in case of match). Caller while searching for the same NID, in the subsequent call can pass the subnet_handle received in the previous match for the NID. For the very first call when searching for a NID, the caller need to use Invalid Subnet Handle MS_INVALID_SUBNET_HANDLE.
[out] | privacy_key | Privacy Key associated with the subnet.
[out] | encrypt_key | Encyption Key associated with the subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_lookup_network_id | ( | UINT8 * | network_id,
 |  | MS_SUBNET_HANDLE * | subnet_handle,
 |  | UINT8 * | beacon_key,
 |  | UINT8 * | is_new_key
 | ) |  |

To search for Network ID.

Description
This routine searches for matching Network ID in subnet table.
Parameters
[in] | network_id | Network ID to be searched in all known subnets for match.
[in,out] | subnet_handle | Same NID can match with multiple subnets. Caller will fill this value to indicate from which subnet handle the search to be started. This function will return the subnet handle, where the match is found (in case of match). Caller while searching for the same NID, in the subsequent call can pass the subnet_handle received in the previous match for the NID. For the very first call when searching for a NID, the caller need to use Invalid Subnet Handle MS_INVALID_SUBNET_HANDLE.
[out] | beacon_key | Beacon Key associated with the subnet.
[out] | is_new_key | Flag to indicate if the network ID is associated with the new Network Key being updated.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_lookup_aid | ( | UINT8 | aid,
 |  | MS_APPKEY_HANDLE * | appkey_handle,
 |  | UINT8 * | app_key
 | ) |  |

To search for AID.

Description
This routine searches for matching NID in subnet table.
Parameters
[in] | aid | AID to be searched in all known AppKeys for match.
[in,out] | appkey_handle | Same AID can match with multiple AppKeys. Caller will fill this value to indicate from which AppKey handle the search to be started. This function will return the AppKey handle, where the match is found (in case of match). Caller while searching for the same AID, in the subsequent call can pass the appkey_handle received in the previous match for the AID. For the very first call when searching for a AID, the caller need to use Invalid Subnet Handle MS_INVALID_APPKEY_HANDLE.
[out] | app_key | AppKey associated with the AID.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_prov_data ( PROV_DATA_S * prov_data )

Set Provisioning Data.

Description
This routine configures the provisioning data with Access Layer.
Parameters
prov_data Provisioning data received during provisioning procedure.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_subnet_nid | ( | MS_SUBNET_HANDLE | handle,
 |  | UINT8 * | nid
 | ) |  |

To get NID associated with a subnet.

Description
This routine fetches the NID associated with a subnet.
Parameters
[in] | handle | Handle identifing the subnet.
[out] | nid | NID associated with the subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_subnet_privacy_key | ( | MS_SUBNET_HANDLE | handle,
 |  | UINT8 * | privacy_key
 | ) |  |

To get Privacy Key associated with a subnet.

Description
This routine fetches the Privacy Key associated with a subnet.
Parameters
[in] | handle | Handle identifing the subnet.
[out] | privacy_key | Privacy Key associated with the subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_subnet_network_id | ( | MS_SUBNET_HANDLE | handle,
 |  | UINT8 * | network_id
 | ) |  |

To get Network ID associated with a subnet.

Description
This routine fetches the Netowrk ID associated with a subnet.
Parameters
[in] | handle | Handle identifing the subnet.
[out] | network_id | Network ID associated with the subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_subnet_beacon_key | ( | MS_SUBNET_HANDLE | handle,
 |  | UINT8 * | beacon_key
 | ) |  |

To get Beacon Key associated with a subnet.

Description
This routine fetches the Beacon Key associated with a subnet.
Parameters
[in] | handle | Handle identifing the subnet.
[out] | beacon_key | Beacon Key associated with the subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_subnet_identity_key | ( | MS_SUBNET_HANDLE | handle,
 |  | UINT8 * | identity_key
 | ) |  |

To get Identity Key associated with a subnet.

Description
This routine fetches the Identity Key associated with a subnet.
Parameters
[in] | handle | Handle identifing the subnet.
[out] | identity_key | Identity Key associated with the subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_subnet_encryption_key | ( | MS_SUBNET_HANDLE | handle,
 |  | UINT8 * | encrypt_key
 | ) |  |

To get Encryption Key associated with a subnet.

Description
This routine fetches the Encryption Key associated with a subnet.
Parameters
[in] | handle | Handle identifing the subnet.
[out] | encrypt_key | Encyption Key associated with the subnet.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_node_identity | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT8 * | id_state
 | ) |  |

To get Node Identity.

Description
This routine gets Node Identity State of a node
Parameters
[in] | subnet_handle | Handle identifing the subnet.
[out] | id_state | Memory location where Node Identity state to be filled.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_node_identity | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT8 * | id_state
 | ) |  |

To set Node Identity.

Description
This routine sets Node Identity State of a node
Parameters
[in] | subnet_handle | Handle identifing the subnet.
[in,out] | id_state | Node Identity state to be set.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_key_refresh_phase | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT8 * | key_refresh_state
 | ) |  |

To get Key Refresh Phase.

Description
This routine gets Key Refresh Phase State of a node
Parameters
[in] | subnet_handle | Handle identifing the subnet.
[out] | key_refresh_state | Memory location where Key Refresh Phase state to be filled.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_key_refresh_phase | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT8 * | key_refresh_state
 | ) |  |

To set Key Refresh Phase.

Description
This routine sets Key Refresh Phase State of a node
Parameters
[in] | subnet_handle | Handle identifing the subnet.
[in,out] | key_refresh_state | Key Refresh Phase state to be set.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_transmit_state | ( | UINT8 | tx_state_type,
 |  | UINT8 | tx_state
 | ) |  |

To set Network/Relay Transmit state.

Description
This routine sets Network/Relay Transmit state.
Parameters
[in] | tx_state_type | Transmit State Type (Network or Relay)
[in] | tx_state | Composite state (3-bits of Tx Count and 5-bits of Tx Interval Steps)
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_transmit_state | ( | UINT8 | tx_state_type,
 |  | UINT8 * | tx_state
 | ) |  |

To get Network/Relay Transmit state.

Description
This routine gets Network/Relay Transmit state.
Parameters
[in] | tx_state_type | Transmit State Type (Network or Relay)
[out] | tx_state | Memory location to fill Composite state (3-bits of Tx Count and 5-bits of Tx Interval Steps)
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_add_appkey | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT16 | appkey_index,
 |  | UINT8 * | app_key
 | ) |  |

To add AppKey.

Description
This routine adds AppKey entry. Each AppKey is associated with a subnet.
Parameters
[in] | subnet_handle | Handle of the Subnet for which AppKey to be added.
[in] | appkey_index | Identifies global Index of AppKey. A 12-bit value.
[in] | app_key | Associated AppKey to be added.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_update_delete_appkey | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT16 | appkey_index,
 |  | UINT32 | opcode,
 |  | UINT8 * | app_key
 | ) |  |

To update/delete AppKey.

Description
This routine updates/deletes AppKey entry. Each AppKey is associated with a subnet.
Parameters
[in] | subnet_handle | Handle of the Subnet for which AppKey to be updated.
[in] | appkey_index | Identifies global Index of AppKey. A 12-bit value.
[in] | opcode | To identify Delete or Update NetKey
[in] | app_key | Associated AppKey to be updated.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_appkey_handle | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT16 | appkey_index,
 |  | UINT8 * | app_key,
 |  | MS_APPKEY_HANDLE * | appkey_handle
 | ) |  |

To get AppKey Handle for a given AppKey Index.

Description
This routine gets AppKey Handle for a given AppKey Index. Each AppKey is associated with a subnet.
Parameters
[in] | subnet_handle | Handle of the Subnet for which AppKey to be updated.
[in] | appkey_index | Identifies global Index of AppKey. A 12-bit value.
[in] | app_key | Associated AppKey to be matched.
[out] | appkey_handle | Memory to hold the associated AppKey Handle.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_appkey_index_list | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT16 * | appkey_count,
 |  | UINT16 * | appkey_index_list
 | ) |  |

To get list of all known AppKeys.

Description
This routine returns a list of known AppKey Indices associated with a subnet.
Parameters
[in] | subnet_handle | Handle of the Subnet for which AppKey to be returned.
[in,out] | appkey_count | Caller fills with maximum number of AppKey Indices that can be stored in 'apptkey_index_list'. This function will update the value with how many AppKey Indices has been filled. If the number of available AppKey Indices is more than that can be returned, maximum possible Indices will be filled and an appropriate error values will inform the caller, there are more NetKey Indices (as an information).
[out] | appkey_index_list | Memory to be filled with the available AppKey Indices.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_bind_model_app | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | UINT16 | appkey_index
 | ) |  |

To bind a model with an AppKey.

Description
This routine binds a model with an AppKey.
Parameters
[in] | model_handle | Model handle identifing the model.
[in] | appkey_index | Identifies global Index of AppKey. A 12-bit value.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_unbind_model_app | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | UINT16 | appkey_index
 | ) |  |

To unbind a model with an AppKey.

Description
This routine unbinds a model with an AppKey.
Parameters
[in] | model_handle | Model handle identifing the model.
[in] | appkey_index | Identifies global Index of AppKey. A 12-bit value.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_model_app_list | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | UINT16 * | appkey_count,
 |  | UINT16 * | appkey_index_list
 | ) |  |

To get list of all AppKeys associated with a model.

Description
This routine returns a list of known AppKey Indices associated with a model.
Parameters
[in] | model_handle | Handle of the Model for which AppKey to be returned.
[in,out] | appkey_count | Caller fills with maximum number of AppKey Indices that can be stored in 'apptkey_index_list'. This function will update the value with how many AppKey Indices has been filled. If the number of available AppKey Indices is more than that can be returned, maximum possible Indices will be filled and an appropriate error values will inform the caller, there are more NetKey Indices (as an information).
[out] | appkey_index_list | Memory to be filled with the available AppKey Indices.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_set_model_publication | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | MS_ACCESS_PUBLISH_INFO * | publish_info
 | ) |  |

To set Publication information associated with a model.

Description
This routine sets Publication information associated with a model.
Parameters
[in] | model_handle | Handle of the Model for which Publication info to be set.
[in,out] | publish_info | Publication Information to be set. If Label UUID is used, on success corresponding Virtual Address will be filled and returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_model_publication | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | MS_ACCESS_PUBLISH_INFO * | publish_info
 | ) |  |

To get Publication information associated with a model.

Description
This routine returns Publication information associated with a model.
Parameters
[in] | model_handle | Handle of the Model for which Publication info to be returned.
[out] | publish_info | Memory to be filled with associated Publication info.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_add_model_subscription | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | MS_ACCESS_ADDRESS * | sub_addr
 | ) |  |

To add an address to a model subscription list.

Description
This routine adds an address to a subscription list of a model
Parameters
[in] | model_handle | Handle of the Model for which address to be added in the subscription list.
[in] | sub_addr | Address to be added in subscription list.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_delete_model_subscription | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | MS_ACCESS_ADDRESS * | sub_addr
 | ) |  |

To delete an address to a model subscription list.

Description
This routine deletes an address to a subscription list of a model
Parameters
[in] | model_handle | Handle of the Model for which address to be deleteed in the subscription list.
[in] | sub_addr | Address to be deleted from subscription list.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_delete_all_model_subscription ( MS_ACCESS_MODEL_HANDLE model_handle )

To discard a model subscription list.

Description
This routine discards a subscription list of a model
Parameters
[in] model_handle Handle of the Model for which the subscription list to be discarded.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_model_subscription_list | ( | MS_ACCESS_MODEL_HANDLE | model_handle,
 |  | UINT16 * | sub_addr_count,
 |  | UINT16 * | sub_addr_list
 | ) |  |

To get list of subscription addresses of a model.

Description
This routine returns a list of subscription addresses of a model.
Parameters
[in] | model_handle | Handle of the Model for which the subscription addresses to be returned.
[in,out] | sub_addr_count | Caller fills with maximum number of subscription addresses that can be stored in 'sub_addr_list'. This function will update the value with how many subscription addresses has been filled. If the number of available subscription addresses is more than that can be returned, maximum possible addresses will be filled and an appropriate error values will inform the caller, there are more subscription addresses (as an information).
[out] | sub_addr_list | Memory to be filled with the available subscription addresses.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_cm_get_all_model_subscription_list | ( | UINT16 * | sub_addr_count,
 |  | UINT16 * | sub_addr_list
 | ) |  |

To get list of subscription addresses of all the models.

Description
This routine returns a consolidated list of subscription addresses of all the models.
Parameters
[in,out] | sub_addr_count | Caller fills with maximum number of subscription addresses that can be stored in 'sub_addr_list'. This function will update the value with how many subscription addresses has been filled. If the number of available subscription addresses is more than that can be returned, maximum possible addresses will be filled and an appropriate error values will inform the caller, there are more subscription addresses (as an information).
[out] | sub_addr_list | Memory to be filled with the available subscription addresses.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_is_valid_element_address ( MS_NET_ADDR addr )

To check if valid element address to receive a packet.

Description
This routine checks if destination address in a received packet matches with any of the known element address of local or friend device.
Parameters
[in] addr Unicast Address to search
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_is_fixed_group_addr_to_be_processed ( MS_NET_ADDR addr )

To check if Fixed Group Address in receive packet to be processed.

Description
This routine checks if destination address in a received packet as a Fixed Group Address to be processed.
Parameters
[in] addr A valid Fixed Group Address, to be checked
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_access_is_valid_subscription_address ( MS_NET_ADDR addr )

To check if valid subscription address to receive a packet.

Description
This routine checks if destination address in a received packet matches with any of the known subscription address of local or friend device.
Parameters
[in] addr Address to search
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
ACCESS (Mesh Access Layer)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* MS_ACCESS_MODEL_CB )(MS_ACCESS_MODEL_HANDLE *handle, MS_NET_ADDR saddr, MS_NET_ADDR daddr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Access Layer Application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_ACCESS_MODEL_CB)(MS_ACCESS_MODEL_HANDLE *handle, MS_NET_ADDR saddr, MS_NET_ADDR daddr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Access Layer Application Asynchronous Notification Callback.

Access Layer calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
saddr | 16 bit Source Address.
daddr | 16 bit Destination Address.
subnet_handle | Subnet Handle.
appkey_handle | AppKey Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 169 of file MS_access_api.h.


EtherMind Mesh SDK (beta): Defines

Modules
Defines
ACCESS (Mesh Access Layer)

Describes defines for the module. More...

Modules

Constants
Describes Constants defined by the module.

Detailed Description

Describes defines for the module.


EtherMind Mesh SDK (beta): Constants

Macros
Constants
Defines

Describes Constants defined by the module. More...

Macros

#define | MS_ACCESS_MAX_PKT_SIZE 384
Maximum Access Packet size. More...
#define | MS_ACCESS_VADDR_LABEL_UUID_SIZE 16
Array sizes for use in the Access layer. More...
#define | MS_ACCESS_NETKEY_SIZE 16
Size of NetKey.
#define | MS_ACCESS_APPKEY_SIZE 16
Size of AppKey.
#define | MS_ACCESS_DEFAULT_NODE_ID 0x00
Default Node Identifier.
#define | MS_ACCESS_DEFAULT_ELEMENT_HANDLE 0x00
Default Element Handle.
#define | MS_ACCESS_GET_REQ 0x01
Get Request.
#define | MS_ACCESS_SET_REQ 0x02
Set Request.
#define | ACCESS_INVALID_DEFAULT_TTL 0xFF
Invalid default TTL value.
#define | ACCESS_MAX_TTL 0x7F
Maximum TTL value - used as initializer.
#define | MS_ACCESS_MODEL_REQ_MSG_T_GET 0
Model Specific Request Message Type: Get, Set or Others. More...
#define | MS_ACCESS_MODEL_REQ_MSG_T_SET 1
Model Specific Request Message Type: Set.
#define | MS_ACCESS_MODEL_REQ_MSG_T_OTHERS 2
Model Specific Request Message Type: Others.
#define | MS_ACCESS_KEY_REFRESH_PHASE_NORMAL 0x00
Key Refersh Phase states. More...
#define | MS_ACCESS_KEY_REFRESH_PHASE_1 0x01
Key Refersh Phase - 1.
#define | MS_ACCESS_KEY_REFRESH_PHASE_2 0x02
Key Refersh Phase - 2.
#define | MS_ACCESS_KEY_REFRESH_PHASE_3 0x03
Key Refersh Phase - 3.
#define | MS_ACCESS_ADDRESS_INVALID_HANDLE 0xFFFFFFFF
Invalid Access Address.

Detailed Description

Describes Constants defined by the module.

Macro Definition Documentation

#define MS_ACCESS_MAX_PKT_SIZE 384

Maximum Access Packet size.

32 segments of 12 octets each.

Definition at line 48 of file MS_access_api.h.

#define MS_ACCESS_VADDR_LABEL_UUID_SIZE 16

Array sizes for use in the Access layer.

Size of Virtual Address (Label UUID)

Definition at line 53 of file MS_access_api.h.

#define MS_ACCESS_MODEL_REQ_MSG_T_GET 0

Model Specific Request Message Type: Get, Set or Others.

Model Specific Request Message Type: Get

Definition at line 79 of file MS_access_api.h.

#define MS_ACCESS_KEY_REFRESH_PHASE_NORMAL 0x00

Key Refersh Phase states.

Key Refersh Phase - Normal

Definition at line 87 of file MS_access_api.h.


EtherMind Mesh SDK (beta): Events

Events
ACCESS (Mesh Access Layer)

This section lists the Asynchronous Events notified to Application by the Module. More...

This section lists the Asynchronous Events notified to Application by the Module.


EtherMind Mesh SDK (beta): Structures

Data Structures | Typedefs
Structures
ACCESS (Mesh Access Layer)

Data Structures

struct | MS_ACCESS_MODEL_ID
Model ID datatype. More...
struct | MS_ACCESS_MODEL
Data structure for model. More...
struct | MS_ACCESS_ELEMENT_DESC
Element description format. More...
struct | MS_ACCESS_ADDRESS
Unicast/Virtual/Group Address. More...
struct | MS_ACCESS_PUBLISH_INFO
Access Publication related information. More...
struct | MS_ACCESS_MODEL_REQ_MSG_CONTEXT
Context of message received for a specific model instance. More...
struct | MS_ACCESS_MODEL_REQ_MSG_RAW
Uninterpreted/raw received message for a specific model instance. More...
struct | MS_ACCESS_MODEL_REQ_MSG_T
Requested message type for a specific model instance. More...
struct | MS_ACCESS_MODEL_STATE_PARAMS
Model specific state parameters in a request or response message. More...
struct | MS_ACCESS_MODEL_EXT_PARAMS
Additional paramters in a Model specific request or response message. More...
struct | MS_PROV_DEV_ENTRY
Provisioned Device List Data Structure, containing Primary Element Address and number of elements. More...

Typedefs

typedef UINT16 | MS_ACCESS_MODEL_ID_SIG
SIG Model ID.
typedef UINT32 | MS_ACCESS_MODEL_ID_VENDOR
Vendor Model ID.
typedef UINT8 | MS_ACCESS_NODE_ID
Access Node ID.
typedef UINT8 | MS_ACCESS_ELEMENT_HANDLE
Access Element Handle.
typedef UINT32 | MS_ACCESS_ADDRESS_HANDLE
Access Address Handle.
typedef UINT32 | MS_ACCESS_DEV_KEY_HANDLE
Device Key Handle.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_ACCESS_MODEL_ID Struct Reference

Data Fields
MS_ACCESS_MODEL_ID Struct Reference
Structures

Model ID datatype. More...

#include <MS_access_api.h>

Data Fields

UINT32 | id
Vendor/SIG ID.
UCHAR | type
Model type. More...

Detailed Description

Model ID datatype.

Definition at line 205 of file MS_access_api.h.

Field Documentation

UCHAR MS_ACCESS_MODEL_ID::type

Model type.

  • SIG or Vendor

Definition at line 214 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_MODEL Struct Reference

Data Fields
MS_ACCESS_MODEL Struct Reference
Structures

Data structure for model. More...

#include <MS_access_api.h>

Data Fields

MS_ACCESS_MODEL_ID model_id
Model ID.
MS_ACCESS_ELEMENT_HANDLE elem_handle
Associated Element Handle.
MS_ACCESS_MODEL_CB cb
Callback function pointer to receive packets from the underlying protocol layers.
UINT16 | num_opcodes
Number of Opcodes.
UINT32 * | opcodes
List of Opcodes.

Detailed Description

Data structure for model.

Models could be bluetooth SIG defined or vendor defined.

Definition at line 223 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_ELEMENT_DESC Struct Reference

Data Fields
MS_ACCESS_ELEMENT_DESC Struct Reference
Structures

Element description format. More...

#include <MS_access_api.h>

Data Fields

UINT16 loc
Location descriptor.

Detailed Description

Element description format.

Definition at line 249 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_ADDRESS Struct Reference

Data Fields
MS_ACCESS_ADDRESS Struct Reference
Structures

Unicast/Virtual/Group Address. More...

#include <MS_access_api.h>

Data Fields

UINT8 | use_label
Flag - which field to be used.
MS_NET_ADDR addr
Address.
UINT8 | label [MS_LABEL_UUID_LENGTH]
Label UUID.

Detailed Description

Unicast/Virtual/Group Address.

Definition at line 259 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_PUBLISH_INFO Struct Reference

Data Fields
MS_ACCESS_PUBLISH_INFO Struct Reference
Structures

Access Publication related information. More...

#include <MS_access_api.h>

Data Fields

MS_ACCESS_ADDRESS addr
PublishAddress (Unicast/Virtual/Group)
UINT16 | appkey_index
UINT8 | crden_flag
CredentialFlag.
UINT8 | ttl
PublishTTL.
UINT8 | period
PublishPeriod.
UINT8 | rtx_count
PublishRetransmitCount.
UINT8 | rtx_interval_steps
PublishRetransmitIntervalSteps.
UINT8 | remote
Flag - if called from local or remote.

Detailed Description

Access Publication related information.

Definition at line 275 of file MS_access_api.h.

Field Documentation

UINT16 MS_ACCESS_PUBLISH_INFO::appkey_index
  • AppKey Index (when set from remote).
  • AppKey Handle (when set from locally for Configuration Client).

Definition at line 284 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_MODEL_REQ_MSG_CONTEXT Struct Reference

Data Fields
MS_ACCESS_MODEL_REQ_MSG_CONTEXT Struct Reference
Structures

Context of message received for a specific model instance. More...

#include <MS_access_api.h>

Data Fields

MS_ACCESS_MODEL_HANDLE handle
Model Handle - for which request is received.
MS_NET_ADDR saddr
Source Address - oritinator of request.
MS_NET_ADDR daddr
Destination Address - of the request.
MS_SUBNET_HANDLE subnet_handle
Associated Subnet Identifier.
MS_APPKEY_HANDLE appkey_handle
Associated AppKey Identifier.

Detailed Description

Context of message received for a specific model instance.

This is required to send response appropriately.

Definition at line 310 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_MODEL_REQ_MSG_RAW Struct Reference

Data Fields
MS_ACCESS_MODEL_REQ_MSG_RAW Struct Reference
Structures

Uninterpreted/raw received message for a specific model instance. More...

#include <MS_access_api.h>

Data Fields

UINT32 | opcode
Request Opcode.
UCHAR * | data_param
Raw received message.
UINT16 | data_len
Raw received message length.

Detailed Description

Uninterpreted/raw received message for a specific model instance.

Definition at line 330 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_MODEL_REQ_MSG_T Struct Reference

Data Fields
MS_ACCESS_MODEL_REQ_MSG_T Struct Reference
Structures

Requested message type for a specific model instance. More...

#include <MS_access_api.h>

Data Fields

UINT8 | type
Flag: GET, SET or Others.
UINT8 | to_be_acked
Flag: True or False.

Detailed Description

Requested message type for a specific model instance.

Definition at line 344 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_MODEL_STATE_PARAMS Struct Reference

Data Fields
MS_ACCESS_MODEL_STATE_PARAMS Struct Reference
Structures

Model specific state parameters in a request or response message. More...

#include <MS_access_api.h>

Data Fields

UCHAR | state_type
State Type.
void * | state
State pointer.

Detailed Description

Model specific state parameters in a request or response message.

Definition at line 355 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_ACCESS_MODEL_EXT_PARAMS Struct Reference

Data Fields
MS_ACCESS_MODEL_EXT_PARAMS Struct Reference
Structures

Additional paramters in a Model specific request or response message. More...

#include <MS_access_api.h>

Data Fields

UCHAR | ext_type
State/Extended Type.
void * | ext
State/Extended data structure pointer.

Detailed Description

Additional paramters in a Model specific request or response message.

Definition at line 366 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): MS_PROV_DEV_ENTRY Struct Reference

Data Fields
MS_PROV_DEV_ENTRY Struct Reference
Structures

Provisioned Device List Data Structure, containing Primary Element Address and number of elements. More...

#include <MS_access_api.h>

Data Fields

MS_NET_ADDR uaddr
Unicast Address of the first element.
UCHAR num_elements
Number of Elements.

Detailed Description

Provisioned Device List Data Structure, containing Primary Element Address and number of elements.

Definition at line 380 of file MS_access_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_access_api.h


EtherMind Mesh SDK (beta): Utility Macros

Macros
Utility Macros
ACCESS (Mesh Access Layer)

This section defines the utility macros for use by the application. More...

Macros

#define | MS_ACCESS_ASSIGN_ELEMENT(pelement, loc) (pelement)->loc = (loc)
Populates the given element with the Model information.
#define | MS_ACCESS_INIT_SIG_MODEL(pmodel, id, eh, cb, num_op, op)
Initializes the SIG model with the given ID and callback information. More...
#define | MS_ACCESS_INIT_VENDOR_MODEL(pmodel, id, eh, cb, num_op, op)
Initializes the Vendor model with the given ID and callback information. More...

Detailed Description

This section defines the utility macros for use by the application.

Macro Definition Documentation

#define MS_ACCESS_INIT_SIG_MODEL | ( | pmodel,
 |  | id,
 |  | eh,
 |  | cb,
 |  | num_op,
 |  | op
 | ) |
Value:
(pmodel)->model_id.type = MS_ACCESS_MODEL_TYPE_SIG; \
(pmodel)->model_id.id = (id); \
(pmodel)->elem_handle = (eh); \
(pmodel)->cb = (cb); \
(pmodel)->num_opcodes = (num_op); \
(pmodel)->opcodes = (op)

Initializes the SIG model with the given ID and callback information.

Definition at line 122 of file MS_access_api.h.

#define MS_ACCESS_INIT_VENDOR_MODEL | ( | pmodel,
 |  | id,
 |  | eh,
 |  | cb,
 |  | num_op,
 |  | op
 | ) |
Value:
(pmodel)->model_id.type = MS_ACCESS_MODEL_TYPE_VENDOR; \
(pmodel)->model_id.id = (id); \
(pmodel)->elem_handle = (eh); \
(pmodel)->cb = (cb); \
(pmodel)->num_opcodes = (num_op); \
(pmodel)->opcodes = (op)

Initializes the Vendor model with the given ID and callback information.

Definition at line 131 of file MS_access_api.h.


EtherMind Mesh SDK (beta): BEARER (Mesh Bearer Layer)

Modules
BEARER (Mesh Bearer Layer)

This section describes the interfaces & APIs offered by the EtherMind Mesh Bearer (BEARER) module to the Application and other upper layers of the stack. More...

Modules

API Definitions
This section describes the EtherMind Mesh Bearer Layer APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Defines
Describes defines for the module.
Events
This section lists the Asynchronous Events notified to Application by the Module.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Bearer (BEARER) module to the Application and other upper layers of the stack.


EtherMind Mesh SDK (beta): API Definitions

Functions
API Definitions
BEARER (Mesh Bearer Layer)

This section describes the EtherMind Mesh Bearer Layer APIs. More...

Functions

API_RESULT | MS_brr_register (BRR_TYPE brr_type, BRR_NTF_CB brr_cb)
Register Interface with Bearer Layer. More...
API_RESULT | MS_brr_register_beacon_handler (UCHAR bcon_type, void(*bcon_handler)(UCHAR *data, UINT16 datalen))
Register Beacon Interface with Bearer Layer. More...
API_RESULT | MS_brr_add_bearer (BRR_TYPE brr_type, BRR_BEARER_INFO *brr_info, BRR_HANDLE *brr_handle)
Add a bearer to Bearer Layer. More...
API_RESULT | MS_brr_remove_bearer (BRR_TYPE brr_type, BRR_HANDLE *brr_handle)
Remove a bearer from Bearer Layer. More...
API_RESULT | MS_brr_observe_beacon (UCHAR bcon_type, UCHAR enable)
Observe ON/OFF for the beacon type. More...
API_RESULT | MS_brr_bcast_unprovisioned_beacon (UCHAR type, UCHAR *dev_uuid, UINT16 oob_info, MS_BUFFER *uri)
API to send Unprovisioned Device Beacon. More...
API_RESULT | MS_brr_broadcast_beacon (UCHAR type, UCHAR *packet, UINT16 length)
API to broadcast a beacon. More...
API_RESULT | MS_brr_start_proxy_adv (UCHAR type, UCHAR *data, UINT16 datalen)
API to send Proxy Device ADV. More...
API_RESULT | MS_brr_bcast_end (UCHAR bcon, UCHAR type)
API to disable broadcast of given beacon type. More...
API_RESULT | MS_brr_send_pdu (BRR_HANDLE *brr_handle, BRR_TYPE brr_type, MS_BUFFER *buffer)
Send a bearer PDU. More...
UCHAR | MS_brr_get_packet_rssi (void)
Get the RSSI of current received packet being processed. More...
API_RESULT | MS_brr_sleep (void)
Put the bearer to sleep. More...
API_RESULT | MS_brr_wakeup (void)
Wakeup the bearer. More...

Detailed Description

This section describes the EtherMind Mesh Bearer Layer APIs.

Function Documentation

API_RESULT MS_brr_register | ( | BRR_TYPE | brr_type,
 |  | BRR_NTF_CB | brr_cb
 | ) |  |

Register Interface with Bearer Layer.

Description
This routine registers interface with the Bearer Layer. Bearer Layer supports single Application, hence this rouine shall be called once.
Parameters
[in] | brr_type | Bearer Type
[in] | brr_cb | Details describing Application Notification Callback
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_register_beacon_handler | ( | UCHAR | bcon_type,
 |  | void(*)(UCHAR *data, UINT16 datalen) | bcon_handler
 | ) |  |

Register Beacon Interface with Bearer Layer.

Description
This routine registers interface with the Bearer Layer to process Beacons. Bearer Layer supports single Application, hence this rouine shall be called once. *1
Parameters
[in] | bcon_type | Beacon type - Unprovisioned Device or Secure Network.
[in] | bcon_handler | Callback handler to be registered for the given beacon type.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_add_bearer | ( | BRR_TYPE | brr_type,
 |  | BRR_BEARER_INFO * | brr_info,
 |  | BRR_HANDLE * | brr_handle
 | ) |  |

Add a bearer to Bearer Layer.

Description
This routine adds a bearer that is setup by the application for use by the Mesh Stack. Bearer Layer supports single Application, hence this rouine shall be called once.
Parameters
[in] | brr_type | Bearer Type
[in] | brr_info | Details describing the Bearer being added
[out] | brr_handle | Handle to the bearer that is added. Used in data APIs.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_remove_bearer | ( | BRR_TYPE | brr_type,
 |  | BRR_HANDLE * | brr_handle
 | ) |  |

Remove a bearer from Bearer Layer.

Description
This routine removes a bearer from the Mesh Stack. Bearer Layer supports single Application, hence this rouine shall be called once.
Parameters
[in] | brr_type | Bearer Type
[out] | brr_handle | Handle to the bearer that is added. Used in data APIs.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_observe_beacon | ( | UCHAR | bcon_type,
 |  | UCHAR | enable
 | ) |  |

Observe ON/OFF for the beacon type.

Description
This routine sends enables/disables the observation procedure for the given beacon type.
Parameters
[in] | bcon_type | Type of beacon to observe - Active/Passive.
[in] | enable | Enable or Disable the observation procedure.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_bcast_unprovisioned_beacon | ( | UCHAR | type,
 |  | UCHAR * | dev_uuid,
 |  | UINT16 | oob_info,
 |  | MS_BUFFER * | uri
 | ) |  |

API to send Unprovisioned Device Beacon.

Description
This routine sends Unprovisioned Device Beacon
Parameters
[in] | type | Active or Passive Broadcast type.
[in] | dev_uuid | Device UUID uniquely identifying this device.
[in] | oob_info | OOB Information
[in] | uri | Optional Parameter. NULL if not present. Points to the length and payload pointer of the URI string to be advertised interleaving with the unprovisioned beacon.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_broadcast_beacon | ( | UCHAR | type,
 |  | UCHAR * | packet,
 |  | UINT16 | length
 | ) |  |

API to broadcast a beacon.

Description
This routine sends the beacon of given type on Adv and GATT bearers
Parameters
[in] | type | The type of beacon
[in] | packet | Beacon data
[in] | length | Beacon data length
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_start_proxy_adv | ( | UCHAR | type,
 |  | UCHAR * | data,
 |  | UINT16 | datalen
 | ) |  |

API to send Proxy Device ADV.

Description
This routine sends Proxy Device ADV
Parameters
[in] | type | Proxy ADV Type: 0x00 - Network ID 0x01 - Node Identity
[in] | data | Data to be advertised by Proxy. If the "type" is: 0x00 - Network ID - 8 Bytes of Network ID 0x01 - Node Identity - 8 Bytes Hash, 8 Bytes Random num
[in] | datalen | Length of the data to be advertised by Proxy. If the "type" is: 0x00 - Network ID - 8 Bytes of Network ID 0x01 - Node Identity - 8 Bytes Hash, 8 Bytes Random num
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_bcast_end | ( | UCHAR | bcon,
 |  | UCHAR | type
 | ) |  |

API to disable broadcast of given beacon type.

Description
This routine stops advertising of given beacon type.
Parameters
[in] | bcon | The Bearer Beacon (Unprovisioned/Secure Network).
[in] | type | The type of braodcast beacon (Active/Passive).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_brr_send_pdu | ( | BRR_HANDLE * | brr_handle,
 |  | BRR_TYPE | brr_type,
 |  | MS_BUFFER * | buffer
 | ) |  |

Send a bearer PDU.

Description
This routine sends a PDU from the Mesh stack to over the bearer indicated by the bearer handle.
Parameters
[in] | brr_handle | Bearer handle on which PDU is to be sent.
[in] | brr_type | Type of Bearer as in BRR_TYPE.
[in] | buffer | PDU data to be sent.
Returns
API_SUCCESS or an error code indicating reason for failure
UCHAR MS_brr_get_packet_rssi ( void )

Get the RSSI of current received packet being processed.

Description
This routine returns the RSSI value of the received packet in its context when called from the Mesh stack.
Returns
RSSI value of the current packet in context.
Note
This applies only when the packet is received over ADV bearer
API_RESULT MS_brr_sleep ( void )

Put the bearer to sleep.

Description
This routine requests the underlying bearer interface to sleep. Default bearer interface is that of advertising bearer.
Returns
API_SUCCESS
API_RESULT MS_brr_wakeup ( void )

Wakeup the bearer.

Description
This routine requests the underlying bearer interface to wakeup. Default bearer interface is that of advertising bearer.
Returns
API_SUCCESS


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
BEARER (Mesh Bearer Layer)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | BRR_NTF_CB )(BRR_HANDLE *brr_handle, UCHAR brr_event, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
BEARER Application Asynchronous Notification Callback. More...
typedef void(* | BRR_BCON_CB )(UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
BEARER Application Asynchronous Notification Callback for Beacons. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* BRR_NTF_CB)(BRR_HANDLE *brr_handle, UCHAR brr_event, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

BEARER Application Asynchronous Notification Callback.

BEARER calls the registered callback to indicate events occurred to the application.

Parameters
brr_type | Bearer Type.
data | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 249 of file MS_brr_api.h.

typedef void(* BRR_BCON_CB)(UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

BEARER Application Asynchronous Notification Callback for Beacons.

Application registers callback for beacon notification with bearer.

Parameters
brr_type | Bearer Type.
data | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 266 of file MS_brr_api.h.


EtherMind Mesh SDK (beta): Defines

Modules | Macros | Typedefs | Enumerations
Defines
BEARER (Mesh Bearer Layer)

Describes defines for the module. More...

Modules

Constants
Describes Constants defined by the module.
Structures

Macros

#define | BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET 6
#define | BRR_SUBTYPE_GATT_T_MASK (0xC0)
#define | BRR_SUBTYPE_GATT_NETWORK_T_MASK ((MESH_GATT_TYPE_NETWORK << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
#define | BRR_SUBTYPE_GATT_BEACON_T_MASK ((MESH_GATT_TYPE_BEACON << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
#define | BRR_SUBTYPE_GATT_PROXY_T_MASK ((MESH_GATT_TYPE_PROXY << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
#define | BRR_SUBTYPE_GATT_PROV_T_MASK ((MESH_GATT_TYPE_PROV << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))

Typedefs

typedef UCHAR BRR_HANDLE
Bearer handle identifier.

Enumerations

enum BRR_TYPE {
BRR_TYPE_BCON, BRR_TYPE_ADV, BRR_TYPE_PB_ADV, BRR_TYPE_GATT,
BRR_TYPE_PB_GATT, BRR_COUNT
}
Bearer Type definitions. More...
enum BRR_BCON_TTYPE {
BRR_BCON_TYPE_UNPROV_DEVICE, BRR_BCON_DUMMY, BRR_BCON_TYPE_SECURE_NET, BRR_BCON_TYPE_PROXY_NETID,
BRR_BCON_TYPE_PROXY_NODEID, BRR_BCON_COUNT
}
Bearer Beacon type definitions. More...

Detailed Description

Describes defines for the module.

Enumeration Type Documentation

enum BRR_TYPE

Bearer Type definitions.

Enumerator
BRR_TYPE_BCON | Beacon Bearer.
BRR_TYPE_ADV | Advertising Bearer.
BRR_TYPE_PB_ADV | Provisioning Advertising Bearer.
BRR_TYPE_GATT | GATT Bearer.
BRR_TYPE_PB_GATT | Provisioning GATT Bearer.
BRR_COUNT | Number of bearers supported.

Definition at line 102 of file MS_brr_api.h.

enum BRR_BCON_TTYPE

Bearer Beacon type definitions.

Enumerator
BRR_BCON_COUNT

Number of Beacon types.

Definition at line 133 of file MS_brr_api.h.


EtherMind Mesh SDK (beta): Constants

Macros
Constants
Defines

Describes Constants defined by the module. More...

Macros

#define | BRR_HANDLE_INVALID 0xFF
Invalid Bearer handle identifier.
#define | BRR_IFACE_DOWN 0x00
Bearer Interface events to the above layer.
#define | BRR_IFACE_UP 0x01
#define | BRR_IFACE_DATA 0x02
#define | BRR_IFACE_PROXY_DATA 0x03
#define | BRR_BCON_PASSIVE 0x00
Bearer beacon types - Connectable (Active) and Non-Connectable (Passive)
#define | BRR_BCON_ACTIVE 0x01
#define | BRR_BROADCAST 0x00
Bearer Beacon Operations - Broadcast/Observe.
#define | BRR_OBSERVE 0x01
#define | BRR_DISABLE 0x00
Bearer Beacon Actions - Enable/Disable.
#define | BRR_ENABLE 0x01
#define | BRR_MAX_PDU_SIZE 65
Maximum PDU size for data received over bearer.
#define | BRR_CLIENT_ROLE 0x00
Bearer Server Client Roles.
#define | BRR_SERVER_ROLE 0x01
#define | BRR_INVALID_ROLE 0xFF

Detailed Description

Describes Constants defined by the module.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
Defines

Data Structures

struct | BRR_BEARER_INFO
Bearer information to register. More...
struct | BRR_BEACON_INFO
Bearer Beacon type data structure. More...
struct | BRR_BEARER_CH_INFO
Bearer GATT Channel informartion related data structure. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): BRR_BEARER_INFO Struct Reference

Data Fields
BRR_BEARER_INFO Struct Reference
Structures

Bearer information to register. More...

#include <MS_brr_api.h>

Data Fields

MS_BUFFER * binfo
Bearer Information.
API_RESULT(* | bearer_send )(BRR_HANDLE *, UCHAR, void *, UINT16)
Data Send routine.
void(* | bearer_recv )(BRR_HANDLE *, UCHAR *, UINT16, MS_BUFFER *info)
Data Receive routine.
void(* | bearer_sleep )(BRR_HANDLE *)
Bearer Sleep Interface.
void(* | bearer_wakeup )(BRR_HANDLE *)
Bearer Wakeup Interface.

Detailed Description

Bearer information to register.

Definition at line 161 of file MS_brr_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_brr_api.h


EtherMind Mesh SDK (beta): BRR_BEACON_INFO Struct Reference

Data Fields
BRR_BEACON_INFO Struct Reference
Structures

Bearer Beacon type data structure. More...

#include <MS_brr_api.h>

Data Fields

UCHAR | action
Beacon Action. More...
UCHAR | type
Beacon type. More...
UCHAR * | bcon_data
Beacon Broadcast Data.
UINT16 | bcon_datalen
Beacon Broadcast Data length.
MS_BUFFER * uri
URI information in case of Unprovisioned Beacons.

Detailed Description

Bearer Beacon type data structure.

Definition at line 181 of file MS_brr_api.h.

Field Documentation

UCHAR BRR_BEACON_INFO::action

Beacon Action.

  • Lower Nibble:

    BRR_OBSERVE BRR_BROADCAST

  • Higher Nibble:

    BRR_ENABLE BRR_DISABLE

Definition at line 193 of file MS_brr_api.h.

UCHAR BRR_BEACON_INFO::type

Beacon type.

  • Lower Nibble:

    BRR_BCON_PASSIVE - Non Connectable beacon BRR_BCON_ACTIVE - Connectable beacon

  • Higher Nibble (Valid only when Passive)

    BRR_BCON_TYPE_UNPROV_DEVICE BRR_BCON_TYPE_SECURE_NET

Definition at line 205 of file MS_brr_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_brr_api.h


EtherMind Mesh SDK (beta): BRR_BEARER_CH_INFO Struct Reference

Data Fields
BRR_BEARER_CH_INFO Struct Reference
Structures

Bearer GATT Channel informartion related data structure. More...

#include <MS_brr_api.h>

Data Fields

UINT16 | mtu
Identifies the MTU for the Bearer Channel.
UCHAR | role
Identifies the role for the Bearer channel.

Detailed Description

Bearer GATT Channel informartion related data structure.

Definition at line 219 of file MS_brr_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_brr_api.h


EtherMind Mesh SDK (beta): Events

Modules
Events
BEARER (Mesh Bearer Layer)

This section lists the Asynchronous Events notified to Application by the Module. More...

Modules

Utility Macros
Initialization and other Utility Macros offered by the module.

Detailed Description

This section lists the Asynchronous Events notified to Application by the Module.


EtherMind Mesh SDK (beta): Utility Macros

Utility Macros
Events

Initialization and other Utility Macros offered by the module. More...

Initialization and other Utility Macros offered by the module.


EtherMind Mesh SDK (beta): CONFIG (Mesh Configuration Model)

Modules
CONFIG (Mesh Configuration Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Configuration Model (CONFIG) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Config Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Defines
Describes defines for the module.
Events
This section lists the Asynchronous Events notified to Application by the Module.
Structures
Utility Macros
This section defines the utility macros for use by the application.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Configuration Model (CONFIG) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
CONFIG (Mesh Configuration Model)

This section describes the EtherMind Mesh Config Model APIs. More...

Modules

Configuration Client API Definitions
This section describes the Configuration Client APIs.
Configuration Server API Definitions
This section describes the Configuration Server APIs.

Detailed Description

This section describes the EtherMind Mesh Config Model APIs.


EtherMind Mesh SDK (beta): Configuration Client API Definitions

Macros | Functions
Configuration Client API Definitions
API Definitions

This section describes the Configuration Client APIs. More...

Macros

#define | MS_config_client_beacon_get()
API to get the secure network beacon state. More...
#define | MS_config_client_beacon_set(param)
API to set the secure network beacon state. More...
#define | MS_config_client_composition_data_get(param)
API to get the composition data state. More...
#define | MS_config_client_default_ttl_get()
API to get the default TTL state. More...
#define | MS_config_client_default_ttl_set(param)
API to set the default TTL state. More...
#define | MS_config_client_gatt_proxy_get()
API to get the GATT proxy state. More...
#define | MS_config_client_gatt_proxy_set(param)
API to set the GATT Proxy state. More...
#define | MS_config_client_relay_get()
API to get the relay state. More...
#define | MS_config_client_relay_set(param)
API to set the relay state. More...
#define | MS_config_client_model_publication_get(param)
API to get the model publication state. More...
#define | MS_config_client_model_publication_set(param)
API to set the model publication state. More...
#define | MS_config_client_model_publication_vaddr_set(param)
API to set the model publication state. More...
#define | MS_config_client_model_subscription_add(param)
API to add subscription address. More...
#define | MS_config_client_model_subscription_vaddr_add(param)
API to add subscription address. More...
#define | MS_config_client_model_subscription_delete(param)
API to delete subscription address. More...
#define | MS_config_client_model_subscription_vaddr_delete(param)
API to delete subscription address. More...
#define | MS_config_client_model_subscription_overwrite(param)
API to add subscription address to cleared list. More...
#define | MS_config_client_model_subscription_vaddr_overwrite(param)
API to add subscription address to cleared list. More...
#define | MS_config_client_model_subscription_delete_all(param)
API to discard subscription list. More...
#define | MS_config_client_sig_model_subscription_get(param)
API to get subscription list. More...
#define | MS_config_client_vendor_model_subscription_get(param)
API to get subscription list. More...
#define | MS_config_client_netkey_add(param)
API to add to Netkey list. More...
#define | MS_config_client_netkey_update(param)
API to update to Netkey list. More...
#define | MS_config_client_netkey_delete(param)
API to delete from Netkey list. More...
#define | MS_config_client_netkey_get()
API to get Netkey list. More...
#define | MS_config_client_appkey_add(param)
API to add to Appkey list. More...
#define | MS_config_client_appkey_update(param)
API to update to Appkey list. More...
#define | MS_config_client_appkey_delete(param)
API to delete from Appkey list. More...
#define | MS_config_client_appkey_get(param)
API to get the Appkey list. More...
#define | MS_config_client_node_identity_get(param)
API to get the Node Identity state. More...
#define | MS_config_client_node_identity_set(param)
API to set the Node Identity state. More...
#define | MS_config_client_model_app_bind(param)
API to bind Appkey to model. More...
#define | MS_config_client_model_app_unbind(param)
API to unbind Appkey to model. More...
#define | MS_config_client_sig_model_app_get(param)
API to get all SIG model Appkeys. More...
#define | MS_config_client_vendor_model_app_get(param)
API to get all Vendor model Appkeys. More...
#define | MS_config_client_node_reset()
API to reset a node. More...
#define | MS_config_client_friend_get()
API to get friend state. More...
#define | MS_config_client_friend_set(param)
API to set friend state. More...
#define | MS_config_client_keyrefresh_phase_get(param)
API to get key refresh phase state. More...
#define | MS_config_client_keyrefresh_phase_set(param)
API to set key refresh phase state. More...
#define | MS_config_client_heartbeat_publication_get()
API to get heartbeat publication state. More...
#define | MS_config_client_heartbeat_publication_set(param)
API to set heartbeat publication state. More...
#define | MS_config_client_heartbeat_subscription_get()
API to get heartbeat subscription state. More...
#define | MS_config_client_heartbeat_subscription_set(param)
API to set heartbeat subscription state. More...
#define | MS_config_client_lpn_polltimeout_get(param)
API to get LPN Polltimeout state. More...
#define | MS_config_client_network_transmit_get()
API to get Network transmit state. More...
#define | MS_config_client_network_transmit_set(param)
API to set Network transmit state. More...

Functions

API_RESULT | MS_config_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_CONFIG_MODEL_CB appl_cb)
API to initialize Configuration Client model. More...
API_RESULT | MS_config_client_set_server (MS_NET_ADDR server_addr, UCHAR *dev_key)
API to set configuration server. More...
API_RESULT | MS_config_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Configuration Client APIs.

Macro Definition Documentation

#define MS_config_client_beacon_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_BEACON_GET_OPCODE,\
NULL,\
MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE \
)

API to get the secure network beacon state.

Description
The Config Beacon Get is an acknowledged message used to get the current Secure Network Beacon state of a node.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 787 of file MS_config_api.h.

#define MS_config_client_beacon_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_BEACON_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE \
)

API to set the secure network beacon state.

Description
The Config Beacon Set is an acknowledged message used to set the current Secure Network Beacon state of a node.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_BEACON_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 807 of file MS_config_api.h.

#define MS_config_client_composition_data_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_COMPOSITION_DATA_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_COMPOSITION_DATA_STATUS_OPCODE \
)

API to get the composition data state.

Description
The Config Composition Data Get is an acknowledged message used to read one page of the Composition Data.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_COMPDATA_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 827 of file MS_config_api.h.

#define MS_config_client_default_ttl_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_DEFAULT_TTL_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE \
)

API to get the default TTL state.

Description
Config Default TTL Get is an acknowledged message used to get the current Default TTL state of a node.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 844 of file MS_config_api.h.

#define MS_config_client_default_ttl_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_DEFAULT_TTL_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE \
)

API to set the default TTL state.

Description
The Config Default TTL Set is an acknowledged message used to set the Default TTL state of a node.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 864 of file MS_config_api.h.

#define MS_config_client_gatt_proxy_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_GATT_PROXY_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE \
)

API to get the GATT proxy state.

Description
The Config GATT Proxy Get is an acknowledged message used to get the GATT Proxy state of a node.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 881 of file MS_config_api.h.

#define MS_config_client_gatt_proxy_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_GATT_PROXY_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE \
)

API to set the GATT Proxy state.

Description
The Config GATT Proxy Set is an acknowledged message used to set the GATT Proxy state of a node.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_GATT_PROXY_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 901 of file MS_config_api.h.

#define MS_config_client_relay_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_RELAY_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE \
)

API to get the relay state.

Description
The Config Relay Get is an acknowledged message used to get the current Relay and Relay Retransmit states of a node.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 918 of file MS_config_api.h.

#define MS_config_client_relay_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_RELAY_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE \
)

API to set the relay state.

Description
The Config Relay Set is an acknowledged message used to set the current Relay and Relay Retransmit states of a node.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_RELAY_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 938 of file MS_config_api.h.

#define MS_config_client_model_publication_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_PUBLICATION_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE \
)

API to get the model publication state.

Description
The Config Model Publication Get is an acknowledged message used to get the publish address and parameters of an outgoing message that originates from a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELPUB_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 959 of file MS_config_api.h.

#define MS_config_client_model_publication_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_PUBLICATION_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE \
)

API to set the model publication state.

Description
The Config Model Publication Set is an acknowledged message used to set the Model Publication state of an outgoing message that originates from a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELPUB_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 980 of file MS_config_api.h.

#define MS_config_client_model_publication_vaddr_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_PUBLICATION_VIRTUAL_ADDRESS_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE \
)

API to set the model publication state.

Description
The Config Model Publication Set is an acknowledged message used to set the Model Publication state of an outgoing message that originates from a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1001 of file MS_config_api.h.

#define MS_config_client_model_subscription_add ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_ADD_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
)

API to add subscription address.

Description
The Config Model Subscription Add is an acknowledged message used to add an address to a Subscription List of a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELSUB_ADD_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1021 of file MS_config_api.h.

#define MS_config_client_model_subscription_vaddr_add ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_ADD_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
)

API to add subscription address.

Description
The Config Model Subscription Add is an acknowledged message used to add an address to a Subscription List of a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1041 of file MS_config_api.h.

#define MS_config_client_model_subscription_delete ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
)

API to delete subscription address.

Description
The Config Model Subscription Delete is an acknowledged message used to delete a subscription address from the Subscription List of a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELSUB_DEL_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1061 of file MS_config_api.h.

#define MS_config_client_model_subscription_vaddr_delete ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_DELETE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
)

API to delete subscription address.

Description
The Config Model Subscription Delete is an acknowledged message used to delete a subscription address from the Subscription List of a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1081 of file MS_config_api.h.

#define MS_config_client_model_subscription_overwrite ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_OVERWRITE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
)

API to add subscription address to cleared list.

Description
The Config Model Subscription Overwrite is an acknowledged message used to discard the Subscription List and add an address to the cleared Subscription List of a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1102 of file MS_config_api.h.

#define MS_config_client_model_subscription_vaddr_overwrite ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_OVERWRITE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
)

API to add subscription address to cleared list.

Description
The Config Model Subscription Overwrite is an acknowledged message used to discard the Subscription List and add an address to the cleared Subscription List of a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1123 of file MS_config_api.h.

#define MS_config_client_model_subscription_delete_all ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_ALL_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
)

API to discard subscription list.

Description
The Config Model Subscription Delete All is an acknowledged message used to discard the Subscription List of a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1143 of file MS_config_api.h.

#define MS_config_client_sig_model_subscription_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_LIST_OPCODE \
)

API to get subscription list.

Description
The Config SIG Model Subscription Get is an acknowledged message used to get the list of subscription addresses of a model within the element. This message is only for SIG Models.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_SIGMODELSUB_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1164 of file MS_config_api.h.

#define MS_config_client_vendor_model_subscription_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_LIST_OPCODE \
)

API to get subscription list.

Description
The Config SIG Model Subscription Get is an acknowledged message used to get the list of subscription addresses of a model within the element. This message is only for Vendor Models.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1185 of file MS_config_api.h.

#define MS_config_client_netkey_add ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NETKEY_ADD_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE \
)

API to add to Netkey list.

Description
The Config NetKey Add is an acknowledged message used to add a NetKey to a NetKey List on a node. The added NetKey is then used by the node to authenticate and decrypt messages it receives, as well as authenticate and encrypt messages it sends.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_NETKEY_ADD_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1207 of file MS_config_api.h.

#define MS_config_client_netkey_update ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NETKEY_UPDATE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE \
)

API to update to Netkey list.

Description
The Config NetKey Update is an acknowledged message used to update a NetKey on a node. The updated NetKey is then used by the node to authenticate and decrypt messages it receives, as well as authenticate and encrypt messages it sends, as defined by the Key Refresh procedure.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_NETKEY_UPDATE_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1229 of file MS_config_api.h.

#define MS_config_client_netkey_delete ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NETKEY_DELETE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE \
)

API to delete from Netkey list.

Description
The Config NetKey Delete is an acknowledged message used to delete a NetKey on a NetKey List from a node.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_NETKEY_DELETE_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1249 of file MS_config_api.h.

#define MS_config_client_netkey_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NETKEY_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_NETKEY_LIST_OPCODE \
)

API to get Netkey list.

Description
The Config NetKey Get is an acknowledged message used to report all NetKeys known to the node.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1266 of file MS_config_api.h.

#define MS_config_client_appkey_add ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_APPKEY_ADD_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE \
)

API to add to Appkey list.

Description
The Config AppKey Add is an acknowledged message used to add an AppKey to the AppKey List on a node and bind it to the NetKey identified by NetKeyIndex. The added AppKey can be used by the node only as a pair with the specified NetKey. The AppKey is used to authenticate and decrypt messages it receives, as well as authenticate and encrypt messages it sends.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_APPKEY_ADD_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1289 of file MS_config_api.h.

#define MS_config_client_appkey_update ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_APPKEY_UPDATE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE \
)

API to update to Appkey list.

Description
The Config AppKey Update is an acknowledged message used to update an AppKey value on the AppKey List on a node. The updated AppKey is used by the node to authenticate and decrypt messages it receives, as well as authenticate and encrypt messages it sends, as defined by the Key Refresh procedure.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_APPKEY_UPDATE_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1311 of file MS_config_api.h.

#define MS_config_client_appkey_delete ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_APPKEY_DELETE_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE \
)

API to delete from Appkey list.

Description
The Config AppKey Delete is an acknowledged message used to delete an AppKey from the AppKey List on a node
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_APPKEY_DELETE_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1331 of file MS_config_api.h.

#define MS_config_client_appkey_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_APPKEY_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_APPKEY_LIST_OPCODE \
)

API to get the Appkey list.

Description
The AppKey Get is an acknowledged message used to report all AppKeys bound to the NetKey.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_APPKEY_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1351 of file MS_config_api.h.

#define MS_config_client_node_identity_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NODE_IDENTITY_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE \
)

API to get the Node Identity state.

Description
The Config Node Identity Get is an acknowledged message used to get the current Node Identity state for a subnet.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_NODEID_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1371 of file MS_config_api.h.

#define MS_config_client_node_identity_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NODE_IDENTITY_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE \
)

API to set the Node Identity state.

Description
The Config Node Identity Set is an acknowledged message used to set the current Node Identity state for a subnet.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_NODEID_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1391 of file MS_config_api.h.

#define MS_config_client_model_app_bind ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_APP_BIND_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE \
)

API to bind Appkey to model.

Description
The Config Model App Bind is an acknowledged message used to bind an AppKey to a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODEL_APP_BIND_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1411 of file MS_config_api.h.

#define MS_config_client_model_app_unbind ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_MODEL_APP_UNBIND_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE \
)

API to unbind Appkey to model.

Description
The Config Model App Unbind is an acknowledged message used to remove the binding between an AppKey and a model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1431 of file MS_config_api.h.

#define MS_config_client_sig_model_app_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_SIG_MODEL_APP_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_SIG_MODEL_APP_LIST_OPCODE \
)

API to get all SIG model Appkeys.

Description
The Config SIG Model App Get is an acknowledged message used to request report of all AppKeys bound to the SIG Model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1451 of file MS_config_api.h.

#define MS_config_client_vendor_model_app_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_VENDOR_MODEL_APP_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_VENDOR_MODEL_APP_LIST_OPCODE \
)

API to get all Vendor model Appkeys.

Description
The Config Vendor Model App Get is an acknowledged message used to request report of all AppKeys bound to the Vendor Model.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1471 of file MS_config_api.h.

#define MS_config_client_node_reset ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NODE_RESET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_NODE_RESET_STATUS_OPCODE \
)

API to reset a node.

Description
The Config Node Reset is an acknowledged message used to reset a node (other than a Provisioner) and remove it from the network.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1488 of file MS_config_api.h.

#define MS_config_client_friend_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_FRIEND_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE \
)

API to get friend state.

Description
The Config Friend Get is an acknowledged message used to get the current Friend state of a node.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1505 of file MS_config_api.h.

#define MS_config_client_friend_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_FRIEND_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE \
)

API to set friend state.

Description
The Config Friend Set is an acknowledged message used to set the Friend state of a node.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_FRIEND_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1525 of file MS_config_api.h.

#define MS_config_client_keyrefresh_phase_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE \
)

API to get key refresh phase state.

Description
The Config Key Refresh Phase Get is an acknowledged message used to get the current Key Refresh Phase state of the identified network key.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1545 of file MS_config_api.h.

#define MS_config_client_keyrefresh_phase_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE \
)

API to set key refresh phase state.

Description
The Config Key Refresh Phase Set is an acknowledged message used to set the current Key Refresh Phase state of the identified network key.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1565 of file MS_config_api.h.

#define MS_config_client_heartbeat_publication_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_STATUS_OPCODE \
)

API to get heartbeat publication state.

Description
The Config Heartbeat Publication Get is an acknowledged message used to get the current Heartbeat Publication state of an element.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1582 of file MS_config_api.h.

#define MS_config_client_heartbeat_publication_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_STATUS_OPCODE \
)

API to set heartbeat publication state.

Description
The Config Heartbeat Publication Set is an acknowledged message used to set the current Heartbeat Publication state of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1602 of file MS_config_api.h.

#define MS_config_client_heartbeat_subscription_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE \
)

API to get heartbeat subscription state.

Description
The Config Heartbeat Subscription Get is an acknowledged message used to get the current Heartbeat Subscription state of an element.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1619 of file MS_config_api.h.

#define MS_config_client_heartbeat_subscription_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE \
)

API to set heartbeat subscription state.

Description
The Config Heartbeat Publication Set is an acknowledged message used to set the current Heartbeat Subscription state of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1639 of file MS_config_api.h.

#define MS_config_client_lpn_polltimeout_get ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_GET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_STATUS_OPCODE \
)

API to get LPN Polltimeout state.

Description
The Config Low Power Node PollTimeout Get is an acknowledged message used to get the current value of PollTimeout timer of the Low Power node within a Friend node. The message is sent to a Friend node that has claimed to be handling messages by sending ACKs On Behalf Of (OBO) the indicated Low Power node. This message should only be sent to a node that has the Friend feature supported and enabled.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1663 of file MS_config_api.h.

#define MS_config_client_network_transmit_get ( )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NETWORK_TRANSMIT_GET_OPCODE,\
NULL, \
MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE \
)

API to get Network transmit state.

Description
The Config Network Transmit Get is an acknowledged message used to get the current Network Transmit state of a node.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1680 of file MS_config_api.h.

#define MS_config_client_network_transmit_set ( param )
Value:
MS_config_client_send_reliable_pdu \
(\
MS_ACCESS_CONFIG_NETWORK_TRANSMIT_SET_OPCODE,\
(void *)param, \
MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE \
)

API to set Network transmit state.

Description
The Config Network Transmit Set is an acknowledged message used to set the current Network Transmit state of a node.
Parameters
[in] param Pointer to the structure populated as in ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 1700 of file MS_config_api.h.

Function Documentation

API_RESULT MS_config_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_CONFIG_MODEL_CB | appl_cb
 | ) |  |

API to initialize Configuration Client model.

Description
This is to initialize Configuration Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Configuration Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_config_client_set_server | ( | MS_NET_ADDR | server_addr,
 |  | UCHAR * | dev_key
 | ) |  |

API to set configuration server.

Description
This is to sets the information about server which is to be configured.
Parameters
[in] | server_addr | Address of Configuration Server.
[in] | dev_key | Device Key of Configuration Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_config_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Configuration Server API Definitions

Functions
Configuration Server API Definitions
API Definitions

This section describes the Configuration Server APIs. More...

Functions

API_RESULT MS_config_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle)
API to initialize configuration server model. More...

Detailed Description

This section describes the Configuration Server APIs.

Function Documentation

API_RESULT MS_config_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle
 | ) |  |

API to initialize configuration server model.

Description
This is to initialize configuration server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
CONFIG (Mesh Configuration Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* MS_CONFIG_MODEL_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Configuration Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_CONFIG_MODEL_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Configuration Client application Asynchronous Notification Callback.

Configuration Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 94 of file MS_config_api.h.


EtherMind Mesh SDK (beta): Defines

Modules
Defines
CONFIG (Mesh Configuration Model)

Describes defines for the module. More...

Modules

Constants
Describes Constants defined by the module.

Detailed Description

Describes defines for the module.


EtherMind Mesh SDK (beta): Constants

Modules
Constants
Defines

Describes Constants defined by the module. More...

Modules

Status Codes
This section lists the Status Codes applicable at the Configuration Model.

Detailed Description

Describes Constants defined by the module.


EtherMind Mesh SDK (beta): Status Codes

Status Codes
Constants

This section lists the Status Codes applicable at the Configuration Model. More...

This section lists the Status Codes applicable at the Configuration Model.


EtherMind Mesh SDK (beta): Events

Events
CONFIG (Mesh Configuration Model)

This section lists the Asynchronous Events notified to Application by the Module. More...

This section lists the Asynchronous Events notified to Application by the Module.


EtherMind Mesh SDK (beta): Structures

Modules
Structures
CONFIG (Mesh Configuration Model)

Modules

Configuration Client Data Structures
This section describes the data structures for use in Configuration Client APIs.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Configuration Client Data Structures

Data Structures
Configuration Client Data Structures
Structures

This section describes the data structures for use in Configuration Client APIs. More...

Data Structures

struct | ACCESS_CONFIG_BEACON_SET_PARAM
Beacon Set parameter structure. More...
struct | ACCESS_CONFIG_COMPDATA_GET_PARAM
Composition Data Get parameter structure. More...
struct | ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM
Default TTL Set parameter structure. More...
struct | ACCESS_CONFIG_GATT_PROXY_SET_PARAM
GATT Proxy Set parameter structure. More...
struct | ACCESS_CONFIG_RELAY_SET_PARAM
Relay Set parameter structure. More...
struct | ACCESS_CONFIG_MODELPUB_GET_PARAM
Model Publication Get parameter structure. More...
struct | ACCESS_CONFIG_MODELPUB_SET_PARAM
Model Publication Set parameter structure. More...
struct | ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
Model Publication Virtual Address Set parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_ADD_PARAM
Model Subscription Add parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM
Model Subscription Virtual Address Add parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_DEL_PARAM
Model Subscription Delete parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM
Model Subscription Virtual Address Delete parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM
Model Subscription Overwrite parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM
Model Subscription Virtual Address Overwrite parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM
Model Subscription Delete All parameter structure. More...
struct | ACCESS_CONFIG_SIGMODELSUB_GET_PARAM
SIG Model Subscription Get parameter structure. More...
struct | ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM
Vendor Model Subscription Get parameter structure. More...
struct | ACCESS_CONFIG_NETKEY_ADD_PARAM
Netkey Add parameter structure. More...
struct | ACCESS_CONFIG_NETKEY_UPDATE_PARAM
Netkey Update parameter structure. More...
struct | ACCESS_CONFIG_NETKEY_DELETE_PARAM
Netkey Delete parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_ADD_PARAM
Appkey Add parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_UPDATE_PARAM
Appkey Update parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_DELETE_PARAM
Appkey Delete parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_GET_PARAM
Appkey Get parameter structure. More...
struct | ACCESS_CONFIG_NODEID_GET_PARAM
Node Identity Get parameter structure. More...
struct | ACCESS_CONFIG_NODEID_SET_PARAM
Node Identity Set parameter structure. More...
struct | ACCESS_CONFIG_MODEL_APP_BIND_PARAM
Model App Bind parameter structure. More...
struct | ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM
Model App Unbind parameter structure. More...
struct | ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM
SIG Model App Get parameter structure. More...
struct | ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM
Vendor Model App Get parameter structure. More...
struct | ACCESS_CONFIG_FRIEND_SET_PARAM
Friend Set parameter structure. More...
struct | ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM
Key Refresh Phase Get parameter structure. More...
struct | ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM
Key Refresh Phase Set parameter structure. More...
struct | ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
Heartbeat Publication Set parameter structure. More...
struct | ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
Heartbeat Subscription Set parameter structure. More...
struct | ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM
Low Power Node PollTimeout Get parameter structure. More...
struct | ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
Network Transmit Set parameter structure. More...

Detailed Description

This section describes the data structures for use in Configuration Client APIs.


EtherMind Mesh SDK (beta): ACCESS_CONFIG_BEACON_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_BEACON_SET_PARAM Struct Reference
Configuration Client Data Structures

Beacon Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR beacon
New Secure Network Beacon state.

Detailed Description

Beacon Set parameter structure.

Definition at line 116 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_COMPDATA_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_COMPDATA_GET_PARAM Struct Reference
Configuration Client Data Structures

Composition Data Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR page
Page number of the Composition Data.

Detailed Description

Composition Data Get parameter structure.

Definition at line 126 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM Struct Reference
Configuration Client Data Structures

Default TTL Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR ttl
New Default TTL value.

Detailed Description

Default TTL Set parameter structure.

Definition at line 136 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_GATT_PROXY_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_GATT_PROXY_SET_PARAM Struct Reference
Configuration Client Data Structures

GATT Proxy Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR proxy
New GATT Proxy state.

Detailed Description

GATT Proxy Set parameter structure.

Definition at line 146 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_RELAY_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_RELAY_SET_PARAM Struct Reference
Configuration Client Data Structures

Relay Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR | relay
Relay.
UCHAR | relay_rtx_count
Number of retransmissions on advertising bearer for each Network PDU relayed by the node. More...
UCHAR | relay_rtx_interval_steps
Number of 10-millisecond steps between retransmissions. More...

Detailed Description

Relay Set parameter structure.

Definition at line 156 of file MS_config_api.h.

Field Documentation

UCHAR ACCESS_CONFIG_RELAY_SET_PARAM::relay_rtx_count

Number of retransmissions on advertising bearer for each Network PDU relayed by the node.

  • 3 bits validity

Definition at line 166 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_RELAY_SET_PARAM::relay_rtx_interval_steps

Number of 10-millisecond steps between retransmissions.

  • 5 bits validity

Definition at line 172 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELPUB_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELPUB_GET_PARAM Struct Reference
Configuration Client Data Structures

Model Publication Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 element_address
Address of the element.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Publication Get parameter structure.

Definition at line 179 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELPUB_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELPUB_SET_PARAM Struct Reference
Configuration Client Data Structures

Model Publication Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UINT16 | publish_address
Value of the publish address.
UINT16 | appkey_index
Index of the application key. More...
UCHAR | credential_flag
Value of the Friendship Credential Flag. More...
UCHAR | publish_ttl
Default TTL value for the outgoing messages.
UCHAR | publish_period
Period for periodic status publishing.
UCHAR | publish_rtx_count
Number of retransmissions for each published message. More...
UCHAR | publish_rtx_interval_steps
Number of 50-millisecond steps between retransmissions. More...
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Publication Set parameter structure.

Definition at line 192 of file MS_config_api.h.

Field Documentation

UINT16 ACCESS_CONFIG_MODELPUB_SET_PARAM::appkey_index

Index of the application key.

  • 12 bits validity

Definition at line 204 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_MODELPUB_SET_PARAM::credential_flag

Value of the Friendship Credential Flag.

  • 1 bit validity

Definition at line 210 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_MODELPUB_SET_PARAM::publish_rtx_count

Number of retransmissions for each published message.

  • 3 bits validity

Definition at line 222 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_MODELPUB_SET_PARAM::publish_rtx_interval_steps

Number of 50-millisecond steps between retransmissions.

  • 5 bits validity

Definition at line 228 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM Struct Reference
Configuration Client Data Structures

Model Publication Virtual Address Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UCHAR | publish_address [MS_ACCESS_VADDR_LABEL_UUID_SIZE]
Value of the Label UUID publish address.
UINT16 | appkey_index
Index of the application key. More...
UCHAR | credential_flag
Value of the Friendship Credential Flag. More...
UCHAR | publish_ttl
Default TTL value for the outgoing messages.
UCHAR | publish_period
Period for periodic status publishing.
UCHAR | publish_rtx_count
Number of retransmissions for each published message. More...
UCHAR | publish_rtx_interval_steps
Number of 50-millisecond steps between retransmissions. More...
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Publication Virtual Address Set parameter structure.

Definition at line 238 of file MS_config_api.h.

Field Documentation

UINT16 ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM::appkey_index

Index of the application key.

  • 12 bits validity

Definition at line 250 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM::credential_flag

Value of the Friendship Credential Flag.

  • 1 bit validity

Definition at line 256 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM::publish_rtx_count

Number of retransmissions for each published message.

  • 3 bits validity

Definition at line 268 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM::publish_rtx_interval_steps

Number of 50-millisecond steps between retransmissions.

  • 5 bits validity

Definition at line 274 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELSUB_ADD_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELSUB_ADD_PARAM Struct Reference
Configuration Client Data Structures

Model Subscription Add parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UINT16 | address
Value of the address.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Subscription Add parameter structure.

Definition at line 284 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM Struct Reference
Configuration Client Data Structures

Model Subscription Virtual Address Add parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UCHAR | label [MS_ACCESS_VADDR_LABEL_UUID_SIZE]
Value of the Label UUID.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Subscription Virtual Address Add parameter structure.

Definition at line 300 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELSUB_DEL_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELSUB_DEL_PARAM Struct Reference
Configuration Client Data Structures

Model Subscription Delete parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UINT16 | address
Value of the address.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Subscription Delete parameter structure.

Definition at line 316 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM Struct Reference
Configuration Client Data Structures

Model Subscription Virtual Address Delete parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UCHAR | label [MS_ACCESS_VADDR_LABEL_UUID_SIZE]
Value of the Label UUID.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Subscription Virtual Address Delete parameter structure.

Definition at line 332 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM Struct Reference
Configuration Client Data Structures

Model Subscription Overwrite parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UINT16 | address
Value of the address.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Subscription Overwrite parameter structure.

Definition at line 348 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM Struct Reference
Configuration Client Data Structures

Model Subscription Virtual Address Overwrite parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UCHAR | label [MS_ACCESS_VADDR_LABEL_UUID_SIZE]
Value of the Label UUID.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Subscription Virtual Address Overwrite parameter structure.

Definition at line 364 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM Struct Reference
Configuration Client Data Structures

Model Subscription Delete All parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 element_address
Address of the element.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model Subscription Delete All parameter structure.

Definition at line 380 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_SIGMODELSUB_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_SIGMODELSUB_GET_PARAM Struct Reference
Configuration Client Data Structures

SIG Model Subscription Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 element_address
Address of the element.
MS_ACCESS_MODEL_ID_SIG model_id
SIG Model ID.

Detailed Description

SIG Model Subscription Get parameter structure.

Definition at line 393 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM Struct Reference
Configuration Client Data Structures

Vendor Model Subscription Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 element_address
Address of the element.
MS_ACCESS_MODEL_ID_VENDOR model_id
Vendor Model ID.

Detailed Description

Vendor Model Subscription Get parameter structure.

Definition at line 406 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_NETKEY_ADD_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_NETKEY_ADD_PARAM Struct Reference
Configuration Client Data Structures

Netkey Add parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR | netkey [MS_ACCESS_NETKEY_SIZE]
Netkey.
UINT16 | netkey_index
Netkey Index.

Detailed Description

Netkey Add parameter structure.

Definition at line 419 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_NETKEY_UPDATE_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_NETKEY_UPDATE_PARAM Struct Reference
Configuration Client Data Structures

Netkey Update parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR | netkey [MS_ACCESS_NETKEY_SIZE]
New Netkey.
UINT16 | netkey_index
Netkey Index.

Detailed Description

Netkey Update parameter structure.

Definition at line 432 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_NETKEY_DELETE_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_NETKEY_DELETE_PARAM Struct Reference
Configuration Client Data Structures

Netkey Delete parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 netkey_index
Netkey Index.

Detailed Description

Netkey Delete parameter structure.

Definition at line 445 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_APPKEY_ADD_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_APPKEY_ADD_PARAM Struct Reference
Configuration Client Data Structures

Appkey Add parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR | appkey [MS_ACCESS_APPKEY_SIZE]
Appkey value.
UINT16 | netkey_index
Index of the NetKey and index of the AppKey. More...
UINT16 | appkey_index

Detailed Description

Appkey Add parameter structure.

Definition at line 455 of file MS_config_api.h.

Field Documentation

UINT16 ACCESS_CONFIG_APPKEY_ADD_PARAM::netkey_index

Index of the NetKey and index of the AppKey.

  • 24 bits valid

Definition at line 464 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_APPKEY_UPDATE_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_APPKEY_UPDATE_PARAM Struct Reference
Configuration Client Data Structures

Appkey Update parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR | appkey [MS_ACCESS_APPKEY_SIZE]
New Appkey value.
UINT16 | netkey_index
Index of the NetKey and index of the AppKey. More...
UINT16 | appkey_index

Detailed Description

Appkey Update parameter structure.

Definition at line 472 of file MS_config_api.h.

Field Documentation

UINT16 ACCESS_CONFIG_APPKEY_UPDATE_PARAM::netkey_index

Index of the NetKey and index of the AppKey.

  • 24 bits valid

Definition at line 481 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_APPKEY_DELETE_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_APPKEY_DELETE_PARAM Struct Reference
Configuration Client Data Structures

Appkey Delete parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | netkey_index
Index of the NetKey and index of the AppKey. More...
UINT16 | appkey_index

Detailed Description

Appkey Delete parameter structure.

Definition at line 489 of file MS_config_api.h.

Field Documentation

UINT16 ACCESS_CONFIG_APPKEY_DELETE_PARAM::netkey_index

Index of the NetKey and index of the AppKey.

  • 24 bits valid

Definition at line 495 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_APPKEY_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_APPKEY_GET_PARAM Struct Reference
Configuration Client Data Structures

Appkey Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 netkey_index
Index of the NetKey.

Detailed Description

Appkey Get parameter structure.

Definition at line 503 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_NODEID_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_NODEID_GET_PARAM Struct Reference
Configuration Client Data Structures

Node Identity Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 netkey_index
Index of the NetKey.

Detailed Description

Node Identity Get parameter structure.

Definition at line 513 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_NODEID_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_NODEID_SET_PARAM Struct Reference
Configuration Client Data Structures

Node Identity Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | netkey_index
Index of the NetKey.
UCHAR | identity
New Node Identity state.

Detailed Description

Node Identity Set parameter structure.

Definition at line 523 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODEL_APP_BIND_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODEL_APP_BIND_PARAM Struct Reference
Configuration Client Data Structures

Model App Bind parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UINT16 | appkey_index
Index of the AppKey.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model App Bind parameter structure.

Definition at line 536 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM Struct Reference
Configuration Client Data Structures

Model App Unbind parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | element_address
Address of the element.
UINT16 | appkey_index
Index of the AppKey.
MS_ACCESS_MODEL_ID model
SIG Model ID or Vendor Model ID.

Detailed Description

Model App Unbind parameter structure.

Definition at line 552 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM Struct Reference
Configuration Client Data Structures

SIG Model App Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 element_address
Address of the element.
MS_ACCESS_MODEL_ID_SIG model_id
SIG Model ID.

Detailed Description

SIG Model App Get parameter structure.

Definition at line 568 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM Struct Reference
Configuration Client Data Structures

Vendor Model App Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 element_address
Address of the element.
MS_ACCESS_MODEL_ID_VENDOR model_id
Vendor Model ID.

Detailed Description

Vendor Model App Get parameter structure.

Definition at line 581 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_FRIEND_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_FRIEND_SET_PARAM Struct Reference
Configuration Client Data Structures

Friend Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR friend
New Friend state.

Detailed Description

Friend Set parameter structure.

Definition at line 594 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM Struct Reference
Configuration Client Data Structures

Key Refresh Phase Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 netkey_index
Netkey Index.

Detailed Description

Key Refresh Phase Get parameter structure.

Definition at line 604 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM Struct Reference
Configuration Client Data Structures

Key Refresh Phase Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | netkey_index
Netkey Index.
UCHAR | transition
New Key Refresh Phase Transition.

Detailed Description

Key Refresh Phase Set parameter structure.

Definition at line 614 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM Struct Reference
Configuration Client Data Structures

Heartbeat Publication Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | destination
Destination address for Heartbeat messages.
UCHAR | countlog
Number of Heartbeat messages to be sent.
UCHAR | periodlog
Period for sending Heartbeat messages.
UCHAR | ttl
TTL to be used when sending Heartbeat messages.
UINT16 | features
Bit field indicating features that trigger Heartbeat messages when changed.
UINT16 | netkey_index
Netkey Index.

Detailed Description

Heartbeat Publication Set parameter structure.

Definition at line 627 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM Struct Reference
Configuration Client Data Structures

Heartbeat Subscription Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 | source
Source address for Heartbeat messages.
UINT16 | destination
Destination address for Heartbeat messages.
UCHAR | periodlog
Period for receiving Heartbeat messages.

Detailed Description

Heartbeat Subscription Set parameter structure.

Definition at line 655 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM Struct Reference
Configuration Client Data Structures

Low Power Node PollTimeout Get parameter structure. More...

#include <MS_config_api.h>

Data Fields

UINT16 lpn_address
The unicast address of the Low Power node.

Detailed Description

Low Power Node PollTimeout Get parameter structure.

Definition at line 671 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM Struct Reference

Data Fields
ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM Struct Reference
Configuration Client Data Structures

Network Transmit Set parameter structure. More...

#include <MS_config_api.h>

Data Fields

UCHAR | net_tx_count
Number of transmissions for each Network PDU originating from the node. More...
UCHAR | net_tx_interval_steps
Number of 10-millisecond steps between transmissions. More...

Detailed Description

Network Transmit Set parameter structure.

Definition at line 681 of file MS_config_api.h.

Field Documentation

UCHAR ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM::net_tx_count

Number of transmissions for each Network PDU originating from the node.

  • 3 bits validity

Definition at line 688 of file MS_config_api.h.

UCHAR ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM::net_tx_interval_steps

Number of 10-millisecond steps between transmissions.

  • 5 bits validity

Definition at line 694 of file MS_config_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_config_api.h


EtherMind Mesh SDK (beta): Utility Macros

Utility Macros
CONFIG (Mesh Configuration Model)

This section defines the utility macros for use by the application. More...

This section defines the utility macros for use by the application.


EtherMind Mesh SDK (beta): Fault Values

Macros
Fault Values

This section lists the Fault Values defined for Health Model. More...

Macros

#define | MS_HEALTH_FAULT_NO_FAULT 0x00
Health Model - Fault Values. More...
#define | MS_HEALTH_FAULT_BATTERY_LOW_WARNING 0x01
Battery Low Warning.
#define | MS_HEALTH_FAULT_BATTERY_LOW_ERROR 0x02
Battery Low Error.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_WARNING 0x03
Supply Voltage Too Low Warning.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_ERROR 0x04
Supply Voltage Too Low Error.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_WARNING 0x05
Supply Voltage Too High Warning.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_ERROR 0x06
Supply Voltage Too High Error.
#define | MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_WARNING 0x07
Power Supply Interrupted Warning.
#define | MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_ERROR 0x08
Power Supply Interrupted Error.
#define | MS_HEALTH_FAULT_NO_LOAD_WARNING 0x09
No Load Warning.
#define | MS_HEALTH_FAULT_NO_LOAD_ERROR 0x0A
No Load Error.
#define | MS_HEALTH_FAULT_OVERLOAD_WARNING 0x0B
Overload Warning.
#define | MS_HEALTH_FAULT_OVERLOAD_ERROR 0x0C
Overload Error.
#define | MS_HEALTH_FAULT_OVERHEAT_WARNING 0x0D
Overheat Warning.
#define | MS_HEALTH_FAULT_OVERHEAT_ERROR 0x0E
Overheat Error.
#define | MS_HEALTH_FAULT_CONDENSATION_WARNING 0x0F
Condensation Warning.
#define | MS_HEALTH_FAULT_CONDENSATION_ERROR 0x10
Condensation Error.
#define | MS_HEALTH_FAULT_VIBRATION_WARNING 0x11
Vibration Warning.
#define | MS_HEALTH_FAULT_VIBRATION_ERROR 0x12
Vibration Error.
#define | MS_HEALTH_FAULT_CONFIGURATION_WARNING 0x13
Configuration Warning.
#define | MS_HEALTH_FAULT_CONFIGURATION_ERROR 0x14
Configuration Error.
#define | MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_WARNING 0x15
Element Not Calibrated Warning.
#define | MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_ERROR 0x16
Element Not Calibrated Error.
#define | MS_HEALTH_FAULT_MEMORY_WARNING 0x17
Memory Warning.
#define | MS_HEALTH_FAULT_MEMORY_ERROR 0x18
Memory Error.
#define | MS_HEALTH_FAULT_SELF_TEST_WARNING 0x19
Self-Test Warning.
#define | MS_HEALTH_FAULT_SELF_TEST_ERROR 0x1A
Self-Test Error.
#define | MS_HEALTH_FAULT_INPUT_TOO_LOW_WARNING 0x1B
Input Too Low Warning.
#define | MS_HEALTH_FAULT_INPUT_TOO_LOW_ERROR 0x1C
Input Too Low Error.
#define | MS_HEALTH_FAULT_INPUT_TOO_HIGH_WARNING 0x1D
Input Too High Warning.
#define | MS_HEALTH_FAULT_INPUT_TOO_HIGH_ERROR 0x1E
Input Too High Error.
#define | MS_HEALTH_FAULT_INPUT_NO_CHANGE_WARNING 0x1F
Input No Change Warning.
#define | MS_HEALTH_FAULT_INPUT_NO_CHANGE_ERROR 0x20
Input No Change Error.
#define | MS_HEALTH_FAULT_ACTUATOR_BLOCKED_WARNING 0x21
Actuator Blocked Warning.
#define | MS_HEALTH_FAULT_ACTUATOR_BLOCKED_ERROR 0x22
Actuator Blocked Error.
#define | MS_HEALTH_FAULT_HOUSING_OPENED_WARNING 0x23
Housing Opened Warning.
#define | MS_HEALTH_FAULT_HOUSING_OPENED_ERROR 0x24
Housing Opened Error.
#define | MS_HEALTH_FAULT_TAMPER_WARNING 0x25
Tamper Warning.
#define | MS_HEALTH_FAULT_TAMPER_ERROR 0x26
Tamper Error.
#define | MS_HEALTH_FAULT_DEVICE_MOVED_WARNING 0x27
Device Moved Warning.
#define | MS_HEALTH_FAULT_DEVICE_MOVED_ERROR 0x28
Device Moved Error.
#define | MS_HEALTH_FAULT_DEVICE_DROPPED_WARNING 0x29
Device Dropped Warning.
#define | MS_HEALTH_FAULT_DEVICE_DROPPED_ERROR 0x2A
Device Dropped Error.
#define | MS_HEALTH_FAULT_OVERFLOW_WARNING 0x2B
Overflow Warning.
#define | MS_HEALTH_FAULT_OVERFLOW_ERROR 0x2C
Overflow Error.
#define | MS_HEALTH_FAULT_EMPTY_WARNING 0x2D
Empty Warning.
#define | MS_HEALTH_FAULT_EMPTY_ERROR 0x2E
Empty Error.
#define | MS_HEALTH_FAULT_INTERNAL_BUS_WARNING 0x2F
Internal Bus Warning.
#define | MS_HEALTH_FAULT_INTERNAL_BUS_ERROR 0x30
Internal Bus Error.
#define | MS_HEALTH_FAULT_MECHANISM_JAMMED_WARNING 0x31
Mechanism Jammed Warning.
#define | MS_HEALTH_FAULT_MECHANISM_JAMMED_ERROR 0x32
Mechanism Jammed Error.

Detailed Description

This section lists the Fault Values defined for Health Model.

Macro Definition Documentation

#define MS_HEALTH_FAULT_NO_FAULT 0x00

Health Model - Fault Values.

No Fault

Definition at line 30 of file MS_health_server_api.h.


EtherMind Mesh SDK (beta): GENERIC_BATTERY (Mesh Generic Battery Model)

Modules
GENERIC_BATTERY (Mesh Generic Battery Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Battery Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_BATTERY (Mesh Generic Battery Model)

This section describes the EtherMind Mesh Generic Battery Model APIs. More...

Modules

Generic Battery Client API Definitions
This section describes the Generic Battery Client APIs.
Generic Battery Server API Definitions
This section describes the Generic Battery Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Battery Model APIs.


EtherMind Mesh SDK (beta): Generic Battery Client API Definitions

Macros | Functions
Generic Battery Client API Definitions
API Definitions

This section describes the Generic Battery Client APIs. More...

Macros

#define MS_generic_battery_get()
API to get the Generic Battery state of an element. More...

Functions

API_RESULT | MS_generic_battery_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_BATTERY_CLIENT_CB appl_cb)
API to initialize Generic_Battery Client model. More...
API_RESULT | MS_generic_battery_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Battery client model handle. More...
API_RESULT | MS_generic_battery_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Battery Client APIs.

Macro Definition Documentation

#define MS_generic_battery_get ( )
Value:
MS_generic_battery_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_BATTERY_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_BATTERY_STATUS_OPCODE\
)

API to get the Generic Battery state of an element.

Description
Generic Battery Get message is an acknowledged message used to get the Generic Battery state of an element. The response to the Generic Battery Get message is a Generic Battery Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 281 of file MS_generic_battery_api.h.

Function Documentation

API_RESULT MS_generic_battery_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_BATTERY_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Battery Client model.

Description
This is to initialize Generic_Battery Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Battery Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_battery_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Battery client model handle.

Description
This is to get the handle of Generic_Battery client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_battery_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic Battery Server API Definitions

Functions
Generic Battery Server API Definitions
API Definitions

This section describes the Generic Battery Server APIs. More...

Functions

API_RESULT | MS_generic_battery_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_BATTERY_SERVER_CB appl_cb)
API to initialize Generic_Battery Server model. More...
API_RESULT | MS_generic_battery_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Generic Battery Server APIs.

Function Documentation

API_RESULT MS_generic_battery_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_BATTERY_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Battery Server model.

Description
This is to initialize Generic_Battery Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Battery Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_battery_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_BATTERY (Mesh Generic Battery Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_BATTERY_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Battery Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_BATTERY_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Battery Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_BATTERY_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Battery Server application Asynchronous Notification Callback.

Generic Battery Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_generic_battery_api.h.

typedef API_RESULT(* MS_GENERIC_BATTERY_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Battery Client application Asynchronous Notification Callback.

Generic Battery Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_generic_battery_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_BATTERY (Mesh Generic Battery Model)

Data Structures

struct MS_GENERIC_BATTERY_STATUS_STRUCT
The Generic Battery state is a set of four values representing the state of a battery: More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_BATTERY_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_BATTERY_STATUS_STRUCT Struct Reference
Structures

The Generic Battery state is a set of four values representing the state of a battery: More...

#include <MS_generic_battery_api.h>

Data Fields

UCHAR | battery_level
Generic Battery Level. More...
UINT32 | time_to_discharge
The Generic Battery Time to Discharge state is a 24-bit unsigned value ranging from 0 through 0xFFFFFF. More...
UINT32 | time_to_charge
The Generic Battery Time to Charge state is a 24-bit unsigned value ranging from 0 through 0xFFFFFF. More...
UCHAR | flags
The Generic Battery Flags state is a concatenation of four 2-bit bit fields: Presence, Indicator, Charging, and Serviceability. More...

Detailed Description

The Generic Battery state is a set of four values representing the state of a battery:

  • a charge level (Generic Battery Level)
  • remaining time to complete discharging (Generic Battery Time to Discharge)
  • remaining time to complete charging (Generic Battery Time to Charge)
  • flags bit field (Generic Battery Flags)

Definition at line 93 of file MS_generic_battery_api.h.

Field Documentation

UCHAR MS_GENERIC_BATTERY_STATUS_STRUCT::battery_level

Generic Battery Level.

The Generic Battery Level state is a value ranging from 0 percent through 100 percent.

Value | Description
0x00-0x64 | The percentage of the charge level. 100% represents fully charged. 0% represents fully discharged.
0x65-0xFE | Prohibited
0xFF | The percentage of the charge level is unknown.

Definition at line 105 of file MS_generic_battery_api.h.

UINT32 MS_GENERIC_BATTERY_STATUS_STRUCT::time_to_discharge

The Generic Battery Time to Discharge state is a 24-bit unsigned value ranging from 0 through 0xFFFFFF.

Value | Description
0x000000-0xFFFFFE | The remaining time (in minutes) of the discharging process
0xFFFFFF | The remaining time of the discharging process is not known.

Definition at line 115 of file MS_generic_battery_api.h.

UINT32 MS_GENERIC_BATTERY_STATUS_STRUCT::time_to_charge

The Generic Battery Time to Charge state is a 24-bit unsigned value ranging from 0 through 0xFFFFFF.

Value | Description
0x000000-0xFFFFFE | The remaining time (in minutes) of the charging process
0xFFFFFF | The remaining time of the charging process is not known.

Definition at line 125 of file MS_generic_battery_api.h.

UCHAR MS_GENERIC_BATTERY_STATUS_STRUCT::flags

The Generic Battery Flags state is a concatenation of four 2-bit bit fields: Presence, Indicator, Charging, and Serviceability.

Bit | Description
0-1 | Generic Battery Flags Presence
2-3 | Generic Battery Flags Indicator
4-5 | Generic Battery Flags Charging
6-7 | Generic Battery Flags Serviceability

Definition at line 137 of file MS_generic_battery_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_battery_api.h


EtherMind Mesh SDK (beta): GENERIC_DEFAULT_TRANSITION_TIME (Mesh Generic Default Transition Time Model)

Modules
GENERIC_DEFAULT_TRANSITION_TIME (Mesh Generic Default Transition Time Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Default Transition Time Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_DEFAULT_TRANSITION_TIME (Mesh Generic Default Transition Time Model)

This section describes the EtherMind Mesh Generic Default Transition Time Model APIs. More...

Modules

Generic Default Transition Time Client API Definitions
This section describes the Generic Default Transition Time Client APIs.
Generic Default Transition Time Server API Definitions
This section describes the Generic Default Transition Time Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Default Transition Time Model APIs.


EtherMind Mesh SDK (beta): Generic Default Transition Time Client API Definitions

Macros | Functions
Generic Default Transition Time Client API Definitions
API Definitions

This section describes the Generic Default Transition Time Client APIs. More...

Macros

#define | MS_generic_default_transition_time_set(param)
API to set the Generic Default Transition Time state of an element. More...
#define | MS_generic_default_transition_time_set_unacknowledged(param)
API to set the Generic Default Transition Time state of an element. More...
#define | MS_generic_default_transition_time_get()
API to get the Generic Default Transition Time state of an element. More...

Functions

API_RESULT | MS_generic_default_transition_time_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB appl_cb)
API to initialize Generic_Default_Transition_Time Client model. More...
API_RESULT | MS_generic_default_transition_time_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Default_Transition_Time client model handle. More...
API_RESULT | MS_generic_default_transition_time_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Default Transition Time Client APIs.

Macro Definition Documentation

#define MS_generic_default_transition_time_set ( param )
Value:
MS_generic_default_transition_time_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE\
)

API to set the Generic Default Transition Time state of an element.

Description
Generic Default Transition Time Set is an acknowledged message used to set the Generic Default Transition Time state of an element. The response to the Generic Default Transition Time Set message is a Generic Default Transition Time Status message.
Parameters
[in] param Transition Time
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 269 of file MS_generic_default_transition_time_api.h.

#define MS_generic_default_transition_time_set_unacknowledged ( param )
Value:
MS_generic_default_transition_time_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic Default Transition Time state of an element.

Description
Generic Default Transition Time Set Unacknowledged is an unacknowledged message used to set the Generic Default Transition Time state of an element.
Parameters
[in] param Transition Time
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 288 of file MS_generic_default_transition_time_api.h.

#define MS_generic_default_transition_time_get ( )
Value:
MS_generic_default_transition_time_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE\
)

API to get the Generic Default Transition Time state of an element.

Description
Generic Default Transition Time Get is an acknowledged message used to get the Generic Default Transition Time state of an element. The response to the Generic Default Transition Time Get message is a Generic Default Transition Time Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 308 of file MS_generic_default_transition_time_api.h.

Function Documentation

API_RESULT MS_generic_default_transition_time_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Default_Transition_Time Client model.

Description
This is to initialize Generic_Default_Transition_Time Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Default_Transition_Time Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_default_transition_time_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Default_Transition_Time client model handle.

Description
This is to get the handle of Generic_Default_Transition_Time client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_default_transition_time_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic Default Transition Time Server API Definitions

Functions
Generic Default Transition Time Server API Definitions
API Definitions

This section describes the Generic Default Transition Time Server APIs. More...

Functions

API_RESULT | MS_generic_default_transition_time_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB appl_cb)
API to initialize Generic_Default_Transition_Time Server model. More...
API_RESULT | MS_generic_default_transition_time_server_get_time (MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT *default_time)
API to get default transition time. More...

Detailed Description

This section describes the Generic Default Transition Time Server APIs.

Function Documentation

API_RESULT MS_generic_default_transition_time_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Default_Transition_Time Server model.

Description
This is to initialize Generic_Default_Transition_Time Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Default_Transition_Time Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_default_transition_time_server_get_time ( MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT * default_time )

API to get default transition time.

Description
This is to get default transition time.
Parameters
[out] default_time Default Transition Time.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_DEFAULT_TRANSITION_TIME (Mesh Generic Default Transition Time Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Default Transition Time Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Default Transition Time Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Default Transition Time Server application Asynchronous Notification Callback.

Generic Default Transition Time Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 53 of file MS_generic_default_transition_time_api.h.

typedef API_RESULT(* MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Default Transition Time Client application Asynchronous Notification Callback.

Generic Default Transition Time Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 74 of file MS_generic_default_transition_time_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_DEFAULT_TRANSITION_TIME (Mesh Generic Default Transition Time Model)

Data Structures

struct MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
The Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT Struct Reference

Data Fields
MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT Struct Reference
Structures

The Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state. More...

#include <MS_generic_default_transition_time_api.h>

Data Fields

UCHAR | transition_number_of_steps
The Default Transition Step Resolution field is a 2-bit bit field that determines the resolution of the Generic Default Transition Time state. More...
UCHAR | transition_step_resolution
The Default Transition Number of Steps field is a 6-bit value representing the number of transition steps. More...

Detailed Description

The Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state.

This is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.

This mechanism covers a wide range of times that may be required by different applications:

  • For 100 millisecond step resolution, the range is 0 through 6.2 seconds.
  • For 1 second step resolution, the range is 0 through 62 seconds.
  • For 10 seconds step resolution, the range is 0 through 620 seconds (10.5 minutes).
  • For 10 minutes step resolution, the range is 0 through 620 minutes (10.5 hours).

The Generic Default Transition Time is calculated using the following formula: Generic Default Transition Time = Default Transition Step Resolution * Default Transition Number of Steps

Definition at line 103 of file MS_generic_default_transition_time_api.h.

Field Documentation

UCHAR MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT::transition_number_of_steps

The Default Transition Step Resolution field is a 2-bit bit field that determines the resolution of the Generic Default Transition Time state.

Value | Description
0b00 | The Default Transition Step Resolution is 100 milliseconds
0b01 | The Default Transition Step Resolution is 1 second
0b10 | The Default Transition Step Resolution is 10 seconds
0b11 | The Default Transition Step Resolution is 10 minutes

Definition at line 116 of file MS_generic_default_transition_time_api.h.

UCHAR MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT::transition_step_resolution

The Default Transition Number of Steps field is a 6-bit value representing the number of transition steps.

Value | Description
0x00 | The Generic Default Transition Time is immediate.
0x01-0x3E | The number of steps.
0x3F | The value is unknown. The state cannot be set to this value,

| but an element may report an unknown value if a transition is higher than 0x3E | or not determined.

Definition at line 130 of file MS_generic_default_transition_time_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_default_transition_time_api.h


EtherMind Mesh SDK (beta): GENERIC_LEVEL (Mesh Generic Level Model)

Modules
GENERIC_LEVEL (Mesh Generic Level Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Level Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_LEVEL (Mesh Generic Level Model)

This section describes the EtherMind Mesh Generic Level Model APIs. More...

Modules

Generic Level Client API Definitions
This section describes the Generic Level Client APIs.
Generic Level Server API Definitions
This section describes the Generic Level Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Level Model APIs.


EtherMind Mesh SDK (beta): Generic Level Client API Definitions

Macros | Functions
Generic Level Client API Definitions
API Definitions

This section describes the Generic Level Client APIs. More...

Macros

#define | MS_generic_level_set(param)
API to set the Generic Level state of an element to a new absolute value. More...
#define | MS_generic_move_set(param)
API to start a process of changing the Generic Level state of an element with a defined transition speed. More...
#define | MS_generic_level_get()
API to get the Generic Level state of an element. More...
#define | MS_generic_delta_set(param)
API to set the Generic Level state of an element by a relative value. More...
#define | MS_generic_delta_set_unacknowledged(param)
API to set the Generic Level state of an element by a relative value. More...
#define | MS_generic_level_set_unacknowledged(param)
API to set the Generic Level state of an element to a new absolute value. More...
#define | MS_generic_move_set_unacknowledged(param)
API to start a process of changing the Generic Level state of an element with a defined transition speed. More...

Functions

API_RESULT | MS_generic_level_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LEVEL_CLIENT_CB appl_cb)
API to initialize Generic_Level Client model. More...
API_RESULT | MS_generic_level_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Level client model handle. More...
API_RESULT | MS_generic_level_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Level Client APIs.

Macro Definition Documentation

#define MS_generic_level_set ( param )
Value:
MS_generic_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LEVEL_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
)

API to set the Generic Level state of an element to a new absolute value.

Description
Generic Level Set is an acknowledged message used to set the Generic Level state of an element to a new absolute value. The response to the Generic Level Set message is a Generic Level Status message.
Parameters
[in] param Generic Level Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 358 of file MS_generic_level_api.h.

#define MS_generic_move_set ( param )
Value:
MS_generic_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_MOVE_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
)

API to start a process of changing the Generic Level state of an element with a defined transition speed.

Description
Generic Move Set is an acknowledged message used to start a process of changing the Generic Level state of an element with a defined transition speed. The response to the Generic Move Set message is a Generic Level Status message.
Parameters
[in] param Generic Move Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 379 of file MS_generic_level_api.h.

#define MS_generic_level_get ( )
Value:
MS_generic_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LEVEL_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
)

API to get the Generic Level state of an element.

Description
Generic Level Get is an acknowledged message used to get the Generic Level state of an element. The response to the Generic Level Get message is a Generic Level Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 397 of file MS_generic_level_api.h.

#define MS_generic_delta_set ( param )
Value:
MS_generic_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_DELTA_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
)

API to set the Generic Level state of an element by a relative value.

Description
Generic Delta Set is an acknowledged message used to set the Generic Level state of an element by a relative value. The message is transactional, it supports changing the state by a cumulative value with a sequence of messages that are part of a transaction. The response to the Generic Delta Set message is a Generic Level Status message.
Parameters
[in] param Generic Delta Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 418 of file MS_generic_level_api.h.

#define MS_generic_delta_set_unacknowledged ( param )
Value:
MS_generic_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_DELTA_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic Level state of an element by a relative value.

Description
Generic Delta Set Unacknowledged is an unacknowledged message used to set the Generic Level state of an element by a relative value.
Parameters
[in] param Generic Delta Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 437 of file MS_generic_level_api.h.

#define MS_generic_level_set_unacknowledged ( param )
Value:
MS_generic_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LEVEL_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic Level state of an element to a new absolute value.

Description
Generic Level Set Unacknowledged is an unacknowledged message used to set the Generic Level state of an element to a new absolute value.
Parameters
[in] param Generic Level Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 456 of file MS_generic_level_api.h.

#define MS_generic_move_set_unacknowledged ( param )
Value:
MS_generic_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_MOVE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to start a process of changing the Generic Level state of an element with a defined transition speed.

Description
Generic Move Set Unacknowledged is an unacknowledged message used to start a process of changing the Generic Level state of an element with a defined transition speed.
Parameters
[in] param Generic Move Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 476 of file MS_generic_level_api.h.

Function Documentation

API_RESULT MS_generic_level_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_LEVEL_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Level Client model.

Description
This is to initialize Generic_Level Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Level Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_level_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Level client model handle.

Description
This is to get the handle of Generic_Level client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_level_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic Level Server API Definitions

Functions
Generic Level Server API Definitions
API Definitions

This section describes the Generic Level Server APIs. More...

Functions

API_RESULT | MS_generic_level_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LEVEL_SERVER_CB appl_cb)
API to initialize Generic_Level Server model. More...
API_RESULT | MS_generic_level_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Generic Level Server APIs.

Function Documentation

API_RESULT MS_generic_level_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_LEVEL_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Level Server model.

Description
This is to initialize Generic_Level Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Level Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_level_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_LEVEL (Mesh Generic Level Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_LEVEL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Level Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_LEVEL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Level Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_LEVEL_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Level Server application Asynchronous Notification Callback.

Generic Level Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_generic_level_api.h.

typedef API_RESULT(* MS_GENERIC_LEVEL_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Level Client application Asynchronous Notification Callback.

Generic Level Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_generic_level_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_LEVEL (Mesh Generic Level Model)

Data Structures

struct | MS_GENERIC_LEVEL_SET_STRUCT
Generic Level Set message parameters. More...
struct | MS_GENERIC_LEVEL_STATUS_STRUCT
Generic Level Status message parameters. More...
struct | MS_GENERIC_DELTA_SET_STRUCT
Generic Delta Set message parameters. More...
struct | MS_GENERIC_MOVE_SET_STRUCT
Generic Move Set message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_LEVEL_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_LEVEL_SET_STRUCT Struct Reference
Structures

Generic Level Set message parameters. More...

#include <MS_generic_level_api.h>

Data Fields

UINT16 | level
The target value of the Generic Level state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Generic Level Set message parameters.

Definition at line 89 of file MS_generic_level_api.h.

Field Documentation

UINT16 MS_GENERIC_LEVEL_SET_STRUCT::level

The target value of the Generic Level state.

The Generic Level state is a 16-bit signed integer (2’s complement) representing the state of an element.

Definition at line 97 of file MS_generic_level_api.h.

UCHAR MS_GENERIC_LEVEL_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 113 of file MS_generic_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_LEVEL_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_LEVEL_STATUS_STRUCT Struct Reference
Structures

Generic Level Status message parameters. More...

#include <MS_generic_level_api.h>

Data Fields

UINT16 | present_level
The present value of the Generic Level state. More...
UINT16 | target_level
The target value of the Generic Level state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target Level and Remaining Time are valid.

Detailed Description

Generic Level Status message parameters.

Definition at line 126 of file MS_generic_level_api.h.

Field Documentation

UINT16 MS_GENERIC_LEVEL_STATUS_STRUCT::present_level

The present value of the Generic Level state.

Definition at line 129 of file MS_generic_level_api.h.

UCHAR MS_GENERIC_LEVEL_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 145 of file MS_generic_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_DELTA_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_DELTA_SET_STRUCT Struct Reference
Structures

Generic Delta Set message parameters. More...

#include <MS_generic_level_api.h>

Data Fields

UINT32 | delta_level
The Delta change of the Generic Level state.
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Generic Delta Set message parameters.

Definition at line 155 of file MS_generic_level_api.h.

Field Documentation

UCHAR MS_GENERIC_DELTA_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 174 of file MS_generic_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_MOVE_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_MOVE_SET_STRUCT Struct Reference
Structures

Generic Move Set message parameters. More...

#include <MS_generic_level_api.h>

Data Fields

UINT16 | delta_level
The Delta Level step to calculate Move speed for the Generic Level state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Generic Move Set message parameters.

Definition at line 187 of file MS_generic_level_api.h.

Field Documentation

UINT16 MS_GENERIC_MOVE_SET_STRUCT::delta_level

The Delta Level step to calculate Move speed for the Generic Level state.

Definition at line 190 of file MS_generic_level_api.h.

UCHAR MS_GENERIC_MOVE_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 206 of file MS_generic_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_level_api.h


EtherMind Mesh SDK (beta): GENERIC_LOCATION (Mesh Generic Location Model)

Modules
GENERIC_LOCATION (Mesh Generic Location Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Location Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_LOCATION (Mesh Generic Location Model)

This section describes the EtherMind Mesh Generic Location Model APIs. More...

Modules

Generic Location Client API Definitions
This section describes the Generic Location Client APIs.
Generic Location Server API Definitions
This section describes the Generic Location Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Location Model APIs.


EtherMind Mesh SDK (beta): Generic Location Client API Definitions

Macros | Functions
Generic Location Client API Definitions
API Definitions

This section describes the Generic Location Client APIs. More...

Macros

#define | MS_generic_location_global_set_unacknowledged(param)
API to set the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_local_get()
API to get the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_local_set(param)
API to set the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_global_set(param)
API to set the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_global_get()
API to get the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_local_set_unacknowledged(param)
API to set the selected fields of the Generic Location state of an element. More...

Functions

API_RESULT | MS_generic_location_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LOCATION_CLIENT_CB appl_cb)
API to initialize Generic_Location Client model. More...
API_RESULT | MS_generic_location_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Location client model handle. More...
API_RESULT | MS_generic_location_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Location Client APIs.

Macro Definition Documentation

#define MS_generic_location_global_set_unacknowledged ( param )
Value:
MS_generic_location_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the selected fields of the Generic Location state of an element.

Description
Generic Location Global Set Unacknowledged is an unacknowledged message used to set the selected fields of the Generic Location state of an element.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 410 of file MS_generic_location_api.h.

#define MS_generic_location_local_get ( )
Value:
MS_generic_location_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LOCATION_LOCAL_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE\
)

API to get the selected fields of the Generic Location state of an element.

Description
Generic Location Local Get message is an acknowledged message used to get the selected fields of the Generic Location state of an element. The response to the Generic Location Local Get message is a Generic Location Local Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 429 of file MS_generic_location_api.h.

#define MS_generic_location_local_set ( param )
Value:
MS_generic_location_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE\
)

API to set the selected fields of the Generic Location state of an element.

Description
Generic Location Local Set is an acknowledged message used to set the selected fields of the Generic Location state of an element. The response to the Generic Location Local Set message is a Generic Location Local Status message.
Parameters
[in] param Generic Location Local Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 449 of file MS_generic_location_api.h.

#define MS_generic_location_global_set ( param )
Value:
MS_generic_location_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE\
)

API to set the selected fields of the Generic Location state of an element.

Description
Generic Location Global Set is an acknowledged message used to set the selected fields of the Generic Location state of an element. The response to the Generic Location Global Set message is a Generic Location Global Status message.
Parameters
[in] param Generic Location Global Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 468 of file MS_generic_location_api.h.

#define MS_generic_location_global_get ( )
Value:
MS_generic_location_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LOCATION_GLOBAL_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE\
)

API to get the selected fields of the Generic Location state of an element.

Description
Generic Location Global Get message is an acknowledged message used to get the selected fields of the Generic Location state of an element. The response to the Generic Location Global Get message is a Generic Location Global Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 487 of file MS_generic_location_api.h.

#define MS_generic_location_local_set_unacknowledged ( param )
Value:
MS_generic_location_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the selected fields of the Generic Location state of an element.

Description
Generic Location Local Set Unacknowledged is an unacknowledged message used to set the selected fields of the Generic Location state of an element.
Parameters
[in] param Generic Location Local Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 506 of file MS_generic_location_api.h.

Function Documentation

API_RESULT MS_generic_location_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_LOCATION_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Location Client model.

Description
This is to initialize Generic_Location Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Location Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_location_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Location client model handle.

Description
This is to get the handle of Generic_Location client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_location_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic Location Server API Definitions

Functions
Generic Location Server API Definitions
API Definitions

This section describes the Generic Location Server APIs. More...

Functions

API_RESULT | MS_generic_location_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LOCATION_SERVER_CB appl_cb)
API to initialize Generic_Location Server model. More...
API_RESULT | MS_generic_location_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_location_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LOCATION_SETUP_SERVER_CB appl_cb)
API to initialize Generic_Location_Setup Server model. More...
API_RESULT | MS_generic_location_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Generic Location Server APIs.

Function Documentation

API_RESULT MS_generic_location_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_LOCATION_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Location Server model.

Description
This is to initialize Generic_Location Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Location Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_location_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_location_setup_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_LOCATION_SETUP_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Location_Setup Server model.

Description
This is to initialize Generic_Location_Setup Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Location_Setup Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_location_setup_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_LOCATION (Mesh Generic Location Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_LOCATION_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Location Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_LOCATION_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Location Client application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_LOCATION_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Location Setup Server application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_LOCATION_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Location Server application Asynchronous Notification Callback.

Generic Location Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_generic_location_api.h.

typedef API_RESULT(* MS_GENERIC_LOCATION_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Location Client application Asynchronous Notification Callback.

Generic Location Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_generic_location_api.h.

typedef API_RESULT(* MS_GENERIC_LOCATION_SETUP_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Location Setup Server application Asynchronous Notification Callback.

Generic Location Setup Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 93 of file MS_generic_location_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_LOCATION (Mesh Generic Location Model)

Data Structures

struct | MS_GENERIC_LOCATION_GLOBAL_STRUCT
Generic Location Global Set message parameters. More...
struct | MS_GENERIC_LOCATION_LOCAL_STRUCT
Generic Location Local Set message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_LOCATION_GLOBAL_STRUCT Struct Reference

Data Fields
MS_GENERIC_LOCATION_GLOBAL_STRUCT Struct Reference
Structures

Generic Location Global Set message parameters. More...

#include <MS_generic_location_api.h>

Data Fields

UINT32 | global_latitude
Global Coordinates (Latitude). More...
UINT32 | global_longitude
Global Coordinates (Longitude). More...
UINT16 | global_altitude
Global Altitude. More...

Detailed Description

Generic Location Global Set message parameters.

Definition at line 112 of file MS_generic_location_api.h.

Field Documentation

UINT32 MS_GENERIC_LOCATION_GLOBAL_STRUCT::global_latitude

Global Coordinates (Latitude).

The Global Latitude field describes the global WGS84 North coordinate of the element.

Definition at line 118 of file MS_generic_location_api.h.

UINT32 MS_GENERIC_LOCATION_GLOBAL_STRUCT::global_longitude

Global Coordinates (Longitude).

The Global Longitude field describes the global WGS84 East coordinate of the element.

Definition at line 124 of file MS_generic_location_api.h.

UINT16 MS_GENERIC_LOCATION_GLOBAL_STRUCT::global_altitude

Global Altitude.

The Global Altitude field determines the altitude of the device above the WGS84 datum. It expresses the altitude beyond the WGS84 ellipsoid of the element that exposed its position.

Value | Description
0x7FFF | Global Altitude is not configured.
0x7FFE | Global Altitude is greater than or equal to 32766 meters.
0x8000-0x7FFD | Global Altitude is (field value) from -32768 meters through 32765 meters.

Definition at line 137 of file MS_generic_location_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_location_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_LOCATION_LOCAL_STRUCT Struct Reference

Data Fields
MS_GENERIC_LOCATION_LOCAL_STRUCT Struct Reference
Structures

Generic Location Local Set message parameters. More...

#include <MS_generic_location_api.h>

Data Fields

UINT16 | local_north
Local Coordinates (North). More...
UINT16 | local_east
Local Coordinates (East). More...
UINT16 | local_altitude
Local Altitude. More...
UCHAR | floor_number
Floor Number. More...
UINT16 | uncertainty
Uncertainty. More...

Detailed Description

Generic Location Local Set message parameters.

Definition at line 144 of file MS_generic_location_api.h.

Field Documentation

UINT16 MS_GENERIC_LOCATION_LOCAL_STRUCT::local_north

Local Coordinates (North).

The Local North field describes the North coordinate of the device using a local coordinate system. It is relative to the north orientation on a predefined map.

The Local North value is encoded in decimeters and has a range of -32767 decimeters through 32767 decimeters. The value 0x8000 means the Local North information is not configured.

Definition at line 154 of file MS_generic_location_api.h.

UINT16 MS_GENERIC_LOCATION_LOCAL_STRUCT::local_east

Local Coordinates (East).

The Local East field describes the East coordinate of the device using a local coordinate system. It is relative to the east orientation of a predefined map.

The Local East value is encoded decimeters and it ranges from -32767 decimeters through 32767 decimeters. The value 0x8000 means the Local East information is not configured.

Definition at line 164 of file MS_generic_location_api.h.

UINT16 MS_GENERIC_LOCATION_LOCAL_STRUCT::local_altitude

Local Altitude.

The Local Altitude field determines the altitude of the device relative to the Generic Location Global Altitude.

Value | Description
0x7FFF | Local Altitude is not configured.
0x7FFE | Local Altitude is greater than or equal to 32766 meters.
0x8000-0x7FFD | Local Altitude is (field value) from -32768 meters through 32765 meters.

Definition at line 176 of file MS_generic_location_api.h.

UCHAR MS_GENERIC_LOCATION_LOCAL_STRUCT::floor_number

Floor Number.

The Floor Number field describes the floor number where the element is installed. The floor number, N, is encoded as X = N + 20, where X is the encoded floor number. Floor number = -20 (X=0) has a special meaning, indicating the floor -20, and also any floor below that. Floor number = 232 (X=252) has a special meaning, indicating the floor 232, and also any floor above that.

Encoded Value X | Floor number N
0x00 | Floor -20 or any floor below -20.
0x01-0xFB | Floor number N, encoded as X = N + 20.
0xFC | Floor 232 or any floor above 232.
0xFD | Ground floor. Floor 0.
0xFE | Ground floor. Floor 1.
0xFF | Not configured

Note: The reason for having two definitions of ground floor (0 or 1) is to allow for different conventions applicable in different countries.

Definition at line 198 of file MS_generic_location_api.h.

UINT16 MS_GENERIC_LOCATION_LOCAL_STRUCT::uncertainty

Uncertainty.

The Uncertainty field is a 16-bit bit field that describes the uncertainty of the location information the element exposes.

bits | Field | Description
0 | Stationary | This bit indicates whether the device broadcasting the location information

has a stationary location or is mobile. (0 = Stationary, 1 = Mobile) 1-7 | RFU | Reserved for Future Use 8-11 | Update Time | This value (x) is a 4-bit value ranging from 0 through 15. It represents the time (t) elapsed since the last update of the device's position, measured in seconds using the following formula: t=2^(x-3) The represented range is from 0.125 seconds through 4096 seconds. Note: If <stationary> is set, this value can be ignored. 12-15 | Precision | This value (y) is a 4-bit value ranging from 0 through 15. It represents a location precision with the formula: Precision = 2^(y-3) The represented range is from 0.125 meters through 4096 meters.

Definition at line 219 of file MS_generic_location_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_location_api.h


EtherMind Mesh SDK (beta): GENERIC_ONOFF (Mesh Generic Onoff Model)

Modules
GENERIC_ONOFF (Mesh Generic Onoff Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Onoff Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_ONOFF (Mesh Generic Onoff Model)

This section describes the EtherMind Mesh Generic Onoff Model APIs. More...

Modules

Generic Onoff Client API Definitions
This section describes the Generic Onoff Client APIs.
Generic Onoff Server API Definitions
This section describes the Generic Onoff Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Onoff Model APIs.


EtherMind Mesh SDK (beta): Generic Onoff Client API Definitions

Macros | Functions
Generic Onoff Client API Definitions
API Definitions

This section describes the Generic Onoff Client APIs. More...

Macros

#define | MS_generic_onoff_set_unacknowledged(param)
API to set Generic OnOff state unacknowledged. More...
#define | MS_generic_onoff_set(param)
API to set Generic OnOff state. More...
#define | MS_generic_onoff_get()
API to get Generic OnOff state. More...

Functions

API_RESULT | MS_generic_onoff_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_ONOFF_CLIENT_CB appl_cb)
API to initialize Generic_Onoff Client model. More...
API_RESULT | MS_generic_onoff_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Onoff client model handle. More...
API_RESULT | MS_generic_onoff_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Onoff Client APIs.

Macro Definition Documentation

#define MS_generic_onoff_set_unacknowledged ( param )
Value:
MS_generic_onoff_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ONOFF_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set Generic OnOff state unacknowledged.

Description
The Generic OnOff Set is an unacknowledged message used to get the Generic OnOff state of an element.
Parameters
[in] param Pointer to the structure populated as in GENERIC_ONOFF_SET_UNACKED_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 289 of file MS_generic_onoff_api.h.

#define MS_generic_onoff_set ( param )
Value:
MS_generic_onoff_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ONOFF_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE\
)

API to set Generic OnOff state.

Description
The Generic OnOff Set is an acknowledged message used to get the Generic OnOff state of an element.
Parameters
[in] param Pointer to the structure populated as in GENERIC_ONOFF_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 309 of file MS_generic_onoff_api.h.

#define MS_generic_onoff_get ( )
Value:
MS_generic_onoff_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ONOFF_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE\
)

API to get Generic OnOff state.

Description
The Generic OnOff Get is an acknowledged message used to get the Generic OnOff state of an element.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 326 of file MS_generic_onoff_api.h.

Function Documentation

API_RESULT MS_generic_onoff_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_ONOFF_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Onoff Client model.

Description
This is to initialize Generic_Onoff Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Onoff Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_onoff_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Onoff client model handle.

Description
This is to get the handle of Generic_Onoff client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_onoff_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic Onoff Server API Definitions

Functions
Generic Onoff Server API Definitions
API Definitions

This section describes the Generic Onoff Server APIs. More...

Functions

API_RESULT | MS_generic_onoff_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_ONOFF_SERVER_CB appl_cb)
API to initialize Generic_Onoff Server model. More...
API_RESULT | MS_generic_onoff_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Generic Onoff Server APIs.

Function Documentation

API_RESULT MS_generic_onoff_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_ONOFF_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Onoff Server model.

Description
This is to initialize Generic_Onoff Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Onoff Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_onoff_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_ONOFF (Mesh Generic Onoff Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_ONOFF_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Onoff Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_ONOFF_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Onoff Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_ONOFF_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Onoff Server application Asynchronous Notification Callback.

Generic Onoff Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_generic_onoff_api.h.

typedef API_RESULT(* MS_GENERIC_ONOFF_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Onoff Client application Asynchronous Notification Callback.

Generic Onoff Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_generic_onoff_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_ONOFF (Mesh Generic Onoff Model)

Data Structures

struct | MS_GENERIC_ONOFF_SET_STRUCT
Generic OnOff Set message parameters. More...
struct | MS_GENERIC_ONOFF_STATUS_STRUCT
Generic OnOff Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_ONOFF_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_ONOFF_SET_STRUCT Struct Reference
Structures

Generic OnOff Set message parameters. More...

#include <MS_generic_onoff_api.h>

Data Fields

UCHAR | onoff
The target value of the Generic OnOff state.
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Generic OnOff Set message parameters.

Definition at line 89 of file MS_generic_onoff_api.h.

Field Documentation

UCHAR MS_GENERIC_ONOFF_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 108 of file MS_generic_onoff_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_onoff_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_ONOFF_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_ONOFF_STATUS_STRUCT Struct Reference
Structures

Generic OnOff Status message parameters. More...

#include <MS_generic_onoff_api.h>

Data Fields

UCHAR | present_onoff
The present value of the Generic OnOff state. More...
UCHAR | target_onoff
The target value of the Generic OnOff state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target OnOff and Remaining Time are valid.

Detailed Description

Generic OnOff Status message parameters.

Definition at line 121 of file MS_generic_onoff_api.h.

Field Documentation

UCHAR MS_GENERIC_ONOFF_STATUS_STRUCT::present_onoff

The present value of the Generic OnOff state.

Definition at line 124 of file MS_generic_onoff_api.h.

UCHAR MS_GENERIC_ONOFF_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 140 of file MS_generic_onoff_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_onoff_api.h


EtherMind Mesh SDK (beta): GENERIC_POWER_LEVEL (Mesh Generic Power Level Model)

Modules
GENERIC_POWER_LEVEL (Mesh Generic Power Level Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Power Level Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_POWER_LEVEL (Mesh Generic Power Level Model)

This section describes the EtherMind Mesh Generic Power Level Model APIs. More...

Modules

Generic Power Level Client API Definitions
This section describes the Generic Power Level Client APIs.
Generic Power Level Server API Definitions
This section describes the Generic Power Level Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Power Level Model APIs.


EtherMind Mesh SDK (beta): Generic Power Level Client API Definitions

Macros | Functions
Generic Power Level Client API Definitions
API Definitions

This section describes the Generic Power Level Client APIs. More...

Macros

#define | MS_generic_power_range_set(param)
API to set the Generic Power Range state of an element. More...
#define | MS_generic_power_level_set(param)
API to set the Generic Power Actual state of an element. More...
#define | MS_generic_power_default_set(param)
API to set the Generic Power Default state of an element. More...
#define | MS_generic_power_level_get()
API to get the Generic Power Actual state of an element. More...
#define | MS_generic_power_default_get()
API to get the Generic Power Default state of an element. More...
#define | MS_generic_power_last_get()
API to get the Generic Power Last state of an element. More...
#define | MS_generic_power_range_get()
API to get the Generic Power Range state of an element. More...
#define | MS_generic_power_default_set_unacknowledged(param)
API to set the Generic Power Default state of an element. More...
#define | MS_generic_power_level_set_unacknowledged(param)
API to set the Generic Power Actual state of an element. More...
#define | MS_generic_power_range_set_unacknowledged(param)
API to set the Generic Power Range state of an element. More...

Functions

API_RESULT | MS_generic_power_level_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_LEVEL_CLIENT_CB appl_cb)
API to initialize Generic_Power_Level Client model. More...
API_RESULT | MS_generic_power_level_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Power_Level client model handle. More...
API_RESULT | MS_generic_power_level_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Power Level Client APIs.

Macro Definition Documentation

#define MS_generic_power_range_set ( param )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_RANGE_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE\
)

API to set the Generic Power Range state of an element.

Description
Generic Power Range Set is an acknowledged message used to set the Generic Power Range state of an element. The response to the Generic Power Range Set message is a Generic Power Range Status message.
Parameters
[in] param Generic Power Range Set message`
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 416 of file MS_generic_power_level_api.h.

#define MS_generic_power_level_set ( param )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_LEVEL_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE\
)

API to set the Generic Power Actual state of an element.

Description
Generic Power Level Set is an acknowledged message used to set the Generic Power Actual state of an element. The response to the Generic Power Level Set message is a Generic Power Level Status message.
Parameters
[in] param Generic Power Level Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 435 of file MS_generic_power_level_api.h.

#define MS_generic_power_default_set ( param )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_DEFAULT_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE\
)

API to set the Generic Power Default state of an element.

Description
Generic Power Default Set is an acknowledged message used to set the Generic Power Default state of an element. The response to the Generic Power Default Set message is a Generic Power Default Status message.
Parameters
[in] param Generic Power Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 454 of file MS_generic_power_level_api.h.

#define MS_generic_power_level_get ( )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_LEVEL_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE\
)

API to get the Generic Power Actual state of an element.

Description
Generic Power Level Get message is an acknowledged message used to get the Generic Power Actual state of an element. The response to the Generic Power Level Get message is a Generic Power Level Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 472 of file MS_generic_power_level_api.h.

#define MS_generic_power_default_get ( )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_DEFAULT_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE\
)

API to get the Generic Power Default state of an element.

Description
Generic Power Default Get is an acknowledged message used to get the Generic Power Default state of an element. The response to a Generic Power Default Get message is a Generic Power Default Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 490 of file MS_generic_power_level_api.h.

#define MS_generic_power_last_get ( )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_LAST_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_POWER_LAST_STATUS_OPCODE\
)

API to get the Generic Power Last state of an element.

Description
Generic Power Last Get is an acknowledged message used to get the Generic Power Last state of an element. The response to a Generic Power Last Get message is a Generic Power Last Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 508 of file MS_generic_power_level_api.h.

#define MS_generic_power_range_get ( )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_RANGE_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE\
)

API to get the Generic Power Range state of an element.

Description
Generic Power Range Get is an acknowledged message used to get the Generic Power Range state of an element. The response to the Generic Power Range Get message is a Generic Power Range Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 526 of file MS_generic_power_level_api.h.

#define MS_generic_power_default_set_unacknowledged ( param )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic Power Default state of an element.

Description
Generic Power Default Set Unacknowledged is an unacknowledged message used to set the Generic Power Default state of an element.
Parameters
[in] param Generic Power Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 545 of file MS_generic_power_level_api.h.

#define MS_generic_power_level_set_unacknowledged ( param )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_LEVEL_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic Power Actual state of an element.

Description
Generic Power Level Set Unacknowledged is an unacknowledged message used to set the Generic Power Actual state of an element.
Parameters
[in] param Generic Power Level Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 564 of file MS_generic_power_level_api.h.

#define MS_generic_power_range_set_unacknowledged ( param )
Value:
MS_generic_power_level_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_POWER_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic Power Range state of an element.

Description
Generic Power Range Set Unacknowledged is an unacknowledged message used to set the Generic Power Range state of an element.
Parameters
[in] param Generic Power Range Set message`
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 583 of file MS_generic_power_level_api.h.

Function Documentation

API_RESULT MS_generic_power_level_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_POWER_LEVEL_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Power_Level Client model.

Description
This is to initialize Generic_Power_Level Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Power_Level Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_level_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Power_Level client model handle.

Description
This is to get the handle of Generic_Power_Level client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_level_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic Power Level Server API Definitions

Functions
Generic Power Level Server API Definitions
API Definitions

This section describes the Generic Power Level Server APIs. More...

Functions

API_RESULT | MS_generic_power_level_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_LEVEL_SERVER_CB appl_cb)
API to initialize Generic_Power_Level Server model. More...
API_RESULT | MS_generic_power_level_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_power_level_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB appl_cb)
API to initialize Generic_Power_Level_Setup Server model. More...
API_RESULT | MS_generic_power_level_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Generic Power Level Server APIs.

Function Documentation

API_RESULT MS_generic_power_level_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_POWER_LEVEL_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Power_Level Server model.

Description
This is to initialize Generic_Power_Level Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Power_Level Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_level_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_level_setup_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Power_Level_Setup Server model.

Description
This is to initialize Generic_Power_Level_Setup Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Power_Level_Setup Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_level_setup_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_POWER_LEVEL (Mesh Generic Power Level Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_POWER_LEVEL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Level Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_LEVEL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Power Level Client application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Level Setup Server application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_POWER_LEVEL_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Power Level Server application Asynchronous Notification Callback.

Generic Power Level Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_generic_power_level_api.h.

typedef API_RESULT(* MS_GENERIC_POWER_LEVEL_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Power Level Client application Asynchronous Notification Callback.

Generic Power Level Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_generic_power_level_api.h.

typedef API_RESULT(* MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Power Level Setup Server application Asynchronous Notification Callback.

Generic Power Level Setup Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 93 of file MS_generic_power_level_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_POWER_LEVEL (Mesh Generic Power Level Model)

Data Structures

struct | MS_GENERIC_POWER_LEVEL_SET_STRUCT
Generic Power Level Set message parameters. More...
struct | MS_GENERIC_POWER_LEVEL_STATUS_STRUCT
Generic Power Level Status message parameters. More...
struct | MS_GENERIC_POWER_LAST_STATUS_STRUCT
Generic Power Last Status message parameters. More...
struct | MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT
Generic Power Default Status message parameters. More...
struct | MS_GENERIC_POWER_RANGE_STATUS_STRUCT
Generic Power Range Status message parameters. More...
struct | MS_GENERIC_POWER_DEFAULT_SET_STRUCT
Generic Power Default Status message parameters. More...
struct | MS_GENERIC_POWER_RANGE_SET_STRUCT
Generic Power Range Set message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_POWER_LEVEL_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_POWER_LEVEL_SET_STRUCT Struct Reference
Structures

Generic Power Level Set message parameters. More...

#include <MS_generic_power_level_api.h>

Data Fields

UINT16 | power
The target value of the Generic Power Actual state.
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Generic Power Level Set message parameters.

Definition at line 111 of file MS_generic_power_level_api.h.

Field Documentation

UCHAR MS_GENERIC_POWER_LEVEL_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 130 of file MS_generic_power_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_POWER_LEVEL_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_POWER_LEVEL_STATUS_STRUCT Struct Reference
Structures

Generic Power Level Status message parameters. More...

#include <MS_generic_power_level_api.h>

Data Fields

UINT16 | present_power
The present value of the Generic Power Actual state. More...
UINT16 | target_power
The target value of the Generic Power Actual state. More...
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target Power and Remaining Time are valid.

Detailed Description

Generic Power Level Status message parameters.

Definition at line 143 of file MS_generic_power_level_api.h.

Field Documentation

UINT16 MS_GENERIC_POWER_LEVEL_STATUS_STRUCT::present_power

The present value of the Generic Power Actual state.

Definition at line 146 of file MS_generic_power_level_api.h.

UINT16 MS_GENERIC_POWER_LEVEL_STATUS_STRUCT::target_power

The target value of the Generic Power Actual state.

Definition at line 149 of file MS_generic_power_level_api.h.

UCHAR MS_GENERIC_POWER_LEVEL_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 162 of file MS_generic_power_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_POWER_LAST_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_POWER_LAST_STATUS_STRUCT Struct Reference
Structures

Generic Power Last Status message parameters. More...

#include <MS_generic_power_level_api.h>

Data Fields

UINT16 power
The value of the Generic Power Last state. More...

Detailed Description

Generic Power Last Status message parameters.

Definition at line 172 of file MS_generic_power_level_api.h.

Field Documentation

UINT16 MS_GENERIC_POWER_LAST_STATUS_STRUCT::power

The value of the Generic Power Last state.

Definition at line 175 of file MS_generic_power_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT Struct Reference
Structures

Generic Power Default Status message parameters. More...

#include <MS_generic_power_level_api.h>

Data Fields

UINT16 power
The value of the Generic Power Default state. More...

Detailed Description

Generic Power Default Status message parameters.

Definition at line 182 of file MS_generic_power_level_api.h.

Field Documentation

UINT16 MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT::power

The value of the Generic Power Default state.

Definition at line 185 of file MS_generic_power_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_POWER_RANGE_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_POWER_RANGE_STATUS_STRUCT Struct Reference
Structures

Generic Power Range Status message parameters. More...

#include <MS_generic_power_level_api.h>

Data Fields

UCHAR | status
Status Code for the requesting message. More...
UINT16 | range_min
The value of the Generic Power Range Min field of the Generic Power Range state. More...
UINT16 | range_max
The value of the Generic Power Range Max field of the Generic Power Range state. More...

Detailed Description

Generic Power Range Status message parameters.

Definition at line 192 of file MS_generic_power_level_api.h.

Field Documentation

UCHAR MS_GENERIC_POWER_RANGE_STATUS_STRUCT::status

Status Code for the requesting message.

Definition at line 195 of file MS_generic_power_level_api.h.

UINT16 MS_GENERIC_POWER_RANGE_STATUS_STRUCT::range_min

The value of the Generic Power Range Min field of the Generic Power Range state.

Definition at line 198 of file MS_generic_power_level_api.h.

UINT16 MS_GENERIC_POWER_RANGE_STATUS_STRUCT::range_max

The value of the Generic Power Range Max field of the Generic Power Range state.

Definition at line 201 of file MS_generic_power_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_POWER_DEFAULT_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_POWER_DEFAULT_SET_STRUCT Struct Reference
Structures

Generic Power Default Status message parameters. More...

#include <MS_generic_power_level_api.h>

Data Fields

UINT16 power
The value of the Generic Power Default state. More...

Detailed Description

Generic Power Default Status message parameters.

Definition at line 208 of file MS_generic_power_level_api.h.

Field Documentation

UINT16 MS_GENERIC_POWER_DEFAULT_SET_STRUCT::power

The value of the Generic Power Default state.

Definition at line 211 of file MS_generic_power_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_level_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_POWER_RANGE_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_POWER_RANGE_SET_STRUCT Struct Reference
Structures

Generic Power Range Set message parameters. More...

#include <MS_generic_power_level_api.h>

Data Fields

UINT16 | range_min
The value of the Generic Power Min field of the Generic Power Range state. More...
UINT16 | range_max
The value of the Generic Power Range Max field of the Generic Power Range state. More...

Detailed Description

Generic Power Range Set message parameters.

Definition at line 218 of file MS_generic_power_level_api.h.

Field Documentation

UINT16 MS_GENERIC_POWER_RANGE_SET_STRUCT::range_min

The value of the Generic Power Min field of the Generic Power Range state.

Definition at line 221 of file MS_generic_power_level_api.h.

UINT16 MS_GENERIC_POWER_RANGE_SET_STRUCT::range_max

The value of the Generic Power Range Max field of the Generic Power Range state.

Definition at line 224 of file MS_generic_power_level_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_level_api.h


EtherMind Mesh SDK (beta): GENERIC_POWER_ONOFF (Mesh Generic Power Onoff Model)

Modules
GENERIC_POWER_ONOFF (Mesh Generic Power Onoff Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Power Onoff Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_POWER_ONOFF (Mesh Generic Power Onoff Model)

This section describes the EtherMind Mesh Generic Power Onoff Model APIs. More...

Modules

Generic Power Onoff Client API Definitions
This section describes the Generic Power Onoff Client APIs.
Generic Power Onoff Server API Definitions
This section describes the Generic Power Onoff Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Power Onoff Model APIs.


EtherMind Mesh SDK (beta): Generic Power Onoff Client API Definitions

Macros | Functions
Generic Power Onoff Client API Definitions
API Definitions

This section describes the Generic Power Onoff Client APIs. More...

Macros

#define | MS_generic_onpowerup_set(param)
API to set the Generic OnPowerUp state of an element. More...
#define | MS_generic_onpowerup_set_unacknowledged(param)
API to set the Generic OnPowerUp state of an element. More...
#define | MS_generic_onpowerup_get()
API to get the Generic OnPowerUp state of an element. More...

Functions

API_RESULT | MS_generic_power_onoff_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_ONOFF_CLIENT_CB appl_cb)
API to initialize Generic_Power_Onoff Client model. More...
API_RESULT | MS_generic_power_onoff_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Power_Onoff client model handle. More...
API_RESULT | MS_generic_power_onoff_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Power Onoff Client APIs.

Macro Definition Documentation

#define MS_generic_onpowerup_set ( param )
Value:
MS_generic_power_onoff_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ONPOWERUP_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE\
)

API to set the Generic OnPowerUp state of an element.

Description
Generic OnPowerUp Set is an acknowledged message used to set the Generic OnPowerUp state of an element. The response to the Generic OnPowerUp Set message is a Generic OnPowerUp Status message.
Parameters
[in] param Generic OnPowerUp Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 317 of file MS_generic_power_onoff_api.h.

#define MS_generic_onpowerup_set_unacknowledged ( param )
Value:
MS_generic_power_onoff_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ONPOWERUP_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic OnPowerUp state of an element.

Description
Generic OnPowerUp Set Unacknowledged is an unacknowledged message used to set the Generic OnPowerUp state of an element.
Parameters
[in] param Generic OnPowerUp Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 336 of file MS_generic_power_onoff_api.h.

#define MS_generic_onpowerup_get ( )
Value:
MS_generic_power_onoff_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ONPOWERUP_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE\
)

API to get the Generic OnPowerUp state of an element.

Description
Generic OnPowerUp Get is an acknowledged message used to get the Generic OnPowerUp state of an element. The response to the Generic OnPowerUp Get message is a Generic OnPowerUp Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 354 of file MS_generic_power_onoff_api.h.

Function Documentation

API_RESULT MS_generic_power_onoff_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_POWER_ONOFF_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Power_Onoff Client model.

Description
This is to initialize Generic_Power_Onoff Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Power_Onoff Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_onoff_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Power_Onoff client model handle.

Description
This is to get the handle of Generic_Power_Onoff client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_onoff_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic Power Onoff Server API Definitions

Functions
Generic Power Onoff Server API Definitions
API Definitions

This section describes the Generic Power Onoff Server APIs. More...

Functions

API_RESULT | MS_generic_power_onoff_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_ONOFF_SERVER_CB appl_cb)
API to initialize Generic_Power_Onoff Server model. More...
API_RESULT | MS_generic_power_onoff_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_power_onoff_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB appl_cb)
API to initialize Generic_Power_Onoff_Setup Server model. More...
API_RESULT | MS_generic_power_onoff_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Generic Power Onoff Server APIs.

Function Documentation

API_RESULT MS_generic_power_onoff_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_POWER_ONOFF_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Power_Onoff Server model.

Description
This is to initialize Generic_Power_Onoff Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Power_Onoff Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_onoff_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_onoff_setup_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Power_Onoff_Setup Server model.

Description
This is to initialize Generic_Power_Onoff_Setup Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Power_Onoff_Setup Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_power_onoff_setup_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_POWER_ONOFF (Mesh Generic Power Onoff Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_POWER_ONOFF_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Onoff Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_ONOFF_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Power Onoff Client application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Onoff Setup Server application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_POWER_ONOFF_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Power Onoff Server application Asynchronous Notification Callback.

Generic Power Onoff Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_generic_power_onoff_api.h.

typedef API_RESULT(* MS_GENERIC_POWER_ONOFF_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Power Onoff Client application Asynchronous Notification Callback.

Generic Power Onoff Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_generic_power_onoff_api.h.

typedef API_RESULT(* MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Power Onoff Setup Server application Asynchronous Notification Callback.

Generic Power Onoff Setup Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 93 of file MS_generic_power_onoff_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_POWER_ONOFF (Mesh Generic Power Onoff Model)

Data Structures

struct MS_GENERIC_ONPOWERUP_STRUCT
Generic OnPowerUp Set message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_ONPOWERUP_STRUCT Struct Reference

Data Fields
MS_GENERIC_ONPOWERUP_STRUCT Struct Reference
Structures

Generic OnPowerUp Set message parameters. More...

#include <MS_generic_power_onoff_api.h>

Data Fields

UCHAR onpowerup
The Generic OnPowerUp state is an enumeration representing the behavior of an element when powered up. More...

Detailed Description

Generic OnPowerUp Set message parameters.

Definition at line 111 of file MS_generic_power_onoff_api.h.

Field Documentation

UCHAR MS_GENERIC_ONPOWERUP_STRUCT::onpowerup

The Generic OnPowerUp state is an enumeration representing the behavior of an element when powered up.

Value | Description
0x00 | Off. After being powered up, the element is in an off state.
0x01 | Default. After being powered up, the element is in an On state and uses default state values.
0x02 | Restore. If a transition was in progress when powered down, the element restores the target

state when powered up. Otherwise the element restores the state it was in when powered down. 0x03-0xFF | Prohibited

Definition at line 124 of file MS_generic_power_onoff_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_power_onoff_api.h


EtherMind Mesh SDK (beta): GENERIC_PROPERTY (Mesh Generic Property Model)

Modules | Macros
GENERIC_PROPERTY (Mesh Generic Property Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic Property Model (GENERIC_PROPERTY) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Generic Property Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Macros

#define | MS_GENERIC_PROP_TYPE_MANUFACTURER 0x00
Generic Manufacturer Properties.
#define | MS_GENERIC_PROP_TYPE_ADMIN 0x01
Generic Admin Properties.
#define | MS_GENERIC_PROP_TYPE_USER 0x02
Generic User Properties.
#define | MS_GENERIC_USER_ACCESS_PROHIBITED 0x00
User Access field values.
#define | MS_GENERIC_USER_ACCESS_READ 0x01
#define | MS_GENERIC_USER_ACCESS_WRITE 0x02
#define | MS_GENERIC_USER_ACCESS_READ_WRITE 0x03
#define | MS_GENERIC_USER_ACCESS_INVALID_PROPERTY_ID 0xFF
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_OCCUPANCY_DELAY 0x003A
Device Property - Light Control Time Occupancy Delay.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_ON 0x0037
Device Property - Light Control Time Fade On.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_RUN_ON 0x003C
Device Property - Light Control Time Run On.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE 0x0036
Device Property - Light Control Time Fade.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_PROLONG 0x003B
Device Property - Light Control Time Prolong.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_AUTO 0x0038
Device Property - Light Control Time Fade Standby Auto.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_MANUAL 0x0039
Device Property - Light Control Time Fade Standby Manual.
#define | MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_ON 0x002E
Device Property - Light Control Lightness On.
#define | MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_PROLONG 0x002F
Device Property - Light Control Lightness Prolong.
#define | MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_STANDBY 0x0030
Device Property - Light Control Lightness Standby.
#define | MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_ON 0x002B
Device Property - Light Control Ambient LuxLevel On.
#define | MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_PROLONG 0x002C
Device Property - Light Control Ambient LuxLevel Prolong.
#define | MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_STANDBY 0x002D
Device Property - Light Control Ambient LuxLevel Standby.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KIU 0x0033
Device Property - Light Control Regulator Kiu.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KID 0x0032
Device Property - Light Control Regulator Kid.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPU 0x0035
Device Property - Light Control Regulator Kpu.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPD 0x0034
Device Property - Light Control Regulator Kpd.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_ACCURACY 0x0031
Device Property - Light Control Regulator Accuracy.
#define | MS_DEV_PROP_MOTION_SENSED 0x0042
Device Property - Motion Sensed.
#define | MS_DEV_PROP_TIME_SINCE_MOTION_SENSED 0x0068
Device Property - Time Since Motion Sensed.
#define | MS_DEV_PROP_PEOPLE_COUNT 0x004C
Device Property - People Count.
#define | MS_DEV_PROP_PRESENCE_DETECTED 0x004D
Device Property - Presence Detected.
#define | MS_DEV_PROP_PRESENT_AMBIENT_LIGHT_LEVEL 0x004E
Device Property - Present Ambient Light Level.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic Property Model (GENERIC_PROPERTY) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
GENERIC_PROPERTY (Mesh Generic Property Model)

This section describes the EtherMind Mesh Generic Property Model APIs. More...

Modules

Generic Property Client API Definitions
This section describes the Generic Property Client APIs.
Generic User Property Server API Definitions
This section describes the Generic User Property Server APIs.

Detailed Description

This section describes the EtherMind Mesh Generic Property Model APIs.


EtherMind Mesh SDK (beta): Generic Property Client API Definitions

Macros | Functions
Generic Property Client API Definitions
API Definitions

This section describes the Generic Property Client APIs. More...

Macros

#define | MS_generic_admin_properties_get()
API to get the list of Generic Admin Property states of an element. More...
#define | MS_generic_admin_property_set(param)
API to set the Generic Admin Property state of an element. More...
#define | MS_generic_user_property_set(param)
API to set the Generic User Property state of an element. More...
#define | MS_generic_client_properties_get(param)
API to get the list of Generic Client Property states of an element. More...
#define | MS_generic_manufacturer_property_get(param)
API to get the Generic Manufacturer Property state of an element. More...
#define | MS_generic_user_property_set_unacknowledged(param)
API to set the Generic User Property state of an element. More...
#define | MS_generic_manufacturer_property_set(param)
API to the Generic Manufacturer Property User Access state of an element. More...
#define | MS_generic_admin_property_set_unacknowledged(param)
API to set the Generic Admin Property state of an element. More...
#define | MS_generic_manufacturer_properties_get()
API to get the list of Generic Manufacturer Property states of an element. More...
#define | MS_generic_user_property_get(param)
API to get the Generic User Property state of an element. More...
#define | MS_generic_admin_property_get(param)
API to get the Generic Admin Property state of an element. More...
#define | MS_generic_manufacturer_property_set_unacknowledged(param)
API to the Generic Manufacturer Property User Access state of an element. More...
#define | MS_generic_user_properties_get()
API to get the list of Generic User Property states of an element. More...

Functions

API_RESULT | MS_generic_property_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_CLIENT_CB appl_cb)
API to initialize Generic_Property Client model. More...
API_RESULT | MS_generic_property_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Property client model handle. More...
API_RESULT | MS_generic_property_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Generic Property Client APIs.

Macro Definition Documentation

#define MS_generic_admin_properties_get ( )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ADMIN_PROPERTIES_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_ADMIN_PROPERTIES_STATUS_OPCODE\
)

API to get the list of Generic Admin Property states of an element.

Description
Generic Admin Properties Get is an acknowledged message used to get the list of Generic Admin Property states of an element. The response to the Generic Admin Properties Get message is a Generic Admin Properties Status message. The message has no parameters.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 668 of file MS_generic_property_api.h.

#define MS_generic_admin_property_set ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE\
)

API to set the Generic Admin Property state of an element.

Description
Generic Admin Property Set is an acknowledged message used to set the Generic Admin Property state of an element. The response to the Generic Admin Property Set message is a Generic Admin Property Status message.
Parameters
[in] param Generic Admin Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 687 of file MS_generic_property_api.h.

#define MS_generic_user_property_set ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_USER_PROPERTY_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE\
)

API to set the Generic User Property state of an element.

Description
Generic User Property Set is an acknowledged message used to set the Generic User Property state of an element. The response to the Generic User Property Set message is a Generic User Property Status message.
Parameters
[in] param Generic User Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 706 of file MS_generic_property_api.h.

#define MS_generic_client_properties_get ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_CLIENT_PROPERTIES_GET_OPCODE,\
param,\
MS_ACCESS_GENERIC_CLIENT_PROPERTIES_STATUS_OPCODE\
)

API to get the list of Generic Client Property states of an element.

Description
Generic Client Properties Get is an acknowledged message used to get the list of Generic Client Property states of an element. The response to the Generic Client Properties Get message is a Generic Client Properties Status message.
Parameters
[in] param Generic Client Properties Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 725 of file MS_generic_property_api.h.

#define MS_generic_manufacturer_property_get ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_GET_OPCODE,\
param,\
MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE\
)

API to get the Generic Manufacturer Property state of an element.

Description
Generic Manufacturer Property Get is an acknowledged message used to get the Generic Manufacturer Property state of an element. The response to the Generic Manufacturer Property Get message is a Generic Manufacturer Property Status message.
Parameters
[in] param Generic Manufacturer Property Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 744 of file MS_generic_property_api.h.

#define MS_generic_user_property_set_unacknowledged ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_USER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic User Property state of an element.

Description
Generic User Property Set Unacknowledged is an unacknowledged message used to set the Generic User Property state of an element.
Parameters
[in] param Generic User Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 763 of file MS_generic_property_api.h.

#define MS_generic_manufacturer_property_set ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_OPCODE,\
param,\
MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE\
)

API to the Generic Manufacturer Property User Access state of an element.

Description
Generic Manufacturer Property Set is an acknowledged message used to set the Generic Manufacturer Property User Access state of an element. The response to the Generic Manufacturer Property Set message is a Generic Manufacturer Property Status message.
Parameters
[in] param Generic Manufacturer Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 782 of file MS_generic_property_api.h.

#define MS_generic_admin_property_set_unacknowledged ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Generic Admin Property state of an element.

Description
Generic Admin Property Set Unacknowledged is an unacknowledged message used to set the Generic Admin Property state of an element.
Parameters
[in] param Generic Admin Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 801 of file MS_generic_property_api.h.

#define MS_generic_manufacturer_properties_get ( )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_OPCODE\
)

API to get the list of Generic Manufacturer Property states of an element.

Description
Generic Manufacturer Properties Get is an acknowledged message used to get the list of Generic Manufacturer Property states of an element. The response to the Generic Manufacturer Properties Get message is a Generic Manufacturer Properties Status message. The message has no parameters.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 821 of file MS_generic_property_api.h.

#define MS_generic_user_property_get ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_USER_PROPERTY_GET_OPCODE,\
param,\
MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE\
)

API to get the Generic User Property state of an element.

Description
Generic User Property Get is an acknowledged message used to get the Generic User Property state of an element. The response to the Generic User Property Get message is a Generic User Property Status message.
Parameters
[in] param Generic User Property Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 840 of file MS_generic_property_api.h.

#define MS_generic_admin_property_get ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_ADMIN_PROPERTY_GET_OPCODE,\
param,\
MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE\
)

API to get the Generic Admin Property state of an element.

Description
Generic Admin Property Get is an acknowledged message used to get the Generic Admin Property state of an element. The response to the Generic Admin Property Get message is a Generic Admin Property Status message.
Parameters
[in] param Generic Admin Property Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 859 of file MS_generic_property_api.h.

#define MS_generic_manufacturer_property_set_unacknowledged ( param )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to the Generic Manufacturer Property User Access state of an element.

Description
The Generic Manufacturer Property Set Unacknowledged is an unacknowledged message used to set the Generic Manufacturer Property User Access state of an element.
Parameters
[in] param Generic Manufacturer Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 877 of file MS_generic_property_api.h.

#define MS_generic_user_properties_get ( )
Value:
MS_generic_property_client_send_reliable_pdu \
(\
MS_ACCESS_GENERIC_USER_PROPERTIES_GET_OPCODE,\
NULL,\
MS_ACCESS_GENERIC_USER_PROPERTIES_STATUS_OPCODE\
)

API to get the list of Generic User Property states of an element.

Description
Generic User Properties Get is an acknowledged message used to get the list of Generic User Property states of an element. The response to the Generic User Properties Get message is a Generic User Properties Status message. The message has no parameters.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 895 of file MS_generic_property_api.h.

Function Documentation

API_RESULT MS_generic_property_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_PROPERTY_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Generic_Property Client model.

Description
This is to initialize Generic_Property Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Property Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_property_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Generic_Property client model handle.

Description
This is to get the handle of Generic_Property client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_property_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Generic User Property Server API Definitions

Functions
Generic User Property Server API Definitions
API Definitions

This section describes the Generic User Property Server APIs. More...

Functions

API_RESULT | MS_generic_user_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_User_Property Server model. More...
API_RESULT | MS_generic_admin_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_Admin_Property Server model. More...
API_RESULT | MS_generic_manufacturer_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_Manufacturer_Property Server model. More...
API_RESULT | MS_generic_client_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_Client_Property Server model. More...
API_RESULT | MS_generic_user_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_admin_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_manufacturer_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_client_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Generic User Property Server APIs.

Function Documentation

API_RESULT MS_generic_user_property_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_PROPERTY_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_User_Property Server model.

Description
This is to initialize Generic_User_Property Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_User_Property Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_admin_property_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_PROPERTY_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Admin_Property Server model.

Description
This is to initialize Generic_Admin_Property Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Admin_Property Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_manufacturer_property_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_PROPERTY_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Manufacturer_Property Server model.

Description
This is to initialize Generic_Manufacturer_Property Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Manufacturer_Property Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_client_property_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_GENERIC_PROPERTY_SERVER_CB | appl_cb
 | ) |  |

API to initialize Generic_Client_Property Server model.

Description
This is to initialize Generic_Client_Property Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Generic_Client_Property Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_user_property_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_admin_property_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_manufacturer_property_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_generic_client_property_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
GENERIC_PROPERTY (Mesh Generic Property Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_PROPERTY_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Property Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_PROPERTY_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Property Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_GENERIC_PROPERTY_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Generic Property Server application Asynchronous Notification Callback.

Generic Property Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 137 of file MS_generic_property_api.h.

typedef API_RESULT(* MS_GENERIC_PROPERTY_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Generic Property Client application Asynchronous Notification Callback.

Generic Property Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 158 of file MS_generic_property_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
GENERIC_PROPERTY (Mesh Generic Property Model)

Data Structures

struct | MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT
Generic User Properties Status message parameters. More...
struct | MS_GENERIC_USER_PROPERTY_GET_STRUCT
Generic User Property Get message parameters. More...
struct | MS_GENERIC_USER_PROPERTY_SET_STRUCT
Generic User Property Set message parameters. More...
struct | MS_GENERIC_USER_PROPERTY_STATUS_STRUCT
Generic User Property Status message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT
Generic Admin Properties Status message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT
Generic Admin Property Get message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT
Generic Admin Property Set message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
Generic Admin Property Status message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT
Generic Manufacturer Properties Status message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT
Generic Manufacturer Property Get message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT
Generic Manufacturer Property Set message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
Generic Manufacturer Property Status message parameters. More...
struct | MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT
Generic Client Properties Get message parameters. More...
struct | MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT
Generic Client Properties Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT Struct Reference
Structures

Generic User Properties Status message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 * | user_property_ids
A sequence of N User Property IDs present within an element, where N is the number of device property IDs included in the message.
UINT16 | user_property_ids_count
Number of User Property IDs.

Detailed Description

Generic User Properties Status message parameters.

Definition at line 174 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_USER_PROPERTY_GET_STRUCT Struct Reference

Data Fields
MS_GENERIC_USER_PROPERTY_GET_STRUCT Struct Reference
Structures

Generic User Property Get message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 user_property_id
Property ID identifying a Generic User Property. More...

Detailed Description

Generic User Property Get message parameters.

Definition at line 190 of file MS_generic_property_api.h.

Field Documentation

UINT16 MS_GENERIC_USER_PROPERTY_GET_STRUCT::user_property_id

Property ID identifying a Generic User Property.

Definition at line 193 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_USER_PROPERTY_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_USER_PROPERTY_SET_STRUCT Struct Reference
Structures

Generic User Property Set message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 | user_property_id
Property ID identifying a Generic User Property.
UCHAR * | user_property_value
Raw value for the User Property.
UINT16 | user_property_value_len

Detailed Description

Generic User Property Set message parameters.

Definition at line 200 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_USER_PROPERTY_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_USER_PROPERTY_STATUS_STRUCT Struct Reference
Structures

Generic User Property Status message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 | user_property_id
Property ID identifying a Generic User Property. More...
UCHAR | user_access
Enumeration indicating user access. More...
UCHAR * | user_property_value
Raw value for the User Property.
UINT16 | user_property_value_len
Raw value length for the User Property.
UCHAR | optional_fields_present
Flag: To represent if optional fields User Access and Raw Value are valid.

Detailed Description

Generic User Property Status message parameters.

Definition at line 216 of file MS_generic_property_api.h.

Field Documentation

UINT16 MS_GENERIC_USER_PROPERTY_STATUS_STRUCT::user_property_id

Property ID identifying a Generic User Property.

Definition at line 219 of file MS_generic_property_api.h.

UCHAR MS_GENERIC_USER_PROPERTY_STATUS_STRUCT::user_access

Enumeration indicating user access.

Definition at line 222 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT Struct Reference
Structures

Generic Admin Properties Status message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 * | admin_property_ids
A sequence of N Admin Property IDs present within an element, where N is the number of device property IDs included in the message.
UINT16 | admin_property_ids_count
Number of Admin Property IDs.

Detailed Description

Generic Admin Properties Status message parameters.

Definition at line 238 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT Struct Reference

Data Fields
MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT Struct Reference
Structures

Generic Admin Property Get message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 admin_property_id
Property ID identifying a Generic Admin Property. More...

Detailed Description

Generic Admin Property Get message parameters.

Definition at line 254 of file MS_generic_property_api.h.

Field Documentation

UINT16 MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT::admin_property_id

Property ID identifying a Generic Admin Property.

Definition at line 257 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT Struct Reference
Structures

Generic Admin Property Set message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 | admin_property_id
Property ID identifying a Generic Admin Property. More...
UCHAR | admin_user_access
Enumeration indicating user access. More...
UCHAR * | admin_property_value
Raw value for the Admin Property.
UINT16 | admin_property_value_len
Raw value length for the Admin Property.

Detailed Description

Generic Admin Property Set message parameters.

Definition at line 264 of file MS_generic_property_api.h.

Field Documentation

UINT16 MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT::admin_property_id

Property ID identifying a Generic Admin Property.

Definition at line 267 of file MS_generic_property_api.h.

UCHAR MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT::admin_user_access

Enumeration indicating user access.

Definition at line 270 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT Struct Reference
Structures

Generic Admin Property Status message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 | admin_property_id
Property ID identifying a Generic Admin Property.
UCHAR | admin_user_access
Enumeration indicating user access (Optional)
UCHAR * | admin_property_value
Raw value for the Admin Property.
UINT16 | admin_property_value_len
Raw value length for the Admin Property.

Detailed Description

Generic Admin Property Status message parameters.

Definition at line 283 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT Struct Reference
Structures

Generic Manufacturer Properties Status message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 * | manufacturer_property_ids
A sequence of N Manufacturer Property IDs present within an element, where N is the number of device property IDs included in the message.
UINT16 | manufacturer_property_ids_count
Number of Manufacturer Property IDs.

Detailed Description

Generic Manufacturer Properties Status message parameters.

Definition at line 302 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT Struct Reference

Data Fields
MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT Struct Reference
Structures

Generic Manufacturer Property Get message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 manufacturer_property_id
Property ID identifying a Generic Manufacturer Property.

Detailed Description

Generic Manufacturer Property Get message parameters.

Definition at line 318 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT Struct Reference

Data Fields
MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT Struct Reference
Structures

Generic Manufacturer Property Set message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 | manufacturer_property_id
Property ID identifying a Generic Manufacturer Property.
UCHAR | manufacturer_user_access
Enumeration indicating user access.

Detailed Description

Generic Manufacturer Property Set message parameters.

Definition at line 328 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT Struct Reference
Structures

Generic Manufacturer Property Status message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 | manufacturer_property_id
Property ID identifying a Generic Manufacturer Property.
UCHAR | manufacturer_user_access
Enumeration indicating user access.
UCHAR * | manufacturer_property_value
Raw value for the Manufacturer Property.
UINT16 | manufacturer_property_value_len
Raw value length for the Manufacturer Property.

Detailed Description

Generic Manufacturer Property Status message parameters.

Definition at line 341 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT Struct Reference

Data Fields
MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT Struct Reference
Structures

Generic Client Properties Get message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 client_property_id
A starting Client Property ID present within an element.

Detailed Description

Generic Client Properties Get message parameters.

Definition at line 360 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT Struct Reference

Data Fields
MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT Struct Reference
Structures

Generic Client Properties Status message parameters. More...

#include <MS_generic_property_api.h>

Data Fields

UINT16 * | client_property_ids
A sequence of N Client Property IDs present within an element, where N is the number of device property IDs included in the message.
UINT16 | client_property_ids_count
Number of Client Property IDs.

Detailed Description

Generic Client Properties Status message parameters.

Definition at line 370 of file MS_generic_property_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_generic_property_api.h


EtherMind Mesh SDK (beta): HEALTH (Mesh Health Model)

Modules
HEALTH (Mesh Health Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Health Model (HEALTH) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Health Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Health Model (HEALTH) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
HEALTH (Mesh Health Model)

This section describes the EtherMind Mesh Health Model APIs. More...

Modules

Health Client API Definitions
This section describes the Health Client APIs.

Detailed Description

This section describes the EtherMind Mesh Health Model APIs.


EtherMind Mesh SDK (beta): Health Client API Definitions

Macros | Functions
Health Client API Definitions
API Definitions

This section describes the Health Client APIs. More...

Macros

#define | MS_health_period_set_unacknowledged(param)
API to set the health period state. More...
#define | MS_health_attention_set(param)
API to set the attention state. More...
#define | MS_health_fault_clear_unacknowledged(param)
API to clear the registered fault state. More...
#define | MS_health_attention_set_unacknowledged(param)
API to set the attention state. More...
#define | MS_health_attention_get()
API to get the attention state. More...
#define | MS_health_fault_test(param)
API to invoke a self-test procedure. More...
#define | MS_health_fault_test_unacknowledged(param)
API to invoke a self-test procedure. More...
#define | MS_health_fault_clear(param)
API to clear the registered fault state. More...
#define | MS_health_fault_get(param)
API to report the registered fault state. More...
#define | MS_health_period_get()
API to get the health period state. More...
#define | MS_health_period_set(param)
API to set the health period state. More...

Functions

API_RESULT | MS_health_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_HEALTH_CLIENT_CB appl_cb)
API to initialize Health Client model. More...
API_RESULT | MS_health_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Health client model handle. More...
API_RESULT | MS_health_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Health Client APIs.

Macro Definition Documentation

#define MS_health_period_set_unacknowledged ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_PERIOD_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the health period state.

Description
The Health Period Set Unacknowledged is an unacknowledged message used to set the current Health Period state of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_PERIOD_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 217 of file MS_health_client_api.h.

#define MS_health_attention_set ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_ATTENTION_SET_OPCODE,\
param,\
MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE\
)

API to set the attention state.

Description
The Health Attention Set is an acknowledged message used to set the Attention Timer state of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_ATTENTION_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 237 of file MS_health_client_api.h.

#define MS_health_fault_clear_unacknowledged ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_FAULT_CLEAR_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to clear the registered fault state.

Description
The Health Fault Clear Unacknowledged is an unacknowledged message used to clear the current Registered Fault state identified by Company ID of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_FAULT_CLEAR_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 257 of file MS_health_client_api.h.

#define MS_health_attention_set_unacknowledged ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_ATTENTION_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the attention state.

Description
The Health Attention Set Unacknowledged is an unacknowledged message used to set the Attention Timer state of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_ATTENTION_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 277 of file MS_health_client_api.h.

#define MS_health_attention_get ( )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_ATTENTION_GET_OPCODE,\
NULL,\
MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE\
)

API to get the attention state.

Description
The Health Attention Get is an acknowledged message used to get the current Attention Timer state of an element.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 294 of file MS_health_client_api.h.

#define MS_health_fault_test ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_FAULT_TEST_OPCODE,\
param,\
MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE\
)

API to invoke a self-test procedure.

Description
The Health Fault Test is an acknowledged message used to invoke a self-test procedure of an element. The procedure is implementation specific and may result in changing the Health Fault state of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_FAULT_TEST_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 315 of file MS_health_client_api.h.

#define MS_health_fault_test_unacknowledged ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_FAULT_TEST_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to invoke a self-test procedure.

Description
The Health Fault Test Unacknowledged is an unacknowledged message used to invoke a self-test procedure of an element. The procedure is implementation specific and may result in changing the Health Fault state of an element.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 333 of file MS_health_client_api.h.

#define MS_health_fault_clear ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_FAULT_CLEAR_OPCODE,\
param,\
MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE\
)

API to clear the registered fault state.

Description
The Health Fault Clear is an acknowledged message used to clear the current Registered Fault state identified by Company ID of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_FAULT_CLEAR_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 353 of file MS_health_client_api.h.

#define MS_health_fault_get ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_FAULT_GET_OPCODE,\
param,\
MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE\
)

API to report the registered fault state.

Description
The Health Fault Get is an acknowledged message used to get the current Registered Fault state identified by Company ID of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_FAULT_GET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 373 of file MS_health_client_api.h.

#define MS_health_period_get ( )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_PERIOD_GET_OPCODE,\
NULL,\
MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE\
)

API to get the health period state.

Description
The Health Period Get is an acknowledged message used to get the current Health Period state of an element.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 390 of file MS_health_client_api.h.

#define MS_health_period_set ( param )
Value:
MS_health_client_send_reliable_pdu \
(\
MS_ACCESS_HEALTH_PERIOD_SET_OPCODE,\
param,\
MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE\
)

API to set the health period state.

Description
The Health Period Set is an acknowledged message used to set the current Health Period state of an element.
Parameters
[in] param Pointer to the structure populated as in ACCESS_HEALTH_PERIOD_SET_PARAM
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 410 of file MS_health_client_api.h.

Function Documentation

API_RESULT MS_health_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_HEALTH_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Health Client model.

Description
This is to initialize Health Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Health Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_health_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Health client model handle.

Description
This is to get the handle of Health client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_health_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
HEALTH (Mesh Health Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* MS_HEALTH_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Health Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_HEALTH_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Health Client application Asynchronous Notification Callback.

Health Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 51 of file MS_health_client_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
HEALTH (Mesh Health Model)

Data Structures

struct | MS_HEALTH_STATUS_STRUCT
Health Status message parameters. More...
struct | MS_HEALTH_FAULT_GET_CLEAR_STRUCT
Health Fault Get clear message parameters. More...
struct | MS_HEALTH_FAULT_TEST_STRUCT
Health Fault Test message parameters. More...
struct | MS_HEALTH_PERIOD_STRUCT
Health Period message parameters. More...
struct | MS_HEALTH_ATTENTION_STRUCT
Health Attention message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_HEALTH_STATUS_STRUCT Struct Reference

Data Fields
MS_HEALTH_STATUS_STRUCT Struct Reference
Structures

Health Status message parameters. More...

#include <MS_health_client_api.h>

Data Fields

UCHAR | test_id
Identifier of a performed test.
UINT16 | company_id
16-bit Bluetooth assigned Company Identifier
UCHAR * | faultarray
The FaultArray field contains a sequence of 1-octet fault values.
UINT16 | faultarray_len
Number of fault values in the FaultArray.

Detailed Description

Health Status message parameters.

Definition at line 67 of file MS_health_client_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_health_client_api.h


EtherMind Mesh SDK (beta): MS_HEALTH_FAULT_GET_CLEAR_STRUCT Struct Reference

Data Fields
MS_HEALTH_FAULT_GET_CLEAR_STRUCT Struct Reference
Structures

Health Fault Get clear message parameters. More...

#include <MS_health_client_api.h>

Data Fields

UINT16 company_id
16-bit Bluetooth assigned Company Identifier

Detailed Description

Health Fault Get clear message parameters.

Definition at line 86 of file MS_health_client_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_health_client_api.h


EtherMind Mesh SDK (beta): MS_HEALTH_FAULT_TEST_STRUCT Struct Reference

Data Fields
MS_HEALTH_FAULT_TEST_STRUCT Struct Reference
Structures

Health Fault Test message parameters. More...

#include <MS_health_client_api.h>

Data Fields

UCHAR | test_id
Identifier of a performed test.
UINT16 | company_id
16-bit Bluetooth assigned Company Identifier

Detailed Description

Health Fault Test message parameters.

Definition at line 96 of file MS_health_client_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_health_client_api.h


EtherMind Mesh SDK (beta): MS_HEALTH_PERIOD_STRUCT Struct Reference

Data Fields
MS_HEALTH_PERIOD_STRUCT Struct Reference
Structures

Health Period message parameters. More...

#include <MS_health_client_api.h>

Data Fields

UCHAR fastperioddivisor
Divider for the Publish Period. More...

Detailed Description

Health Period message parameters.

Definition at line 109 of file MS_health_client_api.h.

Field Documentation

UCHAR MS_HEALTH_PERIOD_STRUCT::fastperioddivisor

Divider for the Publish Period.

Modified Publish Period is used for sending Current Health Status messages when there are active faults to communicate.

Definition at line 116 of file MS_health_client_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_health_client_api.h


EtherMind Mesh SDK (beta): MS_HEALTH_ATTENTION_STRUCT Struct Reference

Data Fields
MS_HEALTH_ATTENTION_STRUCT Struct Reference
Structures

Health Attention message parameters. More...

#include <MS_health_client_api.h>

Data Fields

UCHAR attention
Value of the Attention Timer state.

Detailed Description

Health Attention message parameters.

Definition at line 123 of file MS_health_client_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_health_client_api.h


EtherMind Mesh SDK (beta): Health Server Events

Macros
Health Server Events

This section lists the Application Events defined for Health Server Model. More...

Macros

#define | MS_HEALTH_SERVER_ATTENTION_START 0x01
Attention Start.
#define | MS_HEALTH_SERVER_ATTENTION_RESTART 0x02
Attention Restart.
#define | MS_HEALTH_SERVER_ATTENTION_STOP 0x03
Attention Stop.

Detailed Description

This section lists the Application Events defined for Health Server Model.


EtherMind Mesh SDK (beta): LIGHT_CTL (Mesh Light Ctl Model)

Modules
LIGHT_CTL (Mesh Light Ctl Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Light Ctl Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
LIGHT_CTL (Mesh Light Ctl Model)

This section describes the EtherMind Mesh Light Ctl Model APIs. More...

Modules

Light Ctl Client API Definitions
This section describes the Light Ctl Client APIs.
Light Ctl Server API Definitions
This section describes the Light Ctl Server APIs.

Detailed Description

This section describes the EtherMind Mesh Light Ctl Model APIs.


EtherMind Mesh SDK (beta): Light Ctl Client API Definitions

Macros | Functions
Light Ctl Client API Definitions
API Definitions

This section describes the Light Ctl Client APIs. More...

Macros

#define | MS_light_ctl_set(param)
API to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element. More...
#define | MS_light_ctl_default_get()
API to get the Light CTL Temperature Default and Light CTL Delta UV Default states of an element. More...
#define | MS_light_ctl_set_unacknowledged(param)
API to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element. More...
#define | MS_light_ctl_temperature_range_set_unacknowledged(param)
API to set the Light CTL Temperature Range state of an element. More...
#define | MS_light_ctl_default_set_unacknowledged(param)
API to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element. More...
#define | MS_light_ctl_temperature_get()
API to get the Light CTL Temperature state of an element. More...
#define | MS_light_ctl_temperature_range_set(param)
API to set the Light CTL Temperature Range state of an element. More...
#define | MS_light_ctl_get()
API to get the Light CTL state of an element. More...
#define | MS_light_ctl_default_set(param)
API to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element. More...
#define | MS_light_ctl_temperature_range_get()
API to get the Light CTL Temperature Range state of an element. More...
#define | MS_light_ctl_temperature_set(param)
API to set the Light CTL Temperature state and the Light CTL Delta UV state of an element. More...
#define | MS_light_ctl_temperature_set_unacknowledged(param)
API to set the Light CTL Temperature state and the Light CTL Delta UV state of an element. More...

Functions

API_RESULT | MS_light_ctl_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_CTL_CLIENT_CB appl_cb)
API to initialize Light_Ctl Client model. More...
API_RESULT | MS_light_ctl_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Ctl client model handle. More...
API_RESULT | MS_light_ctl_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Light Ctl Client APIs.

Macro Definition Documentation

#define MS_light_ctl_set ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_CTL_STATUS_OPCODE\
)

API to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element.

Description
Light CTL Set is an acknowledged message used to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element. The response to the Light CTL Set message is a Light CTL Status message.
Parameters
[in] param Light CTL Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 509 of file MS_light_ctl_api.h.

#define MS_light_ctl_default_get ( )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_DEFAULT_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE\
)

API to get the Light CTL Temperature Default and Light CTL Delta UV Default states of an element.

Description
Light CTL Default Get is an acknowledged message used to get the Light CTL Temperature Default and Light CTL Delta UV Default states of an element. The response to the Light CTL Default Get message is a Light CTL Default Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 527 of file MS_light_ctl_api.h.

#define MS_light_ctl_set_unacknowledged ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element.

Description
Light CTL Set Unacknowledged is an unacknowledged message used to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element
Parameters
[in] param Light CTL Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 546 of file MS_light_ctl_api.h.

#define MS_light_ctl_temperature_range_set_unacknowledged ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light CTL Temperature Range state of an element.

Description
Light CTL Temperature Range Set is an acknowledged message used to set the Light CTL Temperature Range state of an element. The response to the Light CTL Temperature Range Get message is a Light CTL Temperature Range Status message.
Parameters
[in] param Light CTL Temperature Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 565 of file MS_light_ctl_api.h.

#define MS_light_ctl_default_set_unacknowledged ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element.

Description
The Light CTL Default Set Unacknowledged is an unacknowledged message used to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element.
Parameters
[in] param Light CTL Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 584 of file MS_light_ctl_api.h.

#define MS_light_ctl_temperature_get ( )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE\
)

API to get the Light CTL Temperature state of an element.

Description
Light CTL Temperature Get is an acknowledged message used to get the Light CTL Temperature state of an element. The response to the Light CTL Temperature Get message is a Light CTL Temperature Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 602 of file MS_light_ctl_api.h.

#define MS_light_ctl_temperature_range_set ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE\
)

API to set the Light CTL Temperature Range state of an element.

Description
Light CTL Temperature Range Set Unacknowledged is an unacknowledged message used to set the Light CTL Temperature Range state of an element.
Parameters
[in] param Light CTL Temperature Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 621 of file MS_light_ctl_api.h.

#define MS_light_ctl_get ( )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_CTL_STATUS_OPCODE\
)

API to get the Light CTL state of an element.

Description
Light CTL Get is an acknowledged message used to get the Light CTL state of an element. The response to the Light CTL Get message is a Light CTL Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 639 of file MS_light_ctl_api.h.

#define MS_light_ctl_default_set ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_DEFAULT_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE\
)

API to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element.

Description
The Light CTL Default Set is an acknowledged message used to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element. The response to the Light CTL Set message is a Light CTL Status message.
Parameters
[in] param Light CTL Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 659 of file MS_light_ctl_api.h.

#define MS_light_ctl_temperature_range_get ( )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE\
)

API to get the Light CTL Temperature Range state of an element.

Description
The Light CTL Temperature Range Get is an acknowledged message used to get the Light CTL Temperature Range state of an element. The response to the Light CTL Temperature Range Get message is a Light CTL Temperature Range Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 677 of file MS_light_ctl_api.h.

#define MS_light_ctl_temperature_set ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE\
)

API to set the Light CTL Temperature state and the Light CTL Delta UV state of an element.

Description
The Light CTL Temperature Set is an acknowledged message used to set the Light CTL Temperature state and the Light CTL Delta UV state of an element. The response to the Light CTL Temperature Set message is a Light CTL Temperature Status message.
Parameters
[in] param Light CTL Temperature Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 697 of file MS_light_ctl_api.h.

#define MS_light_ctl_temperature_set_unacknowledged ( param )
Value:
MS_light_ctl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light CTL Temperature state and the Light CTL Delta UV state of an element.

Description
The Light CTL Temperature Set Unacknowledged is an unacknowledged message used to set the Light CTL Temperature state and the Light CTL Delta UV state of an element
Parameters
[in] param Light CTL Temperature Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 716 of file MS_light_ctl_api.h.

Function Documentation

API_RESULT MS_light_ctl_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_CTL_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Light_Ctl Client model.

Description
This is to initialize Light_Ctl Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Ctl Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_ctl_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Light_Ctl client model handle.

Description
This is to get the handle of Light_Ctl client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_ctl_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Light Ctl Server API Definitions

Functions
Light Ctl Server API Definitions
API Definitions

This section describes the Light Ctl Server APIs. More...

Functions

API_RESULT | MS_light_ctl_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *ctl_model_handle, MS_ACCESS_MODEL_HANDLE *ctl_setup_model_handle, MS_LIGHT_CTL_SERVER_CB appl_cb)
API to initialize Light_Ctl Server model. More...
API_RESULT | MS_light_ctl_temperature_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_CTL_TEMPERATURE_SERVER_CB appl_cb)
API to initialize Light_Ctl_Temperature Server model. More...
API_RESULT | MS_light_ctl_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_ctl_temperature_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Light Ctl Server APIs.

Function Documentation

API_RESULT MS_light_ctl_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | ctl_model_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | ctl_setup_model_handle,
 |  | MS_LIGHT_CTL_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Ctl Server model.

Description
This is to initialize Light_Ctl Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | ctl_model_handle | Model identifier associated with the Light CTL model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in,out] | ctl_setup_model_handle | Model identifier associated with the Light CTL Setup model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Ctl Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_ctl_temperature_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_CTL_TEMPERATURE_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Ctl_Temperature Server model.

Description
This is to initialize Light_Ctl_Temperature Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Ctl_Temperature Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_ctl_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_ctl_temperature_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
LIGHT_CTL (Mesh Light Ctl Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_CTL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Ctl Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_CTL_TEMPERATURE_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Ctl Temperature Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_CTL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Ctl Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_LIGHT_CTL_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Ctl Server application Asynchronous Notification Callback.

Light Ctl Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_light_ctl_api.h.

typedef API_RESULT(* MS_LIGHT_CTL_TEMPERATURE_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Ctl Temperature Server application Asynchronous Notification Callback.

Light Ctl Temperature Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 74 of file MS_light_ctl_api.h.

typedef API_RESULT(* MS_LIGHT_CTL_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Light Ctl Client application Asynchronous Notification Callback.

Light Ctl Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 95 of file MS_light_ctl_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
LIGHT_CTL (Mesh Light Ctl Model)

Data Structures

struct | MS_LIGHT_CTL_SET_STRUCT
Light CTL Set message parameters. More...
struct | MS_LIGHT_CTL_STATUS_STRUCT
Light CTL Status message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT
Light CTL Temperature Set message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT
Light CTL Temperature Status message parameters. More...
struct | MS_LIGHT_CTL_DEFAULT_SET_STRUCT
Light CTL Default Set message parameters. More...
struct | MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT
Light CTL Default Status message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT
Light CTL Temperature Range Set message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT
Light CTL Temperature Range Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_SET_STRUCT Struct Reference
Structures

Light CTL Set message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UINT16 | ctl_lightness
The target value of the Light CTL Lightness state. More...
UINT16 | ctl_temperature
The target value of the Light CTL Temperature state. More...
UINT16 | ctl_delta_uv
The target value of the Light CTL Delta UV state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light CTL Set message parameters.

Definition at line 111 of file MS_light_ctl_api.h.

Field Documentation

UINT16 MS_LIGHT_CTL_SET_STRUCT::ctl_lightness

The target value of the Light CTL Lightness state.

Definition at line 114 of file MS_light_ctl_api.h.

UINT16 MS_LIGHT_CTL_SET_STRUCT::ctl_temperature

The target value of the Light CTL Temperature state.

Definition at line 117 of file MS_light_ctl_api.h.

UINT16 MS_LIGHT_CTL_SET_STRUCT::ctl_delta_uv

The target value of the Light CTL Delta UV state.

Definition at line 120 of file MS_light_ctl_api.h.

UCHAR MS_LIGHT_CTL_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 136 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_STATUS_STRUCT Struct Reference
Structures

Light CTL Status message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UINT16 | present_ctl_lightness
The present value of the Light CTL Lightness state.
UINT16 | present_ctl_temperature
The present value of the Light CTL Temperature state.
UINT16 | target_ctl_lightness
The target value of the Light CTL Lightness state (Optional)
UINT16 | target_ctl_temperature
The target value of the Light CTL Temperature state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target CTL Lightness and Temperature are valid.

Detailed Description

Light CTL Status message parameters.

Definition at line 149 of file MS_light_ctl_api.h.

Field Documentation

UCHAR MS_LIGHT_CTL_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 174 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT Struct Reference
Structures

Light CTL Temperature Set message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UINT16 | ctl_temperature
The target value of the Light CTL Temperature state. More...
UINT16 | ctl_delta_uv
The target value of the Light CTL Delta UV state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light CTL Temperature Set message parameters.

Definition at line 184 of file MS_light_ctl_api.h.

Field Documentation

UINT16 MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT::ctl_temperature

The target value of the Light CTL Temperature state.

Definition at line 187 of file MS_light_ctl_api.h.

UINT16 MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT::ctl_delta_uv

The target value of the Light CTL Delta UV state.

Definition at line 190 of file MS_light_ctl_api.h.

UCHAR MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 206 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT Struct Reference
Structures

Light CTL Temperature Status message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UINT16 | present_ctl_temperature
The present value of the Light CTL Temperature state. More...
UINT16 | present_ctl_delta_uv
The present value of the Light CTL Delta UV state.
UINT16 | target_ctl_temperature
The target value of the Light CTL Temperature state (Optional)
UINT16 | target_ctl_delta_uv
The target value of the Light CTL Delta UV state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target CTL Temperature, Delta UV and Remaining Time are valid.

Detailed Description

Light CTL Temperature Status message parameters.

Definition at line 219 of file MS_light_ctl_api.h.

Field Documentation

UINT16 MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT::present_ctl_temperature

The present value of the Light CTL Temperature state.

Definition at line 222 of file MS_light_ctl_api.h.

UCHAR MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 244 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_DEFAULT_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_DEFAULT_SET_STRUCT Struct Reference
Structures

Light CTL Default Set message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UINT16 | lightness
The value of the Light Lightness Default state. More...
UINT16 | temperature
The value of the Light CTL Temperature Default state. More...
UINT16 | delta_uv
The value of the Light CTL Delta UV Default state. More...

Detailed Description

Light CTL Default Set message parameters.

Definition at line 254 of file MS_light_ctl_api.h.

Field Documentation

UINT16 MS_LIGHT_CTL_DEFAULT_SET_STRUCT::lightness

The value of the Light Lightness Default state.

Definition at line 257 of file MS_light_ctl_api.h.

UINT16 MS_LIGHT_CTL_DEFAULT_SET_STRUCT::temperature

The value of the Light CTL Temperature Default state.

Definition at line 260 of file MS_light_ctl_api.h.

UINT16 MS_LIGHT_CTL_DEFAULT_SET_STRUCT::delta_uv

The value of the Light CTL Delta UV Default state.

Definition at line 263 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT Struct Reference
Structures

Light CTL Default Status message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UINT16 | lightness
The value of the Light Lightness Default state.
UINT16 | temperature
The value of the Light CTL Temperature Default state.
UINT16 | delta_uv
The value of the Light CTL Delta UV Default state.

Detailed Description

Light CTL Default Status message parameters.

Definition at line 270 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT Struct Reference
Structures

Light CTL Temperature Range Set message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UINT16 | range_min
The value of the Temperature Range Min field of the Light CTL Temperature Range state.
UINT16 | range_max
The value of the Temperature Range Max field of the Light CTL Temperature Range state.

Detailed Description

Light CTL Temperature Range Set message parameters.

Definition at line 286 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT Struct Reference
Structures

Light CTL Temperature Range Status message parameters. More...

#include <MS_light_ctl_api.h>

Data Fields

UCHAR | status_code
Status Code for the requesting message. More...
UINT16 | range_min
The value of the Temperature Range Min field of the Light CTL Temperature Range state.
UINT16 | range_max
The value of the Temperature Range Max field of the Light CTL Temperature Range state.

Detailed Description

Light CTL Temperature Range Status message parameters.

Definition at line 299 of file MS_light_ctl_api.h.

Field Documentation

UCHAR MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT::status_code

Status Code for the requesting message.

Definition at line 302 of file MS_light_ctl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_ctl_api.h


EtherMind Mesh SDK (beta): LIGHT_HSL (Mesh Light Hsl Model)

Modules
LIGHT_HSL (Mesh Light Hsl Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Light Hsl Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
LIGHT_HSL (Mesh Light Hsl Model)

This section describes the EtherMind Mesh Light Hsl Model APIs. More...

Modules

Light Hsl Client API Definitions
This section describes the Light Hsl Client APIs.
Light Hsl Server API Definitions
This section describes the Light Hsl Server APIs.

Detailed Description

This section describes the EtherMind Mesh Light Hsl Model APIs.


EtherMind Mesh SDK (beta): Light Hsl Client API Definitions

Macros | Functions
Light Hsl Client API Definitions
API Definitions

This section describes the Light Hsl Client APIs. More...

Macros

#define | MS_light_hsl_hue_get()
API to get the Light HSL Hue state of an element. More...
#define | MS_light_hsl_set_unacknowledged(param)
API to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element. More...
#define | MS_light_hsl_range_get()
API to get the Light HSL Hue Range and Light HSL Saturation Range states of an element. More...
#define | MS_light_hsl_range_set_unacknowledged(param)
API to set the Light HSL Hue Range and Light HSL Saturation Range states of an element. More...
#define | MS_light_hsl_default_set(param)
API to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. More...
#define | MS_light_hsl_saturation_set_unacknowledged(param)
API to set the target Light HSL Saturation state of an element. More...
#define | MS_light_hsl_set(param)
API to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element. More...
#define | MS_light_hsl_saturation_get()
API to get the Light HSL Saturation state of an element. More...
#define | MS_light_hsl_default_get()
API to to get the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. More...
#define | MS_light_hsl_default_set_unacknowledged(param)
API to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. More...
#define | MS_light_hsl_hue_set(param)
API to set the target Light HSL Hue state of an element. More...
#define | MS_light_hsl_range_set(param)
API to set the Light HSL Hue Range and Light HSL Saturation Range states of an element. More...
#define | MS_light_hsl_saturation_set(param)
API to set the target Light HSL Saturation state of an element. More...
#define | MS_light_hsl_target_get()
API to get the target Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element. More...
#define | MS_light_hsl_hue_set_unacknowledged(param)
API to set the target Light HSL Hue state of an element. More...
#define | MS_light_hsl_get()
API to get the Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element. More...

Functions

API_RESULT | MS_light_hsl_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_HSL_CLIENT_CB appl_cb)
API to initialize Light_Hsl Client model. More...
API_RESULT | MS_light_hsl_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Hsl client model handle. More...
API_RESULT | MS_light_hsl_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Light Hsl Client APIs.

Macro Definition Documentation

#define MS_light_hsl_hue_get ( )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_HUE_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE\
)

API to get the Light HSL Hue state of an element.

Description
The Light HSL Hue Get is an acknowledged message used to get the Light HSL Hue state of an element. The response to the Light HSL Hue Get message is a Light HSL Hue Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 669 of file MS_light_hsl_api.h.

#define MS_light_hsl_set_unacknowledged ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element.

Description
The Light HSL Set is an acknowledged message used to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element. The response to the Light HSL Set message is a Light HSL Status message.
Parameters
[in] param Light HSL Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 689 of file MS_light_hsl_api.h.

#define MS_light_hsl_range_get ( )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_RANGE_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE\
)

API to get the Light HSL Hue Range and Light HSL Saturation Range states of an element.

Description
The Light HSL Range Get is an acknowledged message used to get the Light HSL Hue Range and Light HSL Saturation Range states of an element. The response to the Light HSL Range Get message is a Light HSL Range Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 707 of file MS_light_hsl_api.h.

#define MS_light_hsl_range_set_unacknowledged ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light HSL Hue Range and Light HSL Saturation Range states of an element.

Description
Light HSL Range Set Unacknowledged is an unacknowledged message used to set the Light HSL Hue Range and Light HSL Saturation Range states of an element.
Parameters
[in] param Light HSL Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 725 of file MS_light_hsl_api.h.

#define MS_light_hsl_default_set ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_DEFAULT_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE\
)

API to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element.

Description
Light HSL Default Set is an acknowledged message used to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. The response to the Light HSL Default Set message is a Light HSL Default Status message.
Parameters
[in] param Light HSL Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 745 of file MS_light_hsl_api.h.

#define MS_light_hsl_saturation_set_unacknowledged ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_SATURATION_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the target Light HSL Saturation state of an element.

Description
The Light HSL Saturation Set Unacknowledged is an unacknowledged message used to set the target Light HSL Saturation state of an element.
Parameters
[in] param Light HSL Saturation Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 764 of file MS_light_hsl_api.h.

#define MS_light_hsl_set ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_HSL_STATUS_OPCODE\
)

API to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element.

Description
The Light HSL Set Unacknowledged is an unacknowledged message used to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element.
Parameters
[in] param Light HSL Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 783 of file MS_light_hsl_api.h.

#define MS_light_hsl_saturation_get ( )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_SATURATION_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE\
)

API to get the Light HSL Saturation state of an element.

Description
The Light HSL Saturation Get is an acknowledged message used to get the Light HSL Saturation state of an element. The response to the Light HSL Saturation Get message is a Light HSL Saturation Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 801 of file MS_light_hsl_api.h.

#define MS_light_hsl_default_get ( )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_DEFAULT_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE\
)

API to to get the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element.

Description
Light HSL Default Get is an acknowledged message used to get the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. The response to the Light HSL Default Get message is a Light HSL Default Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 820 of file MS_light_hsl_api.h.

#define MS_light_hsl_default_set_unacknowledged ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element.

Description
Light HSL Default Set Unacknowledged is an unacknowledged message used to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element.
Parameters
[in] param Light HSL Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 839 of file MS_light_hsl_api.h.

#define MS_light_hsl_hue_set ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_HUE_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE\
)

API to set the target Light HSL Hue state of an element.

Description
The Light HSL Hue Set is an acknowledged message used to set the target Light HSL Hue state of an element. The response to the Light HSL Hue Set message is a Light HSL Hue Status message.
Parameters
[in] param Light HSL Hue Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 858 of file MS_light_hsl_api.h.

#define MS_light_hsl_range_set ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_RANGE_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE\
)

API to set the Light HSL Hue Range and Light HSL Saturation Range states of an element.

Description
Light HSL Range Set is an acknowledged message used to set the Light HSL Hue Range and Light HSL Saturation Range states of an element. The response to the Light HSL Range Set message is a Light HSL Range Status message.
Parameters
[in] param Light HSL Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 877 of file MS_light_hsl_api.h.

#define MS_light_hsl_saturation_set ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_SATURATION_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE\
)

API to set the target Light HSL Saturation state of an element.

Description
The Light HSL Saturation Set is an acknowledged message used to set the target Light HSL Saturation state of an element. The response to the Light HSL Saturation Set message is a Light HSL Saturation Status message.
Parameters
[in] param Light HSL Saturation Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 896 of file MS_light_hsl_api.h.

#define MS_light_hsl_target_get ( )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_TARGET_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_HSL_TARGET_STATUS_OPCODE\
)

API to get the target Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element.

Description
Light HSL Target Get is an acknowledged message used to get the target Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element. The response to the Light HSL Target Get message is a Light HSL Target Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 915 of file MS_light_hsl_api.h.

#define MS_light_hsl_hue_set_unacknowledged ( param )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_HUE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the target Light HSL Hue state of an element.

Description
The Light HSL Hue Set Unacknowledged is an unacknowledged message used to set the target Light HSL Hue state of an element.
Parameters
[in] param Light HSL Hue Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 934 of file MS_light_hsl_api.h.

#define MS_light_hsl_get ( )
Value:
MS_light_hsl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_HSL_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_HSL_STATUS_OPCODE\
)

API to get the Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element.

Description
The Light HSL Get is an acknowledged message used to get the Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element. The response to the Light HSL Get message is a Light HSL Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 952 of file MS_light_hsl_api.h.

Function Documentation

API_RESULT MS_light_hsl_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_HSL_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Light_Hsl Client model.

Description
This is to initialize Light_Hsl Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Hsl Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_hsl_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Light_Hsl client model handle.

Description
This is to get the handle of Light_Hsl client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_hsl_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Light Hsl Server API Definitions

Functions
Light Hsl Server API Definitions
API Definitions

This section describes the Light Hsl Server APIs. More...

Functions

API_RESULT | MS_light_hsl_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *hsl_model_handle, MS_ACCESS_MODEL_HANDLE *hsl_setup_model_handle, MS_LIGHT_HSL_SERVER_CB appl_cb)
API to initialize Light_Hsl Server model. More...
API_RESULT | MS_light_hsl_hue_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_HSL_HUE_SERVER_CB appl_cb)
API to initialize Light_Hsl_Hue Server model. More...
API_RESULT | MS_light_hsl_saturation_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_HSL_SATURATION_SERVER_CB appl_cb)
API to initialize Light_Hsl_Saturation Server model. More...
API_RESULT | MS_light_hsl_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_hsl_hue_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_hsl_saturation_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Light Hsl Server APIs.

Function Documentation

API_RESULT MS_light_hsl_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | hsl_model_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | hsl_setup_model_handle,
 |  | MS_LIGHT_HSL_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Hsl Server model.

Description
This is to initialize Light_Hsl Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | hsl_model_handle | Model identifier associated with the Light HSL model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in,out] | hsl_setup_model_handle | Model identifier associated with the Light HSL Setup model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Hsl Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_hsl_hue_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_HSL_HUE_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Hsl_Hue Server model.

Description
This is to initialize Light_Hsl_Hue Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Hsl_Hue Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_hsl_saturation_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_HSL_SATURATION_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Hsl_Saturation Server model.

Description
This is to initialize Light_Hsl_Saturation Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Hsl_Saturation Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_hsl_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_hsl_hue_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_hsl_saturation_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
LIGHT_HSL (Mesh Light Hsl Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_HSL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Hsl Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_HSL_HUE_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Hsl Hue Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_HSL_SATURATION_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Hsl Saturation Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_HSL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Hsl Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_LIGHT_HSL_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Hsl Server application Asynchronous Notification Callback.

Light Hsl Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_light_hsl_api.h.

typedef API_RESULT(* MS_LIGHT_HSL_HUE_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Hsl Hue Server application Asynchronous Notification Callback.

Light Hsl Hue Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 74 of file MS_light_hsl_api.h.

typedef API_RESULT(* MS_LIGHT_HSL_SATURATION_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Hsl Saturation Server application Asynchronous Notification Callback.

Light Hsl Saturation Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 96 of file MS_light_hsl_api.h.

typedef API_RESULT(* MS_LIGHT_HSL_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Light Hsl Client application Asynchronous Notification Callback.

Light Hsl Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 117 of file MS_light_hsl_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
LIGHT_HSL (Mesh Light Hsl Model)

Data Structures

struct | MS_LIGHT_HSL_SET_STRUCT
Light HSL Set message parameters. More...
struct | MS_LIGHT_HSL_STATUS_STRUCT
Light HSL Status message parameters. More...
struct | MS_LIGHT_HSL_TARGET_STATUS_STRUCT
Light HSL Target Status message parameters. More...
struct | MS_LIGHT_HSL_DEFAULT_SET_STRUCT
Light HSL Default Set message parameters. More...
struct | MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT
Light HSL Default Status message parameters. More...
struct | MS_LIGHT_HSL_RANGE_SET_STRUCT
Light HSL Range Set message parameters. More...
struct | MS_LIGHT_HSL_RANGE_STATUS_STRUCT
Light HSL Range Status message parameters. More...
struct | MS_LIGHT_HSL_HUE_SET_STRUCT
Light HSL Hue Set message parameters. More...
struct | MS_LIGHT_HSL_HUE_STATUS_STRUCT
Light HSL Hue Status message parameters. More...
struct | MS_LIGHT_HSL_SATURATION_SET_STRUCT
Light HSL Saturation Set message parameters. More...
struct | MS_LIGHT_HSL_SATURATION_STATUS_STRUCT
Light HSL Saturation Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_SET_STRUCT Struct Reference
Structures

Light HSL Set message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | hsl_lightness
The target value of the Light HSL Lightness state.
UINT16 | hsl_hue
The target value of the Light HSL Hue state.
UINT16 | hsl_saturation
The target value of the Light HSL Saturation state.
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light HSL Set message parameters.

Definition at line 133 of file MS_light_hsl_api.h.

Field Documentation

UCHAR MS_LIGHT_HSL_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 158 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_STATUS_STRUCT Struct Reference
Structures

Light HSL Status message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | hsl_lightness
The present value of the Light HSL Lightness state.
UINT16 | hsl_hue
The present value of the Light HSL Hue state.
UINT16 | hsl_saturation
The present value of the Light HSL Saturation state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional field Remaining Time is valid.

Detailed Description

Light HSL Status message parameters.

Definition at line 171 of file MS_light_hsl_api.h.

Field Documentation

UCHAR MS_LIGHT_HSL_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 193 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_TARGET_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_TARGET_STATUS_STRUCT Struct Reference
Structures

Light HSL Target Status message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | hsl_lightness_target
The target value of the Light HSL Lightness state.
UINT16 | hsl_hue_target
The target value of the Light HSL Hue state.
UINT16 | hsl_saturation_target
The target Light HSL Saturation state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional field Remaining Time is valid.

Detailed Description

Light HSL Target Status message parameters.

Definition at line 203 of file MS_light_hsl_api.h.

Field Documentation

UCHAR MS_LIGHT_HSL_TARGET_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 225 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_DEFAULT_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_DEFAULT_SET_STRUCT Struct Reference
Structures

Light HSL Default Set message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | lightness
The value of the Light Lightness Default state.
UINT16 | hue
The value of the Light HSL Hue Default state.
UINT16 | saturation
The value of the Light HSL Saturation Default state.

Detailed Description

Light HSL Default Set message parameters.

Definition at line 235 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT Struct Reference
Structures

Light HSL Default Status message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | lightness
The value of the Light Lightness Default state.
UINT16 | hue
The value of the Light HSL Hue Default state.
UINT16 | saturation
The value of the Light HSL Saturation Default state.

Detailed Description

Light HSL Default Status message parameters.

Definition at line 251 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_RANGE_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_RANGE_SET_STRUCT Struct Reference
Structures

Light HSL Range Set message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | hue_range_min
The value of the Hue Range Min field of the Light HSL Hue Range state.
UINT16 | hue_range_max
The value of the Hue Range Max field of the Light HSL Hue Range state.
UINT16 | saturation_range_min
The value of the Saturation Range Min field of the Light HSL Saturation Range state.
UINT16 | saturation_range_max
The value of the Saturation Range Max field of the Light HSL Saturation Range state.

Detailed Description

Light HSL Range Set message parameters.

Definition at line 267 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_RANGE_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_RANGE_STATUS_STRUCT Struct Reference
Structures

Light HSL Range Status message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UCHAR | status_code
Status Code for the requesting message. More...
UINT16 | hue_range_min
The value of the Hue Range Min field of the Light HSL Hue Range state.
UINT16 | hue_range_max
The value of the Hue Range Max field of the Light HSL Hue Range state.
UINT16 | saturation_range_min
The value of the Saturation Range Min field of the Light HSL Saturation Range state.
UINT16 | saturation_range_max
The value of the Saturation Range Max field of the Light HSL Saturation Range state.

Detailed Description

Light HSL Range Status message parameters.

Definition at line 286 of file MS_light_hsl_api.h.

Field Documentation

UCHAR MS_LIGHT_HSL_RANGE_STATUS_STRUCT::status_code

Status Code for the requesting message.

Definition at line 289 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_HUE_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_HUE_SET_STRUCT Struct Reference
Structures

Light HSL Hue Set message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | hue
The target value of the Light HSL Hue state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light HSL Hue Set message parameters.

Definition at line 308 of file MS_light_hsl_api.h.

Field Documentation

UINT16 MS_LIGHT_HSL_HUE_SET_STRUCT::hue

The target value of the Light HSL Hue state.

Definition at line 311 of file MS_light_hsl_api.h.

UCHAR MS_LIGHT_HSL_HUE_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 327 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_HUE_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_HUE_STATUS_STRUCT Struct Reference
Structures

Light HSL Hue Status message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | present_hue
The present value of the Light HSL Hue state.
UINT16 | target_hue
The target value of the Light HSL Hue state (Optional)
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target Hue and Remaining Time are valid.

Detailed Description

Light HSL Hue Status message parameters.

Definition at line 340 of file MS_light_hsl_api.h.

Field Documentation

UCHAR MS_LIGHT_HSL_HUE_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 359 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_SATURATION_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_SATURATION_SET_STRUCT Struct Reference
Structures

Light HSL Saturation Set message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | saturation
The target value of the Light HSL Saturation state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light HSL Saturation Set message parameters.

Definition at line 369 of file MS_light_hsl_api.h.

Field Documentation

UINT16 MS_LIGHT_HSL_SATURATION_SET_STRUCT::saturation

The target value of the Light HSL Saturation state.

Definition at line 372 of file MS_light_hsl_api.h.

UCHAR MS_LIGHT_HSL_SATURATION_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 388 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_HSL_SATURATION_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_HSL_SATURATION_STATUS_STRUCT Struct Reference
Structures

Light HSL Saturation Status message parameters. More...

#include <MS_light_hsl_api.h>

Data Fields

UINT16 | present_saturation
The present value of the Light HSL Saturation state. More...
UINT16 | target_saturation
The target value of the Light HSL Saturation state. More...
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target Saturation and Remaining Time are valid.

Detailed Description

Light HSL Saturation Status message parameters.

Definition at line 401 of file MS_light_hsl_api.h.

Field Documentation

UINT16 MS_LIGHT_HSL_SATURATION_STATUS_STRUCT::present_saturation

The present value of the Light HSL Saturation state.

Definition at line 404 of file MS_light_hsl_api.h.

UINT16 MS_LIGHT_HSL_SATURATION_STATUS_STRUCT::target_saturation

The target value of the Light HSL Saturation state.

(Optional)

Definition at line 407 of file MS_light_hsl_api.h.

UCHAR MS_LIGHT_HSL_SATURATION_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 420 of file MS_light_hsl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_hsl_api.h


EtherMind Mesh SDK (beta): LIGHT_LC (Mesh Light Lc Model)

Modules
LIGHT_LC (Mesh Light Lc Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Light Lc Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
LIGHT_LC (Mesh Light Lc Model)

This section describes the EtherMind Mesh Light Lc Model APIs. More...

Modules

Light Lc Client API Definitions
This section describes the Light Lc Client APIs.
Light Lc Server API Definitions
This section describes the Light Lc Server APIs.

Detailed Description

This section describes the EtherMind Mesh Light Lc Model APIs.


EtherMind Mesh SDK (beta): Light Lc Client API Definitions

Macros | Functions
Light Lc Client API Definitions
API Definitions

This section describes the Light Lc Client APIs. More...

Macros

#define | MS_light_lc_om_set(param)
API to set the Light LC Occupancy Mode state of an element. More...
#define | MS_light_lc_om_set_unacknowledged(param)
API to set the Light LC Occupancy Mode state of an element. More...
#define | MS_light_lc_property_set_unacknowledged(param)
API to set the Light LC Property state of an element. More...
#define | MS_light_lc_property_get(param)
API to to get the Light LC Property state of an element. More...
#define | MS_light_lc_mode_set(param)
API to set the Light LC Mode state of an element. More...
#define | MS_light_lc_mode_get()
API to get the Light LC Mode state of an element. More...
#define | MS_light_lc_property_set(param)
API to set the Light LC Property state of an element. More...
#define | MS_light_lc_om_get()
API to get the Light LC Occupancy Mode state of an element. More...
#define | MS_light_lc_light_onoff_set_unacknowledged(param)
API to set the Light LC Light OnOff state of an element. More...
#define | MS_light_lc_light_onoff_get()
API to get the Light LC Light OnOff state of an element. More...
#define | MS_light_lc_light_onoff_set(param)
API to set the Light LC Light OnOff state of an element. More...
#define | MS_light_lc_mode_set_unacknowledged(param)
API to set the Light LC Mode state of an element. More...

Functions

API_RESULT | MS_light_lc_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LC_CLIENT_CB appl_cb)
API to initialize Light_Lc Client model. More...
API_RESULT | MS_light_lc_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Lc client model handle. More...
API_RESULT | MS_light_lc_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Light Lc Client APIs.

Macro Definition Documentation

#define MS_light_lc_om_set ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_OM_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE\
)

API to set the Light LC Occupancy Mode state of an element.

Description
The Light LC OM Set is an acknowledged message used to set the Light LC Occupancy Mode state of an element. The response to the Light LC OM Set message is a Light LC OM Status message.
Parameters
[in] param Light LC OM Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 352 of file MS_light_lc_api.h.

#define MS_light_lc_om_set_unacknowledged ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_OM_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light LC Occupancy Mode state of an element.

Description
The Light LC OM Set Unacknowledged is an unacknowledged message used to set the Light LC Occupancy Mode state of an element.
Parameters
[in] param Light LC OM Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 371 of file MS_light_lc_api.h.

#define MS_light_lc_property_set_unacknowledged ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light LC Property state of an element.

Description
The Light LC Property Set Unacknowledged is an unacknowledged message used to set the Light LC Property state of an element.
Parameters
[in] param Light LC Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 390 of file MS_light_lc_api.h.

#define MS_light_lc_property_get ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_PROPERTY_GET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE\
)

API to to get the Light LC Property state of an element.

Description
Light LC Property Get is an acknowledged message used to get the Light LC Property state of an element. The response to the Light LC Property Get message is a Light LC Property Status message.
Parameters
[in] param Light LC Property Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 409 of file MS_light_lc_api.h.

#define MS_light_lc_mode_set ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_MODE_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE\
)

API to set the Light LC Mode state of an element.

Description
The Light LC Mode Set is an acknowledged message used to set the Light LC Mode state of an element. The response to the Light LC Mode Set message is a Light LC Mode Status message.
Parameters
[in] param Light LC Mode Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 428 of file MS_light_lc_api.h.

#define MS_light_lc_mode_get ( )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_MODE_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE\
)

API to get the Light LC Mode state of an element.

Description
Light LC Mode Get is an acknowledged message used to get the Light LC Mode state of an element. The response to the Light LC Mode Get message is a Light LC Mode Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 446 of file MS_light_lc_api.h.

#define MS_light_lc_property_set ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_PROPERTY_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE\
)

API to set the Light LC Property state of an element.

Description
The Light LC Property Set is an acknowledged message used to set the Light LC Property state of an element. The response to the Light LC Property Set message is a Light LC Property Status message.
Parameters
[in] param Light LC Property Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 465 of file MS_light_lc_api.h.

#define MS_light_lc_om_get ( )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_OM_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE\
)

API to get the Light LC Occupancy Mode state of an element.

Description
Light LC OM Get is an acknowledged message used to get the Light LC Occupancy Mode state of an element. The response to the Light LC OM Get message is a Light LC OM Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 483 of file MS_light_lc_api.h.

#define MS_light_lc_light_onoff_set_unacknowledged ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light LC Light OnOff state of an element.

Description
The Light LC Light OnOff Set Unacknowledged is an unacknowledged message used to set the Light LC Light OnOff state of an element.
Parameters
[in] param Light LC Light OnOff Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 502 of file MS_light_lc_api.h.

#define MS_light_lc_light_onoff_get ( )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE\
)

API to get the Light LC Light OnOff state of an element.

Description
Light LC Light OnOff Get is an acknowledged message used to get the Light LC Light OnOff state of an element. The response to the Light LC Light OnOff Get message is a Light LC Light OnOff Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 520 of file MS_light_lc_api.h.

#define MS_light_lc_light_onoff_set ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE\
)

API to set the Light LC Light OnOff state of an element.

Description
The Light LC Light OnOff Set is an acknowledged message used to set the Light LC Light OnOff state of an element. The response to the Light LC Light OnOff Set message is a Light LC Light OnOff Status message.
Parameters
[in] param Light LC Light OnOff Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 539 of file MS_light_lc_api.h.

#define MS_light_lc_mode_set_unacknowledged ( param )
Value:
MS_light_lc_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LC_MODE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light LC Mode state of an element.

Description
The Light LC Mode Set Unacknowledged is an unacknowledged message used to set the Light LC Mode state of an element.
Parameters
[in] param Light LC Mode Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 558 of file MS_light_lc_api.h.

Function Documentation

API_RESULT MS_light_lc_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_LC_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Light_Lc Client model.

Description
This is to initialize Light_Lc Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Lc Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lc_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Light_Lc client model handle.

Description
This is to get the handle of Light_Lc client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lc_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Light Lc Server API Definitions

Functions
Light Lc Server API Definitions
API Definitions

This section describes the Light Lc Server APIs. More...

Functions

API_RESULT | MS_light_lc_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *lc_model_handle, MS_ACCESS_MODEL_HANDLE *lc_setup_model_handle, MS_LIGHT_LC_SERVER_CB appl_cb)
API to initialize Light_Lc Server model. More...
API_RESULT | MS_light_lc_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Light Lc Server APIs.

Function Documentation

API_RESULT MS_light_lc_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | lc_model_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | lc_setup_model_handle,
 |  | MS_LIGHT_LC_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Lc Server model.

Description
This is to initialize Light_Lc Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | lc_model_handle | Model identifier associated with the Light LC model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in,out] | lc_setup_model_handle | Model identifier associated with the Light LC Setup model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Lc Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lc_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
LIGHT_LC (Mesh Light Lc Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_LC_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Lc Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_LC_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Lc Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_LIGHT_LC_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Lc Server application Asynchronous Notification Callback.

Light Lc Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_light_lc_api.h.

typedef API_RESULT(* MS_LIGHT_LC_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Light Lc Client application Asynchronous Notification Callback.

Light Lc Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_light_lc_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
LIGHT_LC (Mesh Light Lc Model)

Data Structures

struct | MS_LIGHT_LC_MODE_STRUCT
Light LC Mode Set/Status message parameters. More...
struct | MS_LIGHT_LC_OM_STRUCT
struct | MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT
Light LC Light OnOff Set message parameters. More...
struct | MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT
Light LC Light OnOff Status message parameters. More...
struct | MS_LIGHT_LC_PROPERTY_GET_STRUCT
Light LC Property Get message parameters. More...
struct | MS_LIGHT_LC_PROPERTY_SET_STRUCT
Light LC Property Set message parameters. More...
struct | MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
Light LC Property Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_LIGHT_LC_MODE_STRUCT Struct Reference

Data Fields
MS_LIGHT_LC_MODE_STRUCT Struct Reference
Structures

Light LC Mode Set/Status message parameters. More...

#include <MS_light_lc_api.h>

Data Fields

UCHAR mode
The target value of the Light LC Mode state.

Detailed Description

Light LC Mode Set/Status message parameters.

Definition at line 89 of file MS_light_lc_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lc_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LC_OM_STRUCT Struct Reference

Data Fields
MS_LIGHT_LC_OM_STRUCT Struct Reference
Structures

Data Fields

UCHAR mode

Detailed Description

Definition at line 96 of file MS_light_lc_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lc_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT Struct Reference
Structures

Light LC Light OnOff Set message parameters. More...

#include <MS_light_lc_api.h>

Data Fields

UCHAR | light_onoff
The target value of the Light LC Light OnOff state.
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light LC Light OnOff Set message parameters.

Definition at line 105 of file MS_light_lc_api.h.

Field Documentation

UCHAR MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 124 of file MS_light_lc_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lc_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT Struct Reference
Structures

Light LC Light OnOff Status message parameters. More...

#include <MS_light_lc_api.h>

Data Fields

UCHAR | present_light_onoff
The present value of the Light LC Light OnOff state.
UCHAR | target_light_onoff
The target value of the Light LC Light OnOff state (Optional)
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target LC Light OnOff and Remaining Time are valid.

Detailed Description

Light LC Light OnOff Status message parameters.

Definition at line 137 of file MS_light_lc_api.h.

Field Documentation

UCHAR MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 156 of file MS_light_lc_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lc_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LC_PROPERTY_GET_STRUCT Struct Reference

Data Fields
MS_LIGHT_LC_PROPERTY_GET_STRUCT Struct Reference
Structures

Light LC Property Get message parameters. More...

#include <MS_light_lc_api.h>

Data Fields

UINT16 light_lc_property_id
Property ID identifying a Light LC Property. More...

Detailed Description

Light LC Property Get message parameters.

Definition at line 166 of file MS_light_lc_api.h.

Field Documentation

UINT16 MS_LIGHT_LC_PROPERTY_GET_STRUCT::light_lc_property_id

Property ID identifying a Light LC Property.

Definition at line 169 of file MS_light_lc_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lc_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LC_PROPERTY_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_LC_PROPERTY_SET_STRUCT Struct Reference
Structures

Light LC Property Set message parameters. More...

#include <MS_light_lc_api.h>

Data Fields

UINT16 | light_lc_property_id
Property ID identifying a Light LC Property. More...
UCHAR * | light_lc_property_value
Raw value for the Light LC Property.
UINT16 | light_lc_property_value_len
Raw value length for the Light LC Property.

Detailed Description

Light LC Property Set message parameters.

Definition at line 176 of file MS_light_lc_api.h.

Field Documentation

UINT16 MS_LIGHT_LC_PROPERTY_SET_STRUCT::light_lc_property_id

Property ID identifying a Light LC Property.

Definition at line 179 of file MS_light_lc_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lc_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LC_PROPERTY_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LC_PROPERTY_STATUS_STRUCT Struct Reference
Structures

Light LC Property Status message parameters. More...

#include <MS_light_lc_api.h>

Data Fields

UINT16 | light_lc_property_id
Property ID identifying a Light LC Property. More...
UCHAR * | light_lc_property_value
Raw value for the Light LC Property.
UINT16 | light_lc_property_value_len
Raw value length for the Light LC Property.

Detailed Description

Light LC Property Status message parameters.

Definition at line 192 of file MS_light_lc_api.h.

Field Documentation

UINT16 MS_LIGHT_LC_PROPERTY_STATUS_STRUCT::light_lc_property_id

Property ID identifying a Light LC Property.

Definition at line 195 of file MS_light_lc_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lc_api.h


EtherMind Mesh SDK (beta): LIGHT_LIGHTNESS (Mesh Light Lightness Model)

Modules
LIGHT_LIGHTNESS (Mesh Light Lightness Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Light Lightness Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
LIGHT_LIGHTNESS (Mesh Light Lightness Model)

This section describes the EtherMind Mesh Light Lightness Model APIs. More...

Modules

Light Lightness Client API Definitions
This section describes the Light Lightness Client APIs.
Light Lightness Server API Definitions
This section describes the Light Lightness Server APIs.

Detailed Description

This section describes the EtherMind Mesh Light Lightness Model APIs.


EtherMind Mesh SDK (beta): Light Lightness Client API Definitions

Macros | Functions
Light Lightness Client API Definitions
API Definitions

This section describes the Light Lightness Client APIs. More...

Macros

#define | MS_light_lightness_range_get()
API to get the Light Lightness Range state of an element. More...
#define | MS_light_lightness_linear_set_unacknowledged(param)
API to set the Light Lightness Linear state of an element. More...
#define | MS_light_lightness_last_get()
API to get the Light Lightness Last state of an element. More...
#define | MS_light_lightness_range_set_unacknowledged(param)
API to acknowledged message used to set the Light Lightness Range state of an element. More...
#define | MS_light_lightness_default_set_unacknowledged(param)
API to set the Light Lightness Default state of an element. More...
#define | MS_light_lightness_get()
API to get the Light Lightness Actual state of an element. More...
#define | MS_light_lightness_default_set(param)
API to set the Light Lightness Default state of an element. More...
#define | MS_light_lightness_default_get()
API to get the Light Lightness Default state of an element. More...
#define | MS_light_lightness_linear_get()
API to get the Light Lightness Linear state of an element. More...
#define | MS_light_lightness_linear_set(param)
API to set the Light Lightness Linear state of an element. More...
#define | MS_light_lightness_set(param)
API to set the Light Lightness Actual state of an element. More...
#define | MS_light_lightness_range_set(param)
API to acknowledged message used to set the Light Lightness Range state of an element. More...
#define | MS_light_lightness_set_unacknowledged(param)
API to set the Light Lightness Actual state of an element. More...

Functions

API_RESULT | MS_light_lightness_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LIGHTNESS_CLIENT_CB appl_cb)
API to initialize Light_Lightness Client model. More...
API_RESULT | MS_light_lightness_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Lightness client model handle. More...
API_RESULT | MS_light_lightness_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Light Lightness Client APIs.

Macro Definition Documentation

#define MS_light_lightness_range_get ( )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_RANGE_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE\
)

API to get the Light Lightness Range state of an element.

Description
The Light Lightness Range Get is an acknowledged message used to get the Light Lightness Range state of an element. The response to the Light Lightness Range Get message is a Light Lightness Range Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 483 of file MS_light_lightness_api.h.

#define MS_light_lightness_linear_set_unacknowledged ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light Lightness Linear state of an element.

Description
The Light Lightness Linear Set Unacknowledged is an unacknowledged message used to set the Light Lightness Linear state of an element.
Parameters
[in] param Light Lightness Linear Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 502 of file MS_light_lightness_api.h.

#define MS_light_lightness_last_get ( )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_LAST_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LIGHTNESS_LAST_STATUS_OPCODE\
)

API to get the Light Lightness Last state of an element.

Description
Light Lightness Last Get is an acknowledged message used to get the Light Lightness Last state of an element. The response to the Light Lightness Last Get message is a Light Lightness Last Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 520 of file MS_light_lightness_api.h.

#define MS_light_lightness_range_set_unacknowledged ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to acknowledged message used to set the Light Lightness Range state of an element.

Description
Light Lightness Range Set Unacknowledged is an unacknowledged message used to set the Light Lightness Range state of an element.
Parameters
[in] param Light Lightness Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 539 of file MS_light_lightness_api.h.

#define MS_light_lightness_default_set_unacknowledged ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light Lightness Default state of an element.

Description
The Light Lightness Default Set Unacknowledged is an unacknowledged message used to set the Light Lightness Default state of an element.
Parameters
[in] param Light Lightness Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 558 of file MS_light_lightness_api.h.

#define MS_light_lightness_get ( )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE\
)

API to get the Light Lightness Actual state of an element.

Description
Light Lightness Get is an acknowledged message used to get the Light Lightness Actual state of an element. The response to the Light Lightness Get message is a Light Lightness Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 576 of file MS_light_lightness_api.h.

#define MS_light_lightness_default_set ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE\
)

API to set the Light Lightness Default state of an element.

Description
The Light Lightness Default Set is an acknowledged message used to set the Light Lightness Default state of an element. The response to the Light Lightness Default Set message is a Light Lightness Default Status message.
Parameters
[in] param Light Lightness Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 595 of file MS_light_lightness_api.h.

#define MS_light_lightness_default_get ( )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE\
)

API to get the Light Lightness Default state of an element.

Description
Light Lightness Default Get is an acknowledged message used to get the Light Lightness Default state of an element. The response to the Light Lightness Default Get message is a Light Lightness Default Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 613 of file MS_light_lightness_api.h.

#define MS_light_lightness_linear_get ( )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE\
)

API to get the Light Lightness Linear state of an element.

Description
Light Lightness Linear Get is an acknowledged message used to get the Light Lightness Linear state of an element. The response to the Light Lightness Linear Get message is a Light Lightness Linear Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 631 of file MS_light_lightness_api.h.

#define MS_light_lightness_linear_set ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE\
)

API to set the Light Lightness Linear state of an element.

Description
The Light Lightness Linear Set is an acknowledged message used to set the Light Lightness Linear state of an element. The response to the Light Lightness Linear Set message is a Light Lightness Linear Status message.
Parameters
[in] param Light Lightness Linear Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 650 of file MS_light_lightness_api.h.

#define MS_light_lightness_set ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE\
)

API to set the Light Lightness Actual state of an element.

Description
The Light Lightness Set is an acknowledged message used to set the Light Lightness Actual state of an element. The response to the Light Lightness Set message is a Light Lightness Status message.
Parameters
[in] param Light Lightness Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 669 of file MS_light_lightness_api.h.

#define MS_light_lightness_range_set ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE\
)

API to acknowledged message used to set the Light Lightness Range state of an element.

Description
Light Lightness Range Set is an acknowledged message used to set the Light Lightness Range state of an element. The response to the Light Lightness Range Get message is a Light Lightness Range Status message.
Parameters
[in] param Light Lightness Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 688 of file MS_light_lightness_api.h.

#define MS_light_lightness_set_unacknowledged ( param )
Value:
MS_light_lightness_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_LIGHTNESS_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light Lightness Actual state of an element.

Description
The Light Lightness Set Unacknowledged is an unacknowledged message used to set the Light Lightness Actual state of an element.
Parameters
[in] param Light Lightness Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 707 of file MS_light_lightness_api.h.

Function Documentation

API_RESULT MS_light_lightness_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_LIGHTNESS_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Light_Lightness Client model.

Description
This is to initialize Light_Lightness Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Lightness Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lightness_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Light_Lightness client model handle.

Description
This is to get the handle of Light_Lightness client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lightness_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Light Lightness Server API Definitions

Functions
Light Lightness Server API Definitions
API Definitions

This section describes the Light Lightness Server APIs. More...

Functions

API_RESULT | MS_light_lightness_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LIGHTNESS_SERVER_CB appl_cb)
API to initialize Light_Lightness Server model. More...
API_RESULT | MS_light_lightness_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB appl_cb)
API to initialize Light_Lightness_Setup Server model. More...
API_RESULT | MS_light_lightness_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_lightness_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Light Lightness Server APIs.

Function Documentation

API_RESULT MS_light_lightness_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_LIGHTNESS_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Lightness Server model.

Description
This is to initialize Light_Lightness Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Lightness Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lightness_setup_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Lightness_Setup Server model.

Description
This is to initialize Light_Lightness_Setup Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Lightness_Setup Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lightness_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_lightness_setup_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
LIGHT_LIGHTNESS (Mesh Light Lightness Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_LIGHTNESS_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Lightness Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Lightness Setup Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_LIGHTNESS_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Lightness Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_LIGHT_LIGHTNESS_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Lightness Server application Asynchronous Notification Callback.

Light Lightness Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_light_lightness_api.h.

typedef API_RESULT(* MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Lightness Setup Server application Asynchronous Notification Callback.

Light Lightness Setup Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 74 of file MS_light_lightness_api.h.

typedef API_RESULT(* MS_LIGHT_LIGHTNESS_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Light Lightness Client application Asynchronous Notification Callback.

Light Lightness Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 95 of file MS_light_lightness_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
LIGHT_LIGHTNESS (Mesh Light Lightness Model)

Data Structures

struct | MS_LIGHT_LIGHTNESS_SET_STRUCT
Light Lightness Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_STATUS_STRUCT
Light Lightness Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT
Light Lightness Linear Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT
Light Lightness Linear Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT
Light Lightness Last Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT
Light Lightness Default Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT
Light Lightness Range Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT
Light Lightness Range Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT
Light Lightness Default Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LAST_OR_DEFAULT_STATUS_STRUCT

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_SET_STRUCT Struct Reference
Structures

Light Lightness Set message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 | lightness
The target value of the Light Lightness Actual state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light Lightness Set message parameters.

Definition at line 111 of file MS_light_lightness_api.h.

Field Documentation

UINT16 MS_LIGHT_LIGHTNESS_SET_STRUCT::lightness

The target value of the Light Lightness Actual state.

Definition at line 114 of file MS_light_lightness_api.h.

UCHAR MS_LIGHT_LIGHTNESS_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 130 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_STATUS_STRUCT Struct Reference
Structures

Light Lightness Status message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 | present_lightness
The present value of the Light Lightness Actual state. More...
UINT16 | target_lightness
The target value of the Light Lightness Actual state. More...
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target Light Lightness Actual and Remaining Time are valid.

Detailed Description

Light Lightness Status message parameters.

Definition at line 143 of file MS_light_lightness_api.h.

Field Documentation

UINT16 MS_LIGHT_LIGHTNESS_STATUS_STRUCT::present_lightness

The present value of the Light Lightness Actual state.

Definition at line 146 of file MS_light_lightness_api.h.

UINT16 MS_LIGHT_LIGHTNESS_STATUS_STRUCT::target_lightness

The target value of the Light Lightness Actual state.

(Optional)

Definition at line 149 of file MS_light_lightness_api.h.

UCHAR MS_LIGHT_LIGHTNESS_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 162 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT Struct Reference
Structures

Light Lightness Linear Set message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 | lightness
The target value of the Light Lightness Linear state. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light Lightness Linear Set message parameters.

Definition at line 172 of file MS_light_lightness_api.h.

Field Documentation

UINT16 MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT::lightness

The target value of the Light Lightness Linear state.

Definition at line 175 of file MS_light_lightness_api.h.

UCHAR MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 191 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT Struct Reference
Structures

Light Lightness Linear Status message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 | present_lightness
The present value of the Light Lightness Linear state.
UINT16 | target_lightness
The target value of the Light Lightness Linear state (Optional)
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target Light Lightness Linear and Remaining Time are valid.

Detailed Description

Light Lightness Linear Status message parameters.

Definition at line 204 of file MS_light_lightness_api.h.

Field Documentation

UCHAR MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 223 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT Struct Reference
Structures

Light Lightness Last Status message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 lightness
The value of the Light Lightness Last.

Detailed Description

Light Lightness Last Status message parameters.

Definition at line 233 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT Struct Reference
Structures

Light Lightness Default Set message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 lightness
The value of the Light Lightness Default state.

Detailed Description

Light Lightness Default Set message parameters.

Definition at line 243 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT Struct Reference
Structures

Light Lightness Range Set message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 | range_min
The value of the Lightness Range Min field of the Light Lightness Range state.
UINT16 | range_max
The value of the Lightness Range Max field of the Light Lightness Range state.

Detailed Description

Light Lightness Range Set message parameters.

Definition at line 253 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT Struct Reference
Structures

Light Lightness Range Status message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UCHAR | status_code
Status Code for the requesting message. More...
UINT16 | range_min
The value of the Lightness Range Min field of the Light Lightness Range state.
UINT16 | range_max
The value of the Lightness Range Max field of the Light Lightness Range state.

Detailed Description

Light Lightness Range Status message parameters.

Definition at line 266 of file MS_light_lightness_api.h.

Field Documentation

UCHAR MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT::status_code

Status Code for the requesting message.

Definition at line 269 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT Struct Reference
Structures

Light Lightness Default Status message parameters. More...

#include <MS_light_lightness_api.h>

Data Fields

UINT16 lightness
The value of the Light Lightness Default state.

Detailed Description

Light Lightness Default Status message parameters.

Definition at line 282 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_LIGHTNESS_LAST_OR_DEFAULT_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_LIGHTNESS_LAST_OR_DEFAULT_STATUS_STRUCT Struct Reference
Structures

Data Fields

UINT16 lightness

Detailed Description

Definition at line 289 of file MS_light_lightness_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_lightness_api.h


EtherMind Mesh SDK (beta): LIGHT_XYL (Mesh Light Xyl Model)

Modules
LIGHT_XYL (Mesh Light Xyl Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Light Xyl Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
LIGHT_XYL (Mesh Light Xyl Model)

This section describes the EtherMind Mesh Light Xyl Model APIs. More...

Modules

Light Xyl Client API Definitions
This section describes the Light Xyl Client APIs.
Light Xyl Server API Definitions
This section describes the Light Xyl Server APIs.

Detailed Description

This section describes the EtherMind Mesh Light Xyl Model APIs.


EtherMind Mesh SDK (beta): Light Xyl Client API Definitions

Macros | Functions
Light Xyl Client API Definitions
API Definitions

This section describes the Light Xyl Client APIs. More...

Macros

#define | MS_light_xyl_default_set(param)
API to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. More...
#define | MS_light_xyl_set_unacknowledged(param)
API to set the Light xyL Lightness, Light xyL x state, and the Light xyL y states of an element. More...
#define | MS_light_xyl_range_get()
API to get the Light xyL x Range and Light xyL y Range states of an element. More...
#define | MS_light_xyl_set(param)
API to set the Light xyL Lightness, Light xyL x state, and the Light xyL y states of an element. More...
#define | MS_light_xyl_default_get()
API to get the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. More...
#define | MS_light_xyl_range_set_unacknowledged(param)
API to set the Light xyL x Range and Light xyL y Range states of an element. More...
#define | MS_light_xyl_get()
API to get the Light xyL Lightness, Light xyL x, and Light xyL y states of an element. More...
#define | MS_light_xyl_default_set_unacknowledged(param)
API to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. More...
#define | MS_light_xyl_target_get()
API to get the target Light xyL Lightness, Light xyL x, and Light xyL y states of an element. More...
#define | MS_light_xyl_range_set(param)
API to set the Light xyL x Range and Light xyL y Range states of an element. More...

Functions

API_RESULT | MS_light_xyl_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_XYL_CLIENT_CB appl_cb)
API to initialize Light_Xyl Client model. More...
API_RESULT | MS_light_xyl_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Xyl client model handle. More...
API_RESULT | MS_light_xyl_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Light Xyl Client APIs.

Macro Definition Documentation

#define MS_light_xyl_default_set ( param )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_DEFAULT_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE\
)

API to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element.

Description
Light xyL Default Set is an acknowledged message used to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. The response to the Light xyL Default Set message is a Light xyL Default Status message.
Parameters
[in] param Light HSL Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 408 of file MS_light_xyl_api.h.

#define MS_light_xyl_set_unacknowledged ( param )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light xyL Lightness, Light xyL x state, and the Light xyL y states of an element.

Description
The Light xyL Set Unacknowledged is an unacknowledged message used to set the Light xyL Lightness, Light xyL x, and the Light xyL y states of an element.
Parameters
[in] param Light xyL Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 428 of file MS_light_xyl_api.h.

#define MS_light_xyl_range_get ( )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_RANGE_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE\
)

API to get the Light xyL x Range and Light xyL y Range states of an element.

Description
The Light xyL Range Get is an acknowledged message used to get the Light xyL x Range and Light xyL y Range states of an element. The response to the Light xyL Range Get message is a Light xyL Range Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 446 of file MS_light_xyl_api.h.

#define MS_light_xyl_set ( param )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_XYL_STATUS_OPCODE\
)

API to set the Light xyL Lightness, Light xyL x state, and the Light xyL y states of an element.

Description
The Light xyL Set is an acknowledged message used to set the Light xyL Lightness, Light xyL x state, and the Light xyL y states of an element. The response to the Light xyL Set message is a Light xyL Status message.
Parameters
[in] param Light xyL Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 465 of file MS_light_xyl_api.h.

#define MS_light_xyl_default_get ( )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_DEFAULT_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE\
)

API to get the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element.

Description
Light xyL Default Get is an acknowledged message used to get the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. The response to the Light xyL Default Get message is a Light xyL Default Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 483 of file MS_light_xyl_api.h.

#define MS_light_xyl_range_set_unacknowledged ( param )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light xyL x Range and Light xyL y Range states of an element.

Description
Light xyL Range Set Unacknowledged is an unacknowledged message used to set the Light xyL x Range and Light xyL y Range states of an element.
Parameters
[in] param Light xyL Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 502 of file MS_light_xyl_api.h.

#define MS_light_xyl_get ( )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_XYL_STATUS_OPCODE\
)

API to get the Light xyL Lightness, Light xyL x, and Light xyL y states of an element.

Description
The Light xyL Get is an acknowledged message used to get the Light xyL Lightness, Light xyL x, and Light xyL y states of an element. Upon receiving a Light xyL Get message, the element shall respond with a Light xyL Status message. The response to the Light xyL Get message is a Light xyL Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 522 of file MS_light_xyl_api.h.

#define MS_light_xyl_default_set_unacknowledged ( param )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element.

Description
Light xyL Default Set Unacknowledged is an unacknowledged message used to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element.
Parameters
[in] param Light HSL Default Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 542 of file MS_light_xyl_api.h.

#define MS_light_xyl_target_get ( )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_TARGET_GET_OPCODE,\
NULL,\
MS_ACCESS_LIGHT_XYL_TARGET_STATUS_OPCODE\
)

API to get the target Light xyL Lightness, Light xyL x, and Light xyL y states of an element.

Description
The Light xyL Target Get is an acknowledged message used to get the target Light xyL Lightness, Light xyL x, and Light xyL y states of an element. The response to the Light xyL Target Get message is a Light xyL Target Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 560 of file MS_light_xyl_api.h.

#define MS_light_xyl_range_set ( param )
Value:
MS_light_xyl_client_send_reliable_pdu \
(\
MS_ACCESS_LIGHT_XYL_RANGE_SET_OPCODE,\
param,\
MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE\
)

API to set the Light xyL x Range and Light xyL y Range states of an element.

Description
Light xyL Range Set is an acknowledged message used to set the Light xyL x Range and Light xyL y Range states of an element. The response to the Light xyL Range Set message is a Light xyL Range Status message.
Parameters
[in] param Light xyL Range Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 579 of file MS_light_xyl_api.h.

Function Documentation

API_RESULT MS_light_xyl_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_LIGHT_XYL_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Light_Xyl Client model.

Description
This is to initialize Light_Xyl Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Xyl Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_xyl_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Light_Xyl client model handle.

Description
This is to get the handle of Light_Xyl client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_xyl_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Light Xyl Server API Definitions

Functions
Light Xyl Server API Definitions
API Definitions

This section describes the Light Xyl Server APIs. More...

Functions

API_RESULT | MS_light_xyl_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *xyl_model_handle, MS_ACCESS_MODEL_HANDLE *xyl_setup_model_handle, MS_LIGHT_XYL_SERVER_CB appl_cb)
API to initialize Light_Xyl Server model. More...
API_RESULT | MS_light_xyl_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Light Xyl Server APIs.

Function Documentation

API_RESULT MS_light_xyl_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | xyl_model_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | xyl_setup_model_handle,
 |  | MS_LIGHT_XYL_SERVER_CB | appl_cb
 | ) |  |

API to initialize Light_Xyl Server model.

Description
This is to initialize Light_Xyl Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | xyl_model_handle | Model identifier associated with the Light xyl model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in,out] | xyl_setup_model_handle | Model identifier associated with the Light xyl Setup model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Light_Xyl Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_light_xyl_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
LIGHT_XYL (Mesh Light Xyl Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_XYL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Xyl Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_XYL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Xyl Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_LIGHT_XYL_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Light Xyl Server application Asynchronous Notification Callback.

Light Xyl Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_light_xyl_api.h.

typedef API_RESULT(* MS_LIGHT_XYL_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Light Xyl Client application Asynchronous Notification Callback.

Light Xyl Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_light_xyl_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
LIGHT_XYL (Mesh Light Xyl Model)

Data Structures

struct | MS_LIGHT_XYL_SET_STRUCT
Light xyL Set message parameters. More...
struct | MS_LIGHT_XYL_STATUS_STRUCT
Light xyL Status Unacknowledged message parameters. More...
struct | MS_LIGHT_XYL_TARGET_STATUS_STRUCT
Light xyL Target Status Unacknowledged message parameters. More...
struct | MS_LIGHT_XYL_DEFAULT_SET_STRUCT
Light HSL Default Set message parameters. More...
struct | MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT
Light xyL Default Status message parameters. More...
struct | MS_LIGHT_XYL_RANGE_SET_STRUCT
Light xyL Range Set message parameters. More...
struct | MS_LIGHT_XYL_RANGE_STATUS_STRUCT
Light xyL Range Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_LIGHT_XYL_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_XYL_SET_STRUCT Struct Reference
Structures

Light xyL Set message parameters. More...

#include <MS_light_xyl_api.h>

Data Fields

UINT16 | xyl_lightness
The target value of the Light xyL Lightness state.
UINT16 | xyl_x
The target value of the Light xyL x state.
UINT16 | xyl_y
The target value of the Light xyL y state.
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Light xyL Set message parameters.

Definition at line 89 of file MS_light_xyl_api.h.

Field Documentation

UCHAR MS_LIGHT_XYL_SET_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 114 of file MS_light_xyl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_xyl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_XYL_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_XYL_STATUS_STRUCT Struct Reference
Structures

Light xyL Status Unacknowledged message parameters. More...

#include <MS_light_xyl_api.h>

Data Fields

UINT16 | xyl_lightness
The present value of the Light xyL Lightness state.
UINT16 | xyl_x
The present value of the Light xyL x state.
UINT16 | xyl_y
The present value of the Light xyL y state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional field Remaining Time is valid.

Detailed Description

Light xyL Status Unacknowledged message parameters.

Definition at line 127 of file MS_light_xyl_api.h.

Field Documentation

UCHAR MS_LIGHT_XYL_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 149 of file MS_light_xyl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_xyl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_XYL_TARGET_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_XYL_TARGET_STATUS_STRUCT Struct Reference
Structures

Light xyL Target Status Unacknowledged message parameters. More...

#include <MS_light_xyl_api.h>

Data Fields

UINT16 | target_xyl_lightness
The target value of the Light xyL Lightness state.
UINT16 | target_xyl_x
The target value of the Light xyL x state.
UINT16 | target_xyl_y
The target value of the Light xyL y state.
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional field Remaining Time is valid.

Detailed Description

Light xyL Target Status Unacknowledged message parameters.

Definition at line 159 of file MS_light_xyl_api.h.

Field Documentation

UCHAR MS_LIGHT_XYL_TARGET_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 181 of file MS_light_xyl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_xyl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_XYL_DEFAULT_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_XYL_DEFAULT_SET_STRUCT Struct Reference
Structures

Light HSL Default Set message parameters. More...

#include <MS_light_xyl_api.h>

Data Fields

UINT16 | lightness
The value of the Light Lightness Default state.
UINT16 | xyl_x
The value of the Light xyL x Default state.
UINT16 | xyl_y
The value of the Light xyL y Default state.

Detailed Description

Light HSL Default Set message parameters.

Definition at line 191 of file MS_light_xyl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_xyl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT Struct Reference
Structures

Light xyL Default Status message parameters. More...

#include <MS_light_xyl_api.h>

Data Fields

UINT16 | lightness
The value of the Light Lightness Default state.
UINT16 | xyl_x
The value of the Light xyL x Default state.
UINT16 | xyl_y
The value of the Light xyL y Default state.

Detailed Description

Light xyL Default Status message parameters.

Definition at line 207 of file MS_light_xyl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_xyl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_XYL_RANGE_SET_STRUCT Struct Reference

Data Fields
MS_LIGHT_XYL_RANGE_SET_STRUCT Struct Reference
Structures

Light xyL Range Set message parameters. More...

#include <MS_light_xyl_api.h>

Data Fields

UINT16 | xyl_x_range_min
The value of the xyL x Range Min field of the Light xyL x Range state.
UINT16 | xyl_x_range_max
The value of the xyL x Range Max field of the Light xyL x Range state.
UINT16 | xyl_y_range_min
The value of the xyL y Range Min field of the Light xyL y Range state.
UINT16 | xyl_y_range_max
The value of the xyL y Range Max field of the Light xyL y Range state.

Detailed Description

Light xyL Range Set message parameters.

Definition at line 223 of file MS_light_xyl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_xyl_api.h


EtherMind Mesh SDK (beta): MS_LIGHT_XYL_RANGE_STATUS_STRUCT Struct Reference

Data Fields
MS_LIGHT_XYL_RANGE_STATUS_STRUCT Struct Reference
Structures

Light xyL Range Status message parameters. More...

#include <MS_light_xyl_api.h>

Data Fields

UCHAR | status_code
Status Code for the requesting message. More...
UINT16 | xyl_x_range_min
The value of the xyL x Range Min field of the Light xyL x Range state.
UINT16 | xyl_x_range_max
The value of the xyL x Range Max field of the Light xyL x Range state.
UINT16 | xyl_y_range_min
The value of the xyL y Range Min field of the Light xyL y Range state.
UINT16 | xyl_y_range_max
The value of the xyL y Range Max field of the Light xyL y Range state.

Detailed Description

Light xyL Range Status message parameters.

Definition at line 242 of file MS_light_xyl_api.h.

Field Documentation

UCHAR MS_LIGHT_XYL_RANGE_STATUS_STRUCT::status_code

Status Code for the requesting message.

Definition at line 245 of file MS_light_xyl_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_light_xyl_api.h


EtherMind Mesh SDK (beta): LTRANSPORT (Mesh Lower Transport Layer)

Modules
LTRANSPORT (Mesh Lower Transport Layer)

This section describes the interfaces & APIs offered by the EtherMind Mesh Lower Transport (LTRANSPORT) module to the Application and other upper layers of the stack. More...

Modules

API Definitions
TCF (Transport Control Field) - Transport Field Value.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Defines
Describes defines for the module.
Utility Macros
Initialization and other Utility Macros offered by the module.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Lower Transport (LTRANSPORT) module to the Application and other upper layers of the stack.


EtherMind Mesh SDK (beta): API Definitions

Functions
API Definitions
LTRANSPORT (Mesh Lower Transport Layer)

TCF (Transport Control Field) - Transport Field Value. More...

Functions

API_RESULT | MS_ltrn_register (LTRN_NTF_CB ltrn_cb)
Register Inerface with Lower Transport Layer. More...
API_RESULT | MS_ltrn_send_pdu (MS_NET_ADDR src_addr, MS_NET_ADDR dst_addr, MS_SUBNET_HANDLE subnet_handle, MS_TRN_MSG_TYPE msg_type, UINT8 ttl, UINT8 akf, UINT8 aid, UINT16 seq_zero, UCHAR *buffer, UINT16 buffer_len)
API to send transport PDUs. More...

Detailed Description

TCF (Transport Control Field) - Transport Field Value.

This section describes the EtherMind Mesh Lower Transport Layer APIs.

Function Documentation

API_RESULT MS_ltrn_register ( LTRN_NTF_CB ltrn_cb )

Register Inerface with Lower Transport Layer.

Description
This routine registers interface with the Lower Transport Layer. Transport Layer supports single Application, hence this rouine shall be called once.
Parameters
[in] ltrn_cb Upper Layer Notification Callback
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_ltrn_send_pdu | ( | MS_NET_ADDR | src_addr,
 |  | MS_NET_ADDR | dst_addr,
 |  | MS_SUBNET_HANDLE | subnet_handle,
 |  | MS_TRN_MSG_TYPE | msg_type,
 |  | UINT8 | ttl,
 |  | UINT8 | akf,
 |  | UINT8 | aid,
 |  | UINT16 | seq_zero,
 |  | UCHAR * | buffer,
 |  | UINT16 | buffer_len
 | ) |  |

API to send transport PDUs.

Description
This routine sends transport PDUs to peer device.
Parameters
[in] | src_addr | Source Address
[in] | dst_addr | Destination Address
[in] | subnet_handle | Handle identifying the Subnet
[in] | msg_type | Transport Message Type
[in] | ttl | Time to Live
[in] | akf | Application Key Flag
[in] | aid | Application Key Identifier
[in] | seq_zero | Least significant bits of SeqAuth (13 bit value)
[in] | buffer | Transport Packet
[in] | buffer_len | Transport Packet Length
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
LTRANSPORT (Mesh Lower Transport Layer)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* LTRN_NTF_CB )(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, UCHAR szmic, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Lower TRANSPORT Application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* LTRN_NTF_CB)(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, UCHAR szmic, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Lower TRANSPORT Application Asynchronous Notification Callback.

Lower TRANSPORT calls the registered callback to indicate events occurred to the application.

Parameters
net_hdr | Network Header.
subnet_handle | Associated Subnet Handle.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 121 of file MS_ltrn_api.h.


EtherMind Mesh SDK (beta): Defines

Modules
Defines
LTRANSPORT (Mesh Lower Transport Layer)

Describes defines for the module. More...

Modules

Constants
Describes Constants defined by the module.
Events
This section lists the Asynchronous Events notified to Application by the Module.
Structures

Detailed Description

Describes defines for the module.


EtherMind Mesh SDK (beta): Constants

Macros | Typedefs
Constants
Defines

Describes Constants defined by the module. More...

Macros

#define | MS_UNSEGMENTED_ACCESS_MSG 0x00
Unsgemented Access Message.
#define | MS_SEGMENTED_ACCESS_MSG 0x01
Segmented Access Message.
#define | MS_UNSEGMENTED_CTRL_MSG 0x02
Unsegmented Control Message.
#define | MS_SEGMENTED_CTRL_MSG 0x03
Segmented Control Message.
#define | MS_TRN_CTRL_PKT 0x01
Transport Layer Control Packet.
#define | MS_TRN_ACCESS_PKT 0x00
Access Layer Packet.

Typedefs

typedef UCHAR MS_TRN_MSG_TYPE
Transport Message Type.

Detailed Description

Describes Constants defined by the module.


EtherMind Mesh SDK (beta): Events

Events
Defines

This section lists the Asynchronous Events notified to Application by the Module. More...

This section lists the Asynchronous Events notified to Application by the Module.


EtherMind Mesh SDK (beta): Structures

Typedefs
Structures
Defines

Typedefs

typedef UINT8 LPN_HANDLE
LPN Handle.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Utility Macros

Utility Macros
LTRANSPORT (Mesh Lower Transport Layer)

Initialization and other Utility Macros offered by the module. More...

Initialization and other Utility Macros offered by the module.


EtherMind Mesh SDK (beta): MESH Common

Modules | Variables
MESH Common

Modules

API Definitions
Constants
Defines
Utility Macros

Variables

MS_CONFIG ms_global_config

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): API Definitions

Functions
API Definitions
MESH Common

Functions

void | MS_init (void *blob)
API to initialize Mesh Stack. More...
API_RESULT | MS_shutdown (void)
API to turn off Bluetooth Hardware. More...
API_RESULT | MS_common_start_transition_timer (MS_ACCESS_STATE_TRANSITION_TYPE *transition, UINT16 *transition_time_handle)
To start transition timer. More...
API_RESULT | MS_common_stop_transition_timer (UINT16 transition_time_handle)
To stop transition timer. More...
API_RESULT | MS_common_get_transition_time_from_ms (UINT32 transition_time_in_ms, UINT8 *transition_time)
To convert transition time from milisecond. More...

Detailed Description

Function Documentation

void MS_init ( void * blob )

API to initialize Mesh Stack.

This is the first API that the application should call before any other API. This function initializes all the internal stack modules and creates necessary tasks.

Note
To initialize Mesh Stack.
Description
API to initialize Mesh Stack. This is the first API that the application should call before any other API. This function initializes all the internal stack modules and data structures.
Parameters
[in] blob If 'MS_HAVE_DYNAMIC_CONFIG' defined, application shall provide the desired dynamic configuration using a pointer to MS_CONFIG data structure instance. else, this parameter shall be NULL and ignored by the API.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_shutdown ( void )

API to turn off Bluetooth Hardware.

This API should be called after MS_init.

Returns
API_RESULT on successful Bluetooth OFF
API_RESULT MS_common_start_transition_timer | ( | MS_ACCESS_STATE_TRANSITION_TYPE * | transition,
 |  | UINT16 * | transition_time_handle
 | ) |  |

To start transition timer.

Description
API to start a transition timer.
Parameters
[in] | transition | State Transition data structure, which includes the timeout, transition start and complete callback etc.
[out] | transition_time_handle | Transition Time Handle, which can be used to stop the transition timer if required.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_common_stop_transition_timer ( UINT16 transition_time_handle )

To stop transition timer.

Description
API to stop a transition timer.
Parameters
[in] transition_time_handle Transition Time Handle, returned by the Start Transition Timer interface.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_common_get_transition_time_from_ms | ( | UINT32 | transition_time_in_ms,
 |  | UINT8 * | transition_time
 | ) |  |

To convert transition time from milisecond.

Description
API to convert transition timer in milisecond to Generic Default Transition Time state format.
Parameters
[in] | transition_time_in_ms | Transition Time in milisecond.
[out] | transition_time | Converted value in Generic Default Transition Time state format.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Constants

Macros
Constants
Defines | MESH Common

Macros

#define | MS_STACK_INIT_UNDEFINED 0x00
#define | MS_STACK_INIT_ETHERMIND_INIT 0x01
#define | MS_FALSE 0
#define | MS_TRUE 1
#define | MS_MODULE_PAGE_4 0x40000000
#define | MS_MODULE_BIT_MASK_COMMON 0x00000001
#define | MS_MODULE_BIT_MASK_BRR 0x00000002
#define | MS_MODULE_BIT_MASK_NET 0x00000004
#define | MS_MODULE_BIT_MASK_LTRN 0x00000008
#define | MS_MODULE_BIT_MASK_TRN 0x00000010
#define | MS_MODULE_BIT_MASK_ACCESS 0x00000020
#define | MS_MODULE_BIT_MASK_APP 0x00000040
#define | MS_MODULE_BIT_MASK_STBX 0x00000080
#define | MS_MODULE_BIT_MASK_CONFIG 0x00000100
#define | MS_MODULE_BIT_MASK_FSM 0x00000200
#define | MS_MODULE_BIT_MASK_PROV 0x00000400
#define | MS_MODULE_BIT_MASK_MESH_MODEL 0x00000800
#define | MS_MODULE_ID_COMMON (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_COMMON)
#define | MS_MODULE_ID_BRR (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_BRR)
#define | MS_MODULE_ID_NET (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_NET)
#define | MS_MODULE_ID_LTRN (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_LTRN)
#define | MS_MODULE_ID_TRN (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_TRN)
#define | MS_MODULE_ID_ACCESS (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_ACCESS)
#define | MS_MODULE_ID_APP (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_APP)
#define | MS_MODULE_ID_STBX (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_STBX)
#define | MS_MODULE_ID_CONFIG (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_CONFIG)
#define | MS_MODULE_ID_FSM (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_FSM)
#define | MS_MODULE_ID_PROV (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_PROV)
#define | MS_MODULE_ID_MESH_MODEL (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_MESH_MODEL)
#define | MS_DEVICE_UUID_SIZE 16
Device UUID Size.
#define | MS_BCON_TYPE_SIZE 1
Beacon Type - Size.
#define | MS_BCON_OOB_IND_SIZE 2
Beacon OOB Indicator Size.
#define | MS_BCON_URI_HASH_SIZE 4
Beacon URI Hash Size.
#define | MS_BCON_TYPE_UNPRVSNG_DEV 0x00
Beacon Types. More...
#define | MS_BCON_TYPE_SECURE 0x01
#define | MS_FRND_ROLE_INVALID 0x00
Friend Role.
#define | MS_FRND_ROLE_FRIEND 0x01
#define | MS_FRND_ROLE_LPN 0x02
#define | MS_FEATURE_RELAY 0x00
Relay Feature.
#define | MS_FEATURE_PROXY 0x01
Proxy Feature.
#define | MS_FEATURE_FRIEND 0x02
Friend Feature.
#define | MS_FEATURE_LPN 0x03
Low Power Feature.
#define | MS_FEATURE_SEC_NET_BEACON 0x04
Secure Nework Beacon.
#define | MS_ENABLE 0x01
Operation: Enable.
#define | MS_DISABLE 0x00
Operation: Disable.
#define | MS_NOT_SUPPORTED 0x02
Feature not supported. More...
#define | MS_NETWORK_TX_STATE 0x00
Network Tx State.
#define | MS_RELAY_TX_STATE 0x01
Relay Tx State.
#define | MS_LABEL_UUID_LENGTH 16
Label UUID Length. More...

Detailed Description

Macro Definition Documentation

#define MS_BCON_TYPE_UNPRVSNG_DEV 0x00

Beacon Types.

Unprovisioned Device Beacon Type

Definition at line 759 of file MS_common.h.

#define MS_NOT_SUPPORTED 0x02

Feature not supported.

Used as stutus for Get/Set Friend/Proxy etc., when the feature is not supported.

Definition at line 795 of file MS_common.h.

#define MS_LABEL_UUID_LENGTH 16

Label UUID Length.

Associated with Virtual Address

Definition at line 803 of file MS_common.h.


EtherMind Mesh SDK (beta): Defines

Modules
Defines
MESH Common

Modules

Common
Constants
Mesh Error Codes
This section contains all the error codes defined for Mesh stack and profiles.
Structures

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Common

Macros
Common
Defines

Macros

#define | MUTEX_INIT_FAILED 0x0001
#define | COND_INIT_FAILED 0x0002
#define | MUTEX_LOCK_FAILED 0x0003
#define | MUTEX_UNLOCK_FAILED 0x0004
#define | MEMORY_ALLOCATION_FAILED 0x0005

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Mesh Error Codes

Modules
Mesh Error Codes
Defines

This section contains all the error codes defined for Mesh stack and profiles. More...

Modules

Defines
Error Grouping
Mesh Result Codes

Detailed Description

This section contains all the error codes defined for Mesh stack and profiles.

Theory:

Every API under Mesh Protocol Suite returns API_RESULT, which is a 2 Byte Unsigned Short variable. The higher order byte signifies the Module from which the Error has been generated, and the lower order byte encodes the actual reason of Error.

Each module under Mesh Stack is given unique Error ID (the higher order byte). Also, for each module the Error Code (the lower order byte) signifies an unique error situation.

For Mesh Protocol Modules (eg, Transport, Network etc.), Error IDs are assigned from the range 0x10 to 0x4F. For Profiles, the range is from 0x50 to 0x7F.

The definition of API_SUCCESS is 0x0000 - which is the 'Success' return value for an API returning API_RESULT. All other values for should be treated as Errors.

The definition of API_FAILURE is 0xFFFF - which stands for "Unknown Error Situation".

Note:

The applications using native/profile Mesh API should NOT do any check on the basis of API_FAILURE - rather, the correct way to detect an error situation is by doing a negative check on API_SUCCESS.

For example,

if ( API_FAILURE == MS_access_register_model(x, y, z) )

... Wrong !

if ( API_SUCCESS != MS_access_register_model(x, y, z) )

... Correct !


EtherMind Mesh SDK (beta): Defines

Macros | Typedefs
Defines
Mesh Error Codes

Macros

#define | API_RESULT_DEFINED
#define | API_SUCCESS 0x0000
Status - 'Success'.
#define | API_FAILURE 0xFFFF
Status - 'Failure'.

Typedefs

typedef UINT16 API_RESULT
Definition of API_RESULT.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Error Grouping

Modules
Error Grouping
Mesh Error Codes

Modules

Core Modules (0x10 - 0x1F)
Error IDs for Mesh Core Modules (0x10 - 0x1F).
Protocols (0x20 - 0x3F)
Error IDs for Mesh Protocol Modules (0x20 - 0x3F).
Specification Error Codes (0x00 - 0x0F)
Error IDs for Bluetooth Specification Defined Error Codes (0x00 - 0x0F).

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Core Modules (0x10 - 0x1F)

Macros
Core Modules (0x10 - 0x1F)
Error Grouping

Error IDs for Mesh Core Modules (0x10 - 0x1F). More...

Macros

#define | MS_COMMON_ERR_ID 0x1000
Error Codes for MS Common - Common.
#define | TIMER_ERR_ID 0x1200
Error Codes for Timer - ms_error_codes_module_timer.

Detailed Description

Error IDs for Mesh Core Modules (0x10 - 0x1F).


EtherMind Mesh SDK (beta): Protocols (0x20 - 0x3F)

Macros
Protocols (0x20 - 0x3F)
Error Grouping

Error IDs for Mesh Protocol Modules (0x20 - 0x3F). More...

Macros

#define | BRR_ERR_ID 0x2000
Error Codes for Bearer - ms_error_codes_module_brr.
#define | NET_ERR_ID 0x2100
#define | LTRN_ERR_ID 0x2200
#define | TRN_ERR_ID 0x2300
#define | ACCESS_ERR_ID 0x2400
#define | PROV_ERR_ID 0x3000
#define | HEALTH_ERR_ID 0x8000

Detailed Description

Error IDs for Mesh Protocol Modules (0x20 - 0x3F).


EtherMind Mesh SDK (beta): Specification Error Codes (0x00 - 0x0F)

Macros
Specification Error Codes (0x00 - 0x0F)
Error Grouping

Error IDs for Bluetooth Specification Defined Error Codes (0x00 - 0x0F). More...

Macros

#define MS_ERR_ID 0x0000
Error Codes for Mesh - Mesh Result Codes.

Detailed Description

Error IDs for Bluetooth Specification Defined Error Codes (0x00 - 0x0F).


EtherMind Mesh SDK (beta): Mesh Result Codes

Macros
Mesh Result Codes
Mesh Error Codes

Macros

#define | MS_SUCCESS (0x0000 | MS_ERR_ID)
#define | MS_INVALID_ADDRESS (0x0001 | MS_ERR_ID)
Invalid Address.
#define | MS_INVALID_MODEL (0x0002 | MS_ERR_ID)
Invalid Model.
#define | MS_INVALID_APPKEY_INDEX (0x0003 | MS_ERR_ID)
Invalid AppKey Index.
#define | MS_INVALID_NETKEY_INDEX (0x0004 | MS_ERR_ID)
Invalid NetKey Index.
#define | MS_INSUFFICIENT_RESOURCES (0x0005 | MS_ERR_ID)
Insufficient Resources.
#define | MS_KEY_INDEX_ALREADY_STORED (0x0006 | MS_ERR_ID)
Key Index Already Stored.
#define | MS_INVALID_PUBLISH_PARAMETER (0x0007 | MS_ERR_ID)
Invalid Publish Parameters.
#define | MS_NOT_A_SUBSCRIBE_MODEL (0x0008 | MS_ERR_ID)
Not a Subscribe Model.
#define | MS_STORAGE_FAILURE (0x0009 | MS_ERR_ID)
Storage Failure.
#define | MS_FEATURE_NOT_SUPPORTED (0x000A | MS_ERR_ID)
Feature Not Supported.
#define | MS_CANNOT_UPDATE (0x000B | MS_ERR_ID)
Cannot Update.
#define | MS_CANNOT_REMOVE (0x000C | MS_ERR_ID)
Cannot Remove.
#define | MS_CANNOT_BIND (0x000D | MS_ERR_ID)
Cannot Bind.
#define | MS_TEMP_UNABLE_TO_CHANGE_STATE (0x000E | MS_ERR_ID)
Temporarily Unable to Change State.
#define | MS_CANNOT_SET (0x000F | MS_ERR_ID)
Cannot Set.
#define | MS_UNSPECIFIED_ERROR (0x0010 | MS_ERR_ID)
Unspecified Error.
#define | MS_INVALID_BINDING (0x0011 | MS_ERR_ID)
Invalid Binding.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
Defines

Data Structures

struct | MS_BUFFER
Payload type. More...
struct | MS_CONFIG
Dynamic configuration of Mesh Datastructure. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_BUFFER Struct Reference

Data Fields
MS_BUFFER Struct Reference
Structures

Payload type. More...

#include <MS_common.h>

Data Fields

UCHAR * | payload
UINT16 | length

Detailed Description

Payload type.

Definition at line 819 of file MS_common.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_common.h


EtherMind Mesh SDK (beta): MS_CONFIG Struct Reference

Data Fields
MS_CONFIG Struct Reference
Structures

Dynamic configuration of Mesh Datastructure. More...

#include <MS_common.h>

Data Fields

UINT16 | config_MS_REPLAY_CACHE_SIZE
The size of the Replay Protection cache. More...
UINT16 | config_MS_DEFAULT_COMPANY_ID
Company ID.
UINT16 | config_MS_DEFAULT_PID
Product ID.
UINT16 | config_MS_DEFAULT_VID
Vendor ID.

Detailed Description

Dynamic configuration of Mesh Datastructure.

Used only if 'MS_HAVE_DYNAMIC_GLOBAL_ARRAY' is defined.

Definition at line 833 of file MS_common.h.

Field Documentation

UINT16 MS_CONFIG::config_MS_REPLAY_CACHE_SIZE

The size of the Replay Protection cache.

Definition at line 836 of file MS_common.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_common.h


EtherMind Mesh SDK (beta): Utility Macros

Macros
Utility Macros
MESH Common

Macros

#define | MS_PACK_LE_1_BYTE(dst, src)
Packing Macros. More...
#define | MS_PACK_LE_1_BYTE_VAL(dst, src) *((UCHAR *)(dst) + 0) = src;
#define | MS_PACK_LE_2_BYTE(dst, src)
#define | MS_PACK_LE_2_BYTE_VAL(dst, src)
#define | MS_PACK_LE_3_BYTE(dst, src)
#define | MS_PACK_LE_3_BYTE_VAL(dst, src)
#define | MS_PACK_LE_4_BYTE(dst, src)
#define | MS_PACK_LE_4_BYTE_VAL(dst, src)
#define | MS_PACK_LE_8_BYTE(dst, val) EM_mem_copy ((dst), (val), 8)
#define | MS_PACK_LE_16_BYTE(dst, val) EM_mem_copy ((dst), (val), 16)
#define | MS_PACK_LE_N_BYTE(dst, val, n) EM_mem_copy ((dst), (val), (n))
#define | MS_PACK_BE_1_BYTE(dst, src)
#define | MS_PACK_BE_1_BYTE_VAL(dst, src) *((UCHAR *)(dst) + 0) = src;
#define | MS_PACK_BE_2_BYTE(dst, src)
#define | MS_PACK_BE_2_BYTE_VAL(dst, src)
#define | MS_PACK_BE_3_BYTE(dst, src)
#define | MS_PACK_BE_3_BYTE_VAL(dst, src)
#define | MS_PACK_BE_4_BYTE(dst, src)
#define | MS_PACK_BE_4_BYTE_VAL(dst, src)
#define | MS_PACK_BE_8_BYTE(dst, val) EM_mem_copy ((dst), (val), 8)
#define | MS_PACK_BE_16_BYTE(dst, val) EM_mem_copy ((dst), (val), 16)
#define | MS_PACK_BE_N_BYTE(dst, val, n) EM_mem_copy ((dst), (val), (n))
#define | MS_UNPACK_LE_1_BYTE(dst, src) *((UCHAR *)(dst)) = (UCHAR)(*((UCHAR *)(src)));
Unpacking Macros. More...
#define | MS_UNPACK_LE_2_BYTE(dst, src)
#define | MS_UNPACK_LE_3_BYTE(dst, src)
#define | MS_UNPACK_LE_4_BYTE(dst, src)
#define | MS_UNPACK_LE_8_BYTE(dst, src) EM_mem_copy ((dst), (src), 8)
#define | MS_UNPACK_LE_16_BYTE(dst, src) EM_mem_copy ((dst), (src), 16)
#define | MS_UNPACK_LE_N_BYTE(dst, src, n) EM_mem_copy ((dst), (src), (n))
#define | MS_UNPACK_BE_1_BYTE(dst, src) *((UCHAR *)(dst)) = (UCHAR)(*((UCHAR *)(src)));
#define | MS_UNPACK_BE_2_BYTE(dst, src)
#define | MS_UNPACK_BE_3_BYTE(dst, src)
#define | MS_UNPACK_BE_4_BYTE(dst, src)
#define | MS_UNPACK_BE_8_BYTE(dst, src) EM_mem_copy ((dst), (src), 8)
#define | MS_UNPACK_BE_16_BYTE(dst, src) EM_mem_copy ((dst), (src), 16)
#define | MS_UNPACK_BE_N_BYTE(dst, src, n) EM_mem_copy ((dst), (src), (n))
#define | MS_DEFINE_MUTEX(mutex) EM_thread_mutex_type mutex;
#define | MS_DEFINE_MUTEX_TYPE(type, mutex) type EM_thread_mutex_type mutex;
#define | MS_DEFINE_COND(cond) EM_thread_cond_type cond;
#define | MS_DEFINE_COND_TYPE(type, cond) type EM_thread_cond_type cond;
#define | MS_MUTEX_INIT_VOID(mutex, MODULE)
#define | MS_MUTEX_INIT(mutex, MODULE)
#define | MS_COND_INIT_VOID(cond, MODULE)
#define | MS_COND_INIT(cond, MODULE)
#define | MS_MUTEX_LOCK(mutex, MODULE)
#define | MS_MUTEX_LOCK_VOID(mutex, MODULE)
#define | MS_MUTEX_LOCK_RETURN_ON_FAILURE(mutex, MODULE, value)
#define | MS_MUTEX_LOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE)
#define | MS_MUTEX_UNLOCK(mutex, MODULE)
#define | MS_MUTEX_UNLOCK_VOID(mutex, MODULE)
#define | MS_MUTEX_UNLOCK_RETURN_ON_FAILURE(mutex, MODULE, value)
#define | MS_MUTEX_UNLOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE)
#define | MS_EXTRACT_BITNUM(val, bitnum) (((val) >> (bitnum)) & 1)
#define | MS_SET_BITNUM(val, bitnum) ((val) |= (1 << (bitnum)))
#define | MS_CLR_BITNUM(val, bitnum) ((val) &= (~(1 << (bitnum))))
#define | MS_GET_MIN(a, b) (((a) > (b)) ? (b) : (a))
#define | MS_GET_MAX(a, b) (((a) > (b)) ? (a) : (b))
#define | MS_IGNORE_UNUSED_PARAM(v) (void)(v)
#define | MS_LOOP_FOREVER() for(;;)
#define | MS_INIT_CONFIG(config)
#define | MS_CONFIG_LIMITS(x) (x)
#define | MS_DEFINE_GLOBAL_ARRAY(type, var, s) type var[(s)]
#define | MS_DECLARE_GLOBAL_ARRAY(type, var, s) extern type var[(s)]
#define | MS_INIT_GLOBAL_ARRAY(type, var, s, i) EM_mem_set(var, (i), ((s) * sizeof(type)))
#define | MODEL_OPCODE_HANDLER_EMPTY_DEF(x)
#define | MODEL_OPCODE_HANDLER_CALL(handler)
#define | MS_STREAM_REV_ENDIANNESS(s, d, n)

Detailed Description

Macro Definition Documentation

#define MS_PACK_LE_1_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UCHAR val; \
val = (UCHAR)(*(src)); \
MS_PACK_LE_1_BYTE_VAL((dst), val); \
}

Packing Macros.

Syntax: MS_PACK_<Endian-ness LE/BE>_<no_of_bytes>_BYTE

Usage: Based on the endian-ness defined for each protocol/profile layer, appropriate packing macros to be used by each layer.

Example: HCI is defined as little endian protocol, so if HCI defines HCI_PACK_2_BYTE for packing a parameter of size 2 byte, that shall be mapped to MS_PACK_LE_2_BYTE

By default both the packing and unpaking macros uses pointer to a single or multi-octet variable which to be packed to or unpacked from a buffer (unsinged character array).

For the packing macro, another variation is available, where the single or multi-octet variable itself is used (not its pointer).

Syntax: MS_PACK_<Endian-ness LE/BE>_<no_of_bytes>_BYTE_VAL

Definition at line 145 of file MS_common.h.

#define MS_PACK_LE_2_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UINT16 val; \
val = (UINT16)(*(src)); \
MS_PACK_LE_2_BYTE_VAL((dst), val); \
}

Definition at line 155 of file MS_common.h.

#define MS_PACK_LE_2_BYTE_VAL | ( | dst,
 |  | src
 | ) |
Value:
*((UCHAR *)(dst) + 0) = (UCHAR)(src); \
*((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);

Definition at line 162 of file MS_common.h.

#define MS_PACK_LE_3_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UINT32 val; \
val = (UINT32)(*(src)); \
MS_PACK_LE_3_BYTE_VAL((dst), val); \
}

Definition at line 166 of file MS_common.h.

#define MS_PACK_LE_3_BYTE_VAL | ( | dst,
 |  | src
 | ) |
Value:
*((UCHAR *)(dst) + 0) = (UCHAR)(src);\
*((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);\
*((UCHAR *)(dst) + 2) = (UCHAR)(src >> 16);

Definition at line 173 of file MS_common.h.

#define MS_PACK_LE_4_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UINT32 val; \
val = (UINT32)(*(src)); \
MS_PACK_LE_4_BYTE_VAL((dst), val); \
}

Definition at line 178 of file MS_common.h.

#define MS_PACK_LE_4_BYTE_VAL | ( | dst,
 |  | src
 | ) |
Value:
*((UCHAR *)(dst) + 0) = (UCHAR)(src);\
*((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);\
*((UCHAR *)(dst) + 2) = (UCHAR)(src >> 16);\
*((UCHAR *)(dst) + 3) = (UCHAR)(src >> 24);

Definition at line 185 of file MS_common.h.

#define MS_PACK_BE_1_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UCHAR val; \
val = (UCHAR)(*((UCHAR *)(src))); \
MS_PACK_BE_1_BYTE_VAL((dst), val); \
}

Definition at line 202 of file MS_common.h.

#define MS_PACK_BE_2_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UINT16 val; \
val = (UINT16)(*((UINT16 *)(src))); \
MS_PACK_BE_2_BYTE_VAL((dst), val); \
}

Definition at line 212 of file MS_common.h.

#define MS_PACK_BE_2_BYTE_VAL | ( | dst,
 |  | src
 | ) |
Value:
*((UCHAR *)(dst) + 1) = (UCHAR)(src); \
*((UCHAR *)(dst) + 0) = (UCHAR)(src >> 8);

Definition at line 219 of file MS_common.h.

#define MS_PACK_BE_3_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UINT32 val; \
val = (UINT32)(*((UINT32 *)(src))); \
MS_PACK_BE_3_BYTE_VAL((dst), val); \
}

Definition at line 223 of file MS_common.h.

#define MS_PACK_BE_3_BYTE_VAL | ( | dst,
 |  | src
 | ) |
Value:
*((UCHAR *)(dst) + 2) = (UCHAR)(src);\
*((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);\
*((UCHAR *)(dst) + 0) = (UCHAR)(src >> 16);

Definition at line 230 of file MS_common.h.

#define MS_PACK_BE_4_BYTE | ( | dst,
 |  | src
 | ) |
Value:
{ \
UINT32 val; \
val = (UINT32)(*((UINT32 *)(src))); \
MS_PACK_BE_4_BYTE_VAL((dst), val); \
}

Definition at line 235 of file MS_common.h.

#define MS_PACK_BE_4_BYTE_VAL | ( | dst,
 |  | src
 | ) |
Value:
*((UCHAR *)(dst) + 3) = (UCHAR)(src);\
*((UCHAR *)(dst) + 2) = (UCHAR)(src >> 8);\
*((UCHAR *)(dst) + 1) = (UCHAR)(src >> 16);\
*((UCHAR *)(dst) + 0) = (UCHAR)(src >> 24);

Definition at line 242 of file MS_common.h.

#define MS_UNPACK_LE_1_BYTE | ( | dst,
 |  | src
 | ) | *((UCHAR *)(dst)) = (UCHAR)(*((UCHAR *)(src)));

Unpacking Macros.

Syntax: MS_UNPACK_<Endian-ness LE/BE>_<no_of_bytes>_BYTE

Usage: Based on the endian-ness defined for each protocol/profile layer, appropriate unpacking macros to be used by each layer.

Example: HCI is defined as little endian protocol, so if HCI defines HCI_UNPACK_4_BYTE for unpacking a parameter of size 4 byte, that shall be mapped to MS_UNPACK_LE_4_BYTE

Definition at line 273 of file MS_common.h.

#define MS_UNPACK_LE_2_BYTE | ( | dst,
 |  | src
 | ) |
Value:
*((UINT16 *)(dst)) = *((src) + 1); \
*((UINT16 *)(dst)) = *((UINT16 *)(dst)) << 8; \
*((UINT16 *)(dst)) |= *((src) + 0);

Definition at line 276 of file MS_common.h.

#define MS_UNPACK_LE_3_BYTE | ( | dst,
 |  | src
 | ) |
Value:
*((UINT32 *)(dst)) = *((src) + 2);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 1);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 0);

Definition at line 281 of file MS_common.h.

#define MS_UNPACK_LE_4_BYTE | ( | dst,
 |  | src
 | ) |
Value:
*((UINT32 *)(dst)) = *((src) + 3);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 2);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 1);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 0);

Definition at line 288 of file MS_common.h.

#define MS_UNPACK_BE_2_BYTE | ( | dst,
 |  | src
 | ) |
Value:
*((UINT16 *)(dst)) = *((src) + 0); \
*((UINT16 *)(dst)) = *((UINT16 *)(dst)) << 8; \
*((UINT16 *)(dst)) |= *((src) + 1);

Definition at line 311 of file MS_common.h.

#define MS_UNPACK_BE_3_BYTE | ( | dst,
 |  | src
 | ) |
Value:
*((UINT32 *)(dst)) = *((src) + 0);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 1);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 2);

Definition at line 316 of file MS_common.h.

#define MS_UNPACK_BE_4_BYTE | ( | dst,
 |  | src
 | ) |
Value:
*((UINT32 *)(dst)) = *((src) + 0);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 1);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 2);\
*((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
*((UINT32 *)(dst)) |= *((src) + 3);

Definition at line 323 of file MS_common.h.

#define MS_MUTEX_INIT_VOID | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_init(&(mutex), NULL) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Initialize Mutex in " #MODULE ".\n"); \
return; \
}

Definition at line 360 of file MS_common.h.

#define MS_MUTEX_INIT | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_init(&(mutex), NULL) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Initialize Mutex in " #MODULE ".\n"); \
return MODULE##_MUTEX_INIT_FAILED; \
}

Definition at line 373 of file MS_common.h.

#define MS_COND_INIT_VOID | ( | cond,
 |  | MODULE
 | ) |
Value:
if (EM_thread_cond_init(&(cond), NULL) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Initialize Conditional Variable in " #MODULE ".\n"); \
return; \
}

Definition at line 386 of file MS_common.h.

#define MS_COND_INIT | ( | cond,
 |  | MODULE
 | ) |
Value:
if (EM_thread_cond_init(&(cond), NULL) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Initialize Conditional Variable in " #MODULE ".\n"); \
return MODULE##_COND_INIT_FAILED; \
}

Definition at line 399 of file MS_common.h.

#define MS_MUTEX_LOCK | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_lock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Lock Mutex in " #MODULE ".\n"); \
return MODULE##_MUTEX_LOCK_FAILED; \
}

Definition at line 412 of file MS_common.h.

#define MS_MUTEX_LOCK_VOID | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_lock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Lock Mutex in " #MODULE ".\n"); \
return; \
}

Definition at line 426 of file MS_common.h.

#define MS_MUTEX_LOCK_RETURN_ON_FAILURE | ( | mutex,
 |  | MODULE,
 |  | value
 | ) |
Value:
if (EM_thread_mutex_lock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Lock Mutex in " #MODULE ".\n"); \
return (value); \
}

Definition at line 440 of file MS_common.h.

#define MS_MUTEX_LOCK_DONOT_RETURN_ON_FAILURE | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_lock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Lock Mutex in " #MODULE ".\n"); \
}

Definition at line 454 of file MS_common.h.

#define MS_MUTEX_UNLOCK | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_unlock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Unlock Mutex in " #MODULE ".\n"); \
return MODULE##_MUTEX_UNLOCK_FAILED; \
}

Definition at line 466 of file MS_common.h.

#define MS_MUTEX_UNLOCK_VOID | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_unlock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Unlock Mutex in " #MODULE ".\n"); \
return; \
}

Definition at line 480 of file MS_common.h.

#define MS_MUTEX_UNLOCK_RETURN_ON_FAILURE | ( | mutex,
 |  | MODULE,
 |  | value
 | ) |
Value:
if (EM_thread_mutex_unlock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Unlock Mutex in " #MODULE ".\n"); \
return (value); \
}

Definition at line 494 of file MS_common.h.

#define MS_MUTEX_UNLOCK_DONOT_RETURN_ON_FAILURE | ( | mutex,
 |  | MODULE
 | ) |
Value:
if (EM_thread_mutex_unlock(&(mutex)) < 0) \
{ \
EM_debug_error( \
MS_MODULE_ID_##MODULE, \
"FAILED to Unlock Mutex in " #MODULE ".\n"); \
}

Definition at line 508 of file MS_common.h.

#define MS_INIT_CONFIG ( config )
Value:
(config).config_MS_REPLAY_CACHE_SIZE = MS_REPLAY_CACHE_SIZE; \
(config).config_MS_DEFAULT_COMPANY_ID = MS_DEFAULT_COMPANY_ID; \
(config).config_MS_DEFAULT_PID = MS_DEFAULT_PID; \
(config).config_MS_DEFAULT_VID = MS_DEFAULT_VID

Definition at line 629 of file MS_common.h.

#define MS_STREAM_REV_ENDIANNESS | ( | s,
 |  | d,
 |  | n
 | ) |
Value:
{ \
UCHAR i; \
for (i = 0; i < (n); i++) \
{ \
(d)[(n - 1) - i] = (s)[i]; \
} \
}

Definition at line 692 of file MS_common.h.


EtherMind Mesh SDK (beta): NETWORK (Mesh Network Layer)

Modules
NETWORK (Mesh Network Layer)

This section describes the interfaces & APIs offered by the EtherMind Mesh Network (NETWORK) module to the Application and other upper layers of the stack. More...

Modules

API Definitions
This section describes the EtherMind Mesh Network Layer APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Defines
Describes defines for the module.
Utility Macros
Initialization and other Utility Macros offered by the module.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Network (NETWORK) module to the Application and other upper layers of the stack.


EtherMind Mesh SDK (beta): API Definitions

Macros | Functions
API Definitions
NETWORK (Mesh Network Layer)

This section describes the EtherMind Mesh Network Layer APIs. More...

Macros

#define | MS_IS_UNICAST_ADDR(addr)
Macro to check if Unicast Address. More...
#define | MS_IS_VIRTUAL_ADDR(addr)
Macro to check if Virtual Address. More...
#define | MS_IS_GROUP_ADDR(addr)
Macro to check if Group Address. More...
#define | NET_IS_VALID_SRC_ADDR(addr) MS_IS_UNICAST_ADDR(addr)
Source address shall be Unicast Address.
#define | NET_IS_VALID_DST_ADDR(addr, ctl)
Destination address. More...
#define | MS_proxy_set_whitelist_filter(nh, sh)
Set Proxy WhiteList Filter. More...
#define | MS_proxy_set_blacklist_filter(nh, sh)
Set Proxy BlackList Filter. More...
#define | MS_proxy_add_to_list(nh, sh, a, c)
Add addressess to Proxy Filter List. More...
#define | MS_proxy_del_from_list(nh, sh, a, c)
Delete addresses from Proxy Filter List. More...

Functions

API_RESULT | MS_net_register (NET_NTF_CB net_cb)
Register Inerface with NETWORK Layer. More...
API_RESULT | MS_net_broadcast_secure_beacon (MS_SUBNET_HANDLE subnet_handle)
API to send Secure Network Beacon. More...
API_RESULT | MS_net_send_pdu (MS_NET_HEADER *hdr, MS_SUBNET_HANDLE subnet_handle, MS_BUFFER *buffer)
API to send NETWORK PDUs. More...
MS_NET_ADDR_TYPE | MS_net_get_address_type (MS_NET_ADDR addr)
To get address type. More...
API_RESULT | MS_proxy_register (PROXY_NTF_CB proxy_cb)
Register Interface with NETWORK PROXY Layer. More...
API_RESULT | MS_proxy_fetch_state (UCHAR *proxy_state)
Check if the Proxy Module is ready to handle Proxy Messages/Events. More...
API_RESULT | MS_proxy_server_adv_start (MS_SUBNET_HANDLE subnet_handle, UCHAR proxy_adv_mode)
Start Connectable Advertisements for a Proxy Server. More...
API_RESULT | MS_proxy_server_adv_stop (void)
Stop Connectable Advertisements for a Proxy Server. More...
API_RESULT | MS_net_alloc_seq_num (UINT32 *seq_num)
To allocate Sequence Number. More...

Detailed Description

This section describes the EtherMind Mesh Network Layer APIs.

Macro Definition Documentation

#define MS_IS_UNICAST_ADDR ( addr )
Value:
(((MS_NET_ADDR_UNASSIGNED != (addr)) && \
(MS_NET_ADDR_UNICAST_COMPARE == ((addr) & MS_NET_ADDR_UNICAST_BIT_MASK))) \
? MS_TRUE : MS_FALSE)

Macro to check if Unicast Address.

Definition at line 386 of file MS_net_api.h.

#define MS_IS_VIRTUAL_ADDR ( addr )
Value:
((MS_NET_ADDR_VIRTUAL_COMPARE == ((addr) & MS_NET_ADDR_VIRTUAL_BIT_MASK)) \
? MS_TRUE : MS_FALSE)

Macro to check if Virtual Address.

Definition at line 394 of file MS_net_api.h.

#define MS_IS_GROUP_ADDR ( addr )
Value:
((MS_NET_ADDR_GROUP_COMPARE == ((addr) & MS_NET_ADDR_GROUP_BIT_MASK)) \
? MS_TRUE : MS_FALSE)

Macro to check if Group Address.

Definition at line 401 of file MS_net_api.h.

#define NET_IS_VALID_DST_ADDR | ( | addr,
 |  | ctl
 | ) |
Value:
(((MS_NET_ADDR_UNASSIGNED != (addr)) && \
((0x01 != (ctl)) || (MS_FALSE == MS_IS_VIRTUAL_ADDR(addr)))) \
? MS_TRUE : MS_FALSE)

Destination address.

  • Shall not be Unassigned Address.
  • Control Message shall not be a Virtual Address.

Definition at line 416 of file MS_net_api.h.

#define MS_proxy_set_whitelist_filter | ( | nh,
 |  | sh
 | ) |
Value:
MS_proxy_set_filter \
( \
(nh), \
(sh), \
MS_PROXY_WHITELIST_FILTER \
);

Set Proxy WhiteList Filter.

Description This function is used by the Proxy Client
to set the filter type on the Proxy Server to MS_PROXY_WHITELIST_FILTER.
Parameters
[in] | nh | Network Interface Handle
[in] | sh | Subnet Handle
Note
This API will be used by the Proxy Client only.
Returns
API_SUCCESS or Error Code on failure

Definition at line 436 of file MS_net_api.h.

#define MS_proxy_set_blacklist_filter | ( | nh,
 |  | sh
 | ) |
Value:
MS_proxy_set_filter \
( \
(nh), \
(sh), \
MS_PROXY_BLACKLIST_FILTER \
);

Set Proxy BlackList Filter.

Description This function is used by the Proxy Client
to set the filter type on the Proxy Server to MS_PROXY_BLACKLIST_FILTER.
Parameters
[in] | nh | Network Interface Handle
[in] | sh | Subnet Handle
Note
This API will be used by the Proxy Client only.
Returns
API_SUCCESS or Error Code on failure

Definition at line 457 of file MS_net_api.h.

#define MS_proxy_add_to_list | ( | nh,
 |  | sh,
 |  | a,
 |  | c
 | ) |
Value:
MS_proxy_filter_op \
( \
(nh), \
(sh), \
MS_PROXY_ADD_TO_FILTER_OPCODE, \
(a), \
(c) \
);

Add addressess to Proxy Filter List.

Description This function is used by the Proxy Client
to add Addressess to the Proxy Server's filter List.
Parameters
[in] | nh | Network Interface Handle
[in] | sh | Subnet Handle
[in] | a | Pointer to List of Address to be added
[in] | c | Count of Addressess present in the provided List
Note
This API will be used by the Proxy Client only.
Returns
API_SUCCESS or Error Code on failure

Definition at line 480 of file MS_net_api.h.

#define MS_proxy_del_from_list | ( | nh,
 |  | sh,
 |  | a,
 |  | c
 | ) |
Value:
MS_proxy_filter_op \
( \
(nh), \
(sh), \
MS_PROXY_REM_FROM_FILTER_OPCODE, \
(a), \
(c) \
);

Delete addresses from Proxy Filter List.

Description This function is used by the Proxy Client
to delete/remove Addresses from the Proxy Server's filter List.
Parameters
[in] | nh | Network Interface Handle
[in] | sh | Subnet Handle
[in] | a | Pointer to List of Address to be deleted/removed
[in] | c | Count of Addressess present in the provided List
Note
This API will be used by the Proxy Client only.
Returns
API_SUCCESS or Error Code on failure

Definition at line 505 of file MS_net_api.h.

Function Documentation

API_RESULT MS_net_register ( NET_NTF_CB net_cb )

Register Inerface with NETWORK Layer.

Description
This routine registers interface with the NETWORK Layer. NETWORK Layer supports only one upper layer, hence this routine shall be called once.
Parameters
[in] net_cb Upper Layer Notification Callback
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_net_broadcast_secure_beacon ( MS_SUBNET_HANDLE subnet_handle )

API to send Secure Network Beacon.

Description
This routine sends Secure Network Beacon for the given subnet handle
Parameters
[in] subnet_handle Subnet handle of the network to be broadcasted.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_net_send_pdu | ( | MS_NET_HEADER * | hdr,
 |  | MS_SUBNET_HANDLE | subnet_handle,
 |  | MS_BUFFER * | buffer
 | ) |  |

API to send NETWORK PDUs.

Description
This routine sends NETWORK PDUs to peer device.
Parameters
[in] | hdr | Network Header
[in] | subnet_handle | Subnet Handle
[in] | buffer | Lower Transport Payload
Returns
API_SUCCESS or an error code indicating reason for failure
MS_NET_ADDR_TYPE MS_net_get_address_type ( MS_NET_ADDR addr )

To get address type.

Description
This routine is to get address type for a given address.
Parameters
[in] addr Input Network Address
Returns
One of the following address type MS_NET_ADDR_TYPE_INVALID MS_NET_ADDR_TYPE_UNICAST MS_NET_ADDR_TYPE_VIRTUAL MS_NET_ADDR_TYPE_GROUP
API_RESULT MS_proxy_register ( PROXY_NTF_CB proxy_cb )

Register Interface with NETWORK PROXY Layer.

Description
This routine registers interface with the NETWORK PROXY Layer. NETWORK PROXY Layer supports only one upper layer, hence this rouine shall be called once.
Parameters
[in] proxy_cb Upper Layer Notification Callback
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_proxy_fetch_state ( UCHAR * proxy_state )

Check if the Proxy Module is ready to handle Proxy Messages/Events.

Description
This routine returns the current state of the Proxy. The valid states of proxy are:
  1. MS_PROXY_NULL - If no callback registered by Upper Layers
  2. MS_PROXY_READY - If callback registered and Proxy not connected
  3. MS_PROXY_CONNECTED - if callback registered and Proxy connected
Parameters
[out] proxy_state returns the current state of the Proxy
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_proxy_server_adv_start | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UCHAR | proxy_adv_mode
 | ) |  |

Start Connectable Advertisements for a Proxy Server.

Description This function is used by the Proxy Server
to start Connectable Undirected Advertisements.
Parameters
[in] | subnet_handle | Subnet Handle which the Proxy Server is part of.
[in] | proxy_adv_mode | Mode of Proxy Advertisements. This could be of two types MS_PROXY_NET_ID_ADV_MODE or MS_PROXY_NODE_ID_ADV_MODE
Note
This API will be used by the Proxy Server only.
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_proxy_server_adv_stop ( void )

Stop Connectable Advertisements for a Proxy Server.

Description This function is used by the Proxy Server
to stop Connectable Undirected Advertisements.
Note
This API will be used by the Proxy Server only.
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_net_alloc_seq_num ( UINT32 * seq_num )

To allocate Sequence Number.

Description This function is used to allocate
Sequence Number.
Parameters
[out] seq_num Location where SeqNum to be filled.
Returns
API_SUCCESS or Error Code on failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
NETWORK (Mesh Network Layer)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | NET_NTF_CB )(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
NETWORK Application Asynchronous Notification Callback. More...
typedef void(* | PROXY_NTF_CB )(NETIF_HANDLE *handle, UCHAR p_evt, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Network Proxy Application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* NET_NTF_CB)(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

NETWORK Application Asynchronous Notification Callback.

NETWORK calls the registered callback to indicate events occurred to the application.

Parameters
brr_type | Bearer Type.
net_hdr | Network Header.
subnet_handle | Associated Subnet Handle.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.
Returns
  • NET_POST_PROCESS_RX_PKT: To inform Network Layer if the packet to be further processed, e.g. to be relayed or proxied etc.
  • Any Other Result/Error Code defined in MS_error.h: Ignored by Network Layer.

Definition at line 350 of file MS_net_api.h.

typedef void(* PROXY_NTF_CB)(NETIF_HANDLE *handle, UCHAR p_evt, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Network Proxy Application Asynchronous Notification Callback.

NETWORK PROXY calls the registered callback to indicate events occurred to the application.

Parameters
handle | Network Interface Handle.
p_evt | Proxy Event.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 369 of file MS_net_api.h.


EtherMind Mesh SDK (beta): Defines

Modules
Defines
NETWORK (Mesh Network Layer)

Describes defines for the module. More...

Modules

Constants
Describes Constants defined by the module.
Events
This section lists the Asynchronous Events notified to Application by the Module.
Proxy
Describes Network Layer Proxy Feature related defines.
Structures

Detailed Description

Describes defines for the module.


EtherMind Mesh SDK (beta): Constants

Modules
Constants
Defines

Describes Constants defined by the module. More...

Modules

Addressing
Describes five basic type of addresses, the Network Layer defines.
Proxy
Describes Network Layer Proxy Feature related defines.

Detailed Description

Describes Constants defined by the module.


EtherMind Mesh SDK (beta): Addressing

Macros
Addressing
Constants

Describes five basic type of addresses, the Network Layer defines. More...

Macros

#define | MS_NET_ADDR_UNASSIGNED 0x0000
Unassigned Address. More...
#define | MS_NET_ADDR_TYPE_INVALID 0x00
Network Address Type - Invalid.
#define | MS_NET_ADDR_UNICAST_BIT_MASK 0x8000
Unicast Address. More...
#define | MS_NET_ADDR_UNICAST_COMPARE 0x0000
Comparison value for Network Address Type - Unicast.
#define | MS_NET_ADDR_TYPE_UNICAST 0x01
Network Address Type - Unicast.
#define | MS_NET_ADDR_VIRTUAL_BIT_MASK 0xC000
Virtual Address. More...
#define | MS_NET_ADDR_VIRTUAL_COMPARE 0x8000
Comparison value for Network Address Type - Virtual.
#define | MS_NET_ADDR_TYPE_VIRTUAL 0x02
Network Address Type - Virtual.
#define | MS_NET_ADDR_GROUP_BIT_MASK 0xC000
Group Address. More...
#define | MS_NET_ADDR_GROUP_COMPARE 0xC000
Comparison value for Network Address Type - Group.
#define | MS_NET_ADDR_TYPE_GROUP 0x03
Network Address Type - Group.
#define | MS_NET_ADDR_ALL_PROXIES 0xFFFC
Fixed Group Addresses are all-proxies, all-friends, all-relays and all-nodes. More...
#define | MS_NET_ADDR_ALL_FRIENDS 0xFFFD
Fixed Group Address - All-Friends.
#define | MS_NET_ADDR_ALL_RELAYS 0xFFFE
Fixed Group Address - All-Relays.
#define | MS_NET_ADDR_ALL_NODES 0xFFFF
Fixed Group Address - All-Nodes.
#define | MS_NET_FEATURE_PROXY 0x00
Address Validity. More...
#define | MS_NET_FEATURE_RELAY 0x01
Network Layer Feature - Relay.
#define | MS_PRIMARY_SUBNET 0x000
Primary Subnet - NetKey Index is 0x000.
#define | MS_INVALID_SUBNET_HANDLE 0xFFFF
Invalid Subnet Handle.
#define | MS_INVALID_APPKEY_HANDLE 0xFFFF
Invalid AppKey Handle.

Detailed Description

Describes five basic type of addresses, the Network Layer defines.

Macro Definition Documentation

#define MS_NET_ADDR_UNASSIGNED 0x0000

Unassigned Address.

An unassigned address is an address that means that the component of a node has not been configured yet or no address has been allocated.

An unassigned address shall not be used in a source or destination address field of a message.

A Primary Component shall not have an unassigned address. A Secondary Component may have an unassigned address. A component with an unassigned address is inactive (i.e., it cannot send nor receive and process messages).

Definition at line 64 of file MS_net_api.h.

#define MS_NET_ADDR_UNICAST_BIT_MASK 0x8000

Unicast Address.

A unicast address is a unique address allocated to each component within a node. A unicast address has bit 15 cleared to zero. The unicast address shall not have the value 0x0000, and therefore can have any value from 0x0001 to 0x7FFF inclusive.

A unicast address is allocated to a primary component of an unprovisioned device by the Provisioner during provisioning for the lifetime of the node on the network.

A unicast address can be allocated to any secondary component within an already provisioned node.

A unicast address shall be used in the source address field of a message and can be used in a destination address field of a message. A message sent to a unicast address will be processed by at most one node or one component within a node.Bitmask for Network Address Type - Unicast

Definition at line 88 of file MS_net_api.h.

#define MS_NET_ADDR_VIRTUAL_BIT_MASK 0xC000

Virtual Address.

A virtual address is an address that is similar to a group address, in that multiple devices may know such an address. This type of address is used to identify a label to which devices may publish or subscribe. The label referred to by a given virtual address is uniquely identified by a 128-bit UUID, called virtual label UUID.

The format of a Virtual Address is 10vv vvvv vvvv vvvv. The fourteen v-bits are the least significant bits of the following calculation: v = AES-CMAC (virtual label UUID, "vtad")[0-13]Bitmask for Network Address Type - Virtual

Definition at line 108 of file MS_net_api.h.

#define MS_NET_ADDR_GROUP_BIT_MASK 0xC000

Group Address.

A group address is an address that is programmed into zero or more nodes or components within nodes. A group address has bit 15 set to one and bit 14 set to one. The group address shall not have the value 0xFFFF, and therefore can have any value from 0xC000 to 0xFFFE. A group address shall only be used in the destination address field of a message. A message sent to a group address will be processed by all the nodes that know this group address.Bitmask for Network Address Type - Group

Definition at line 126 of file MS_net_api.h.

#define MS_NET_ADDR_ALL_PROXIES 0xFFFC

Fixed Group Addresses are all-proxies, all-friends, all-relays and all-nodes.

Note: Fixed Group Addresses in the range 0xFF00 - 0xFFFB are Reserved for Future.Fixed Group Address - All-Proxies

Definition at line 138 of file MS_net_api.h.

#define MS_NET_FEATURE_PROXY 0x00

Address Validity.

Address Type | Valid in Source Address Field | Valid in Destination Address Field
Unassigned | No | No
Unicast | Yes | Yes
Virtual | No | Yes
Group | No | Yes
Broadcast | No | Yes

Network Layer Feature Idenfiers Network Layer Feature - Proxy

Definition at line 160 of file MS_net_api.h.


EtherMind Mesh SDK (beta): Proxy

Macros
Proxy
Constants | Defines

Describes Network Layer Proxy Feature related defines. More...

Macros

#define | MS_PROXY_WHITELIST_FILTER 0x00
GATT Proxy Filter Types. More...
#define | MS_PROXY_BLACKLIST_FILTER 0x01
GATT Proxy Filter Type - Blacklist.
#define | MS_PROXY_SET_FILTER_OPCODE 0x00
GATT Proxy Configuration Opcodes. More...
#define | MS_PROXY_ADD_TO_FILTER_OPCODE 0x01
GATT Proxy Configuration - Add to Filter Opcode.
#define | MS_PROXY_REM_FROM_FILTER_OPCODE 0x02
GATT Proxy Configuration - Remove From Filter Opcode.
#define | MS_PROXY_FILTER_STATUS_OPCODE 0x03
GATT Proxy Configuration - Filter Status Opcode.
#define | MS_PROXY_NET_ID_ADV_MODE 0x01
GATT Proxy ADV Modes. More...
#define | MS_PROXY_NODE_ID_ADV_MODE 0x02
Node Idetity Type.
#define | MS_PROXY_NULL 0x00
GATT Proxy States. More...
#define | MS_PROXY_READY 0x01
GATT Proxy State - Ready/Initialized.
#define | MS_PROXY_CONNECTED 0x02
GATT Proxy State - Connected.

Detailed Description

Describes Network Layer Proxy Feature related defines.

This section lists the various states of Proxy Module exposed by it to other Modules.

Macro Definition Documentation

#define MS_PROXY_WHITELIST_FILTER 0x00

GATT Proxy Filter Types.

GATT Proxy Filter Type - Whitelist

Definition at line 182 of file MS_net_api.h.

#define MS_PROXY_SET_FILTER_OPCODE 0x00

GATT Proxy Configuration Opcodes.

GATT Proxy Configuration - Set Filter Opcode

Definition at line 188 of file MS_net_api.h.

#define MS_PROXY_NET_ID_ADV_MODE 0x01

GATT Proxy ADV Modes.

Network ID Type

Definition at line 198 of file MS_net_api.h.

#define MS_PROXY_NULL 0x00

GATT Proxy States.

Proxy Callback | Proxy Iface | Error Code
NULL | Down | MS_PROXY_NULL
NULL | Up | MS_PROXY_NULL
!NULL | Down | MS_PROXY_READY
!NULL | UP | MS_PROXY_CONNECTED

GATT Proxy State - Invalid/Not Initialized

Definition at line 241 of file MS_net_api.h.


EtherMind Mesh SDK (beta): Events

Macros
Events
Defines

This section lists the Asynchronous Events notified to Application by the Module. More...

Macros

#define | MS_PROXY_UP_EVENT 0x00
GATT Proxy Events. More...
#define | MS_PROXY_DOWN_EVENT 0x01
GATT Proxy Event - Interface Down.
#define | MS_PROXY_STATUS_EVENT 0x02
GATT Proxy Event - Status.

Detailed Description

This section lists the Asynchronous Events notified to Application by the Module.

Macro Definition Documentation

#define MS_PROXY_UP_EVENT 0x00

GATT Proxy Events.

GATT Proxy Event - Interface UP

Definition at line 215 of file MS_net_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures | Typedefs
Structures
Defines

Data Structures

struct MS_NET_HEADER
Network Header Type. More...

Typedefs

typedef UINT16 | MS_NET_ADDR
Network Address Type.
typedef UINT16 | MS_SUBNET_HANDLE
Subnet Handle.
typedef UINT16 | MS_APPKEY_HANDLE
AppKey Handle.
typedef UCHAR | MS_NET_ADDR_TYPE
Address Type.
typedef UCHAR | PROXY_FILTER_TYPE
Data structures for filter type and address list.
typedef MS_NET_ADDR | PROXY_ADDR
Proxy Address.
typedef UINT8 | NETIF_HANDLE
Network Interface Handle.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_NET_HEADER Struct Reference

Data Fields
MS_NET_HEADER Struct Reference
Structures

Network Header Type. More...

#include <MS_net_api.h>

Data Fields

UINT8 | ivi
Least significant bit of IV Index - 1 bit.
UINT8 | nid
Value derived from the NetKey used to identify the Encrytion Key and Privacy Key used to secure this PDU - 7 bits.
UINT8 | ctl
Network Control - 1 bit.
UINT8 | ttl
Time To Live - 7 bits.
MS_NET_ADDR saddr
16 Bit Source Address
MS_NET_ADDR daddr
16 Bit Destination Address
UINT32 | seq_num
24 bit sequence number - currently filled only in recption path

Detailed Description

Network Header Type.

Definition at line 283 of file MS_net_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_net_api.h


EtherMind Mesh SDK (beta): Utility Macros

Utility Macros
NETWORK (Mesh Network Layer)

Initialization and other Utility Macros offered by the module. More...

Initialization and other Utility Macros offered by the module.


EtherMind Mesh SDK (beta): PROVISIONING (Mesh Provisioning Layer)

Modules
PROVISIONING (Mesh Provisioning Layer)

This section describes the interfaces & APIs offered by the EtherMind Mesh Provisioning module to the Application and other upper layers of the stack. More...

Modules

API Definitions
This section describes the EtherMind Mesh Provisioning Layer APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Defines
Describes defines for the module.
Utility Macros
Initialization and other Utility Macros offered by the module.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Provisioning module to the Application and other upper layers of the stack.


EtherMind Mesh SDK (beta): API Definitions

Functions
API Definitions
PROVISIONING (Mesh Provisioning Layer)

This section describes the EtherMind Mesh Provisioning Layer APIs. More...

Functions

API_RESULT | MS_prov_register (PROV_CAPABILITIES_S *pcapab, PROV_UI_NOTIFY_CB cb)
Register provisioning capabilities and callback. More...
API_RESULT | MS_prov_setup (PROV_ROLE role, PROV_BRR bearer, PROV_DEVICE_S *pdevice, UINT16 timeout)
Setup the device for provisioning. More...
API_RESULT | MS_prov_bind (PROV_BRR bearer, PROV_DEVICE_S *pdevice, UCHAR attention, PROV_HANDLE *phandle)
Bind to the peer device for provisioning. More...
API_RESULT | MS_prov_send_pdu (PROV_HANDLE *phandle, UCHAR pdu, void *pdata, UINT16 datalen)
Send provisioning PDUs to the peer. More...
API_RESULT | MS_prov_set_authval (PROV_HANDLE *phandle, void *pdata, UINT16 datalen)
Set the display authval. More...
API_RESULT | MS_prov_abort (PROV_HANDLE *phandle, UCHAR reason)
Abort the provisioning procedure. More...
API_RESULT | MS_prov_get_local_public_key (UCHAR *public_key)
Utility API to fetch current ECDH Public Key to be used for Provisioning. More...

Detailed Description

This section describes the EtherMind Mesh Provisioning Layer APIs.

Function Documentation

API_RESULT MS_prov_register | ( | PROV_CAPABILITIES_S * | pcapab,
 |  | PROV_UI_NOTIFY_CB | cb
 | ) |  |

Register provisioning capabilities and callback.

Description This function registers the provisioning capabilities of the
application along with the application callback to notify events during the provisioning procedure.
Parameters
[in] | pcapab | Pointer to the provisioning capabilities structure PROV_CAPABILITIES_S
[in] | cb | Application callback function pointer
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_prov_setup | ( | PROV_ROLE | role,
 |  | PROV_BRR | bearer,
 |  | PROV_DEVICE_S * | pdevice,
 |  | UINT16 | timeout
 | ) |  |

Setup the device for provisioning.

Description This function configures the device to get in a provisionable
state by specifying the role, bearer and creating a context.
Parameters
[in] | role | Provisioniong role to be setup - Device or Provisioner.
[in] | bearer | Provisioning bearer to be setup - PB-ADV or PB-GATT
[in] | pdevice | Pointer to the device strcuture PROV_DEVICE_S containing the UUID to be beaconed. This parameter is used only when the role is PROV_ROLE_DEVICE and ignored otherwise.
[in] | timeout | The time period for which the setup shall be active.
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_prov_bind | ( | PROV_BRR | bearer,
 |  | PROV_DEVICE_S * | pdevice,
 |  | UCHAR | attention,
 |  | PROV_HANDLE * | phandle
 | ) |  |

Bind to the peer device for provisioning.

Description This function establishes a provisioning link with the peer device
and exchanges the capabilities for provisioning.
Parameters
[in] | bearer | Provisioning bearer on which to be bound - PB-ADV or PB-GATT
[in] | pdevice | Pointer to the device strcuture PROV_DEVICE_S.
[in] | attention | The attention duration in seconds to be configured by the device. This parameter is dont care if the role is PROV_ROLE_DEVICE.
[out] | phandle | The handle to the context setup on successful allocation.
Note
This API is for use by the Provisioner application only upon reception of an Unprovisioned Device Beacon.
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_prov_send_pdu | ( | PROV_HANDLE * | phandle,
 |  | UCHAR | pdu,
 |  | void * | pdata,
 |  | UINT16 | datalen
 | ) |  |

Send provisioning PDUs to the peer.

Description This function is used by the provisioning application to send
the provisioning PDUs to the peer device during the procedure.
Parameters
[in] | phandle | Provisioning context to be used.
[in] | pdu | Following PDU types are handled - PROV_PDU_TYPE_START PROV_PDU_TYPE_INPUT_CMPLT PROV_PDU_TYPE_DATA
[in] | pdata | Pointer to the data corresponding to the above PDUs
[in] | datalen | Size of the pdata
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_prov_set_authval | ( | PROV_HANDLE * | phandle,
 |  | void * | pdata,
 |  | UINT16 | datalen
 | ) |  |

Set the display authval.

Description This function shall be used by the provisioning application
to set the authval being displayed to the user on receiving PROV_EVT_OOB_DISPLAY event with the respective OOB Action and Size.
Parameters
[in] | phandle | Provisioning context to be used.
[in] | pdata | Pointer to the Authval (UINT32 *) or (UCHAR *)
[in] | datalen | Size of the pdata
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_prov_abort | ( | PROV_HANDLE * | phandle,
 |  | UCHAR | reason
 | ) |  |

Abort the provisioning procedure.

Description
This API can be used by the application to abort the ongoing provisioning procedure. This routine closes the provisioning link with the reason as specified.
Parameters
[in] | phandle | Provisioning context to be used.
[in] | reason | Reason for termination.
Returns
API_SUCCESS or Error Code on failure
API_RESULT MS_prov_get_local_public_key ( UCHAR * public_key )

Utility API to fetch current ECDH Public Key to be used for Provisioning.

Description
This API can be used by the application to fetch the current ECDH P256 Public Key which is to be used for the Provisioning Procedure.
Parameters
[out] public_key to a pointer of UCHAR array of length PROV_PUBKEY_SIZE
Returns
API_SUCCESS or Error Code on failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
PROVISIONING (Mesh Provisioning Layer)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* PROV_UI_NOTIFY_CB )(PROV_HANDLE *phandle, UCHAR event_type, API_RESULT event_result, void *event_data, UINT16 event_datalen)
Provisioning Application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* PROV_UI_NOTIFY_CB)(PROV_HANDLE *phandle, UCHAR event_type, API_RESULT event_result, void *event_data, UINT16 event_datalen)

Provisioning Application Asynchronous Notification Callback.

Provisioning calls the registered callback to indicate events occurred to the application.

Parameters
phandle | Handle that identifies the provisioning context.
event_type | Event type from any of the events in Events.
event_result | API_SUCCESS or any error code.
event_data | Data associated with the event if any or NULL.
event_datalen | Size of the event data. 0 if event data is NULL.

Definition at line 502 of file MS_prov_api.h.


EtherMind Mesh SDK (beta): Defines

Modules
Defines
PROVISIONING (Mesh Provisioning Layer)

Describes defines for the module. More...

Modules

Constants
Describes Constants defined by the module.
Events
This section lists the Asynchronous Events notified to Application by the Module.
Structures

Detailed Description

Describes defines for the module.


EtherMind Mesh SDK (beta): Constants

Modules | Macros
Constants
Defines

Describes Constants defined by the module. More...

Modules

ADV Transport Opcodes
Specification defined transport Opcodes for PB-ADV bearer.
Control Constants
Control constants defined by the specification.
Error Codes
Describes Error Codes defined by the specification.
GATT Transport Opcodes
Implementation specific transport Opcodes for PB-GATT bearer.

Macros

#define | PROV_ROLE_DEVICE 0x01
Provisiong Roles.
#define | PROV_ROLE_PROVISIONER 0x02
#define | PROV_BRR_ADV 0x01
Provisioning Bearer Types.
#define | PROV_BRR_GATT 0x02
#define | PROV_PDU_TYPE_INVITE 0x00
Provisioning PDU Types.
#define | PROV_PDU_TYPE_CAPAB 0x01
#define | PROV_PDU_TYPE_START 0x02
#define | PROV_PDU_TYPE_PUBKEY 0x03
#define | PROV_PDU_TYPE_INPUT_CMPLT 0x04
#define | PROV_PDU_TYPE_CONF 0x05
#define | PROV_PDU_TYPE_RAND 0x06
#define | PROV_PDU_TYPE_DATA 0x07
#define | PROV_PDU_TYPE_COMPLETE 0x08
#define | PROV_PDU_TYPE_FAILED 0x09
#define | PROV_ALGO_EC_FIPS_P256 0x00
Provisioning algorithm values.
#define | PROV_PUBKEY_NO_OOB 0x00
Provisioning public key values.
#define | PROV_PUBKEY_OOB 0x01
#define | PROV_AUTH_OOB_NONE 0x00
Provisioning authentication method values.
#define | PROV_AUTH_OOB_STATIC 0x01
#define | PROV_AUTH_OOB_OUTPUT 0x02
#define | PROV_AUTH_OOB_INPUT 0x03
#define | PROV_OOOB_ACTION_BLINK 0x00
Provisioning Output OOB action values.
#define | PROV_OOOB_ACTION_BEEP 0x01
#define | PROV_OOOB_ACTION_VIBRATE 0x02
#define | PROV_OOOB_ACTION_NUMERIC 0x03
#define | PROV_OOOB_ACTION_ALPHANUMERIC 0x04
#define | PROV_IOOB_ACTION_PUSH 0x00
Provisioning Input OOB action values.
#define | PROV_IOOB_ACTION_TWIST 0x01
#define | PROV_IOOB_ACTION_NUMERIC 0x02
#define | PROV_IOOB_ACTION_ALPHANUMERIC 0x03
#define | PROV_MASK_ALGO_EC_FIPS_P256 (1 << 0)
Provisioning algorithm support masks.
#define | PROV_MASK_PUBKEY_OOBINFO (1 << 0)
Provisioning public key supported type masks.
#define | PROV_MASK_STATIC_OOBINFO (1 << 0)
Provisioning static oob supported type masks.
#define | PROV_MASK_OOOB_ACTION_BLINK (1 << 0)
Output OOB actions supported masks.
#define | PROV_MASK_OOOB_ACTION_BEEP (1 << 1)
#define | PROV_MASK_OOOB_ACTION_VIBRATE (1 << 2)
#define | PROV_MASK_OOOB_ACTION_NUMERIC (1 << 3)
#define | PROV_MASK_OOOB_ACTION_ALPHANUMERIC (1 << 4)
#define | PROV_MASK_IOOB_ACTION_PUSH (1 << 0)
Input OOB actions supported masks.
#define | PROV_MASK_IOOB_ACTION_TWIST (1 << 1)
#define | PROV_MASK_IOOB_ACTION_NUMERIC (1 << 2)
#define | PROV_MASK_IOOB_ACTION_ALPHANUMERIC (1 << 3)
#define | PROV_KEY_NETKEY_SIZE 16
Provisioning array size requirements.
#define | PROV_OOB_VALUE_SIZE 16
#define | PROV_URI_HASH_SIZE 4
#define | PROV_OOB_TYPE_OTHER (1 << 0)
Provisioning OOB type masks for ADV data.
#define | PROV_OOB_TYPE_URI (1 << 1)
#define | PROV_OOB_TYPE_2DMRC (1 << 2)
#define | PROV_OOB_TYPE_BARCODE (1 << 3)
#define | PROV_OOB_TYPE_NFC (1 << 4)
#define | PROV_OOB_TYPE_NUMBER (1 << 5)
#define | PROV_OOB_TYPE_STRING (1 << 6)
#define | PROV_OOB_TYPE_ONBOX (1 << 11)
#define | PROV_OOB_TYPE_INSIDEBOX (1 << 12)
#define | PROV_OOB_TYPE_ONPIECEOFPAPER (1 << 13)
#define | PROV_OOB_TYPE_INSIDEMANUAL (1 << 14)
#define | PROV_OOB_TYPE_ONDEVICE (1 << 15)
#define | PROV_HANDLE_INVALID 0xFF
Invalid Provisioning Handle.

Detailed Description

Describes Constants defined by the module.


EtherMind Mesh SDK (beta): ADV Transport Opcodes

Macros
ADV Transport Opcodes
Constants

Specification defined transport Opcodes for PB-ADV bearer. More...

Macros

#define | PROV_PB_ADV_OPEN_REQ 0x00
#define | PROV_PB_ADV_OPEN_CNF 0x01
#define | PROV_PB_ADV_CLOSE_IND 0x02

Detailed Description

Specification defined transport Opcodes for PB-ADV bearer.


EtherMind Mesh SDK (beta): Control Constants

Macros
Control Constants
Constants

Control constants defined by the specification. More...

Macros

#define | PROV_PCF_NUM_FRGMNTS 0x00
Number of Fragments - Start of New Transaction.
#define | PROV_PCF_CTRL_MSG 0x01
Control Message.
#define | PROV_PCF_CONTINU_FRGMNT 0x02
Fragment Index - Continuation of a transaction.
#define | PROV_PCF_TX_SPECIFIC 0x03
Transport Specific Messaging (only used by PB ADV)

Detailed Description

Control constants defined by the specification.


EtherMind Mesh SDK (beta): Error Codes

Macros
Error Codes
Constants

Describes Error Codes defined by the specification. More...

Macros

#define | PROV_ERR_PROHIBITED 0x00
Provisioning Failure Error Codes.
#define | PROV_ERR_INVALID_PDU 0x01
#define | PROV_ERR_INVALID_FORMAT 0x02
#define | PROV_ERR_UNEXPECTED_PDU 0x03
#define | PROV_ERR_CONFIRMATION_FAILED 0x04
#define | PROV_ERR_OUT_OF_RESOURCES 0x05
#define | PROV_ERR_DECRYPTION_FAILED 0x06
#define | PROV_ERR_UNEXPECTED_ERROR 0x07
#define | PROV_ERR_CANNOT_ASSIGN_ADDRESS 0x08
#define | PROV_CLOSE_REASON_SUCCESS 0x00
Provisioning LinkClose Error codes.
#define | PROV_CLOSE_REASON_TIMEOUT 0x01
#define | PROV_CLOSE_REASON_FAIL 0x02

Detailed Description

Describes Error Codes defined by the specification.


EtherMind Mesh SDK (beta): GATT Transport Opcodes

Macros
GATT Transport Opcodes
Constants

Implementation specific transport Opcodes for PB-GATT bearer. More...

Macros

#define | PROV_PB_GATT_OPEN_IND 0xF1
#define | PROV_PB_GATT_CLOSE_IND 0xF0

Detailed Description

Implementation specific transport Opcodes for PB-GATT bearer.


EtherMind Mesh SDK (beta): Events

Macros
Events
Defines

This section lists the Asynchronous Events notified to Application by the Module. More...

Macros

#define | PROV_EVT_UNPROVISIONED_BEACON 0x01
This event indicates the availability of an unprovisioned device beacon, with the following values as parameters in the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVISIONING_SETUP 0x02
This event indicates that the provisioning procedure capability exchange is complete, with the following values as parameters in the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_OOB_DISPLAY 0x03
This event indicates to the application the OOB random data that is to be displayed on the UI via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_OOB_ENTRY 0x04
This event indicates to the application requesting for OOB random data that is to be used in the procedure via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_DEVINPUT_COMPLETE 0x05
This event indicates to the application that the peer device has completed the Input of OOB when this capability is negotiated via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVDATA_INFO_REQ 0x06
This event indicates to the application requesting for Provisional data to be sent to the peer device via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVDATA_INFO 0x07
This event indicates to the application the Provisional data received from the Provisioner via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVISIONING_COMPLETE 0x08
This event indicates to the application that the provisioning procedure is complete via the PROV_UI_NOTIFY_CB callback. More...

Detailed Description

This section lists the Asynchronous Events notified to Application by the Module.

Macro Definition Documentation

#define PROV_EVT_UNPROVISIONED_BEACON 0x01

This event indicates the availability of an unprovisioned device beacon, with the following values as parameters in the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_UNPROVISIONED_BEACON.
[in] | event_result | API_SUCCESS.
[in] | event_data | Pointer to the array with the UUID of the device.
[in] | event_datalen | MS_DEVICE_UUID_SIZE
Note
This event is received by the Provisioner application. On reception of this event, the application shall make use of the MS_prov_bind() to initiate the provisioning procedure.
Returns
API_SUCCESS (always)

Definition at line 234 of file MS_prov_api.h.

#define PROV_EVT_PROVISIONING_SETUP 0x02

This event indicates that the provisioning procedure capability exchange is complete, with the following values as parameters in the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_PROVISIONING_SETUP.
[in] | event_result | API_SUCCESS on successful procedure completion, else an Error Code.
[in] | event_data | When local provisioner, this contains peer device capabilities and when local device, this contains the attention timeout value.
[in] | event_datalen | When local provisioner, sizeof(PROV_CAPABILITIES_S) and when local device, sizeof(UINT32).
Note
When local provisioner, the appliation shall select the required capability from the received capabilities and choose to start the procedure by calling MS_prov_start().
Returns
API_SUCCESS (always)

Definition at line 257 of file MS_prov_api.h.

#define PROV_EVT_OOB_DISPLAY 0x03

This event indicates to the application the OOB random data that is to be displayed on the UI via the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_OOB_DISPLAY.
[in] | event_result | API_SUCCESS on successful procedure completion, else an Error Code.
[in] | event_data | Pointer to OOB information as in PROV_OOB_TYPE_S.
[in] | event_datalen | sizeof (PROV_OOB_TYPE_S).
Returns
API_SUCCESS (always)

Definition at line 272 of file MS_prov_api.h.

#define PROV_EVT_OOB_ENTRY 0x04

This event indicates to the application requesting for OOB random data that is to be used in the procedure via the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_OOB_ENTRY.
[in] | event_result | API_SUCCESS on successful procedure completion, else an Error Code.
[in] | event_data | Pointer to OOB information as in PROV_OOB_TYPE_S.
[in] | event_datalen | sizeof (PROV_OOB_TYPE_S).
Returns
API_SUCCESS (always)

Definition at line 287 of file MS_prov_api.h.

#define PROV_EVT_DEVINPUT_COMPLETE 0x05

This event indicates to the application that the peer device has completed the Input of OOB when this capability is negotiated via the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_DEVINPUT_COMPLETE.
[in] | event_result | API_SUCCESS on successful procedure completion, else an Error Code.
[in] | event_data | NULL.
[in] | event_datalen | 0.
Note
This event is generated only for the provisioner application.
Returns
API_SUCCESS (always)

Definition at line 305 of file MS_prov_api.h.

#define PROV_EVT_PROVDATA_INFO_REQ 0x06

This event indicates to the application requesting for Provisional data to be sent to the peer device via the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_PROVDATA_INFO_REQ.
[in] | event_result | API_SUCCESS on successful procedure completion, else an Error Code.
[in] | event_data | NULL.
[in] | event_datalen | 0.
Note
This event is generated only for the provisioner application.
Returns
API_SUCCESS (always)

Definition at line 322 of file MS_prov_api.h.

#define PROV_EVT_PROVDATA_INFO 0x07

This event indicates to the application the Provisional data received from the Provisioner via the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_PROVDATA_INFO.
[in] | event_result | API_SUCCESS on successful procedure completion, else an Error Code.
[in] | event_data | Pointer to the provisioning data PROV_DATA_S.
[in] | event_datalen | sizeof(PROV_DATA_S).
Note
This event is generated only for the device application.
Returns
API_SUCCESS (always)

Definition at line 339 of file MS_prov_api.h.

#define PROV_EVT_PROVISIONING_COMPLETE 0x08

This event indicates to the application that the provisioning procedure is complete via the PROV_UI_NOTIFY_CB callback.

Parameters
[in] | phandle | Pointer to the Provisioning context handle
[in] | event_type | PROV_EVT_PROVISIONING_COMPLETE.
[in] | event_result | API_SUCCESS on successful procedure completion, else an Error Code.
[in] | event_data | NULL.
[in] | event_datalen | 0.
Returns
API_SUCCESS (always)

Definition at line 354 of file MS_prov_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures | Typedefs
Structures
Defines

Data Structures

struct | PROV_DEVICE_S
Device Information used for Provisioning. More...
struct | PROV_OOB_TYPE_S
OOB type for provisioning. More...
struct | PROV_CAPABILITIES_S
Device capabilities used for Provisioning. More...
struct | PROV_METHOD_S
Provisioning method information. More...
struct | PROV_DATA_S
Data exchanged during Provisiong procedure. More...

Typedefs

typedef UCHAR | PROV_ROLE
Role of the device.
typedef UCHAR | PROV_BRR
Bearer for the provisioning session.
typedef UCHAR | PROV_HANDLE
Handle to reference the active provisioning context.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): PROV_DEVICE_S Struct Reference

Data Fields
PROV_DEVICE_S Struct Reference
Structures

Device Information used for Provisioning. More...

#include <MS_prov_api.h>

Data Fields

UCHAR | uuid [MS_DEVICE_UUID_SIZE]
Device UUID - Used in unprovisioned device beacon and Provisioning Invite.
UINT16 | oob
OOB Information.
MS_BUFFER * uri
URI if any, to be given in encoded form.

Detailed Description

Device Information used for Provisioning.

Definition at line 382 of file MS_prov_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_prov_api.h


EtherMind Mesh SDK (beta): PROV_OOB_TYPE_S Struct Reference

Data Fields
PROV_OOB_TYPE_S Struct Reference
Structures

OOB type for provisioning. More...

#include <MS_prov_api.h>

Data Fields

UINT16 | action
OOB Action information.
UCHAR | size
OOB Size information.

Detailed Description

OOB type for provisioning.

Definition at line 399 of file MS_prov_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_prov_api.h


EtherMind Mesh SDK (beta): PROV_CAPABILITIES_S Struct Reference

Data Fields
PROV_CAPABILITIES_S Struct Reference
Structures

Device capabilities used for Provisioning. More...

#include <MS_prov_api.h>

Data Fields

UCHAR | num_elements
Number of Elements.
UINT16 | supp_algorithms
Supported algorithms.
UCHAR | supp_pubkey
Public key type.
UCHAR | supp_soob
Static OOB type.
PROV_OOB_TYPE_S ooob
Output OOB information.
PROV_OOB_TYPE_S ioob
Input OOB information.

Detailed Description

Device capabilities used for Provisioning.

Definition at line 410 of file MS_prov_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_prov_api.h


EtherMind Mesh SDK (beta): PROV_METHOD_S Struct Reference

Data Fields
PROV_METHOD_S Struct Reference
Structures

Provisioning method information. More...

#include <MS_prov_api.h>

Data Fields

UCHAR | algorithm
Algorithm selected.
UCHAR | pubkey
Public key usage.
UCHAR | auth
Authentication type.
PROV_OOB_TYPE_S oob
OOB type.

Detailed Description

Provisioning method information.

Definition at line 433 of file MS_prov_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_prov_api.h


EtherMind Mesh SDK (beta): PROV_DATA_S Struct Reference

Data Fields
PROV_DATA_S Struct Reference
Structures

Data exchanged during Provisiong procedure. More...

#include <MS_prov_api.h>

Data Fields

UCHAR | netkey [PROV_KEY_NETKEY_SIZE]
NetKey.
UINT16 | keyid
Index of the NetKey.
UCHAR | flags
Flags bitmask bit 0: Key Refresh Flag. More...
UINT32 | ivindex
Current value of the IV index.
UINT16 | uaddr
Unicast address of the primary element.

Detailed Description

Data exchanged during Provisiong procedure.

Definition at line 450 of file MS_prov_api.h.

Field Documentation

UCHAR PROV_DATA_S::flags

Flags bitmask bit 0: Key Refresh Flag.

   0: Not-In-Phase2
   1: In-Phase2

bit 1: IV Update Flag 0: Normal operation 1: IV Update active

bits 2-7: RFU

Definition at line 469 of file MS_prov_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_prov_api.h


EtherMind Mesh SDK (beta): Utility Macros

Macros
Utility Macros
PROVISIONING (Mesh Provisioning Layer)

Initialization and other Utility Macros offered by the module. More...

Macros

#define | MS_prov_setup_device_pbadv(pdev, tmo, phdl) MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_ADV, (pdev), (tmo), (phdl))
Setup the Device for provisioning. More...
#define | MS_prov_setup_provisioner_pbadv(tmo, phdl) MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_ADV, NULL, (tmo), (phdl))
Setup the Provisioner for provisioning. More...
#define | MS_prov_setup_device_pbgatt(pdev, tmo, phdl) MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_GATT, (pdev), (tmo), (phdl))
Setup the device for provisioning. More...
#define | MS_prov_setup_provisioner_pbgatt(tmo, phdl) MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_GATT, NULL, (tmo), (phdl))
Setup the Provisioner for provisioning. More...
#define | MS_prov_start(phandle, pmethod) MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_START, (pmethod), sizeof(PROV_METHOD_S))
Start Provisioning on the select set of device capabilities. More...
#define | MS_prov_input_authval(phandle, pauth, size) MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_INPUT_CMPLT, (pauth), (size))
Input Authentication value from Device/Provisioner application. More...
#define | MS_prov_data(phandle, pdata) MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_DATA, (pdata), sizeof (PROV_DATA_S))
Send provisioning data to the device. More...

Detailed Description

Initialization and other Utility Macros offered by the module.

Macro Definition Documentation

#define MS_prov_setup_device_pbadv | ( | pdev,
 |  | tmo,
 |  | phdl
 | ) | MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_ADV, (pdev), (tmo), (phdl))

Setup the Device for provisioning.

Description This function configures the application as an Unprovisioned
device over Advertising channel bearer and sets it ready for provisioning.
Parameters
[in] | pdev | Pointer to the device strcuture PROV_DEVICE_S.
[in] | tmo | The setup timeout value
[out] | phdl | The handle to the context setup on successful allocation
Returns
API_SUCCESS or Error Code on failure

Definition at line 531 of file MS_prov_api.h.

#define MS_prov_setup_provisioner_pbadv | ( | tmo,
 |  | phdl
 | ) | MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_ADV, NULL, (tmo), (phdl))

Setup the Provisioner for provisioning.

Description This function configures the application as a Provisioner
over Advertising channel bearer and sets it ready for provisioning.
Parameters
[in] | tmo | The setup timeout value
[out] | phdl | The handle to the context setup on successful allocation
Returns
API_SUCCESS or Error Code on failure

Definition at line 545 of file MS_prov_api.h.

#define MS_prov_setup_device_pbgatt | ( | pdev,
 |  | tmo,
 |  | phdl
 | ) | MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_GATT, (pdev), (tmo), (phdl))

Setup the device for provisioning.

Description This function configures the application as an Unprovisioned
device over GATT channel bearer and sets it ready for provisioning.
Parameters
[in] | pdev | Pointer to the device strcuture PROV_DEVICE_S.
[in] | tmo | The setup timeout value
[out] | phdl | The handle to the context setup on successful allocation
Returns
API_SUCCESS or Error Code on failure

Definition at line 560 of file MS_prov_api.h.

#define MS_prov_setup_provisioner_pbgatt | ( | tmo,
 |  | phdl
 | ) | MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_GATT, NULL, (tmo), (phdl))

Setup the Provisioner for provisioning.

Description This function configures the application as a Provisioner
over GATT channel bearer and sets it ready for provisioning.
Parameters
[in] | tmo | The setup timeout value
[out] | phdl | The handle to the context setup on successful allocation
Returns
API_SUCCESS or Error Code on failure

Definition at line 574 of file MS_prov_api.h.

#define MS_prov_start | ( | phandle,
 |  | pmethod
 | ) | MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_START, (pmethod), sizeof(PROV_METHOD_S))

Start Provisioning on the select set of device capabilities.

Description This function is used by the provisioner application to start
the procedure using the selected set of capabilities of the unprovisioned device.
Parameters
[in] | phandle | Provisioning context to be used.
[in] | pmethod | Pointer to the structure with selected method.
Note
This API will be used by the provisioner only, in response to the PROV_EVT_PROVISIONING_SETUP event
Returns
API_SUCCESS or Error Code on failure

Definition at line 592 of file MS_prov_api.h.

#define MS_prov_input_authval | ( | phandle,
 |  | pauth,
 |  | size
 | ) | MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_INPUT_CMPLT, (pauth), (size))

Input Authentication value from Device/Provisioner application.

Description This function is used to receive the Authval from the
application and use it for the algorithm. When the application is that of a device, it also sends the input complete message to the provisioner in the given context.
Parameters
[in] | phandle | Provisioning context to be used.
[in] | pauth | Authentication Value (UINT32 *) or (UCHAR *)
[in] | size | Size of pauth
Note
This API will be used in response to the PROV_EVT_OOB_ENTRY event
Returns
API_SUCCESS or Error Code on failure

Definition at line 612 of file MS_prov_api.h.

#define MS_prov_data | ( | phandle,
 |  | pdata
 | ) | MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_DATA, (pdata), sizeof (PROV_DATA_S))

Send provisioning data to the device.

Description This function is used by the provisioning application to send
the provisioning data to the device after authentication is complete.
Parameters
[in] | phandle | Provisioning context to be used.
[in] | pdata | Pointer to the Provisioning data structre as in PROV_DATA_S
Note
This API will be used by the provisioner only, in response to the PROV_EVT_PROVDATA_INFO_REQ event
Returns
API_SUCCESS or Error Code on failure

Definition at line 630 of file MS_prov_api.h.


EtherMind Mesh SDK (beta): SCENE (Mesh Scene Model)

Modules | Macros
SCENE (Mesh Scene Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Scene Model (SCENE) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Scene Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Macros

#define | MS_SCENE_EVENT_STORE 0x01
Scene Event Types. More...
#define | MS_SCENE_EVENT_DELETE 0x02
Scene Event - Delete.
#define | MS_SCENE_EVENT_RECALL_START 0x03
Scene Event - Recall Start.
#define | MS_SCENE_EVENT_RECALL_COMPLETE 0x04
Scene Event - Recall Complete.
#define | MS_SCENE_EVENT_RECALL_IMMEDIATE 0x05
Scene Event - Recall Immediate.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Scene Model (SCENE) module to the Application.

Macro Definition Documentation

#define MS_SCENE_EVENT_STORE 0x01

Scene Event Types.

Scene Event - Store

Definition at line 31 of file MS_scene_api.h.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
SCENE (Mesh Scene Model)

This section describes the EtherMind Mesh Scene Model APIs. More...

Modules

Scene Client API Definitions
This section describes the Scene Client APIs.
Scene Server API Definitions
This section describes the Scene Server APIs.

Detailed Description

This section describes the EtherMind Mesh Scene Model APIs.


EtherMind Mesh SDK (beta): Scene Client API Definitions

Macros | Functions
Scene Client API Definitions
API Definitions

This section describes the Scene Client APIs. More...

Macros

#define | MS_scene_recall(param)
API to ecall the current state of an element. More...
#define | MS_scene_recall_unacknowledged(param)
API to ecall the current state of an element. More...
#define | MS_scene_store(param)
API to store the current state of an element as a Scene. More...
#define | MS_scene_delete_unacknowledged(param)
API to delete a Scene from the Scene Register state of an element. More...
#define | MS_scene_get()
API to get the current status of a currently active scene of an element. More...
#define | MS_scene_delete(param)
API to delete a Scene from the Scene Register state of an element. More...
#define | MS_scene_store_unacknowledged(param)
API to store the current state of an element as a Scene. More...
#define | MS_scene_register_get()
API to get the current status of the Scene Register of an element. More...

Functions

API_RESULT | MS_scene_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SCENE_CLIENT_CB appl_cb)
API to initialize Scene Client model. More...
API_RESULT | MS_scene_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Scene client model handle. More...
API_RESULT | MS_scene_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Scene Client APIs.

Macro Definition Documentation

#define MS_scene_recall ( param )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_RECALL_OPCODE,\
param,\
MS_ACCESS_SCENE_STATUS_OPCODE\
)

API to ecall the current state of an element.

Description
Scene Recall is an acknowledged message that is used to recall the current state of an element from a previously stored scene. The response to the Scene Recall message is a Scene Status message.
Parameters
[in] param Scene Recall message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 341 of file MS_scene_api.h.

#define MS_scene_recall_unacknowledged ( param )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_RECALL_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to ecall the current state of an element.

Description
Scene Recall Unacknowledged is an unacknowledged message used to recall the current state of an element from a previously stored Scene.
Parameters
[in] param Scene Recall message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 359 of file MS_scene_api.h.

#define MS_scene_store ( param )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_STORE_OPCODE,\
param,\
MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE\
)

API to store the current state of an element as a Scene.

Description
Scene Store is an acknowledged message used to store the current state of an element as a Scene, which can be recalled later. The response to the Scene Store message is a Scene Register Status message.
Parameters
[in] param Scene Store message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 378 of file MS_scene_api.h.

#define MS_scene_delete_unacknowledged ( param )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_DELETE_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to delete a Scene from the Scene Register state of an element.

Description
Scene Delete Unacknowledged is an unacknowledged message used to delete a scene from the Scene Register state of an element.
Parameters
[in] param Scene Delete parameter
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 396 of file MS_scene_api.h.

#define MS_scene_get ( )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_GET_OPCODE,\
NULL,\
MS_ACCESS_SCENE_STATUS_OPCODE\
)

API to get the current status of a currently active scene of an element.

Description
Scene Get is an acknowledged message used to get the current status of a currently active scene of an element. The response to the Scene Get message is a Scene Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 414 of file MS_scene_api.h.

#define MS_scene_delete ( param )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_DELETE_OPCODE,\
param,\
MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE\
)

API to delete a Scene from the Scene Register state of an element.

Description
Scene Delete is an acknowledged message used to delete a Scene from the Scene Register state of an element. The response to the Scene Delete message is a Scene Register Status message.
Parameters
[in] param Scene Delete parameter
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 433 of file MS_scene_api.h.

#define MS_scene_store_unacknowledged ( param )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_STORE_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to store the current state of an element as a Scene.

Description
Scene Store Unacknowledged is an unacknowledged message used to store the current state of an element as a Scene, which can be recalled later.
Parameters
[in] param Scene Store message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 451 of file MS_scene_api.h.

#define MS_scene_register_get ( )
Value:
MS_scene_client_send_reliable_pdu \
(\
MS_ACCESS_SCENE_REGISTER_GET_OPCODE,\
NULL,\
MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE\
)

API to get the current status of the Scene Register of an element.

Description
Scene Register Get is an acknowledged message used to get the current status of the Scene Register of an element. The response to the Scene Register Get message is a Scene Register Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 469 of file MS_scene_api.h.

Function Documentation

API_RESULT MS_scene_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_SCENE_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Scene Client model.

Description
This is to initialize Scene Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Scene Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_scene_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Scene client model handle.

Description
This is to get the handle of Scene client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_scene_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Scene Server API Definitions

Functions
Scene Server API Definitions
API Definitions

This section describes the Scene Server APIs. More...

Functions

API_RESULT | MS_scene_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *scene_model_handle, MS_ACCESS_MODEL_HANDLE *scene_setup_model_handle, MS_SCENE_SERVER_CB appl_cb)
API to initialize Scene Server model. More...
API_RESULT | MS_scene_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Scene Server APIs.

Function Documentation

API_RESULT MS_scene_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | scene_model_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | scene_setup_model_handle,
 |  | MS_SCENE_SERVER_CB | appl_cb
 | ) |  |

API to initialize Scene Server model.

Description
This is to initialize Scene Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | scene_model_handle | Model identifier associated with the Scene model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in,out] | scene_setup_model_handle | Model identifier associated with the Scene Setup model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Scene Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_scene_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
SCENE (Mesh Scene Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef void *(* | MS_SCENE_SERVER_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT8 event_type, void *event_param, UINT16 event_length, void *context) DECL_REENTRANT
Scene Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SCENE_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Scene Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef void*(* MS_SCENE_SERVER_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT8 event_type, void *event_param, UINT16 event_length, void *context) DECL_REENTRANT

Scene Server application Asynchronous Notification Callback.

Scene Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

TODO: Update

Definition at line 68 of file MS_scene_api.h.

typedef API_RESULT(* MS_SCENE_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Scene Client application Asynchronous Notification Callback.

Scene Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 88 of file MS_scene_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
SCENE (Mesh Scene Model)

Data Structures

struct | MS_SCENE_RECALL_STRUCT
Scene Recall message parameters. More...
struct | MS_SCENE_STATUS_STRUCT
Scene Status message parameters. More...
struct | MS_SCENE_REGISTER_STATUS_STRUCT
Scene Register Status message parameters. More...
struct | MS_SCENE_STRUCT
Scene Store message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_SCENE_RECALL_STRUCT Struct Reference

Data Fields
MS_SCENE_RECALL_STRUCT Struct Reference
Structures

Scene Recall message parameters. More...

#include <MS_scene_api.h>

Data Fields

UINT16 | scene_number
The number of the scene to be recalled. More...
UCHAR | tid
Transaction Identifier.
UCHAR | transition_time
Transition Time is a 1-octet value that consists of two fields: More...
UCHAR | delay
Message execution delay in 5 milliseconds steps.
UCHAR | optional_fields_present
Flag: To represent if optional Transaction time and Delay fields are valid.

Detailed Description

Scene Recall message parameters.

Definition at line 104 of file MS_scene_api.h.

Field Documentation

UINT16 MS_SCENE_RECALL_STRUCT::scene_number

The number of the scene to be recalled.

Definition at line 107 of file MS_scene_api.h.

UCHAR MS_SCENE_RECALL_STRUCT::transition_time

Transition Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 123 of file MS_scene_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scene_api.h


EtherMind Mesh SDK (beta): MS_SCENE_STATUS_STRUCT Struct Reference

Data Fields
MS_SCENE_STATUS_STRUCT Struct Reference
Structures

Scene Status message parameters. More...

#include <MS_scene_api.h>

Data Fields

UCHAR | status_code
Status Code.
UINT16 | current_scene
Scene Number of a current scene. More...
UINT16 | target_scene
Scene Number of a target scene. More...
UCHAR | remaining_time
Remaining Time is a 1-octet value that consists of two fields: More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Target Scene and Remaining Time are valid.

Detailed Description

Scene Status message parameters.

Definition at line 136 of file MS_scene_api.h.

Field Documentation

UINT16 MS_SCENE_STATUS_STRUCT::current_scene

Scene Number of a current scene.

Definition at line 142 of file MS_scene_api.h.

UINT16 MS_SCENE_STATUS_STRUCT::target_scene

Scene Number of a target scene.

(Optional)

Definition at line 145 of file MS_scene_api.h.

UCHAR MS_SCENE_STATUS_STRUCT::remaining_time

Remaining Time is a 1-octet value that consists of two fields:

  • a 2-bit bit field representing the step resolution
  • a 6-bit bit field representing the number of transition steps.
Field | Size (bits) | Description
Transition Number of Steps | 6 | The number of Steps
Transition Step Resolution | 2 | The resolution of the Default Transition

| Number of Steps field

Definition at line 158 of file MS_scene_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scene_api.h


EtherMind Mesh SDK (beta): MS_SCENE_REGISTER_STATUS_STRUCT Struct Reference

Data Fields
MS_SCENE_REGISTER_STATUS_STRUCT Struct Reference
Structures

Scene Register Status message parameters. More...

#include <MS_scene_api.h>

Data Fields

UCHAR | status_code
Status Code.
UINT16 | current_scene
Scene Number of a current scene.
UCHAR * | scenes
A list of scenes stored within an element.
UINT16 | scenes_len
Number of Scenes.

Detailed Description

Scene Register Status message parameters.

Definition at line 168 of file MS_scene_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scene_api.h


EtherMind Mesh SDK (beta): MS_SCENE_STRUCT Struct Reference

Data Fields
MS_SCENE_STRUCT Struct Reference
Structures

Scene Store message parameters. More...

#include <MS_scene_api.h>

Data Fields

UINT16 scene_number
The number of the scene to be stored. More...

Detailed Description

Scene Store message parameters.

Definition at line 187 of file MS_scene_api.h.

Field Documentation

UINT16 MS_SCENE_STRUCT::scene_number

The number of the scene to be stored.

Definition at line 190 of file MS_scene_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scene_api.h


EtherMind Mesh SDK (beta): SCHEDULER (Mesh Scheduler Model)

Modules
SCHEDULER (Mesh Scheduler Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Scheduler Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
SCHEDULER (Mesh Scheduler Model)

This section describes the EtherMind Mesh Scheduler Model APIs. More...

Modules

Scheduler Client API Definitions
This section describes the Scheduler Client APIs.
Scheduler Server API Definitions
This section describes the Scheduler Server APIs.

Detailed Description

This section describes the EtherMind Mesh Scheduler Model APIs.


EtherMind Mesh SDK (beta): Scheduler Client API Definitions

Macros | Functions
Scheduler Client API Definitions
API Definitions

This section describes the Scheduler Client APIs. More...

Macros

#define | MS_scheduler_action_set(param)
API to set the entry of the Schedule Register state of an element. More...
#define | MS_scheduler_get()
API to get the current Schedule Register state of an element. More...
#define | MS_scheduler_action_set_unacknowledged(param)
API to set the entry of the Schedule Register state of an element. More...
#define | MS_scheduler_action_get(param)
API to report the action defined by the entry of the Schedule Register state of an element, identified by the Index field. More...

Functions

API_RESULT | MS_scheduler_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SCHEDULER_CLIENT_CB appl_cb)
API to initialize Scheduler Client model. More...
API_RESULT | MS_scheduler_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Scheduler client model handle. More...
API_RESULT | MS_scheduler_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Scheduler Client APIs.

Macro Definition Documentation

#define MS_scheduler_action_set ( param )
Value:
MS_scheduler_client_send_reliable_pdu \
(\
MS_ACCESS_SCHEDULER_ACTION_SET_OPCODE,\
param,\
MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE\
)

API to set the entry of the Schedule Register state of an element.

Description
Scheduler Action Set is an acknowledged message used to set the entry of the Schedule Register state of an element, identified by the Index field. The response to the Scheduler Action Set message is a Scheduler Action Status message.
Parameters
[in] param Scheduler Action Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 335 of file MS_scheduler_api.h.

#define MS_scheduler_get ( )
Value:
MS_scheduler_client_send_reliable_pdu \
(\
MS_ACCESS_SCHEDULER_GET_OPCODE,\
NULL,\
MS_ACCESS_SCHEDULER_STATUS_OPCODE\
)

API to get the current Schedule Register state of an element.

Description
Scheduler Get is an acknowledged message used to get the current Schedule Register state of an element. The response to the Scheduler Get message is a Scheduler Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 353 of file MS_scheduler_api.h.

#define MS_scheduler_action_set_unacknowledged ( param )
Value:
MS_scheduler_client_send_reliable_pdu \
(\
MS_ACCESS_SCHEDULER_ACTION_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the entry of the Schedule Register state of an element.

Description
Scheduler Action Set Unacknowledged is an unacknowledged message used to set the entry of the Schedule Register state of an element, identified by the Index field.
Parameters
[in] param Scheduler Action Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 372 of file MS_scheduler_api.h.

#define MS_scheduler_action_get ( param )
Value:
MS_scheduler_client_send_reliable_pdu \
(\
MS_ACCESS_SCHEDULER_ACTION_GET_OPCODE,\
param,\
MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE\
)

API to report the action defined by the entry of the Schedule Register state of an element, identified by the Index field.

Description
Scheduler Action Get is an acknowledged message used to report the action defined by the entry of the Schedule Register state of an element, identified by the Index field. The response to the Scheduler Action Get message is a Scheduler Action Status message.
Parameters
[in] param Scheduler Action Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 393 of file MS_scheduler_api.h.

Function Documentation

API_RESULT MS_scheduler_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_SCHEDULER_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Scheduler Client model.

Description
This is to initialize Scheduler Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Scheduler Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_scheduler_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Scheduler client model handle.

Description
This is to get the handle of Scheduler client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_scheduler_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Scheduler Server API Definitions

Functions
Scheduler Server API Definitions
API Definitions

This section describes the Scheduler Server APIs. More...

Functions

API_RESULT | MS_scheduler_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *scheduler_model_handle, MS_ACCESS_MODEL_HANDLE *scheduler_setup_model_handle, MS_SCHEDULER_SERVER_CB appl_cb)
API to initialize Scheduler Server model. More...
API_RESULT | MS_scheduler_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Scheduler Server APIs.

Function Documentation

API_RESULT MS_scheduler_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | scheduler_model_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | scheduler_setup_model_handle,
 |  | MS_SCHEDULER_SERVER_CB | appl_cb
 | ) |  |

API to initialize Scheduler Server model.

Description
This is to initialize Scheduler Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | scheduler_model_handle | Model identifier associated with the Scheduler model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in,out] | scheduler_setup_model_handle | Model identifier associated with the Scheduler Setup model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Scheduler Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_scheduler_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
SCHEDULER (Mesh Scheduler Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_SCHEDULER_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Scheduler Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SCHEDULER_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Scheduler Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_SCHEDULER_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Scheduler Server application Asynchronous Notification Callback.

Scheduler Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_scheduler_api.h.

typedef API_RESULT(* MS_SCHEDULER_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Scheduler Client application Asynchronous Notification Callback.

Scheduler Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_scheduler_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
SCHEDULER (Mesh Scheduler Model)

Data Structures

struct | MS_SCHEDULER_STATUS_STRUCT
Scheduler Status message parameters. More...
struct | MS_SCHEDULER_ACTION_GET_STRUCT
Scheduler Action Get message parameters. More...
struct | MS_SCHEDULER_ACTION_STATUS_STRUCT
Scheduler Action Status message parameters. More...
struct | MS_SCHEDULER_ACTION_SET_STRUCT
Scheduler Action Set message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_SCHEDULER_STATUS_STRUCT Struct Reference

Data Fields
MS_SCHEDULER_STATUS_STRUCT Struct Reference
Structures

Scheduler Status message parameters. More...

#include <MS_scheduler_api.h>

Data Fields

UINT16 schedules
Bit field indicating defined Actions in the Schedule Register.

Detailed Description

Scheduler Status message parameters.

Definition at line 89 of file MS_scheduler_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scheduler_api.h


EtherMind Mesh SDK (beta): MS_SCHEDULER_ACTION_GET_STRUCT Struct Reference

Data Fields
MS_SCHEDULER_ACTION_GET_STRUCT Struct Reference
Structures

Scheduler Action Get message parameters. More...

#include <MS_scheduler_api.h>

Data Fields

UCHAR index
Index of the Schedule Register entry to get.

Detailed Description

Scheduler Action Get message parameters.

Definition at line 99 of file MS_scheduler_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scheduler_api.h


EtherMind Mesh SDK (beta): MS_SCHEDULER_ACTION_STATUS_STRUCT Struct Reference

Data Fields
MS_SCHEDULER_ACTION_STATUS_STRUCT Struct Reference
Structures

Scheduler Action Status message parameters. More...

#include <MS_scheduler_api.h>

Data Fields

UCHAR | index
Enumerates (selects) a Schedule Register entry.
UINT8 | year
Scheduled year for the action.
UINT16 | month
Scheduled month for the action.
UINT8 | day
Scheduled day of the month for the action.
UINT8 | hour
Scheduled hour for the action.
UINT8 | minute
Scheduled minute for the action.
UINT8 | second
Scheduled second for the action.
UINT8 | day_of_week
Schedule days of the week for the action.
UINT8 | action
Action to be performed at the scheduled time.
UINT8 | transition_time
Transition time for this action.
UINT16 | scene_number
Scene number to be used for some actions.

Detailed Description

Scheduler Action Status message parameters.

TODO: Merge with MS_scheduler_action_set_struct

Definition at line 111 of file MS_scheduler_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scheduler_api.h


EtherMind Mesh SDK (beta): MS_SCHEDULER_ACTION_SET_STRUCT Struct Reference

Data Fields
MS_SCHEDULER_ACTION_SET_STRUCT Struct Reference
Structures

Scheduler Action Set message parameters. More...

#include <MS_scheduler_api.h>

Data Fields

UCHAR | index
Index of the Schedule Register entry to set.
UINT8 | year
Scheduled year for the action.
UINT16 | month
Scheduled month for the action.
UINT8 | day
Scheduled day of the month for the action.
UINT8 | hour
Scheduled hour for the action.
UINT8 | minute
Scheduled minute for the action.
UINT8 | second
Scheduled second for the action.
UINT8 | day_of_week
Schedule days of the week for the action.
UINT8 | action
Action to be performed at the scheduled time.
UINT8 | transition_time
Transition time for this action.
UINT16 | scene_number
Scene number to be used for some actions.

Detailed Description

Scheduler Action Set message parameters.

Definition at line 150 of file MS_scheduler_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_scheduler_api.h


EtherMind Mesh SDK (beta): SENSOR (Mesh Sensor Model)

Modules
SENSOR (Mesh Sensor Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Sensor Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
SENSOR (Mesh Sensor Model)

This section describes the EtherMind Mesh Sensor Model APIs. More...

Modules

Sensor Client API Definitions
This section describes the Sensor Client APIs.
Sensor Server API Definitions
This section describes the Sensor Server APIs.

Detailed Description

This section describes the EtherMind Mesh Sensor Model APIs.


EtherMind Mesh SDK (beta): Sensor Client API Definitions

Macros | Functions
Sensor Client API Definitions
API Definitions

This section describes the Sensor Client APIs. More...

Macros

#define | MS_sensor_setting_get(param)
API to get the Sensor Setting state of an element. More...
#define | MS_sensor_settings_get(param)
API to get the list of Sensor Setting states of an element. More...
#define | MS_sensor_series_get(param)
API to get a sequence of the Sensor Series Column states. More...
#define | MS_sensor_cadence_get(param)
API to get the Sensor Cadence state of an element. More...
#define | MS_sensor_descriptor_get(param)
API to get the Sensor Descriptor state of all sensors within an element. More...
#define | MS_sensor_cadence_set(param)
API to set the Sensor Cadence state of an element. More...
#define | MS_sensor_setting_set(param)
API to set the Sensor Setting state of an element. More...
#define | MS_sensor_get(param)
API to get the Sensor Data state. More...
#define | MS_sensor_column_get(param)
API to get the Sensor Series Column state. More...
#define | MS_sensor_cadence_set_unacknowledged(param)
API to set the Sensor Cadence state of an element. More...
#define | MS_sensor_setting_set_unacknowledged(param)
API to set the Sensor Setting state of an element. More...

Functions

API_RESULT | MS_sensor_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SENSOR_CLIENT_CB appl_cb)
API to initialize Sensor Client model. More...
API_RESULT | MS_sensor_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Sensor client model handle. More...
API_RESULT | MS_sensor_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Sensor Client APIs.

Macro Definition Documentation

#define MS_sensor_setting_get ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_SETTING_GET_OPCODE,\
param,\
MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE\
)

API to get the Sensor Setting state of an element.

Description
Sensor Setting Get is an acknowledged message used to get the Sensor Setting state of an element. The response to the Sensor Setting Get message is a Sensor Setting Status message.
Parameters
[in] param Sensor Setting Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 635 of file MS_sensor_api.h.

#define MS_sensor_settings_get ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_SETTINGS_GET_OPCODE,\
param,\
MS_ACCESS_SENSOR_SETTINGS_STATUS_OPCODE\
)

API to get the list of Sensor Setting states of an element.

Description
Sensor Settings Get is an acknowledged message used to get the list of Sensor Setting states of an element. The response to the Sensor Settings Get message is a Sensor Settings Status message
Parameters
[in] param Sensor Settings Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 654 of file MS_sensor_api.h.

#define MS_sensor_series_get ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_SERIES_GET_OPCODE,\
param,\
MS_ACCESS_SENSOR_SERIES_STATUS_OPCODE\
)

API to get a sequence of the Sensor Series Column states.

Description
Sensor Series Get is an acknowledged message used to get a sequence of the Sensor Series Column states. The response to the Sensor Series Get message is a Sensor Series Status message.
Parameters
[in] param Sensor Series Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 673 of file MS_sensor_api.h.

#define MS_sensor_cadence_get ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_CADENCE_GET_OPCODE,\
param,\
MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE\
)

API to get the Sensor Cadence state of an element.

Description
Sensor Cadence Get is an acknowledged message used to get the Sensor Cadence state of an element. The response to the Sensor Cadence Get message is a Sensor Cadence Status message.
Parameters
[in] param Sensor Cadence Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 692 of file MS_sensor_api.h.

#define MS_sensor_descriptor_get ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_DESCRIPTOR_GET_OPCODE,\
param,\
MS_ACCESS_SENSOR_DESCRIPTOR_STATUS_OPCODE\
)

API to get the Sensor Descriptor state of all sensors within an element.

Description
Sensor Descriptor Get is an acknowledged message used to get the Sensor Descriptor state of all sensors within an element. The response to a Sensor Descriptor Get message is a Sensor Descriptor Status message.
Parameters
[in] param Sensor Descriptor Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 711 of file MS_sensor_api.h.

#define MS_sensor_cadence_set ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_CADENCE_SET_OPCODE,\
param,\
MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE\
)

API to set the Sensor Cadence state of an element.

Description
Sensor Cadence Set is an acknowledged message used to set the Sensor Cadence state of an element. The response to the Sensor Cadence Set message is a Sensor Cadence Status message.
Parameters
[in] param Sensor Cadence Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 730 of file MS_sensor_api.h.

#define MS_sensor_setting_set ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_SETTING_SET_OPCODE,\
param,\
MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE\
)

API to set the Sensor Setting state of an element.

Description
Sensor Setting Set is an acknowledged message used to set the Sensor Setting state of an element. The response to the Sensor Setting Set message is a Sensor Setting Status message.
Parameters
[in] param Sensor Setting Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 749 of file MS_sensor_api.h.

#define MS_sensor_get ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_GET_OPCODE,\
param,\
MS_ACCESS_SENSOR_STATUS_OPCODE\
)

API to get the Sensor Data state.

Description
Sensor Get is an acknowledged message used to get the Sensor Data state. The response to the Sensor Get message is a Sensor Status message.
Parameters
[in] param Sensor Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 768 of file MS_sensor_api.h.

#define MS_sensor_column_get ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_COLUMN_GET_OPCODE,\
param,\
MS_ACCESS_SENSOR_COLUMN_STATUS_OPCODE\
)

API to get the Sensor Series Column state.

Description
Sensor Column Get is an acknowledged message used to get the Sensor Series Column state. The response to the Sensor Column Get message is a Sensor Column Status message
Parameters
[in] param Sensor Column Get message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 787 of file MS_sensor_api.h.

#define MS_sensor_cadence_set_unacknowledged ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_CADENCE_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Sensor Cadence state of an element.

Description
Sensor Cadence Set Unacknowledged is an unacknowledged message used to set the Sensor Cadence state of an element.
Parameters
[in] param Sensor Cadence Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 805 of file MS_sensor_api.h.

#define MS_sensor_setting_set_unacknowledged ( param )
Value:
MS_sensor_client_send_reliable_pdu \
(\
MS_ACCESS_SENSOR_SETTING_SET_UNACKNOWLEDGED_OPCODE,\
param,\
0xFFFFFFFF\
)

API to set the Sensor Setting state of an element.

Description
Sensor Setting Set Unacknowledged is an unacknowledged message used to set the Sensor Setting state of an element.
Parameters
[in] param Sensor Setting Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 823 of file MS_sensor_api.h.

Function Documentation

API_RESULT MS_sensor_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_SENSOR_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Sensor Client model.

Description
This is to initialize Sensor Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Sensor Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_sensor_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Sensor client model handle.

Description
This is to get the handle of Sensor client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_sensor_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Sensor Server API Definitions

Functions
Sensor Server API Definitions
API Definitions

This section describes the Sensor Server APIs. More...

Functions

API_RESULT | MS_sensor_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SENSOR_SERVER_CB appl_cb)
API to initialize Sensor Server model. More...
API_RESULT | MS_sensor_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SENSOR_SETUP_SERVER_CB appl_cb)
API to initialize Sensor_Setup Server model. More...
API_RESULT | MS_sensor_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_sensor_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Sensor Server APIs.

Function Documentation

API_RESULT MS_sensor_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_SENSOR_SERVER_CB | appl_cb
 | ) |  |

API to initialize Sensor Server model.

Description
This is to initialize Sensor Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Sensor Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_sensor_setup_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_SENSOR_SETUP_SERVER_CB | appl_cb
 | ) |  |

API to initialize Sensor_Setup Server model.

Description
This is to initialize Sensor_Setup Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Sensor_Setup Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_sensor_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_sensor_setup_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
SENSOR (Mesh Sensor Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_SENSOR_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Sensor Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SENSOR_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Sensor Setup Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SENSOR_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Sensor Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_SENSOR_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Sensor Server application Asynchronous Notification Callback.

Sensor Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_sensor_api.h.

typedef API_RESULT(* MS_SENSOR_SETUP_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Sensor Setup Server application Asynchronous Notification Callback.

Sensor Setup Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 74 of file MS_sensor_api.h.

typedef API_RESULT(* MS_SENSOR_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Sensor Client application Asynchronous Notification Callback.

Sensor Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 95 of file MS_sensor_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
SENSOR (Mesh Sensor Model)

Data Structures

struct | MS_SENSOR_DESCRIPTOR_GET_STRUCT
Sensor Descriptor Get message parameters. More...
struct | MS_SENSOR_DESCRIPTOR_STATUS_STRUCT
Sensor Descriptor Status message parameters. More...
struct | MS_SENSOR_GET_STRUCT
Sensor Get message parameters. More...
struct | MS_SENSOR_STATUS_STRUCT
Sensor Status message parameters. More...
struct | MS_SENSOR_COLUMN_GET_STRUCT
Sensor Column Get message parameters. More...
struct | MS_SENSOR_COLUMN_STATUS_STRUCT
Sensor Column Status message parameters. More...
struct | MS_SENSOR_SERIES_GET_STRUCT
Sensor Series Get message parameters. More...
struct | MS_SENSOR_SERIES_STATUS_STRUCT
Sensor Series Status message parameters. More...
struct | MS_SENSOR_CADENCE_GET_STRUCT
Sensor Cadence Get message parameters. More...
struct | MS_SENSOR_CADENCE_SET_STRUCT
Sensor Cadence Set message parameters. More...
struct | MS_SENSOR_CADENCE_STATUS_STRUCT
Sensor Cadence Status message parameters. More...
struct | MS_SENSOR_SETTINGS_GET_STRUCT
Sensor Settings Get message parameters. More...
struct | MS_SENSOR_SETTINGS_STATUS_STRUCT
Sensor Setting Status message parameters. More...
struct | MS_SENSOR_SETTING_GET_STRUCT
Sensor Setting Get message parameters. More...
struct | MS_SENSOR_SETTING_SET_STRUCT
Sensor Setting Set message parameters. More...
struct | MS_SENSOR_SETTING_STATUS_STRUCT
Sensor Setting Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_SENSOR_DESCRIPTOR_GET_STRUCT Struct Reference

Data Fields
MS_SENSOR_DESCRIPTOR_GET_STRUCT Struct Reference
Structures

Sensor Descriptor Get message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property ID for the sensor (Optional)
UCHAR | optional_fields_present
Flag: To represent if optional field Property ID is valid.

Detailed Description

Sensor Descriptor Get message parameters.

Definition at line 111 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_DESCRIPTOR_STATUS_STRUCT Struct Reference

Data Fields
MS_SENSOR_DESCRIPTOR_STATUS_STRUCT Struct Reference
Structures

Sensor Descriptor Status message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UCHAR * | descriptor
Sequence of 8-octet Sensor Descriptors (Optional)
UCHAR | optional_fields_present
Flag: To represent if optional field Descriptors are valid.

Detailed Description

Sensor Descriptor Status message parameters.

Definition at line 124 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_GET_STRUCT Struct Reference

Data Fields
MS_SENSOR_GET_STRUCT Struct Reference
Structures

Sensor Get message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property for the sensor. More...
UCHAR | optional_fields_present
Flag: To represent if optional field Property ID is valid.

Detailed Description

Sensor Get message parameters.

Definition at line 137 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_GET_STRUCT::property_id

Property for the sensor.

Definition at line 140 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_STATUS_STRUCT Struct Reference

Data Fields
MS_SENSOR_STATUS_STRUCT Struct Reference
Structures

Sensor Status message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UCHAR * | marshalled_sensor_data
The Marshaled Sensor Data. More...
UINT16 | marshalled_sensor_data_len
The Marshaled Sensor Data Length . More...
UCHAR | optional_fields_present
Flag: To represent if optional field Marshaled Sensor Data is valid.

Detailed Description

Sensor Status message parameters.

Definition at line 150 of file MS_sensor_api.h.

Field Documentation

UCHAR* MS_SENSOR_STATUS_STRUCT::marshalled_sensor_data

The Marshaled Sensor Data.

Definition at line 153 of file MS_sensor_api.h.

UINT16 MS_SENSOR_STATUS_STRUCT::marshalled_sensor_data_len

The Marshaled Sensor Data Length .

Definition at line 156 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_COLUMN_GET_STRUCT Struct Reference

Data Fields
MS_SENSOR_COLUMN_GET_STRUCT Struct Reference
Structures

Sensor Column Get message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property identifying a sensor.
UCHAR * | raw_value_x
Raw value identifying a column.
UINT16 | raw_value_x_len
Raw value length identifying a column.

Detailed Description

Sensor Column Get message parameters.

Definition at line 166 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_COLUMN_STATUS_STRUCT Struct Reference

Data Fields
MS_SENSOR_COLUMN_STATUS_STRUCT Struct Reference
Structures

Sensor Column Status message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property identifying a sensor and the Y axis. More...
UCHAR * | raw_value_x
Raw value representing the left corner of the column on the X axis. More...
UINT16 | raw_value_x_len
Raw value length representing the left corner of the column on the X axis. More...
UCHAR * | column_width
Raw value representing the width of the column. More...
UINT16 | column_width_len
Raw value length representing the width of the column. More...
UCHAR * | raw_value_y
Raw value representing the height of the column on the Y axis. More...
UINT16 | raw_value_y_len
Raw value length representing the height of the column on the Y axis. More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Column Width and Raw Value Y are valid.

Detailed Description

Sensor Column Status message parameters.

Definition at line 183 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_COLUMN_STATUS_STRUCT::property_id

Property identifying a sensor and the Y axis.

Definition at line 186 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_COLUMN_STATUS_STRUCT::raw_value_x

Raw value representing the left corner of the column on the X axis.

Definition at line 189 of file MS_sensor_api.h.

UINT16 MS_SENSOR_COLUMN_STATUS_STRUCT::raw_value_x_len

Raw value length representing the left corner of the column on the X axis.

Definition at line 192 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_COLUMN_STATUS_STRUCT::column_width

Raw value representing the width of the column.

(Optional)

Definition at line 195 of file MS_sensor_api.h.

UINT16 MS_SENSOR_COLUMN_STATUS_STRUCT::column_width_len

Raw value length representing the width of the column.

(Optional)

Definition at line 198 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_COLUMN_STATUS_STRUCT::raw_value_y

Raw value representing the height of the column on the Y axis.

Definition at line 201 of file MS_sensor_api.h.

UINT16 MS_SENSOR_COLUMN_STATUS_STRUCT::raw_value_y_len

Raw value length representing the height of the column on the Y axis.

Definition at line 204 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_SERIES_GET_STRUCT Struct Reference

Data Fields
MS_SENSOR_SERIES_GET_STRUCT Struct Reference
Structures

Sensor Series Get message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property identifying a sensor. More...
UCHAR * | raw_value_x1
Raw value identifying a starting column. More...
UINT16 | raw_value_x1_len
Raw value length identifying a starting column. More...
UCHAR * | raw_value_x2
Raw value identifying an ending column. More...
UINT16 | raw_value_x2_len
Raw value length identifying an ending column. More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Raw Value X1 and X2 are valid.

Detailed Description

Sensor Series Get message parameters.

Definition at line 214 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_SERIES_GET_STRUCT::property_id

Property identifying a sensor.

Definition at line 217 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_SERIES_GET_STRUCT::raw_value_x1

Raw value identifying a starting column.

(Optional)

Definition at line 220 of file MS_sensor_api.h.

UINT16 MS_SENSOR_SERIES_GET_STRUCT::raw_value_x1_len

Raw value length identifying a starting column.

(Optional)

Definition at line 223 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_SERIES_GET_STRUCT::raw_value_x2

Raw value identifying an ending column.

Definition at line 226 of file MS_sensor_api.h.

UINT16 MS_SENSOR_SERIES_GET_STRUCT::raw_value_x2_len

Raw value length identifying an ending column.

Definition at line 229 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_SERIES_STATUS_STRUCT Struct Reference

Data Fields
MS_SENSOR_SERIES_STATUS_STRUCT Struct Reference
Structures

Sensor Series Status message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property identifying a sensor and the Y axis. More...
UCHAR * | raw_value_x
Raw value representing the left corner of the nth column on the X axis. More...
UINT16 | raw_value_x_len
Number of values in raw_value_x.
UCHAR * | column_width
Raw value representing the width of the nth column. More...
UINT16 | column_width_len
Number of values in column_width.
UCHAR * | raw_value_y
Raw value representing the height of the nth column on the Y axis. More...
UINT16 | raw_value_y_len
Number of values in raw_value_y.

Detailed Description

Sensor Series Status message parameters.

Definition at line 239 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_SERIES_STATUS_STRUCT::property_id

Property identifying a sensor and the Y axis.

Definition at line 242 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_SERIES_STATUS_STRUCT::raw_value_x

Raw value representing the left corner of the nth column on the X axis.

Definition at line 245 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_SERIES_STATUS_STRUCT::column_width

Raw value representing the width of the nth column.

Definition at line 251 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_SERIES_STATUS_STRUCT::raw_value_y

Raw value representing the height of the nth column on the Y axis.

Definition at line 257 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_CADENCE_GET_STRUCT Struct Reference

Data Fields
MS_SENSOR_CADENCE_GET_STRUCT Struct Reference
Structures

Sensor Cadence Get message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 property_id
Property ID for the sensor. More...

Detailed Description

Sensor Cadence Get message parameters.

Definition at line 267 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_CADENCE_GET_STRUCT::property_id

Property ID for the sensor.

Definition at line 270 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_CADENCE_SET_STRUCT Struct Reference

Data Fields
MS_SENSOR_CADENCE_SET_STRUCT Struct Reference
Structures

Sensor Cadence Set message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property ID for the sensor. More...
UCHAR | fast_cadence_period_divisor
Divisor for the Publish Period.
UCHAR | status_trigger_type
Defines the unit and format of the Status Trigger Delta fields. More...
UCHAR * | status_trigger_delta_down
Delta down value that triggers a status message. More...
UINT16 | status_trigger_delta_down_len
Delta down value length that triggers a status message. More...
UCHAR * | status_trigger_delta_up
Delta up value that triggers a status message. More...
UINT16 | status_trigger_delta_up_len
Delta up value length that triggers a status message. More...
UCHAR | status_min_interval
Minimum interval between two consecutive Status messages. More...
UCHAR * | fast_cadence_low
Low value for the fast cadence range. More...
UINT16 | fast_cadence_low_len
Low value length for the fast cadence range. More...
UCHAR * | fast_cadence_high
High value for the fast cadence range. More...
UINT16 | fast_cadence_high_len
High value length for the fast cadence range. More...

Detailed Description

Sensor Cadence Set message parameters.

Definition at line 277 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_CADENCE_SET_STRUCT::property_id

Property ID for the sensor.

Definition at line 280 of file MS_sensor_api.h.

UCHAR MS_SENSOR_CADENCE_SET_STRUCT::status_trigger_type

Defines the unit and format of the Status Trigger Delta fields.

Definition at line 286 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_SET_STRUCT::status_trigger_delta_down

Delta down value that triggers a status message.

Definition at line 289 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_SET_STRUCT::status_trigger_delta_down_len

Delta down value length that triggers a status message.

Definition at line 292 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_SET_STRUCT::status_trigger_delta_up

Delta up value that triggers a status message.

Definition at line 295 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_SET_STRUCT::status_trigger_delta_up_len

Delta up value length that triggers a status message.

Definition at line 298 of file MS_sensor_api.h.

UCHAR MS_SENSOR_CADENCE_SET_STRUCT::status_min_interval

Minimum interval between two consecutive Status messages.

Definition at line 301 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_SET_STRUCT::fast_cadence_low

Low value for the fast cadence range.

Definition at line 304 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_SET_STRUCT::fast_cadence_low_len

Low value length for the fast cadence range.

Definition at line 307 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_SET_STRUCT::fast_cadence_high

High value for the fast cadence range.

Definition at line 310 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_SET_STRUCT::fast_cadence_high_len

High value length for the fast cadence range.

Definition at line 313 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_CADENCE_STATUS_STRUCT Struct Reference

Data Fields
MS_SENSOR_CADENCE_STATUS_STRUCT Struct Reference
Structures

Sensor Cadence Status message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | property_id
Property ID for the sensor. More...
UCHAR | fast_cadence_period_divisor
Divisor for the Publish Period.
UCHAR | status_trigger_type
Defines the unit and format of the Status Trigger Delta fields. More...
UCHAR * | status_trigger_delta_down
Delta down value that triggers a status message. More...
UINT16 | status_trigger_delta_down_len
Delta down value length that triggers a status message. More...
UCHAR * | status_trigger_delta_up
Delta up value that triggers a status message. More...
UINT16 | status_trigger_delta_up_len
Delta up value length that triggers a status message. More...
UCHAR | status_min_interval
Minimum interval between two consecutive Status messages. More...
UCHAR * | fast_cadence_low
Low value for the fast cadence range. More...
UINT16 | fast_cadence_low_len
Low value length for the fast cadence range. More...
UCHAR * | fast_cadence_high
High value for the fast cadence range. More...
UINT16 | fast_cadence_high_len
High value length for the fast cadence range. More...

Detailed Description

Sensor Cadence Status message parameters.

Definition at line 320 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_CADENCE_STATUS_STRUCT::property_id

Property ID for the sensor.

Definition at line 323 of file MS_sensor_api.h.

UCHAR MS_SENSOR_CADENCE_STATUS_STRUCT::status_trigger_type

Defines the unit and format of the Status Trigger Delta fields.

Definition at line 329 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_STATUS_STRUCT::status_trigger_delta_down

Delta down value that triggers a status message.

Definition at line 332 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_STATUS_STRUCT::status_trigger_delta_down_len

Delta down value length that triggers a status message.

Definition at line 335 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_STATUS_STRUCT::status_trigger_delta_up

Delta up value that triggers a status message.

Definition at line 338 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_STATUS_STRUCT::status_trigger_delta_up_len

Delta up value length that triggers a status message.

Definition at line 341 of file MS_sensor_api.h.

UCHAR MS_SENSOR_CADENCE_STATUS_STRUCT::status_min_interval

Minimum interval between two consecutive Status messages.

Definition at line 344 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_STATUS_STRUCT::fast_cadence_low

Low value for the fast cadence range.

Definition at line 347 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_STATUS_STRUCT::fast_cadence_low_len

Low value length for the fast cadence range.

Definition at line 350 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_CADENCE_STATUS_STRUCT::fast_cadence_high

High value for the fast cadence range.

Definition at line 353 of file MS_sensor_api.h.

UINT16 MS_SENSOR_CADENCE_STATUS_STRUCT::fast_cadence_high_len

High value length for the fast cadence range.

Definition at line 356 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_SETTINGS_GET_STRUCT Struct Reference

Data Fields
MS_SENSOR_SETTINGS_GET_STRUCT Struct Reference
Structures

Sensor Settings Get message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 sensor_property_id
Property ID identifying a sensor. More...

Detailed Description

Sensor Settings Get message parameters.

Definition at line 363 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_SETTINGS_GET_STRUCT::sensor_property_id

Property ID identifying a sensor.

Definition at line 366 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_SETTINGS_STATUS_STRUCT Struct Reference

Data Fields
MS_SENSOR_SETTINGS_STATUS_STRUCT Struct Reference
Structures

Sensor Setting Status message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | sensor_property_id
Property ID identifying a sensor. More...
UINT16 * | sensor_setting_property_ids
A sequence of N Sensor Setting Property IDs identifying settings within a sensor, where N is the number of property IDs included in the message. More...
UINT16 | sensor_setting_property_ids_count
Number of Sensor Setting Property IDs.

Detailed Description

Sensor Setting Status message parameters.

Definition at line 373 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_SETTINGS_STATUS_STRUCT::sensor_property_id

Property ID identifying a sensor.

Definition at line 376 of file MS_sensor_api.h.

UINT16* MS_SENSOR_SETTINGS_STATUS_STRUCT::sensor_setting_property_ids

A sequence of N Sensor Setting Property IDs identifying settings within a sensor, where N is the number of property IDs included in the message.

(Optional)

Definition at line 382 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_SETTING_GET_STRUCT Struct Reference

Data Fields
MS_SENSOR_SETTING_GET_STRUCT Struct Reference
Structures

Sensor Setting Get message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | sensor_property_id
Property ID identifying a sensor. More...
UINT16 | sensor_setting_property_id
Setting Property ID identifying a setting within a sensor. More...

Detailed Description

Sensor Setting Get message parameters.

Definition at line 392 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_SETTING_GET_STRUCT::sensor_property_id

Property ID identifying a sensor.

Definition at line 395 of file MS_sensor_api.h.

UINT16 MS_SENSOR_SETTING_GET_STRUCT::sensor_setting_property_id

Setting Property ID identifying a setting within a sensor.

Definition at line 398 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_SETTING_SET_STRUCT Struct Reference

Data Fields
MS_SENSOR_SETTING_SET_STRUCT Struct Reference
Structures

Sensor Setting Set message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | sensor_property_id
Property ID identifying a sensor. More...
UINT16 | sensor_setting_property_id
Setting ID identifying a setting within a sensor. More...
UCHAR * | sensor_setting_raw
Raw value for the setting. More...
UINT16 | sensor_setting_raw_len
Raw value length for the setting. More...

Detailed Description

Sensor Setting Set message parameters.

Definition at line 405 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_SETTING_SET_STRUCT::sensor_property_id

Property ID identifying a sensor.

Definition at line 408 of file MS_sensor_api.h.

UINT16 MS_SENSOR_SETTING_SET_STRUCT::sensor_setting_property_id

Setting ID identifying a setting within a sensor.

Definition at line 411 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_SETTING_SET_STRUCT::sensor_setting_raw

Raw value for the setting.

Definition at line 414 of file MS_sensor_api.h.

UINT16 MS_SENSOR_SETTING_SET_STRUCT::sensor_setting_raw_len

Raw value length for the setting.

Definition at line 417 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): MS_SENSOR_SETTING_STATUS_STRUCT Struct Reference

Data Fields
MS_SENSOR_SETTING_STATUS_STRUCT Struct Reference
Structures

Sensor Setting Status message parameters. More...

#include <MS_sensor_api.h>

Data Fields

UINT16 | sensor_property_id
Property ID identifying a sensor. More...
UINT16 | sensor_setting_property_id
Setting ID identifying a setting within a sensor. More...
UCHAR | sensor_setting_access
Read / Write access rights for the setting. More...
UCHAR * | sensor_setting_raw
Raw value for the setting. More...
UINT16 | sensor_setting_raw_len
Raw value length for the setting. More...
UCHAR | optional_fields_present
Flag: To represent if optional fields Access and Setting Raw are valid.

Detailed Description

Sensor Setting Status message parameters.

Definition at line 424 of file MS_sensor_api.h.

Field Documentation

UINT16 MS_SENSOR_SETTING_STATUS_STRUCT::sensor_property_id

Property ID identifying a sensor.

Definition at line 427 of file MS_sensor_api.h.

UINT16 MS_SENSOR_SETTING_STATUS_STRUCT::sensor_setting_property_id

Setting ID identifying a setting within a sensor.

Definition at line 430 of file MS_sensor_api.h.

UCHAR MS_SENSOR_SETTING_STATUS_STRUCT::sensor_setting_access

Read / Write access rights for the setting.

(Optional)

Definition at line 433 of file MS_sensor_api.h.

UCHAR* MS_SENSOR_SETTING_STATUS_STRUCT::sensor_setting_raw

Raw value for the setting.

Definition at line 436 of file MS_sensor_api.h.

UINT16 MS_SENSOR_SETTING_STATUS_STRUCT::sensor_setting_raw_len

Raw value length for the setting.

Definition at line 439 of file MS_sensor_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_sensor_api.h


EtherMind Mesh SDK (beta): TIME (Mesh Time Model)

Modules
TIME (Mesh Time Model)

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application. More...

Modules

API Definitions
This section describes the EtherMind Mesh Time Model APIs.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Structures

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Generic OnOff Model (ONOFF) module to the Application.


EtherMind Mesh SDK (beta): API Definitions

Modules
API Definitions
TIME (Mesh Time Model)

This section describes the EtherMind Mesh Time Model APIs. More...

Modules

Time Client API Definitions
This section describes the Time Client APIs.
Time Server API Definitions
This section describes the Time Server APIs.

Detailed Description

This section describes the EtherMind Mesh Time Model APIs.


EtherMind Mesh SDK (beta): Time Client API Definitions

Macros | Functions
Time Client API Definitions
API Definitions

This section describes the Time Client APIs. More...

Macros

#define | MS_time_set(param)
API to set the Time state of an element. More...
#define | MS_time_zone_get()
API to get the Time Zone Offset Current state. More...
#define | MS_tai_utc_delta_set(param)
API to set the TAI-UTC Delta New state and the TAI of Delta Change state. More...
#define | MS_time_role_set(param)
API to set the Time Role state of an element. More...
#define | MS_tai_utc_delta_get()
API to get the TAI-UTC Delta Current state, the TAI-UTC Delta New state, and the TAI of Delta Change state. More...
#define | MS_time_zone_set(param)
API to set the Time Zone Offset New state. More...
#define | MS_time_role_get()
API to get the Time Role state of an element. More...
#define | MS_time_get()
API to get the Time state of neighbor nodes. More...

Functions

API_RESULT | MS_time_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_TIME_CLIENT_CB appl_cb)
API to initialize Time Client model. More...
API_RESULT | MS_time_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Time client model handle. More...
API_RESULT | MS_time_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This section describes the Time Client APIs.

Macro Definition Documentation

#define MS_time_set ( param )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TIME_SET_OPCODE,\
param,\
MS_ACCESS_TIME_STATUS_OPCODE\
)

API to set the Time state of an element.

Description
Time Set is an acknowledged message used to set the Time state of an element. The response to the Time Set message is a Time Status message.
Parameters
[in] param Time Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 335 of file MS_time_api.h.

#define MS_time_zone_get ( )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TIME_ZONE_GET_OPCODE,\
NULL,\
MS_ACCESS_TIME_ZONE_STATUS_OPCODE\
)

API to get the Time Zone Offset Current state.

Description
Time Zone Get is an acknowledged message used to get the Time Zone Offset Current state, the Time Zone Offset New state , and the TAI of Zone Change state. The response to the Time Zone Get message is a Time Zone Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 354 of file MS_time_api.h.

#define MS_tai_utc_delta_set ( param )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TAI_UTC_DELTA_SET_OPCODE,\
param,\
MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE\
)

API to set the TAI-UTC Delta New state and the TAI of Delta Change state.

Description
TAI-UTC Delta Set is an acknowledged message used to set the TAI-UTC Delta New state and the TAI of Delta Change state.
Parameters
[in] param TAI-UTC Delta Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 372 of file MS_time_api.h.

#define MS_time_role_set ( param )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TIME_ROLE_SET_OPCODE,\
param,\
MS_ACCESS_TIME_ROLE_STATUS_OPCODE\
)

API to set the Time Role state of an element.

Description
Time Role Set is an acknowledged message used to set the Time Role state of an element. The response to the Time Role Set message is a Time Role Status message.
Parameters
[in] param Time Role Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 391 of file MS_time_api.h.

#define MS_tai_utc_delta_get ( )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TAI_UTC_DELTA_GET_OPCODE,\
NULL,\
MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE\
)

API to get the TAI-UTC Delta Current state, the TAI-UTC Delta New state, and the TAI of Delta Change state.

Description
TAI-UTC Delta Get is an acknowledged message used to get the TAI-UTC Delta Current state, the TAI-UTC Delta New state, and the TAI of Delta Change state. The response to the TAI-UTC Delta Get message is a TAI-UTC Delta Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 410 of file MS_time_api.h.

#define MS_time_zone_set ( param )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TIME_ZONE_SET_OPCODE,\
param,\
MS_ACCESS_TIME_ZONE_STATUS_OPCODE\
)

API to set the Time Zone Offset New state.

Description
Time Zone Set is an acknowledged message used to set the Time Zone Offset New state and the TAI of Zone Change state.
Parameters
[in] param Time Zone Set message
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 428 of file MS_time_api.h.

#define MS_time_role_get ( )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TIME_ROLE_GET_OPCODE,\
NULL,\
MS_ACCESS_TIME_ROLE_STATUS_OPCODE\
)

API to get the Time Role state of an element.

Description
Time Role Get is an acknowledged message used to get the Time Role state of an element. The response to the Time Role Get message is a Time Role Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 446 of file MS_time_api.h.

#define MS_time_get ( )
Value:
MS_time_client_send_reliable_pdu \
(\
MS_ACCESS_TIME_GET_OPCODE,\
NULL,\
MS_ACCESS_TIME_STATUS_OPCODE\
)

API to get the Time state of neighbor nodes.

Description
Time Get is a message used to get the Time state of neighbor nodes. The response to the Time Get message is a Time Status message. There are no parameters for this message.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 464 of file MS_time_api.h.

Function Documentation

API_RESULT MS_time_client_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | MS_TIME_CLIENT_CB | appl_cb
 | ) |  |

API to initialize Time Client model.

Description
This is to initialize Time Client model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Time Client.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_time_client_get_model_handle ( MS_ACCESS_MODEL_HANDLE * model_handle )

API to get Time client model handle.

Description
This is to get the handle of Time client model.
Parameters
[out] model_handle Address of model handle to be filled/returned.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_time_client_send_reliable_pdu | ( | UINT32 | req_opcode,
 |  | void * | param,
 |  | UINT32 | rsp_opcode
 | ) |  |

API to send acknowledged commands.

Description
This is to initialize sending acknowledged commands.
Parameters
[in] | req_opcode | Request Opcode.
[in] | param | Parameter associated with Request Opcode.
[in] | rsp_opcode | Response Opcode.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Time Server API Definitions

Functions
Time Server API Definitions
API Definitions

This section describes the Time Server APIs. More...

Functions

API_RESULT | MS_time_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *time_model_handle, MS_ACCESS_MODEL_HANDLE *time_setup_model_handle, MS_TIME_SERVER_CB appl_cb)
API to initialize Time Server model. More...
API_RESULT | MS_time_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...

Detailed Description

This section describes the Time Server APIs.

Function Documentation

API_RESULT MS_time_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | time_model_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | time_setup_model_handle,
 |  | MS_TIME_SERVER_CB | appl_cb
 | ) |  |

API to initialize Time Server model.

Description
This is to initialize Time Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | time_model_handle | Model identifier associated with the time model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in,out] | time_setup_model_handle | Model identifier associated with the time setup model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | appl_cb | Application Callback to be used by the Time Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_time_server_state_update | ( | MS_ACCESS_MODEL_REQ_MSG_CONTEXT * | ctx,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | current_state_params,
 |  | MS_ACCESS_MODEL_STATE_PARAMS * | target_state_params,
 |  | UINT16 | remaining_time,
 |  | MS_ACCESS_MODEL_EXT_PARAMS * | ext_params
 | ) |  |

API to send reply or to update state change.

Description
This is to send reply for a request or to inform change in state.
Parameters
[in] | ctx | Context of the message.
[in] | current_state_params | Model specific current state parameters.
[in] | target_state_params | Model specific target state parameters (NULL: to be ignored).
[in] | remaining_time | Time from current state to target state (0: to be ignored).
[in] | ext_params | Additional parameters (NULL: to be ignored).
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
TIME (Mesh Time Model)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef API_RESULT(* | MS_TIME_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Time Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_TIME_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Time Client application Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef API_RESULT(* MS_TIME_SERVER_CB)(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT

Time Server application Asynchronous Notification Callback.

Time Server calls the registered callback to indicate events occurred to the application.

Parameters
[in] | ctx | Context of the message received for a specific model instance.
[in] | msg_raw | Uninterpreted/raw received message.
[in] | req_type | Requested message type.
[in] | state_params | Model specific state parameters.
[in] | ext_params | Additional parameters.

Definition at line 52 of file MS_time_api.h.

typedef API_RESULT(* MS_TIME_CLIENT_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

Time Client application Asynchronous Notification Callback.

Time Client calls the registered callback to indicate events occurred to the application.

Parameters
handle | Model Handle.
opcode | Opcode.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 73 of file MS_time_api.h.


EtherMind Mesh SDK (beta): Structures

Data Structures
Structures
TIME (Mesh Time Model)

Data Structures

struct | MS_TIME_STRUCT
Time Set message parameters. More...
struct | MS_TIME_ZONE_SET_STRUCT
Time Zone Set message parameters. More...
struct | MS_TIME_ZONE_STATUS_STRUCT
Time Zone Status message parameters. More...
struct | MS_TAI_UTC_DELTA_SET_STRUCT
TAI-UTC Delta Set message parameters. More...
struct | MS_TAI_UTC_DELTA_STATUS_STRUCT
TAI-UTC Delta Status message parameters. More...
struct | MS_TIME_ROLE_STRUCT
Time Role Set/Status message parameters. More...

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_TIME_STRUCT Struct Reference

Data Fields
MS_TIME_STRUCT Struct Reference
Structures

Time Set message parameters. More...

#include <MS_time_api.h>

Data Fields

UCHAR | tai_seconds [5]
The current TAI time in seconds.
UCHAR | subsecond
The sub-second time in units of 1/256th second.
UCHAR | uncertainty
The estimated uncertainty in 10 millisecond steps.
UCHAR | time_authority
0 = No Time Authority, 1 = Time Authority
UINT16 | tai_utc_delta
Current difference between TAI and UTC in seconds.
UCHAR | time_zone_offset
The local time zone offset in 15-minute increments.

Detailed Description

Time Set message parameters.

Definition at line 89 of file MS_time_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_time_api.h


EtherMind Mesh SDK (beta): MS_TIME_ZONE_SET_STRUCT Struct Reference

Data Fields
MS_TIME_ZONE_SET_STRUCT Struct Reference
Structures

Time Zone Set message parameters. More...

#include <MS_time_api.h>

Data Fields

UCHAR | time_zone_offset_new
Upcoming local time zone offset.
UCHAR | tai_of_zone_change [5]
TAI Seconds time of the upcoming Time Zone Offset change.

Detailed Description

Time Zone Set message parameters.

Definition at line 114 of file MS_time_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_time_api.h


EtherMind Mesh SDK (beta): MS_TIME_ZONE_STATUS_STRUCT Struct Reference

Data Fields
MS_TIME_ZONE_STATUS_STRUCT Struct Reference
Structures

Time Zone Status message parameters. More...

#include <MS_time_api.h>

Data Fields

UCHAR | time_zone_offset_current
Current local time zone offset.
UCHAR | time_zone_offset_new
Upcoming local time zone offset.
UCHAR | tai_of_zone_change [5]
TAI Seconds time of the upcoming Time Zone Offset change.

Detailed Description

Time Zone Status message parameters.

Definition at line 127 of file MS_time_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_time_api.h


EtherMind Mesh SDK (beta): MS_TAI_UTC_DELTA_SET_STRUCT Struct Reference

Data Fields
MS_TAI_UTC_DELTA_SET_STRUCT Struct Reference
Structures

TAI-UTC Delta Set message parameters. More...

#include <MS_time_api.h>

Data Fields

UINT16 | tai_utc_delta_new
Upcoming difference between TAI and UTC in seconds.
UCHAR | padding
Always 0b0. More...
UCHAR | tai_of_delta_change [5]
TAI Seconds time of the upcoming TAI-UTC Delta change.

Detailed Description

TAI-UTC Delta Set message parameters.

Definition at line 143 of file MS_time_api.h.

Field Documentation

UCHAR MS_TAI_UTC_DELTA_SET_STRUCT::padding

Always 0b0.

Other values are Prohibited.

Definition at line 149 of file MS_time_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_time_api.h


EtherMind Mesh SDK (beta): MS_TAI_UTC_DELTA_STATUS_STRUCT Struct Reference

Data Fields
MS_TAI_UTC_DELTA_STATUS_STRUCT Struct Reference
Structures

TAI-UTC Delta Status message parameters. More...

#include <MS_time_api.h>

Data Fields

UINT16 | tai_utc_delta_current
Current difference between TAI and UTC in seconds.
UCHAR | padding_1
Always 0b0. More...
UINT16 | tai_utc_delta_new
Upcoming difference between TAI and UTC in seconds.
UCHAR | padding_2
Always 0b0. More...
UCHAR | tai_of_delta_change [5]
TAI Seconds time of the upcoming TAI-UTC Delta change.

Detailed Description

TAI-UTC Delta Status message parameters.

Definition at line 159 of file MS_time_api.h.

Field Documentation

UCHAR MS_TAI_UTC_DELTA_STATUS_STRUCT::padding_1

Always 0b0.

Other values are Prohibited.

Definition at line 165 of file MS_time_api.h.

UCHAR MS_TAI_UTC_DELTA_STATUS_STRUCT::padding_2

Always 0b0.

Other values are Prohibited.

Definition at line 171 of file MS_time_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_time_api.h


EtherMind Mesh SDK (beta): MS_TIME_ROLE_STRUCT Struct Reference

Data Fields
MS_TIME_ROLE_STRUCT Struct Reference
Structures

Time Role Set/Status message parameters. More...

#include <MS_time_api.h>

Data Fields

UCHAR time_role
The Time Role for the element.

Detailed Description

Time Role Set/Status message parameters.

Definition at line 181 of file MS_time_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_time_api.h


EtherMind Mesh SDK (beta): TRANSPORT (Mesh Transport Layer)

Modules
TRANSPORT (Mesh Transport Layer)

This section describes the interfaces & APIs offered by the EtherMind Mesh Transport (TRANSPORT) module to the Application and other upper layers of the stack. More...

Modules

API Definitions
TCF (Transport Control Field) - Transport Field Value.
Application Callback
This Section Describes the module Notification Callback interface offered to the application.
Defines
Describes defines for the module.
Utility Macros
Initialization and other Utility Macros offered by the module.

Detailed Description

This section describes the interfaces & APIs offered by the EtherMind Mesh Transport (TRANSPORT) module to the Application and other upper layers of the stack.


EtherMind Mesh SDK (beta): API Definitions

Macros | Functions
API Definitions
TRANSPORT (Mesh Transport Layer)

TCF (Transport Control Field) - Transport Field Value. More...

Macros

#define | MS_trn_lpn_subscrn_list_add(addr_list, count)
API to add to friend subscription list. More...
#define | MS_trn_lpn_subscrn_list_remove(addr_list, count)
API to remove from friend subscription list. More...

Functions

API_RESULT | MS_trn_register (TRN_NTF_CB trn_cb, MS_TRN_MSG_TYPE msg_type)
Register Inerface with Transport Layer. More...
API_RESULT | MS_trn_send_access_pdu (MS_NET_ADDR src_addr, MS_NET_ADDR dst_addr, UINT8 *label, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT8 ttl, void *param)
API to send Access Layer PDUs. More...
API_RESULT | MS_trn_send_control_pdu (MS_NET_ADDR src_addr, MS_NET_ADDR dst_addr, MS_SUBNET_HANDLE subnet_handle, UINT8 ttl, MS_TRN_CTRL_PKT_OPCODE ctrl_opcode, void *param)
API to send transport Control PDUs. More...
API_RESULT | MS_trn_lpn_setup_friendship (MS_SUBNET_HANDLE subnet_handle, UCHAR criteria, UCHAR rx_delay, UINT32 poll_timeout, UINT32 setup_timeout, TRN_FRND_CB cb)
API to setup Friendship. More...
API_RESULT | MS_trn_lpn_clear_friendship (void)
API to terminate friendship. More...
API_RESULT | MS_trn_lpn_manage_subscription (UCHAR action, UINT16 *addr_list, UINT16 count)
API to manage friend subscription list. More...
API_RESULT | MS_trn_is_valid_lpn_element_address (MS_NET_ADDR addr, LPN_HANDLE *lpn_handle)
To check if address matches with any of the LPN. More...
API_RESULT | MS_trn_is_valid_lpn_subscription_address (MS_NET_ADDR addr, LPN_HANDLE *lpn_handle)
To check if valid subscription address of an LPN to receive a packet. More...
API_RESULT | MS_trn_get_lpn_polltimeout (MS_NET_ADDR lpn_addr, UINT32 *poll_timeout)
To get Poll Timeout of an LPN. More...
API_RESULT | MS_trn_get_frndship_info (UINT8 role, UINT16 lpn_index, MS_TRN_FRNDSHIP_INFO *node)
To get the LPN node information. More...
API_RESULT | MS_trn_lpn_register_security_update (MS_SUBNET_HANDLE subnet_handle, UCHAR flag, UINT32 ivindex)
To add the security update information. More...
API_RESULT | MS_trn_set_heartbeat_publication (MS_TRN_HEARTBEAT_PUBLICATION_INFO *info)
To set the Heartbeat publication data. More...
API_RESULT | MS_trn_get_heartbeat_publication (MS_TRN_HEARTBEAT_PUBLICATION_INFO *info)
To get the Heartbeat publication data. More...
API_RESULT | MS_trn_set_heartbeat_subscription (MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO *info)
To set the Heartbeat subscription data. More...
API_RESULT | MS_trn_get_heartbeat_subscription (MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO *info)
To get the Heartbeat subscription data. More...
API_RESULT | MS_trn_trigger_heartbeat (UINT8 change_in_feature_bit)
To trigger Heartbeat send on change in feature. More...

Detailed Description

TCF (Transport Control Field) - Transport Field Value.

This section describes the EtherMind Mesh Transport Layer APIs.

Macro Definition Documentation

#define MS_trn_lpn_subscrn_list_add | ( | addr_list,
 |  | count
 | ) |
Value:
MS_trn_lpn_manage_subscription\
(\
MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD,\
(addr_list),\
(count)\
);

API to add to friend subscription list.

Description
This routine is used by the device acting as a low power node add addresses to the friends subscription list.
Parameters
[in] | addr_list | Pointer to the list of addresses to be managed.
[in] | count | Number of addresses given.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 746 of file MS_trn_api.h.

#define MS_trn_lpn_subscrn_list_remove | ( | addr_list,
 |  | count
 | ) |
Value:
MS_trn_lpn_manage_subscription\
(\
MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE,\
(addr_list),\
(count)\
);

API to remove from friend subscription list.

Description
This routine is used by the device acting as a low power node remove addresses from the friends subscription list.
Parameters
[in] | addr_list | Pointer to the list of addresses to be managed.
[in] | count | Number of addresses given.
Returns
API_SUCCESS or an error code indicating reason for failure

Definition at line 770 of file MS_trn_api.h.

Function Documentation

API_RESULT MS_trn_register | ( | TRN_NTF_CB | trn_cb,
 |  | MS_TRN_MSG_TYPE | msg_type
 | ) |  |

Register Inerface with Transport Layer.

Description
This routine registers interface with the Transport Layer. Transport Layer supports single Application, hence this rouine shall be called once.
Parameters
[in] | trn_cb | Upper Layer Notification Callback for specific message type
[in] | msg_type | Message type (Control or Access) for which the callback to be called.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_send_access_pdu | ( | MS_NET_ADDR | src_addr,
 |  | MS_NET_ADDR | dst_addr,
 |  | UINT8 * | label,
 |  | MS_SUBNET_HANDLE | subnet_handle,
 |  | MS_APPKEY_HANDLE | appkey_handle,
 |  | UINT8 | ttl,
 |  | void * | param
 | ) |  |

API to send Access Layer PDUs.

Description
This routine sends Access Layer PDUs to peer device.
Parameters
[in] | src_addr | Source Address
[in] | dst_addr | Destination Address
[in] | label | Lable UUID, represending Virtual Address of Destination
[in] | subnet_handle | Handle identifying the Subnet
[in] | appkey_handle | Handle identifying the AppKey to be used for Transport Layer encryption.
[in] | ttl | Time to Live
[in] | param | Transport parameter, based on the type and header
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_send_control_pdu | ( | MS_NET_ADDR | src_addr,
 |  | MS_NET_ADDR | dst_addr,
 |  | MS_SUBNET_HANDLE | subnet_handle,
 |  | UINT8 | ttl,
 |  | MS_TRN_CTRL_PKT_OPCODE | ctrl_opcode,
 |  | void * | param
 | ) |  |

API to send transport Control PDUs.

Description
This routine sends transport Control PDUs to peer device.
Parameters
[in] | src_addr | Source Address
[in] | dst_addr | Destination Address
[in] | subnet_handle | Handle identifying the Subnet
[in] | ttl | Time to Live
[in] | ctrl_opcode | Control Packet Opcode.
[in] | param | Transport parameter, based on the type and header
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_lpn_setup_friendship | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UCHAR | criteria,
 |  | UCHAR | rx_delay,
 |  | UINT32 | poll_timeout,
 |  | UINT32 | setup_timeout,
 |  | TRN_FRND_CB | cb
 | ) |  |

API to setup Friendship.

Description
This routine is used by the device acting as a low power node to setup a friendship procedure to any available friend nodes.
Parameters
[in] | subnet_handle | The subnet to initiate the friendship procedure.
[in] | criteria | Friend criteria that is required. RSSI, Receive Window, MessageQueue size requirements can be established.
[in] | rx_delay | Receive delay in milliseconds that the LPN will wait before listening to response for any request.
[in] | poll_timeout | Timeout in milliseconds after which the LPN will send Poll PDU to check for data from the friend.
[in] | setup_timeout | Timeout in milliseconds for which the Friend Establishment procedure is to be tried.
[in] | cb | Application Callback to notify the result of friendship procedures.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_lpn_clear_friendship ( void )

API to terminate friendship.

Description
This routine is used by the device acting as a low power node terminate friendship with an active Friend node.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_lpn_manage_subscription | ( | UCHAR | action,
 |  | UINT16 * | addr_list,
 |  | UINT16 | count
 | ) |  |

API to manage friend subscription list.

Description
This routine is used by the device acting as a low power node add/remove addresses to/from the friends subscription list.
Parameters
[in] | action | Will be one of MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD or MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE
[in] | addr_list | Pointer to the packed list of addresses to be managed.
[in] | count | Number of addresses given.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_is_valid_lpn_element_address | ( | MS_NET_ADDR | addr,
 |  | LPN_HANDLE * | lpn_handle
 | ) |  |

To check if address matches with any of the LPN.

Description
This routine checks if destination address in a received packet matches with any of the known element address of LPN.
Parameters
[in] | addr | Unicast Address to search
[out] | lpn_handle | LPN Handle on match
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_is_valid_lpn_subscription_address | ( | MS_NET_ADDR | addr,
 |  | LPN_HANDLE * | lpn_handle
 | ) |  |

To check if valid subscription address of an LPN to receive a packet.

Description
This routine checks if destination address in a received packet matches with any of the known subscription address of an LPN.
Parameters
[in] | addr | Address to search
[out] | lpn_handle | Pointer to an LPN Handle, which will be filled if match found
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_get_lpn_polltimeout | ( | MS_NET_ADDR | lpn_addr,
 |  | UINT32 * | poll_timeout
 | ) |  |

To get Poll Timeout of an LPN.

Description
This routine checks if LPN address is valid and then returns Poll Timeout configured for the LPN.
Parameters
[in] | lpn_addr | LPN Address to search
[out] | poll_timeout | Memory where poll timeout of the LPN to be filled (if match found)
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_get_frndship_info | ( | UINT8 | role,
 |  | UINT16 | lpn_index,
 |  | MS_TRN_FRNDSHIP_INFO * | node
 | ) |  |

To get the LPN node information.

Description
This routine fetches the node information of the LPN element at the given index
Parameters
[in] | role | Local friendship role
[in] | lpn_index | Index of the LPN element
[out] | node | Pointer to copy the information
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_lpn_register_security_update | ( | MS_SUBNET_HANDLE | subnet_handle,
 |  | UCHAR | flag,
 |  | UINT32 | ivindex
 | ) |  |

To add the security update information.

Description
This routine updates the security state of the network to all the active LPN elements. This will be forwarded to the elements when it polls for the next packet available.
Parameters
[in] | subnet_handle | Handle to identitfy the network.
[in] | flag | Flag indicating the Key Refresh and IV Update state.
[in] | ivindex | Current IV Index of teh network.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_set_heartbeat_publication ( MS_TRN_HEARTBEAT_PUBLICATION_INFO * info )

To set the Heartbeat publication data.

Description
This routine configures the Heartbeat publication information
Parameters
[out] info Heartbeat Publication information data as in MS_TRN_HEARTBEAT_PUBLICATION_INFO
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_get_heartbeat_publication ( MS_TRN_HEARTBEAT_PUBLICATION_INFO * info )

To get the Heartbeat publication data.

Description
This routine retrieves the Heartbeat publication information
Parameters
[out] info Heartbeat Publication information data as in MS_TRN_HEARTBEAT_PUBLICATION_INFO
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_set_heartbeat_subscription ( MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO * info )

To set the Heartbeat subscription data.

Description
This routine configures the Heartbeat subscription information
Parameters
[in,out] info Heartbeat Subscription information data as in MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_get_heartbeat_subscription ( MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO * info )

To get the Heartbeat subscription data.

Description
This routine retrieves the Heartbeat subscription information
Parameters
[out] info Heartbeat Subscription information data as in MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_trn_trigger_heartbeat ( UINT8 change_in_feature_bit )

To trigger Heartbeat send on change in feature.

Description
This routine triggers the Heartbeat send on change in state of supported features.
Parameters
[in] change_in_feature_bit Bit mask of the changed feature field
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): Application Callback

Typedefs
Application Callback
TRANSPORT (Mesh Transport Layer)

This Section Describes the module Notification Callback interface offered to the application. More...

Typedefs

typedef void(* | TRN_NTF_CB )(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
TRANSPORT Application Asynchronous Notification Callback. More...
typedef void(* | TRN_FRND_CB )(MS_SUBNET_HANDLE subnet_handle, UCHAR event_type, UINT16 status) DECL_REENTRANT
TRANSPORT Application Friendship Asynchronous Notification Callback. More...

Detailed Description

This Section Describes the module Notification Callback interface offered to the application.

Typedef Documentation

typedef void(* TRN_NTF_CB)(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT

TRANSPORT Application Asynchronous Notification Callback.

TRANSPORT calls the registered callback to indicate events occurred to the application.

Parameters
brr_type | Bearer Type.
net_hdr | Network Header.
subnet_handle | Associated Subnet Handle.
appkey_handle | Associated AppKey Handle.
data_param | Data associated with the event if any or NULL.
data_len | Size of the event data. 0 if event data is NULL.

Definition at line 226 of file MS_trn_api.h.

typedef void(* TRN_FRND_CB)(MS_SUBNET_HANDLE subnet_handle, UCHAR event_type, UINT16 status) DECL_REENTRANT

TRANSPORT Application Friendship Asynchronous Notification Callback.

TRANSPORT calls the registered callback to indicate the status of froednship setup procedure to the application

Parameters
subnet_handle | Associated Subnet Handle.
event_type | Friendship event. Events
status | Result of the procedure.

Definition at line 245 of file MS_trn_api.h.


EtherMind Mesh SDK (beta): Defines

Modules
Defines
TRANSPORT (Mesh Transport Layer)

Describes defines for the module. More...

Modules

Constants
Describes Constants defined by the module.
Events
This section lists the Asynchronous Events notified to Application by the Module.
Structures

Detailed Description

Describes defines for the module.


EtherMind Mesh SDK (beta): Constants

Macros
Constants
Defines

Describes Constants defined by the module. More...

Macros

#define | MS_TRN_CTRL_OPCODE_FRND_POLL 0x01
Tranport Layer Control Packet Opcodes. More...
#define | MS_TRN_CTRL_OPCODE_FRND_UPDATE 0x02
Sent by a Friend node to a Low Power node to inform it about cache and/or security updates.
#define | MS_TRN_CTRL_OPCODE_FRND_REQ 0x03
Broadcast by a Low Power node to start to find a friend.
#define | MS_TRN_CTRL_OPCODE_FRND_OFFER 0x04
Sent by a Friend node to a Low Power node to offer to become its friend.
#define | MS_TRN_CTRL_OPCODE_FRND_CLEAR 0x05
Sent to a Friend node to inform a previous friend of a Low Power node about the removal of a friendship.
#define | MS_TRN_CTRL_OPCODE_FRND_CLEAR_CNF 0x06
Sent from a previous friend to Friend node to confirm that a prior friend relationship has been removed.
#define | MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD 0x07
Sent to a Friend node to add one or more addresses to the Friend Subscription List.
#define | MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE 0x08
Sent to a Friend node to remove one or more addresses from the Friend Subscription List.
#define | MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_CNF 0x09
Sent by a Friend node to confirm Friend Subscription List updates.
#define | MS_TRN_CTRL_OPCODE_HEARTBEAT 0x0A
Sent by a node to let other nodes determine topology of a Subnet.
#define | MS_FRNDUPD_FLAG_KEYREF_BIT 0
Parameter defines for Friendship Opcodes. More...
#define | MS_FRNDUPD_FLAG_KEYREF_NOTINPHASE_2 0x00
#define | MS_FRNDUPD_FLAG_KEYREF_INPHASE_2 0x01
#define | MS_FRNDUPD_FLAG_IVUPDATE_BIT 1
#define | MS_FRNDUPD_FLAG_IVUPDATE_NORMAL 0x00
#define | MS_FRNDUPD_FLAG_IVUPDATE_ACTIVE 0x01
#define | MS_FRNDUPD_MD_QUEUE_EMPTY 0x00
Friend Update More Data.
#define | MS_FRNDUPD_MD_QUEUE_NOTEMPTY 0x01
#define | MS_FRNDREQ_RSSIFACTOR_OFFSET 5
Friend Request Criteria.
#define | MS_FRNDREQ_RSSIFACTOR_MASK 0x60
#define | MS_FRNDREQ_RSSIFACTOR_1 0x00
#define | MS_FRNDREQ_RSSIFACTOR_1_5 0x01
#define | MS_FRNDREQ_RSSIFACTOR_2 0x02
#define | MS_FRNDREQ_RSSIFACTOR_2_5 0x03
#define | MS_FRNDREQ_RCVWINFACTOR_OFFSET 3
#define | MS_FRNDREQ_RCVWINFACTOR_MASK 0x18
#define | MS_FRNDREQ_RCVWINFACTOR_1 0x00
#define | MS_FRNDREQ_RCVWINFACTOR_1_5 0x01
#define | MS_FRNDREQ_RCVWINFACTOR_2 0x02
#define | MS_FRNDREQ_RCVWINFACTOR_2_5 0x03
#define | MS_FRNDREQ_MINQSIZELOG_OFFSET 0
#define | MS_FRNDREQ_MINQSIZELOG_MASK 0x07
#define | MS_FRNDREQ_MINQSIZE_INVALID 0x00
#define | MS_FRNDREQ_MINQSIZE_2 0x01
#define | MS_FRNDREQ_MINQSIZE_4 0x02
#define | MS_FRNDREQ_MINQSIZE_8 0x03
#define | MS_FRNDREQ_MINQSIZE_16 0x04
#define | MS_FRNDREQ_MINQSIZE_32 0x05
#define | MS_FRNDREQ_MINQSIZE_64 0x06
#define | MS_FRNDREQ_MINQSIZE_128 0x07
#define | MS_HEARTBEAT_FEATURE_RELAY (1 << 0)
Heartbeat features.
#define | MS_HEARTBEAT_FEATURE_PROXY (1 << 1)
#define | MS_HEARTBEAT_FEATURE_FRIEND (1 << 2)
#define | MS_HEARTBEAT_FEATURE_LOWPOWER (1 << 3)
#define | MS_MIN_FRNDOFFER_DELAY 100 /* ms */
Friendship constants as defined in the specification.
#define | MS_TRN_INITIAL_FRNDPOLL_TIMEOUT 1000 /* ms */

Detailed Description

Describes Constants defined by the module.

Macro Definition Documentation

#define MS_TRN_CTRL_OPCODE_FRND_POLL 0x01

Tranport Layer Control Packet Opcodes.

RFU: 0x02 - 0x0F Sent by a Low Power node to its Friend node to request any messages that it has cached for the Low Power node

Definition at line 54 of file MS_trn_api.h.

#define MS_FRNDUPD_FLAG_KEYREF_BIT 0

Parameter defines for Friendship Opcodes.

Friend Update Flags

Bit 0: Key Refresh Flag 0: Not-In-Phase2 1: In-Phase2

Bit 1: IV Update Flag 0: Normal operation 1: IV Update active

Definition at line 112 of file MS_trn_api.h.


EtherMind Mesh SDK (beta): Events

Macros
Events
Defines

This section lists the Asynchronous Events notified to Application by the Module. More...

Macros

#define | MS_TRN_FRIEND_SETUP_CNF 0x00
#define | MS_TRN_FRIEND_SUBSCRNLIST_CNF 0x01
#define | MS_TRN_FRIEND_CLEAR_CNF 0x02
#define | MS_TRN_FRIEND_TERMINATE_IND 0x03

Detailed Description

This section lists the Asynchronous Events notified to Application by the Module.


EtherMind Mesh SDK (beta): Structures

Data Structures | Macros | Typedefs
Structures
Defines

Data Structures

struct | MS_TRN_FRIEND_ENTRY
Friend Data Structure. More...
struct | MS_TRN_FRND_POLL_PARAM
Transport Friend Poll Message. More...
struct | MS_TRN_FRND_UPDATE_PARAM
Transport Friend Update Message. More...
struct | MS_TRN_FRND_REQ_PARAM
Transport Friend Request Message. More...
struct | MS_TRN_FRND_OFFER_PARAM
Transport Friend Offer Message. More...
struct | MS_TRN_FRND_CLEAR_PARAM
Transport Friend Clear Message. More...
struct | MS_TRN_FRND_CLEAR_CNF_PARAM
Transport Friend Clear Confirm Message. More...
struct | MS_TRN_FRND_MANAGE_PARAM
Transport Friend Subscription List Add/Remove Message. More...
struct | MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM
Transport Friend Subscription List Confirm Message. More...
struct | MS_TRN_HEARTBEAT_PARAM
Transport Heartbeat Message. More...
struct | MS_TRN_FRNDSHIP_INFO
Low Power Node element information. More...
struct | MS_TRN_HEARTBEAT_PUBLICATION_INFO
Hearbeat Publication state. More...
struct | MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
Hearbeat Subscription state. More...

Macros

#define LPN_HANDLE_INVALID MS_CONFIG_LIMITS(MS_MAX_FRIENDS)

Typedefs

typedef UCHAR MS_TRN_CTRL_PKT_OPCODE
Transport Control Packet Opcode Type.

Detailed Description

Proprietary and Confidential (C) Mindtree


EtherMind Mesh SDK (beta): MS_TRN_FRIEND_ENTRY Struct Reference

Data Fields
MS_TRN_FRIEND_ENTRY Struct Reference
Structures

Friend Data Structure. More...

#include <MS_trn_api.h>

Data Fields

UINT8 | fsn
Friend Seqnece Number - 7 bit value.
MS_NET_ADDR addr
Low Power Node Address.
UINT8 | num_elements
Number of Elements in LPN.
MS_NET_ADDR prev_faddr
Previous Friend Address.

Detailed Description

Friend Data Structure.

Definition at line 266 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_POLL_PARAM Struct Reference

Data Fields
MS_TRN_FRND_POLL_PARAM Struct Reference
Structures

Transport Friend Poll Message. More...

#include <MS_trn_api.h>

Data Fields

UINT8 fsn
Friend Sequence Number used to acknowledge receipt of previous messages from the Friend node to the Low Power node.

Detailed Description

Transport Friend Poll Message.

Definition at line 289 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_UPDATE_PARAM Struct Reference

Data Fields
MS_TRN_FRND_UPDATE_PARAM Struct Reference
Structures

Transport Friend Update Message. More...

#include <MS_trn_api.h>

Data Fields

UINT8 | flags
Contains the IV Update Flag and the Key Refresh Flag.
UINT32 | ivi
The current IV Index value known by the Friend node.
UCHAR | md
Availability of data in friend queue. More...

Detailed Description

Transport Friend Update Message.

Definition at line 300 of file MS_trn_api.h.

Field Documentation

UCHAR MS_TRN_FRND_UPDATE_PARAM::md

Availability of data in friend queue.

Value | Description
0 | Friend Queue is empty
1 | Friend Queue is not empty

Definition at line 316 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_REQ_PARAM Struct Reference

Data Fields
MS_TRN_FRND_REQ_PARAM Struct Reference
Structures

Transport Friend Request Message. More...

#include <MS_trn_api.h>

Data Fields

UCHAR | criteria
The criteria that a Friend node should support in order to participate in friendship negotiation.
UCHAR | rx_delay
Receive delay requested by the Low Power node.
UINT32 | poll_to
Poll timeout requested by the Low Power node.
UINT16 | prev_addr
Previous Friend's unicast address.
UCHAR | num_elem
Number of Elements in the Low Power node.
UINT16 | lpn_counter
Number of Friend Request messages that the Low Power node has sent.

Detailed Description

Transport Friend Request Message.

Definition at line 321 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_OFFER_PARAM Struct Reference

Data Fields
MS_TRN_FRND_OFFER_PARAM Struct Reference
Structures

Transport Friend Offer Message. More...

#include <MS_trn_api.h>

Data Fields

UINT8 | rx_window
Receive Window value supported by the Friend node.
UINT8 | queue_size
Queue Size available on the Friend node.
UINT8 | sublist_size
Size of the Subscription List that can be supported by a Friend node for a Low Power node.
UINT8 | rssi
RSSI measured by the Friend node.
UINT16 | frnd_counter
Number of Friend Offer messages that the Friend node has sent.

Detailed Description

Transport Friend Offer Message.

Definition at line 347 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_CLEAR_PARAM Struct Reference

Data Fields
MS_TRN_FRND_CLEAR_PARAM Struct Reference
Structures

Transport Friend Clear Message. More...

#include <MS_trn_api.h>

Data Fields

UINT16 | lpn_addr
The unicast address of the Low Power node being removed.
UINT16 | lpn_counter
Value of the LPNCounter of new relationship.

Detailed Description

Transport Friend Clear Message.

Definition at line 370 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_CLEAR_CNF_PARAM Struct Reference

Data Fields
MS_TRN_FRND_CLEAR_CNF_PARAM Struct Reference
Structures

Transport Friend Clear Confirm Message. More...

#include <MS_trn_api.h>

Data Fields

UINT16 | lpn_addr
The unicast address of the Low Power node being removed.
UINT16 | lpn_counter
Value of the LPNCounter of corresponding Friend Clear message.

Detailed Description

Transport Friend Clear Confirm Message.

Definition at line 381 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_MANAGE_PARAM Struct Reference

Data Fields
MS_TRN_FRND_MANAGE_PARAM Struct Reference
Structures

Transport Friend Subscription List Add/Remove Message. More...

#include <MS_trn_api.h>

Data Fields

UINT8 | txn_num
The number for identifying a transaction.
void * | addr_list
List of group addresses and virtual addresses where N is the number of group addresses and virtual addresses in this message. More...
UINT16 | num_addr
Number of Addresses in the list. More...
UINT8 | opcode
Opcode - Add/Delete.

Detailed Description

Transport Friend Subscription List Add/Remove Message.

Definition at line 392 of file MS_trn_api.h.

Field Documentation

void* MS_TRN_FRND_MANAGE_PARAM::addr_list

List of group addresses and virtual addresses where N is the number of group addresses and virtual addresses in this message.

Address octet stream packed in big-endian format.

Definition at line 403 of file MS_trn_api.h.

UINT16 MS_TRN_FRND_MANAGE_PARAM::num_addr

Number of Addresses in the list.

Note: Number of addresses is half of the octets in the addr_list field.

Definition at line 410 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM Struct Reference

Data Fields
MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM Struct Reference
Structures

Transport Friend Subscription List Confirm Message. More...

#include <MS_trn_api.h>

Data Fields

UINT8 txn_num
The number for identifying a transaction.

Detailed Description

Transport Friend Subscription List Confirm Message.

Definition at line 418 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_HEARTBEAT_PARAM Struct Reference

Data Fields
MS_TRN_HEARTBEAT_PARAM Struct Reference
Structures

Transport Heartbeat Message. More...

#include <MS_trn_api.h>

Data Fields

UINT8 | init_ttl
Initial TTL used when sending the message.
UINT16 | features
Bit field of currently active features of the node.

Detailed Description

Transport Heartbeat Message.

Definition at line 426 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_FRNDSHIP_INFO Struct Reference

Data Fields
MS_TRN_FRNDSHIP_INFO Struct Reference
Structures

Low Power Node element information. More...

#include <MS_trn_api.h>

Data Fields

MS_SUBNET_HANDLE | subnet_handle
MS_NET_ADDR | addr
UINT16 | lpn_counter
UINT16 | frnd_counter

Detailed Description

Low Power Node element information.

Definition at line 437 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_HEARTBEAT_PUBLICATION_INFO Struct Reference

Data Fields
MS_TRN_HEARTBEAT_PUBLICATION_INFO Struct Reference
Structures

Hearbeat Publication state. More...

#include <MS_trn_api.h>

Data Fields

MS_NET_ADDR daddr
Destination address for Heartbeat messages.
UINT8 | count_log
Count to control the number of periodic heartbeat transport messages to be sent.
UINT8 | period_log
Period to control the cadence of periodic heartbeat transport messages.
UINT8 | ttl
TTL value to be used when sending Heartbeat messages.
UINT16 | features
Features that trigger sending Heartbeat messages when changed.
UINT16 | netkey_index
Global NetKey index of the NetKey to be used to send Heartbeat messges.

Detailed Description

Hearbeat Publication state.

Definition at line 457 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO Struct Reference

Data Fields
MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO Struct Reference
Structures

Hearbeat Subscription state. More...

#include <MS_trn_api.h>

Data Fields

MS_NET_ADDR saddr
Source address for Heartbeat messages that a node shall process.
MS_NET_ADDR daddr
Destination address for Heartbeat messages.
UINT8 | count_log
Counter that tracks the number of periodic heartbeat transport message received since receiving the most recent Config Heartbeat Subscription Set message.
UINT8 | period_log
Period that controls the period for processing periodical Heartbeat transport control messages.
UINT16 | min_hops
Minimum hops value registered when receiving heartbeat messages since receiving the most recent Config Heartbeat Subscription Set message.
UINT16 | max_hops
Maximum hops value registered when receiving heartbeat messages since receiving the most recent Config Heartbeat Subscription Set message.

Detailed Description

Hearbeat Subscription state.

Definition at line 494 of file MS_trn_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_trn_api.h


EtherMind Mesh SDK (beta): Utility Macros

Utility Macros
TRANSPORT (Mesh Transport Layer)

Initialization and other Utility Macros offered by the module. More...

Initialization and other Utility Macros offered by the module.


EtherMind Mesh SDK (beta): Data Structures

Data Structures
Here are the data structures with brief descriptions:
o C ACCESS_CONFIG_APPKEY_ADD_PARAM | Appkey Add parameter structure
o C ACCESS_CONFIG_APPKEY_DELETE_PARAM | Appkey Delete parameter structure
o C ACCESS_CONFIG_APPKEY_GET_PARAM | Appkey Get parameter structure
o C ACCESS_CONFIG_APPKEY_UPDATE_PARAM | Appkey Update parameter structure
o C ACCESS_CONFIG_BEACON_SET_PARAM | Beacon Set parameter structure
o C ACCESS_CONFIG_COMPDATA_GET_PARAM | Composition Data Get parameter structure
o C ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM | Default TTL Set parameter structure
o C ACCESS_CONFIG_FRIEND_SET_PARAM | Friend Set parameter structure
o C ACCESS_CONFIG_GATT_PROXY_SET_PARAM | GATT Proxy Set parameter structure
o C ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM | Heartbeat Publication Set parameter structure
o C ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM | Heartbeat Subscription Set parameter structure
o C ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM | Key Refresh Phase Get parameter structure
o C ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM | Key Refresh Phase Set parameter structure
o C ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM | Low Power Node PollTimeout Get parameter structure
o C ACCESS_CONFIG_MODEL_APP_BIND_PARAM | Model App Bind parameter structure
o C ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM | Model App Unbind parameter structure
o C ACCESS_CONFIG_MODELPUB_GET_PARAM | Model Publication Get parameter structure
o C ACCESS_CONFIG_MODELPUB_SET_PARAM | Model Publication Set parameter structure
o C ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM | Model Publication Virtual Address Set parameter structure
o C ACCESS_CONFIG_MODELSUB_ADD_PARAM | Model Subscription Add parameter structure
o C ACCESS_CONFIG_MODELSUB_DEL_PARAM | Model Subscription Delete parameter structure
o C ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM | Model Subscription Delete All parameter structure
o C ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM | Model Subscription Overwrite parameter structure
o C ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM | Model Subscription Virtual Address Add parameter structure
o C ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM | Model Subscription Virtual Address Delete parameter structure
o C ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM | Model Subscription Virtual Address Overwrite parameter structure
o C ACCESS_CONFIG_NETKEY_ADD_PARAM | Netkey Add parameter structure
o C ACCESS_CONFIG_NETKEY_DELETE_PARAM | Netkey Delete parameter structure
o C ACCESS_CONFIG_NETKEY_UPDATE_PARAM | Netkey Update parameter structure
o C ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM | Network Transmit Set parameter structure
o C ACCESS_CONFIG_NODEID_GET_PARAM | Node Identity Get parameter structure
o C ACCESS_CONFIG_NODEID_SET_PARAM | Node Identity Set parameter structure
o C ACCESS_CONFIG_RELAY_SET_PARAM | Relay Set parameter structure
o C ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM | SIG Model App Get parameter structure
o C ACCESS_CONFIG_SIGMODELSUB_GET_PARAM | SIG Model Subscription Get parameter structure
o C ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM | Vendor Model App Get parameter structure
o C ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM | Vendor Model Subscription Get parameter structure
o C BRR_BEACON_INFO | Bearer Beacon type data structure
o C BRR_BEARER_CH_INFO | Bearer GATT Channel informartion related data structure
o C BRR_BEARER_INFO | Bearer information to register
o C MS_ACCESS_ADDRESS | Unicast/Virtual/Group Address
o C MS_ACCESS_ELEMENT_DESC | Element description format
o C MS_ACCESS_MODEL | Data structure for model
o C MS_ACCESS_MODEL_EXT_PARAMS | Additional paramters in a Model specific request or response message
o C MS_ACCESS_MODEL_ID | Model ID datatype
o C MS_ACCESS_MODEL_REQ_MSG_CONTEXT | Context of message received for a specific model instance
o C MS_ACCESS_MODEL_REQ_MSG_RAW | Uninterpreted/raw received message for a specific model instance
o C MS_ACCESS_MODEL_REQ_MSG_T | Requested message type for a specific model instance
o C MS_ACCESS_MODEL_STATE_PARAMS | Model specific state parameters in a request or response message
o C MS_ACCESS_PUBLISH_INFO | Access Publication related information
o C MS_ACCESS_STATE_TRANSITION_TYPE |
o C MS_BUFFER | Payload type
o C MS_CONFIG | Dynamic configuration of Mesh Datastructure
o C MS_EXT_STATUS_STRUCT | The Status Code field identifies the Status Code for the last operation
o C MS_EXT_TID_AND_TRANSITION_STRUCT | TID and Transition is a structure which contains Transaction ID (TID) as mandatory field
o C MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT | Generic Admin Properties Status message parameters
o C MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT | Generic Admin Property Get message parameters
o C MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT | Generic Admin Property Set message parameters
o C MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT | Generic Admin Property Status message parameters
o C MS_GENERIC_BATTERY_STATUS_STRUCT | The Generic Battery state is a set of four values representing the state of a battery:
o C MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT | Generic Client Properties Get message parameters
o C MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT | Generic Client Properties Status message parameters
o C MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT | The Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state
o C MS_GENERIC_DELTA_SET_STRUCT | Generic Delta Set message parameters
o C MS_GENERIC_LEVEL_SET_STRUCT | Generic Level Set message parameters
o C MS_GENERIC_LEVEL_STATUS_STRUCT | Generic Level Status message parameters
o C MS_GENERIC_LOCATION_GLOBAL_STRUCT | Generic Location Global Set message parameters
o C MS_GENERIC_LOCATION_LOCAL_STRUCT | Generic Location Local Set message parameters
o C MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT | Generic Manufacturer Properties Status message parameters
o C MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT | Generic Manufacturer Property Get message parameters
o C MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT | Generic Manufacturer Property Set message parameters
o C MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT | Generic Manufacturer Property Status message parameters
o C MS_GENERIC_MOVE_SET_STRUCT | Generic Move Set message parameters
o C MS_GENERIC_ONOFF_SET_STRUCT | Generic OnOff Set message parameters
o C MS_GENERIC_ONOFF_STATUS_STRUCT | Generic OnOff Status message parameters
o C MS_GENERIC_ONPOWERUP_STRUCT | Generic OnPowerUp Set message parameters
o C MS_GENERIC_POWER_DEFAULT_SET_STRUCT | Generic Power Default Status message parameters
o C MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT | Generic Power Default Status message parameters
o C MS_GENERIC_POWER_LAST_STATUS_STRUCT | Generic Power Last Status message parameters
o C MS_GENERIC_POWER_LEVEL_SET_STRUCT | Generic Power Level Set message parameters
o C MS_GENERIC_POWER_LEVEL_STATUS_STRUCT | Generic Power Level Status message parameters
o C MS_GENERIC_POWER_RANGE_SET_STRUCT | Generic Power Range Set message parameters
o C MS_GENERIC_POWER_RANGE_STATUS_STRUCT | Generic Power Range Status message parameters
o C MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT | Generic User Properties Status message parameters
o C MS_GENERIC_USER_PROPERTY_GET_STRUCT | Generic User Property Get message parameters
o C MS_GENERIC_USER_PROPERTY_SET_STRUCT | Generic User Property Set message parameters
o C MS_GENERIC_USER_PROPERTY_STATUS_STRUCT | Generic User Property Status message parameters
o C MS_HEALTH_ATTENTION_STRUCT | Health Attention message parameters
o C MS_HEALTH_FAULT_GET_CLEAR_STRUCT | Health Fault Get clear message parameters
o C MS_HEALTH_FAULT_TEST_STRUCT | Health Fault Test message parameters
o C MS_HEALTH_PERIOD_STRUCT | Health Period message parameters
o C MS_HEALTH_SERVER_SELF_TEST | Health Server Self Test Funtion Structure
o C MS_HEALTH_STATUS_STRUCT | Health Status message parameters
o C MS_LIGHT_CTL_DEFAULT_SET_STRUCT | Light CTL Default Set message parameters
o C MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT | Light CTL Default Status message parameters
o C MS_LIGHT_CTL_SET_STRUCT | Light CTL Set message parameters
o C MS_LIGHT_CTL_STATUS_STRUCT | Light CTL Status message parameters
o C MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT | Light CTL Temperature Range Set message parameters
o C MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT | Light CTL Temperature Range Status message parameters
o C MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT | Light CTL Temperature Set message parameters
o C MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT | Light CTL Temperature Status message parameters
o C MS_LIGHT_HSL_DEFAULT_SET_STRUCT | Light HSL Default Set message parameters
o C MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT | Light HSL Default Status message parameters
o C MS_LIGHT_HSL_HUE_SET_STRUCT | Light HSL Hue Set message parameters
o C MS_LIGHT_HSL_HUE_STATUS_STRUCT | Light HSL Hue Status message parameters
o C MS_LIGHT_HSL_RANGE_SET_STRUCT | Light HSL Range Set message parameters
o C MS_LIGHT_HSL_RANGE_STATUS_STRUCT | Light HSL Range Status message parameters
o C MS_LIGHT_HSL_SATURATION_SET_STRUCT | Light HSL Saturation Set message parameters
o C MS_LIGHT_HSL_SATURATION_STATUS_STRUCT | Light HSL Saturation Status message parameters
o C MS_LIGHT_HSL_SET_STRUCT | Light HSL Set message parameters
o C MS_LIGHT_HSL_STATUS_STRUCT | Light HSL Status message parameters
o C MS_LIGHT_HSL_TARGET_STATUS_STRUCT | Light HSL Target Status message parameters
o C MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT | Light LC Light OnOff Set message parameters
o C MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT | Light LC Light OnOff Status message parameters
o C MS_LIGHT_LC_MODE_STRUCT | Light LC Mode Set/Status message parameters
o C MS_LIGHT_LC_OM_STRUCT |
o C MS_LIGHT_LC_PROPERTY_GET_STRUCT | Light LC Property Get message parameters
o C MS_LIGHT_LC_PROPERTY_SET_STRUCT | Light LC Property Set message parameters
o C MS_LIGHT_LC_PROPERTY_STATUS_STRUCT | Light LC Property Status message parameters
o C MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT | Light Lightness Default Set message parameters
o C MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT | Light Lightness Default Status message parameters
o C MS_LIGHT_LIGHTNESS_LAST_OR_DEFAULT_STATUS_STRUCT |
o C MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT | Light Lightness Last Status message parameters
o C MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT | Light Lightness Linear Set message parameters
o C MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT | Light Lightness Linear Status message parameters
o C MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT | Light Lightness Range Set message parameters
o C MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT | Light Lightness Range Status message parameters
o C MS_LIGHT_LIGHTNESS_SET_STRUCT | Light Lightness Set message parameters
o C MS_LIGHT_LIGHTNESS_STATUS_STRUCT | Light Lightness Status message parameters
o C MS_LIGHT_XYL_DEFAULT_SET_STRUCT | Light HSL Default Set message parameters
o C MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT | Light xyL Default Status message parameters
o C MS_LIGHT_XYL_RANGE_SET_STRUCT | Light xyL Range Set message parameters
o C MS_LIGHT_XYL_RANGE_STATUS_STRUCT | Light xyL Range Status message parameters
o C MS_LIGHT_XYL_SET_STRUCT | Light xyL Set message parameters
o C MS_LIGHT_XYL_STATUS_STRUCT | Light xyL Status Unacknowledged message parameters
o C MS_LIGHT_XYL_TARGET_STATUS_STRUCT | Light xyL Target Status Unacknowledged message parameters
o C MS_NET_HEADER | Network Header Type
o C MS_PROV_DEV_ENTRY | Provisioned Device List Data Structure, containing Primary Element Address and number of elements
o C MS_SCENE_RECALL_STRUCT | Scene Recall message parameters
o C MS_SCENE_REGISTER_STATUS_STRUCT | Scene Register Status message parameters
o C MS_SCENE_STATUS_STRUCT | Scene Status message parameters
o C MS_SCENE_STRUCT | Scene Store message parameters
o C MS_SCHEDULER_ACTION_GET_STRUCT | Scheduler Action Get message parameters
o C MS_SCHEDULER_ACTION_SET_STRUCT | Scheduler Action Set message parameters
o C MS_SCHEDULER_ACTION_STATUS_STRUCT | Scheduler Action Status message parameters
o C MS_SCHEDULER_STATUS_STRUCT | Scheduler Status message parameters
o C MS_SENSOR_CADENCE_GET_STRUCT | Sensor Cadence Get message parameters
o C MS_SENSOR_CADENCE_SET_STRUCT | Sensor Cadence Set message parameters
o C MS_SENSOR_CADENCE_STATUS_STRUCT | Sensor Cadence Status message parameters
o C MS_SENSOR_COLUMN_GET_STRUCT | Sensor Column Get message parameters
o C MS_SENSOR_COLUMN_STATUS_STRUCT | Sensor Column Status message parameters
o C MS_SENSOR_DESCRIPTOR_GET_STRUCT | Sensor Descriptor Get message parameters
o C MS_SENSOR_DESCRIPTOR_STATUS_STRUCT | Sensor Descriptor Status message parameters
o C MS_SENSOR_GET_STRUCT | Sensor Get message parameters
o C MS_SENSOR_SERIES_GET_STRUCT | Sensor Series Get message parameters
o C MS_SENSOR_SERIES_STATUS_STRUCT | Sensor Series Status message parameters
o C MS_SENSOR_SETTING_GET_STRUCT | Sensor Setting Get message parameters
o C MS_SENSOR_SETTING_SET_STRUCT | Sensor Setting Set message parameters
o C MS_SENSOR_SETTING_STATUS_STRUCT | Sensor Setting Status message parameters
o C MS_SENSOR_SETTINGS_GET_STRUCT | Sensor Settings Get message parameters
o C MS_SENSOR_SETTINGS_STATUS_STRUCT | Sensor Setting Status message parameters
o C MS_SENSOR_STATUS_STRUCT | Sensor Status message parameters
o C MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT | Generic Admin Property is a state representing a device property of an element that can be read or written
o C MS_STATE_GENERIC_BATTERY_STRUCT | Generic Battery state is a set of four values representing the state of a battery
o C MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT | Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state
o C MS_STATE_GENERIC_LEVEL_STRUCT | Generic Level state is a 16-bit signed integer (2-s complement) representing the state of an element
o C MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT | Generic Global Location state defines location information of an element
o C MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT | Generic Local Location state defines location information of an element
o C MS_STATE_GENERIC_LOCATION_STRUCT | Generic Location state is a composite state that includes a Generic Location Global state and a Generic Location Local state
o C MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT | Generic Manufacturer Property is a state representing a device property of an element that is programmed by a manufacturer and can be read
o C MS_STATE_GENERIC_ONOFF_STRUCT | Generic OnOff state is a Boolean value that represents the state of an element
o C MS_STATE_GENERIC_ONPOWERUP_STRUCT | Generic OnPowerUp state is an enumeration representing the behavior of an element when powered up
o C MS_STATE_GENERIC_POWER_ACTUAL_STRUCT | Generic Power Actual state determines the linear percentage of the maximum power level of an element, representing a range from 0 percent through 100 percent
o C MS_STATE_GENERIC_POWER_DEFAULT_STRUCT | Generic Power Default state is a 16-bit value ranging from 0 through 65535
o C MS_STATE_GENERIC_POWER_LAST_STRUCT | Generic Power Last state is a 16-bit value representing a percentage ranging from (1/65535) percent to 100 percent
o C MS_STATE_GENERIC_POWER_LEVEL_STRUCT | Generic Power Level state is a composite state that includes a Generic Power Actual state, a Generic Power Last state, a Generic Power Default state, and a Generic Power Range state
o C MS_STATE_GENERIC_POWER_RANGE_STRUCT | Generic Power Range state determines the minimum and maximum power levels of an element relative to the maximum power level an element can output
o C MS_STATE_GENERIC_PROPERTY_ID_STRUCT | Generic Property ID a read-only state representing a device property that an element supports
o C MS_STATE_GENERIC_PROPERTY_IDS_STRUCT | Generic Property IDs a state representing a set of device properties that an element supports
o C MS_STATE_GENERIC_PROPERTY_STRUCT | Generic Property is a state representing a device property of an element
o C MS_STATE_GENERIC_USER_PROPERTY_STRUCT | Generic User Property is a state representing a device property of an element
o C MS_STATE_LIGHT_CTL_DEFAULT_STRUCT | Light CTL Default state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states
o C MS_STATE_LIGHT_CTL_STRUCT | Light CTL state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states
o C MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT | Light CTL Temperature Range state determines the minimum and maximum color temperatures of tunable white light an element is capable of emitting
o C MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT | Light CTL Temperature state is a composite state that includes the Light CTL Temperature and the Light CTL Delta UV states
o C MS_STATE_LIGHT_HSL_DEFAULT_STRUCT | Light HSL Default state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states
o C MS_STATE_LIGHT_HSL_HUE_STRUCT | Light HSL Hue
o C MS_STATE_LIGHT_HSL_RANGE_STRUCT | Light HSL Range state is a composite state that includes Minimum and Maximum of the Light HSL Hue and the Light HSL Saturation states
o C MS_STATE_LIGHT_HSL_SATURATION_STRUCT | Light HSL Saturation
o C MS_STATE_LIGHT_HSL_STRUCT | Light HSL state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states
o C MS_STATE_LIGHT_HSL_TARGET_STRUCT | Light HSL Target state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states
o C MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT | Light LC Light OnOff State
o C MS_STATE_LIGHT_LC_MODE_STRUCT | Light LC Mode state
o C MS_STATE_LIGHT_LC_OM_STRUCT | Light LC Occupancy Mode state
o C MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT | Property ID identifying a Light LC Property
o C MS_STATE_LIGHT_LC_PROPERTY_STRUCT | Light LC Property state
o C MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT | Light Lightness Actual state represents the lightness of a light on a perceptually uniform lightness scale
o C MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT | Light Lightness Default state is a value ranging from 0x0000 to 0xFFFF, representing a default lightness level for the Light Lightness Actual state
o C MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT | Light Lightness Last state represents the lightness of a light on a perceptually uniform lightness scale
o C MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT | Light Lightness Linear state represents the lightness of a light on a linear scale
o C MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT | Light Lightness Range state determines the minimum and maximum lightness of an element
o C MS_STATE_LIGHT_LIGHTNESS_STRUCT | Light Lightness state is a composite state that includes the Light Lightness Linear, the Light Lightness Actual, the Light Lightness Last, and the Light Lightness Default states
o C MS_STATE_LIGHT_XYL_DEFAULT_STRUCT | Light xyL default state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states
o C MS_STATE_LIGHT_XYL_RANGE_STRUCT | Light xyL Range state determines the minimum and maximum values of the Light xyL x and syL y state of an element
o C MS_STATE_LIGHT_XYL_STRUCT | Light xyL state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states
o C MS_STATE_LIGHT_XYL_TARGET_STRUCT | Light xyL target state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states
o C MS_STATE_SCENE_NUMBER_STRUCT | The state to identify a scene
o C MS_STATE_SCENE_REGISTER_STATUS_STRUCT | The current status of scene register
o C MS_STATE_SCENE_STATUS_STRUCT | The current status of a currently active scene
o C MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT | The entry index of the Schedule Register state
o C MS_STATE_SCHEDULER_ENTRY_STRUCT | The entry of the Schedule Register state
o C MS_STATE_SCHEDULER_SCHEDULES_STRUCT | The current Schedule Register state of an element
o C MS_STATE_SENSOR_CADENCE_STRUCT | Sensor Cadence state controls the cadence of sensor reports
o C MS_STATE_SENSOR_DATA_STRUCT | The Sensor Data state is a sequence of one or more pairs of Sensor Property ID and Raw Value fields, with each Raw Value field size and representation defined by the characteristics referenced by the Sensor Property ID
o C MS_STATE_SENSOR_DESCRIPTOR_STRUCT | Sensor Descriptor state represents the attributes describing the sensor data
o C MS_STATE_SENSOR_PROPERTY_ID_STRUCT | Sensor Property ID field is a 2-octet value referencing a device property that describes the meaning and the format of data reported by a sensor
o C MS_STATE_SENSOR_SERIES_COLUMN_STRUCT | Values measured by sensors may be organized as arrays (and represented as series of columns, such as histograms
o C MS_STATE_SENSOR_SETTING_STRUCT | Sensor Setting state controls parameters of a sensor
o C MS_STATE_SENSOR_SETTINGS_STRUCT | Sensor Settings state controls parameters of a sensor
o C MS_STATE_TIME_ROLE_STRUCT | The Time Role state of an element
o C MS_STATE_TIME_STRUCT | Mesh defines times based on International Atomic Time (TAI)
o C MS_STATE_TIME_TAI_UTC_DELTA_STRUCT | TAI-UTC Delta
o C MS_STATE_TIME_ZONE_STRUCT | Time Zone
o C MS_TAI_UTC_DELTA_SET_STRUCT | TAI-UTC Delta Set message parameters
o C MS_TAI_UTC_DELTA_STATUS_STRUCT | TAI-UTC Delta Status message parameters
o C MS_TIME_ROLE_STRUCT | Time Role Set/Status message parameters
o C MS_TIME_STRUCT | Time Set message parameters
o C MS_TIME_ZONE_SET_STRUCT | Time Zone Set message parameters
o C MS_TIME_ZONE_STATUS_STRUCT | Time Zone Status message parameters
o C MS_TRN_FRIEND_ENTRY | Friend Data Structure
o C MS_TRN_FRND_CLEAR_CNF_PARAM | Transport Friend Clear Confirm Message
o C MS_TRN_FRND_CLEAR_PARAM | Transport Friend Clear Message
o C MS_TRN_FRND_MANAGE_PARAM | Transport Friend Subscription List Add/Remove Message
o C MS_TRN_FRND_OFFER_PARAM | Transport Friend Offer Message
o C MS_TRN_FRND_POLL_PARAM | Transport Friend Poll Message
o C MS_TRN_FRND_REQ_PARAM | Transport Friend Request Message
o C MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM | Transport Friend Subscription List Confirm Message
o C MS_TRN_FRND_UPDATE_PARAM | Transport Friend Update Message
o C MS_TRN_FRNDSHIP_INFO | Low Power Node element information
o C MS_TRN_HEARTBEAT_PARAM | Transport Heartbeat Message
o C MS_TRN_HEARTBEAT_PUBLICATION_INFO | Hearbeat Publication state
o C MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO | Hearbeat Subscription state
o C MS_VERSION_NUMBER | Version Number Structure
o C PROV_CAPABILITIES_S | Device capabilities used for Provisioning
o C PROV_DATA_S | Data exchanged during Provisiong procedure
o C PROV_DEVICE_S | Device Information used for Provisioning
o C PROV_METHOD_S | Provisioning method information
\ C PROV_OOB_TYPE_S | OOB type for provisioning


EtherMind Mesh SDK (beta): MS_ACCESS_STATE_TRANSITION_TYPE Struct Reference

Data Fields
MS_ACCESS_STATE_TRANSITION_TYPE Struct Reference

Data Fields

EM_timer_handle | transition_timer_handle
UINT8 | transition_state
UINT8 | delay
UINT8 | transition_time
void(* | transition_start_cb )(void *)
void(* | transition_complete_cb )(void *)
void * | blob

Detailed Description

Definition at line 1352 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_EXT_STATUS_STRUCT Struct Reference

Data Fields
MS_EXT_STATUS_STRUCT Struct Reference

The Status Code field identifies the Status Code for the last operation. More...

#include <MS_model_states.h>

Data Fields

UCHAR status

Detailed Description

The Status Code field identifies the Status Code for the last operation.

Definition at line 1345 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_EXT_TID_AND_TRANSITION_STRUCT Struct Reference

Data Fields
MS_EXT_TID_AND_TRANSITION_STRUCT Struct Reference

TID and Transition is a structure which contains Transaction ID (TID) as mandatory field. More...

#include <MS_model_states.h>

Data Fields

UCHAR | tid
UCHAR | transition_time
UCHAR | delay
UCHAR | optional_fields_present

Detailed Description

TID and Transition is a structure which contains Transaction ID (TID) as mandatory field.

Other two fields, Transition Time and Delay are optional.

TID field is a transaction identifier indicating whether the message is a new message or a retransmission of a previously sent message.

If present, the Transition Time field identifies the time that an element will take to transition to the target state from the present state.

The Delay field shall be present when the Transition Time field is present. It identifies the message execution delay, representing a time interval between receiving the message by a model and executing the associated model behaviors.

Definition at line 1333 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_HEALTH_SERVER_SELF_TEST Struct Reference

Data Fields
MS_HEALTH_SERVER_SELF_TEST Struct Reference

Health Server Self Test Funtion Structure. More...

#include <MS_health_server_api.h>

Data Fields

UINT8 test_id
Test ID.
MS_HEALTH_SERVER_SELF_TEST_FN self_test_fn
Self Test Function.

Detailed Description

Health Server Self Test Funtion Structure.

Definition at line 186 of file MS_health_server_api.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_health_server_api.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT Struct Reference

Generic Admin Property is a state representing a device property of an element that can be read or written. More...

#include <MS_model_states.h>

Data Fields

UINT16 | property_id
Admin Property ID field is a 2-octet Assigned Number value referencing a device property.
UCHAR | user_access
Admin User Access field is an enumeration indicating whether the device property can be read or written as a Generic User Property.
UCHAR * | property_value
Admin Property Value field is a conditional field.
UINT16 | property_value_len

Detailed Description

Generic Admin Property is a state representing a device property of an element that can be read or written.

Definition at line 392 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_BATTERY_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_BATTERY_STRUCT Struct Reference

Generic Battery state is a set of four values representing the state of a battery. More...

#include <MS_model_states.h>

Data Fields

UCHAR | generic_battery_level
Generic Battery Level state is a value ranging from 0 percent through 100 percent.
UINT32 | generic_battery_time_to_discharge
Generic Battery Time to Discharge state is a 24-bit unsigned value ranging from 0 through 0xFFFFFF.
UINT32 | generic_battery_time_to_charge
Generic Battery Time to Charge state is a 24-bit unsigned value ranging from 0 through 0xFFFFFF.
UCHAR | generic_battery_flags
Generic Battery Flags state is a concatenation of four 2-bit bit fields: Presence, Indicator, Charging, and Serviceability.

Detailed Description

Generic Battery state is a set of four values representing the state of a battery.

Definition at line 264 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT Struct Reference

Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state. More...

#include <MS_model_states.h>

Data Fields

UCHAR | default_transition_number_of_steps
The number of Steps.
UCHAR | default_transition_step_resolution
The resolution of the Default Transition Number of Steps field.

Detailed Description

Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state.

Definition at line 160 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_LEVEL_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_LEVEL_STRUCT Struct Reference

Generic Level state is a 16-bit signed integer (2-s complement) representing the state of an element. More...

#include <MS_model_states.h>

Data Fields

UINT16 | level
Generic Level.
UINT32 | delta_level
Delta Level.
UINT16 | move_level
Move Level.
UINT8 | tid
UINT8 | transition_time
UINT8 | delay
UINT16 | target_level
Target Level.

Detailed Description

Generic Level state is a 16-bit signed integer (2-s complement) representing the state of an element.

Definition at line 130 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT Struct Reference

Generic Global Location state defines location information of an element. More...

#include <MS_model_states.h>

Data Fields

UINT32 | global_latitude
Global Coordinates (Latitude)
UINT32 | global_longitude
Global Coordinates (Longitude)
UINT16 | global_altitude
Global Altitude.

Detailed Description

Generic Global Location state defines location information of an element.

Definition at line 292 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT Struct Reference

Generic Local Location state defines location information of an element. More...

#include <MS_model_states.h>

Data Fields

UINT16 | local_north
Local Coordinates (North)
UINT16 | local_east
Local Coordinates (East)
UINT16 | local_altitude
Local Altitude.
UCHAR | floor_number
Floor Number.
UINT16 | uncertainty
Uncertainty.

Detailed Description

Generic Local Location state defines location information of an element.

Definition at line 305 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_LOCATION_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_LOCATION_STRUCT Struct Reference

Generic Location state is a composite state that includes a Generic Location Global state and a Generic Location Local state. More...

#include <MS_model_states.h>

Data Fields

MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT global_location
Global Location.
MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT local_location
Local Location.

Detailed Description

Generic Location state is a composite state that includes a Generic Location Global state and a Generic Location Local state.

Definition at line 327 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT Struct Reference

Generic Manufacturer Property is a state representing a device property of an element that is programmed by a manufacturer and can be read. More...

#include <MS_model_states.h>

Data Fields

UINT16 | property_id
Manufacturer Property ID field is a 2-octet Assigned Number value that references a device property.
UCHAR | user_access
Manufacturer User Access field is an enumeration indicating whether or not the device property can be read as a Generic User Property.
UCHAR * | property_value
Manufacturer Property Value field is a conditional field.
UINT16 | property_value_len

Detailed Description

Generic Manufacturer Property is a state representing a device property of an element that is programmed by a manufacturer and can be read.

Definition at line 415 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_ONOFF_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_ONOFF_STRUCT Struct Reference

Generic OnOff state is a Boolean value that represents the state of an element. More...

#include <MS_model_states.h>

Data Fields

UINT8 | onoff
Generic On/Off.
UINT8 | target_onoff
Target On/Off - Used in response path.
UINT8 | last_onoff
Last On/Off.
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Generic OnOff state is a Boolean value that represents the state of an element.

Definition at line 101 of file MS_model_states.h.

Field Documentation

UINT8 MS_STATE_GENERIC_ONOFF_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 119 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_ONPOWERUP_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_ONPOWERUP_STRUCT Struct Reference

Generic OnPowerUp state is an enumeration representing the behavior of an element when powered up. More...

#include <MS_model_states.h>

Data Fields

UCHAR onpowerup
Generic OnPowerUp.

Detailed Description

Generic OnPowerUp state is an enumeration representing the behavior of an element when powered up.

Definition at line 173 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_POWER_ACTUAL_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_POWER_ACTUAL_STRUCT Struct Reference

Generic Power Actual state determines the linear percentage of the maximum power level of an element, representing a range from 0 percent through 100 percent. More...

#include <MS_model_states.h>

Data Fields

UINT16 | power_actual
Generic Power Actual.
UINT8 | tid
UINT16 | power_target
Generic Power Target - Used only in response path.
UINT8 | transition_time
Transition Time - Used in request path Used as Remaining Time in response path.
UINT8 | delay

Detailed Description

Generic Power Actual state determines the linear percentage of the maximum power level of an element, representing a range from 0 percent through 100 percent.

Definition at line 184 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_POWER_DEFAULT_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_POWER_DEFAULT_STRUCT Struct Reference

Generic Power Default state is a 16-bit value ranging from 0 through 65535. More...

#include <MS_model_states.h>

Data Fields

UINT16 power_default
Generic Power Default.

Detailed Description

Generic Power Default state is a 16-bit value ranging from 0 through 65535.

Definition at line 217 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_POWER_LAST_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_POWER_LAST_STRUCT Struct Reference

Generic Power Last state is a 16-bit value representing a percentage ranging from (1/65535) percent to 100 percent. More...

#include <MS_model_states.h>

Data Fields

UINT16 power_last
Generic Power Last.

Detailed Description

Generic Power Last state is a 16-bit value representing a percentage ranging from (1/65535) percent to 100 percent.

Definition at line 210 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_POWER_LEVEL_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_POWER_LEVEL_STRUCT Struct Reference

Generic Power Level state is a composite state that includes a Generic Power Actual state, a Generic Power Last state, a Generic Power Default state, and a Generic Power Range state. More...

#include <MS_model_states.h>

Data Fields

MS_STATE_GENERIC_POWER_ACTUAL_STRUCT generic_power_actual
Generic Power Actual.
MS_STATE_GENERIC_POWER_LAST_STRUCT generic_power_last
Generic Power Last.
MS_STATE_GENERIC_POWER_DEFAULT_STRUCT generic_power_default
Generic Power Default.
MS_STATE_GENERIC_POWER_RANGE_STRUCT generic_power_range
Generic Power Range.

Detailed Description

Generic Power Level state is a composite state that includes a Generic Power Actual state, a Generic Power Last state, a Generic Power Default state, and a Generic Power Range state.

Definition at line 245 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_POWER_RANGE_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_POWER_RANGE_STRUCT Struct Reference

Generic Power Range state determines the minimum and maximum power levels of an element relative to the maximum power level an element can output. More...

#include <MS_model_states.h>

Data Fields

UINT16 | power_range_min
Generic Power Range - Minimum.
UINT16 | power_range_max
Generic Power Range - Maximum.
UINT8 | status
Status - Used only in the response path.

Detailed Description

Generic Power Range state determines the minimum and maximum power levels of an element relative to the maximum power level an element can output.

Definition at line 227 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_PROPERTY_ID_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_PROPERTY_ID_STRUCT Struct Reference

Generic Property ID a read-only state representing a device property that an element supports. More...

#include <MS_model_states.h>

Data Fields

UINT16 property_id
Property ID field is a 2-octet Assigned Number value that references a device property.

Detailed Description

Generic Property ID a read-only state representing a device property that an element supports.

Definition at line 438 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_PROPERTY_IDS_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_PROPERTY_IDS_STRUCT Struct Reference

Generic Property IDs a state representing a set of device properties that an element supports. More...

#include <MS_model_states.h>

Data Fields

UINT16 * | property_ids
Property IDs field is a set of 2-octet Assigned Number value that references a set of device properties.
UINT16 | property_ids_count

Detailed Description

Generic Property IDs a state representing a set of device properties that an element supports.

Definition at line 451 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_PROPERTY_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_PROPERTY_STRUCT Struct Reference

Generic Property is a state representing a device property of an element. More...

#include <MS_model_states.h>

Data Fields

UINT16 | property_id
User Property ID field is a 2-octet Assigned Number value referencing a property.
UINT8 | property_type
Property Type - Manufacturer/Admin/User.
UCHAR | access
User Access field is an enumeration indicating whether the device property can be read or written as a Generic Admin/User Property.
UCHAR * | property_value
User Property Value field is a conditional field.
UINT16 | property_value_len

Detailed Description

Generic Property is a state representing a device property of an element.

The properties can be one of the following

  • Manufacturer Properties
  • Admin Properties
  • User Properties

Definition at line 344 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_GENERIC_USER_PROPERTY_STRUCT Struct Reference

Data Fields
MS_STATE_GENERIC_USER_PROPERTY_STRUCT Struct Reference

Generic User Property is a state representing a device property of an element. More...

#include <MS_model_states.h>

Data Fields

UINT16 | property_id
User Property ID field is a 2-octet Assigned Number value referencing a device property.
UCHAR | user_access
User Access field is an enumeration indicating whether the device property can be read or written as a Generic User Property.
UCHAR * | property_value
User Property Value field is a conditional field.
UINT16 | property_value_len

Detailed Description

Generic User Property is a state representing a device property of an element.

Definition at line 369 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_CTL_DEFAULT_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_CTL_DEFAULT_STRUCT Struct Reference

Light CTL Default state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | ctl_lightness
Light CTL Lightness.
UINT16 | ctl_temperature
Light CTL Temperature.
UINT16 | ctl_delta_uv
Light CTL Delta UV.

Detailed Description

Light CTL Default state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states.

Definition at line 986 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_CTL_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_CTL_STRUCT Struct Reference

Light CTL state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | ctl_lightness
Light CTL Lightness.
UINT16 | target_ctl_lightness
Target Light CTL Lightness - Used in response path.
UINT16 | ctl_temperature
Light CTL Temperature.
UINT16 | target_ctl_temperature
Terget Light CTL Temperature - Used in response path.
UINT16 | ctl_delta_uv
Light CTL Delta UV.
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Light CTL state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states.

Definition at line 951 of file MS_model_states.h.

Field Documentation

UINT8 MS_STATE_LIGHT_CTL_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 975 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT Struct Reference

Light CTL Temperature Range state determines the minimum and maximum color temperatures of tunable white light an element is capable of emitting. More...

#include <MS_model_states.h>

Data Fields

UINT16 | ctl_temperature_range_min
CTL Temperature Range Min.
UINT16 | ctl_temperature_range_max
CTL Temperature Range Max.
UINT8 | status
Status - Used in response path.

Detailed Description

Light CTL Temperature Range state determines the minimum and maximum color temperatures of tunable white light an element is capable of emitting.

Definition at line 1034 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT Struct Reference

Light CTL Temperature state is a composite state that includes the Light CTL Temperature and the Light CTL Delta UV states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | ctl_temperature
Light CTL Temperature.
UINT16 | target_ctl_temperature
Target Light CTL Temperature - Used in response path.
UINT16 | ctl_delta_uv
Light CTL Delta UV.
UINT16 | target_ctl_delta_uv
Target Light CTL Delta UV - Used in response path.
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Light CTL Temperature state is a composite state that includes the Light CTL Temperature and the Light CTL Delta UV states.

Definition at line 1002 of file MS_model_states.h.

Field Documentation

UINT8 MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 1023 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_HSL_DEFAULT_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_HSL_DEFAULT_STRUCT Struct Reference

Light HSL Default state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | hsl_lightness
The perceived lightness of a light emitted by the element.
UINT16 | hsl_hue
The 16-bit value representing the hue.
UINT16 | hsl_saturation
The saturation of a color light.

Detailed Description

Light HSL Default state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states.

Definition at line 1105 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_HSL_HUE_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_HSL_HUE_STRUCT Struct Reference

Light HSL Hue. More...

#include <MS_model_states.h>

Data Fields

UINT16 hsl_hue
The 16-bit value representing the hue.

Detailed Description

Light HSL Hue.

Definition at line 1118 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_HSL_RANGE_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_HSL_RANGE_STRUCT Struct Reference

Light HSL Range state is a composite state that includes Minimum and Maximum of the Light HSL Hue and the Light HSL Saturation states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | hue_range_min
The value of the Hue Range Min field of the Light HSL Hue Range state.
UINT16 | hue_range_max
The value of the Hue Range Max field of the Light HSL Hue Range state.
UINT16 | saturation_range_min
The value of the Saturation Range Min field of the Light HSL Saturation Range state.
UINT16 | saturation_range_max
The value of the Saturation Range Max field of the Light HSL Saturation Range state.
UINT8 | status
Status - Used only in response path.

Detailed Description

Light HSL Range state is a composite state that includes Minimum and Maximum of the Light HSL Hue and the Light HSL Saturation states.

Definition at line 1135 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_HSL_SATURATION_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_HSL_SATURATION_STRUCT Struct Reference

Light HSL Saturation. More...

#include <MS_model_states.h>

Data Fields

UINT16 hsl_saturation
The saturation of a color light.

Detailed Description

Light HSL Saturation.

Definition at line 1125 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_HSL_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_HSL_STRUCT Struct Reference

Light HSL state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | hsl_lightness
The perceived lightness of a light emitted by the element.
UINT16 | target_hsl_lightness
Target Perceived lightness - used in the response path.
UINT16 | hsl_hue
The 16-bit value representing the hue.
UINT16 | target_hsl_hue
Target hue - used in the response path.
UINT16 | hsl_saturation
The saturation of a color light.
UINT16 | target_hsl_saturation
Target saturation - used in the response path.
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Light HSL state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states.

Definition at line 1051 of file MS_model_states.h.

Field Documentation

UINT8 MS_STATE_LIGHT_HSL_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 1078 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_HSL_TARGET_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_HSL_TARGET_STRUCT Struct Reference

Light HSL Target state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | hsl_lightness
The perceived lightness of a light emitted by the element.
UINT16 | hsl_hue
The 16-bit value representing the hue.
UINT16 | hsl_saturation
The saturation of a color light.

Detailed Description

Light HSL Target state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states.

Definition at line 1089 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT Struct Reference

Light LC Light OnOff State. More...

#include <MS_model_states.h>

Data Fields

UCHAR | present_light_onoff
Light LC Light OnOff State.
UCHAR | target_light_onoff
Light LC Light OnOff State.
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Light LC Light OnOff State.

Definition at line 1276 of file MS_model_states.h.

Field Documentation

UINT8 MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 1291 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LC_MODE_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LC_MODE_STRUCT Struct Reference

Light LC Mode state. More...

#include <MS_model_states.h>

Data Fields

UCHAR | present_mode
Light LC Mode state - present.
UCHAR | target_mode
Light LC Mode state - target.

Detailed Description

Light LC Mode state.

Definition at line 1254 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LC_OM_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LC_OM_STRUCT Struct Reference

Light LC Occupancy Mode state. More...

#include <MS_model_states.h>

Data Fields

UCHAR | present_mode
Light LC Occupancy Mode state - present.
UCHAR | target_mode
Light LC Occupancy Mode state - target.

Detailed Description

Light LC Occupancy Mode state.

Definition at line 1265 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT Struct Reference

Property ID identifying a Light LC Property. More...

#include <MS_model_states.h>

Data Fields

UINT16 property_id
Property ID identifying a Light LC Property.

Detailed Description

Property ID identifying a Light LC Property.

Definition at line 1299 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LC_PROPERTY_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LC_PROPERTY_STRUCT Struct Reference

Light LC Property state. More...

#include <MS_model_states.h>

Data Fields

UINT16 | property_id
Property ID identifying a Light LC Property.
UCHAR * | property_value
Raw value for the Light LC Property.
UINT16 | property_value_len

Detailed Description

Light LC Property state.

Definition at line 1306 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT Struct Reference

Light Lightness Actual state represents the lightness of a light on a perceptually uniform lightness scale. More...

#include <MS_model_states.h>

Data Fields

UINT16 | lightness_actual
Light Lightness Actual.
UINT16 | lightness_target
Light Lightness Target - Used in response path. More...
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Light Lightness Actual state represents the lightness of a light on a perceptually uniform lightness scale.

Definition at line 851 of file MS_model_states.h.

Field Documentation

UINT16 MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT::lightness_target

Light Lightness Target - Used in response path.

Definition at line 857 of file MS_model_states.h.

UINT8 MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 866 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT Struct Reference

Light Lightness Default state is a value ranging from 0x0000 to 0xFFFF, representing a default lightness level for the Light Lightness Actual state. More...

#include <MS_model_states.h>

Data Fields

UINT16 lightness_default
Light Lightness Default.

Detailed Description

Light Lightness Default state is a value ranging from 0x0000 to 0xFFFF, representing a default lightness level for the Light Lightness Actual state.

Definition at line 887 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT Struct Reference

Light Lightness Last state represents the lightness of a light on a perceptually uniform lightness scale. More...

#include <MS_model_states.h>

Data Fields

UINT16 lightness_last
Light Lightness Last.

Detailed Description

Light Lightness Last state represents the lightness of a light on a perceptually uniform lightness scale.

Definition at line 877 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT Struct Reference

Light Lightness Linear state represents the lightness of a light on a linear scale. More...

#include <MS_model_states.h>

Data Fields

UINT16 | lightness_linear
Light Lightness Linear.
UINT16 | lightness_target
Light Lightness Target - Used in response path. More...
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Light Lightness Linear state represents the lightness of a light on a linear scale.

Definition at line 825 of file MS_model_states.h.

Field Documentation

UINT16 MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT::lightness_target

Light Lightness Target - Used in response path.

Definition at line 831 of file MS_model_states.h.

UINT8 MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 840 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT Struct Reference

Light Lightness Range state determines the minimum and maximum lightness of an element. More...

#include <MS_model_states.h>

Data Fields

UINT16 | lightness_range_min
Light Lightness Range Min.
UINT16 | lightness_range_max
Light Lightness Range Max.

Detailed Description

Light Lightness Range state determines the minimum and maximum lightness of an element.

Definition at line 897 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_LIGHTNESS_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_LIGHTNESS_STRUCT Struct Reference

Light Lightness state is a composite state that includes the Light Lightness Linear, the Light Lightness Actual, the Light Lightness Last, and the Light Lightness Default states. More...

#include <MS_model_states.h>

Data Fields

MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT light_lightness_linear
Light Lightness Linear state represents the lightness of a light on a linear scale.
MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT light_lightness_actual
Light Lightness Actual state represents the lightness of a light on a perceptually uniform lightness scale.
MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT light_lightness_last
Light Lightness Last state represents the lightness of a light on a perceptually uniform lightness scale.
MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT light_lightness_default
Light Lightness Default state is a value ranging from 0x0000 to 0xFFFF, representing a default lightness level for the Light Lightness Actual state.
MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT light_lightness_range
Light Lightness Range state.
UINT8 range_status
Status field used only for the Range Status.

Detailed Description

Light Lightness state is a composite state that includes the Light Lightness Linear, the Light Lightness Actual, the Light Lightness Last, and the Light Lightness Default states.

Definition at line 911 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_XYL_DEFAULT_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_XYL_DEFAULT_STRUCT Struct Reference

Light xyL default state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | xyl_lightness
The perceived lightness of a light emitted by the element.
UINT16 | xyl_x
The 16-bit value representing the x coordinate of a CIE1931 color light.
UINT16 | xyl_y
The 16-bit value representing the y coordinate of a CIE1931 color light.

Detailed Description

Light xyL default state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states.

Definition at line 1218 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_XYL_RANGE_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_XYL_RANGE_STRUCT Struct Reference

Light xyL Range state determines the minimum and maximum values of the Light xyL x and syL y state of an element. More...

#include <MS_model_states.h>

Data Fields

UINT16 | xyl_x_range_min
The minimum value of a Light xyL x state of an element.
UINT16 | xyl_x_range_max
The maximum value of a Light xyL x state of an element.
UINT16 | xyl_y_range_min
The minimum value of a Light xyL y state of an element.
UINT16 | xyl_y_range_max
The maximum value of a Light xyL y state of an element.
UINT8 | status
Status - Used in the response path.

Detailed Description

Light xyL Range state determines the minimum and maximum values of the Light xyL x and syL y state of an element.

Definition at line 1234 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_XYL_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_XYL_STRUCT Struct Reference

Light xyL state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | xyl_lightness
The perceived lightness of a light emitted by the element.
UINT16 | target_xyl_lightness
Target perceived lightness - used in response path.
UINT16 | xyl_x
The 16-bit value representing the x coordinate of a CIE1931 color light.
UINT16 | target_xyl_x
Target x coordinate - used in response path.
UINT16 | xyl_y
The 16-bit value representing the y coordinate of a CIE1931 color light.
UINT16 | target_xyl_y
Target y coordinate - used in response path.
UINT8 | tid
TID - Used in request path.
UINT8 | transition_time
Transition Time - Used in request path. More...
UINT8 | delay
Delay - Used in request path.

Detailed Description

Light xyL state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states.

Definition at line 1164 of file MS_model_states.h.

Field Documentation

UINT8 MS_STATE_LIGHT_XYL_STRUCT::transition_time

Transition Time - Used in request path.

Used as remaining time in response path.

Definition at line 1191 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_LIGHT_XYL_TARGET_STRUCT Struct Reference

Data Fields
MS_STATE_LIGHT_XYL_TARGET_STRUCT Struct Reference

Light xyL target state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states. More...

#include <MS_model_states.h>

Data Fields

UINT16 | xyl_lightness
The perceived lightness of a light emitted by the element.
UINT16 | xyl_x
The 16-bit value representing the x coordinate of a CIE1931 color light.
UINT16 | xyl_y
The 16-bit value representing the y coordinate of a CIE1931 color light.

Detailed Description

Light xyL target state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states.

Definition at line 1202 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SCENE_NUMBER_STRUCT Struct Reference

Data Fields
MS_STATE_SCENE_NUMBER_STRUCT Struct Reference

The state to identify a scene. More...

#include <MS_model_states.h>

Data Fields

UINT16 number
The number to identify a scene.

Detailed Description

The state to identify a scene.

Definition at line 732 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SCENE_REGISTER_STATUS_STRUCT Struct Reference

Data Fields
MS_STATE_SCENE_REGISTER_STATUS_STRUCT Struct Reference

The current status of scene register. More...

#include <MS_model_states.h>

Data Fields

UCHAR | status_code
Status Code.
UINT16 | current_scene
Scene Number of a current scene. More...
UINT16 * | scenes
A list of scenes stored within an element.
UINT16 | scenes_count

Detailed Description

The current status of scene register.

Definition at line 756 of file MS_model_states.h.

Field Documentation

UINT16 MS_STATE_SCENE_REGISTER_STATUS_STRUCT::current_scene

Scene Number of a current scene.

Definition at line 762 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SCENE_STATUS_STRUCT Struct Reference

Data Fields
MS_STATE_SCENE_STATUS_STRUCT Struct Reference

The current status of a currently active scene. More...

#include <MS_model_states.h>

Data Fields

UCHAR | status_code
Status Code.
UINT16 | current_scene
Scene Number of a current scene. More...
UINT16 | target_scene
Scene Number of a target scene. More...
UINT8 | remaining_time

Detailed Description

The current status of a currently active scene.

Definition at line 739 of file MS_model_states.h.

Field Documentation

UINT16 MS_STATE_SCENE_STATUS_STRUCT::current_scene

Scene Number of a current scene.

Definition at line 745 of file MS_model_states.h.

UINT16 MS_STATE_SCENE_STATUS_STRUCT::target_scene

Scene Number of a target scene.

Definition at line 748 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT Struct Reference

Data Fields
MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT Struct Reference

The entry index of the Schedule Register state. More...

#include <MS_model_states.h>

Data Fields

UCHAR index
Index of the Schedule Register entry.

Detailed Description

The entry index of the Schedule Register state.

Definition at line 777 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SCHEDULER_ENTRY_STRUCT Struct Reference

Data Fields
MS_STATE_SCHEDULER_ENTRY_STRUCT Struct Reference

The entry of the Schedule Register state. More...

#include <MS_model_states.h>

Data Fields

UCHAR | index
Index of the Schedule Register entry.
UCHAR | year
Scheduled year for the action.
UINT16 | month
Scheduled month for the action.
UCHAR | day
Scheduled day of the month for the action.
UCHAR | hour
Scheduled hour for the action.
UCHAR | minute
Scheduled minute for the action.
UCHAR | second
Scheduled second for the action.
UCHAR | dayofweek
Schedule days of the week for the action.
UCHAR | action
Action to be performed at the scheduled time.
UCHAR | transition_time
Transition time for this action.
UINT16 | scene_number
Scene number to be used for some actions.

Detailed Description

The entry of the Schedule Register state.

Definition at line 784 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SCHEDULER_SCHEDULES_STRUCT Struct Reference

Data Fields
MS_STATE_SCHEDULER_SCHEDULES_STRUCT Struct Reference

The current Schedule Register state of an element. More...

#include <MS_model_states.h>

Data Fields

UINT16 schedules
Bit field indicating defined Actions in the Schedule Register.

Detailed Description

The current Schedule Register state of an element.

Definition at line 770 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SENSOR_CADENCE_STRUCT Struct Reference

Data Fields
MS_STATE_SENSOR_CADENCE_STRUCT Struct Reference

Sensor Cadence state controls the cadence of sensor reports. More...

#include <MS_model_states.h>

Data Fields

UINT16 | sensor_property_id
Property ID of a sensor.
UCHAR | fast_cadence_period_divisor
Divisor for the Publish Period.
UCHAR | status_trigger_type
Defines the unit and format of the Status Trigger Delta fields.
UCHAR * | status_trigger_delta_down
Delta down value that triggers a status message.
UINT16 | status_trigger_delta_down_len
UCHAR * | status_trigger_delta_up
Delta up value that triggers a status message.
UINT16 | status_trigger_delta_up_len
UCHAR | status_min_interval
Minimum interval between two consecutive Status messages.
UCHAR * | fast_cadence_low
Low value for the fast cadence range.
UINT16 | fast_cadence_low_len
UCHAR * | fast_cadence_high
High value for the fast cadence range.
UINT16 | fast_cadence_high_len
UINT8 | status
Status - used in response path.

Detailed Description

Sensor Cadence state controls the cadence of sensor reports.

Definition at line 555 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SENSOR_DATA_STRUCT Struct Reference

Data Fields
MS_STATE_SENSOR_DATA_STRUCT Struct Reference

The Sensor Data state is a sequence of one or more pairs of Sensor Property ID and Raw Value fields, with each Raw Value field size and representation defined by the characteristics referenced by the Sensor Property ID. More...

#include <MS_model_states.h>

Data Fields

UINT16 | property_id_1
ID of the 1st device property of the sensor.
UCHAR * | raw_value_1
Raw Value field with a size and representation defined by the 1st device property.
UINT16 | raw_value_1_len
UINT16 | property_id_2
ID of the 2nd device property of the sensor.
UCHAR * | raw_value_2
Raw Value field with a size and representation defined by the 2nd device property.
UINT16 | raw_value_2_len
UINT16 | property_id_n
ID of the nth device property of the sensor.
UCHAR * | raw_value_n
Raw Value field with a size and representation defined by the nth device property.
UINT16 | raw_value_n_len
UINT8 | status
Status - used in response path.

Detailed Description

The Sensor Data state is a sequence of one or more pairs of Sensor Property ID and Raw Value fields, with each Raw Value field size and representation defined by the characteristics referenced by the Sensor Property ID.

Definition at line 595 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SENSOR_DESCRIPTOR_STRUCT Struct Reference

Data Fields
MS_STATE_SENSOR_DESCRIPTOR_STRUCT Struct Reference

Sensor Descriptor state represents the attributes describing the sensor data. More...

#include <MS_model_states.h>

Data Fields

UINT16 | sensor_property_id
Sensor Property ID field is a 2-octet value referencing a device property that describes the meaning and the format of data reported by a sensor.
UINT16 | sensor_positive_tolerance
Sensor Positive Tolerance field is a 12-bit value representing the magnitude of a possible positive error associated with the measurements that the sensor is reporting.
UINT16 | sensor_negative_tolerance
Sensor Negative Tolerance field is a 12-bit value representing the magnitude of a possible negative error associated with the measurements that the sensor is reporting.
UCHAR | sensor_sampling_function
Sensor Sampling Function field specifies the averaging operation or type of sampling function applied to the measured value.
UCHAR | sensor_measurement_period
Sensor Measurement Period field specifies a uint8 value n that represents the averaging time span, accumulation time, or measurement period in seconds over which the measurement is taken.
UCHAR | sensor_update_interval
measurement reported by a sensor is internally refreshed at the frequency indicated in the Sensor Update Interval field
UINT8 | status
Status - used in response to indicate if other fields to be included.

Detailed Description

Sensor Descriptor state represents the attributes describing the sensor data.

Definition at line 475 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SENSOR_PROPERTY_ID_STRUCT Struct Reference

Data Fields
MS_STATE_SENSOR_PROPERTY_ID_STRUCT Struct Reference

Sensor Property ID field is a 2-octet value referencing a device property that describes the meaning and the format of data reported by a sensor. More...

#include <MS_model_states.h>

Data Fields

UINT16 property_id
Sensor Property ID field is a 2-octet value referencing a device property that describes the meaning and the format of data reported by a sensor.

Detailed Description

Sensor Property ID field is a 2-octet value referencing a device property that describes the meaning and the format of data reported by a sensor.

Definition at line 465 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SENSOR_SERIES_COLUMN_STRUCT Struct Reference

Data Fields
MS_STATE_SENSOR_SERIES_COLUMN_STRUCT Struct Reference

Values measured by sensors may be organized as arrays (and represented as series of columns, such as histograms. More...

#include <MS_model_states.h>

Data Fields

UINT16 | sensor_property_id
Property describing the data series of the sensor.
UCHAR * | sensor_raw_value_x
Raw value representing the left corner of a column on the X axis.
UINT16 | sensor_raw_value_x_len
UCHAR * | sensor_column_width
Raw value representing the width of the column.
UINT16 | sensor_column_width_len
UCHAR * | sensor_raw_value_y
Raw value representing the height of the column on the Y axis.
UINT16 | sensor_raw_value_y_len
UINT8 | status
Status - used in response path.

Detailed Description

Values measured by sensors may be organized as arrays (and represented as series of columns, such as histograms.

Definition at line 636 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SENSOR_SETTING_STRUCT Struct Reference

Data Fields
MS_STATE_SENSOR_SETTING_STRUCT Struct Reference

Sensor Setting state controls parameters of a sensor. More...

#include <MS_model_states.h>

Data Fields

UINT16 | sensor_property_id
Property ID of a sensor.
UINT16 | sensor_setting_property_id
Property ID of a setting within a sensor.
UCHAR | sensor_setting_access
Read/Write access rights for the setting.
UCHAR * | sensor_setting_raw
Raw value of a setting within a sensor.
UINT16 | sensor_setting_raw_len
UINT8 | status

Detailed Description

Sensor Setting state controls parameters of a sensor.

Definition at line 534 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_SENSOR_SETTINGS_STRUCT Struct Reference

Data Fields
MS_STATE_SENSOR_SETTINGS_STRUCT Struct Reference

Sensor Settings state controls parameters of a sensor. More...

#include <MS_model_states.h>

Data Fields

UINT16 | sensor_property_id
Property ID of a sensor.
UINT16 * | setting_property_ids
Property ID of a setting within a sensor.
UINT16 | setting_property_ids_count

Detailed Description

Sensor Settings state controls parameters of a sensor.

Definition at line 522 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_TIME_ROLE_STRUCT Struct Reference

Data Fields
MS_STATE_TIME_ROLE_STRUCT Struct Reference

The Time Role state of an element. More...

#include <MS_model_states.h>

Data Fields

UCHAR role
Time Role.

Detailed Description

The Time Role state of an element.

Definition at line 725 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_TIME_STRUCT Struct Reference

Data Fields
MS_STATE_TIME_STRUCT Struct Reference

Mesh defines times based on International Atomic Time (TAI). More...

#include <MS_model_states.h>

Data Fields

UCHAR | tai_seconds [5]
Current TAI time in seconds since the epoch. More...
UCHAR | subsecond
The sub-second time in units of 1/256s. More...
UCHAR | uncertainty
Estimated uncertainty in 10-millisecond steps. More...
UCHAR | time_authority
0 = No Time Authority. More...
UINT16 | tai_utc_delta
Current difference between TAI and UTC in seconds.
UCHAR | time_zone_offset
The local time zone offset in 15-minute increments.

Detailed Description

Mesh defines times based on International Atomic Time (TAI).

The base representation of times is the number of seconds after 00:00:00 TAI on 2000-01-01 (that is, 1999-12-31T23:59:28 UTC)

Definition at line 663 of file MS_model_states.h.

Field Documentation

UCHAR MS_STATE_TIME_STRUCT::tai_seconds[5]

Current TAI time in seconds since the epoch.

Definition at line 666 of file MS_model_states.h.

UCHAR MS_STATE_TIME_STRUCT::subsecond

The sub-second time in units of 1/256s.

Definition at line 669 of file MS_model_states.h.

UCHAR MS_STATE_TIME_STRUCT::uncertainty

Estimated uncertainty in 10-millisecond steps.

Definition at line 672 of file MS_model_states.h.

UCHAR MS_STATE_TIME_STRUCT::time_authority

0 = No Time Authority.

The element does not have a trusted OOB source of time, such as GPS or NTP. 1 = Time Authority. The element has a trusted OOB source of time, such as GPS or NTP or a battery-backed, properly initialized RTC.

Definition at line 680 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_TIME_TAI_UTC_DELTA_STRUCT Struct Reference

Data Fields
MS_STATE_TIME_TAI_UTC_DELTA_STRUCT Struct Reference

TAI-UTC Delta. More...

#include <MS_model_states.h>

Data Fields

UINT16 | tai_utc_delta_current
Current difference between TAI and UTC in seconds. More...
UINT16 | tai_utc_delta_new
Upcoming difference between TAI and UTC in seconds. More...
UCHAR | padding
Always 0b0. More...
UCHAR | tai_of_delta_change [5]
TAI Seconds time of the upcoming TAI-UTC Delta change.

Detailed Description

TAI-UTC Delta.

Definition at line 706 of file MS_model_states.h.

Field Documentation

UINT16 MS_STATE_TIME_TAI_UTC_DELTA_STRUCT::tai_utc_delta_current

Current difference between TAI and UTC in seconds.

Meaningful only in 'TAI-UTC Delta Status' response.

Definition at line 712 of file MS_model_states.h.

UINT16 MS_STATE_TIME_TAI_UTC_DELTA_STRUCT::tai_utc_delta_new

Upcoming difference between TAI and UTC in seconds.

Definition at line 715 of file MS_model_states.h.

UCHAR MS_STATE_TIME_TAI_UTC_DELTA_STRUCT::padding

Always 0b0.

Other values are Prohibited.

Definition at line 718 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_STATE_TIME_ZONE_STRUCT Struct Reference

Data Fields
MS_STATE_TIME_ZONE_STRUCT Struct Reference

Time Zone. More...

#include <MS_model_states.h>

Data Fields

UCHAR | time_zone_offset_current
Current local time zone offset. More...
UCHAR | time_zone_offset_new
Upcoming local time zone offset. More...
UCHAR | tai_of_zone_change [5]
Absolute TAI time when the Time Zone Offset will change from Current to New. More...

Detailed Description

Time Zone.

Definition at line 690 of file MS_model_states.h.

Field Documentation

UCHAR MS_STATE_TIME_ZONE_STRUCT::time_zone_offset_current

Current local time zone offset.

Meaningful only in 'Time Zone Status' response.

Definition at line 696 of file MS_model_states.h.

UCHAR MS_STATE_TIME_ZONE_STRUCT::time_zone_offset_new

Upcoming local time zone offset.

Definition at line 699 of file MS_model_states.h.

UCHAR MS_STATE_TIME_ZONE_STRUCT::tai_of_zone_change[5]

Absolute TAI time when the Time Zone Offset will change from Current to New.

Definition at line 702 of file MS_model_states.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_model_states.h


EtherMind Mesh SDK (beta): MS_VERSION_NUMBER Struct Reference

Data Fields
MS_VERSION_NUMBER Struct Reference

Version Number Structure. More...

#include <MS_version.h>

Data Fields

UCHAR | major
Major Version Number.
UCHAR | minor
Minor Version Number.
UCHAR | subminor
Sub-minor Version Number.

Detailed Description

Version Number Structure.

Definition at line 69 of file MS_version.h.

The documentation for this struct was generated from the following file:
  • mesh/export/include/MS_version.h


EtherMind Mesh SDK (beta): Data Structure Index

Data Structure Index
A | B | M | P
A
MS_ACCESS_MODEL_REQ_MSG_RAW MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT MS_SENSOR_COLUMN_STATUS_STRUCT MS_STATE_LIGHT_XYL_DEFAULT_STRUCT
MS_ACCESS_MODEL_REQ_MSG_T MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT MS_SENSOR_DESCRIPTOR_GET_STRUCT MS_STATE_LIGHT_XYL_RANGE_STRUCT
ACCESS_CONFIG_APPKEY_ADD_PARAM MS_ACCESS_MODEL_STATE_PARAMS MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT MS_SENSOR_DESCRIPTOR_STATUS_STRUCT MS_STATE_LIGHT_XYL_STRUCT
ACCESS_CONFIG_APPKEY_DELETE_PARAM MS_ACCESS_PUBLISH_INFO MS_LIGHT_HSL_DEFAULT_SET_STRUCT MS_SENSOR_GET_STRUCT MS_STATE_LIGHT_XYL_TARGET_STRUCT
ACCESS_CONFIG_APPKEY_GET_PARAM MS_ACCESS_STATE_TRANSITION_TYPE MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT MS_SENSOR_SERIES_GET_STRUCT MS_STATE_SCENE_NUMBER_STRUCT
ACCESS_CONFIG_APPKEY_UPDATE_PARAM MS_BUFFER MS_LIGHT_HSL_HUE_SET_STRUCT MS_SENSOR_SERIES_STATUS_STRUCT MS_STATE_SCENE_REGISTER_STATUS_STRUCT
ACCESS_CONFIG_BEACON_SET_PARAM MS_CONFIG MS_LIGHT_HSL_HUE_STATUS_STRUCT MS_SENSOR_SETTING_GET_STRUCT MS_STATE_SCENE_STATUS_STRUCT
ACCESS_CONFIG_COMPDATA_GET_PARAM MS_EXT_STATUS_STRUCT MS_LIGHT_HSL_RANGE_SET_STRUCT MS_SENSOR_SETTING_SET_STRUCT MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT
ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM MS_EXT_TID_AND_TRANSITION_STRUCT MS_LIGHT_HSL_RANGE_STATUS_STRUCT MS_SENSOR_SETTING_STATUS_STRUCT MS_STATE_SCHEDULER_ENTRY_STRUCT
ACCESS_CONFIG_FRIEND_SET_PARAM MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT MS_LIGHT_HSL_SATURATION_SET_STRUCT MS_SENSOR_SETTINGS_GET_STRUCT MS_STATE_SCHEDULER_SCHEDULES_STRUCT
ACCESS_CONFIG_GATT_PROXY_SET_PARAM MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT MS_LIGHT_HSL_SATURATION_STATUS_STRUCT MS_SENSOR_SETTINGS_STATUS_STRUCT MS_STATE_SENSOR_CADENCE_STRUCT
ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT MS_LIGHT_HSL_SET_STRUCT MS_SENSOR_STATUS_STRUCT MS_STATE_SENSOR_DATA_STRUCT
ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT MS_LIGHT_HSL_STATUS_STRUCT MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT MS_STATE_SENSOR_DESCRIPTOR_STRUCT
ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM MS_GENERIC_BATTERY_STATUS_STRUCT MS_LIGHT_HSL_TARGET_STATUS_STRUCT MS_STATE_GENERIC_BATTERY_STRUCT MS_STATE_SENSOR_PROPERTY_ID_STRUCT
ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT MS_STATE_GENERIC_LEVEL_STRUCT MS_STATE_SENSOR_SETTING_STRUCT
ACCESS_CONFIG_MODEL_APP_BIND_PARAM MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT MS_LIGHT_LC_MODE_STRUCT MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT MS_STATE_SENSOR_SETTINGS_STRUCT
ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM MS_GENERIC_DELTA_SET_STRUCT MS_LIGHT_LC_OM_STRUCT MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT MS_STATE_TIME_ROLE_STRUCT
ACCESS_CONFIG_MODELPUB_GET_PARAM MS_GENERIC_LEVEL_SET_STRUCT MS_LIGHT_LC_PROPERTY_GET_STRUCT MS_STATE_GENERIC_LOCATION_STRUCT MS_STATE_TIME_STRUCT
ACCESS_CONFIG_MODELPUB_SET_PARAM MS_GENERIC_LEVEL_STATUS_STRUCT MS_LIGHT_LC_PROPERTY_SET_STRUCT MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT MS_STATE_TIME_TAI_UTC_DELTA_STRUCT
ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM MS_GENERIC_LOCATION_GLOBAL_STRUCT MS_LIGHT_LC_PROPERTY_STATUS_STRUCT MS_STATE_GENERIC_ONOFF_STRUCT MS_STATE_TIME_ZONE_STRUCT
ACCESS_CONFIG_MODELSUB_ADD_PARAM MS_GENERIC_LOCATION_LOCAL_STRUCT MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT MS_STATE_GENERIC_ONPOWERUP_STRUCT MS_TAI_UTC_DELTA_SET_STRUCT
ACCESS_CONFIG_MODELSUB_DEL_PARAM MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT MS_STATE_GENERIC_POWER_ACTUAL_STRUCT MS_TAI_UTC_DELTA_STATUS_STRUCT
ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT MS_LIGHT_LIGHTNESS_LAST_OR_DEFAULT_STATUS_STRUCT MS_STATE_GENERIC_POWER_DEFAULT_STRUCT MS_TIME_ROLE_STRUCT
ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT MS_STATE_GENERIC_POWER_LAST_STRUCT MS_TIME_STRUCT
ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT MS_STATE_GENERIC_POWER_LEVEL_STRUCT MS_TIME_ZONE_SET_STRUCT
ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM MS_GENERIC_MOVE_SET_STRUCT MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT MS_STATE_GENERIC_POWER_RANGE_STRUCT MS_TIME_ZONE_STATUS_STRUCT
ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM MS_GENERIC_ONOFF_SET_STRUCT MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT MS_STATE_GENERIC_PROPERTY_ID_STRUCT MS_TRN_FRIEND_ENTRY
ACCESS_CONFIG_NETKEY_ADD_PARAM MS_GENERIC_ONOFF_STATUS_STRUCT MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT MS_STATE_GENERIC_PROPERTY_IDS_STRUCT MS_TRN_FRND_CLEAR_CNF_PARAM
ACCESS_CONFIG_NETKEY_DELETE_PARAM MS_GENERIC_ONPOWERUP_STRUCT MS_LIGHT_LIGHTNESS_SET_STRUCT MS_STATE_GENERIC_PROPERTY_STRUCT MS_TRN_FRND_CLEAR_PARAM
ACCESS_CONFIG_NETKEY_UPDATE_PARAM MS_GENERIC_POWER_DEFAULT_SET_STRUCT MS_LIGHT_LIGHTNESS_STATUS_STRUCT MS_STATE_GENERIC_USER_PROPERTY_STRUCT MS_TRN_FRND_MANAGE_PARAM
ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT MS_LIGHT_XYL_DEFAULT_SET_STRUCT MS_STATE_LIGHT_CTL_DEFAULT_STRUCT MS_TRN_FRND_OFFER_PARAM
ACCESS_CONFIG_NODEID_GET_PARAM MS_GENERIC_POWER_LAST_STATUS_STRUCT MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT MS_STATE_LIGHT_CTL_STRUCT MS_TRN_FRND_POLL_PARAM
ACCESS_CONFIG_NODEID_SET_PARAM MS_GENERIC_POWER_LEVEL_SET_STRUCT MS_LIGHT_XYL_RANGE_SET_STRUCT MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT MS_TRN_FRND_REQ_PARAM
ACCESS_CONFIG_RELAY_SET_PARAM MS_GENERIC_POWER_LEVEL_STATUS_STRUCT MS_LIGHT_XYL_RANGE_STATUS_STRUCT MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM
ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM MS_GENERIC_POWER_RANGE_SET_STRUCT MS_LIGHT_XYL_SET_STRUCT MS_STATE_LIGHT_HSL_DEFAULT_STRUCT MS_TRN_FRND_UPDATE_PARAM
ACCESS_CONFIG_SIGMODELSUB_GET_PARAM MS_GENERIC_POWER_RANGE_STATUS_STRUCT MS_LIGHT_XYL_STATUS_STRUCT MS_STATE_LIGHT_HSL_HUE_STRUCT MS_TRN_FRNDSHIP_INFO
ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT MS_LIGHT_XYL_TARGET_STATUS_STRUCT MS_STATE_LIGHT_HSL_RANGE_STRUCT MS_TRN_HEARTBEAT_PARAM
ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM MS_GENERIC_USER_PROPERTY_GET_STRUCT MS_NET_HEADER MS_STATE_LIGHT_HSL_SATURATION_STRUCT MS_TRN_HEARTBEAT_PUBLICATION_INFO
B
MS_GENERIC_USER_PROPERTY_SET_STRUCT MS_PROV_DEV_ENTRY MS_STATE_LIGHT_HSL_STRUCT MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
MS_GENERIC_USER_PROPERTY_STATUS_STRUCT MS_SCENE_RECALL_STRUCT MS_STATE_LIGHT_HSL_TARGET_STRUCT MS_VERSION_NUMBER
BRR_BEACON_INFO MS_HEALTH_ATTENTION_STRUCT MS_SCENE_REGISTER_STATUS_STRUCT MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT
P
BRR_BEARER_CH_INFO MS_HEALTH_FAULT_GET_CLEAR_STRUCT MS_SCENE_STATUS_STRUCT MS_STATE_LIGHT_LC_MODE_STRUCT
BRR_BEARER_INFO MS_HEALTH_FAULT_TEST_STRUCT MS_SCENE_STRUCT MS_STATE_LIGHT_LC_OM_STRUCT PROV_CAPABILITIES_S
M
MS_HEALTH_PERIOD_STRUCT MS_SCHEDULER_ACTION_GET_STRUCT MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT PROV_DATA_S
MS_HEALTH_SERVER_SELF_TEST MS_SCHEDULER_ACTION_SET_STRUCT MS_STATE_LIGHT_LC_PROPERTY_STRUCT PROV_DEVICE_S
MS_ACCESS_ADDRESS MS_HEALTH_STATUS_STRUCT MS_SCHEDULER_ACTION_STATUS_STRUCT MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT PROV_METHOD_S
MS_ACCESS_ELEMENT_DESC MS_LIGHT_CTL_DEFAULT_SET_STRUCT MS_SCHEDULER_STATUS_STRUCT MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT PROV_OOB_TYPE_S
MS_ACCESS_MODEL MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT MS_SENSOR_CADENCE_GET_STRUCT MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT
MS_ACCESS_MODEL_EXT_PARAMS MS_LIGHT_CTL_SET_STRUCT MS_SENSOR_CADENCE_SET_STRUCT MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT
MS_ACCESS_MODEL_ID MS_LIGHT_CTL_STATUS_STRUCT MS_SENSOR_CADENCE_STATUS_STRUCT MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT
MS_ACCESS_MODEL_REQ_MSG_CONTEXT MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT MS_SENSOR_COLUMN_GET_STRUCT MS_STATE_LIGHT_LIGHTNESS_STRUCT
A | B | M | P


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • access : MS_STATE_GENERIC_PROPERTY_STRUCT
  • action : BRR_BEACON_INFO , PROV_OOB_TYPE_S , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • addr : MS_ACCESS_PUBLISH_INFO , MS_TRN_FRIEND_ENTRY , MS_ACCESS_ADDRESS
  • addr_list : MS_TRN_FRND_MANAGE_PARAM
  • address : ACCESS_CONFIG_MODELSUB_ADD_PARAM , ACCESS_CONFIG_MODELSUB_DEL_PARAM , ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM
  • admin_property_id : MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT , MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT
  • admin_property_ids : MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT
  • admin_property_ids_count : MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT
  • admin_property_value : MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
  • admin_property_value_len : MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
  • admin_user_access : MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
  • algorithm : PROV_METHOD_S
  • appkey : ACCESS_CONFIG_APPKEY_UPDATE_PARAM , ACCESS_CONFIG_APPKEY_ADD_PARAM
  • appkey_handle : MS_ACCESS_MODEL_REQ_MSG_CONTEXT
  • appkey_index : MS_ACCESS_PUBLISH_INFO , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODEL_APP_BIND_PARAM , ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM
  • attention : MS_HEALTH_ATTENTION_STRUCT
  • auth : PROV_METHOD_S


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- b -

  • battery_level : MS_GENERIC_BATTERY_STATUS_STRUCT
  • bcon_data : BRR_BEACON_INFO
  • bcon_datalen : BRR_BEACON_INFO
  • beacon : ACCESS_CONFIG_BEACON_SET_PARAM
  • bearer_recv : BRR_BEARER_INFO
  • bearer_send : BRR_BEARER_INFO
  • bearer_sleep : BRR_BEARER_INFO
  • bearer_wakeup : BRR_BEARER_INFO
  • binfo : BRR_BEARER_INFO


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- c -

  • cb : MS_ACCESS_MODEL
  • client_property_id : MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT
  • client_property_ids : MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT
  • client_property_ids_count : MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT
  • column_width : MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • column_width_len : MS_SENSOR_SERIES_STATUS_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT
  • company_id : MS_HEALTH_STATUS_STRUCT , MS_HEALTH_FAULT_GET_CLEAR_STRUCT , MS_HEALTH_FAULT_TEST_STRUCT
  • config_MS_DEFAULT_COMPANY_ID : MS_CONFIG
  • config_MS_DEFAULT_PID : MS_CONFIG
  • config_MS_DEFAULT_VID : MS_CONFIG
  • config_MS_REPLAY_CACHE_SIZE : MS_CONFIG
  • count_log : MS_TRN_HEARTBEAT_PUBLICATION_INFO , MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • countlog : ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
  • crden_flag : MS_ACCESS_PUBLISH_INFO
  • credential_flag : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • criteria : MS_TRN_FRND_REQ_PARAM
  • ctl : MS_NET_HEADER
  • ctl_delta_uv : MS_STATE_LIGHT_CTL_DEFAULT_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • ctl_lightness : MS_STATE_LIGHT_CTL_DEFAULT_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT
  • ctl_temperature : MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT , MS_STATE_LIGHT_CTL_DEFAULT_STRUCT
  • ctl_temperature_range_max : MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT
  • ctl_temperature_range_min : MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT
  • current_scene : MS_SCENE_STATUS_STRUCT , MS_STATE_SCENE_STATUS_STRUCT , MS_SCENE_REGISTER_STATUS_STRUCT , MS_STATE_SCENE_REGISTER_STATUS_STRUCT


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- d -

  • daddr : MS_ACCESS_MODEL_REQ_MSG_CONTEXT , MS_NET_HEADER , MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO , MS_TRN_HEARTBEAT_PUBLICATION_INFO
  • data_len : MS_ACCESS_MODEL_REQ_MSG_RAW
  • data_param : MS_ACCESS_MODEL_REQ_MSG_RAW
  • day : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT
  • day_of_week : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • dayofweek : MS_STATE_SCHEDULER_ENTRY_STRUCT
  • default_transition_number_of_steps : MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • default_transition_step_resolution : MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • delay : MS_GENERIC_DELTA_SET_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT , MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_SCENE_RECALL_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_STATE_LIGHT_HSL_STRUCT
  • delta_level : MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_STATE_GENERIC_LEVEL_STRUCT
  • delta_uv : MS_LIGHT_CTL_DEFAULT_SET_STRUCT , MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT
  • descriptor : MS_SENSOR_DESCRIPTOR_STATUS_STRUCT
  • destination : ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- e -

  • elem_handle : MS_ACCESS_MODEL
  • element_address : ACCESS_CONFIG_MODELPUB_GET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM , ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM , ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM , ACCESS_CONFIG_MODEL_APP_BIND_PARAM , ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM , ACCESS_CONFIG_SIGMODELSUB_GET_PARAM , ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM , ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM , ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_DEL_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM , ACCESS_CONFIG_MODELSUB_ADD_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM
  • ext : MS_ACCESS_MODEL_EXT_PARAMS
  • ext_type : MS_ACCESS_MODEL_EXT_PARAMS


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- f -

  • fast_cadence_high : MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fast_cadence_high_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fast_cadence_low : MS_SENSOR_CADENCE_STATUS_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT
  • fast_cadence_low_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fast_cadence_period_divisor : MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fastperioddivisor : MS_HEALTH_PERIOD_STRUCT
  • faultarray : MS_HEALTH_STATUS_STRUCT
  • faultarray_len : MS_HEALTH_STATUS_STRUCT
  • features : MS_TRN_HEARTBEAT_PUBLICATION_INFO , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM , MS_TRN_HEARTBEAT_PARAM
  • flags : PROV_DATA_S , MS_GENERIC_BATTERY_STATUS_STRUCT , MS_TRN_FRND_UPDATE_PARAM
  • floor_number : MS_GENERIC_LOCATION_LOCAL_STRUCT , MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT
  • friend : ACCESS_CONFIG_FRIEND_SET_PARAM
  • frnd_counter : MS_TRN_FRND_OFFER_PARAM
  • fsn : MS_TRN_FRND_POLL_PARAM , MS_TRN_FRIEND_ENTRY


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- g -

  • generic_battery_flags : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_battery_level : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_battery_time_to_charge : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_battery_time_to_discharge : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_power_actual : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • generic_power_default : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • generic_power_last : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • generic_power_range : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • global_altitude : MS_GENERIC_LOCATION_GLOBAL_STRUCT , MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT
  • global_latitude : MS_GENERIC_LOCATION_GLOBAL_STRUCT , MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT
  • global_location : MS_STATE_GENERIC_LOCATION_STRUCT
  • global_longitude : MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT , MS_GENERIC_LOCATION_GLOBAL_STRUCT


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- h -

  • handle : MS_ACCESS_MODEL_REQ_MSG_CONTEXT
  • hour : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT
  • hsl_hue : MS_STATE_LIGHT_HSL_TARGET_STRUCT , MS_STATE_LIGHT_HSL_DEFAULT_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_STATE_LIGHT_HSL_HUE_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_STATE_LIGHT_HSL_STRUCT
  • hsl_hue_target : MS_LIGHT_HSL_TARGET_STATUS_STRUCT
  • hsl_lightness : MS_STATE_LIGHT_HSL_DEFAULT_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_STATE_LIGHT_HSL_STRUCT , MS_STATE_LIGHT_HSL_TARGET_STRUCT
  • hsl_lightness_target : MS_LIGHT_HSL_TARGET_STATUS_STRUCT
  • hsl_saturation : MS_STATE_LIGHT_HSL_SATURATION_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_STATE_LIGHT_HSL_STRUCT , MS_STATE_LIGHT_HSL_TARGET_STRUCT , MS_STATE_LIGHT_HSL_DEFAULT_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT
  • hsl_saturation_target : MS_LIGHT_HSL_TARGET_STATUS_STRUCT
  • hue : MS_LIGHT_HSL_DEFAULT_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT
  • hue_range_max : MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT , MS_LIGHT_HSL_RANGE_SET_STRUCT
  • hue_range_min : MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT , MS_LIGHT_HSL_RANGE_SET_STRUCT


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- i -

  • id : MS_ACCESS_MODEL_ID
  • identity : ACCESS_CONFIG_NODEID_SET_PARAM
  • index : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_GET_STRUCT , MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • init_ttl : MS_TRN_HEARTBEAT_PARAM
  • ioob : PROV_CAPABILITIES_S
  • ivi : MS_TRN_FRND_UPDATE_PARAM , MS_NET_HEADER
  • ivindex : PROV_DATA_S


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- k -

  • keyid : PROV_DATA_S


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- l -

  • label : MS_ACCESS_ADDRESS , ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM
  • last_onoff : MS_STATE_GENERIC_ONOFF_STRUCT
  • level : MS_GENERIC_LEVEL_SET_STRUCT , MS_STATE_GENERIC_LEVEL_STRUCT
  • light_lc_property_id : MS_LIGHT_LC_PROPERTY_GET_STRUCT , MS_LIGHT_LC_PROPERTY_SET_STRUCT , MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
  • light_lc_property_value : MS_LIGHT_LC_PROPERTY_SET_STRUCT , MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
  • light_lc_property_value_len : MS_LIGHT_LC_PROPERTY_SET_STRUCT , MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
  • light_lightness_actual : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_default : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_last : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_linear : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_range : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_onoff : MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT
  • lightness : MS_LIGHT_CTL_DEFAULT_SET_STRUCT , MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT , MS_LIGHT_HSL_DEFAULT_SET_STRUCT , MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT , MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT , MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT , MS_LIGHT_XYL_DEFAULT_SET_STRUCT
  • lightness_actual : MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT
  • lightness_default : MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT
  • lightness_last : MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT
  • lightness_linear : MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT
  • lightness_range_max : MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT
  • lightness_range_min : MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT
  • lightness_target : MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT
  • loc : MS_ACCESS_ELEMENT_DESC
  • local_altitude : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT
  • local_east : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT
  • local_location : MS_STATE_GENERIC_LOCATION_STRUCT
  • local_north : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT
  • lpn_addr : MS_TRN_FRND_CLEAR_PARAM , MS_TRN_FRND_CLEAR_CNF_PARAM
  • lpn_address : ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM
  • lpn_counter : MS_TRN_FRND_CLEAR_CNF_PARAM , MS_TRN_FRND_REQ_PARAM , MS_TRN_FRND_CLEAR_PARAM


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- m -

  • major : MS_VERSION_NUMBER
  • manufacturer_property_id : MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT , MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT , MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT
  • manufacturer_property_ids : MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT
  • manufacturer_property_ids_count : MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT
  • manufacturer_property_value : MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
  • manufacturer_property_value_len : MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
  • manufacturer_user_access : MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT , MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
  • marshalled_sensor_data : MS_SENSOR_STATUS_STRUCT
  • marshalled_sensor_data_len : MS_SENSOR_STATUS_STRUCT
  • max_hops : MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • md : MS_TRN_FRND_UPDATE_PARAM
  • min_hops : MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • minor : MS_VERSION_NUMBER
  • minute : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • mode : MS_LIGHT_LC_MODE_STRUCT
  • model : ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM , ACCESS_CONFIG_MODELPUB_GET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_ADD_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM , ACCESS_CONFIG_MODEL_APP_BIND_PARAM , ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_DEL_PARAM , ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM
  • model_id : ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM , ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM , MS_ACCESS_MODEL , ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM , ACCESS_CONFIG_SIGMODELSUB_GET_PARAM
  • month : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT
  • move_level : MS_STATE_GENERIC_LEVEL_STRUCT
  • mtu : BRR_BEARER_CH_INFO


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- n -

  • net_tx_count : ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
  • net_tx_interval_steps : ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
  • netkey : ACCESS_CONFIG_NETKEY_UPDATE_PARAM , PROV_DATA_S , ACCESS_CONFIG_NETKEY_ADD_PARAM
  • netkey_index : ACCESS_CONFIG_NETKEY_DELETE_PARAM , ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM , ACCESS_CONFIG_APPKEY_ADD_PARAM , MS_TRN_HEARTBEAT_PUBLICATION_INFO , ACCESS_CONFIG_APPKEY_UPDATE_PARAM , ACCESS_CONFIG_APPKEY_DELETE_PARAM , ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM , ACCESS_CONFIG_NODEID_SET_PARAM , ACCESS_CONFIG_NODEID_GET_PARAM , ACCESS_CONFIG_NETKEY_ADD_PARAM , ACCESS_CONFIG_APPKEY_GET_PARAM , ACCESS_CONFIG_NETKEY_UPDATE_PARAM
  • nid : MS_NET_HEADER
  • num_addr : MS_TRN_FRND_MANAGE_PARAM
  • num_elem : MS_TRN_FRND_REQ_PARAM
  • num_elements : PROV_CAPABILITIES_S , MS_PROV_DEV_ENTRY , MS_TRN_FRIEND_ENTRY
  • num_opcodes : MS_ACCESS_MODEL
  • number : MS_STATE_SCENE_NUMBER_STRUCT


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- o -

  • onoff : MS_GENERIC_ONOFF_SET_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT
  • onpowerup : MS_STATE_GENERIC_ONPOWERUP_STRUCT , MS_GENERIC_ONPOWERUP_STRUCT
  • oob : PROV_DEVICE_S , PROV_METHOD_S
  • ooob : PROV_CAPABILITIES_S
  • opcode : MS_ACCESS_MODEL_REQ_MSG_RAW , MS_TRN_FRND_MANAGE_PARAM
  • opcodes : MS_ACCESS_MODEL
  • optional_fields_present : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_LIGHT_HSL_SATURATION_STATUS_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT , MS_LIGHT_HSL_HUE_STATUS_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_LIGHT_HSL_TARGET_STATUS_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_GENERIC_POWER_LEVEL_STATUS_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_GENERIC_ONOFF_STATUS_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_GENERIC_LEVEL_STATUS_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_SENSOR_SERIES_GET_STRUCT , MS_SENSOR_STATUS_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT , MS_SENSOR_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT , MS_SENSOR_DESCRIPTOR_GET_STRUCT , MS_SENSOR_DESCRIPTOR_STATUS_STRUCT , MS_SCENE_RECALL_STRUCT


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- p -

  • padding : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_SET_STRUCT
  • padding_1 : MS_TAI_UTC_DELTA_STATUS_STRUCT
  • padding_2 : MS_TAI_UTC_DELTA_STATUS_STRUCT
  • page : ACCESS_CONFIG_COMPDATA_GET_PARAM
  • period : MS_ACCESS_PUBLISH_INFO
  • period_log : MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO , MS_TRN_HEARTBEAT_PUBLICATION_INFO
  • periodlog : ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM , ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
  • poll_to : MS_TRN_FRND_REQ_PARAM
  • power : MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_GENERIC_POWER_LAST_STATUS_STRUCT , MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT , MS_GENERIC_POWER_DEFAULT_SET_STRUCT
  • power_actual : MS_STATE_GENERIC_POWER_ACTUAL_STRUCT
  • power_default : MS_STATE_GENERIC_POWER_DEFAULT_STRUCT
  • power_last : MS_STATE_GENERIC_POWER_LAST_STRUCT
  • power_range_max : MS_STATE_GENERIC_POWER_RANGE_STRUCT
  • power_range_min : MS_STATE_GENERIC_POWER_RANGE_STRUCT
  • power_target : MS_STATE_GENERIC_POWER_ACTUAL_STRUCT
  • present_ctl_delta_uv : MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT
  • present_ctl_lightness : MS_LIGHT_CTL_STATUS_STRUCT
  • present_ctl_temperature : MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT
  • present_hue : MS_LIGHT_HSL_HUE_STATUS_STRUCT
  • present_level : MS_GENERIC_LEVEL_STATUS_STRUCT
  • present_light_onoff : MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT
  • present_lightness : MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT
  • present_mode : MS_STATE_LIGHT_LC_MODE_STRUCT , MS_STATE_LIGHT_LC_OM_STRUCT
  • present_onoff : MS_GENERIC_ONOFF_STATUS_STRUCT
  • present_power : MS_GENERIC_POWER_LEVEL_STATUS_STRUCT
  • present_saturation : MS_LIGHT_HSL_SATURATION_STATUS_STRUCT
  • prev_addr : MS_TRN_FRND_REQ_PARAM
  • prev_faddr : MS_TRN_FRIEND_ENTRY
  • property_id : MS_SENSOR_DESCRIPTOR_GET_STRUCT , MS_STATE_GENERIC_PROPERTY_ID_STRUCT , MS_STATE_GENERIC_PROPERTY_STRUCT , MS_STATE_GENERIC_USER_PROPERTY_STRUCT , MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT , MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT , MS_STATE_SENSOR_PROPERTY_ID_STRUCT , MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT , MS_STATE_LIGHT_LC_PROPERTY_STRUCT , MS_SENSOR_CADENCE_GET_STRUCT , MS_SENSOR_GET_STRUCT , MS_SENSOR_COLUMN_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT , MS_SENSOR_SERIES_GET_STRUCT
  • property_id_1 : MS_STATE_SENSOR_DATA_STRUCT
  • property_id_2 : MS_STATE_SENSOR_DATA_STRUCT
  • property_id_n : MS_STATE_SENSOR_DATA_STRUCT
  • property_ids : MS_STATE_GENERIC_PROPERTY_IDS_STRUCT
  • property_type : MS_STATE_GENERIC_PROPERTY_STRUCT
  • property_value : MS_STATE_GENERIC_USER_PROPERTY_STRUCT , MS_STATE_GENERIC_PROPERTY_STRUCT , MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT , MS_STATE_LIGHT_LC_PROPERTY_STRUCT , MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT
  • proxy : ACCESS_CONFIG_GATT_PROXY_SET_PARAM
  • pubkey : PROV_METHOD_S
  • publish_address : ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM
  • publish_period : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • publish_rtx_count : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • publish_rtx_interval_steps : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • publish_ttl : ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- q -

  • queue_size : MS_TRN_FRND_OFFER_PARAM


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- r -

  • range_max : MS_GENERIC_POWER_RANGE_STATUS_STRUCT , MS_GENERIC_POWER_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT
  • range_min : MS_GENERIC_POWER_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT , MS_GENERIC_POWER_RANGE_STATUS_STRUCT
  • range_status : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • raw_value_1 : MS_STATE_SENSOR_DATA_STRUCT
  • raw_value_2 : MS_STATE_SENSOR_DATA_STRUCT
  • raw_value_n : MS_STATE_SENSOR_DATA_STRUCT
  • raw_value_x : MS_SENSOR_COLUMN_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • raw_value_x1 : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x1_len : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x2 : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x2_len : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x_len : MS_SENSOR_COLUMN_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • raw_value_y : MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • raw_value_y_len : MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • relay : ACCESS_CONFIG_RELAY_SET_PARAM
  • relay_rtx_count : ACCESS_CONFIG_RELAY_SET_PARAM
  • relay_rtx_interval_steps : ACCESS_CONFIG_RELAY_SET_PARAM
  • remaining_time : MS_GENERIC_ONOFF_STATUS_STRUCT , MS_GENERIC_LEVEL_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_HSL_SATURATION_STATUS_STRUCT , MS_LIGHT_HSL_HUE_STATUS_STRUCT , MS_GENERIC_POWER_LEVEL_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_LIGHT_HSL_TARGET_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT , MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_LIGHT_XYL_TARGET_STATUS_STRUCT
  • remote : MS_ACCESS_PUBLISH_INFO
  • role : BRR_BEARER_CH_INFO , MS_STATE_TIME_ROLE_STRUCT
  • rssi : MS_TRN_FRND_OFFER_PARAM
  • rtx_count : MS_ACCESS_PUBLISH_INFO
  • rtx_interval_steps : MS_ACCESS_PUBLISH_INFO
  • rx_delay : MS_TRN_FRND_REQ_PARAM
  • rx_window : MS_TRN_FRND_OFFER_PARAM


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- s -

  • saddr : MS_ACCESS_MODEL_REQ_MSG_CONTEXT , MS_NET_HEADER , MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • saturation : MS_LIGHT_HSL_DEFAULT_SET_STRUCT , MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT
  • saturation_range_max : MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT , MS_LIGHT_HSL_RANGE_SET_STRUCT
  • saturation_range_min : MS_LIGHT_HSL_RANGE_SET_STRUCT , MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT
  • scene_number : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCENE_RECALL_STRUCT , MS_SCENE_STRUCT
  • scenes : MS_STATE_SCENE_REGISTER_STATUS_STRUCT , MS_SCENE_REGISTER_STATUS_STRUCT
  • scenes_len : MS_SCENE_REGISTER_STATUS_STRUCT
  • schedules : MS_STATE_SCHEDULER_SCHEDULES_STRUCT , MS_SCHEDULER_STATUS_STRUCT
  • second : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • self_test_fn : MS_HEALTH_SERVER_SELF_TEST
  • sensor_column_width : MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
  • sensor_measurement_period : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_negative_tolerance : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_positive_tolerance : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_property_id : MS_STATE_SENSOR_SETTINGS_STRUCT , MS_STATE_SENSOR_SETTING_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT , MS_STATE_SENSOR_SERIES_COLUMN_STRUCT , MS_SENSOR_SETTINGS_GET_STRUCT , MS_SENSOR_SETTINGS_STATUS_STRUCT , MS_SENSOR_SETTING_GET_STRUCT , MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT , MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_raw_value_x : MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
  • sensor_raw_value_y : MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
  • sensor_sampling_function : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_setting_access : MS_STATE_SENSOR_SETTING_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_setting_property_id : MS_STATE_SENSOR_SETTING_STRUCT , MS_SENSOR_SETTING_GET_STRUCT , MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_setting_property_ids : MS_SENSOR_SETTINGS_STATUS_STRUCT
  • sensor_setting_property_ids_count : MS_SENSOR_SETTINGS_STATUS_STRUCT
  • sensor_setting_raw : MS_STATE_SENSOR_SETTING_STRUCT , MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_setting_raw_len : MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_update_interval : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • seq_num : MS_NET_HEADER
  • setting_property_ids : MS_STATE_SENSOR_SETTINGS_STRUCT
  • size : PROV_OOB_TYPE_S
  • source : ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
  • state : MS_ACCESS_MODEL_STATE_PARAMS
  • state_type : MS_ACCESS_MODEL_STATE_PARAMS
  • status : MS_GENERIC_POWER_RANGE_STATUS_STRUCT , MS_STATE_GENERIC_POWER_RANGE_STRUCT , MS_STATE_SENSOR_DESCRIPTOR_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT , MS_STATE_SENSOR_DATA_STRUCT , MS_STATE_SENSOR_SERIES_COLUMN_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT
  • status_code : MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT , MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_SCENE_REGISTER_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT , MS_STATE_SCENE_STATUS_STRUCT , MS_STATE_SCENE_REGISTER_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT
  • status_min_interval : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT
  • status_trigger_delta_down : MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • status_trigger_delta_down_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • status_trigger_delta_up : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT
  • status_trigger_delta_up_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • status_trigger_type : MS_SENSOR_CADENCE_STATUS_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT
  • sublist_size : MS_TRN_FRND_OFFER_PARAM
  • subminor : MS_VERSION_NUMBER
  • subnet_handle : MS_ACCESS_MODEL_REQ_MSG_CONTEXT
  • subsecond : MS_TIME_STRUCT , MS_STATE_TIME_STRUCT
  • supp_algorithms : PROV_CAPABILITIES_S
  • supp_pubkey : PROV_CAPABILITIES_S
  • supp_soob : PROV_CAPABILITIES_S


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- t -

  • tai_of_delta_change : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_SET_STRUCT , MS_TAI_UTC_DELTA_STATUS_STRUCT
  • tai_of_zone_change : MS_STATE_TIME_ZONE_STRUCT , MS_TIME_ZONE_SET_STRUCT , MS_TIME_ZONE_STATUS_STRUCT
  • tai_seconds : MS_TIME_STRUCT , MS_STATE_TIME_STRUCT
  • tai_utc_delta : MS_STATE_TIME_STRUCT , MS_TIME_STRUCT
  • tai_utc_delta_current : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_STATUS_STRUCT
  • tai_utc_delta_new : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_SET_STRUCT , MS_TAI_UTC_DELTA_STATUS_STRUCT
  • target_ctl_delta_uv : MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • target_ctl_lightness : MS_LIGHT_CTL_STATUS_STRUCT , MS_STATE_LIGHT_CTL_STRUCT
  • target_ctl_temperature : MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • target_hsl_hue : MS_STATE_LIGHT_HSL_STRUCT
  • target_hsl_lightness : MS_STATE_LIGHT_HSL_STRUCT
  • target_hsl_saturation : MS_STATE_LIGHT_HSL_STRUCT
  • target_hue : MS_LIGHT_HSL_HUE_STATUS_STRUCT
  • target_level : MS_GENERIC_LEVEL_STATUS_STRUCT , MS_STATE_GENERIC_LEVEL_STRUCT
  • target_light_onoff : MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT
  • target_lightness : MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT
  • target_mode : MS_STATE_LIGHT_LC_MODE_STRUCT , MS_STATE_LIGHT_LC_OM_STRUCT
  • target_onoff : MS_GENERIC_ONOFF_STATUS_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT
  • target_power : MS_GENERIC_POWER_LEVEL_STATUS_STRUCT
  • target_saturation : MS_LIGHT_HSL_SATURATION_STATUS_STRUCT
  • target_scene : MS_STATE_SCENE_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT
  • target_xyl_lightness : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • target_xyl_x : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • target_xyl_y : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • temperature : MS_LIGHT_CTL_DEFAULT_SET_STRUCT , MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT
  • test_id : MS_HEALTH_STATUS_STRUCT , MS_HEALTH_FAULT_TEST_STRUCT , MS_HEALTH_SERVER_SELF_TEST
  • tid : MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_SCENE_RECALL_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT , MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT , MS_STATE_LIGHT_HSL_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT
  • time_authority : MS_STATE_TIME_STRUCT , MS_TIME_STRUCT
  • time_role : MS_TIME_ROLE_STRUCT
  • time_to_charge : MS_GENERIC_BATTERY_STATUS_STRUCT
  • time_to_discharge : MS_GENERIC_BATTERY_STATUS_STRUCT
  • time_zone_offset : MS_STATE_TIME_STRUCT , MS_TIME_STRUCT
  • time_zone_offset_current : MS_STATE_TIME_ZONE_STRUCT , MS_TIME_ZONE_STATUS_STRUCT
  • time_zone_offset_new : MS_STATE_TIME_ZONE_STRUCT , MS_TIME_ZONE_SET_STRUCT , MS_TIME_ZONE_STATUS_STRUCT
  • to_be_acked : MS_ACCESS_MODEL_REQ_MSG_T
  • transition : ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM
  • transition_number_of_steps : MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • transition_step_resolution : MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • transition_time : MS_STATE_LIGHT_HSL_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_STATE_GENERIC_POWER_ACTUAL_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_SCENE_RECALL_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT , MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • ttl : ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM , MS_NET_HEADER , MS_TRN_HEARTBEAT_PUBLICATION_INFO , MS_ACCESS_PUBLISH_INFO , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
  • txn_num : MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM , MS_TRN_FRND_MANAGE_PARAM
  • type : MS_ACCESS_MODEL_REQ_MSG_T , MS_ACCESS_MODEL_ID , BRR_BEACON_INFO


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- u -

  • uaddr : MS_PROV_DEV_ENTRY , PROV_DATA_S
  • uncertainty : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_STATE_TIME_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT , MS_TIME_STRUCT
  • uri : PROV_DEVICE_S , BRR_BEACON_INFO
  • use_label : MS_ACCESS_ADDRESS
  • user_access : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_STATE_GENERIC_USER_PROPERTY_STRUCT , MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT , MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT
  • user_property_id : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_GENERIC_USER_PROPERTY_SET_STRUCT , MS_GENERIC_USER_PROPERTY_GET_STRUCT
  • user_property_ids : MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT
  • user_property_ids_count : MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT
  • user_property_value : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_GENERIC_USER_PROPERTY_SET_STRUCT
  • user_property_value_len : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT
  • uuid : PROV_DEVICE_S


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- x -

  • xyl_lightness : MS_LIGHT_XYL_SET_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_STATE_LIGHT_XYL_TARGET_STRUCT , MS_STATE_LIGHT_XYL_DEFAULT_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • xyl_x : MS_LIGHT_XYL_DEFAULT_SET_STRUCT , MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_STATE_LIGHT_XYL_TARGET_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_STATE_LIGHT_XYL_DEFAULT_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT
  • xyl_x_range_max : MS_LIGHT_XYL_RANGE_SET_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT
  • xyl_x_range_min : MS_LIGHT_XYL_RANGE_SET_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT
  • xyl_y : MS_STATE_LIGHT_XYL_DEFAULT_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT , MS_LIGHT_XYL_DEFAULT_SET_STRUCT , MS_STATE_LIGHT_XYL_TARGET_STRUCT , MS_LIGHT_XYL_SET_STRUCT
  • xyl_y_range_max : MS_STATE_LIGHT_XYL_RANGE_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_LIGHT_XYL_RANGE_SET_STRUCT
  • xyl_y_range_min : MS_LIGHT_XYL_RANGE_SET_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT


EtherMind Mesh SDK (beta): Data Fields

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- y -

  • year : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT


EtherMind Mesh SDK (beta): Data Fields - Variables

- a -

  • access : MS_STATE_GENERIC_PROPERTY_STRUCT
  • action : BRR_BEACON_INFO , PROV_OOB_TYPE_S , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • addr : MS_ACCESS_PUBLISH_INFO , MS_TRN_FRIEND_ENTRY , MS_ACCESS_ADDRESS
  • addr_list : MS_TRN_FRND_MANAGE_PARAM
  • address : ACCESS_CONFIG_MODELSUB_ADD_PARAM , ACCESS_CONFIG_MODELSUB_DEL_PARAM , ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM
  • admin_property_id : MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT , MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT
  • admin_property_ids : MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT
  • admin_property_ids_count : MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT
  • admin_property_value : MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
  • admin_property_value_len : MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
  • admin_user_access : MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT , MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
  • algorithm : PROV_METHOD_S
  • appkey : ACCESS_CONFIG_APPKEY_UPDATE_PARAM , ACCESS_CONFIG_APPKEY_ADD_PARAM
  • appkey_handle : MS_ACCESS_MODEL_REQ_MSG_CONTEXT
  • appkey_index : MS_ACCESS_PUBLISH_INFO , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODEL_APP_BIND_PARAM , ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM
  • attention : MS_HEALTH_ATTENTION_STRUCT
  • auth : PROV_METHOD_S


EtherMind Mesh SDK (beta): Data Fields - Variables

- b -

  • battery_level : MS_GENERIC_BATTERY_STATUS_STRUCT
  • bcon_data : BRR_BEACON_INFO
  • bcon_datalen : BRR_BEACON_INFO
  • beacon : ACCESS_CONFIG_BEACON_SET_PARAM
  • bearer_recv : BRR_BEARER_INFO
  • bearer_send : BRR_BEARER_INFO
  • bearer_sleep : BRR_BEARER_INFO
  • bearer_wakeup : BRR_BEARER_INFO
  • binfo : BRR_BEARER_INFO


EtherMind Mesh SDK (beta): Data Fields - Variables

- c -

  • cb : MS_ACCESS_MODEL
  • client_property_id : MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT
  • client_property_ids : MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT
  • client_property_ids_count : MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT
  • column_width : MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • column_width_len : MS_SENSOR_SERIES_STATUS_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT
  • company_id : MS_HEALTH_STATUS_STRUCT , MS_HEALTH_FAULT_GET_CLEAR_STRUCT , MS_HEALTH_FAULT_TEST_STRUCT
  • config_MS_DEFAULT_COMPANY_ID : MS_CONFIG
  • config_MS_DEFAULT_PID : MS_CONFIG
  • config_MS_DEFAULT_VID : MS_CONFIG
  • config_MS_REPLAY_CACHE_SIZE : MS_CONFIG
  • count_log : MS_TRN_HEARTBEAT_PUBLICATION_INFO , MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • countlog : ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
  • crden_flag : MS_ACCESS_PUBLISH_INFO
  • credential_flag : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • criteria : MS_TRN_FRND_REQ_PARAM
  • ctl : MS_NET_HEADER
  • ctl_delta_uv : MS_STATE_LIGHT_CTL_DEFAULT_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • ctl_lightness : MS_STATE_LIGHT_CTL_DEFAULT_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT
  • ctl_temperature : MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT , MS_STATE_LIGHT_CTL_DEFAULT_STRUCT
  • ctl_temperature_range_max : MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT
  • ctl_temperature_range_min : MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT
  • current_scene : MS_SCENE_STATUS_STRUCT , MS_STATE_SCENE_STATUS_STRUCT , MS_SCENE_REGISTER_STATUS_STRUCT , MS_STATE_SCENE_REGISTER_STATUS_STRUCT


EtherMind Mesh SDK (beta): Data Fields - Variables

- d -

  • daddr : MS_ACCESS_MODEL_REQ_MSG_CONTEXT , MS_NET_HEADER , MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO , MS_TRN_HEARTBEAT_PUBLICATION_INFO
  • data_len : MS_ACCESS_MODEL_REQ_MSG_RAW
  • data_param : MS_ACCESS_MODEL_REQ_MSG_RAW
  • day : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT
  • day_of_week : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • dayofweek : MS_STATE_SCHEDULER_ENTRY_STRUCT
  • default_transition_number_of_steps : MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • default_transition_step_resolution : MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • delay : MS_GENERIC_DELTA_SET_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT , MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_SCENE_RECALL_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_STATE_LIGHT_HSL_STRUCT
  • delta_level : MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_STATE_GENERIC_LEVEL_STRUCT
  • delta_uv : MS_LIGHT_CTL_DEFAULT_SET_STRUCT , MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT
  • descriptor : MS_SENSOR_DESCRIPTOR_STATUS_STRUCT
  • destination : ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM


EtherMind Mesh SDK (beta): Data Fields - Variables

- e -

  • elem_handle : MS_ACCESS_MODEL
  • element_address : ACCESS_CONFIG_MODELPUB_GET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM , ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM , ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM , ACCESS_CONFIG_MODEL_APP_BIND_PARAM , ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM , ACCESS_CONFIG_SIGMODELSUB_GET_PARAM , ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM , ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM , ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_DEL_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM , ACCESS_CONFIG_MODELSUB_ADD_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM
  • ext : MS_ACCESS_MODEL_EXT_PARAMS
  • ext_type : MS_ACCESS_MODEL_EXT_PARAMS


EtherMind Mesh SDK (beta): Data Fields - Variables

- f -

  • fast_cadence_high : MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fast_cadence_high_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fast_cadence_low : MS_SENSOR_CADENCE_STATUS_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT
  • fast_cadence_low_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fast_cadence_period_divisor : MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • fastperioddivisor : MS_HEALTH_PERIOD_STRUCT
  • faultarray : MS_HEALTH_STATUS_STRUCT
  • faultarray_len : MS_HEALTH_STATUS_STRUCT
  • features : MS_TRN_HEARTBEAT_PUBLICATION_INFO , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM , MS_TRN_HEARTBEAT_PARAM
  • flags : PROV_DATA_S , MS_GENERIC_BATTERY_STATUS_STRUCT , MS_TRN_FRND_UPDATE_PARAM
  • floor_number : MS_GENERIC_LOCATION_LOCAL_STRUCT , MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT
  • friend : ACCESS_CONFIG_FRIEND_SET_PARAM
  • frnd_counter : MS_TRN_FRND_OFFER_PARAM
  • fsn : MS_TRN_FRND_POLL_PARAM , MS_TRN_FRIEND_ENTRY


EtherMind Mesh SDK (beta): Data Fields - Variables

- g -

  • generic_battery_flags : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_battery_level : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_battery_time_to_charge : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_battery_time_to_discharge : MS_STATE_GENERIC_BATTERY_STRUCT
  • generic_power_actual : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • generic_power_default : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • generic_power_last : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • generic_power_range : MS_STATE_GENERIC_POWER_LEVEL_STRUCT
  • global_altitude : MS_GENERIC_LOCATION_GLOBAL_STRUCT , MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT
  • global_latitude : MS_GENERIC_LOCATION_GLOBAL_STRUCT , MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT
  • global_location : MS_STATE_GENERIC_LOCATION_STRUCT
  • global_longitude : MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT , MS_GENERIC_LOCATION_GLOBAL_STRUCT


EtherMind Mesh SDK (beta): Data Fields - Variables

- h -

  • handle : MS_ACCESS_MODEL_REQ_MSG_CONTEXT
  • hour : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT
  • hsl_hue : MS_STATE_LIGHT_HSL_TARGET_STRUCT , MS_STATE_LIGHT_HSL_DEFAULT_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_STATE_LIGHT_HSL_HUE_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_STATE_LIGHT_HSL_STRUCT
  • hsl_hue_target : MS_LIGHT_HSL_TARGET_STATUS_STRUCT
  • hsl_lightness : MS_STATE_LIGHT_HSL_DEFAULT_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_STATE_LIGHT_HSL_STRUCT , MS_STATE_LIGHT_HSL_TARGET_STRUCT
  • hsl_lightness_target : MS_LIGHT_HSL_TARGET_STATUS_STRUCT
  • hsl_saturation : MS_STATE_LIGHT_HSL_SATURATION_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_STATE_LIGHT_HSL_STRUCT , MS_STATE_LIGHT_HSL_TARGET_STRUCT , MS_STATE_LIGHT_HSL_DEFAULT_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT
  • hsl_saturation_target : MS_LIGHT_HSL_TARGET_STATUS_STRUCT
  • hue : MS_LIGHT_HSL_DEFAULT_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT
  • hue_range_max : MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT , MS_LIGHT_HSL_RANGE_SET_STRUCT
  • hue_range_min : MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT , MS_LIGHT_HSL_RANGE_SET_STRUCT


EtherMind Mesh SDK (beta): Data Fields - Variables

- i -

  • id : MS_ACCESS_MODEL_ID
  • identity : ACCESS_CONFIG_NODEID_SET_PARAM
  • index : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_GET_STRUCT , MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • init_ttl : MS_TRN_HEARTBEAT_PARAM
  • ioob : PROV_CAPABILITIES_S
  • ivi : MS_TRN_FRND_UPDATE_PARAM , MS_NET_HEADER
  • ivindex : PROV_DATA_S


EtherMind Mesh SDK (beta): Data Fields - Variables

- k -

  • keyid : PROV_DATA_S


EtherMind Mesh SDK (beta): Data Fields - Variables

- l -

  • label : MS_ACCESS_ADDRESS , ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM
  • last_onoff : MS_STATE_GENERIC_ONOFF_STRUCT
  • level : MS_GENERIC_LEVEL_SET_STRUCT , MS_STATE_GENERIC_LEVEL_STRUCT
  • light_lc_property_id : MS_LIGHT_LC_PROPERTY_GET_STRUCT , MS_LIGHT_LC_PROPERTY_SET_STRUCT , MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
  • light_lc_property_value : MS_LIGHT_LC_PROPERTY_SET_STRUCT , MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
  • light_lc_property_value_len : MS_LIGHT_LC_PROPERTY_SET_STRUCT , MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
  • light_lightness_actual : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_default : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_last : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_linear : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_lightness_range : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • light_onoff : MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT
  • lightness : MS_LIGHT_CTL_DEFAULT_SET_STRUCT , MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT , MS_LIGHT_HSL_DEFAULT_SET_STRUCT , MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT , MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT , MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT , MS_LIGHT_XYL_DEFAULT_SET_STRUCT
  • lightness_actual : MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT
  • lightness_default : MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT
  • lightness_last : MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT
  • lightness_linear : MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT
  • lightness_range_max : MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT
  • lightness_range_min : MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT
  • lightness_target : MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT
  • loc : MS_ACCESS_ELEMENT_DESC
  • local_altitude : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT
  • local_east : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT
  • local_location : MS_STATE_GENERIC_LOCATION_STRUCT
  • local_north : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT
  • lpn_addr : MS_TRN_FRND_CLEAR_PARAM , MS_TRN_FRND_CLEAR_CNF_PARAM
  • lpn_address : ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM
  • lpn_counter : MS_TRN_FRND_CLEAR_CNF_PARAM , MS_TRN_FRND_REQ_PARAM , MS_TRN_FRND_CLEAR_PARAM


EtherMind Mesh SDK (beta): Data Fields - Variables

- m -

  • major : MS_VERSION_NUMBER
  • manufacturer_property_id : MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT , MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT , MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT
  • manufacturer_property_ids : MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT
  • manufacturer_property_ids_count : MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT
  • manufacturer_property_value : MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
  • manufacturer_property_value_len : MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
  • manufacturer_user_access : MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT , MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
  • marshalled_sensor_data : MS_SENSOR_STATUS_STRUCT
  • marshalled_sensor_data_len : MS_SENSOR_STATUS_STRUCT
  • max_hops : MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • md : MS_TRN_FRND_UPDATE_PARAM
  • min_hops : MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • minor : MS_VERSION_NUMBER
  • minute : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • mode : MS_LIGHT_LC_MODE_STRUCT
  • model : ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM , ACCESS_CONFIG_MODELPUB_GET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_ADD_PARAM , ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM , ACCESS_CONFIG_MODEL_APP_BIND_PARAM , ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM , ACCESS_CONFIG_MODELSUB_DEL_PARAM , ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM
  • model_id : ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM , ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM , MS_ACCESS_MODEL , ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM , ACCESS_CONFIG_SIGMODELSUB_GET_PARAM
  • month : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT
  • move_level : MS_STATE_GENERIC_LEVEL_STRUCT
  • mtu : BRR_BEARER_CH_INFO


EtherMind Mesh SDK (beta): Data Fields - Variables

- n -

  • net_tx_count : ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
  • net_tx_interval_steps : ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
  • netkey : ACCESS_CONFIG_NETKEY_UPDATE_PARAM , PROV_DATA_S , ACCESS_CONFIG_NETKEY_ADD_PARAM
  • netkey_index : ACCESS_CONFIG_NETKEY_DELETE_PARAM , ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM , ACCESS_CONFIG_APPKEY_ADD_PARAM , MS_TRN_HEARTBEAT_PUBLICATION_INFO , ACCESS_CONFIG_APPKEY_UPDATE_PARAM , ACCESS_CONFIG_APPKEY_DELETE_PARAM , ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM , ACCESS_CONFIG_NODEID_SET_PARAM , ACCESS_CONFIG_NODEID_GET_PARAM , ACCESS_CONFIG_NETKEY_ADD_PARAM , ACCESS_CONFIG_APPKEY_GET_PARAM , ACCESS_CONFIG_NETKEY_UPDATE_PARAM
  • nid : MS_NET_HEADER
  • num_addr : MS_TRN_FRND_MANAGE_PARAM
  • num_elem : MS_TRN_FRND_REQ_PARAM
  • num_elements : PROV_CAPABILITIES_S , MS_PROV_DEV_ENTRY , MS_TRN_FRIEND_ENTRY
  • num_opcodes : MS_ACCESS_MODEL
  • number : MS_STATE_SCENE_NUMBER_STRUCT


EtherMind Mesh SDK (beta): Data Fields - Variables

- o -

  • onoff : MS_GENERIC_ONOFF_SET_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT
  • onpowerup : MS_STATE_GENERIC_ONPOWERUP_STRUCT , MS_GENERIC_ONPOWERUP_STRUCT
  • oob : PROV_DEVICE_S , PROV_METHOD_S
  • ooob : PROV_CAPABILITIES_S
  • opcode : MS_ACCESS_MODEL_REQ_MSG_RAW , MS_TRN_FRND_MANAGE_PARAM
  • opcodes : MS_ACCESS_MODEL
  • optional_fields_present : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_LIGHT_HSL_SATURATION_STATUS_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT , MS_LIGHT_HSL_HUE_STATUS_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_LIGHT_HSL_TARGET_STATUS_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_GENERIC_POWER_LEVEL_STATUS_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_GENERIC_ONOFF_STATUS_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_GENERIC_LEVEL_STATUS_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_SENSOR_SERIES_GET_STRUCT , MS_SENSOR_STATUS_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT , MS_SENSOR_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT , MS_SENSOR_DESCRIPTOR_GET_STRUCT , MS_SENSOR_DESCRIPTOR_STATUS_STRUCT , MS_SCENE_RECALL_STRUCT


EtherMind Mesh SDK (beta): Data Fields - Variables

- p -

  • padding : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_SET_STRUCT
  • padding_1 : MS_TAI_UTC_DELTA_STATUS_STRUCT
  • padding_2 : MS_TAI_UTC_DELTA_STATUS_STRUCT
  • page : ACCESS_CONFIG_COMPDATA_GET_PARAM
  • period : MS_ACCESS_PUBLISH_INFO
  • period_log : MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO , MS_TRN_HEARTBEAT_PUBLICATION_INFO
  • periodlog : ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM , ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
  • poll_to : MS_TRN_FRND_REQ_PARAM
  • power : MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_GENERIC_POWER_LAST_STATUS_STRUCT , MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT , MS_GENERIC_POWER_DEFAULT_SET_STRUCT
  • power_actual : MS_STATE_GENERIC_POWER_ACTUAL_STRUCT
  • power_default : MS_STATE_GENERIC_POWER_DEFAULT_STRUCT
  • power_last : MS_STATE_GENERIC_POWER_LAST_STRUCT
  • power_range_max : MS_STATE_GENERIC_POWER_RANGE_STRUCT
  • power_range_min : MS_STATE_GENERIC_POWER_RANGE_STRUCT
  • power_target : MS_STATE_GENERIC_POWER_ACTUAL_STRUCT
  • present_ctl_delta_uv : MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT
  • present_ctl_lightness : MS_LIGHT_CTL_STATUS_STRUCT
  • present_ctl_temperature : MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT
  • present_hue : MS_LIGHT_HSL_HUE_STATUS_STRUCT
  • present_level : MS_GENERIC_LEVEL_STATUS_STRUCT
  • present_light_onoff : MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT
  • present_lightness : MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT
  • present_mode : MS_STATE_LIGHT_LC_MODE_STRUCT , MS_STATE_LIGHT_LC_OM_STRUCT
  • present_onoff : MS_GENERIC_ONOFF_STATUS_STRUCT
  • present_power : MS_GENERIC_POWER_LEVEL_STATUS_STRUCT
  • present_saturation : MS_LIGHT_HSL_SATURATION_STATUS_STRUCT
  • prev_addr : MS_TRN_FRND_REQ_PARAM
  • prev_faddr : MS_TRN_FRIEND_ENTRY
  • property_id : MS_SENSOR_DESCRIPTOR_GET_STRUCT , MS_STATE_GENERIC_PROPERTY_ID_STRUCT , MS_STATE_GENERIC_PROPERTY_STRUCT , MS_STATE_GENERIC_USER_PROPERTY_STRUCT , MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT , MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT , MS_STATE_SENSOR_PROPERTY_ID_STRUCT , MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT , MS_STATE_LIGHT_LC_PROPERTY_STRUCT , MS_SENSOR_CADENCE_GET_STRUCT , MS_SENSOR_GET_STRUCT , MS_SENSOR_COLUMN_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT , MS_SENSOR_SERIES_GET_STRUCT
  • property_id_1 : MS_STATE_SENSOR_DATA_STRUCT
  • property_id_2 : MS_STATE_SENSOR_DATA_STRUCT
  • property_id_n : MS_STATE_SENSOR_DATA_STRUCT
  • property_ids : MS_STATE_GENERIC_PROPERTY_IDS_STRUCT
  • property_type : MS_STATE_GENERIC_PROPERTY_STRUCT
  • property_value : MS_STATE_GENERIC_USER_PROPERTY_STRUCT , MS_STATE_GENERIC_PROPERTY_STRUCT , MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT , MS_STATE_LIGHT_LC_PROPERTY_STRUCT , MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT
  • proxy : ACCESS_CONFIG_GATT_PROXY_SET_PARAM
  • pubkey : PROV_METHOD_S
  • publish_address : ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM
  • publish_period : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • publish_rtx_count : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • publish_rtx_interval_steps : ACCESS_CONFIG_MODELPUB_SET_PARAM , ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
  • publish_ttl : ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM , ACCESS_CONFIG_MODELPUB_SET_PARAM


EtherMind Mesh SDK (beta): Data Fields - Variables

- q -

  • queue_size : MS_TRN_FRND_OFFER_PARAM


EtherMind Mesh SDK (beta): Data Fields - Variables

- r -

  • range_max : MS_GENERIC_POWER_RANGE_STATUS_STRUCT , MS_GENERIC_POWER_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT
  • range_min : MS_GENERIC_POWER_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT , MS_GENERIC_POWER_RANGE_STATUS_STRUCT
  • range_status : MS_STATE_LIGHT_LIGHTNESS_STRUCT
  • raw_value_1 : MS_STATE_SENSOR_DATA_STRUCT
  • raw_value_2 : MS_STATE_SENSOR_DATA_STRUCT
  • raw_value_n : MS_STATE_SENSOR_DATA_STRUCT
  • raw_value_x : MS_SENSOR_COLUMN_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • raw_value_x1 : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x1_len : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x2 : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x2_len : MS_SENSOR_SERIES_GET_STRUCT
  • raw_value_x_len : MS_SENSOR_COLUMN_GET_STRUCT , MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • raw_value_y : MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • raw_value_y_len : MS_SENSOR_COLUMN_STATUS_STRUCT , MS_SENSOR_SERIES_STATUS_STRUCT
  • relay : ACCESS_CONFIG_RELAY_SET_PARAM
  • relay_rtx_count : ACCESS_CONFIG_RELAY_SET_PARAM
  • relay_rtx_interval_steps : ACCESS_CONFIG_RELAY_SET_PARAM
  • remaining_time : MS_GENERIC_ONOFF_STATUS_STRUCT , MS_GENERIC_LEVEL_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_HSL_SATURATION_STATUS_STRUCT , MS_LIGHT_HSL_HUE_STATUS_STRUCT , MS_GENERIC_POWER_LEVEL_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_LIGHT_HSL_STATUS_STRUCT , MS_LIGHT_HSL_TARGET_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT , MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_LIGHT_XYL_TARGET_STATUS_STRUCT
  • remote : MS_ACCESS_PUBLISH_INFO
  • role : BRR_BEARER_CH_INFO , MS_STATE_TIME_ROLE_STRUCT
  • rssi : MS_TRN_FRND_OFFER_PARAM
  • rtx_count : MS_ACCESS_PUBLISH_INFO
  • rtx_interval_steps : MS_ACCESS_PUBLISH_INFO
  • rx_delay : MS_TRN_FRND_REQ_PARAM
  • rx_window : MS_TRN_FRND_OFFER_PARAM


EtherMind Mesh SDK (beta): Data Fields - Variables

- s -

  • saddr : MS_ACCESS_MODEL_REQ_MSG_CONTEXT , MS_NET_HEADER , MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
  • saturation : MS_LIGHT_HSL_DEFAULT_SET_STRUCT , MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT
  • saturation_range_max : MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT , MS_LIGHT_HSL_RANGE_SET_STRUCT
  • saturation_range_min : MS_LIGHT_HSL_RANGE_SET_STRUCT , MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT
  • scene_number : MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCENE_RECALL_STRUCT , MS_SCENE_STRUCT
  • scenes : MS_STATE_SCENE_REGISTER_STATUS_STRUCT , MS_SCENE_REGISTER_STATUS_STRUCT
  • scenes_len : MS_SCENE_REGISTER_STATUS_STRUCT
  • schedules : MS_STATE_SCHEDULER_SCHEDULES_STRUCT , MS_SCHEDULER_STATUS_STRUCT
  • second : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT
  • self_test_fn : MS_HEALTH_SERVER_SELF_TEST
  • sensor_column_width : MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
  • sensor_measurement_period : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_negative_tolerance : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_positive_tolerance : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_property_id : MS_STATE_SENSOR_SETTINGS_STRUCT , MS_STATE_SENSOR_SETTING_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT , MS_STATE_SENSOR_SERIES_COLUMN_STRUCT , MS_SENSOR_SETTINGS_GET_STRUCT , MS_SENSOR_SETTINGS_STATUS_STRUCT , MS_SENSOR_SETTING_GET_STRUCT , MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT , MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_raw_value_x : MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
  • sensor_raw_value_y : MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
  • sensor_sampling_function : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • sensor_setting_access : MS_STATE_SENSOR_SETTING_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_setting_property_id : MS_STATE_SENSOR_SETTING_STRUCT , MS_SENSOR_SETTING_GET_STRUCT , MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_setting_property_ids : MS_SENSOR_SETTINGS_STATUS_STRUCT
  • sensor_setting_property_ids_count : MS_SENSOR_SETTINGS_STATUS_STRUCT
  • sensor_setting_raw : MS_STATE_SENSOR_SETTING_STRUCT , MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_setting_raw_len : MS_SENSOR_SETTING_SET_STRUCT , MS_SENSOR_SETTING_STATUS_STRUCT
  • sensor_update_interval : MS_STATE_SENSOR_DESCRIPTOR_STRUCT
  • seq_num : MS_NET_HEADER
  • setting_property_ids : MS_STATE_SENSOR_SETTINGS_STRUCT
  • size : PROV_OOB_TYPE_S
  • source : ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
  • state : MS_ACCESS_MODEL_STATE_PARAMS
  • state_type : MS_ACCESS_MODEL_STATE_PARAMS
  • status : MS_GENERIC_POWER_RANGE_STATUS_STRUCT , MS_STATE_GENERIC_POWER_RANGE_STRUCT , MS_STATE_SENSOR_DESCRIPTOR_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT , MS_STATE_SENSOR_DATA_STRUCT , MS_STATE_SENSOR_SERIES_COLUMN_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT , MS_STATE_LIGHT_HSL_RANGE_STRUCT
  • status_code : MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT , MS_LIGHT_HSL_RANGE_STATUS_STRUCT , MS_SCENE_REGISTER_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT , MS_STATE_SCENE_STATUS_STRUCT , MS_STATE_SCENE_REGISTER_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT
  • status_min_interval : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT
  • status_trigger_delta_down : MS_STATE_SENSOR_CADENCE_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • status_trigger_delta_down_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • status_trigger_delta_up : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT
  • status_trigger_delta_up_len : MS_SENSOR_CADENCE_SET_STRUCT , MS_SENSOR_CADENCE_STATUS_STRUCT
  • status_trigger_type : MS_SENSOR_CADENCE_STATUS_STRUCT , MS_SENSOR_CADENCE_SET_STRUCT , MS_STATE_SENSOR_CADENCE_STRUCT
  • sublist_size : MS_TRN_FRND_OFFER_PARAM
  • subminor : MS_VERSION_NUMBER
  • subnet_handle : MS_ACCESS_MODEL_REQ_MSG_CONTEXT
  • subsecond : MS_TIME_STRUCT , MS_STATE_TIME_STRUCT
  • supp_algorithms : PROV_CAPABILITIES_S
  • supp_pubkey : PROV_CAPABILITIES_S
  • supp_soob : PROV_CAPABILITIES_S


EtherMind Mesh SDK (beta): Data Fields - Variables

- t -

  • tai_of_delta_change : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_SET_STRUCT , MS_TAI_UTC_DELTA_STATUS_STRUCT
  • tai_of_zone_change : MS_STATE_TIME_ZONE_STRUCT , MS_TIME_ZONE_SET_STRUCT , MS_TIME_ZONE_STATUS_STRUCT
  • tai_seconds : MS_TIME_STRUCT , MS_STATE_TIME_STRUCT
  • tai_utc_delta : MS_STATE_TIME_STRUCT , MS_TIME_STRUCT
  • tai_utc_delta_current : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_STATUS_STRUCT
  • tai_utc_delta_new : MS_STATE_TIME_TAI_UTC_DELTA_STRUCT , MS_TAI_UTC_DELTA_SET_STRUCT , MS_TAI_UTC_DELTA_STATUS_STRUCT
  • target_ctl_delta_uv : MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • target_ctl_lightness : MS_LIGHT_CTL_STATUS_STRUCT , MS_STATE_LIGHT_CTL_STRUCT
  • target_ctl_temperature : MS_LIGHT_CTL_STATUS_STRUCT , MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • target_hsl_hue : MS_STATE_LIGHT_HSL_STRUCT
  • target_hsl_lightness : MS_STATE_LIGHT_HSL_STRUCT
  • target_hsl_saturation : MS_STATE_LIGHT_HSL_STRUCT
  • target_hue : MS_LIGHT_HSL_HUE_STATUS_STRUCT
  • target_level : MS_GENERIC_LEVEL_STATUS_STRUCT , MS_STATE_GENERIC_LEVEL_STRUCT
  • target_light_onoff : MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT
  • target_lightness : MS_LIGHT_LIGHTNESS_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT
  • target_mode : MS_STATE_LIGHT_LC_MODE_STRUCT , MS_STATE_LIGHT_LC_OM_STRUCT
  • target_onoff : MS_GENERIC_ONOFF_STATUS_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT
  • target_power : MS_GENERIC_POWER_LEVEL_STATUS_STRUCT
  • target_saturation : MS_LIGHT_HSL_SATURATION_STATUS_STRUCT
  • target_scene : MS_STATE_SCENE_STATUS_STRUCT , MS_SCENE_STATUS_STRUCT
  • target_xyl_lightness : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • target_xyl_x : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • target_xyl_y : MS_LIGHT_XYL_TARGET_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • temperature : MS_LIGHT_CTL_DEFAULT_SET_STRUCT , MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT
  • test_id : MS_HEALTH_STATUS_STRUCT , MS_HEALTH_FAULT_TEST_STRUCT , MS_HEALTH_SERVER_SELF_TEST
  • tid : MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_SCENE_RECALL_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT , MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT , MS_STATE_LIGHT_HSL_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT
  • time_authority : MS_STATE_TIME_STRUCT , MS_TIME_STRUCT
  • time_role : MS_TIME_ROLE_STRUCT
  • time_to_charge : MS_GENERIC_BATTERY_STATUS_STRUCT
  • time_to_discharge : MS_GENERIC_BATTERY_STATUS_STRUCT
  • time_zone_offset : MS_STATE_TIME_STRUCT , MS_TIME_STRUCT
  • time_zone_offset_current : MS_STATE_TIME_ZONE_STRUCT , MS_TIME_ZONE_STATUS_STRUCT
  • time_zone_offset_new : MS_STATE_TIME_ZONE_STRUCT , MS_TIME_ZONE_SET_STRUCT , MS_TIME_ZONE_STATUS_STRUCT
  • to_be_acked : MS_ACCESS_MODEL_REQ_MSG_T
  • transition : ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM
  • transition_number_of_steps : MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • transition_step_resolution : MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
  • transition_time : MS_STATE_LIGHT_HSL_STRUCT , MS_GENERIC_MOVE_SET_STRUCT , MS_GENERIC_LEVEL_SET_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT , MS_STATE_GENERIC_POWER_ACTUAL_STRUCT , MS_GENERIC_DELTA_SET_STRUCT , MS_SCENE_RECALL_STRUCT , MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT , MS_LIGHT_HSL_SATURATION_SET_STRUCT , MS_LIGHT_HSL_HUE_SET_STRUCT , MS_STATE_GENERIC_ONOFF_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_STATE_LIGHT_CTL_STRUCT , MS_GENERIC_POWER_LEVEL_SET_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_LIGHT_CTL_SET_STRUCT , MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT , MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT , MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT , MS_LIGHT_HSL_SET_STRUCT , MS_GENERIC_ONOFF_SET_STRUCT , MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_LIGHT_LIGHTNESS_SET_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT , MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT , MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
  • ttl : ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM , MS_NET_HEADER , MS_TRN_HEARTBEAT_PUBLICATION_INFO , MS_ACCESS_PUBLISH_INFO , ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
  • txn_num : MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM , MS_TRN_FRND_MANAGE_PARAM
  • type : MS_ACCESS_MODEL_REQ_MSG_T , MS_ACCESS_MODEL_ID , BRR_BEACON_INFO


EtherMind Mesh SDK (beta): Data Fields - Variables

- u -

  • uaddr : MS_PROV_DEV_ENTRY , PROV_DATA_S
  • uncertainty : MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT , MS_STATE_TIME_STRUCT , MS_GENERIC_LOCATION_LOCAL_STRUCT , MS_TIME_STRUCT
  • uri : PROV_DEVICE_S , BRR_BEACON_INFO
  • use_label : MS_ACCESS_ADDRESS
  • user_access : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_STATE_GENERIC_USER_PROPERTY_STRUCT , MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT , MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT
  • user_property_id : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_GENERIC_USER_PROPERTY_SET_STRUCT , MS_GENERIC_USER_PROPERTY_GET_STRUCT
  • user_property_ids : MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT
  • user_property_ids_count : MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT
  • user_property_value : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT , MS_GENERIC_USER_PROPERTY_SET_STRUCT
  • user_property_value_len : MS_GENERIC_USER_PROPERTY_STATUS_STRUCT
  • uuid : PROV_DEVICE_S


EtherMind Mesh SDK (beta): Data Fields - Variables

- x -

  • xyl_lightness : MS_LIGHT_XYL_SET_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_STATE_LIGHT_XYL_TARGET_STRUCT , MS_STATE_LIGHT_XYL_DEFAULT_STRUCT , MS_STATE_LIGHT_XYL_STRUCT
  • xyl_x : MS_LIGHT_XYL_DEFAULT_SET_STRUCT , MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_STATE_LIGHT_XYL_TARGET_STRUCT , MS_LIGHT_XYL_SET_STRUCT , MS_STATE_LIGHT_XYL_DEFAULT_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT
  • xyl_x_range_max : MS_LIGHT_XYL_RANGE_SET_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT
  • xyl_x_range_min : MS_LIGHT_XYL_RANGE_SET_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT
  • xyl_y : MS_STATE_LIGHT_XYL_DEFAULT_STRUCT , MS_STATE_LIGHT_XYL_STRUCT , MS_LIGHT_XYL_STATUS_STRUCT , MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT , MS_LIGHT_XYL_DEFAULT_SET_STRUCT , MS_STATE_LIGHT_XYL_TARGET_STRUCT , MS_LIGHT_XYL_SET_STRUCT
  • xyl_y_range_max : MS_STATE_LIGHT_XYL_RANGE_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT , MS_LIGHT_XYL_RANGE_SET_STRUCT
  • xyl_y_range_min : MS_LIGHT_XYL_RANGE_SET_STRUCT , MS_STATE_LIGHT_XYL_RANGE_STRUCT , MS_LIGHT_XYL_RANGE_STATUS_STRUCT


EtherMind Mesh SDK (beta): Data Fields - Variables

- y -

  • year : MS_STATE_SCHEDULER_ENTRY_STRUCT , MS_SCHEDULER_ACTION_SET_STRUCT , MS_SCHEDULER_ACTION_STATUS_STRUCT


EtherMind Mesh SDK (beta): File List

File List
Here is a list of all documented files with brief descriptions:
[detail level 1234]
\ - mesh |
o - build |
| \ - doc |
| \ * z_sequence.html |
\ - export |
\ - include |
o * MS_access_api.h | This file defines the Mesh Access Application Interface - includes Data Structures and Methods
o * MS_assigned_numbers.h | This header file describes various definitions from the Mesh Assigned Numbers Specification
o * MS_brr_api.h | This file defines the Mesh Bearer Application Interface - includes Data Structures and Methods
o * MS_common.h | This Header file describes common declarations for the EtherMind Mesh modules
o * MS_config_api.h | This file defines the Mesh Configuration Foundation Model Application Interface
o * MS_error.h | This file lists all the Error Codes returned by EtherMind Mesh APIs
o * MS_generic_battery_api.h | This file defines the Mesh Generic Battery Model Application Interface
o * MS_generic_default_transition_time_api.h | This file defines the Mesh Generic Default Transition Time Model Application Interface
o * MS_generic_level_api.h | This file defines the Mesh Generic Level Model Application Interface
o * MS_generic_location_api.h | This file defines the Mesh Generic Location Model Application Interface
o * MS_generic_onoff_api.h | This file defines the Mesh Generic Onoff Model Application Interface
o * MS_generic_power_level_api.h | This file defines the Mesh Generic Power Level Model Application Interface
o * MS_generic_power_onoff_api.h | This file defines the Mesh Generic Power Onoff Model Application Interface
o * MS_generic_property_api.h | This file defines the Mesh Generic User, Admin, Manufacturer and Client Property Model Application Interface
o * MS_health_client_api.h | This file defines the Mesh Health Model Application Interface
o * MS_health_server_api.h | This file defines the Mesh Health Model Application Interface
o * MS_light_ctl_api.h | This file defines the Mesh Light Ctl Model Application Interface
o * MS_light_hsl_api.h | This file defines the Mesh Light Hsl Model Application Interface
o * MS_light_lc_api.h | This file defines the Mesh Light Lc Model Application Interface
o * MS_light_lightness_api.h | This file defines the Mesh Light Lightness Model Application Interface
o * MS_light_xyl_api.h | This file defines the Mesh Light Xyl Model Application Interface
o * MS_ltrn_api.h | This file defines the Mesh Lower Transport Application Interface - includes Data Structures and Methods
o * MS_model_states.h |
o * MS_net_api.h | This file defines the Mesh Network Layer Interface - includes Data Structures and Methods
o * MS_prov_api.h | This file defines the Mesh Provisioning Application Interface - includes Data Structures and Methods
o * MS_scene_api.h | This file defines the Mesh Scene Model Application Interface
o * MS_scheduler_api.h | This file defines the Mesh Scheduler Model Application Interface
o * MS_sensor_api.h | This file defines the Mesh Sensor Model Application Interface
o * MS_time_api.h | This file defines the Mesh Time Model Application Interface
o * MS_trn_api.h | This file defines the Mesh Transport Application Interface - includes Data Structures and Methods
\ * MS_version.h | This EtherMind Header File containing version number of the stack


EtherMind Mesh SDK (beta): mesh Directory Reference

  • mesh
mesh Directory Reference
Directory dependency graph for mesh:

Directories

directory | build
directory | export


EtherMind Mesh SDK (beta): mesh/build Directory Reference

  • mesh
  • build
build Directory Reference
Directory dependency graph for build:

Directories

directory doc


EtherMind Mesh SDK (beta): mesh/build/doc Directory Reference

  • mesh
  • build
  • doc
doc Directory Reference
Directory dependency graph for doc:

Files

file z_sequence.html [code]


EtherMind Mesh SDK (beta): mesh/build/doc/z_sequence.html Source File

  • mesh
  • build
  • doc
z_sequence.html
1


EtherMind Mesh SDK (beta): mesh/export Directory Reference

  • mesh
  • export
export Directory Reference
Directory dependency graph for export:

Directories

directory include


EtherMind Mesh SDK (beta): mesh/export/include Directory Reference

  • mesh
  • export
  • include
include Directory Reference
Directory dependency graph for include:

Files

file | MS_access_api.h [code]
This file defines the Mesh Access Application Interface - includes Data Structures and Methods.
file | MS_assigned_numbers.h [code]
This header file describes various definitions from the Mesh Assigned Numbers Specification.
file | MS_brr_api.h [code]
This file defines the Mesh Bearer Application Interface - includes Data Structures and Methods.
file | MS_common.h [code]
This Header file describes common declarations for the EtherMind Mesh modules.
file | MS_config_api.h [code]
This file defines the Mesh Configuration Foundation Model Application Interface.
file | MS_error.h [code]
This file lists all the Error Codes returned by EtherMind Mesh APIs.
file | MS_generic_battery_api.h [code]
This file defines the Mesh Generic Battery Model Application Interface.
file | MS_generic_default_transition_time_api.h [code]
This file defines the Mesh Generic Default Transition Time Model Application Interface.
file | MS_generic_level_api.h [code]
This file defines the Mesh Generic Level Model Application Interface.
file | MS_generic_location_api.h [code]
This file defines the Mesh Generic Location Model Application Interface.
file | MS_generic_onoff_api.h [code]
This file defines the Mesh Generic Onoff Model Application Interface.
file | MS_generic_power_level_api.h [code]
This file defines the Mesh Generic Power Level Model Application Interface.
file | MS_generic_power_onoff_api.h [code]
This file defines the Mesh Generic Power Onoff Model Application Interface.
file | MS_generic_property_api.h [code]
This file defines the Mesh Generic User, Admin, Manufacturer and Client Property Model Application Interface.
file | MS_health_client_api.h [code]
This file defines the Mesh Health Model Application Interface.
file | MS_health_server_api.h [code]
This file defines the Mesh Health Model Application Interface.
file | MS_light_ctl_api.h [code]
This file defines the Mesh Light Ctl Model Application Interface.
file | MS_light_hsl_api.h [code]
This file defines the Mesh Light Hsl Model Application Interface.
file | MS_light_lc_api.h [code]
This file defines the Mesh Light Lc Model Application Interface.
file | MS_light_lightness_api.h [code]
This file defines the Mesh Light Lightness Model Application Interface.
file | MS_light_xyl_api.h [code]
This file defines the Mesh Light Xyl Model Application Interface.
file | MS_ltrn_api.h [code]
This file defines the Mesh Lower Transport Application Interface - includes Data Structures and Methods.
file | MS_model_states.h [code]
file | MS_net_api.h [code]
This file defines the Mesh Network Layer Interface - includes Data Structures and Methods.
file | MS_prov_api.h [code]
This file defines the Mesh Provisioning Application Interface - includes Data Structures and Methods.
file | MS_scene_api.h [code]
This file defines the Mesh Scene Model Application Interface.
file | MS_scheduler_api.h [code]
This file defines the Mesh Scheduler Model Application Interface.
file | MS_sensor_api.h [code]
This file defines the Mesh Sensor Model Application Interface.
file | MS_time_api.h [code]
This file defines the Mesh Time Model Application Interface.
file | MS_trn_api.h [code]
This file defines the Mesh Transport Application Interface - includes Data Structures and Methods.
file | MS_version.h [code]
This EtherMind Header File containing version number of the stack.


EtherMind Mesh SDK (beta): mesh/export/include/MS_access_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_access_api.h File Reference

This file defines the Mesh Access Application Interface - includes Data Structures and Methods. More...

#include "MS_trn_api.h"
Include dependency graph for MS_access_api.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | MS_ACCESS_MODEL_ID
Model ID datatype. More...
struct | MS_ACCESS_MODEL
Data structure for model. More...
struct | MS_ACCESS_ELEMENT_DESC
Element description format. More...
struct | MS_ACCESS_ADDRESS
Unicast/Virtual/Group Address. More...
struct | MS_ACCESS_PUBLISH_INFO
Access Publication related information. More...
struct | MS_ACCESS_MODEL_REQ_MSG_CONTEXT
Context of message received for a specific model instance. More...
struct | MS_ACCESS_MODEL_REQ_MSG_RAW
Uninterpreted/raw received message for a specific model instance. More...
struct | MS_ACCESS_MODEL_REQ_MSG_T
Requested message type for a specific model instance. More...
struct | MS_ACCESS_MODEL_STATE_PARAMS
Model specific state parameters in a request or response message. More...
struct | MS_ACCESS_MODEL_EXT_PARAMS
Additional paramters in a Model specific request or response message. More...
struct | MS_PROV_DEV_ENTRY
Provisioned Device List Data Structure, containing Primary Element Address and number of elements. More...

Macros

#define | MS_ACCESS_MAX_PKT_SIZE 384
Maximum Access Packet size. More...
#define | MS_ACCESS_VADDR_LABEL_UUID_SIZE 16
Array sizes for use in the Access layer. More...
#define | MS_ACCESS_NETKEY_SIZE 16
Size of NetKey.
#define | MS_ACCESS_APPKEY_SIZE 16
Size of AppKey.
#define | MS_ACCESS_DEFAULT_NODE_ID 0x00
Default Node Identifier.
#define | MS_ACCESS_DEFAULT_ELEMENT_HANDLE 0x00
Default Element Handle.
#define | MS_ACCESS_GET_REQ 0x01
Get Request.
#define | MS_ACCESS_SET_REQ 0x02
Set Request.
#define | ACCESS_INVALID_DEFAULT_TTL 0xFF
Invalid default TTL value.
#define | ACCESS_MAX_TTL 0x7F
Maximum TTL value - used as initializer.
#define | MS_ACCESS_MODEL_REQ_MSG_T_GET 0
Model Specific Request Message Type: Get, Set or Others. More...
#define | MS_ACCESS_MODEL_REQ_MSG_T_SET 1
Model Specific Request Message Type: Set.
#define | MS_ACCESS_MODEL_REQ_MSG_T_OTHERS 2
Model Specific Request Message Type: Others.
#define | MS_ACCESS_KEY_REFRESH_PHASE_NORMAL 0x00
Key Refersh Phase states. More...
#define | MS_ACCESS_KEY_REFRESH_PHASE_1 0x01
Key Refersh Phase - 1.
#define | MS_ACCESS_KEY_REFRESH_PHASE_2 0x02
Key Refersh Phase - 2.
#define | MS_ACCESS_KEY_REFRESH_PHASE_3 0x03
Key Refersh Phase - 3.
#define | MS_ACCESS_ADDRESS_INVALID_HANDLE 0xFFFFFFFF
Invalid Access Address.
#define | MS_ACCESS_ASSIGN_ELEMENT(pelement, loc) (pelement)->loc = (loc)
Populates the given element with the Model information.
#define | MS_ACCESS_INIT_SIG_MODEL(pmodel, id, eh, cb, num_op, op)
Initializes the SIG model with the given ID and callback information. More...
#define | MS_ACCESS_INIT_VENDOR_MODEL(pmodel, id, eh, cb, num_op, op)
Initializes the Vendor model with the given ID and callback information. More...
#define | MS_ENABLE_RELAY_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_RELAY)
Enable Relay Feature.
#define | MS_DISABLE_RELAY_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_RELAY)
Disable Relay Feature.
#define | MS_ENABLE_PROXY_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_PROXY)
Enable Proxy Feature.
#define | MS_DISABLE_PROXY_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_PROXY)
Disable Proxy Feature.
#define | MS_ENABLE_FRIEND_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_FRIEND)
Enable Friend Feature.
#define | MS_DISABLE_FRIEND_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_FRIEND)
Disable Friend Feature.
#define | MS_ENABLE_LPN_FEATURE() MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_LPN)
Enable Low Power Feature.
#define | MS_DISABLE_LPN_FEATURE() MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_LPN)
Disable Low Power Feature.

Typedefs

typedef UINT16 | MS_ACCESS_MODEL_HANDLE
Access Model Handle.
typedef API_RESULT(* | MS_ACCESS_MODEL_CB )(MS_ACCESS_MODEL_HANDLE *handle, MS_NET_ADDR saddr, MS_NET_ADDR daddr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Access Layer Application Asynchronous Notification Callback. More...
typedef UINT16 | MS_ACCESS_MODEL_ID_SIG
SIG Model ID.
typedef UINT32 | MS_ACCESS_MODEL_ID_VENDOR
Vendor Model ID.
typedef UINT8 | MS_ACCESS_NODE_ID
Access Node ID.
typedef UINT8 | MS_ACCESS_ELEMENT_HANDLE
Access Element Handle.
typedef UINT32 | MS_ACCESS_ADDRESS_HANDLE
Access Address Handle.
typedef UINT32 | MS_ACCESS_DEV_KEY_HANDLE
Device Key Handle.

Functions

API_RESULT | MS_access_create_node (MS_ACCESS_NODE_ID *node_id)
Create a new node in the device. More...
API_RESULT | MS_access_register_element (MS_ACCESS_NODE_ID node_id, MS_ACCESS_ELEMENT_DESC *element, MS_ACCESS_ELEMENT_HANDLE *element_handle)
Register an element with the access layer. More...
API_RESULT | MS_access_register_model (MS_ACCESS_NODE_ID node_id, MS_ACCESS_MODEL *model, MS_ACCESS_MODEL_HANDLE *model_handle)
Register a model with the access layer. More...
API_RESULT | MS_access_get_element_handle (MS_NET_ADDR elem_addr, MS_ACCESS_ELEMENT_HANDLE *handle)
Get element handle. More...
API_RESULT | MS_access_get_model_handle (MS_ACCESS_ELEMENT_HANDLE elem_handle, MS_ACCESS_MODEL_ID model_id, MS_ACCESS_MODEL_HANDLE *handle)
Get model handle. More...
API_RESULT | MS_access_publish (MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len, UINT8 reliable)
API to publish access layer message. More...
API_RESULT | MS_access_reply (MS_ACCESS_MODEL_HANDLE *handle, MS_NET_ADDR saddr, MS_NET_ADDR daddr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT8 ttl, UINT32 opcode, UCHAR *data_param, UINT16 data_length)
API to reply to access layer message. More...
API_RESULT | MS_access_send_pdu (MS_NET_ADDR saddr, MS_NET_ADDR daddr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT8 ttl, UINT32 opcode, UCHAR *data_param, UINT16 data_length)
API to send Access PDUs. More...
API_RESULT | MS_access_get_composition_data (MS_BUFFER *buffer)
TBD: add function header.
API_RESULT | MS_access_cm_reset (void)
To reset a node. More...
API_RESULT | MS_access_cm_get_element_count (UINT8 *count)
To get the number of elements in local node. More...
API_RESULT | MS_access_cm_set_primary_unicast_address (MS_NET_ADDR addr)
To set primary unicast address. More...
API_RESULT | MS_access_cm_get_primary_unicast_address (MS_NET_ADDR *addr)
To get primary unicast address. More...
API_RESULT | MS_access_cm_set_default_ttl (UINT8 ttl)
To set default TTL. More...
API_RESULT | MS_access_cm_get_default_ttl (UINT8 *ttl)
To get default TTL. More...
API_RESULT | MS_access_cm_set_iv_index (UINT32 iv_index, UINT8 iv_update_flag)
To set IV Index. More...
API_RESULT | MS_access_cm_get_iv_index (UINT32 *iv_index, UINT8 *iv_update_flag)
To get IV Index. More...
API_RESULT | MS_access_cm_get_iv_index_by_ivi (UINT8 ivi, UINT32 *iv_index)
To get IV Index by IVI. More...
API_RESULT | MS_access_cm_set_features_field (UINT8 enable, UINT8 feature)
To enable/disable a feature. More...
API_RESULT | MS_access_cm_get_features_field (UINT8 *enable, UINT8 feature)
To get state of a feature. More...
API_RESULT | MS_access_cm_get_features (UINT8 *features)
To get state of all features. More...
API_RESULT | MS_access_cm_get_friendship_role (UINT8 *frnd_role)
To get friendship role of the node. More...
API_RESULT | MS_access_cm_set_friendship_role (UINT8 frnd_role)
To set friendship role of the node. More...
API_RESULT | MS_access_cm_add_device_key (UINT8 *dev_key, MS_NET_ADDR uaddr, UINT8 num_elements)
To add Device Key. More...
API_RESULT | MS_access_cm_get_device_key (UINT8 dev_key_index, UINT8 **dev_key)
To get Device Key. More...
API_RESULT | MS_access_cm_remove_all_device_keys (void)
To remove all Device Keys. More...
API_RESULT | MS_access_cm_get_prov_devices_list (MS_PROV_DEV_ENTRY *prov_dev_list, UINT16 *num_entries)
To get list of Provisioned Device List. More...
API_RESULT | MS_access_cm_get_device_key_handle (MS_NET_ADDR prim_elem_uaddr, MS_ACCESS_DEV_KEY_HANDLE *handle)
To get Device Key Handle. More...
API_RESULT | MS_access_cm_get_app_key (MS_APPKEY_HANDLE appkey_handle, UINT8 **app_key, UINT8 *aid)
To get AppKey. More...
API_RESULT | MS_access_cm_add_update_netkey (UINT16 netkey_index, UINT32 opcode, UINT8 *net_key)
To add/update NetKey. More...
API_RESULT | MS_access_cm_add_friend_sec_credential (MS_SUBNET_HANDLE subnet_handle, UINT16 friend_offset, MS_NET_ADDR lpn_addr, MS_NET_ADDR friend_addr, UINT16 lpn_counter, UINT16 friend_counter)
To add Security Credential of a LPN or the Friend. More...
API_RESULT | MS_access_cm_delete_friend_sec_credential (MS_SUBNET_HANDLE subnet_handle, UINT16 friend_index)
To delete the Security Credential of a LPN or the Friend. More...
API_RESULT | MS_access_cm_find_subnet (UINT16 netkey_index, MS_SUBNET_HANDLE *subnet_handle)
To find a Subnet associated with the NetKey. More...
API_RESULT | MS_access_cm_delete_netkey (MS_SUBNET_HANDLE subnet_handle)
To delete NetKey. More...
API_RESULT | MS_access_cm_get_netkey (MS_SUBNET_HANDLE subnet_handle, UINT8 *net_key)
To get NetKey. More...
API_RESULT | MS_access_cm_get_netkey_index_list (UINT16 *netkey_count, UINT16 *netkey_index_list)
To get list of all known NetKeys. More...
API_RESULT | MS_access_cm_lookup_nid (UINT8 nid, MS_SUBNET_HANDLE *subnet_handle, UINT8 *privacy_key, UINT8 *encrypt_key)
To search for NID. More...
API_RESULT | MS_access_cm_lookup_network_id (UINT8 *network_id, MS_SUBNET_HANDLE *subnet_handle, UINT8 *beacon_key, UINT8 *is_new_key)
To search for Network ID. More...
API_RESULT | MS_access_cm_lookup_aid (UINT8 aid, MS_APPKEY_HANDLE *appkey_handle, UINT8 *app_key)
To search for AID. More...
API_RESULT | MS_access_cm_set_prov_data (PROV_DATA_S *prov_data)
Set Provisioning Data. More...
API_RESULT | MS_access_cm_get_subnet_nid (MS_SUBNET_HANDLE handle, UINT8 *nid)
To get NID associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_privacy_key (MS_SUBNET_HANDLE handle, UINT8 *privacy_key)
To get Privacy Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_network_id (MS_SUBNET_HANDLE handle, UINT8 *network_id)
To get Network ID associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_beacon_key (MS_SUBNET_HANDLE handle, UINT8 *beacon_key)
To get Beacon Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_identity_key (MS_SUBNET_HANDLE handle, UINT8 *identity_key)
To get Identity Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_subnet_encryption_key (MS_SUBNET_HANDLE handle, UINT8 *encrypt_key)
To get Encryption Key associated with a subnet. More...
API_RESULT | MS_access_cm_get_node_identity (MS_SUBNET_HANDLE subnet_handle, UINT8 *id_state)
To get Node Identity. More...
API_RESULT | MS_access_cm_set_node_identity (MS_SUBNET_HANDLE subnet_handle, UINT8 *id_state)
To set Node Identity. More...
API_RESULT | MS_access_cm_get_key_refresh_phase (MS_SUBNET_HANDLE subnet_handle, UINT8 *key_refresh_state)
To get Key Refresh Phase. More...
API_RESULT | MS_access_cm_set_key_refresh_phase (MS_SUBNET_HANDLE subnet_handle, UINT8 *key_refresh_state)
To set Key Refresh Phase. More...
API_RESULT | MS_access_cm_set_transmit_state (UINT8 tx_state_type, UINT8 tx_state)
To set Network/Relay Transmit state. More...
API_RESULT | MS_access_cm_get_transmit_state (UINT8 tx_state_type, UINT8 *tx_state)
To get Network/Relay Transmit state. More...
API_RESULT | MS_access_cm_add_appkey (MS_SUBNET_HANDLE subnet_handle, UINT16 appkey_index, UINT8 *app_key)
To add AppKey. More...
API_RESULT | MS_access_cm_update_delete_appkey (MS_SUBNET_HANDLE subnet_handle, UINT16 appkey_index, UINT32 opcode, UINT8 *app_key)
To update/delete AppKey. More...
API_RESULT | MS_access_cm_get_appkey_handle (MS_SUBNET_HANDLE subnet_handle, UINT16 appkey_index, UINT8 *app_key, MS_APPKEY_HANDLE *appkey_handle)
To get AppKey Handle for a given AppKey Index. More...
API_RESULT | MS_access_cm_get_appkey_index_list (MS_SUBNET_HANDLE subnet_handle, UINT16 *appkey_count, UINT16 *appkey_index_list)
To get list of all known AppKeys. More...
API_RESULT | MS_access_bind_model_app (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 appkey_index)
To bind a model with an AppKey. More...
API_RESULT | MS_access_unbind_model_app (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 appkey_index)
To unbind a model with an AppKey. More...
API_RESULT | MS_access_cm_get_model_app_list (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 *appkey_count, UINT16 *appkey_index_list)
To get list of all AppKeys associated with a model. More...
API_RESULT | MS_access_cm_set_model_publication (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_PUBLISH_INFO *publish_info)
To set Publication information associated with a model. More...
API_RESULT | MS_access_cm_get_model_publication (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_PUBLISH_INFO *publish_info)
To get Publication information associated with a model. More...
API_RESULT | MS_access_cm_add_model_subscription (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_ADDRESS *sub_addr)
To add an address to a model subscription list. More...
API_RESULT | MS_access_cm_delete_model_subscription (MS_ACCESS_MODEL_HANDLE model_handle, MS_ACCESS_ADDRESS *sub_addr)
To delete an address to a model subscription list. More...
API_RESULT | MS_access_cm_delete_all_model_subscription (MS_ACCESS_MODEL_HANDLE model_handle)
To discard a model subscription list. More...
API_RESULT | MS_access_cm_get_model_subscription_list (MS_ACCESS_MODEL_HANDLE model_handle, UINT16 *sub_addr_count, UINT16 *sub_addr_list)
To get list of subscription addresses of a model. More...
API_RESULT | MS_access_cm_get_all_model_subscription_list (UINT16 *sub_addr_count, UINT16 *sub_addr_list)
To get list of subscription addresses of all the models. More...
API_RESULT | MS_access_is_valid_element_address (MS_NET_ADDR addr)
To check if valid element address to receive a packet. More...
API_RESULT | MS_access_is_fixed_group_addr_to_be_processed (MS_NET_ADDR addr)
To check if Fixed Group Address in receive packet to be processed. More...
API_RESULT | MS_access_is_valid_subscription_address (MS_NET_ADDR addr)
To check if valid subscription address to receive a packet. More...

Detailed Description

This file defines the Mesh Access Application Interface - includes Data Structures and Methods.

Definition in file MS_access_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_assigned_numbers.h File Reference

  • mesh
  • export
  • include
Macros
MS_assigned_numbers.h File Reference

This header file describes various definitions from the Mesh Assigned Numbers Specification. More...

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Macros

#define | MESH_PROVISIONING_SERVICE 0x1827
Service UUIDs. More...
#define | MESH_PROXY_SERVICE 0x1828
Mesh Proxy Service.
#define | MESH_CH_PROVISIONING_DATA_IN 0x2ADB
Characteristic UUIDs.
#define | MESH_CH_PROVISIONING_DATA_OUT 0x2ADC
#define | MESH_CH_PROXY_DATA_IN 0x2ADD
#define | MESH_CH_PROXY_DATA_OUT 0x2ADE
#define | MESH_AD_TYPE_PB_ADV 0x29
Advertising Type.
#define | MESH_AD_TYPE_PKT 0x2A
#define | MESH_AD_TYPE_BCON 0x2B
#define | MESH_GATT_TYPE_NETWORK 0x00
GATT PDU Types.
#define | MESH_GATT_TYPE_BEACON 0x01
#define | MESH_GATT_TYPE_PROXY 0x02
#define | MESH_GATT_TYPE_PROV 0x03
#define | MESH_GATT_SAR_COMPLETE 0x00
GATT Segmentation & Reassembly (SAR) constants.
#define | MESH_GATT_SAR_START 0x01
#define | MESH_GATT_SAR_CONTINUE 0x02
#define | MESH_GATT_SAR_END 0x03
#define | MESH_MODEL_CONFIG 0x7FB0
Model Identifiers.
#define | MESH_MODEL_NET_MGMT 0x7FB1
#define | MESH_MODEL_PROVISIONING 0x7FB2
#define | MESH_MODEL_PING 0x7FB3
#define | MS_MODEL_ID_CONFIG_SERVER 0x0000
SIG defined model IDs. More...
#define | MS_MODEL_ID_CONFIG_CLIENT 0x0001
Model ID - Config Client.
#define | MS_MODEL_ID_HEALTH_SERVER 0x0002
Model ID - Health Server.
#define | MS_MODEL_ID_HEALTH_CLIENT 0x0003
Model ID - Health Client.
#define | MS_MODEL_ID_GENERIC_ONOFF_SERVER 0x1000
Generic. More...
#define | MS_MODEL_ID_GENERIC_ONOFF_CLIENT 0x1001
Model ID - Generic OnOff Client.
#define | MS_ACCESS_MODEL_TYPE_SIG 0x00
Model type definitions.
#define | MS_ACCESS_MODEL_TYPE_VENDOR 0x01
#define | MS_NONCE_T_NETWORK 0x00
Mesh Nonce Types.
#define | MS_NONCE_T_APPLICATION 0x01
#define | MS_NONCE_T_DEVICE 0x02
#define | MS_NONCE_T_PROXY 0x03
#define | MS_ACCESS_CONFIG_APPKEY_ADD_OPCODE 0x00
Opcode definitions for the Foundation Model. More...
#define | MS_ACCESS_CONFIG_APPKEY_UPDATE_OPCODE 0x01
#define | MS_ACCESS_CONFIG_COMPOSITION_DATA_STATUS_OPCODE 0x02
#define | MS_ACCESS_CONFIG_MODEL_PUBLICATION_SET_OPCODE 0x03
#define | MS_ACCESS_HEALTH_CURRENT_STATUS_OPCODE 0x04
#define | MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE 0x05
#define | MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_STATUS_OPCODE 0x06
#define | MS_ACCESS_CONFIG_APPKEY_DELETE_OPCODE 0x8000
16-bit Opcodes of Model specific messages More...
#define | MS_ACCESS_CONFIG_APPKEY_GET_OPCODE 0x8001
Config AppKey Get Opcode.
#define | MS_ACCESS_CONFIG_APPKEY_LIST_OPCODE 0x8002
Config AppKey List Opcode.
#define | MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE 0x8003
Config AppKey Status Opcode.
#define | MS_ACCESS_HEALTH_ATTENTION_GET_OPCODE 0x8004
Health Attention Get Opcode.
#define | MS_ACCESS_HEALTH_ATTENTION_SET_OPCODE 0x8005
Health Attention Set Opcode.
#define | MS_ACCESS_HEALTH_ATTENTION_SET_UNACKNOWLEDGED_OPCODE 0x8006
Health Attention Set Unacknowledged Opcode.
#define | MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE 0x8007
Health Attention Status Opcode.
#define | MS_ACCESS_CONFIG_COMPOSITION_DATA_GET_OPCODE 0x8008
Config Composition Data Get Opcode.
#define | MS_ACCESS_CONFIG_BEACON_GET_OPCODE 0x8009
Config Beacon Get Opcode.
#define | MS_ACCESS_CONFIG_BEACON_SET_OPCODE 0x800A
Config Beacon Set Opcode.
#define | MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE 0x800B
Config Beacon Status Opcode.
#define | MS_ACCESS_CONFIG_DEFAULT_TTL_GET_OPCODE 0x800C
Config Deafault TTL Get Opcode.
#define | MS_ACCESS_CONFIG_DEFAULT_TTL_SET_OPCODE 0x800D
Config Deafault TTL Set Opcode.
#define | MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE 0x800E
Config Deafault TTL Status Opcode.
#define | MS_ACCESS_CONFIG_FRIEND_GET_OPCODE 0x800F
Config Friend Get Opcode.
#define | MS_ACCESS_CONFIG_FRIEND_SET_OPCODE 0x8010
Config Friend Set Opcode.
#define | MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE 0x8011
Config Friend Status Opcode.
#define | MS_ACCESS_CONFIG_GATT_PROXY_GET_OPCODE 0x8012
Config GATT Proxy Get Opcode.
#define | MS_ACCESS_CONFIG_GATT_PROXY_SET_OPCODE 0x8013
Config GATT Proxy Set Opcode.
#define | MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE 0x8014
Config GATT Proxy Status Opcode.
#define | MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_GET_OPCODE 0x8015
Config Key Refresh Phase Get Opcode.
#define | MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_SET_OPCODE 0x8016
Config Key Refresh Phase Set Opcode.
#define | MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE 0x8017
Config Key Refresh Phase Status Opcode.
#define | MS_ACCESS_CONFIG_MODEL_PUBLICATION_GET_OPCODE 0x8018
Config Model Publication Get Opcode.
#define | MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE 0x8019
Config Model Publication Status Opcode.
#define | MS_ACCESS_CONFIG_MODEL_PUBLICATION_VIRTUAL_ADDRESS_SET_OPCODE 0x801A
Config Model Publication Virtual Address Set Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_ADD_OPCODE 0x801B
Config Model Subscription Add Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_OPCODE 0x801C
Config Model Subscription Delete Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_ALL_OPCODE 0x801D
Config Model Subscription Delete All Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_OVERWRITE_OPCODE 0x801E
Config Model Subscription Overwrite Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE 0x801F
Config Model Subscription Status Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_ADD_OPCODE 0x8020
Config Model Subscription Virtual Address Add Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_DELETE_OPCODE 0x8021
Config Model Subscription Virtual Address Delete Opcode.
#define | MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_OVERWRITE_OPCODE 0x8022
Config Model Subscription Virtual Address Overwrite Opcode.
#define | MS_ACCESS_CONFIG_NETWORK_TRANSMIT_GET_OPCODE 0x8023
Config Network Transmit Get Opcode.
#define | MS_ACCESS_CONFIG_NETWORK_TRANSMIT_SET_OPCODE 0x8024
Config Network Transmit Set Opcode.
#define | MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE 0x8025
Config Network Transmit Status Opcode.
#define | MS_ACCESS_CONFIG_RELAY_GET_OPCODE 0x8026
Config Relay Get Opcode.
#define | MS_ACCESS_CONFIG_RELAY_SET_OPCODE 0x8027
Config Relay Set Opcode.
#define | MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE 0x8028
Config Relay Status Opcode.
#define | MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_GET_OPCODE 0x8029
Config SIG Model Subscription Get Opcode.
#define | MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_LIST_OPCODE 0x802A
Config SIG Model Subscription List Opcode.
#define | MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_GET_OPCODE 0x802B
Config Vendor Model Subscription Get Opcode.
#define | MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_LIST_OPCODE 0x802C
Config Vendor Model Subscription List Opcode.
#define | MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_GET_OPCODE 0x802D
Config Low Power Node PollTimeout Get Opcode.
#define | MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_STATUS_OPCODE 0x802E
Config Low Power Node PollTimeout Status Opcode.
#define | MS_ACCESS_HEALTH_FAULT_CLEAR_OPCODE 0x802F
Health Fault Clear Opcode.
#define | MS_ACCESS_HEALTH_FAULT_CLEAR_UNACKNOWLEDGED_OPCODE 0x8030
Health Fault Clear Unacknowledged Opcode.
#define | MS_ACCESS_HEALTH_FAULT_GET_OPCODE 0x8031
Health Fault Get Opcode.
#define | MS_ACCESS_HEALTH_FAULT_TEST_OPCODE 0x8032
Health Fault Test Opcode.
#define | MS_ACCESS_HEALTH_FAULT_TEST_UNACKNOWLEDGED_OPCODE 0x8033
Health Fault Test Unacknowledged Opcode.
#define | MS_ACCESS_HEALTH_PERIOD_GET_OPCODE 0x8034
Health Period Get Opcode.
#define | MS_ACCESS_HEALTH_PERIOD_SET_OPCODE 0x8035
Health Period Set Opcode.
#define | MS_ACCESS_HEALTH_PERIOD_SET_UNACKNOWLEDGED_OPCODE 0x8036
Health Period Set Unacknowledged Opcode.
#define | MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE 0x8037
Health Period Status Opcode.
#define | MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_GET_OPCODE 0x8038
Config Heartbeat Publication Get Opcode.
#define | MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_SET_OPCODE 0x8039
Config Heartbeat Publication Set Opcode.
#define | MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_GET_OPCODE 0x803A
Config Heartbeat Subscription Get Opcode.
#define | MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_SET_OPCODE 0x803B
Config Heartbeat Subscription Set Opcode.
#define | MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE 0x803C
Config Heartbeat Subscription Status Opcode.
#define | MS_ACCESS_CONFIG_MODEL_APP_BIND_OPCODE 0x803D
Config Model App Bind Opcode.
#define | MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE 0x803E
Config Model App Status Opcode.
#define | MS_ACCESS_CONFIG_MODEL_APP_UNBIND_OPCODE 0x803F
Config Model App Unbind Opcode.
#define | MS_ACCESS_CONFIG_NETKEY_ADD_OPCODE 0x8040
Config NetKey Add Opcode.
#define | MS_ACCESS_CONFIG_NETKEY_DELETE_OPCODE 0x8041
Config NetKey Delete Opcode.
#define | MS_ACCESS_CONFIG_NETKEY_GET_OPCODE 0x8042
Config NetKey Get Opcode.
#define | MS_ACCESS_CONFIG_NETKEY_LIST_OPCODE 0x8043
Config NetKey List Opcode.
#define | MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE 0x8044
Config NetKey Status Opcode.
#define | MS_ACCESS_CONFIG_NETKEY_UPDATE_OPCODE 0x8045
Config NetKey Update Opcode.
#define | MS_ACCESS_CONFIG_NODE_IDENTITY_GET_OPCODE 0x8046
Config Node Identity Get Opcode.
#define | MS_ACCESS_CONFIG_NODE_IDENTITY_SET_OPCODE 0x8047
Config Node Identity Set Opcode.
#define | MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE 0x8048
Config Node Identity Status Opcode.
#define | MS_ACCESS_CONFIG_NODE_RESET_OPCODE 0x8049
Config Node Reset Opcode.
#define | MS_ACCESS_CONFIG_NODE_RESET_STATUS_OPCODE 0x804A
Config Node Reset Status Opcode.
#define | MS_ACCESS_CONFIG_SIG_MODEL_APP_GET_OPCODE 0x804B
Config SIG Model App Get Opcode.
#define | MS_ACCESS_CONFIG_SIG_MODEL_APP_LIST_OPCODE 0x804C
Config SIG Model App List Opcode.
#define | MS_ACCESS_CONFIG_VENDOR_MODEL_APP_GET_OPCODE 0x804D
Config Vendor Model App Get Opcode.
#define | MS_ACCESS_CONFIG_VENDOR_MODEL_APP_LIST_OPCODE 0x804E
Config Vendor Model App List Opcode.
#define | MS_ACCESS_GENERIC_ONOFF_GET_OPCODE 0x8201
Generic OnOff. More...
#define | MS_ACCESS_GENERIC_ONOFF_SET_OPCODE 0x8202
Generic OnOff Set Opcode.
#define | MS_ACCESS_GENERIC_ONOFF_SET_UNACKNOWLEDGED_OPCODE 0x8203
Generic OnOff Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE 0x8204
Generic OnOff Status Opcode.
#define | MS_ACCESS_GENERIC_LEVEL_GET_OPCODE 0x8205
Generic Level. More...
#define | MS_ACCESS_GENERIC_LEVEL_SET_OPCODE 0x8206
Generic Level Set Opcode.
#define | MS_ACCESS_GENERIC_LEVEL_SET_UNACKNOWLEDGED_OPCODE 0x8207
Generic Level Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE 0x8208
Generic Level Status Opcode.
#define | MS_ACCESS_GENERIC_DELTA_SET_OPCODE 0x8209
Generic Delta Set Opcode.
#define | MS_ACCESS_GENERIC_DELTA_SET_UNACKNOWLEDGED_OPCODE 0x820A
Generic Delta Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_MOVE_SET_OPCODE 0x820B
Generic Move Set Opcode.
#define | MS_ACCESS_GENERIC_MOVE_SET_UNACKNOWLEDGED_OPCODE 0x820C
Generic Move Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_GET_OPCODE 0x820D
Generic Default Transition Time. More...
#define | MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_OPCODE 0x820E
Generic Default Transition Time Set Opcode.
#define | MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_UNACKNOWLEDGED_OPCODE 0x820F
Generic Default Transition Time Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE 0x8210
Generic Default Transition Time Status Opcode.
#define | MS_ACCESS_GENERIC_ONPOWERUP_GET_OPCODE 0x8211
Generic Power OnOff. More...
#define | MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE 0x8212
Generic Power OnOff Status Opcode.
#define | MS_ACCESS_GENERIC_ONPOWERUP_SET_OPCODE 0x8213
Generic Power OnOff Setup. More...
#define | MS_ACCESS_GENERIC_ONPOWERUP_SET_UNACKNOWLEDGED_OPCODE 0x8214
Generic Power OnOff Setup Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_POWER_LEVEL_GET_OPCODE 0x8215
Generic Power Level. More...
#define | MS_ACCESS_GENERIC_POWER_LEVEL_SET_OPCODE 0x8216
Generic Power Level Set Opcode.
#define | MS_ACCESS_GENERIC_POWER_LEVEL_SET_UNACKNOWLEDGED_OPCODE 0x8217
Generic Power Level Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE 0x8218
Generic Power Level Status Opcode.
#define | MS_ACCESS_GENERIC_POWER_LAST_GET_OPCODE 0x8219
Generic Power Last Get Opcode.
#define | MS_ACCESS_GENERIC_POWER_LAST_STATUS_OPCODE 0x821A
Generic Power Last Status Opcode.
#define | MS_ACCESS_GENERIC_POWER_DEFAULT_GET_OPCODE 0x821B
Generic Power Default Get Opcode.
#define | MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE 0x821C
Generic Power Default Status Opcode.
#define | MS_ACCESS_GENERIC_POWER_RANGE_GET_OPCODE 0x821D
Generic Power Range Get Opcode.
#define | MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE 0x821E
Generic Power Range Status Opcode.
#define | MS_ACCESS_GENERIC_POWER_DEFAULT_SET_OPCODE 0x821F
Generic Power Level Setup. More...
#define | MS_ACCESS_GENERIC_POWER_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x8220
Generic Power Default Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_POWER_RANGE_SET_OPCODE 0x8221
Generic Power Range Set Opcode.
#define | MS_ACCESS_GENERIC_POWER_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x8222
Generic Power Range Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_BATTERY_GET_OPCODE 0x8223
Generic Battery. More...
#define | MS_ACCESS_GENERIC_BATTERY_STATUS_OPCODE 0x8224
Generic Battery Status Opcode.
#define | MS_ACCESS_GENERIC_LOCATION_GLOBAL_GET_OPCODE 0x8225
Generic Location. More...
#define | MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE 0x40
Generic Location Global Status Opcode.
#define | MS_ACCESS_GENERIC_LOCATION_LOCAL_GET_OPCODE 0x8226
Generic Location Local Get Opcode.
#define | MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE 0x8227
Generic Location Local Status Opcode.
#define | MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_OPCODE 0x41
Generic Location Setup. More...
#define | MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_UNACKNOWLEDGED_OPCODE 0x42
Generic Location Global Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_OPCODE 0x8228
Generic Location Local Set Opcode.
#define | MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_UNACKNOWLEDGED_OPCODE 0x8229
Generic Location Local Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_GET_OPCODE 0x822A
Generic Manufacturer Property. More...
#define | MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_OPCODE 0x43
Generic Manufacturer Properties Status Opcode.
#define | MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_GET_OPCODE 0x822B
Generic Manufacturer Property Get Opcode.
#define | MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_OPCODE 0x44
Generic Manufacturer Property Set Opcode.
#define | MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x45
Generic Manufacturer Property Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE 0x46
Generic Manufacturer Property Status Opcode.
#define | MS_ACCESS_GENERIC_ADMIN_PROPERTIES_GET_OPCODE 0x822C
Generic Admin Property. More...
#define | MS_ACCESS_GENERIC_ADMIN_PROPERTIES_STATUS_OPCODE 0x47
Generic Admin Properties Status Opcode.
#define | MS_ACCESS_GENERIC_ADMIN_PROPERTY_GET_OPCODE 0x822D
Generic Admin Property Get Opcode.
#define | MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_OPCODE 0x48
Generic Admin Property Set Opcode.
#define | MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x49
Generic Admin Property Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE 0x4A
Generic Admin Property Status Opcode.
#define | MS_ACCESS_GENERIC_USER_PROPERTIES_GET_OPCODE 0x822E
Generic User Property. More...
#define | MS_ACCESS_GENERIC_USER_PROPERTIES_STATUS_OPCODE 0x4B
Generic User Properties Status Opcode.
#define | MS_ACCESS_GENERIC_USER_PROPERTY_GET_OPCODE 0x822F
Generic User Property Get Opcode.
#define | MS_ACCESS_GENERIC_USER_PROPERTY_SET_OPCODE 0x4C
Generic User Property Set Opcode.
#define | MS_ACCESS_GENERIC_USER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x4D
Generic User Property Set Unacknowledged Opcode.
#define | MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE 0x4E
Generic User Property Status Opcode.
#define | MS_ACCESS_GENERIC_CLIENT_PROPERTIES_GET_OPCODE 0x4F
Generic Client Property. More...
#define | MS_ACCESS_GENERIC_CLIENT_PROPERTIES_STATUS_OPCODE 0x50
Generic Client Properties Status Opcode.
#define | MS_ACCESS_SENSOR_DESCRIPTOR_GET_OPCODE 0x8230
Sensor. More...
#define | MS_ACCESS_SENSOR_DESCRIPTOR_STATUS_OPCODE 0x51
Sensor Descriptor Status Opcode.
#define | MS_ACCESS_SENSOR_GET_OPCODE 0x8231
Sensor Get Opcode.
#define | MS_ACCESS_SENSOR_STATUS_OPCODE 0x52
Sensor Status Opcode.
#define | MS_ACCESS_SENSOR_COLUMN_GET_OPCODE 0x8232
Sensor Column Get Opcode.
#define | MS_ACCESS_SENSOR_COLUMN_STATUS_OPCODE 0x53
Sensor Column Status Opcode.
#define | MS_ACCESS_SENSOR_SERIES_GET_OPCODE 0x8233
Sensor Series Get Opcode.
#define | MS_ACCESS_SENSOR_SERIES_STATUS_OPCODE 0x54
Sensor Series Status Opcode.
#define | MS_ACCESS_SENSOR_CADENCE_GET_OPCODE 0x8234
Sensor Setup. More...
#define | MS_ACCESS_SENSOR_CADENCE_SET_OPCODE 0x55
Sensor Cadence Set Opcode.
#define | MS_ACCESS_SENSOR_CADENCE_SET_UNACKNOWLEDGED_OPCODE 0x56
Sensor Cadence Set Unacknowledged Opcode.
#define | MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE 0x57
Sensor Cadence Status Opcode.
#define | MS_ACCESS_SENSOR_SETTINGS_GET_OPCODE 0x8235
Sensor Settings Get Opcode.
#define | MS_ACCESS_SENSOR_SETTINGS_STATUS_OPCODE 0x58
Sensor Settings Status Opcode.
#define | MS_ACCESS_SENSOR_SETTING_GET_OPCODE 0x8236
Sensor Setting Get Opcode.
#define | MS_ACCESS_SENSOR_SETTING_SET_OPCODE 0x59
Sensor Setting Set Opcode.
#define | MS_ACCESS_SENSOR_SETTING_SET_UNACKNOWLEDGED_OPCODE 0x5A
Sensor Setting Set Unacknowledged Opcode.
#define | MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE 0x5B
Sensor Setting Status Opcode.
#define | MS_ACCESS_TIME_GET_OPCODE 0x8237
Time. More...
#define | MS_ACCESS_TIME_SET_OPCODE 0x5C
Time Set Opcode.
#define | MS_ACCESS_TIME_STATUS_OPCODE 0x5D
Time Status Opcode.
#define | MS_ACCESS_TIME_ROLE_GET_OPCODE 0x8238
Time Role Get Opcode.
#define | MS_ACCESS_TIME_ROLE_SET_OPCODE 0x8239
Time Role Set Opcode.
#define | MS_ACCESS_TIME_ROLE_STATUS_OPCODE 0x823A
Time Role Status Opcode.
#define | MS_ACCESS_TIME_ZONE_GET_OPCODE 0x823B
Time Zone Get Opcode.
#define | MS_ACCESS_TIME_ZONE_SET_OPCODE 0x823C
Time Zone Set Opcode.
#define | MS_ACCESS_TIME_ZONE_STATUS_OPCODE 0x823D
Time Zone Status Opcode.
#define | MS_ACCESS_TAI_UTC_DELTA_GET_OPCODE 0x823E
Time - TAI UTC Delta Get Opcode.
#define | MS_ACCESS_TAI_UTC_DELTA_SET_OPCODE 0x823F
Time - TAI UTC Delta Set Opcode.
#define | MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE 0x8240
Time - TAI UTC Delta Status Opcode.
#define | MS_ACCESS_SCENE_GET_OPCODE 0x8241
Scene. More...
#define | MS_ACCESS_SCENE_RECALL_OPCODE 0x8242
Scene Recall Opcode.
#define | MS_ACCESS_SCENE_RECALL_UNACKNOWLEDGED_OPCODE 0x8243
Scene Recall Unacknowledged Opcode.
#define | MS_ACCESS_SCENE_STATUS_OPCODE 0x5E
Scene Status Opcode.
#define | MS_ACCESS_SCENE_REGISTER_GET_OPCODE 0x8244
Scene Register Get Opcode.
#define | MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE 0x8245
Scene Register Status Opcode.
#define | MS_ACCESS_SCENE_STORE_OPCODE 0x8246
Scene Setup. More...
#define | MS_ACCESS_SCENE_STORE_UNACKNOWLEDGED_OPCODE 0x8247
Scene Store Unacknowledged Opcode.
#define | MS_ACCESS_SCENE_DELETE_OPCODE 0x829E
Scene Delete Opcode.
#define | MS_ACCESS_SCENE_DELETE_UNACKNOWLEDGED_OPCODE 0x829F
Scene Delete Unacknowledged Opcode.
#define | MS_ACCESS_SCHEDULER_ACTION_GET_OPCODE 0x8248
Scheduler. More...
#define | MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE 0x5F
Scheduler Action Status Opcode.
#define | MS_ACCESS_SCHEDULER_GET_OPCODE 0x8249
Scheduler Get Opcode.
#define | MS_ACCESS_SCHEDULER_STATUS_OPCODE 0x824A
Scheduler Status Opcode.
#define | MS_ACCESS_SCHEDULER_ACTION_SET_OPCODE 0x60
Scheduler Setup. More...
#define | MS_ACCESS_SCHEDULER_ACTION_SET_UNACKNOWLEDGED_OPCODE 0x61
Scheduler Action Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_GET_OPCODE 0x824B
Light Lightness. More...
#define | MS_ACCESS_LIGHT_LIGHTNESS_SET_OPCODE 0x824C
Light Lightness Set Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_SET_UNACKNOWLEDGED_OPCODE 0x824D
Light Lightness Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE 0x824E
Light Lightness Status Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_GET_OPCODE 0x824F
Light Lightness Linear Get Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_OPCODE 0x8250
Light Lightness Linear Set Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_UNACKNOWLEDGED_OPCODE 0x8251
Light Lightness Linear Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE 0x8252
Light Lightness Linear Status Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_LAST_GET_OPCODE 0x8253
Light Lightness Last Get Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_LAST_STATUS_OPCODE 0x8254
Light Lightness Last Status Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_GET_OPCODE 0x8255
Light Lightness Default Get Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE 0x8256
Light Lightness Default Status Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_RANGE_GET_OPCODE 0x8257
Light Lightness Range Get Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE 0x8258
Light Lightness Range Status Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_OPCODE 0x8259
Light Lightness Setup. More...
#define | MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x825A
Light Lightness Range Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_OPCODE 0x825B
Light Lightness Range Set Opcode.
#define | MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x825C
Light Lightness Range Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_CTL_GET_OPCODE 0x825D
Light CTL. More...
#define | MS_ACCESS_LIGHT_CTL_SET_OPCODE 0x825E
Light CTL Set Opcode.
#define | MS_ACCESS_LIGHT_CTL_SET_UNACKNOWLEDGED_OPCODE 0x825F
Light CTL Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_CTL_STATUS_OPCODE 0x8260
Light CTL Status Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_GET_OPCODE 0x8261
Light CTL Temperature Get Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_GET_OPCODE 0x8262
Light CTL Temperature Range Get Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE 0x8263
Light CTL Temperature Range Status Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_OPCODE 0x8264
Light CTL Temperature Set Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_UNACKNOWLEDGED_OPCODE 0x8265
Light CTL Temperature Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE 0x8266
Light CTL Temperature Status Opcode.
#define | MS_ACCESS_LIGHT_CTL_DEFAULT_GET_OPCODE 0x8267
Light CTL Default Get Opcode.
#define | MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE 0x8268
Light CTL Default Status Opcode.
#define | MS_ACCESS_LIGHT_CTL_DEFAULT_SET_OPCODE 0x8269
Light CTL Setup. More...
#define | MS_ACCESS_LIGHT_CTL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x826A
Light CTL Default Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_OPCODE 0x826B
Light CTL Default Range Set Opcode.
#define | MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x826C
Light CTL Default Range Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_HSL_GET_OPCODE 0x826D
Light HSL. More...
#define | MS_ACCESS_LIGHT_HSL_HUE_GET_OPCODE 0x826E
Light HSL HUE Get Opcode.
#define | MS_ACCESS_LIGHT_HSL_HUE_SET_OPCODE 0x826F
Light HSL HUE Set Opcode.
#define | MS_ACCESS_LIGHT_HSL_HUE_SET_UNACKNOWLEDGED_OPCODE 0x8270
Light HSL HUE Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE 0x8271
Light HSL HUE Status Opcode.
#define | MS_ACCESS_LIGHT_HSL_SATURATION_GET_OPCODE 0x8272
Light HSL Saturation Get Opcode.
#define | MS_ACCESS_LIGHT_HSL_SATURATION_SET_OPCODE 0x8273
Light HSL Saturation Set Opcode.
#define | MS_ACCESS_LIGHT_HSL_SATURATION_SET_UNACKNOWLEDGED_OPCODE 0x8274
Light HSL Saturation Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE 0x8275
Light HSL Saturation Status Opcode.
#define | MS_ACCESS_LIGHT_HSL_SET_OPCODE 0x8276
Light HSL Set Opcode.
#define | MS_ACCESS_LIGHT_HSL_SET_UNACKNOWLEDGED_OPCODE 0x8277
Light HSL Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_HSL_STATUS_OPCODE 0x8278
Light HSL Status Opcode.
#define | MS_ACCESS_LIGHT_HSL_TARGET_GET_OPCODE 0x8279
Light HSL Target Get Opcode.
#define | MS_ACCESS_LIGHT_HSL_TARGET_STATUS_OPCODE 0x827A
Light HSL Target Status Opcode.
#define | MS_ACCESS_LIGHT_HSL_DEFAULT_GET_OPCODE 0x827B
Light HSL Default Get Opcode.
#define | MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE 0x827C
Light HSL Default Status Opcode.
#define | MS_ACCESS_LIGHT_HSL_RANGE_GET_OPCODE 0x827D
Light HSL Range Get Opcode.
#define | MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE 0x827E
Light HSL Range Status Opcode.
#define | MS_ACCESS_LIGHT_HSL_DEFAULT_SET_OPCODE 0x827F
Light HSL Setup. More...
#define | MS_ACCESS_LIGHT_HSL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x8280
Light HSL Default Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_HSL_RANGE_SET_OPCODE 0x8281
Light HSL Range Set Opcode.
#define | MS_ACCESS_LIGHT_HSL_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x8282
Light HSL Range Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_XYL_GET_OPCODE 0x8283
Light xyL. More...
#define | MS_ACCESS_LIGHT_XYL_SET_OPCODE 0x8284
Light xyL Set Opcode.
#define | MS_ACCESS_LIGHT_XYL_SET_UNACKNOWLEDGED_OPCODE 0x8285
Light xyL Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_XYL_STATUS_OPCODE 0x8286
Light xyL Status Opcode.
#define | MS_ACCESS_LIGHT_XYL_TARGET_GET_OPCODE 0x8287
Light xyL Target Get Opcode.
#define | MS_ACCESS_LIGHT_XYL_TARGET_STATUS_OPCODE 0x8288
Light xyL Target Status Opcode.
#define | MS_ACCESS_LIGHT_XYL_DEFAULT_GET_OPCODE 0x8289
Light xyL Default Get Opcode.
#define | MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE 0x828A
Light xyL Default Status Opcode.
#define | MS_ACCESS_LIGHT_XYL_RANGE_GET_OPCODE 0x828B
Light xyL Range Get Opcode.
#define | MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE 0x828C
Light xyL Range Status Opcode.
#define | MS_ACCESS_LIGHT_XYL_DEFAULT_SET_OPCODE 0x828D
Light xyL Setup. More...
#define | MS_ACCESS_LIGHT_XYL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x828E
Light xyL Default Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_XYL_RANGE_SET_OPCODE 0x828F
Light xyL Range Set Opcode.
#define | MS_ACCESS_LIGHT_XYL_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x8290
Light xyL Range Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LC_MODE_GET_OPCODE 0x8291
Light Control. More...
#define | MS_ACCESS_LIGHT_LC_MODE_SET_OPCODE 0x8292
Light LC Mode Set Opcode.
#define | MS_ACCESS_LIGHT_LC_MODE_SET_UNACKNOWLEDGED_OPCODE 0x8293
Light LC Mode Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE 0x8294
Light LC Mode Status Opcode.
#define | MS_ACCESS_LIGHT_LC_OM_GET_OPCODE 0x8295
Light LC Occupancy Mode Get Opcode.
#define | MS_ACCESS_LIGHT_LC_OM_SET_OPCODE 0x8296
Light LC Occupancy Mode Set Opcode.
#define | MS_ACCESS_LIGHT_LC_OM_SET_UNACKNOWLEDGED_OPCODE 0x8297
Light LC Occupancy Mode Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE 0x8298
Light LC Occupancy Mode Status Opcode.
#define | MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_GET_OPCODE 0x8299
Light LC Light OnOff Get Opcode.
#define | MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_OPCODE 0x829A
Light LC Light OnOff Set Opcode.
#define | MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_UNACKNOWLEDGED_OPCODE 0x829B
Light LC Light OnOff Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE 0x829C
Light LC Light OnOff Status Opcode.
#define | MS_ACCESS_LIGHT_LC_PROPERTY_GET_OPCODE 0x829D
Light LC Property Get Opcode.
#define | MS_ACCESS_LIGHT_LC_PROPERTY_SET_OPCODE 0x62
Light LC Property Set Opcode.
#define | MS_ACCESS_LIGHT_LC_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x63
Light LC Property Set Unacknowledged Opcode.
#define | MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE 0x64
Light LC Property Status Opcode.
#define | MS_ACCESS_INVALID_OPCODE 0xFFFFFFFF
Invalid Opcode.
#define | MS_MODEL_ID_CONFIG_SERVER 0x0000
SIG defined model IDs. More...
#define | MS_MODEL_ID_CONFIG_CLIENT 0x0001
Model ID - Config Client.
#define | MS_MODEL_ID_HEALTH_SERVER 0x0002
Model ID - Health Server.
#define | MS_MODEL_ID_HEALTH_CLIENT 0x0003
Model ID - Health Client.
#define | MS_MODEL_ID_GENERIC_ONOFF_SERVER 0x1000
Generic. More...
#define | MS_MODEL_ID_GENERIC_ONOFF_CLIENT 0x1001
Model ID - Generic OnOff Client.
#define | MS_MODEL_ID_GENERIC_LEVEL_SERVER 0x1002
Model ID - Generic Level Server.
#define | MS_MODEL_ID_GENERIC_LEVEL_CLIENT 0x1003
Model ID - Generic Level Client.
#define | MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_SERVER 0x1004
Model ID - Generic Default Transition Time Server.
#define | MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT 0x1005
Model ID - Generic Default Transition Time Client.
#define | MS_MODEL_ID_GENERIC_POWER_ONOFF_SERVER 0x1006
Model ID - Generic Power OnOff Server.
#define | MS_MODEL_ID_GENERIC_POWER_ONOFF_SETUP_SERVER 0x1007
Model ID - Generic Power OnOff Setup Server.
#define | MS_MODEL_ID_GENERIC_POWER_ONOFF_CLIENT 0x1008
Model ID - Generic Power OnOff Client.
#define | MS_MODEL_ID_GENERIC_POWER_LEVEL_SERVER 0x1009
Model ID - Generic Power Level Server.
#define | MS_MODEL_ID_GENERIC_POWER_LEVEL_SETUP_SERVER 0x100A
Model ID - Generic Power Level Setup Server.
#define | MS_MODEL_ID_GENERIC_POWER_LEVEL_CLIENT 0x100B
Model ID - Generic Power Level Client.
#define | MS_MODEL_ID_GENERIC_BATTERY_SERVER 0x100C
Model ID - Generic Battery Server.
#define | MS_MODEL_ID_GENERIC_BATTERY_CLIENT 0x100D
Model ID - Generic Battery Client.
#define | MS_MODEL_ID_GENERIC_LOCATION_SERVER 0x100E
Model ID - Generic Location Server.
#define | MS_MODEL_ID_GENERIC_LOCATION_SETUP_SERVER 0x100F
Model ID - Generic Location Setup Server.
#define | MS_MODEL_ID_GENERIC_LOCATION_CLIENT 0x1010
Model ID - Generic Location Client.
#define | MS_MODEL_ID_GENERIC_ADMIN_PROPERTY_SERVER 0x1011
Model ID - Generic Admin Property Server.
#define | MS_MODEL_ID_GENERIC_MANUFACTURER_PROPERTY_SERVER 0x1012
Model ID - Generic Manufacturer Property Server.
#define | MS_MODEL_ID_GENERIC_USER_PROPERTY_SERVER 0x1013
Model ID - Generic User Property Server.
#define | MS_MODEL_ID_GENERIC_CLIENT_PROPERTY_SERVER 0x1014
Model ID - Generic Client Property Server.
#define | MS_MODEL_ID_GENERIC_PROPERTY_CLIENT 0x1015
Model ID - Generic Property Client.
#define | MS_MODEL_ID_SENSOR_SERVER 0x1100
Sensors. More...
#define | MS_MODEL_ID_SENSOR_SETUP_SERVER 0x1101
Model ID - Sensor Setup Server.
#define | MS_MODEL_ID_SENSOR_CLIENT 0x1102
Model ID - Sensor Client.
#define | MS_MODEL_ID_TIME_SERVER 0x1200
Time and Scenes. More...
#define | MS_MODEL_ID_TIME_SETUP_SERVER 0x1201
Model ID - Time Setup Server.
#define | MS_MODEL_ID_TIME_CLIENT 0x1202
Model ID - Time Client.
#define | MS_MODEL_ID_SCENE_SERVER 0x1203
Model ID - Scene Server.
#define | MS_MODEL_ID_SCENE_SETUP_SERVER 0x1204
Model ID - Scene Setup Server.
#define | MS_MODEL_ID_SCENE_CLIENT 0x1205
Model ID - Scene Client.
#define | MS_MODEL_ID_SCHEDULER_SERVER 0x1206
Model ID - Scheduler Server.
#define | MS_MODEL_ID_SCHEDULER_SETUP_SERVER 0x1207
Model ID - Scheduler Setup Server.
#define | MS_MODEL_ID_SCHEDULER_CLIENT 0x1208
Model ID - Scheduler Client.
#define | MS_MODEL_ID_LIGHT_LIGHTNESS_SERVER 0x1300
Lighting. More...
#define | MS_MODEL_ID_LIGHT_LIGHTNESS_SETUP_SERVER 0x1301
Model ID - Light Lightness Setup Server.
#define | MS_MODEL_ID_LIGHT_LIGHTNESS_CLIENT 0x1302
Model ID - Light Lightness Client.
#define | MS_MODEL_ID_LIGHT_CTL_SERVER 0x1303
Model ID - Light CTL Server.
#define | MS_MODEL_ID_LIGHT_CTL_SETUP_SERVER 0x1304
Model ID - Light CTL Setup Server.
#define | MS_MODEL_ID_LIGHT_CTL_CLIENT 0x1305
Model ID - Light CTL Client.
#define | MS_MODEL_ID_LIGHT_CTL_TEMPERATURE_SERVER 0x1306
Model ID - Light CTL Temperature Server.
#define | MS_MODEL_ID_LIGHT_HSL_SERVER 0x1307
Model ID - Light HSL Server.
#define | MS_MODEL_ID_LIGHT_HSL_SETUP_SERVER 0x1308
Model ID - Light HSL Setup Server.
#define | MS_MODEL_ID_LIGHT_HSL_CLIENT 0x1309
Model ID - Light HSL Client.
#define | MS_MODEL_ID_LIGHT_HSL_HUE_SERVER 0x130A
Model ID - Light HSL HUE Server.
#define | MS_MODEL_ID_LIGHT_HSL_SATURATION_SERVER 0x130B
Model ID - Light HSL Saturation Server.
#define | MS_MODEL_ID_LIGHT_XYL_SERVER 0x130C
Model ID - Light xyL Server.
#define | MS_MODEL_ID_LIGHT_XYL_SETUP_SERVER 0x130D
Model ID - Light xyL Setup Server.
#define | MS_MODEL_ID_LIGHT_XYL_CLIENT 0x130E
Model ID - Light xyL Client.
#define | MS_MODEL_ID_LIGHT_LC_SERVER 0x130F
Model ID - Light LC Server.
#define | MS_MODEL_ID_LIGHT_LC_SETUP_SERVER 0x1310
Model ID - Light LC Setup Server.
#define | MS_MODEL_ID_LIGHT_LC_CLIENT 0x1311
Model ID - Light LC Client.

Detailed Description

This header file describes various definitions from the Mesh Assigned Numbers Specification.

Definition in file MS_assigned_numbers.h.

Macro Definition Documentation

#define MESH_PROVISIONING_SERVICE 0x1827

Service UUIDs.

Mesh Provisioning Service

Definition at line 22 of file MS_assigned_numbers.h.

#define MS_MODEL_ID_CONFIG_SERVER 0x0000

SIG defined model IDs.

-------------------------------------------------------------------——— Model IDs

SIG defined model IDs Model ID - Config Server

Definition at line 704 of file MS_assigned_numbers.h.

#define MS_MODEL_ID_GENERIC_ONOFF_SERVER 0x1000

Generic.

Model ID - Generic OnOff Server

Definition at line 714 of file MS_assigned_numbers.h.

#define MS_ACCESS_CONFIG_APPKEY_ADD_OPCODE 0x00

Opcode definitions for the Foundation Model.

8-bit Opcodes of Model specific messages

Definition at line 77 of file MS_assigned_numbers.h.

#define MS_ACCESS_CONFIG_APPKEY_DELETE_OPCODE 0x8000

16-bit Opcodes of Model specific messages

Config AppKey Delete Opcode

Definition at line 87 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_ONOFF_GET_OPCODE 0x8201

Generic OnOff.

Generic OnOff Get Opcode

Definition at line 247 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_LEVEL_GET_OPCODE 0x8205

Generic Level.

Generic Level Get Opcode

Definition at line 257 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_GET_OPCODE 0x820D

Generic Default Transition Time.

Generic Default Transition Time Get Opcode

Definition at line 275 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_ONPOWERUP_GET_OPCODE 0x8211

Generic Power OnOff.

Generic Power OnOff Get Opcode

Definition at line 285 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_ONPOWERUP_SET_OPCODE 0x8213

Generic Power OnOff Setup.

Generic Power OnOff Setup Set Opcode

Definition at line 291 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_POWER_LEVEL_GET_OPCODE 0x8215

Generic Power Level.

Generic Power Level Get Opcode

Definition at line 297 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_POWER_DEFAULT_SET_OPCODE 0x821F

Generic Power Level Setup.

Generic Power Default Set Opcode

Definition at line 319 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_BATTERY_GET_OPCODE 0x8223

Generic Battery.

Generic Battery Get Opcode

Definition at line 329 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_LOCATION_GLOBAL_GET_OPCODE 0x8225

Generic Location.

Generic Location Global Get Opcode

Definition at line 335 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_OPCODE 0x41

Generic Location Setup.

Generic Location Global Set Opcode

Definition at line 345 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_GET_OPCODE 0x822A

Generic Manufacturer Property.

Generic Manufacturer Properties Get Opcode

Definition at line 355 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_ADMIN_PROPERTIES_GET_OPCODE 0x822C

Generic Admin Property.

Generic Admin Properties Get Opcode

Definition at line 369 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_USER_PROPERTIES_GET_OPCODE 0x822E

Generic User Property.

Generic User Properties Get Opcode

Definition at line 383 of file MS_assigned_numbers.h.

#define MS_ACCESS_GENERIC_CLIENT_PROPERTIES_GET_OPCODE 0x4F

Generic Client Property.

Generic Client Properties Get Opcode

Definition at line 397 of file MS_assigned_numbers.h.

#define MS_ACCESS_SENSOR_DESCRIPTOR_GET_OPCODE 0x8230

Sensor.

Sensor Descriptor Get Opcode

Definition at line 403 of file MS_assigned_numbers.h.

#define MS_ACCESS_SENSOR_CADENCE_GET_OPCODE 0x8234

Sensor Setup.

Sensor Cadence Get Opcode

Definition at line 421 of file MS_assigned_numbers.h.

#define MS_ACCESS_TIME_GET_OPCODE 0x8237

Time.

Time Get Opcode

Definition at line 443 of file MS_assigned_numbers.h.

#define MS_ACCESS_SCENE_GET_OPCODE 0x8241

Scene.

Scene Get Opcode

Definition at line 469 of file MS_assigned_numbers.h.

#define MS_ACCESS_SCENE_STORE_OPCODE 0x8246

Scene Setup.

Scene Store Opcode

Definition at line 483 of file MS_assigned_numbers.h.

#define MS_ACCESS_SCHEDULER_ACTION_GET_OPCODE 0x8248

Scheduler.

Scheduler Action Get Opcode

Definition at line 493 of file MS_assigned_numbers.h.

#define MS_ACCESS_SCHEDULER_ACTION_SET_OPCODE 0x60

Scheduler Setup.

Scheduler Action Set Opcode

Definition at line 503 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_LIGHTNESS_GET_OPCODE 0x824B

Light Lightness.

Light Lightness Get Opcode

Definition at line 509 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_OPCODE 0x8259

Light Lightness Setup.

Light Lightness Range Set Opcode

Definition at line 539 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_CTL_GET_OPCODE 0x825D

Light CTL.

Light CTL Get Opcode

Definition at line 549 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_CTL_DEFAULT_SET_OPCODE 0x8269

Light CTL Setup.

Light CTL Default Set Opcode

Definition at line 575 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_HSL_GET_OPCODE 0x826D

Light HSL.

Light HSL Get Opcode

Definition at line 585 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_HSL_DEFAULT_SET_OPCODE 0x827F

Light HSL Setup.

Light HSL Default Set Opcode

Definition at line 623 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_XYL_GET_OPCODE 0x8283

Light xyL.

Light xyL Get Opcode

Definition at line 633 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_XYL_DEFAULT_SET_OPCODE 0x828D

Light xyL Setup.

Light xyL Default Set Opcode

Definition at line 655 of file MS_assigned_numbers.h.

#define MS_ACCESS_LIGHT_LC_MODE_GET_OPCODE 0x8291

Light Control.

Light LC Mode Get Opcode

Definition at line 665 of file MS_assigned_numbers.h.

#define MS_MODEL_ID_CONFIG_SERVER 0x0000

SIG defined model IDs.

-------------------------------------------------------------------——— Model IDs

SIG defined model IDs Model ID - Config Server

Definition at line 704 of file MS_assigned_numbers.h.

#define MS_MODEL_ID_GENERIC_ONOFF_SERVER 0x1000

Generic.

Model ID - Generic OnOff Server

Definition at line 714 of file MS_assigned_numbers.h.

#define MS_MODEL_ID_SENSOR_SERVER 0x1100

Sensors.

Model ID - Sensor Server

Definition at line 760 of file MS_assigned_numbers.h.

#define MS_MODEL_ID_TIME_SERVER 0x1200

Time and Scenes.

Model ID - Time Server

Definition at line 768 of file MS_assigned_numbers.h.

#define MS_MODEL_ID_LIGHT_LIGHTNESS_SERVER 0x1300

Lighting.

Model ID - Light Lightness Server

Definition at line 788 of file MS_assigned_numbers.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_brr_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Enumerations | Functions
MS_brr_api.h File Reference

This file defines the Mesh Bearer Application Interface - includes Data Structures and Methods. More...

#include "MS_common.h"
Include dependency graph for MS_brr_api.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | BRR_BEARER_INFO
Bearer information to register. More...
struct | BRR_BEACON_INFO
Bearer Beacon type data structure. More...
struct | BRR_BEARER_CH_INFO
Bearer GATT Channel informartion related data structure. More...

Macros

#define | BRR_HANDLE_INVALID 0xFF
Invalid Bearer handle identifier.
#define | BRR_IFACE_DOWN 0x00
Bearer Interface events to the above layer.
#define | BRR_IFACE_UP 0x01
#define | BRR_IFACE_DATA 0x02
#define | BRR_IFACE_PROXY_DATA 0x03
#define | BRR_BCON_PASSIVE 0x00
Bearer beacon types - Connectable (Active) and Non-Connectable (Passive)
#define | BRR_BCON_ACTIVE 0x01
#define | BRR_BROADCAST 0x00
Bearer Beacon Operations - Broadcast/Observe.
#define | BRR_OBSERVE 0x01
#define | BRR_DISABLE 0x00
Bearer Beacon Actions - Enable/Disable.
#define | BRR_ENABLE 0x01
#define | BRR_MAX_PDU_SIZE 65
Maximum PDU size for data received over bearer.
#define | BRR_CLIENT_ROLE 0x00
Bearer Server Client Roles.
#define | BRR_SERVER_ROLE 0x01
#define | BRR_INVALID_ROLE 0xFF
#define | BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET 6
#define | BRR_SUBTYPE_GATT_T_MASK (0xC0)
#define | BRR_SUBTYPE_GATT_NETWORK_T_MASK ((MESH_GATT_TYPE_NETWORK << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
#define | BRR_SUBTYPE_GATT_BEACON_T_MASK ((MESH_GATT_TYPE_BEACON << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
#define | BRR_SUBTYPE_GATT_PROXY_T_MASK ((MESH_GATT_TYPE_PROXY << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
#define | BRR_SUBTYPE_GATT_PROV_T_MASK ((MESH_GATT_TYPE_PROV << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))

Typedefs

typedef UCHAR | BRR_HANDLE
Bearer handle identifier.
typedef API_RESULT(* | BRR_NTF_CB )(BRR_HANDLE *brr_handle, UCHAR brr_event, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
BEARER Application Asynchronous Notification Callback. More...
typedef void(* | BRR_BCON_CB )(UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
BEARER Application Asynchronous Notification Callback for Beacons. More...

Enumerations

enum BRR_TYPE {
BRR_TYPE_BCON, BRR_TYPE_ADV, BRR_TYPE_PB_ADV, BRR_TYPE_GATT,
BRR_TYPE_PB_GATT, BRR_COUNT
}
Bearer Type definitions. More...
enum BRR_BCON_TTYPE {
BRR_BCON_TYPE_UNPROV_DEVICE, BRR_BCON_DUMMY, BRR_BCON_TYPE_SECURE_NET, BRR_BCON_TYPE_PROXY_NETID,
BRR_BCON_TYPE_PROXY_NODEID, BRR_BCON_COUNT
}
Bearer Beacon type definitions. More...

Functions

API_RESULT | MS_brr_register (BRR_TYPE brr_type, BRR_NTF_CB brr_cb)
Register Interface with Bearer Layer. More...
API_RESULT | MS_brr_register_beacon_handler (UCHAR bcon_type, void(*bcon_handler)(UCHAR *data, UINT16 datalen))
Register Beacon Interface with Bearer Layer. More...
API_RESULT | MS_brr_add_bearer (BRR_TYPE brr_type, BRR_BEARER_INFO *brr_info, BRR_HANDLE *brr_handle)
Add a bearer to Bearer Layer. More...
API_RESULT | MS_brr_remove_bearer (BRR_TYPE brr_type, BRR_HANDLE *brr_handle)
Remove a bearer from Bearer Layer. More...
API_RESULT | MS_brr_observe_beacon (UCHAR bcon_type, UCHAR enable)
Observe ON/OFF for the beacon type. More...
API_RESULT | MS_brr_bcast_unprovisioned_beacon (UCHAR type, UCHAR *dev_uuid, UINT16 oob_info, MS_BUFFER *uri)
API to send Unprovisioned Device Beacon. More...
API_RESULT | MS_brr_broadcast_beacon (UCHAR type, UCHAR *packet, UINT16 length)
API to broadcast a beacon. More...
API_RESULT | MS_brr_start_proxy_adv (UCHAR type, UCHAR *data, UINT16 datalen)
API to send Proxy Device ADV. More...
API_RESULT | MS_brr_bcast_end (UCHAR bcon, UCHAR type)
API to disable broadcast of given beacon type. More...
API_RESULT | MS_brr_send_pdu (BRR_HANDLE *brr_handle, BRR_TYPE brr_type, MS_BUFFER *buffer)
Send a bearer PDU. More...
UCHAR | MS_brr_get_packet_rssi (void)
Get the RSSI of current received packet being processed. More...
API_RESULT | MS_brr_sleep (void)
Put the bearer to sleep. More...
API_RESULT | MS_brr_wakeup (void)
Wakeup the bearer. More...

Detailed Description

This file defines the Mesh Bearer Application Interface - includes Data Structures and Methods.

Definition in file MS_brr_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_common.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Functions | Variables
MS_common.h File Reference

This Header file describes common declarations for the EtherMind Mesh modules. More...

#include "EM_os.h"
#include "MS_features.h"
#include "MS_limits.h"
#include "MS_assigned_numbers.h"
#include "MS_error.h"
#include "EM_debug.h"
#include "EM_assert.h"
#include "EM_timer.h"
#include "MS_common_pl.h"
#include "MS_model_states.h"
Include dependency graph for MS_common.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | MS_BUFFER
Payload type. More...
struct | MS_CONFIG
Dynamic configuration of Mesh Datastructure. More...

Macros

#define | COMMON_ERR(...) EM_debug_error(MS_MODULE_ID_COMMON, __VA_ARGS__)
#define | COMMON_TRC EM_debug_null
#define | COMMON_INF EM_debug_null
#define | MS_STACK_INIT_UNDEFINED 0x00
#define | MS_STACK_INIT_ETHERMIND_INIT 0x01
#define | MS_FALSE 0
#define | MS_TRUE 1
#define | MS_PACK_LE_1_BYTE(dst, src)
Packing Macros. More...
#define | MS_PACK_LE_1_BYTE_VAL(dst, src) *((UCHAR *)(dst) + 0) = src;
#define | MS_PACK_LE_2_BYTE(dst, src)
#define | MS_PACK_LE_2_BYTE_VAL(dst, src)
#define | MS_PACK_LE_3_BYTE(dst, src)
#define | MS_PACK_LE_3_BYTE_VAL(dst, src)
#define | MS_PACK_LE_4_BYTE(dst, src)
#define | MS_PACK_LE_4_BYTE_VAL(dst, src)
#define | MS_PACK_LE_8_BYTE(dst, val) EM_mem_copy ((dst), (val), 8)
#define | MS_PACK_LE_16_BYTE(dst, val) EM_mem_copy ((dst), (val), 16)
#define | MS_PACK_LE_N_BYTE(dst, val, n) EM_mem_copy ((dst), (val), (n))
#define | MS_PACK_BE_1_BYTE(dst, src)
#define | MS_PACK_BE_1_BYTE_VAL(dst, src) *((UCHAR *)(dst) + 0) = src;
#define | MS_PACK_BE_2_BYTE(dst, src)
#define | MS_PACK_BE_2_BYTE_VAL(dst, src)
#define | MS_PACK_BE_3_BYTE(dst, src)
#define | MS_PACK_BE_3_BYTE_VAL(dst, src)
#define | MS_PACK_BE_4_BYTE(dst, src)
#define | MS_PACK_BE_4_BYTE_VAL(dst, src)
#define | MS_PACK_BE_8_BYTE(dst, val) EM_mem_copy ((dst), (val), 8)
#define | MS_PACK_BE_16_BYTE(dst, val) EM_mem_copy ((dst), (val), 16)
#define | MS_PACK_BE_N_BYTE(dst, val, n) EM_mem_copy ((dst), (val), (n))
#define | MS_UNPACK_LE_1_BYTE(dst, src) *((UCHAR *)(dst)) = (UCHAR)(*((UCHAR *)(src)));
Unpacking Macros. More...
#define | MS_UNPACK_LE_2_BYTE(dst, src)
#define | MS_UNPACK_LE_3_BYTE(dst, src)
#define | MS_UNPACK_LE_4_BYTE(dst, src)
#define | MS_UNPACK_LE_8_BYTE(dst, src) EM_mem_copy ((dst), (src), 8)
#define | MS_UNPACK_LE_16_BYTE(dst, src) EM_mem_copy ((dst), (src), 16)
#define | MS_UNPACK_LE_N_BYTE(dst, src, n) EM_mem_copy ((dst), (src), (n))
#define | MS_UNPACK_BE_1_BYTE(dst, src) *((UCHAR *)(dst)) = (UCHAR)(*((UCHAR *)(src)));
#define | MS_UNPACK_BE_2_BYTE(dst, src)
#define | MS_UNPACK_BE_3_BYTE(dst, src)
#define | MS_UNPACK_BE_4_BYTE(dst, src)
#define | MS_UNPACK_BE_8_BYTE(dst, src) EM_mem_copy ((dst), (src), 8)
#define | MS_UNPACK_BE_16_BYTE(dst, src) EM_mem_copy ((dst), (src), 16)
#define | MS_UNPACK_BE_N_BYTE(dst, src, n) EM_mem_copy ((dst), (src), (n))
#define | MS_DEFINE_MUTEX(mutex) EM_thread_mutex_type mutex;
#define | MS_DEFINE_MUTEX_TYPE(type, mutex) type EM_thread_mutex_type mutex;
#define | MS_DEFINE_COND(cond) EM_thread_cond_type cond;
#define | MS_DEFINE_COND_TYPE(type, cond) type EM_thread_cond_type cond;
#define | MS_MUTEX_INIT_VOID(mutex, MODULE)
#define | MS_MUTEX_INIT(mutex, MODULE)
#define | MS_COND_INIT_VOID(cond, MODULE)
#define | MS_COND_INIT(cond, MODULE)
#define | MS_MUTEX_LOCK(mutex, MODULE)
#define | MS_MUTEX_LOCK_VOID(mutex, MODULE)
#define | MS_MUTEX_LOCK_RETURN_ON_FAILURE(mutex, MODULE, value)
#define | MS_MUTEX_LOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE)
#define | MS_MUTEX_UNLOCK(mutex, MODULE)
#define | MS_MUTEX_UNLOCK_VOID(mutex, MODULE)
#define | MS_MUTEX_UNLOCK_RETURN_ON_FAILURE(mutex, MODULE, value)
#define | MS_MUTEX_UNLOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE)
#define | MS_EXTRACT_BITNUM(val, bitnum) (((val) >> (bitnum)) & 1)
#define | MS_SET_BITNUM(val, bitnum) ((val) |= (1 << (bitnum)))
#define | MS_CLR_BITNUM(val, bitnum) ((val) &= (~(1 << (bitnum))))
#define | MS_GET_MIN(a, b) (((a) > (b)) ? (b) : (a))
#define | MS_GET_MAX(a, b) (((a) > (b)) ? (a) : (b))
#define | MS_IGNORE_UNUSED_PARAM(v) (void)(v)
#define | MS_LOOP_FOREVER() for(;;)
#define | MS_INIT_CONFIG(config)
#define | MS_CONFIG_LIMITS(x) (x)
#define | MS_DEFINE_GLOBAL_ARRAY(type, var, s) type var[(s)]
#define | MS_DECLARE_GLOBAL_ARRAY(type, var, s) extern type var[(s)]
#define | MS_INIT_GLOBAL_ARRAY(type, var, s, i) EM_mem_set(var, (i), ((s) * sizeof(type)))
#define | MODEL_OPCODE_HANDLER_EMPTY_DEF(x)
#define | MODEL_OPCODE_HANDLER_CALL(handler)
#define | MS_STREAM_REV_ENDIANNESS(s, d, n)
#define | MS_MODULE_PAGE_4 0x40000000
#define | MS_MODULE_BIT_MASK_COMMON 0x00000001
#define | MS_MODULE_BIT_MASK_BRR 0x00000002
#define | MS_MODULE_BIT_MASK_NET 0x00000004
#define | MS_MODULE_BIT_MASK_LTRN 0x00000008
#define | MS_MODULE_BIT_MASK_TRN 0x00000010
#define | MS_MODULE_BIT_MASK_ACCESS 0x00000020
#define | MS_MODULE_BIT_MASK_APP 0x00000040
#define | MS_MODULE_BIT_MASK_STBX 0x00000080
#define | MS_MODULE_BIT_MASK_CONFIG 0x00000100
#define | MS_MODULE_BIT_MASK_FSM 0x00000200
#define | MS_MODULE_BIT_MASK_PROV 0x00000400
#define | MS_MODULE_BIT_MASK_MESH_MODEL 0x00000800
#define | MS_MODULE_ID_COMMON (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_COMMON)
#define | MS_MODULE_ID_BRR (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_BRR)
#define | MS_MODULE_ID_NET (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_NET)
#define | MS_MODULE_ID_LTRN (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_LTRN)
#define | MS_MODULE_ID_TRN (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_TRN)
#define | MS_MODULE_ID_ACCESS (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_ACCESS)
#define | MS_MODULE_ID_APP (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_APP)
#define | MS_MODULE_ID_STBX (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_STBX)
#define | MS_MODULE_ID_CONFIG (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_CONFIG)
#define | MS_MODULE_ID_FSM (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_FSM)
#define | MS_MODULE_ID_PROV (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_PROV)
#define | MS_MODULE_ID_MESH_MODEL (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_MESH_MODEL)
#define | MS_DEVICE_UUID_SIZE 16
Device UUID Size.
#define | MS_BCON_TYPE_SIZE 1
Beacon Type - Size.
#define | MS_BCON_OOB_IND_SIZE 2
Beacon OOB Indicator Size.
#define | MS_BCON_URI_HASH_SIZE 4
Beacon URI Hash Size.
#define | MS_BCON_TYPE_UNPRVSNG_DEV 0x00
Beacon Types. More...
#define | MS_BCON_TYPE_SECURE 0x01
#define | MS_FRND_ROLE_INVALID 0x00
Friend Role.
#define | MS_FRND_ROLE_FRIEND 0x01
#define | MS_FRND_ROLE_LPN 0x02
#define | MS_FEATURE_RELAY 0x00
Relay Feature.
#define | MS_FEATURE_PROXY 0x01
Proxy Feature.
#define | MS_FEATURE_FRIEND 0x02
Friend Feature.
#define | MS_FEATURE_LPN 0x03
Low Power Feature.
#define | MS_FEATURE_SEC_NET_BEACON 0x04
Secure Nework Beacon.
#define | MS_ENABLE 0x01
Operation: Enable.
#define | MS_DISABLE 0x00
Operation: Disable.
#define | MS_NOT_SUPPORTED 0x02
Feature not supported. More...
#define | MS_NETWORK_TX_STATE 0x00
Network Tx State.
#define | MS_RELAY_TX_STATE 0x01
Relay Tx State.
#define | MS_LABEL_UUID_LENGTH 16
Label UUID Length. More...

Functions

void | MS_init (void *blob)
API to initialize Mesh Stack. More...
API_RESULT | MS_shutdown (void)
API to turn off Bluetooth Hardware. More...
API_RESULT | MS_common_start_transition_timer (MS_ACCESS_STATE_TRANSITION_TYPE *transition, UINT16 *transition_time_handle)
To start transition timer. More...
API_RESULT | MS_common_stop_transition_timer (UINT16 transition_time_handle)
To stop transition timer. More...
API_RESULT | MS_common_get_transition_time_from_ms (UINT32 transition_time_in_ms, UINT8 *transition_time)
To convert transition time from milisecond. More...

Variables

MS_CONFIG ms_global_config

Detailed Description

This Header file describes common declarations for the EtherMind Mesh modules.

Definition in file MS_common.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_config_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_config_api.h File Reference

This file defines the Mesh Configuration Foundation Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_config_api.h:

Go to the source code of this file.

Data Structures

struct | ACCESS_CONFIG_BEACON_SET_PARAM
Beacon Set parameter structure. More...
struct | ACCESS_CONFIG_COMPDATA_GET_PARAM
Composition Data Get parameter structure. More...
struct | ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM
Default TTL Set parameter structure. More...
struct | ACCESS_CONFIG_GATT_PROXY_SET_PARAM
GATT Proxy Set parameter structure. More...
struct | ACCESS_CONFIG_RELAY_SET_PARAM
Relay Set parameter structure. More...
struct | ACCESS_CONFIG_MODELPUB_GET_PARAM
Model Publication Get parameter structure. More...
struct | ACCESS_CONFIG_MODELPUB_SET_PARAM
Model Publication Set parameter structure. More...
struct | ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
Model Publication Virtual Address Set parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_ADD_PARAM
Model Subscription Add parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM
Model Subscription Virtual Address Add parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_DEL_PARAM
Model Subscription Delete parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM
Model Subscription Virtual Address Delete parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM
Model Subscription Overwrite parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM
Model Subscription Virtual Address Overwrite parameter structure. More...
struct | ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM
Model Subscription Delete All parameter structure. More...
struct | ACCESS_CONFIG_SIGMODELSUB_GET_PARAM
SIG Model Subscription Get parameter structure. More...
struct | ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM
Vendor Model Subscription Get parameter structure. More...
struct | ACCESS_CONFIG_NETKEY_ADD_PARAM
Netkey Add parameter structure. More...
struct | ACCESS_CONFIG_NETKEY_UPDATE_PARAM
Netkey Update parameter structure. More...
struct | ACCESS_CONFIG_NETKEY_DELETE_PARAM
Netkey Delete parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_ADD_PARAM
Appkey Add parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_UPDATE_PARAM
Appkey Update parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_DELETE_PARAM
Appkey Delete parameter structure. More...
struct | ACCESS_CONFIG_APPKEY_GET_PARAM
Appkey Get parameter structure. More...
struct | ACCESS_CONFIG_NODEID_GET_PARAM
Node Identity Get parameter structure. More...
struct | ACCESS_CONFIG_NODEID_SET_PARAM
Node Identity Set parameter structure. More...
struct | ACCESS_CONFIG_MODEL_APP_BIND_PARAM
Model App Bind parameter structure. More...
struct | ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM
Model App Unbind parameter structure. More...
struct | ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM
SIG Model App Get parameter structure. More...
struct | ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM
Vendor Model App Get parameter structure. More...
struct | ACCESS_CONFIG_FRIEND_SET_PARAM
Friend Set parameter structure. More...
struct | ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM
Key Refresh Phase Get parameter structure. More...
struct | ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM
Key Refresh Phase Set parameter structure. More...
struct | ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
Heartbeat Publication Set parameter structure. More...
struct | ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
Heartbeat Subscription Set parameter structure. More...
struct | ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM
Low Power Node PollTimeout Get parameter structure. More...
struct | ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
Network Transmit Set parameter structure. More...

Macros

#define | MS_config_client_beacon_get()
API to get the secure network beacon state. More...
#define | MS_config_client_beacon_set(param)
API to set the secure network beacon state. More...
#define | MS_config_client_composition_data_get(param)
API to get the composition data state. More...
#define | MS_config_client_default_ttl_get()
API to get the default TTL state. More...
#define | MS_config_client_default_ttl_set(param)
API to set the default TTL state. More...
#define | MS_config_client_gatt_proxy_get()
API to get the GATT proxy state. More...
#define | MS_config_client_gatt_proxy_set(param)
API to set the GATT Proxy state. More...
#define | MS_config_client_relay_get()
API to get the relay state. More...
#define | MS_config_client_relay_set(param)
API to set the relay state. More...
#define | MS_config_client_model_publication_get(param)
API to get the model publication state. More...
#define | MS_config_client_model_publication_set(param)
API to set the model publication state. More...
#define | MS_config_client_model_publication_vaddr_set(param)
API to set the model publication state. More...
#define | MS_config_client_model_subscription_add(param)
API to add subscription address. More...
#define | MS_config_client_model_subscription_vaddr_add(param)
API to add subscription address. More...
#define | MS_config_client_model_subscription_delete(param)
API to delete subscription address. More...
#define | MS_config_client_model_subscription_vaddr_delete(param)
API to delete subscription address. More...
#define | MS_config_client_model_subscription_overwrite(param)
API to add subscription address to cleared list. More...
#define | MS_config_client_model_subscription_vaddr_overwrite(param)
API to add subscription address to cleared list. More...
#define | MS_config_client_model_subscription_delete_all(param)
API to discard subscription list. More...
#define | MS_config_client_sig_model_subscription_get(param)
API to get subscription list. More...
#define | MS_config_client_vendor_model_subscription_get(param)
API to get subscription list. More...
#define | MS_config_client_netkey_add(param)
API to add to Netkey list. More...
#define | MS_config_client_netkey_update(param)
API to update to Netkey list. More...
#define | MS_config_client_netkey_delete(param)
API to delete from Netkey list. More...
#define | MS_config_client_netkey_get()
API to get Netkey list. More...
#define | MS_config_client_appkey_add(param)
API to add to Appkey list. More...
#define | MS_config_client_appkey_update(param)
API to update to Appkey list. More...
#define | MS_config_client_appkey_delete(param)
API to delete from Appkey list. More...
#define | MS_config_client_appkey_get(param)
API to get the Appkey list. More...
#define | MS_config_client_node_identity_get(param)
API to get the Node Identity state. More...
#define | MS_config_client_node_identity_set(param)
API to set the Node Identity state. More...
#define | MS_config_client_model_app_bind(param)
API to bind Appkey to model. More...
#define | MS_config_client_model_app_unbind(param)
API to unbind Appkey to model. More...
#define | MS_config_client_sig_model_app_get(param)
API to get all SIG model Appkeys. More...
#define | MS_config_client_vendor_model_app_get(param)
API to get all Vendor model Appkeys. More...
#define | MS_config_client_node_reset()
API to reset a node. More...
#define | MS_config_client_friend_get()
API to get friend state. More...
#define | MS_config_client_friend_set(param)
API to set friend state. More...
#define | MS_config_client_keyrefresh_phase_get(param)
API to get key refresh phase state. More...
#define | MS_config_client_keyrefresh_phase_set(param)
API to set key refresh phase state. More...
#define | MS_config_client_heartbeat_publication_get()
API to get heartbeat publication state. More...
#define | MS_config_client_heartbeat_publication_set(param)
API to set heartbeat publication state. More...
#define | MS_config_client_heartbeat_subscription_get()
API to get heartbeat subscription state. More...
#define | MS_config_client_heartbeat_subscription_set(param)
API to set heartbeat subscription state. More...
#define | MS_config_client_lpn_polltimeout_get(param)
API to get LPN Polltimeout state. More...
#define | MS_config_client_network_transmit_get()
API to get Network transmit state. More...
#define | MS_config_client_network_transmit_set(param)
API to set Network transmit state. More...

Typedefs

typedef API_RESULT(* MS_CONFIG_MODEL_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Configuration Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_config_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_CONFIG_MODEL_CB appl_cb)
API to initialize Configuration Client model. More...
API_RESULT | MS_config_client_set_server (MS_NET_ADDR server_addr, UCHAR *dev_key)
API to set configuration server. More...
API_RESULT | MS_config_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...
API_RESULT | MS_config_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle)
API to initialize configuration server model. More...

Detailed Description

This file defines the Mesh Configuration Foundation Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_config_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_error.h File Reference

  • mesh
  • export
  • include
Macros | Typedefs
MS_error.h File Reference

This file lists all the Error Codes returned by EtherMind Mesh APIs. More...

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Macros

#define | API_RESULT_DEFINED
#define | API_SUCCESS 0x0000
Status - 'Success'.
#define | API_FAILURE 0xFFFF
Status - 'Failure'.
#define | MS_ERR_ID 0x0000
Error Codes for Mesh - Mesh Result Codes.
#define | MS_COMMON_ERR_ID 0x1000
Error Codes for MS Common - Common.
#define | TIMER_ERR_ID 0x1200
Error Codes for Timer - ms_error_codes_module_timer.
#define | BRR_ERR_ID 0x2000
Error Codes for Bearer - ms_error_codes_module_brr.
#define | NET_ERR_ID 0x2100
#define | LTRN_ERR_ID 0x2200
#define | TRN_ERR_ID 0x2300
#define | ACCESS_ERR_ID 0x2400
#define | PROV_ERR_ID 0x3000
#define | HEALTH_ERR_ID 0x8000
#define | MUTEX_INIT_FAILED 0x0001
#define | COND_INIT_FAILED 0x0002
#define | MUTEX_LOCK_FAILED 0x0003
#define | MUTEX_UNLOCK_FAILED 0x0004
#define | MEMORY_ALLOCATION_FAILED 0x0005
#define | MS_SUCCESS (0x0000 | MS_ERR_ID)
#define | MS_INVALID_ADDRESS (0x0001 | MS_ERR_ID)
Invalid Address.
#define | MS_INVALID_MODEL (0x0002 | MS_ERR_ID)
Invalid Model.
#define | MS_INVALID_APPKEY_INDEX (0x0003 | MS_ERR_ID)
Invalid AppKey Index.
#define | MS_INVALID_NETKEY_INDEX (0x0004 | MS_ERR_ID)
Invalid NetKey Index.
#define | MS_INSUFFICIENT_RESOURCES (0x0005 | MS_ERR_ID)
Insufficient Resources.
#define | MS_KEY_INDEX_ALREADY_STORED (0x0006 | MS_ERR_ID)
Key Index Already Stored.
#define | MS_INVALID_PUBLISH_PARAMETER (0x0007 | MS_ERR_ID)
Invalid Publish Parameters.
#define | MS_NOT_A_SUBSCRIBE_MODEL (0x0008 | MS_ERR_ID)
Not a Subscribe Model.
#define | MS_STORAGE_FAILURE (0x0009 | MS_ERR_ID)
Storage Failure.
#define | MS_FEATURE_NOT_SUPPORTED (0x000A | MS_ERR_ID)
Feature Not Supported.
#define | MS_CANNOT_UPDATE (0x000B | MS_ERR_ID)
Cannot Update.
#define | MS_CANNOT_REMOVE (0x000C | MS_ERR_ID)
Cannot Remove.
#define | MS_CANNOT_BIND (0x000D | MS_ERR_ID)
Cannot Bind.
#define | MS_TEMP_UNABLE_TO_CHANGE_STATE (0x000E | MS_ERR_ID)
Temporarily Unable to Change State.
#define | MS_CANNOT_SET (0x000F | MS_ERR_ID)
Cannot Set.
#define | MS_UNSPECIFIED_ERROR (0x0010 | MS_ERR_ID)
Unspecified Error.
#define | MS_INVALID_BINDING (0x0011 | MS_ERR_ID)
Invalid Binding.
#define | TIMER_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | TIMER_ERR_ID)
#define | TIMER_COND_INIT_FAILED (COND_INIT_FAILED | TIMER_ERR_ID)
#define | TIMER_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | TIMER_ERR_ID)
#define | TIMER_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | TIMER_ERR_ID)
#define | TIMER_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | TIMER_ERR_ID)
#define | TIMER_HANDLE_IS_NULL (0x0011 | TIMER_ERR_ID)
#define | TIMER_CALLBACK_IS_NULL (0x0012 | TIMER_ERR_ID)
#define | TIMER_QUEUE_EMPTY (0x0013 | TIMER_ERR_ID)
#define | TIMER_QUEUE_FULL (0x0014 | TIMER_ERR_ID)
#define | TIMER_ENTITY_SEARCH_FAILED (0x0015 | TIMER_ERR_ID)
#define | TIMER_NULL_PARAMETER_NOT_ALLOWED (0x0016 | TIMER_ERR_ID)
#define | TIMER_TIMEOUT_ZERO_NOT_ALLOWED (0x0017 | TIMER_ERR_ID)
#define | BRR_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | BRR_ERR_ID)
#define | BRR_COND_INIT_FAILED (COND_INIT_FAILED | BRR_ERR_ID)
#define | BRR_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | BRR_ERR_ID)
#define | BRR_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | BRR_ERR_ID)
#define | BRR_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | BRR_ERR_ID)
#define | BRR_INVALID_PARAMETER_VALUE (0x0011 | BRR_ERR_ID)
#define | BRR_PARAMETER_OUTSIDE_RANGE (0x0012 | BRR_ERR_ID)
#define | BRR_NULL_PARAMETER_NOT_ALLOWED (0x0013 | BRR_ERR_ID)
#define | BRR_INTERFACE_NOT_READY (0x0014 | BRR_ERR_ID)
#define | BRR_API_NOT_SUPPORTED (0x00FF | BRR_ERR_ID)
#define | NET_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | NET_ERR_ID)
#define | NET_COND_INIT_FAILED (COND_INIT_FAILED | NET_ERR_ID)
#define | NET_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | NET_ERR_ID)
#define | NET_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | NET_ERR_ID)
#define | NET_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | NET_ERR_ID)
#define | NET_INVALID_PARAMETER_VALUE (0x0011 | NET_ERR_ID)
#define | NET_PARAMETER_OUTSIDE_RANGE (0x0012 | NET_ERR_ID)
#define | NET_NULL_PARAMETER_NOT_ALLOWED (0x0013 | NET_ERR_ID)
#define | NET_TX_QUEUE_FULL (0x0014 | NET_ERR_ID)
#define | NET_TX_QUEUE_EMPTY (0x0015 | NET_ERR_ID)
#define | NET_INVALID_RX_PKT_FORMAT (0x0016 | NET_ERR_ID)
#define | NET_RX_LOCAL_SRC_ADDR_PKT (0x0017 | NET_ERR_ID)
#define | NET_POST_PROCESS_RX_PKT (0x0018 | NET_ERR_ID)
#define | NET_API_NOT_SUPPORTED (0x00FF | NET_ERR_ID)
#define | LTRN_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | LTRN_ERR_ID)
#define | LTRN_COND_INIT_FAILED (COND_INIT_FAILED | LTRN_ERR_ID)
#define | LTRN_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | LTRN_ERR_ID)
#define | LTRN_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | LTRN_ERR_ID)
#define | LTRN_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | LTRN_ERR_ID)
#define | LTRN_INVALID_PARAMETER_VALUE (0x0011 | LTRN_ERR_ID)
#define | LTRN_PARAMETER_OUTSIDE_RANGE (0x0012 | LTRN_ERR_ID)
#define | LTRN_NULL_PARAMETER_NOT_ALLOWED (0x0013 | LTRN_ERR_ID)
#define | LTRN_SAR_CTX_ALLOCATION_FAILED (0x0014 | LTRN_ERR_ID)
#define | TRN_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | TRN_ERR_ID)
#define | TRN_COND_INIT_FAILED (COND_INIT_FAILED | TRN_ERR_ID)
#define | TRN_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | TRN_ERR_ID)
#define | TRN_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | TRN_ERR_ID)
#define | TRN_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | TRN_ERR_ID)
#define | TRN_INVALID_PARAMETER_VALUE (0x0011 | TRN_ERR_ID)
#define | TRN_PARAMETER_OUTSIDE_RANGE (0x0012 | TRN_ERR_ID)
#define | TRN_NULL_PARAMETER_NOT_ALLOWED (0x0013 | TRN_ERR_ID)
#define | TRN_QUEUE_FULL (0x0014 | TRN_ERR_ID)
#define | TRN_QUEUE_EMPTY (0x0015 | TRN_ERR_ID)
#define | TRN_INCOMPLETE_PKT_RECEIVED (0x0016 | TRN_ERR_ID)
#define | TRN_API_NOT_SUPPORTED (0x00FF | TRN_ERR_ID)
#define | ACCESS_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | ACCESS_ERR_ID)
#define | ACCESS_COND_INIT_FAILED (COND_INIT_FAILED | ACCESS_ERR_ID)
#define | ACCESS_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | ACCESS_ERR_ID)
#define | ACCESS_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | ACCESS_ERR_ID)
#define | ACCESS_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | ACCESS_ERR_ID)
#define | ACCESS_INVALID_PARAMETER_VALUE (0x0011 | ACCESS_ERR_ID)
#define | ACCESS_PARAMETER_OUTSIDE_RANGE (0x0012 | ACCESS_ERR_ID)
#define | ACCESS_NULL_PARAMETER_NOT_ALLOWED (0x0013 | ACCESS_ERR_ID)
#define | ACCESS_NO_RESOURCE (0x0020 | ACCESS_ERR_ID)
#define | ACCESS_NO_MATCH (0x0021 | ACCESS_ERR_ID)
#define | ACCESS_INVALID_HANDLE (0x0022 | ACCESS_ERR_ID)
#define | ACCESS_MODEL_ALREADY_REGISTERED (0x0023 | ACCESS_ERR_ID)
#define | ACCESS_INVALID_SRC_ADDR (0x0024 | ACCESS_ERR_ID)
#define | ACCESS_DEV_KEY_TABLE_FULL (0x0025 | ACCESS_ERR_ID)
#define | ACCESS_API_NOT_SUPPORTED (0x00FF | ACCESS_ERR_ID)
#define | PROV_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | PROV_ERR_ID)
#define | PROV_COND_INIT_FAILED (COND_INIT_FAILED | PROV_ERR_ID)
#define | PROV_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | PROV_ERR_ID)
#define | PROV_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | PROV_ERR_ID)
#define | PROV_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | PROV_ERR_ID)
#define | PROV_INVALID_STATE (0x0011 | PROV_ERR_ID)
#define | PROV_INVALID_PARAMETER (0x0012 | PROV_ERR_ID)
#define | PROV_CONTEXT_ALLOC_FAILED (0x0013 | PROV_ERR_ID)
#define | PROV_CONTEXT_ASSERT_FAILED (0x0014 | PROV_ERR_ID)
#define | PROV_CONTEXT_LINK_OPEN (0x0015 | PROV_ERR_ID)
#define | PROV_BEARER_ASSERT_FAILED (0x0016 | PROV_ERR_ID)
#define | PROV_PROCEDURE_TIMEOUT (0x0017 | PROV_ERR_ID)
#define | HEALTH_MUTEX_INIT_FAILED (MUTEX_INIT_FAILED | HEALTH_ERR_ID)
#define | HEALTH_COND_INIT_FAILED (COND_INIT_FAILED | HEALTH_ERR_ID)
#define | HEALTH_MUTEX_LOCK_FAILED (MUTEX_LOCK_FAILED | HEALTH_ERR_ID)
#define | HEALTH_MUTEX_UNLOCK_FAILED (MUTEX_UNLOCK_FAILED | HEALTH_ERR_ID)
#define | HEALTH_MEMORY_ALLOCATION_FAILED (MEMORY_ALLOCATION_FAILED | HEALTH_ERR_ID)
#define | HEALTH_INVALID_STATE (0x0011 | HEALTH_ERR_ID)
#define | HEALTH_INVALID_PARAMETER (0x0012 | HEALTH_ERR_ID)
#define | HEALTH_CONTEXT_ALLOC_FAILED (0x0013 | HEALTH_ERR_ID)
#define | HEALTH_CONTEXT_ASSERT_FAILED (0x0014 | HEALTH_ERR_ID)

Typedefs

typedef UINT16 API_RESULT
Definition of API_RESULT.

Detailed Description

This file lists all the Error Codes returned by EtherMind Mesh APIs.

Definition in file MS_error.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_battery_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_battery_api.h File Reference

This file defines the Mesh Generic Battery Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_generic_battery_api.h:

Go to the source code of this file.

Data Structures

struct MS_GENERIC_BATTERY_STATUS_STRUCT
The Generic Battery state is a set of four values representing the state of a battery: More...

Macros

#define MS_generic_battery_get()
API to get the Generic Battery state of an element. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_BATTERY_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Battery Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_BATTERY_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Battery Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_battery_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_BATTERY_SERVER_CB appl_cb)
API to initialize Generic_Battery Server model. More...
API_RESULT | MS_generic_battery_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_battery_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_BATTERY_CLIENT_CB appl_cb)
API to initialize Generic_Battery Client model. More...
API_RESULT | MS_generic_battery_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Battery client model handle. More...
API_RESULT | MS_generic_battery_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic Battery Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_battery_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_default_transition_time_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_default_transition_time_api.h File Reference

This file defines the Mesh Generic Default Transition Time Model Application Interface. More...

#include "MS_access_api.h"
#include "MS_model_states.h"
Include dependency graph for MS_generic_default_transition_time_api.h:

Go to the source code of this file.

Data Structures

struct MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
The Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state. More...

Macros

#define | MS_generic_default_transition_time_set(param)
API to set the Generic Default Transition Time state of an element. More...
#define | MS_generic_default_transition_time_set_unacknowledged(param)
API to set the Generic Default Transition Time state of an element. More...
#define | MS_generic_default_transition_time_get()
API to get the Generic Default Transition Time state of an element. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Default Transition Time Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Default Transition Time Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_default_transition_time_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB appl_cb)
API to initialize Generic_Default_Transition_Time Server model. More...
API_RESULT | MS_generic_default_transition_time_server_get_time (MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT *default_time)
API to get default transition time. More...
API_RESULT | MS_generic_default_transition_time_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB appl_cb)
API to initialize Generic_Default_Transition_Time Client model. More...
API_RESULT | MS_generic_default_transition_time_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Default_Transition_Time client model handle. More...
API_RESULT | MS_generic_default_transition_time_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic Default Transition Time Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_default_transition_time_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_level_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_level_api.h File Reference

This file defines the Mesh Generic Level Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_generic_level_api.h:

Go to the source code of this file.

Data Structures

struct | MS_GENERIC_LEVEL_SET_STRUCT
Generic Level Set message parameters. More...
struct | MS_GENERIC_LEVEL_STATUS_STRUCT
Generic Level Status message parameters. More...
struct | MS_GENERIC_DELTA_SET_STRUCT
Generic Delta Set message parameters. More...
struct | MS_GENERIC_MOVE_SET_STRUCT
Generic Move Set message parameters. More...

Macros

#define | MS_generic_level_set(param)
API to set the Generic Level state of an element to a new absolute value. More...
#define | MS_generic_move_set(param)
API to start a process of changing the Generic Level state of an element with a defined transition speed. More...
#define | MS_generic_level_get()
API to get the Generic Level state of an element. More...
#define | MS_generic_delta_set(param)
API to set the Generic Level state of an element by a relative value. More...
#define | MS_generic_delta_set_unacknowledged(param)
API to set the Generic Level state of an element by a relative value. More...
#define | MS_generic_level_set_unacknowledged(param)
API to set the Generic Level state of an element to a new absolute value. More...
#define | MS_generic_move_set_unacknowledged(param)
API to start a process of changing the Generic Level state of an element with a defined transition speed. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_LEVEL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Level Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_LEVEL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Level Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_level_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LEVEL_SERVER_CB appl_cb)
API to initialize Generic_Level Server model. More...
API_RESULT | MS_generic_level_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_level_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LEVEL_CLIENT_CB appl_cb)
API to initialize Generic_Level Client model. More...
API_RESULT | MS_generic_level_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Level client model handle. More...
API_RESULT | MS_generic_level_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic Level Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_level_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_location_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_location_api.h File Reference

This file defines the Mesh Generic Location Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_generic_location_api.h:

Go to the source code of this file.

Data Structures

struct | MS_GENERIC_LOCATION_GLOBAL_STRUCT
Generic Location Global Set message parameters. More...
struct | MS_GENERIC_LOCATION_LOCAL_STRUCT
Generic Location Local Set message parameters. More...

Macros

#define | MS_generic_location_global_set_unacknowledged(param)
API to set the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_local_get()
API to get the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_local_set(param)
API to set the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_global_set(param)
API to set the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_global_get()
API to get the selected fields of the Generic Location state of an element. More...
#define | MS_generic_location_local_set_unacknowledged(param)
API to set the selected fields of the Generic Location state of an element. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_LOCATION_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Location Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_LOCATION_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Location Client application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_LOCATION_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Location Setup Server application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_location_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LOCATION_SERVER_CB appl_cb)
API to initialize Generic_Location Server model. More...
API_RESULT | MS_generic_location_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_location_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LOCATION_SETUP_SERVER_CB appl_cb)
API to initialize Generic_Location_Setup Server model. More...
API_RESULT | MS_generic_location_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_location_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_LOCATION_CLIENT_CB appl_cb)
API to initialize Generic_Location Client model. More...
API_RESULT | MS_generic_location_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Location client model handle. More...
API_RESULT | MS_generic_location_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic Location Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_location_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_onoff_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_onoff_api.h File Reference

This file defines the Mesh Generic Onoff Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_generic_onoff_api.h:

Go to the source code of this file.

Data Structures

struct | MS_GENERIC_ONOFF_SET_STRUCT
Generic OnOff Set message parameters. More...
struct | MS_GENERIC_ONOFF_STATUS_STRUCT
Generic OnOff Status message parameters. More...

Macros

#define | MS_generic_onoff_set_unacknowledged(param)
API to set Generic OnOff state unacknowledged. More...
#define | MS_generic_onoff_set(param)
API to set Generic OnOff state. More...
#define | MS_generic_onoff_get()
API to get Generic OnOff state. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_ONOFF_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Onoff Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_ONOFF_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Onoff Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_onoff_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_ONOFF_SERVER_CB appl_cb)
API to initialize Generic_Onoff Server model. More...
API_RESULT | MS_generic_onoff_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_onoff_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_ONOFF_CLIENT_CB appl_cb)
API to initialize Generic_Onoff Client model. More...
API_RESULT | MS_generic_onoff_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Onoff client model handle. More...
API_RESULT | MS_generic_onoff_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic Onoff Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_onoff_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_power_level_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_power_level_api.h File Reference

This file defines the Mesh Generic Power Level Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_generic_power_level_api.h:

Go to the source code of this file.

Data Structures

struct | MS_GENERIC_POWER_LEVEL_SET_STRUCT
Generic Power Level Set message parameters. More...
struct | MS_GENERIC_POWER_LEVEL_STATUS_STRUCT
Generic Power Level Status message parameters. More...
struct | MS_GENERIC_POWER_LAST_STATUS_STRUCT
Generic Power Last Status message parameters. More...
struct | MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT
Generic Power Default Status message parameters. More...
struct | MS_GENERIC_POWER_RANGE_STATUS_STRUCT
Generic Power Range Status message parameters. More...
struct | MS_GENERIC_POWER_DEFAULT_SET_STRUCT
Generic Power Default Status message parameters. More...
struct | MS_GENERIC_POWER_RANGE_SET_STRUCT
Generic Power Range Set message parameters. More...

Macros

#define | MS_generic_power_range_set(param)
API to set the Generic Power Range state of an element. More...
#define | MS_generic_power_level_set(param)
API to set the Generic Power Actual state of an element. More...
#define | MS_generic_power_default_set(param)
API to set the Generic Power Default state of an element. More...
#define | MS_generic_power_level_get()
API to get the Generic Power Actual state of an element. More...
#define | MS_generic_power_default_get()
API to get the Generic Power Default state of an element. More...
#define | MS_generic_power_last_get()
API to get the Generic Power Last state of an element. More...
#define | MS_generic_power_range_get()
API to get the Generic Power Range state of an element. More...
#define | MS_generic_power_default_set_unacknowledged(param)
API to set the Generic Power Default state of an element. More...
#define | MS_generic_power_level_set_unacknowledged(param)
API to set the Generic Power Actual state of an element. More...
#define | MS_generic_power_range_set_unacknowledged(param)
API to set the Generic Power Range state of an element. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_POWER_LEVEL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Level Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_LEVEL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Power Level Client application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Level Setup Server application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_power_level_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_LEVEL_SERVER_CB appl_cb)
API to initialize Generic_Power_Level Server model. More...
API_RESULT | MS_generic_power_level_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_power_level_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB appl_cb)
API to initialize Generic_Power_Level_Setup Server model. More...
API_RESULT | MS_generic_power_level_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_power_level_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_LEVEL_CLIENT_CB appl_cb)
API to initialize Generic_Power_Level Client model. More...
API_RESULT | MS_generic_power_level_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Power_Level client model handle. More...
API_RESULT | MS_generic_power_level_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic Power Level Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_power_level_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_power_onoff_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_power_onoff_api.h File Reference

This file defines the Mesh Generic Power Onoff Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_generic_power_onoff_api.h:

Go to the source code of this file.

Data Structures

struct MS_GENERIC_ONPOWERUP_STRUCT
Generic OnPowerUp Set message parameters. More...

Macros

#define | MS_generic_onpowerup_set(param)
API to set the Generic OnPowerUp state of an element. More...
#define | MS_generic_onpowerup_set_unacknowledged(param)
API to set the Generic OnPowerUp state of an element. More...
#define | MS_generic_onpowerup_get()
API to get the Generic OnPowerUp state of an element. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_POWER_ONOFF_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Onoff Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_ONOFF_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Power Onoff Client application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Power Onoff Setup Server application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_power_onoff_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_ONOFF_SERVER_CB appl_cb)
API to initialize Generic_Power_Onoff Server model. More...
API_RESULT | MS_generic_power_onoff_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_power_onoff_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB appl_cb)
API to initialize Generic_Power_Onoff_Setup Server model. More...
API_RESULT | MS_generic_power_onoff_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_power_onoff_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_POWER_ONOFF_CLIENT_CB appl_cb)
API to initialize Generic_Power_Onoff Client model. More...
API_RESULT | MS_generic_power_onoff_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Power_Onoff client model handle. More...
API_RESULT | MS_generic_power_onoff_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic Power Onoff Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_power_onoff_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_property_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_generic_property_api.h File Reference

This file defines the Mesh Generic User, Admin, Manufacturer and Client Property Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_generic_property_api.h:

Go to the source code of this file.

Data Structures

struct | MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT
Generic User Properties Status message parameters. More...
struct | MS_GENERIC_USER_PROPERTY_GET_STRUCT
Generic User Property Get message parameters. More...
struct | MS_GENERIC_USER_PROPERTY_SET_STRUCT
Generic User Property Set message parameters. More...
struct | MS_GENERIC_USER_PROPERTY_STATUS_STRUCT
Generic User Property Status message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT
Generic Admin Properties Status message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT
Generic Admin Property Get message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT
Generic Admin Property Set message parameters. More...
struct | MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT
Generic Admin Property Status message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT
Generic Manufacturer Properties Status message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT
Generic Manufacturer Property Get message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT
Generic Manufacturer Property Set message parameters. More...
struct | MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT
Generic Manufacturer Property Status message parameters. More...
struct | MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT
Generic Client Properties Get message parameters. More...
struct | MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT
Generic Client Properties Status message parameters. More...

Macros

#define | MS_GENERIC_PROP_TYPE_MANUFACTURER 0x00
Generic Manufacturer Properties.
#define | MS_GENERIC_PROP_TYPE_ADMIN 0x01
Generic Admin Properties.
#define | MS_GENERIC_PROP_TYPE_USER 0x02
Generic User Properties.
#define | MS_GENERIC_USER_ACCESS_PROHIBITED 0x00
User Access field values.
#define | MS_GENERIC_USER_ACCESS_READ 0x01
#define | MS_GENERIC_USER_ACCESS_WRITE 0x02
#define | MS_GENERIC_USER_ACCESS_READ_WRITE 0x03
#define | MS_GENERIC_USER_ACCESS_INVALID_PROPERTY_ID 0xFF
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_OCCUPANCY_DELAY 0x003A
Device Property - Light Control Time Occupancy Delay.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_ON 0x0037
Device Property - Light Control Time Fade On.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_RUN_ON 0x003C
Device Property - Light Control Time Run On.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE 0x0036
Device Property - Light Control Time Fade.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_PROLONG 0x003B
Device Property - Light Control Time Prolong.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_AUTO 0x0038
Device Property - Light Control Time Fade Standby Auto.
#define | MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_MANUAL 0x0039
Device Property - Light Control Time Fade Standby Manual.
#define | MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_ON 0x002E
Device Property - Light Control Lightness On.
#define | MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_PROLONG 0x002F
Device Property - Light Control Lightness Prolong.
#define | MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_STANDBY 0x0030
Device Property - Light Control Lightness Standby.
#define | MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_ON 0x002B
Device Property - Light Control Ambient LuxLevel On.
#define | MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_PROLONG 0x002C
Device Property - Light Control Ambient LuxLevel Prolong.
#define | MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_STANDBY 0x002D
Device Property - Light Control Ambient LuxLevel Standby.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KIU 0x0033
Device Property - Light Control Regulator Kiu.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KID 0x0032
Device Property - Light Control Regulator Kid.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPU 0x0035
Device Property - Light Control Regulator Kpu.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPD 0x0034
Device Property - Light Control Regulator Kpd.
#define | MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_ACCURACY 0x0031
Device Property - Light Control Regulator Accuracy.
#define | MS_DEV_PROP_MOTION_SENSED 0x0042
Device Property - Motion Sensed.
#define | MS_DEV_PROP_TIME_SINCE_MOTION_SENSED 0x0068
Device Property - Time Since Motion Sensed.
#define | MS_DEV_PROP_PEOPLE_COUNT 0x004C
Device Property - People Count.
#define | MS_DEV_PROP_PRESENCE_DETECTED 0x004D
Device Property - Presence Detected.
#define | MS_DEV_PROP_PRESENT_AMBIENT_LIGHT_LEVEL 0x004E
Device Property - Present Ambient Light Level.
#define | MS_generic_admin_properties_get()
API to get the list of Generic Admin Property states of an element. More...
#define | MS_generic_admin_property_set(param)
API to set the Generic Admin Property state of an element. More...
#define | MS_generic_user_property_set(param)
API to set the Generic User Property state of an element. More...
#define | MS_generic_client_properties_get(param)
API to get the list of Generic Client Property states of an element. More...
#define | MS_generic_manufacturer_property_get(param)
API to get the Generic Manufacturer Property state of an element. More...
#define | MS_generic_user_property_set_unacknowledged(param)
API to set the Generic User Property state of an element. More...
#define | MS_generic_manufacturer_property_set(param)
API to the Generic Manufacturer Property User Access state of an element. More...
#define | MS_generic_admin_property_set_unacknowledged(param)
API to set the Generic Admin Property state of an element. More...
#define | MS_generic_manufacturer_properties_get()
API to get the list of Generic Manufacturer Property states of an element. More...
#define | MS_generic_user_property_get(param)
API to get the Generic User Property state of an element. More...
#define | MS_generic_admin_property_get(param)
API to get the Generic Admin Property state of an element. More...
#define | MS_generic_manufacturer_property_set_unacknowledged(param)
API to the Generic Manufacturer Property User Access state of an element. More...
#define | MS_generic_user_properties_get()
API to get the list of Generic User Property states of an element. More...

Typedefs

typedef API_RESULT(* | MS_GENERIC_PROPERTY_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Generic Property Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_GENERIC_PROPERTY_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Generic Property Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_generic_user_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_User_Property Server model. More...
API_RESULT | MS_generic_admin_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_Admin_Property Server model. More...
API_RESULT | MS_generic_manufacturer_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_Manufacturer_Property Server model. More...
API_RESULT | MS_generic_client_property_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_SERVER_CB appl_cb)
API to initialize Generic_Client_Property Server model. More...
API_RESULT | MS_generic_user_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_admin_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_manufacturer_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_client_property_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_generic_property_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_GENERIC_PROPERTY_CLIENT_CB appl_cb)
API to initialize Generic_Property Client model. More...
API_RESULT | MS_generic_property_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Generic_Property client model handle. More...
API_RESULT | MS_generic_property_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Generic User, Admin, Manufacturer and Client Property Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_generic_property_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_health_client_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_health_client_api.h File Reference

This file defines the Mesh Health Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_health_client_api.h:

Go to the source code of this file.

Data Structures

struct | MS_HEALTH_STATUS_STRUCT
Health Status message parameters. More...
struct | MS_HEALTH_FAULT_GET_CLEAR_STRUCT
Health Fault Get clear message parameters. More...
struct | MS_HEALTH_FAULT_TEST_STRUCT
Health Fault Test message parameters. More...
struct | MS_HEALTH_PERIOD_STRUCT
Health Period message parameters. More...
struct | MS_HEALTH_ATTENTION_STRUCT
Health Attention message parameters. More...

Macros

#define | MS_health_period_set_unacknowledged(param)
API to set the health period state. More...
#define | MS_health_attention_set(param)
API to set the attention state. More...
#define | MS_health_fault_clear_unacknowledged(param)
API to clear the registered fault state. More...
#define | MS_health_attention_set_unacknowledged(param)
API to set the attention state. More...
#define | MS_health_attention_get()
API to get the attention state. More...
#define | MS_health_fault_test(param)
API to invoke a self-test procedure. More...
#define | MS_health_fault_test_unacknowledged(param)
API to invoke a self-test procedure. More...
#define | MS_health_fault_clear(param)
API to clear the registered fault state. More...
#define | MS_health_fault_get(param)
API to report the registered fault state. More...
#define | MS_health_period_get()
API to get the health period state. More...
#define | MS_health_period_set(param)
API to set the health period state. More...

Typedefs

typedef API_RESULT(* MS_HEALTH_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Health Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_health_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_HEALTH_CLIENT_CB appl_cb)
API to initialize Health Client model. More...
API_RESULT | MS_health_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Health client model handle. More...
API_RESULT | MS_health_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Health Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_health_client_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_health_server_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_health_server_api.h File Reference

This file defines the Mesh Health Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_health_server_api.h:

Go to the source code of this file.

Data Structures

struct MS_HEALTH_SERVER_SELF_TEST
Health Server Self Test Funtion Structure. More...

Macros

#define | MS_HEALTH_FAULT_NO_FAULT 0x00
Health Model - Fault Values. More...
#define | MS_HEALTH_FAULT_BATTERY_LOW_WARNING 0x01
Battery Low Warning.
#define | MS_HEALTH_FAULT_BATTERY_LOW_ERROR 0x02
Battery Low Error.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_WARNING 0x03
Supply Voltage Too Low Warning.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_ERROR 0x04
Supply Voltage Too Low Error.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_WARNING 0x05
Supply Voltage Too High Warning.
#define | MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_ERROR 0x06
Supply Voltage Too High Error.
#define | MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_WARNING 0x07
Power Supply Interrupted Warning.
#define | MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_ERROR 0x08
Power Supply Interrupted Error.
#define | MS_HEALTH_FAULT_NO_LOAD_WARNING 0x09
No Load Warning.
#define | MS_HEALTH_FAULT_NO_LOAD_ERROR 0x0A
No Load Error.
#define | MS_HEALTH_FAULT_OVERLOAD_WARNING 0x0B
Overload Warning.
#define | MS_HEALTH_FAULT_OVERLOAD_ERROR 0x0C
Overload Error.
#define | MS_HEALTH_FAULT_OVERHEAT_WARNING 0x0D
Overheat Warning.
#define | MS_HEALTH_FAULT_OVERHEAT_ERROR 0x0E
Overheat Error.
#define | MS_HEALTH_FAULT_CONDENSATION_WARNING 0x0F
Condensation Warning.
#define | MS_HEALTH_FAULT_CONDENSATION_ERROR 0x10
Condensation Error.
#define | MS_HEALTH_FAULT_VIBRATION_WARNING 0x11
Vibration Warning.
#define | MS_HEALTH_FAULT_VIBRATION_ERROR 0x12
Vibration Error.
#define | MS_HEALTH_FAULT_CONFIGURATION_WARNING 0x13
Configuration Warning.
#define | MS_HEALTH_FAULT_CONFIGURATION_ERROR 0x14
Configuration Error.
#define | MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_WARNING 0x15
Element Not Calibrated Warning.
#define | MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_ERROR 0x16
Element Not Calibrated Error.
#define | MS_HEALTH_FAULT_MEMORY_WARNING 0x17
Memory Warning.
#define | MS_HEALTH_FAULT_MEMORY_ERROR 0x18
Memory Error.
#define | MS_HEALTH_FAULT_SELF_TEST_WARNING 0x19
Self-Test Warning.
#define | MS_HEALTH_FAULT_SELF_TEST_ERROR 0x1A
Self-Test Error.
#define | MS_HEALTH_FAULT_INPUT_TOO_LOW_WARNING 0x1B
Input Too Low Warning.
#define | MS_HEALTH_FAULT_INPUT_TOO_LOW_ERROR 0x1C
Input Too Low Error.
#define | MS_HEALTH_FAULT_INPUT_TOO_HIGH_WARNING 0x1D
Input Too High Warning.
#define | MS_HEALTH_FAULT_INPUT_TOO_HIGH_ERROR 0x1E
Input Too High Error.
#define | MS_HEALTH_FAULT_INPUT_NO_CHANGE_WARNING 0x1F
Input No Change Warning.
#define | MS_HEALTH_FAULT_INPUT_NO_CHANGE_ERROR 0x20
Input No Change Error.
#define | MS_HEALTH_FAULT_ACTUATOR_BLOCKED_WARNING 0x21
Actuator Blocked Warning.
#define | MS_HEALTH_FAULT_ACTUATOR_BLOCKED_ERROR 0x22
Actuator Blocked Error.
#define | MS_HEALTH_FAULT_HOUSING_OPENED_WARNING 0x23
Housing Opened Warning.
#define | MS_HEALTH_FAULT_HOUSING_OPENED_ERROR 0x24
Housing Opened Error.
#define | MS_HEALTH_FAULT_TAMPER_WARNING 0x25
Tamper Warning.
#define | MS_HEALTH_FAULT_TAMPER_ERROR 0x26
Tamper Error.
#define | MS_HEALTH_FAULT_DEVICE_MOVED_WARNING 0x27
Device Moved Warning.
#define | MS_HEALTH_FAULT_DEVICE_MOVED_ERROR 0x28
Device Moved Error.
#define | MS_HEALTH_FAULT_DEVICE_DROPPED_WARNING 0x29
Device Dropped Warning.
#define | MS_HEALTH_FAULT_DEVICE_DROPPED_ERROR 0x2A
Device Dropped Error.
#define | MS_HEALTH_FAULT_OVERFLOW_WARNING 0x2B
Overflow Warning.
#define | MS_HEALTH_FAULT_OVERFLOW_ERROR 0x2C
Overflow Error.
#define | MS_HEALTH_FAULT_EMPTY_WARNING 0x2D
Empty Warning.
#define | MS_HEALTH_FAULT_EMPTY_ERROR 0x2E
Empty Error.
#define | MS_HEALTH_FAULT_INTERNAL_BUS_WARNING 0x2F
Internal Bus Warning.
#define | MS_HEALTH_FAULT_INTERNAL_BUS_ERROR 0x30
Internal Bus Error.
#define | MS_HEALTH_FAULT_MECHANISM_JAMMED_WARNING 0x31
Mechanism Jammed Warning.
#define | MS_HEALTH_FAULT_MECHANISM_JAMMED_ERROR 0x32
Mechanism Jammed Error.
#define | MS_HEALTH_SERVER_ATTENTION_START 0x01
Attention Start.
#define | MS_HEALTH_SERVER_ATTENTION_RESTART 0x02
Attention Restart.
#define | MS_HEALTH_SERVER_ATTENTION_STOP 0x03
Attention Stop.

Typedefs

typedef API_RESULT(* | MS_HEALTH_SERVER_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT8 event_type, UINT8 *event_param, UINT16 param_len) DECL_REENTRANT
Health Server application Asynchronous Notification Callback. More...
typedef void(* | MS_HEALTH_SERVER_SELF_TEST_FN )(UINT8 test_id, UINT16 company_id)
Health Server Self Test Function.

Functions

API_RESULT | MS_health_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, UINT16 company_id, MS_HEALTH_SERVER_SELF_TEST *self_tests, UINT32 num_self_tests, MS_HEALTH_SERVER_CB appl_cb)
API to initialize Health Server model. More...
API_RESULT | MS_health_server_report_fault (MS_ACCESS_MODEL_HANDLE *model_handle, UINT8 test_id, UINT16 company_id, UINT8 fault_code)
API to report self-test fault. More...

Detailed Description

This file defines the Mesh Health Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_health_server_api.h.

Typedef Documentation

typedef API_RESULT(* MS_HEALTH_SERVER_CB)(MS_ACCESS_MODEL_HANDLE *handle, UINT8 event_type, UINT8 *event_param, UINT16 param_len) DECL_REENTRANT

Health Server application Asynchronous Notification Callback.

Description
Health Server calls the registered callback to indicate events occurred to the application.
Parameters
handle | Model Handle.
event_type | Health Server Event type.
event_param | Parameter associated with the event if any or NULL.
param_len | Size of the event parameter data. 0 if event param is NULL.

Definition at line 169 of file MS_health_server_api.h.

Function Documentation

API_RESULT MS_health_server_init | ( | MS_ACCESS_ELEMENT_HANDLE | element_handle,
 |  | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | UINT16 | company_id,
 |  | MS_HEALTH_SERVER_SELF_TEST * | self_tests,
 |  | UINT32 | num_self_tests,
 |  | MS_HEALTH_SERVER_CB | appl_cb
 | ) |  |

API to initialize Health Server model.

Description
This is to initialize Health Server model and to register with Acess layer.
Parameters
[in] | element_handle | Element identifier to be associated with the model instance.
[in,out] | model_handle | Model identifier associated with the model instance on successful initialization. After power cycle of an already provisioned node, the model handle will have valid value and the same will be reused for registration.
[in] | company_id | Company Identifier
[in] | self_tests | List of Self Tests that can be run.
[in] | num_self_tests | Number of Self Tests in the list.
[in] | appl_cb | Application Callback to be used by the Health Server.
Returns
API_SUCCESS or an error code indicating reason for failure
API_RESULT MS_health_server_report_fault | ( | MS_ACCESS_MODEL_HANDLE * | model_handle,
 |  | UINT8 | test_id,
 |  | UINT16 | company_id,
 |  | UINT8 | fault_code
 | ) |  |

API to report self-test fault.

Description
This is to report fault observed during self-test procedure.
Parameters
[in] | model_handle | Model Handle identifying the Health Server model instance.
[in] | test_id | Identifier of the self-test
[in] | company_id | Company Identifier
[in] | fault_code | Fault value indicating the error.
Returns
API_SUCCESS or an error code indicating reason for failure


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_ctl_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_light_ctl_api.h File Reference

This file defines the Mesh Light Ctl Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_light_ctl_api.h:

Go to the source code of this file.

Data Structures

struct | MS_LIGHT_CTL_SET_STRUCT
Light CTL Set message parameters. More...
struct | MS_LIGHT_CTL_STATUS_STRUCT
Light CTL Status message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT
Light CTL Temperature Set message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT
Light CTL Temperature Status message parameters. More...
struct | MS_LIGHT_CTL_DEFAULT_SET_STRUCT
Light CTL Default Set message parameters. More...
struct | MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT
Light CTL Default Status message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT
Light CTL Temperature Range Set message parameters. More...
struct | MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT
Light CTL Temperature Range Status message parameters. More...

Macros

#define | MS_light_ctl_set(param)
API to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element. More...
#define | MS_light_ctl_default_get()
API to get the Light CTL Temperature Default and Light CTL Delta UV Default states of an element. More...
#define | MS_light_ctl_set_unacknowledged(param)
API to set the Light CTL Lightness state, Light CTL Temperature state, and the Light CTL Delta UV state of an element. More...
#define | MS_light_ctl_temperature_range_set_unacknowledged(param)
API to set the Light CTL Temperature Range state of an element. More...
#define | MS_light_ctl_default_set_unacknowledged(param)
API to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element. More...
#define | MS_light_ctl_temperature_get()
API to get the Light CTL Temperature state of an element. More...
#define | MS_light_ctl_temperature_range_set(param)
API to set the Light CTL Temperature Range state of an element. More...
#define | MS_light_ctl_get()
API to get the Light CTL state of an element. More...
#define | MS_light_ctl_default_set(param)
API to set the Light CTL Temperature Default state and the Light CTL Delta UV Default state of an element. More...
#define | MS_light_ctl_temperature_range_get()
API to get the Light CTL Temperature Range state of an element. More...
#define | MS_light_ctl_temperature_set(param)
API to set the Light CTL Temperature state and the Light CTL Delta UV state of an element. More...
#define | MS_light_ctl_temperature_set_unacknowledged(param)
API to set the Light CTL Temperature state and the Light CTL Delta UV state of an element. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_CTL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Ctl Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_CTL_TEMPERATURE_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Ctl Temperature Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_CTL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Ctl Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_light_ctl_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *ctl_model_handle, MS_ACCESS_MODEL_HANDLE *ctl_setup_model_handle, MS_LIGHT_CTL_SERVER_CB appl_cb)
API to initialize Light_Ctl Server model. More...
API_RESULT | MS_light_ctl_temperature_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_CTL_TEMPERATURE_SERVER_CB appl_cb)
API to initialize Light_Ctl_Temperature Server model. More...
API_RESULT | MS_light_ctl_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_ctl_temperature_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_ctl_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_CTL_CLIENT_CB appl_cb)
API to initialize Light_Ctl Client model. More...
API_RESULT | MS_light_ctl_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Ctl client model handle. More...
API_RESULT | MS_light_ctl_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Light Ctl Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_light_ctl_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_hsl_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_light_hsl_api.h File Reference

This file defines the Mesh Light Hsl Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_light_hsl_api.h:

Go to the source code of this file.

Data Structures

struct | MS_LIGHT_HSL_SET_STRUCT
Light HSL Set message parameters. More...
struct | MS_LIGHT_HSL_STATUS_STRUCT
Light HSL Status message parameters. More...
struct | MS_LIGHT_HSL_TARGET_STATUS_STRUCT
Light HSL Target Status message parameters. More...
struct | MS_LIGHT_HSL_DEFAULT_SET_STRUCT
Light HSL Default Set message parameters. More...
struct | MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT
Light HSL Default Status message parameters. More...
struct | MS_LIGHT_HSL_RANGE_SET_STRUCT
Light HSL Range Set message parameters. More...
struct | MS_LIGHT_HSL_RANGE_STATUS_STRUCT
Light HSL Range Status message parameters. More...
struct | MS_LIGHT_HSL_HUE_SET_STRUCT
Light HSL Hue Set message parameters. More...
struct | MS_LIGHT_HSL_HUE_STATUS_STRUCT
Light HSL Hue Status message parameters. More...
struct | MS_LIGHT_HSL_SATURATION_SET_STRUCT
Light HSL Saturation Set message parameters. More...
struct | MS_LIGHT_HSL_SATURATION_STATUS_STRUCT
Light HSL Saturation Status message parameters. More...

Macros

#define | MS_light_hsl_hue_get()
API to get the Light HSL Hue state of an element. More...
#define | MS_light_hsl_set_unacknowledged(param)
API to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element. More...
#define | MS_light_hsl_range_get()
API to get the Light HSL Hue Range and Light HSL Saturation Range states of an element. More...
#define | MS_light_hsl_range_set_unacknowledged(param)
API to set the Light HSL Hue Range and Light HSL Saturation Range states of an element. More...
#define | MS_light_hsl_default_set(param)
API to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. More...
#define | MS_light_hsl_saturation_set_unacknowledged(param)
API to set the target Light HSL Saturation state of an element. More...
#define | MS_light_hsl_set(param)
API to set the Light HSL Lightness state, Light HSL Hue state, and the Light HSL Saturation state of an element. More...
#define | MS_light_hsl_saturation_get()
API to get the Light HSL Saturation state of an element. More...
#define | MS_light_hsl_default_get()
API to to get the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. More...
#define | MS_light_hsl_default_set_unacknowledged(param)
API to set the Light Lightness Default, the Light HSL Hue Default, and Light HSL Saturation Default states of an element. More...
#define | MS_light_hsl_hue_set(param)
API to set the target Light HSL Hue state of an element. More...
#define | MS_light_hsl_range_set(param)
API to set the Light HSL Hue Range and Light HSL Saturation Range states of an element. More...
#define | MS_light_hsl_saturation_set(param)
API to set the target Light HSL Saturation state of an element. More...
#define | MS_light_hsl_target_get()
API to get the target Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element. More...
#define | MS_light_hsl_hue_set_unacknowledged(param)
API to set the target Light HSL Hue state of an element. More...
#define | MS_light_hsl_get()
API to get the Light HSL Lightness, Light HSL Hue, and Light HSL Saturation states of an element. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_HSL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Hsl Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_HSL_HUE_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Hsl Hue Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_HSL_SATURATION_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Hsl Saturation Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_HSL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Hsl Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_light_hsl_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *hsl_model_handle, MS_ACCESS_MODEL_HANDLE *hsl_setup_model_handle, MS_LIGHT_HSL_SERVER_CB appl_cb)
API to initialize Light_Hsl Server model. More...
API_RESULT | MS_light_hsl_hue_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_HSL_HUE_SERVER_CB appl_cb)
API to initialize Light_Hsl_Hue Server model. More...
API_RESULT | MS_light_hsl_saturation_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_HSL_SATURATION_SERVER_CB appl_cb)
API to initialize Light_Hsl_Saturation Server model. More...
API_RESULT | MS_light_hsl_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_hsl_hue_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_hsl_saturation_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_hsl_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_HSL_CLIENT_CB appl_cb)
API to initialize Light_Hsl Client model. More...
API_RESULT | MS_light_hsl_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Hsl client model handle. More...
API_RESULT | MS_light_hsl_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Light Hsl Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_light_hsl_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_lc_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_light_lc_api.h File Reference

This file defines the Mesh Light Lc Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_light_lc_api.h:

Go to the source code of this file.

Data Structures

struct | MS_LIGHT_LC_MODE_STRUCT
Light LC Mode Set/Status message parameters. More...
struct | MS_LIGHT_LC_OM_STRUCT
struct | MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT
Light LC Light OnOff Set message parameters. More...
struct | MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT
Light LC Light OnOff Status message parameters. More...
struct | MS_LIGHT_LC_PROPERTY_GET_STRUCT
Light LC Property Get message parameters. More...
struct | MS_LIGHT_LC_PROPERTY_SET_STRUCT
Light LC Property Set message parameters. More...
struct | MS_LIGHT_LC_PROPERTY_STATUS_STRUCT
Light LC Property Status message parameters. More...

Macros

#define | MS_light_lc_om_set(param)
API to set the Light LC Occupancy Mode state of an element. More...
#define | MS_light_lc_om_set_unacknowledged(param)
API to set the Light LC Occupancy Mode state of an element. More...
#define | MS_light_lc_property_set_unacknowledged(param)
API to set the Light LC Property state of an element. More...
#define | MS_light_lc_property_get(param)
API to to get the Light LC Property state of an element. More...
#define | MS_light_lc_mode_set(param)
API to set the Light LC Mode state of an element. More...
#define | MS_light_lc_mode_get()
API to get the Light LC Mode state of an element. More...
#define | MS_light_lc_property_set(param)
API to set the Light LC Property state of an element. More...
#define | MS_light_lc_om_get()
API to get the Light LC Occupancy Mode state of an element. More...
#define | MS_light_lc_light_onoff_set_unacknowledged(param)
API to set the Light LC Light OnOff state of an element. More...
#define | MS_light_lc_light_onoff_get()
API to get the Light LC Light OnOff state of an element. More...
#define | MS_light_lc_light_onoff_set(param)
API to set the Light LC Light OnOff state of an element. More...
#define | MS_light_lc_mode_set_unacknowledged(param)
API to set the Light LC Mode state of an element. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_LC_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Lc Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_LC_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Lc Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_light_lc_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *lc_model_handle, MS_ACCESS_MODEL_HANDLE *lc_setup_model_handle, MS_LIGHT_LC_SERVER_CB appl_cb)
API to initialize Light_Lc Server model. More...
API_RESULT | MS_light_lc_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_lc_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LC_CLIENT_CB appl_cb)
API to initialize Light_Lc Client model. More...
API_RESULT | MS_light_lc_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Lc client model handle. More...
API_RESULT | MS_light_lc_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Light Lc Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_light_lc_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_lightness_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_light_lightness_api.h File Reference

This file defines the Mesh Light Lightness Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_light_lightness_api.h:

Go to the source code of this file.

Data Structures

struct | MS_LIGHT_LIGHTNESS_SET_STRUCT
Light Lightness Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_STATUS_STRUCT
Light Lightness Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT
Light Lightness Linear Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT
Light Lightness Linear Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT
Light Lightness Last Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT
Light Lightness Default Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT
Light Lightness Range Set message parameters. More...
struct | MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT
Light Lightness Range Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT
Light Lightness Default Status message parameters. More...
struct | MS_LIGHT_LIGHTNESS_LAST_OR_DEFAULT_STATUS_STRUCT

Macros

#define | MS_light_lightness_range_get()
API to get the Light Lightness Range state of an element. More...
#define | MS_light_lightness_linear_set_unacknowledged(param)
API to set the Light Lightness Linear state of an element. More...
#define | MS_light_lightness_last_get()
API to get the Light Lightness Last state of an element. More...
#define | MS_light_lightness_range_set_unacknowledged(param)
API to acknowledged message used to set the Light Lightness Range state of an element. More...
#define | MS_light_lightness_default_set_unacknowledged(param)
API to set the Light Lightness Default state of an element. More...
#define | MS_light_lightness_get()
API to get the Light Lightness Actual state of an element. More...
#define | MS_light_lightness_default_set(param)
API to set the Light Lightness Default state of an element. More...
#define | MS_light_lightness_default_get()
API to get the Light Lightness Default state of an element. More...
#define | MS_light_lightness_linear_get()
API to get the Light Lightness Linear state of an element. More...
#define | MS_light_lightness_linear_set(param)
API to set the Light Lightness Linear state of an element. More...
#define | MS_light_lightness_set(param)
API to set the Light Lightness Actual state of an element. More...
#define | MS_light_lightness_range_set(param)
API to acknowledged message used to set the Light Lightness Range state of an element. More...
#define | MS_light_lightness_set_unacknowledged(param)
API to set the Light Lightness Actual state of an element. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_LIGHTNESS_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Lightness Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Lightness Setup Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_LIGHTNESS_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Lightness Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_light_lightness_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LIGHTNESS_SERVER_CB appl_cb)
API to initialize Light_Lightness Server model. More...
API_RESULT | MS_light_lightness_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB appl_cb)
API to initialize Light_Lightness_Setup Server model. More...
API_RESULT | MS_light_lightness_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_lightness_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_lightness_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_LIGHTNESS_CLIENT_CB appl_cb)
API to initialize Light_Lightness Client model. More...
API_RESULT | MS_light_lightness_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Lightness client model handle. More...
API_RESULT | MS_light_lightness_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Light Lightness Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_light_lightness_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_xyl_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_light_xyl_api.h File Reference

This file defines the Mesh Light Xyl Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_light_xyl_api.h:

Go to the source code of this file.

Data Structures

struct | MS_LIGHT_XYL_SET_STRUCT
Light xyL Set message parameters. More...
struct | MS_LIGHT_XYL_STATUS_STRUCT
Light xyL Status Unacknowledged message parameters. More...
struct | MS_LIGHT_XYL_TARGET_STATUS_STRUCT
Light xyL Target Status Unacknowledged message parameters. More...
struct | MS_LIGHT_XYL_DEFAULT_SET_STRUCT
Light HSL Default Set message parameters. More...
struct | MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT
Light xyL Default Status message parameters. More...
struct | MS_LIGHT_XYL_RANGE_SET_STRUCT
Light xyL Range Set message parameters. More...
struct | MS_LIGHT_XYL_RANGE_STATUS_STRUCT
Light xyL Range Status message parameters. More...

Macros

#define | MS_light_xyl_default_set(param)
API to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. More...
#define | MS_light_xyl_set_unacknowledged(param)
API to set the Light xyL Lightness, Light xyL x state, and the Light xyL y states of an element. More...
#define | MS_light_xyl_range_get()
API to get the Light xyL x Range and Light xyL y Range states of an element. More...
#define | MS_light_xyl_set(param)
API to set the Light xyL Lightness, Light xyL x state, and the Light xyL y states of an element. More...
#define | MS_light_xyl_default_get()
API to get the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. More...
#define | MS_light_xyl_range_set_unacknowledged(param)
API to set the Light xyL x Range and Light xyL y Range states of an element. More...
#define | MS_light_xyl_get()
API to get the Light xyL Lightness, Light xyL x, and Light xyL y states of an element. More...
#define | MS_light_xyl_default_set_unacknowledged(param)
API to set the Light Lightness Default, the Light xyL x Default, and Light xyL y Default states of an element. More...
#define | MS_light_xyl_target_get()
API to get the target Light xyL Lightness, Light xyL x, and Light xyL y states of an element. More...
#define | MS_light_xyl_range_set(param)
API to set the Light xyL x Range and Light xyL y Range states of an element. More...

Typedefs

typedef API_RESULT(* | MS_LIGHT_XYL_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Light Xyl Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_LIGHT_XYL_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Light Xyl Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_light_xyl_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *xyl_model_handle, MS_ACCESS_MODEL_HANDLE *xyl_setup_model_handle, MS_LIGHT_XYL_SERVER_CB appl_cb)
API to initialize Light_Xyl Server model. More...
API_RESULT | MS_light_xyl_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_light_xyl_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_LIGHT_XYL_CLIENT_CB appl_cb)
API to initialize Light_Xyl Client model. More...
API_RESULT | MS_light_xyl_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Light_Xyl client model handle. More...
API_RESULT | MS_light_xyl_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Light Xyl Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_light_xyl_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_ltrn_api.h File Reference

  • mesh
  • export
  • include
Macros | Typedefs | Functions
MS_ltrn_api.h File Reference

This file defines the Mesh Lower Transport Application Interface - includes Data Structures and Methods. More...

#include "MS_net_api.h"
Include dependency graph for MS_ltrn_api.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Macros

#define | MS_UNSEGMENTED_ACCESS_MSG 0x00
Unsgemented Access Message.
#define | MS_SEGMENTED_ACCESS_MSG 0x01
Segmented Access Message.
#define | MS_UNSEGMENTED_CTRL_MSG 0x02
Unsegmented Control Message.
#define | MS_SEGMENTED_CTRL_MSG 0x03
Segmented Control Message.
#define | MS_TRN_CTRL_PKT 0x01
Transport Layer Control Packet.
#define | MS_TRN_ACCESS_PKT 0x00
Access Layer Packet.

Typedefs

typedef UCHAR | MS_TRN_MSG_TYPE
Transport Message Type.
typedef UINT8 | LPN_HANDLE
LPN Handle.
typedef API_RESULT(* | LTRN_NTF_CB )(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, UCHAR szmic, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Lower TRANSPORT Application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_ltrn_register (LTRN_NTF_CB ltrn_cb)
Register Inerface with Lower Transport Layer. More...
API_RESULT | MS_ltrn_send_pdu (MS_NET_ADDR src_addr, MS_NET_ADDR dst_addr, MS_SUBNET_HANDLE subnet_handle, MS_TRN_MSG_TYPE msg_type, UINT8 ttl, UINT8 akf, UINT8 aid, UINT16 seq_zero, UCHAR *buffer, UINT16 buffer_len)
API to send transport PDUs. More...

Detailed Description

This file defines the Mesh Lower Transport Application Interface - includes Data Structures and Methods.

Definition in file MS_ltrn_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_model_states.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros
MS_model_states.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | MS_STATE_GENERIC_ONOFF_STRUCT
Generic OnOff state is a Boolean value that represents the state of an element. More...
struct | MS_STATE_GENERIC_LEVEL_STRUCT
Generic Level state is a 16-bit signed integer (2-s complement) representing the state of an element. More...
struct | MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT
Generic Default Transition Time state determines how long an element shall take to transition from a present state to a new state. More...
struct | MS_STATE_GENERIC_ONPOWERUP_STRUCT
Generic OnPowerUp state is an enumeration representing the behavior of an element when powered up. More...
struct | MS_STATE_GENERIC_POWER_ACTUAL_STRUCT
Generic Power Actual state determines the linear percentage of the maximum power level of an element, representing a range from 0 percent through 100 percent. More...
struct | MS_STATE_GENERIC_POWER_LAST_STRUCT
Generic Power Last state is a 16-bit value representing a percentage ranging from (1/65535) percent to 100 percent. More...
struct | MS_STATE_GENERIC_POWER_DEFAULT_STRUCT
Generic Power Default state is a 16-bit value ranging from 0 through 65535. More...
struct | MS_STATE_GENERIC_POWER_RANGE_STRUCT
Generic Power Range state determines the minimum and maximum power levels of an element relative to the maximum power level an element can output. More...
struct | MS_STATE_GENERIC_POWER_LEVEL_STRUCT
Generic Power Level state is a composite state that includes a Generic Power Actual state, a Generic Power Last state, a Generic Power Default state, and a Generic Power Range state. More...
struct | MS_STATE_GENERIC_BATTERY_STRUCT
Generic Battery state is a set of four values representing the state of a battery. More...
struct | MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT
Generic Global Location state defines location information of an element. More...
struct | MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT
Generic Local Location state defines location information of an element. More...
struct | MS_STATE_GENERIC_LOCATION_STRUCT
Generic Location state is a composite state that includes a Generic Location Global state and a Generic Location Local state. More...
struct | MS_STATE_GENERIC_PROPERTY_STRUCT
Generic Property is a state representing a device property of an element. More...
struct | MS_STATE_GENERIC_USER_PROPERTY_STRUCT
Generic User Property is a state representing a device property of an element. More...
struct | MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT
Generic Admin Property is a state representing a device property of an element that can be read or written. More...
struct | MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT
Generic Manufacturer Property is a state representing a device property of an element that is programmed by a manufacturer and can be read. More...
struct | MS_STATE_GENERIC_PROPERTY_ID_STRUCT
Generic Property ID a read-only state representing a device property that an element supports. More...
struct | MS_STATE_GENERIC_PROPERTY_IDS_STRUCT
Generic Property IDs a state representing a set of device properties that an element supports. More...
struct | MS_STATE_SENSOR_PROPERTY_ID_STRUCT
Sensor Property ID field is a 2-octet value referencing a device property that describes the meaning and the format of data reported by a sensor. More...
struct | MS_STATE_SENSOR_DESCRIPTOR_STRUCT
Sensor Descriptor state represents the attributes describing the sensor data. More...
struct | MS_STATE_SENSOR_SETTINGS_STRUCT
Sensor Settings state controls parameters of a sensor. More...
struct | MS_STATE_SENSOR_SETTING_STRUCT
Sensor Setting state controls parameters of a sensor. More...
struct | MS_STATE_SENSOR_CADENCE_STRUCT
Sensor Cadence state controls the cadence of sensor reports. More...
struct | MS_STATE_SENSOR_DATA_STRUCT
The Sensor Data state is a sequence of one or more pairs of Sensor Property ID and Raw Value fields, with each Raw Value field size and representation defined by the characteristics referenced by the Sensor Property ID. More...
struct | MS_STATE_SENSOR_SERIES_COLUMN_STRUCT
Values measured by sensors may be organized as arrays (and represented as series of columns, such as histograms. More...
struct | MS_STATE_TIME_STRUCT
Mesh defines times based on International Atomic Time (TAI). More...
struct | MS_STATE_TIME_ZONE_STRUCT
Time Zone. More...
struct | MS_STATE_TIME_TAI_UTC_DELTA_STRUCT
TAI-UTC Delta. More...
struct | MS_STATE_TIME_ROLE_STRUCT
The Time Role state of an element. More...
struct | MS_STATE_SCENE_NUMBER_STRUCT
The state to identify a scene. More...
struct | MS_STATE_SCENE_STATUS_STRUCT
The current status of a currently active scene. More...
struct | MS_STATE_SCENE_REGISTER_STATUS_STRUCT
The current status of scene register. More...
struct | MS_STATE_SCHEDULER_SCHEDULES_STRUCT
The current Schedule Register state of an element. More...
struct | MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT
The entry index of the Schedule Register state. More...
struct | MS_STATE_SCHEDULER_ENTRY_STRUCT
The entry of the Schedule Register state. More...
struct | MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT
Light Lightness Linear state represents the lightness of a light on a linear scale. More...
struct | MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT
Light Lightness Actual state represents the lightness of a light on a perceptually uniform lightness scale. More...
struct | MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT
Light Lightness Last state represents the lightness of a light on a perceptually uniform lightness scale. More...
struct | MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT
Light Lightness Default state is a value ranging from 0x0000 to 0xFFFF, representing a default lightness level for the Light Lightness Actual state. More...
struct | MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT
Light Lightness Range state determines the minimum and maximum lightness of an element. More...
struct | MS_STATE_LIGHT_LIGHTNESS_STRUCT
Light Lightness state is a composite state that includes the Light Lightness Linear, the Light Lightness Actual, the Light Lightness Last, and the Light Lightness Default states. More...
struct | MS_STATE_LIGHT_CTL_STRUCT
Light CTL state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states. More...
struct | MS_STATE_LIGHT_CTL_DEFAULT_STRUCT
Light CTL Default state is a composite state that includes the Light CTL Lightness, the Light CTL Temperature and the Light CTL Delta UV states. More...
struct | MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT
Light CTL Temperature state is a composite state that includes the Light CTL Temperature and the Light CTL Delta UV states. More...
struct | MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT
Light CTL Temperature Range state determines the minimum and maximum color temperatures of tunable white light an element is capable of emitting. More...
struct | MS_STATE_LIGHT_HSL_STRUCT
Light HSL state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states. More...
struct | MS_STATE_LIGHT_HSL_TARGET_STRUCT
Light HSL Target state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states. More...
struct | MS_STATE_LIGHT_HSL_DEFAULT_STRUCT
Light HSL Default state is a composite state that includes the Light HSL Lighness, the Light HSL Hue and the Light HSL Saturation states. More...
struct | MS_STATE_LIGHT_HSL_HUE_STRUCT
Light HSL Hue. More...
struct | MS_STATE_LIGHT_HSL_SATURATION_STRUCT
Light HSL Saturation. More...
struct | MS_STATE_LIGHT_HSL_RANGE_STRUCT
Light HSL Range state is a composite state that includes Minimum and Maximum of the Light HSL Hue and the Light HSL Saturation states. More...
struct | MS_STATE_LIGHT_XYL_STRUCT
Light xyL state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states. More...
struct | MS_STATE_LIGHT_XYL_TARGET_STRUCT
Light xyL target state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states. More...
struct | MS_STATE_LIGHT_XYL_DEFAULT_STRUCT
Light xyL default state is a composite state that includes the xyL Lightness, the Light xyL x and the Light xyL y states. More...
struct | MS_STATE_LIGHT_XYL_RANGE_STRUCT
Light xyL Range state determines the minimum and maximum values of the Light xyL x and syL y state of an element. More...
struct | MS_STATE_LIGHT_LC_MODE_STRUCT
Light LC Mode state. More...
struct | MS_STATE_LIGHT_LC_OM_STRUCT
Light LC Occupancy Mode state. More...
struct | MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT
Light LC Light OnOff State. More...
struct | MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT
Property ID identifying a Light LC Property. More...
struct | MS_STATE_LIGHT_LC_PROPERTY_STRUCT
Light LC Property state. More...
struct | MS_EXT_TID_AND_TRANSITION_STRUCT
TID and Transition is a structure which contains Transaction ID (TID) as mandatory field. More...
struct | MS_EXT_STATUS_STRUCT
The Status Code field identifies the Status Code for the last operation. More...
struct | MS_ACCESS_STATE_TRANSITION_TYPE

Macros

#define | MS_STATE_GENERIC_ONOFF_T 0
Model State Type Defines.
#define | MS_STATE_GENERIC_LEVEL_T 1
#define | MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_T 2
#define | MS_STATE_GENERIC_ONPOWERUP_T 3
#define | MS_STATE_GENERIC_POWER_ACTUAL_T 4
#define | MS_STATE_GENERIC_POWER_LAST_T 5
#define | MS_STATE_GENERIC_POWER_DEFAULT_T 6
#define | MS_STATE_GENERIC_POWER_RANGE_T 7
#define | MS_STATE_GENERIC_POWER_LEVEL_T 8
#define | MS_STATE_GENERIC_BATTERY_T 9
#define | MS_STATE_GENERIC_LOCATION_GLOBAL_T 10
#define | MS_STATE_GENERIC_LOCATION_LOCAL_T 11
#define | MS_STATE_GENERIC_LOCATION_T 12
#define | MS_STATE_GENERIC_USER_PROPERTY_T 13
#define | MS_STATE_GENERIC_ADMIN_PROPERTY_T 14
#define | MS_STATE_GENERIC_MANUFACTURER_PROPERTY_T 15
#define | MS_STATE_GENERIC_PROPERTY_ID_T 16
#define | MS_STATE_GENERIC_PROPERTY_IDS_T 17
#define | MS_STATE_SENSOR_PROPERTY_ID_T 18
#define | MS_STATE_SENSOR_DESCRIPTOR_T 19
#define | MS_STATE_SENSOR_SETTINGS_T 20
#define | MS_STATE_SENSOR_SETTING_T 21
#define | MS_STATE_SENSOR_CADENCE_T 22
#define | MS_STATE_SENSOR_DATA_T 23
#define | MS_STATE_SENSOR_SERIES_COLUMN_T 24
#define | MS_STATE_TIME_T 25
#define | MS_STATE_TIME_ZONE_T 26
#define | MS_STATE_TIME_TAI_UTC_DELTA_T 27
#define | MS_STATE_TIME_ROLE_T 28
#define | MS_STATE_SCENE_NUMBER_T 29
#define | MS_STATE_SCENE_STATUS_T 30
#define | MS_STATE_SCENE_REGISTER_STATUS_T 31
#define | MS_STATE_SCHEDULER_SCHEDULES_T 32
#define | MS_STATE_SCHEDULER_ENTRY_INDEX_T 33
#define | MS_STATE_SCHEDULER_ENTRY_T 34
#define | MS_STATE_LIGHT_LIGHTNESS_LINEAR_T 35
#define | MS_STATE_LIGHT_LIGHTNESS_ACTUAL_T 36
#define | MS_STATE_LIGHT_LIGHTNESS_LAST_T 37
#define | MS_STATE_LIGHT_LIGHTNESS_DEFAULT_T 38
#define | MS_STATE_LIGHT_LIGHTNESS_RANGE_T 39
#define | MS_STATE_LIGHT_LIGHTNESS_T 40
#define | MS_STATE_LIGHT_CTL_T 41
#define | MS_STATE_LIGHT_CTL_DEFAULT_T 42
#define | MS_STATE_LIGHT_CTL_TEMPERATURE_T 43
#define | MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_T 44
#define | MS_STATE_LIGHT_HSL_T 45
#define | MS_STATE_LIGHT_HSL_TARGET_T 46
#define | MS_STATE_LIGHT_HSL_DEFAULT_T 47
#define | MS_STATE_LIGHT_HSL_HUE_T 48
#define | MS_STATE_LIGHT_HSL_SATURATION_T 49
#define | MS_STATE_LIGHT_HSL_RANGE_T 50
#define | MS_STATE_LIGHT_XYL_T 51
#define | MS_STATE_LIGHT_XYL_TARGET_T 52
#define | MS_STATE_LIGHT_XYL_DEFAULT_T 53
#define | MS_STATE_LIGHT_XYL_RANGE_T 54
#define | MS_STATE_LIGHT_LC_MODE_T 55
#define | MS_STATE_LIGHT_LC_OM_T 56
#define | MS_STATE_LIGHT_LC_LIGHT_ONOFF_T 57
#define | MS_STATE_LIGHT_LC_PROPERTY_ID_T 58
#define | MS_STATE_LIGHT_LC_PROPERTY_T 59
#define | MS_STATE_GENERIC_USER_PROPERTY_IDS_T 60
#define | MS_STATE_GENERIC_ADMIN_PROPERTY_IDS_T 61
#define | MS_STATE_GENERIC_MANUFACTURER_PROPERTY_IDS_T 62
#define | MS_STATE_GENERIC_CLIENT_PROPERTY_IDS_T 63
#define | MS_STATE_SCENE_STORE_T 64
#define | MS_STATE_SCENE_RECALL_T 65
#define | MS_STATE_SCENE_DELETE_T 66
#define | MS_STATE_DELTA_LEVEL_T 67
#define | MS_STATE_MOVE_LEVEL_T 68
#define | MS_EXT_TID_AND_TRANSITION_STRUCT_T 128
#define | MS_EXT_STATUS_STRUCT_T 129
#define | MS_STATE_SENSOR_SERIES_T 130


EtherMind Mesh SDK (beta): mesh/export/include/MS_net_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_net_api.h File Reference

This file defines the Mesh Network Layer Interface - includes Data Structures and Methods. More...

#include "MS_brr_api.h"
#include "MS_prov_api.h"
Include dependency graph for MS_net_api.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct MS_NET_HEADER
Network Header Type. More...

Macros

#define | MS_NET_ADDR_UNASSIGNED 0x0000
Unassigned Address. More...
#define | MS_NET_ADDR_TYPE_INVALID 0x00
Network Address Type - Invalid.
#define | MS_NET_ADDR_UNICAST_BIT_MASK 0x8000
Unicast Address. More...
#define | MS_NET_ADDR_UNICAST_COMPARE 0x0000
Comparison value for Network Address Type - Unicast.
#define | MS_NET_ADDR_TYPE_UNICAST 0x01
Network Address Type - Unicast.
#define | MS_NET_ADDR_VIRTUAL_BIT_MASK 0xC000
Virtual Address. More...
#define | MS_NET_ADDR_VIRTUAL_COMPARE 0x8000
Comparison value for Network Address Type - Virtual.
#define | MS_NET_ADDR_TYPE_VIRTUAL 0x02
Network Address Type - Virtual.
#define | MS_NET_ADDR_GROUP_BIT_MASK 0xC000
Group Address. More...
#define | MS_NET_ADDR_GROUP_COMPARE 0xC000
Comparison value for Network Address Type - Group.
#define | MS_NET_ADDR_TYPE_GROUP 0x03
Network Address Type - Group.
#define | MS_NET_ADDR_ALL_PROXIES 0xFFFC
Fixed Group Addresses are all-proxies, all-friends, all-relays and all-nodes. More...
#define | MS_NET_ADDR_ALL_FRIENDS 0xFFFD
Fixed Group Address - All-Friends.
#define | MS_NET_ADDR_ALL_RELAYS 0xFFFE
Fixed Group Address - All-Relays.
#define | MS_NET_ADDR_ALL_NODES 0xFFFF
Fixed Group Address - All-Nodes.
#define | MS_NET_FEATURE_PROXY 0x00
Address Validity. More...
#define | MS_NET_FEATURE_RELAY 0x01
Network Layer Feature - Relay.
#define | MS_PRIMARY_SUBNET 0x000
Primary Subnet - NetKey Index is 0x000.
#define | MS_INVALID_SUBNET_HANDLE 0xFFFF
Invalid Subnet Handle.
#define | MS_INVALID_APPKEY_HANDLE 0xFFFF
Invalid AppKey Handle.
#define | MS_PROXY_WHITELIST_FILTER 0x00
GATT Proxy Filter Types. More...
#define | MS_PROXY_BLACKLIST_FILTER 0x01
GATT Proxy Filter Type - Blacklist.
#define | MS_PROXY_SET_FILTER_OPCODE 0x00
GATT Proxy Configuration Opcodes. More...
#define | MS_PROXY_ADD_TO_FILTER_OPCODE 0x01
GATT Proxy Configuration - Add to Filter Opcode.
#define | MS_PROXY_REM_FROM_FILTER_OPCODE 0x02
GATT Proxy Configuration - Remove From Filter Opcode.
#define | MS_PROXY_FILTER_STATUS_OPCODE 0x03
GATT Proxy Configuration - Filter Status Opcode.
#define | MS_PROXY_NET_ID_ADV_MODE 0x01
GATT Proxy ADV Modes. More...
#define | MS_PROXY_NODE_ID_ADV_MODE 0x02
Node Idetity Type.
#define | MS_PROXY_UP_EVENT 0x00
GATT Proxy Events. More...
#define | MS_PROXY_DOWN_EVENT 0x01
GATT Proxy Event - Interface Down.
#define | MS_PROXY_STATUS_EVENT 0x02
GATT Proxy Event - Status.
#define | MS_PROXY_NULL 0x00
GATT Proxy States. More...
#define | MS_PROXY_READY 0x01
GATT Proxy State - Ready/Initialized.
#define | MS_PROXY_CONNECTED 0x02
GATT Proxy State - Connected.
#define | MS_IS_UNICAST_ADDR(addr)
Macro to check if Unicast Address. More...
#define | MS_IS_VIRTUAL_ADDR(addr)
Macro to check if Virtual Address. More...
#define | MS_IS_GROUP_ADDR(addr)
Macro to check if Group Address. More...
#define | NET_IS_VALID_SRC_ADDR(addr) MS_IS_UNICAST_ADDR(addr)
Source address shall be Unicast Address.
#define | NET_IS_VALID_DST_ADDR(addr, ctl)
Destination address. More...
#define | MS_proxy_set_whitelist_filter(nh, sh)
Set Proxy WhiteList Filter. More...
#define | MS_proxy_set_blacklist_filter(nh, sh)
Set Proxy BlackList Filter. More...
#define | MS_proxy_add_to_list(nh, sh, a, c)
Add addressess to Proxy Filter List. More...
#define | MS_proxy_del_from_list(nh, sh, a, c)
Delete addresses from Proxy Filter List. More...

Typedefs

typedef UINT16 | MS_NET_ADDR
Network Address Type.
typedef UINT16 | MS_SUBNET_HANDLE
Subnet Handle.
typedef UINT16 | MS_APPKEY_HANDLE
AppKey Handle.
typedef UCHAR | MS_NET_ADDR_TYPE
Address Type.
typedef UCHAR | PROXY_FILTER_TYPE
Data structures for filter type and address list.
typedef MS_NET_ADDR | PROXY_ADDR
Proxy Address.
typedef UINT8 | NETIF_HANDLE
Network Interface Handle.
typedef API_RESULT(* | NET_NTF_CB )(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
NETWORK Application Asynchronous Notification Callback. More...
typedef void(* | PROXY_NTF_CB )(NETIF_HANDLE *handle, UCHAR p_evt, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Network Proxy Application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_net_register (NET_NTF_CB net_cb)
Register Inerface with NETWORK Layer. More...
API_RESULT | MS_net_broadcast_secure_beacon (MS_SUBNET_HANDLE subnet_handle)
API to send Secure Network Beacon. More...
API_RESULT | MS_net_send_pdu (MS_NET_HEADER *hdr, MS_SUBNET_HANDLE subnet_handle, MS_BUFFER *buffer)
API to send NETWORK PDUs. More...
MS_NET_ADDR_TYPE | MS_net_get_address_type (MS_NET_ADDR addr)
To get address type. More...
API_RESULT | MS_proxy_register (PROXY_NTF_CB proxy_cb)
Register Interface with NETWORK PROXY Layer. More...
API_RESULT | MS_proxy_fetch_state (UCHAR *proxy_state)
Check if the Proxy Module is ready to handle Proxy Messages/Events. More...
API_RESULT | MS_proxy_server_adv_start (MS_SUBNET_HANDLE subnet_handle, UCHAR proxy_adv_mode)
Start Connectable Advertisements for a Proxy Server. More...
API_RESULT | MS_proxy_server_adv_stop (void)
Stop Connectable Advertisements for a Proxy Server. More...
API_RESULT | MS_net_alloc_seq_num (UINT32 *seq_num)
To allocate Sequence Number. More...

Detailed Description

This file defines the Mesh Network Layer Interface - includes Data Structures and Methods.

Definition in file MS_net_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_prov_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_prov_api.h File Reference

This file defines the Mesh Provisioning Application Interface - includes Data Structures and Methods. More...

#include "MS_brr_api.h"
Include dependency graph for MS_prov_api.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | PROV_DEVICE_S
Device Information used for Provisioning. More...
struct | PROV_OOB_TYPE_S
OOB type for provisioning. More...
struct | PROV_CAPABILITIES_S
Device capabilities used for Provisioning. More...
struct | PROV_METHOD_S
Provisioning method information. More...
struct | PROV_DATA_S
Data exchanged during Provisiong procedure. More...

Macros

#define | PROV_ROLE_DEVICE 0x01
Provisiong Roles.
#define | PROV_ROLE_PROVISIONER 0x02
#define | PROV_BRR_ADV 0x01
Provisioning Bearer Types.
#define | PROV_BRR_GATT 0x02
#define | PROV_PDU_TYPE_INVITE 0x00
Provisioning PDU Types.
#define | PROV_PDU_TYPE_CAPAB 0x01
#define | PROV_PDU_TYPE_START 0x02
#define | PROV_PDU_TYPE_PUBKEY 0x03
#define | PROV_PDU_TYPE_INPUT_CMPLT 0x04
#define | PROV_PDU_TYPE_CONF 0x05
#define | PROV_PDU_TYPE_RAND 0x06
#define | PROV_PDU_TYPE_DATA 0x07
#define | PROV_PDU_TYPE_COMPLETE 0x08
#define | PROV_PDU_TYPE_FAILED 0x09
#define | PROV_ALGO_EC_FIPS_P256 0x00
Provisioning algorithm values.
#define | PROV_PUBKEY_NO_OOB 0x00
Provisioning public key values.
#define | PROV_PUBKEY_OOB 0x01
#define | PROV_AUTH_OOB_NONE 0x00
Provisioning authentication method values.
#define | PROV_AUTH_OOB_STATIC 0x01
#define | PROV_AUTH_OOB_OUTPUT 0x02
#define | PROV_AUTH_OOB_INPUT 0x03
#define | PROV_OOOB_ACTION_BLINK 0x00
Provisioning Output OOB action values.
#define | PROV_OOOB_ACTION_BEEP 0x01
#define | PROV_OOOB_ACTION_VIBRATE 0x02
#define | PROV_OOOB_ACTION_NUMERIC 0x03
#define | PROV_OOOB_ACTION_ALPHANUMERIC 0x04
#define | PROV_IOOB_ACTION_PUSH 0x00
Provisioning Input OOB action values.
#define | PROV_IOOB_ACTION_TWIST 0x01
#define | PROV_IOOB_ACTION_NUMERIC 0x02
#define | PROV_IOOB_ACTION_ALPHANUMERIC 0x03
#define | PROV_MASK_ALGO_EC_FIPS_P256 (1 << 0)
Provisioning algorithm support masks.
#define | PROV_MASK_PUBKEY_OOBINFO (1 << 0)
Provisioning public key supported type masks.
#define | PROV_MASK_STATIC_OOBINFO (1 << 0)
Provisioning static oob supported type masks.
#define | PROV_MASK_OOOB_ACTION_BLINK (1 << 0)
Output OOB actions supported masks.
#define | PROV_MASK_OOOB_ACTION_BEEP (1 << 1)
#define | PROV_MASK_OOOB_ACTION_VIBRATE (1 << 2)
#define | PROV_MASK_OOOB_ACTION_NUMERIC (1 << 3)
#define | PROV_MASK_OOOB_ACTION_ALPHANUMERIC (1 << 4)
#define | PROV_MASK_IOOB_ACTION_PUSH (1 << 0)
Input OOB actions supported masks.
#define | PROV_MASK_IOOB_ACTION_TWIST (1 << 1)
#define | PROV_MASK_IOOB_ACTION_NUMERIC (1 << 2)
#define | PROV_MASK_IOOB_ACTION_ALPHANUMERIC (1 << 3)
#define | PROV_PCF_NUM_FRGMNTS 0x00
Number of Fragments - Start of New Transaction.
#define | PROV_PCF_CTRL_MSG 0x01
Control Message.
#define | PROV_PCF_CONTINU_FRGMNT 0x02
Fragment Index - Continuation of a transaction.
#define | PROV_PCF_TX_SPECIFIC 0x03
Transport Specific Messaging (only used by PB ADV)
#define | PROV_PB_ADV_OPEN_REQ 0x00
#define | PROV_PB_ADV_OPEN_CNF 0x01
#define | PROV_PB_ADV_CLOSE_IND 0x02
#define | PROV_PB_GATT_OPEN_IND 0xF1
#define | PROV_PB_GATT_CLOSE_IND 0xF0
#define | PROV_ERR_PROHIBITED 0x00
Provisioning Failure Error Codes.
#define | PROV_ERR_INVALID_PDU 0x01
#define | PROV_ERR_INVALID_FORMAT 0x02
#define | PROV_ERR_UNEXPECTED_PDU 0x03
#define | PROV_ERR_CONFIRMATION_FAILED 0x04
#define | PROV_ERR_OUT_OF_RESOURCES 0x05
#define | PROV_ERR_DECRYPTION_FAILED 0x06
#define | PROV_ERR_UNEXPECTED_ERROR 0x07
#define | PROV_ERR_CANNOT_ASSIGN_ADDRESS 0x08
#define | PROV_CLOSE_REASON_SUCCESS 0x00
Provisioning LinkClose Error codes.
#define | PROV_CLOSE_REASON_TIMEOUT 0x01
#define | PROV_CLOSE_REASON_FAIL 0x02
#define | PROV_KEY_NETKEY_SIZE 16
Provisioning array size requirements.
#define | PROV_OOB_VALUE_SIZE 16
#define | PROV_URI_HASH_SIZE 4
#define | PROV_OOB_TYPE_OTHER (1 << 0)
Provisioning OOB type masks for ADV data.
#define | PROV_OOB_TYPE_URI (1 << 1)
#define | PROV_OOB_TYPE_2DMRC (1 << 2)
#define | PROV_OOB_TYPE_BARCODE (1 << 3)
#define | PROV_OOB_TYPE_NFC (1 << 4)
#define | PROV_OOB_TYPE_NUMBER (1 << 5)
#define | PROV_OOB_TYPE_STRING (1 << 6)
#define | PROV_OOB_TYPE_ONBOX (1 << 11)
#define | PROV_OOB_TYPE_INSIDEBOX (1 << 12)
#define | PROV_OOB_TYPE_ONPIECEOFPAPER (1 << 13)
#define | PROV_OOB_TYPE_INSIDEMANUAL (1 << 14)
#define | PROV_OOB_TYPE_ONDEVICE (1 << 15)
#define | PROV_HANDLE_INVALID 0xFF
Invalid Provisioning Handle.
#define | PROV_EVT_UNPROVISIONED_BEACON 0x01
This event indicates the availability of an unprovisioned device beacon, with the following values as parameters in the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVISIONING_SETUP 0x02
This event indicates that the provisioning procedure capability exchange is complete, with the following values as parameters in the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_OOB_DISPLAY 0x03
This event indicates to the application the OOB random data that is to be displayed on the UI via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_OOB_ENTRY 0x04
This event indicates to the application requesting for OOB random data that is to be used in the procedure via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_DEVINPUT_COMPLETE 0x05
This event indicates to the application that the peer device has completed the Input of OOB when this capability is negotiated via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVDATA_INFO_REQ 0x06
This event indicates to the application requesting for Provisional data to be sent to the peer device via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVDATA_INFO 0x07
This event indicates to the application the Provisional data received from the Provisioner via the PROV_UI_NOTIFY_CB callback. More...
#define | PROV_EVT_PROVISIONING_COMPLETE 0x08
This event indicates to the application that the provisioning procedure is complete via the PROV_UI_NOTIFY_CB callback. More...
#define | MS_prov_setup_device_pbadv(pdev, tmo, phdl) MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_ADV, (pdev), (tmo), (phdl))
Setup the Device for provisioning. More...
#define | MS_prov_setup_provisioner_pbadv(tmo, phdl) MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_ADV, NULL, (tmo), (phdl))
Setup the Provisioner for provisioning. More...
#define | MS_prov_setup_device_pbgatt(pdev, tmo, phdl) MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_GATT, (pdev), (tmo), (phdl))
Setup the device for provisioning. More...
#define | MS_prov_setup_provisioner_pbgatt(tmo, phdl) MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_GATT, NULL, (tmo), (phdl))
Setup the Provisioner for provisioning. More...
#define | MS_prov_start(phandle, pmethod) MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_START, (pmethod), sizeof(PROV_METHOD_S))
Start Provisioning on the select set of device capabilities. More...
#define | MS_prov_input_authval(phandle, pauth, size) MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_INPUT_CMPLT, (pauth), (size))
Input Authentication value from Device/Provisioner application. More...
#define | MS_prov_data(phandle, pdata) MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_DATA, (pdata), sizeof (PROV_DATA_S))
Send provisioning data to the device. More...

Typedefs

typedef UCHAR | PROV_ROLE
Role of the device.
typedef UCHAR | PROV_BRR
Bearer for the provisioning session.
typedef UCHAR | PROV_HANDLE
Handle to reference the active provisioning context.
typedef API_RESULT(* | PROV_UI_NOTIFY_CB )(PROV_HANDLE *phandle, UCHAR event_type, API_RESULT event_result, void *event_data, UINT16 event_datalen)
Provisioning Application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_prov_register (PROV_CAPABILITIES_S *pcapab, PROV_UI_NOTIFY_CB cb)
Register provisioning capabilities and callback. More...
API_RESULT | MS_prov_setup (PROV_ROLE role, PROV_BRR bearer, PROV_DEVICE_S *pdevice, UINT16 timeout)
Setup the device for provisioning. More...
API_RESULT | MS_prov_bind (PROV_BRR bearer, PROV_DEVICE_S *pdevice, UCHAR attention, PROV_HANDLE *phandle)
Bind to the peer device for provisioning. More...
API_RESULT | MS_prov_send_pdu (PROV_HANDLE *phandle, UCHAR pdu, void *pdata, UINT16 datalen)
Send provisioning PDUs to the peer. More...
API_RESULT | MS_prov_set_authval (PROV_HANDLE *phandle, void *pdata, UINT16 datalen)
Set the display authval. More...
API_RESULT | MS_prov_abort (PROV_HANDLE *phandle, UCHAR reason)
Abort the provisioning procedure. More...
API_RESULT | MS_prov_get_local_public_key (UCHAR *public_key)
Utility API to fetch current ECDH Public Key to be used for Provisioning. More...

Detailed Description

This file defines the Mesh Provisioning Application Interface - includes Data Structures and Methods.

Definition in file MS_prov_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_scene_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_scene_api.h File Reference

This file defines the Mesh Scene Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_scene_api.h:

Go to the source code of this file.

Data Structures

struct | MS_SCENE_RECALL_STRUCT
Scene Recall message parameters. More...
struct | MS_SCENE_STATUS_STRUCT
Scene Status message parameters. More...
struct | MS_SCENE_REGISTER_STATUS_STRUCT
Scene Register Status message parameters. More...
struct | MS_SCENE_STRUCT
Scene Store message parameters. More...

Macros

#define | MS_SCENE_EVENT_STORE 0x01
Scene Event Types. More...
#define | MS_SCENE_EVENT_DELETE 0x02
Scene Event - Delete.
#define | MS_SCENE_EVENT_RECALL_START 0x03
Scene Event - Recall Start.
#define | MS_SCENE_EVENT_RECALL_COMPLETE 0x04
Scene Event - Recall Complete.
#define | MS_SCENE_EVENT_RECALL_IMMEDIATE 0x05
Scene Event - Recall Immediate.
#define | MS_scene_recall(param)
API to ecall the current state of an element. More...
#define | MS_scene_recall_unacknowledged(param)
API to ecall the current state of an element. More...
#define | MS_scene_store(param)
API to store the current state of an element as a Scene. More...
#define | MS_scene_delete_unacknowledged(param)
API to delete a Scene from the Scene Register state of an element. More...
#define | MS_scene_get()
API to get the current status of a currently active scene of an element. More...
#define | MS_scene_delete(param)
API to delete a Scene from the Scene Register state of an element. More...
#define | MS_scene_store_unacknowledged(param)
API to store the current state of an element as a Scene. More...
#define | MS_scene_register_get()
API to get the current status of the Scene Register of an element. More...

Typedefs

typedef void *(* | MS_SCENE_SERVER_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT8 event_type, void *event_param, UINT16 event_length, void *context) DECL_REENTRANT
Scene Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SCENE_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Scene Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_scene_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *scene_model_handle, MS_ACCESS_MODEL_HANDLE *scene_setup_model_handle, MS_SCENE_SERVER_CB appl_cb)
API to initialize Scene Server model. More...
API_RESULT | MS_scene_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_scene_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SCENE_CLIENT_CB appl_cb)
API to initialize Scene Client model. More...
API_RESULT | MS_scene_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Scene client model handle. More...
API_RESULT | MS_scene_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Scene Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_scene_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_scheduler_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_scheduler_api.h File Reference

This file defines the Mesh Scheduler Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_scheduler_api.h:

Go to the source code of this file.

Data Structures

struct | MS_SCHEDULER_STATUS_STRUCT
Scheduler Status message parameters. More...
struct | MS_SCHEDULER_ACTION_GET_STRUCT
Scheduler Action Get message parameters. More...
struct | MS_SCHEDULER_ACTION_STATUS_STRUCT
Scheduler Action Status message parameters. More...
struct | MS_SCHEDULER_ACTION_SET_STRUCT
Scheduler Action Set message parameters. More...

Macros

#define | MS_scheduler_action_set(param)
API to set the entry of the Schedule Register state of an element. More...
#define | MS_scheduler_get()
API to get the current Schedule Register state of an element. More...
#define | MS_scheduler_action_set_unacknowledged(param)
API to set the entry of the Schedule Register state of an element. More...
#define | MS_scheduler_action_get(param)
API to report the action defined by the entry of the Schedule Register state of an element, identified by the Index field. More...

Typedefs

typedef API_RESULT(* | MS_SCHEDULER_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Scheduler Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SCHEDULER_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Scheduler Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_scheduler_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *scheduler_model_handle, MS_ACCESS_MODEL_HANDLE *scheduler_setup_model_handle, MS_SCHEDULER_SERVER_CB appl_cb)
API to initialize Scheduler Server model. More...
API_RESULT | MS_scheduler_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_scheduler_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SCHEDULER_CLIENT_CB appl_cb)
API to initialize Scheduler Client model. More...
API_RESULT | MS_scheduler_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Scheduler client model handle. More...
API_RESULT | MS_scheduler_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Scheduler Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_scheduler_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_sensor_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_sensor_api.h File Reference

This file defines the Mesh Sensor Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_sensor_api.h:

Go to the source code of this file.

Data Structures

struct | MS_SENSOR_DESCRIPTOR_GET_STRUCT
Sensor Descriptor Get message parameters. More...
struct | MS_SENSOR_DESCRIPTOR_STATUS_STRUCT
Sensor Descriptor Status message parameters. More...
struct | MS_SENSOR_GET_STRUCT
Sensor Get message parameters. More...
struct | MS_SENSOR_STATUS_STRUCT
Sensor Status message parameters. More...
struct | MS_SENSOR_COLUMN_GET_STRUCT
Sensor Column Get message parameters. More...
struct | MS_SENSOR_COLUMN_STATUS_STRUCT
Sensor Column Status message parameters. More...
struct | MS_SENSOR_SERIES_GET_STRUCT
Sensor Series Get message parameters. More...
struct | MS_SENSOR_SERIES_STATUS_STRUCT
Sensor Series Status message parameters. More...
struct | MS_SENSOR_CADENCE_GET_STRUCT
Sensor Cadence Get message parameters. More...
struct | MS_SENSOR_CADENCE_SET_STRUCT
Sensor Cadence Set message parameters. More...
struct | MS_SENSOR_CADENCE_STATUS_STRUCT
Sensor Cadence Status message parameters. More...
struct | MS_SENSOR_SETTINGS_GET_STRUCT
Sensor Settings Get message parameters. More...
struct | MS_SENSOR_SETTINGS_STATUS_STRUCT
Sensor Setting Status message parameters. More...
struct | MS_SENSOR_SETTING_GET_STRUCT
Sensor Setting Get message parameters. More...
struct | MS_SENSOR_SETTING_SET_STRUCT
Sensor Setting Set message parameters. More...
struct | MS_SENSOR_SETTING_STATUS_STRUCT
Sensor Setting Status message parameters. More...

Macros

#define | MS_sensor_setting_get(param)
API to get the Sensor Setting state of an element. More...
#define | MS_sensor_settings_get(param)
API to get the list of Sensor Setting states of an element. More...
#define | MS_sensor_series_get(param)
API to get a sequence of the Sensor Series Column states. More...
#define | MS_sensor_cadence_get(param)
API to get the Sensor Cadence state of an element. More...
#define | MS_sensor_descriptor_get(param)
API to get the Sensor Descriptor state of all sensors within an element. More...
#define | MS_sensor_cadence_set(param)
API to set the Sensor Cadence state of an element. More...
#define | MS_sensor_setting_set(param)
API to set the Sensor Setting state of an element. More...
#define | MS_sensor_get(param)
API to get the Sensor Data state. More...
#define | MS_sensor_column_get(param)
API to get the Sensor Series Column state. More...
#define | MS_sensor_cadence_set_unacknowledged(param)
API to set the Sensor Cadence state of an element. More...
#define | MS_sensor_setting_set_unacknowledged(param)
API to set the Sensor Setting state of an element. More...

Typedefs

typedef API_RESULT(* | MS_SENSOR_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Sensor Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SENSOR_SETUP_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Sensor Setup Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_SENSOR_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Sensor Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_sensor_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SENSOR_SERVER_CB appl_cb)
API to initialize Sensor Server model. More...
API_RESULT | MS_sensor_setup_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SENSOR_SETUP_SERVER_CB appl_cb)
API to initialize Sensor_Setup Server model. More...
API_RESULT | MS_sensor_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_sensor_setup_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_sensor_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_SENSOR_CLIENT_CB appl_cb)
API to initialize Sensor Client model. More...
API_RESULT | MS_sensor_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Sensor client model handle. More...
API_RESULT | MS_sensor_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Sensor Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_sensor_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_time_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_time_api.h File Reference

This file defines the Mesh Time Model Application Interface. More...

#include "MS_access_api.h"
Include dependency graph for MS_time_api.h:

Go to the source code of this file.

Data Structures

struct | MS_TIME_STRUCT
Time Set message parameters. More...
struct | MS_TIME_ZONE_SET_STRUCT
Time Zone Set message parameters. More...
struct | MS_TIME_ZONE_STATUS_STRUCT
Time Zone Status message parameters. More...
struct | MS_TAI_UTC_DELTA_SET_STRUCT
TAI-UTC Delta Set message parameters. More...
struct | MS_TAI_UTC_DELTA_STATUS_STRUCT
TAI-UTC Delta Status message parameters. More...
struct | MS_TIME_ROLE_STRUCT
Time Role Set/Status message parameters. More...

Macros

#define | MS_time_set(param)
API to set the Time state of an element. More...
#define | MS_time_zone_get()
API to get the Time Zone Offset Current state. More...
#define | MS_tai_utc_delta_set(param)
API to set the TAI-UTC Delta New state and the TAI of Delta Change state. More...
#define | MS_time_role_set(param)
API to set the Time Role state of an element. More...
#define | MS_tai_utc_delta_get()
API to get the TAI-UTC Delta Current state, the TAI-UTC Delta New state, and the TAI of Delta Change state. More...
#define | MS_time_zone_set(param)
API to set the Time Zone Offset New state. More...
#define | MS_time_role_get()
API to get the Time Role state of an element. More...
#define | MS_time_get()
API to get the Time state of neighbor nodes. More...

Typedefs

typedef API_RESULT(* | MS_TIME_SERVER_CB )(MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_REQ_MSG_RAW *msg_raw, MS_ACCESS_MODEL_REQ_MSG_T *req_type, MS_ACCESS_MODEL_STATE_PARAMS *state_params, MS_ACCESS_MODEL_EXT_PARAMS *ext_params) DECL_REENTRANT
Time Server application Asynchronous Notification Callback. More...
typedef API_RESULT(* | MS_TIME_CLIENT_CB )(MS_ACCESS_MODEL_HANDLE *handle, UINT32 opcode, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
Time Client application Asynchronous Notification Callback. More...

Functions

API_RESULT | MS_time_server_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *time_model_handle, MS_ACCESS_MODEL_HANDLE *time_setup_model_handle, MS_TIME_SERVER_CB appl_cb)
API to initialize Time Server model. More...
API_RESULT | MS_time_server_state_update (MS_ACCESS_MODEL_REQ_MSG_CONTEXT *ctx, MS_ACCESS_MODEL_STATE_PARAMS *current_state_params, MS_ACCESS_MODEL_STATE_PARAMS *target_state_params, UINT16 remaining_time, MS_ACCESS_MODEL_EXT_PARAMS *ext_params)
API to send reply or to update state change. More...
API_RESULT | MS_time_client_init (MS_ACCESS_ELEMENT_HANDLE element_handle, MS_ACCESS_MODEL_HANDLE *model_handle, MS_TIME_CLIENT_CB appl_cb)
API to initialize Time Client model. More...
API_RESULT | MS_time_client_get_model_handle (MS_ACCESS_MODEL_HANDLE *model_handle)
API to get Time client model handle. More...
API_RESULT | MS_time_client_send_reliable_pdu (UINT32 req_opcode, void *param, UINT32 rsp_opcode)
API to send acknowledged commands. More...

Detailed Description

This file defines the Mesh Time Model Application Interface.

  • includes Data Structures and Methods for both Server and Client.

Definition in file MS_time_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_trn_api.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Typedefs | Functions
MS_trn_api.h File Reference

This file defines the Mesh Transport Application Interface - includes Data Structures and Methods. More...

#include "MS_ltrn_api.h"
Include dependency graph for MS_trn_api.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | MS_TRN_FRIEND_ENTRY
Friend Data Structure. More...
struct | MS_TRN_FRND_POLL_PARAM
Transport Friend Poll Message. More...
struct | MS_TRN_FRND_UPDATE_PARAM
Transport Friend Update Message. More...
struct | MS_TRN_FRND_REQ_PARAM
Transport Friend Request Message. More...
struct | MS_TRN_FRND_OFFER_PARAM
Transport Friend Offer Message. More...
struct | MS_TRN_FRND_CLEAR_PARAM
Transport Friend Clear Message. More...
struct | MS_TRN_FRND_CLEAR_CNF_PARAM
Transport Friend Clear Confirm Message. More...
struct | MS_TRN_FRND_MANAGE_PARAM
Transport Friend Subscription List Add/Remove Message. More...
struct | MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM
Transport Friend Subscription List Confirm Message. More...
struct | MS_TRN_HEARTBEAT_PARAM
Transport Heartbeat Message. More...
struct | MS_TRN_FRNDSHIP_INFO
Low Power Node element information. More...
struct | MS_TRN_HEARTBEAT_PUBLICATION_INFO
Hearbeat Publication state. More...
struct | MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
Hearbeat Subscription state. More...

Macros

#define | MS_TRN_CTRL_OPCODE_FRND_POLL 0x01
Tranport Layer Control Packet Opcodes. More...
#define | MS_TRN_CTRL_OPCODE_FRND_UPDATE 0x02
Sent by a Friend node to a Low Power node to inform it about cache and/or security updates.
#define | MS_TRN_CTRL_OPCODE_FRND_REQ 0x03
Broadcast by a Low Power node to start to find a friend.
#define | MS_TRN_CTRL_OPCODE_FRND_OFFER 0x04
Sent by a Friend node to a Low Power node to offer to become its friend.
#define | MS_TRN_CTRL_OPCODE_FRND_CLEAR 0x05
Sent to a Friend node to inform a previous friend of a Low Power node about the removal of a friendship.
#define | MS_TRN_CTRL_OPCODE_FRND_CLEAR_CNF 0x06
Sent from a previous friend to Friend node to confirm that a prior friend relationship has been removed.
#define | MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD 0x07
Sent to a Friend node to add one or more addresses to the Friend Subscription List.
#define | MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE 0x08
Sent to a Friend node to remove one or more addresses from the Friend Subscription List.
#define | MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_CNF 0x09
Sent by a Friend node to confirm Friend Subscription List updates.
#define | MS_TRN_CTRL_OPCODE_HEARTBEAT 0x0A
Sent by a node to let other nodes determine topology of a Subnet.
#define | MS_FRNDUPD_FLAG_KEYREF_BIT 0
Parameter defines for Friendship Opcodes. More...
#define | MS_FRNDUPD_FLAG_KEYREF_NOTINPHASE_2 0x00
#define | MS_FRNDUPD_FLAG_KEYREF_INPHASE_2 0x01
#define | MS_FRNDUPD_FLAG_IVUPDATE_BIT 1
#define | MS_FRNDUPD_FLAG_IVUPDATE_NORMAL 0x00
#define | MS_FRNDUPD_FLAG_IVUPDATE_ACTIVE 0x01
#define | MS_FRNDUPD_MD_QUEUE_EMPTY 0x00
Friend Update More Data.
#define | MS_FRNDUPD_MD_QUEUE_NOTEMPTY 0x01
#define | MS_FRNDREQ_RSSIFACTOR_OFFSET 5
Friend Request Criteria.
#define | MS_FRNDREQ_RSSIFACTOR_MASK 0x60
#define | MS_FRNDREQ_RSSIFACTOR_1 0x00
#define | MS_FRNDREQ_RSSIFACTOR_1_5 0x01
#define | MS_FRNDREQ_RSSIFACTOR_2 0x02
#define | MS_FRNDREQ_RSSIFACTOR_2_5 0x03
#define | MS_FRNDREQ_RCVWINFACTOR_OFFSET 3
#define | MS_FRNDREQ_RCVWINFACTOR_MASK 0x18
#define | MS_FRNDREQ_RCVWINFACTOR_1 0x00
#define | MS_FRNDREQ_RCVWINFACTOR_1_5 0x01
#define | MS_FRNDREQ_RCVWINFACTOR_2 0x02
#define | MS_FRNDREQ_RCVWINFACTOR_2_5 0x03
#define | MS_FRNDREQ_MINQSIZELOG_OFFSET 0
#define | MS_FRNDREQ_MINQSIZELOG_MASK 0x07
#define | MS_FRNDREQ_MINQSIZE_INVALID 0x00
#define | MS_FRNDREQ_MINQSIZE_2 0x01
#define | MS_FRNDREQ_MINQSIZE_4 0x02
#define | MS_FRNDREQ_MINQSIZE_8 0x03
#define | MS_FRNDREQ_MINQSIZE_16 0x04
#define | MS_FRNDREQ_MINQSIZE_32 0x05
#define | MS_FRNDREQ_MINQSIZE_64 0x06
#define | MS_FRNDREQ_MINQSIZE_128 0x07
#define | MS_HEARTBEAT_FEATURE_RELAY (1 << 0)
Heartbeat features.
#define | MS_HEARTBEAT_FEATURE_PROXY (1 << 1)
#define | MS_HEARTBEAT_FEATURE_FRIEND (1 << 2)
#define | MS_HEARTBEAT_FEATURE_LOWPOWER (1 << 3)
#define | MS_MIN_FRNDOFFER_DELAY 100 /* ms */
Friendship constants as defined in the specification.
#define | MS_TRN_INITIAL_FRNDPOLL_TIMEOUT 1000 /* ms */
#define | MS_TRN_FRIEND_SETUP_CNF 0x00
#define | MS_TRN_FRIEND_SUBSCRNLIST_CNF 0x01
#define | MS_TRN_FRIEND_CLEAR_CNF 0x02
#define | MS_TRN_FRIEND_TERMINATE_IND 0x03
#define | LPN_HANDLE_INVALID MS_CONFIG_LIMITS(MS_MAX_FRIENDS)
#define | MS_trn_lpn_subscrn_list_add(addr_list, count)
API to add to friend subscription list. More...
#define | MS_trn_lpn_subscrn_list_remove(addr_list, count)
API to remove from friend subscription list. More...

Typedefs

typedef void(* | TRN_NTF_CB )(MS_NET_HEADER *net_hdr, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UCHAR *data_param, UINT16 data_len) DECL_REENTRANT
TRANSPORT Application Asynchronous Notification Callback. More...
typedef void(* | TRN_FRND_CB )(MS_SUBNET_HANDLE subnet_handle, UCHAR event_type, UINT16 status) DECL_REENTRANT
TRANSPORT Application Friendship Asynchronous Notification Callback. More...
typedef UCHAR | MS_TRN_CTRL_PKT_OPCODE
Transport Control Packet Opcode Type.

Functions

API_RESULT | MS_trn_register (TRN_NTF_CB trn_cb, MS_TRN_MSG_TYPE msg_type)
Register Inerface with Transport Layer. More...
API_RESULT | MS_trn_send_access_pdu (MS_NET_ADDR src_addr, MS_NET_ADDR dst_addr, UINT8 *label, MS_SUBNET_HANDLE subnet_handle, MS_APPKEY_HANDLE appkey_handle, UINT8 ttl, void *param)
API to send Access Layer PDUs. More...
API_RESULT | MS_trn_send_control_pdu (MS_NET_ADDR src_addr, MS_NET_ADDR dst_addr, MS_SUBNET_HANDLE subnet_handle, UINT8 ttl, MS_TRN_CTRL_PKT_OPCODE ctrl_opcode, void *param)
API to send transport Control PDUs. More...
API_RESULT | MS_trn_lpn_setup_friendship (MS_SUBNET_HANDLE subnet_handle, UCHAR criteria, UCHAR rx_delay, UINT32 poll_timeout, UINT32 setup_timeout, TRN_FRND_CB cb)
API to setup Friendship. More...
API_RESULT | MS_trn_lpn_clear_friendship (void)
API to terminate friendship. More...
API_RESULT | MS_trn_lpn_manage_subscription (UCHAR action, UINT16 *addr_list, UINT16 count)
API to manage friend subscription list. More...
API_RESULT | MS_trn_is_valid_lpn_element_address (MS_NET_ADDR addr, LPN_HANDLE *lpn_handle)
To check if address matches with any of the LPN. More...
API_RESULT | MS_trn_is_valid_lpn_subscription_address (MS_NET_ADDR addr, LPN_HANDLE *lpn_handle)
To check if valid subscription address of an LPN to receive a packet. More...
API_RESULT | MS_trn_get_lpn_polltimeout (MS_NET_ADDR lpn_addr, UINT32 *poll_timeout)
To get Poll Timeout of an LPN. More...
API_RESULT | MS_trn_get_frndship_info (UINT8 role, UINT16 lpn_index, MS_TRN_FRNDSHIP_INFO *node)
To get the LPN node information. More...
API_RESULT | MS_trn_lpn_register_security_update (MS_SUBNET_HANDLE subnet_handle, UCHAR flag, UINT32 ivindex)
To add the security update information. More...
API_RESULT | MS_trn_set_heartbeat_publication (MS_TRN_HEARTBEAT_PUBLICATION_INFO *info)
To set the Heartbeat publication data. More...
API_RESULT | MS_trn_get_heartbeat_publication (MS_TRN_HEARTBEAT_PUBLICATION_INFO *info)
To get the Heartbeat publication data. More...
API_RESULT | MS_trn_set_heartbeat_subscription (MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO *info)
To set the Heartbeat subscription data. More...
API_RESULT | MS_trn_get_heartbeat_subscription (MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO *info)
To get the Heartbeat subscription data. More...
API_RESULT | MS_trn_trigger_heartbeat (UINT8 change_in_feature_bit)
To trigger Heartbeat send on change in feature. More...

Detailed Description

This file defines the Mesh Transport Application Interface - includes Data Structures and Methods.

Definition in file MS_trn_api.h.


EtherMind Mesh SDK (beta): mesh/export/include/MS_version.h File Reference

  • mesh
  • export
  • include
Data Structures | Macros | Functions
MS_version.h File Reference

This EtherMind Header File containing version number of the stack. More...

#include "MS_common.h"
Include dependency graph for MS_version.h:

Go to the source code of this file.

Data Structures

struct MS_VERSION_NUMBER
Version Number Structure. More...

Macros

#define | MS_MAJOR_VERSION_NUMBER 1
An increment in the major number of the stack implies a large update to the stack. More...
#define | MS_MINOR_VERSION_NUMBER 1
An increment in the minor number of the stack implies an update to fix an observed defect or changes resulting from optimzations performed on the stack or enhancement to accommodate addendums to specifications. More...
#define | MS_SUB_MINOR_VERSION_NUMBER 4
An increment in this number implies a trivial change, changes such as update in debug log, updating comments, macros, conditions renaming, internal function/variable names etc are viewed as changes that result in increment in this number.

Functions

void MS_get_version_number (MS_VERSION_NUMBER *version_number)
Routine to get Stack Version Number. More...

Detailed Description

This EtherMind Header File containing version number of the stack.

Definition in file MS_version.h.

Macro Definition Documentation

#define MS_MAJOR_VERSION_NUMBER 1

An increment in the major number of the stack implies a large update to the stack.

Such an update could occur due to multiple factors, including changes to stack to adhere to new version of the specification or support for new device specializations or in extreme cases a design overhaul to address future needs.

An update in the major number would signify an update to the application interface offered by the stack. Update need not necessarily imply a change in existing interface, it could be additional APIs or events. When an increment in major number occurs, minor & sub-minor numbers are reset to zero. In event of minor number reaching 255, the max permissible number, a change resulting in increment in minor version number will result in increment in major number.

Definition at line 36 of file MS_version.h.

#define MS_MINOR_VERSION_NUMBER 1

An increment in the minor number of the stack implies an update to fix an observed defect or changes resulting from optimzations performed on the stack or enhancement to accommodate addendums to specifications.

Minor utility functions added may also result in increase in this number, however none of these changes are categorized as causing an increment in minor number, cause any change in existing interface. It is possible that an existing functionality is required to be conditionally included; hence feature flag may be introduced to enable or disable inclusion of the functionality. Such a change would be categorized under a change resulting in increment in minor number. When an increment in minor number occurs, sub-minor number is reset to zero. In event of sub-minor number reaching 255, the max permissible number, a change resulting in increment in sub-minor number will result in increment in minor number.

Definition at line 54 of file MS_version.h.

Function Documentation

void MS_get_version_number ( MS_VERSION_NUMBER * version_number )

Routine to get Stack Version Number.

Description
Routine to get the version number of the stack as return value. The version nimber consists of 3 fields: Major Number Minor Number Sub-Minor Number
Parameters
[out] version_number Pointer to MS_VERSION_NUMBER structure to be filled.


EtherMind Mesh SDK (beta): Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • ACCESS_INVALID_DEFAULT_TTL : MS_access_api.h
  • ACCESS_MAX_TTL : MS_access_api.h
  • API_FAILURE : MS_error.h
  • API_RESULT : MS_error.h
  • API_SUCCESS : MS_error.h


EtherMind Mesh SDK (beta): Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- b -

  • BRR_BCON_CB : MS_brr_api.h
  • BRR_BCON_COUNT : MS_brr_api.h
  • BRR_BCON_PASSIVE : MS_brr_api.h
  • BRR_BCON_TTYPE : MS_brr_api.h
  • BRR_BROADCAST : MS_brr_api.h
  • BRR_CLIENT_ROLE : MS_brr_api.h
  • BRR_COUNT : MS_brr_api.h
  • BRR_DISABLE : MS_brr_api.h
  • BRR_ERR_ID : MS_error.h
  • BRR_HANDLE : MS_brr_api.h
  • BRR_HANDLE_INVALID : MS_brr_api.h
  • BRR_IFACE_DOWN : MS_brr_api.h
  • BRR_MAX_PDU_SIZE : MS_brr_api.h
  • BRR_NTF_CB : MS_brr_api.h
  • BRR_TYPE : MS_brr_api.h
  • BRR_TYPE_ADV : MS_brr_api.h
  • BRR_TYPE_BCON : MS_brr_api.h
  • BRR_TYPE_GATT : MS_brr_api.h
  • BRR_TYPE_PB_ADV : MS_brr_api.h
  • BRR_TYPE_PB_GATT : MS_brr_api.h


EtherMind Mesh SDK (beta): Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- l -

  • LPN_HANDLE : MS_ltrn_api.h
  • LTRN_NTF_CB : MS_ltrn_api.h


EtherMind Mesh SDK (beta): Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- m -

  • MESH_AD_TYPE_PB_ADV : MS_assigned_numbers.h
  • MESH_CH_PROVISIONING_DATA_IN : MS_assigned_numbers.h
  • MESH_GATT_SAR_COMPLETE : MS_assigned_numbers.h
  • MESH_GATT_TYPE_NETWORK : MS_assigned_numbers.h
  • MESH_MODEL_CONFIG : MS_assigned_numbers.h
  • MESH_PROVISIONING_SERVICE : MS_assigned_numbers.h
  • MESH_PROXY_SERVICE : MS_assigned_numbers.h
  • MS_ACCESS_ADDRESS_HANDLE : MS_access_api.h
  • MS_ACCESS_ADDRESS_INVALID_HANDLE : MS_access_api.h
  • MS_ACCESS_APPKEY_SIZE : MS_access_api.h
  • MS_ACCESS_ASSIGN_ELEMENT : MS_access_api.h
  • MS_access_bind_model_app() : MS_access_api.h
  • MS_access_cm_add_appkey() : MS_access_api.h
  • MS_access_cm_add_device_key() : MS_access_api.h
  • MS_access_cm_add_friend_sec_credential() : MS_access_api.h
  • MS_access_cm_add_model_subscription() : MS_access_api.h
  • MS_access_cm_add_update_netkey() : MS_access_api.h
  • MS_access_cm_delete_all_model_subscription() : MS_access_api.h
  • MS_access_cm_delete_friend_sec_credential() : MS_access_api.h
  • MS_access_cm_delete_model_subscription() : MS_access_api.h
  • MS_access_cm_delete_netkey() : MS_access_api.h
  • MS_access_cm_find_subnet() : MS_access_api.h
  • MS_access_cm_get_all_model_subscription_list() : MS_access_api.h
  • MS_access_cm_get_app_key() : MS_access_api.h
  • MS_access_cm_get_appkey_handle() : MS_access_api.h
  • MS_access_cm_get_appkey_index_list() : MS_access_api.h
  • MS_access_cm_get_default_ttl() : MS_access_api.h
  • MS_access_cm_get_device_key() : MS_access_api.h
  • MS_access_cm_get_device_key_handle() : MS_access_api.h
  • MS_access_cm_get_element_count() : MS_access_api.h
  • MS_access_cm_get_features() : MS_access_api.h
  • MS_access_cm_get_features_field() : MS_access_api.h
  • MS_access_cm_get_friendship_role() : MS_access_api.h
  • MS_access_cm_get_iv_index() : MS_access_api.h
  • MS_access_cm_get_iv_index_by_ivi() : MS_access_api.h
  • MS_access_cm_get_key_refresh_phase() : MS_access_api.h
  • MS_access_cm_get_model_app_list() : MS_access_api.h
  • MS_access_cm_get_model_publication() : MS_access_api.h
  • MS_access_cm_get_model_subscription_list() : MS_access_api.h
  • MS_access_cm_get_netkey() : MS_access_api.h
  • MS_access_cm_get_netkey_index_list() : MS_access_api.h
  • MS_access_cm_get_node_identity() : MS_access_api.h
  • MS_access_cm_get_primary_unicast_address() : MS_access_api.h
  • MS_access_cm_get_prov_devices_list() : MS_access_api.h
  • MS_access_cm_get_subnet_beacon_key() : MS_access_api.h
  • MS_access_cm_get_subnet_encryption_key() : MS_access_api.h
  • MS_access_cm_get_subnet_identity_key() : MS_access_api.h
  • MS_access_cm_get_subnet_network_id() : MS_access_api.h
  • MS_access_cm_get_subnet_nid() : MS_access_api.h
  • MS_access_cm_get_subnet_privacy_key() : MS_access_api.h
  • MS_access_cm_get_transmit_state() : MS_access_api.h
  • MS_access_cm_lookup_aid() : MS_access_api.h
  • MS_access_cm_lookup_network_id() : MS_access_api.h
  • MS_access_cm_lookup_nid() : MS_access_api.h
  • MS_access_cm_remove_all_device_keys() : MS_access_api.h
  • MS_access_cm_reset() : MS_access_api.h
  • MS_access_cm_set_default_ttl() : MS_access_api.h
  • MS_access_cm_set_features_field() : MS_access_api.h
  • MS_access_cm_set_friendship_role() : MS_access_api.h
  • MS_access_cm_set_iv_index() : MS_access_api.h
  • MS_access_cm_set_key_refresh_phase() : MS_access_api.h
  • MS_access_cm_set_model_publication() : MS_access_api.h
  • MS_access_cm_set_node_identity() : MS_access_api.h
  • MS_access_cm_set_primary_unicast_address() : MS_access_api.h
  • MS_access_cm_set_prov_data() : MS_access_api.h
  • MS_access_cm_set_transmit_state() : MS_access_api.h
  • MS_access_cm_update_delete_appkey() : MS_access_api.h
  • MS_ACCESS_CONFIG_APPKEY_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_BEACON_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_BEACON_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_COMPOSITION_DATA_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_DEFAULT_TTL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_DEFAULT_TTL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_FRIEND_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_FRIEND_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_GATT_PROXY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_GATT_PROXY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_APP_BIND_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_APP_UNBIND_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_PUBLICATION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_PUBLICATION_VIRTUAL_ADDRESS_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_ALL_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_OVERWRITE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_OVERWRITE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_UPDATE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETWORK_TRANSMIT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETWORK_TRANSMIT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_IDENTITY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_IDENTITY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_RESET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_RESET_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_RELAY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_RELAY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_APP_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_APP_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_APP_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_APP_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_LIST_OPCODE : MS_assigned_numbers.h
  • MS_access_create_node() : MS_access_api.h
  • MS_ACCESS_DEFAULT_ELEMENT_HANDLE : MS_access_api.h
  • MS_ACCESS_DEFAULT_NODE_ID : MS_access_api.h
  • MS_ACCESS_DEV_KEY_HANDLE : MS_access_api.h
  • MS_ACCESS_ELEMENT_HANDLE : MS_access_api.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_BATTERY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_BATTERY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_CLIENT_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_CLIENT_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DELTA_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DELTA_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MOVE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MOVE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LAST_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LAST_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_access_get_composition_data() : MS_access_api.h
  • MS_access_get_element_handle() : MS_access_api.h
  • MS_access_get_model_handle() : MS_access_api.h
  • MS_ACCESS_GET_REQ : MS_access_api.h
  • MS_ACCESS_HEALTH_ATTENTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_ATTENTION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_ATTENTION_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_CLEAR_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_CLEAR_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_TEST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_TEST_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_INIT_SIG_MODEL : MS_access_api.h
  • MS_ACCESS_INIT_VENDOR_MODEL : MS_access_api.h
  • MS_ACCESS_INVALID_OPCODE : MS_assigned_numbers.h
  • MS_access_is_fixed_group_addr_to_be_processed() : MS_access_api.h
  • MS_access_is_valid_element_address() : MS_access_api.h
  • MS_access_is_valid_subscription_address() : MS_access_api.h
  • MS_ACCESS_KEY_REFRESH_PHASE_1 : MS_access_api.h
  • MS_ACCESS_KEY_REFRESH_PHASE_2 : MS_access_api.h
  • MS_ACCESS_KEY_REFRESH_PHASE_3 : MS_access_api.h
  • MS_ACCESS_KEY_REFRESH_PHASE_NORMAL : MS_access_api.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_TARGET_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_TARGET_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LAST_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LAST_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_TARGET_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_TARGET_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_MAX_PKT_SIZE : MS_access_api.h
  • MS_ACCESS_MODEL_CB : MS_access_api.h
  • MS_ACCESS_MODEL_HANDLE : MS_access_api.h
  • MS_ACCESS_MODEL_ID_SIG : MS_access_api.h
  • MS_ACCESS_MODEL_ID_VENDOR : MS_access_api.h
  • MS_ACCESS_MODEL_REQ_MSG_T_GET : MS_access_api.h
  • MS_ACCESS_MODEL_REQ_MSG_T_OTHERS : MS_access_api.h
  • MS_ACCESS_MODEL_REQ_MSG_T_SET : MS_access_api.h
  • MS_ACCESS_MODEL_TYPE_SIG : MS_assigned_numbers.h
  • MS_ACCESS_NETKEY_SIZE : MS_access_api.h
  • MS_ACCESS_NODE_ID : MS_access_api.h
  • MS_access_publish() : MS_access_api.h
  • MS_access_register_element() : MS_access_api.h
  • MS_access_register_model() : MS_access_api.h
  • MS_access_reply() : MS_access_api.h
  • MS_ACCESS_SCENE_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_DELETE_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_RECALL_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_RECALL_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_REGISTER_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_STORE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_STORE_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_access_send_pdu() : MS_access_api.h
  • MS_ACCESS_SENSOR_CADENCE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_CADENCE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_CADENCE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_COLUMN_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_COLUMN_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_DESCRIPTOR_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_DESCRIPTOR_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SERIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SERIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTINGS_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTINGS_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SET_REQ : MS_access_api.h
  • MS_ACCESS_TAI_UTC_DELTA_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TAI_UTC_DELTA_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ROLE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ROLE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ROLE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ZONE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ZONE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ZONE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_access_unbind_model_app() : MS_access_api.h
  • MS_ACCESS_VADDR_LABEL_UUID_SIZE : MS_access_api.h
  • MS_APPKEY_HANDLE : MS_net_api.h
  • MS_BCON_OOB_IND_SIZE : MS_common.h
  • MS_BCON_TYPE_SIZE : MS_common.h
  • MS_BCON_TYPE_UNPRVSNG_DEV : MS_common.h
  • MS_BCON_URI_HASH_SIZE : MS_common.h
  • MS_brr_add_bearer() : MS_brr_api.h
  • MS_brr_bcast_end() : MS_brr_api.h
  • MS_brr_bcast_unprovisioned_beacon() : MS_brr_api.h
  • MS_brr_broadcast_beacon() : MS_brr_api.h
  • MS_brr_get_packet_rssi() : MS_brr_api.h
  • MS_brr_observe_beacon() : MS_brr_api.h
  • MS_brr_register() : MS_brr_api.h
  • MS_brr_register_beacon_handler() : MS_brr_api.h
  • MS_brr_remove_bearer() : MS_brr_api.h
  • MS_brr_send_pdu() : MS_brr_api.h
  • MS_brr_sleep() : MS_brr_api.h
  • MS_brr_start_proxy_adv() : MS_brr_api.h
  • MS_brr_wakeup() : MS_brr_api.h
  • MS_CANNOT_BIND : MS_error.h
  • MS_CANNOT_REMOVE : MS_error.h
  • MS_CANNOT_SET : MS_error.h
  • MS_CANNOT_UPDATE : MS_error.h
  • MS_COMMON_ERR_ID : MS_error.h
  • MS_common_get_transition_time_from_ms() : MS_common.h
  • MS_common_start_transition_timer() : MS_common.h
  • MS_common_stop_transition_timer() : MS_common.h
  • MS_config_client_appkey_add : MS_config_api.h
  • MS_config_client_appkey_delete : MS_config_api.h
  • MS_config_client_appkey_get : MS_config_api.h
  • MS_config_client_appkey_update : MS_config_api.h
  • MS_config_client_beacon_get : MS_config_api.h
  • MS_config_client_beacon_set : MS_config_api.h
  • MS_config_client_composition_data_get : MS_config_api.h
  • MS_config_client_default_ttl_get : MS_config_api.h
  • MS_config_client_default_ttl_set : MS_config_api.h
  • MS_config_client_friend_get : MS_config_api.h
  • MS_config_client_friend_set : MS_config_api.h
  • MS_config_client_gatt_proxy_get : MS_config_api.h
  • MS_config_client_gatt_proxy_set : MS_config_api.h
  • MS_config_client_heartbeat_publication_get : MS_config_api.h
  • MS_config_client_heartbeat_publication_set : MS_config_api.h
  • MS_config_client_heartbeat_subscription_get : MS_config_api.h
  • MS_config_client_heartbeat_subscription_set : MS_config_api.h
  • MS_config_client_init() : MS_config_api.h
  • MS_config_client_keyrefresh_phase_get : MS_config_api.h
  • MS_config_client_keyrefresh_phase_set : MS_config_api.h
  • MS_config_client_lpn_polltimeout_get : MS_config_api.h
  • MS_config_client_model_app_bind : MS_config_api.h
  • MS_config_client_model_app_unbind : MS_config_api.h
  • MS_config_client_model_publication_get : MS_config_api.h
  • MS_config_client_model_publication_set : MS_config_api.h
  • MS_config_client_model_publication_vaddr_set : MS_config_api.h
  • MS_config_client_model_subscription_add : MS_config_api.h
  • MS_config_client_model_subscription_delete : MS_config_api.h
  • MS_config_client_model_subscription_delete_all : MS_config_api.h
  • MS_config_client_model_subscription_overwrite : MS_config_api.h
  • MS_config_client_model_subscription_vaddr_add : MS_config_api.h
  • MS_config_client_model_subscription_vaddr_delete : MS_config_api.h
  • MS_config_client_model_subscription_vaddr_overwrite : MS_config_api.h
  • MS_config_client_netkey_add : MS_config_api.h
  • MS_config_client_netkey_delete : MS_config_api.h
  • MS_config_client_netkey_get : MS_config_api.h
  • MS_config_client_netkey_update : MS_config_api.h
  • MS_config_client_network_transmit_get : MS_config_api.h
  • MS_config_client_network_transmit_set : MS_config_api.h
  • MS_config_client_node_identity_get : MS_config_api.h
  • MS_config_client_node_identity_set : MS_config_api.h
  • MS_config_client_node_reset : MS_config_api.h
  • MS_config_client_relay_get : MS_config_api.h
  • MS_config_client_relay_set : MS_config_api.h
  • MS_config_client_send_reliable_pdu() : MS_config_api.h
  • MS_config_client_set_server() : MS_config_api.h
  • MS_config_client_sig_model_app_get : MS_config_api.h
  • MS_config_client_sig_model_subscription_get : MS_config_api.h
  • MS_config_client_vendor_model_app_get : MS_config_api.h
  • MS_config_client_vendor_model_subscription_get : MS_config_api.h
  • MS_CONFIG_MODEL_CB : MS_config_api.h
  • MS_config_server_init() : MS_config_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_ON : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_PROLONG : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_STANDBY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_ON : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_PROLONG : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_STANDBY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_ACCURACY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KID : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KIU : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPD : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPU : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_ON : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_AUTO : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_MANUAL : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_OCCUPANCY_DELAY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_PROLONG : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_RUN_ON : MS_generic_property_api.h
  • MS_DEV_PROP_MOTION_SENSED : MS_generic_property_api.h
  • MS_DEV_PROP_PEOPLE_COUNT : MS_generic_property_api.h
  • MS_DEV_PROP_PRESENCE_DETECTED : MS_generic_property_api.h
  • MS_DEV_PROP_PRESENT_AMBIENT_LIGHT_LEVEL : MS_generic_property_api.h
  • MS_DEV_PROP_TIME_SINCE_MOTION_SENSED : MS_generic_property_api.h
  • MS_DEVICE_UUID_SIZE : MS_common.h
  • MS_DISABLE : MS_common.h
  • MS_DISABLE_FRIEND_FEATURE : MS_access_api.h
  • MS_DISABLE_LPN_FEATURE : MS_access_api.h
  • MS_DISABLE_PROXY_FEATURE : MS_access_api.h
  • MS_DISABLE_RELAY_FEATURE : MS_access_api.h
  • MS_ENABLE : MS_common.h
  • MS_ENABLE_FRIEND_FEATURE : MS_access_api.h
  • MS_ENABLE_LPN_FEATURE : MS_access_api.h
  • MS_ENABLE_PROXY_FEATURE : MS_access_api.h
  • MS_ENABLE_RELAY_FEATURE : MS_access_api.h
  • MS_ERR_ID : MS_error.h
  • MS_FEATURE_FRIEND : MS_common.h
  • MS_FEATURE_LPN : MS_common.h
  • MS_FEATURE_NOT_SUPPORTED : MS_error.h
  • MS_FEATURE_PROXY : MS_common.h
  • MS_FEATURE_RELAY : MS_common.h
  • MS_FEATURE_SEC_NET_BEACON : MS_common.h
  • MS_FRND_ROLE_INVALID : MS_common.h
  • MS_FRNDREQ_RSSIFACTOR_OFFSET : MS_trn_api.h
  • MS_FRNDUPD_FLAG_KEYREF_BIT : MS_trn_api.h
  • MS_FRNDUPD_MD_QUEUE_EMPTY : MS_trn_api.h
  • MS_generic_admin_properties_get : MS_generic_property_api.h
  • MS_generic_admin_property_get : MS_generic_property_api.h
  • MS_generic_admin_property_server_init() : MS_generic_property_api.h
  • MS_generic_admin_property_server_state_update() : MS_generic_property_api.h
  • MS_generic_admin_property_set : MS_generic_property_api.h
  • MS_generic_admin_property_set_unacknowledged : MS_generic_property_api.h
  • MS_GENERIC_BATTERY_CLIENT_CB : MS_generic_battery_api.h
  • MS_generic_battery_client_get_model_handle() : MS_generic_battery_api.h
  • MS_generic_battery_client_init() : MS_generic_battery_api.h
  • MS_generic_battery_client_send_reliable_pdu() : MS_generic_battery_api.h
  • MS_generic_battery_get : MS_generic_battery_api.h
  • MS_GENERIC_BATTERY_SERVER_CB : MS_generic_battery_api.h
  • MS_generic_battery_server_init() : MS_generic_battery_api.h
  • MS_generic_battery_server_state_update() : MS_generic_battery_api.h
  • MS_generic_client_properties_get : MS_generic_property_api.h
  • MS_generic_client_property_server_init() : MS_generic_property_api.h
  • MS_generic_client_property_server_state_update() : MS_generic_property_api.h
  • MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_client_get_model_handle() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_client_init() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_client_send_reliable_pdu() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_get : MS_generic_default_transition_time_api.h
  • MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_server_get_time() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_server_init() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_set : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_set_unacknowledged : MS_generic_default_transition_time_api.h
  • MS_generic_delta_set : MS_generic_level_api.h
  • MS_generic_delta_set_unacknowledged : MS_generic_level_api.h
  • MS_GENERIC_LEVEL_CLIENT_CB : MS_generic_level_api.h
  • MS_generic_level_client_get_model_handle() : MS_generic_level_api.h
  • MS_generic_level_client_init() : MS_generic_level_api.h
  • MS_generic_level_client_send_reliable_pdu() : MS_generic_level_api.h
  • MS_generic_level_get : MS_generic_level_api.h
  • MS_GENERIC_LEVEL_SERVER_CB : MS_generic_level_api.h
  • MS_generic_level_server_init() : MS_generic_level_api.h
  • MS_generic_level_server_state_update() : MS_generic_level_api.h
  • MS_generic_level_set : MS_generic_level_api.h
  • MS_generic_level_set_unacknowledged : MS_generic_level_api.h
  • MS_GENERIC_LOCATION_CLIENT_CB : MS_generic_location_api.h
  • MS_generic_location_client_get_model_handle() : MS_generic_location_api.h
  • MS_generic_location_client_init() : MS_generic_location_api.h
  • MS_generic_location_client_send_reliable_pdu() : MS_generic_location_api.h
  • MS_generic_location_global_get : MS_generic_location_api.h
  • MS_generic_location_global_set : MS_generic_location_api.h
  • MS_generic_location_global_set_unacknowledged : MS_generic_location_api.h
  • MS_generic_location_local_get : MS_generic_location_api.h
  • MS_generic_location_local_set : MS_generic_location_api.h
  • MS_generic_location_local_set_unacknowledged : MS_generic_location_api.h
  • MS_GENERIC_LOCATION_SERVER_CB : MS_generic_location_api.h
  • MS_generic_location_server_init() : MS_generic_location_api.h
  • MS_generic_location_server_state_update() : MS_generic_location_api.h
  • MS_GENERIC_LOCATION_SETUP_SERVER_CB : MS_generic_location_api.h
  • MS_generic_location_setup_server_init() : MS_generic_location_api.h
  • MS_generic_location_setup_server_state_update() : MS_generic_location_api.h
  • MS_generic_manufacturer_properties_get : MS_generic_property_api.h
  • MS_generic_manufacturer_property_get : MS_generic_property_api.h
  • MS_generic_manufacturer_property_server_init() : MS_generic_property_api.h
  • MS_generic_manufacturer_property_server_state_update() : MS_generic_property_api.h
  • MS_generic_manufacturer_property_set : MS_generic_property_api.h
  • MS_generic_manufacturer_property_set_unacknowledged : MS_generic_property_api.h
  • MS_generic_move_set : MS_generic_level_api.h
  • MS_generic_move_set_unacknowledged : MS_generic_level_api.h
  • MS_GENERIC_ONOFF_CLIENT_CB : MS_generic_onoff_api.h
  • MS_generic_onoff_client_get_model_handle() : MS_generic_onoff_api.h
  • MS_generic_onoff_client_init() : MS_generic_onoff_api.h
  • MS_generic_onoff_client_send_reliable_pdu() : MS_generic_onoff_api.h
  • MS_generic_onoff_get : MS_generic_onoff_api.h
  • MS_GENERIC_ONOFF_SERVER_CB : MS_generic_onoff_api.h
  • MS_generic_onoff_server_init() : MS_generic_onoff_api.h
  • MS_generic_onoff_server_state_update() : MS_generic_onoff_api.h
  • MS_generic_onoff_set : MS_generic_onoff_api.h
  • MS_generic_onoff_set_unacknowledged : MS_generic_onoff_api.h
  • MS_generic_onpowerup_get : MS_generic_power_onoff_api.h
  • MS_generic_onpowerup_set : MS_generic_power_onoff_api.h
  • MS_generic_onpowerup_set_unacknowledged : MS_generic_power_onoff_api.h
  • MS_generic_power_default_get : MS_generic_power_level_api.h
  • MS_generic_power_default_set : MS_generic_power_level_api.h
  • MS_generic_power_default_set_unacknowledged : MS_generic_power_level_api.h
  • MS_generic_power_last_get : MS_generic_power_level_api.h
  • MS_GENERIC_POWER_LEVEL_CLIENT_CB : MS_generic_power_level_api.h
  • MS_generic_power_level_client_get_model_handle() : MS_generic_power_level_api.h
  • MS_generic_power_level_client_init() : MS_generic_power_level_api.h
  • MS_generic_power_level_client_send_reliable_pdu() : MS_generic_power_level_api.h
  • MS_generic_power_level_get : MS_generic_power_level_api.h
  • MS_GENERIC_POWER_LEVEL_SERVER_CB : MS_generic_power_level_api.h
  • MS_generic_power_level_server_init() : MS_generic_power_level_api.h
  • MS_generic_power_level_server_state_update() : MS_generic_power_level_api.h
  • MS_generic_power_level_set : MS_generic_power_level_api.h
  • MS_generic_power_level_set_unacknowledged : MS_generic_power_level_api.h
  • MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB : MS_generic_power_level_api.h
  • MS_generic_power_level_setup_server_init() : MS_generic_power_level_api.h
  • MS_generic_power_level_setup_server_state_update() : MS_generic_power_level_api.h
  • MS_GENERIC_POWER_ONOFF_CLIENT_CB : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_client_get_model_handle() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_client_init() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_client_send_reliable_pdu() : MS_generic_power_onoff_api.h
  • MS_GENERIC_POWER_ONOFF_SERVER_CB : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_server_init() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_server_state_update() : MS_generic_power_onoff_api.h
  • MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_setup_server_init() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_setup_server_state_update() : MS_generic_power_onoff_api.h
  • MS_generic_power_range_get : MS_generic_power_level_api.h
  • MS_generic_power_range_set : MS_generic_power_level_api.h
  • MS_generic_power_range_set_unacknowledged : MS_generic_power_level_api.h
  • MS_GENERIC_PROP_TYPE_ADMIN : MS_generic_property_api.h
  • MS_GENERIC_PROP_TYPE_MANUFACTURER : MS_generic_property_api.h
  • MS_GENERIC_PROP_TYPE_USER : MS_generic_property_api.h
  • MS_GENERIC_PROPERTY_CLIENT_CB : MS_generic_property_api.h
  • MS_generic_property_client_get_model_handle() : MS_generic_property_api.h
  • MS_generic_property_client_init() : MS_generic_property_api.h
  • MS_generic_property_client_send_reliable_pdu() : MS_generic_property_api.h
  • MS_GENERIC_PROPERTY_SERVER_CB : MS_generic_property_api.h
  • MS_GENERIC_USER_ACCESS_PROHIBITED : MS_generic_property_api.h
  • MS_generic_user_properties_get : MS_generic_property_api.h
  • MS_generic_user_property_get : MS_generic_property_api.h
  • MS_generic_user_property_server_init() : MS_generic_property_api.h
  • MS_generic_user_property_server_state_update() : MS_generic_property_api.h
  • MS_generic_user_property_set : MS_generic_property_api.h
  • MS_generic_user_property_set_unacknowledged : MS_generic_property_api.h
  • MS_get_version_number() : MS_version.h
  • MS_health_attention_get : MS_health_client_api.h
  • MS_health_attention_set : MS_health_client_api.h
  • MS_health_attention_set_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_CLIENT_CB : MS_health_client_api.h
  • MS_health_client_get_model_handle() : MS_health_client_api.h
  • MS_health_client_init() : MS_health_client_api.h
  • MS_health_client_send_reliable_pdu() : MS_health_client_api.h
  • MS_HEALTH_FAULT_ACTUATOR_BLOCKED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_ACTUATOR_BLOCKED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_BATTERY_LOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_BATTERY_LOW_WARNING : MS_health_server_api.h
  • MS_health_fault_clear : MS_health_client_api.h
  • MS_health_fault_clear_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_FAULT_CONDENSATION_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_CONDENSATION_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_CONFIGURATION_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_CONFIGURATION_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_DROPPED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_DROPPED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_MOVED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_MOVED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_EMPTY_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_EMPTY_WARNING : MS_health_server_api.h
  • MS_health_fault_get : MS_health_client_api.h
  • MS_HEALTH_FAULT_HOUSING_OPENED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_HOUSING_OPENED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_NO_CHANGE_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_NO_CHANGE_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_HIGH_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_HIGH_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_LOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_LOW_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INTERNAL_BUS_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INTERNAL_BUS_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_MECHANISM_JAMMED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_MECHANISM_JAMMED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_MEMORY_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_MEMORY_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_NO_FAULT : MS_health_server_api.h
  • MS_HEALTH_FAULT_NO_LOAD_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_NO_LOAD_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERFLOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERFLOW_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERHEAT_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERHEAT_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERLOAD_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERLOAD_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_SELF_TEST_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_SELF_TEST_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_TAMPER_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_TAMPER_WARNING : MS_health_server_api.h
  • MS_health_fault_test : MS_health_client_api.h
  • MS_health_fault_test_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_FAULT_VIBRATION_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_VIBRATION_WARNING : MS_health_server_api.h
  • MS_health_period_get : MS_health_client_api.h
  • MS_health_period_set : MS_health_client_api.h
  • MS_health_period_set_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_SERVER_ATTENTION_RESTART : MS_health_server_api.h
  • MS_HEALTH_SERVER_ATTENTION_START : MS_health_server_api.h
  • MS_HEALTH_SERVER_ATTENTION_STOP : MS_health_server_api.h
  • MS_HEALTH_SERVER_CB : MS_health_server_api.h
  • MS_health_server_init() : MS_health_server_api.h
  • MS_health_server_report_fault() : MS_health_server_api.h
  • MS_HEALTH_SERVER_SELF_TEST_FN : MS_health_server_api.h
  • MS_HEARTBEAT_FEATURE_RELAY : MS_trn_api.h
  • MS_init() : MS_common.h
  • MS_INSUFFICIENT_RESOURCES : MS_error.h
  • MS_INVALID_ADDRESS : MS_error.h
  • MS_INVALID_APPKEY_HANDLE : MS_net_api.h
  • MS_INVALID_APPKEY_INDEX : MS_error.h
  • MS_INVALID_BINDING : MS_error.h
  • MS_INVALID_MODEL : MS_error.h
  • MS_INVALID_NETKEY_INDEX : MS_error.h
  • MS_INVALID_PUBLISH_PARAMETER : MS_error.h
  • MS_INVALID_SUBNET_HANDLE : MS_net_api.h
  • MS_IS_GROUP_ADDR : MS_net_api.h
  • MS_IS_UNICAST_ADDR : MS_net_api.h
  • MS_IS_VIRTUAL_ADDR : MS_net_api.h
  • MS_KEY_INDEX_ALREADY_STORED : MS_error.h
  • MS_LABEL_UUID_LENGTH : MS_common.h
  • MS_LIGHT_CTL_CLIENT_CB : MS_light_ctl_api.h
  • MS_light_ctl_client_get_model_handle() : MS_light_ctl_api.h
  • MS_light_ctl_client_init() : MS_light_ctl_api.h
  • MS_light_ctl_client_send_reliable_pdu() : MS_light_ctl_api.h
  • MS_light_ctl_default_get : MS_light_ctl_api.h
  • MS_light_ctl_default_set : MS_light_ctl_api.h
  • MS_light_ctl_default_set_unacknowledged : MS_light_ctl_api.h
  • MS_light_ctl_get : MS_light_ctl_api.h
  • MS_LIGHT_CTL_SERVER_CB : MS_light_ctl_api.h
  • MS_light_ctl_server_init() : MS_light_ctl_api.h
  • MS_light_ctl_server_state_update() : MS_light_ctl_api.h
  • MS_light_ctl_set : MS_light_ctl_api.h
  • MS_light_ctl_set_unacknowledged : MS_light_ctl_api.h
  • MS_light_ctl_temperature_get : MS_light_ctl_api.h
  • MS_light_ctl_temperature_range_get : MS_light_ctl_api.h
  • MS_light_ctl_temperature_range_set : MS_light_ctl_api.h
  • MS_light_ctl_temperature_range_set_unacknowledged : MS_light_ctl_api.h
  • MS_LIGHT_CTL_TEMPERATURE_SERVER_CB : MS_light_ctl_api.h
  • MS_light_ctl_temperature_server_init() : MS_light_ctl_api.h
  • MS_light_ctl_temperature_server_state_update() : MS_light_ctl_api.h
  • MS_light_ctl_temperature_set : MS_light_ctl_api.h
  • MS_light_ctl_temperature_set_unacknowledged : MS_light_ctl_api.h
  • MS_LIGHT_HSL_CLIENT_CB : MS_light_hsl_api.h
  • MS_light_hsl_client_get_model_handle() : MS_light_hsl_api.h
  • MS_light_hsl_client_init() : MS_light_hsl_api.h
  • MS_light_hsl_client_send_reliable_pdu() : MS_light_hsl_api.h
  • MS_light_hsl_default_get : MS_light_hsl_api.h
  • MS_light_hsl_default_set : MS_light_hsl_api.h
  • MS_light_hsl_default_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_get : MS_light_hsl_api.h
  • MS_light_hsl_hue_get : MS_light_hsl_api.h
  • MS_LIGHT_HSL_HUE_SERVER_CB : MS_light_hsl_api.h
  • MS_light_hsl_hue_server_init() : MS_light_hsl_api.h
  • MS_light_hsl_hue_server_state_update() : MS_light_hsl_api.h
  • MS_light_hsl_hue_set : MS_light_hsl_api.h
  • MS_light_hsl_hue_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_range_get : MS_light_hsl_api.h
  • MS_light_hsl_range_set : MS_light_hsl_api.h
  • MS_light_hsl_range_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_saturation_get : MS_light_hsl_api.h
  • MS_LIGHT_HSL_SATURATION_SERVER_CB : MS_light_hsl_api.h
  • MS_light_hsl_saturation_server_init() : MS_light_hsl_api.h
  • MS_light_hsl_saturation_server_state_update() : MS_light_hsl_api.h
  • MS_light_hsl_saturation_set : MS_light_hsl_api.h
  • MS_light_hsl_saturation_set_unacknowledged : MS_light_hsl_api.h
  • MS_LIGHT_HSL_SERVER_CB : MS_light_hsl_api.h
  • MS_light_hsl_server_init() : MS_light_hsl_api.h
  • MS_light_hsl_server_state_update() : MS_light_hsl_api.h
  • MS_light_hsl_set : MS_light_hsl_api.h
  • MS_light_hsl_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_target_get : MS_light_hsl_api.h
  • MS_LIGHT_LC_CLIENT_CB : MS_light_lc_api.h
  • MS_light_lc_client_get_model_handle() : MS_light_lc_api.h
  • MS_light_lc_client_init() : MS_light_lc_api.h
  • MS_light_lc_client_send_reliable_pdu() : MS_light_lc_api.h
  • MS_light_lc_light_onoff_get : MS_light_lc_api.h
  • MS_light_lc_light_onoff_set : MS_light_lc_api.h
  • MS_light_lc_light_onoff_set_unacknowledged : MS_light_lc_api.h
  • MS_light_lc_mode_get : MS_light_lc_api.h
  • MS_light_lc_mode_set : MS_light_lc_api.h
  • MS_light_lc_mode_set_unacknowledged : MS_light_lc_api.h
  • MS_light_lc_om_get : MS_light_lc_api.h
  • MS_light_lc_om_set : MS_light_lc_api.h
  • MS_light_lc_om_set_unacknowledged : MS_light_lc_api.h
  • MS_light_lc_property_get : MS_light_lc_api.h
  • MS_light_lc_property_set : MS_light_lc_api.h
  • MS_light_lc_property_set_unacknowledged : MS_light_lc_api.h
  • MS_LIGHT_LC_SERVER_CB : MS_light_lc_api.h
  • MS_light_lc_server_init() : MS_light_lc_api.h
  • MS_light_lc_server_state_update() : MS_light_lc_api.h
  • MS_LIGHT_LIGHTNESS_CLIENT_CB : MS_light_lightness_api.h
  • MS_light_lightness_client_get_model_handle() : MS_light_lightness_api.h
  • MS_light_lightness_client_init() : MS_light_lightness_api.h
  • MS_light_lightness_client_send_reliable_pdu() : MS_light_lightness_api.h
  • MS_light_lightness_default_get : MS_light_lightness_api.h
  • MS_light_lightness_default_set : MS_light_lightness_api.h
  • MS_light_lightness_default_set_unacknowledged : MS_light_lightness_api.h
  • MS_light_lightness_get : MS_light_lightness_api.h
  • MS_light_lightness_last_get : MS_light_lightness_api.h
  • MS_light_lightness_linear_get : MS_light_lightness_api.h
  • MS_light_lightness_linear_set : MS_light_lightness_api.h
  • MS_light_lightness_linear_set_unacknowledged : MS_light_lightness_api.h
  • MS_light_lightness_range_get : MS_light_lightness_api.h
  • MS_light_lightness_range_set : MS_light_lightness_api.h
  • MS_light_lightness_range_set_unacknowledged : MS_light_lightness_api.h
  • MS_LIGHT_LIGHTNESS_SERVER_CB : MS_light_lightness_api.h
  • MS_light_lightness_server_init() : MS_light_lightness_api.h
  • MS_light_lightness_server_state_update() : MS_light_lightness_api.h
  • MS_light_lightness_set : MS_light_lightness_api.h
  • MS_light_lightness_set_unacknowledged : MS_light_lightness_api.h
  • MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB : MS_light_lightness_api.h
  • MS_light_lightness_setup_server_init() : MS_light_lightness_api.h
  • MS_light_lightness_setup_server_state_update() : MS_light_lightness_api.h
  • MS_LIGHT_XYL_CLIENT_CB : MS_light_xyl_api.h
  • MS_light_xyl_client_get_model_handle() : MS_light_xyl_api.h
  • MS_light_xyl_client_init() : MS_light_xyl_api.h
  • MS_light_xyl_client_send_reliable_pdu() : MS_light_xyl_api.h
  • MS_light_xyl_default_get : MS_light_xyl_api.h
  • MS_light_xyl_default_set : MS_light_xyl_api.h
  • MS_light_xyl_default_set_unacknowledged : MS_light_xyl_api.h
  • MS_light_xyl_get : MS_light_xyl_api.h
  • MS_light_xyl_range_get : MS_light_xyl_api.h
  • MS_light_xyl_range_set : MS_light_xyl_api.h
  • MS_light_xyl_range_set_unacknowledged : MS_light_xyl_api.h
  • MS_LIGHT_XYL_SERVER_CB : MS_light_xyl_api.h
  • MS_light_xyl_server_init() : MS_light_xyl_api.h
  • MS_light_xyl_server_state_update() : MS_light_xyl_api.h
  • MS_light_xyl_set : MS_light_xyl_api.h
  • MS_light_xyl_set_unacknowledged : MS_light_xyl_api.h
  • MS_light_xyl_target_get : MS_light_xyl_api.h
  • MS_ltrn_register() : MS_ltrn_api.h
  • MS_ltrn_send_pdu() : MS_ltrn_api.h
  • MS_MAJOR_VERSION_NUMBER : MS_version.h
  • MS_MIN_FRNDOFFER_DELAY : MS_trn_api.h
  • MS_MINOR_VERSION_NUMBER : MS_version.h
  • MS_MODEL_ID_CONFIG_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_CONFIG_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_ADMIN_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_BATTERY_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_BATTERY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_CLIENT_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LEVEL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LEVEL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LOCATION_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LOCATION_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LOCATION_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_MANUFACTURER_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_ONOFF_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_ONOFF_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_LEVEL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_LEVEL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_LEVEL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_ONOFF_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_ONOFF_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_ONOFF_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_PROPERTY_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_USER_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_HEALTH_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_HEALTH_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_TEMPERATURE_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_HUE_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_SATURATION_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LC_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LC_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LC_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LIGHTNESS_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LIGHTNESS_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LIGHTNESS_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_XYL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_XYL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_XYL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCENE_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_SCENE_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCENE_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCHEDULER_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_SCHEDULER_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCHEDULER_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SENSOR_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_SENSOR_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SENSOR_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_TIME_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_TIME_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_TIME_SETUP_SERVER : MS_assigned_numbers.h
  • MS_NET_ADDR : MS_net_api.h
  • MS_NET_ADDR_ALL_FRIENDS : MS_net_api.h
  • MS_NET_ADDR_ALL_NODES : MS_net_api.h
  • MS_NET_ADDR_ALL_PROXIES : MS_net_api.h
  • MS_NET_ADDR_ALL_RELAYS : MS_net_api.h
  • MS_NET_ADDR_GROUP_BIT_MASK : MS_net_api.h
  • MS_NET_ADDR_GROUP_COMPARE : MS_net_api.h
  • MS_NET_ADDR_TYPE : MS_net_api.h
  • MS_NET_ADDR_TYPE_GROUP : MS_net_api.h
  • MS_NET_ADDR_TYPE_INVALID : MS_net_api.h
  • MS_NET_ADDR_TYPE_UNICAST : MS_net_api.h
  • MS_NET_ADDR_TYPE_VIRTUAL : MS_net_api.h
  • MS_NET_ADDR_UNASSIGNED : MS_net_api.h
  • MS_NET_ADDR_UNICAST_BIT_MASK : MS_net_api.h
  • MS_NET_ADDR_UNICAST_COMPARE : MS_net_api.h
  • MS_NET_ADDR_VIRTUAL_BIT_MASK : MS_net_api.h
  • MS_NET_ADDR_VIRTUAL_COMPARE : MS_net_api.h
  • MS_net_alloc_seq_num() : MS_net_api.h
  • MS_net_broadcast_secure_beacon() : MS_net_api.h
  • MS_NET_FEATURE_PROXY : MS_net_api.h
  • MS_NET_FEATURE_RELAY : MS_net_api.h
  • MS_net_get_address_type() : MS_net_api.h
  • MS_net_register() : MS_net_api.h
  • MS_net_send_pdu() : MS_net_api.h
  • MS_NETWORK_TX_STATE : MS_common.h
  • MS_NONCE_T_NETWORK : MS_assigned_numbers.h
  • MS_NOT_A_SUBSCRIBE_MODEL : MS_error.h
  • MS_NOT_SUPPORTED : MS_common.h
  • MS_PACK_LE_1_BYTE : MS_common.h
  • MS_PRIMARY_SUBNET : MS_net_api.h
  • MS_prov_abort() : MS_prov_api.h
  • MS_prov_bind() : MS_prov_api.h
  • MS_prov_data : MS_prov_api.h
  • MS_prov_get_local_public_key() : MS_prov_api.h
  • MS_prov_input_authval : MS_prov_api.h
  • MS_prov_register() : MS_prov_api.h
  • MS_prov_send_pdu() : MS_prov_api.h
  • MS_prov_set_authval() : MS_prov_api.h
  • MS_prov_setup() : MS_prov_api.h
  • MS_prov_setup_device_pbadv : MS_prov_api.h
  • MS_prov_setup_device_pbgatt : MS_prov_api.h
  • MS_prov_setup_provisioner_pbadv : MS_prov_api.h
  • MS_prov_setup_provisioner_pbgatt : MS_prov_api.h
  • MS_prov_start : MS_prov_api.h
  • MS_PROXY_ADD_TO_FILTER_OPCODE : MS_net_api.h
  • MS_proxy_add_to_list : MS_net_api.h
  • MS_PROXY_BLACKLIST_FILTER : MS_net_api.h
  • MS_PROXY_CONNECTED : MS_net_api.h
  • MS_proxy_del_from_list : MS_net_api.h
  • MS_PROXY_DOWN_EVENT : MS_net_api.h
  • MS_proxy_fetch_state() : MS_net_api.h
  • MS_PROXY_FILTER_STATUS_OPCODE : MS_net_api.h
  • MS_PROXY_NET_ID_ADV_MODE : MS_net_api.h
  • MS_PROXY_NODE_ID_ADV_MODE : MS_net_api.h
  • MS_PROXY_NULL : MS_net_api.h
  • MS_PROXY_READY : MS_net_api.h
  • MS_proxy_register() : MS_net_api.h
  • MS_PROXY_REM_FROM_FILTER_OPCODE : MS_net_api.h
  • MS_proxy_server_adv_start() : MS_net_api.h
  • MS_proxy_server_adv_stop() : MS_net_api.h
  • MS_proxy_set_blacklist_filter : MS_net_api.h
  • MS_PROXY_SET_FILTER_OPCODE : MS_net_api.h
  • MS_proxy_set_whitelist_filter : MS_net_api.h
  • MS_PROXY_STATUS_EVENT : MS_net_api.h
  • MS_PROXY_UP_EVENT : MS_net_api.h
  • MS_PROXY_WHITELIST_FILTER : MS_net_api.h
  • MS_RELAY_TX_STATE : MS_common.h
  • MS_SCENE_CLIENT_CB : MS_scene_api.h
  • MS_scene_client_get_model_handle() : MS_scene_api.h
  • MS_scene_client_init() : MS_scene_api.h
  • MS_scene_client_send_reliable_pdu() : MS_scene_api.h
  • MS_scene_delete : MS_scene_api.h
  • MS_scene_delete_unacknowledged : MS_scene_api.h
  • MS_SCENE_EVENT_DELETE : MS_scene_api.h
  • MS_SCENE_EVENT_RECALL_COMPLETE : MS_scene_api.h
  • MS_SCENE_EVENT_RECALL_IMMEDIATE : MS_scene_api.h
  • MS_SCENE_EVENT_RECALL_START : MS_scene_api.h
  • MS_SCENE_EVENT_STORE : MS_scene_api.h
  • MS_scene_get : MS_scene_api.h
  • MS_scene_recall : MS_scene_api.h
  • MS_scene_recall_unacknowledged : MS_scene_api.h
  • MS_scene_register_get : MS_scene_api.h
  • MS_SCENE_SERVER_CB : MS_scene_api.h
  • MS_scene_server_init() : MS_scene_api.h
  • MS_scene_server_state_update() : MS_scene_api.h
  • MS_scene_store : MS_scene_api.h
  • MS_scene_store_unacknowledged : MS_scene_api.h
  • MS_scheduler_action_get : MS_scheduler_api.h
  • MS_scheduler_action_set : MS_scheduler_api.h
  • MS_scheduler_action_set_unacknowledged : MS_scheduler_api.h
  • MS_SCHEDULER_CLIENT_CB : MS_scheduler_api.h
  • MS_scheduler_client_get_model_handle() : MS_scheduler_api.h
  • MS_scheduler_client_init() : MS_scheduler_api.h
  • MS_scheduler_client_send_reliable_pdu() : MS_scheduler_api.h
  • MS_scheduler_get : MS_scheduler_api.h
  • MS_SCHEDULER_SERVER_CB : MS_scheduler_api.h
  • MS_scheduler_server_init() : MS_scheduler_api.h
  • MS_scheduler_server_state_update() : MS_scheduler_api.h
  • MS_SEGMENTED_ACCESS_MSG : MS_ltrn_api.h
  • MS_SEGMENTED_CTRL_MSG : MS_ltrn_api.h
  • MS_sensor_cadence_get : MS_sensor_api.h
  • MS_sensor_cadence_set : MS_sensor_api.h
  • MS_sensor_cadence_set_unacknowledged : MS_sensor_api.h
  • MS_SENSOR_CLIENT_CB : MS_sensor_api.h
  • MS_sensor_client_get_model_handle() : MS_sensor_api.h
  • MS_sensor_client_init() : MS_sensor_api.h
  • MS_sensor_client_send_reliable_pdu() : MS_sensor_api.h
  • MS_sensor_column_get : MS_sensor_api.h
  • MS_sensor_descriptor_get : MS_sensor_api.h
  • MS_sensor_get : MS_sensor_api.h
  • MS_sensor_series_get : MS_sensor_api.h
  • MS_SENSOR_SERVER_CB : MS_sensor_api.h
  • MS_sensor_server_init() : MS_sensor_api.h
  • MS_sensor_server_state_update() : MS_sensor_api.h
  • MS_sensor_setting_get : MS_sensor_api.h
  • MS_sensor_setting_set : MS_sensor_api.h
  • MS_sensor_setting_set_unacknowledged : MS_sensor_api.h
  • MS_sensor_settings_get : MS_sensor_api.h
  • MS_SENSOR_SETUP_SERVER_CB : MS_sensor_api.h
  • MS_sensor_setup_server_init() : MS_sensor_api.h
  • MS_sensor_setup_server_state_update() : MS_sensor_api.h
  • MS_shutdown() : MS_common.h
  • MS_STATE_GENERIC_ONOFF_T : MS_model_states.h
  • MS_STORAGE_FAILURE : MS_error.h
  • MS_SUB_MINOR_VERSION_NUMBER : MS_version.h
  • MS_SUBNET_HANDLE : MS_net_api.h
  • MS_tai_utc_delta_get : MS_time_api.h
  • MS_tai_utc_delta_set : MS_time_api.h
  • MS_TEMP_UNABLE_TO_CHANGE_STATE : MS_error.h
  • MS_TIME_CLIENT_CB : MS_time_api.h
  • MS_time_client_get_model_handle() : MS_time_api.h
  • MS_time_client_init() : MS_time_api.h
  • MS_time_client_send_reliable_pdu() : MS_time_api.h
  • MS_time_get : MS_time_api.h
  • MS_time_role_get : MS_time_api.h
  • MS_time_role_set : MS_time_api.h
  • MS_TIME_SERVER_CB : MS_time_api.h
  • MS_time_server_init() : MS_time_api.h
  • MS_time_server_state_update() : MS_time_api.h
  • MS_time_set : MS_time_api.h
  • MS_time_zone_get : MS_time_api.h
  • MS_time_zone_set : MS_time_api.h
  • MS_TRN_ACCESS_PKT : MS_ltrn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_CLEAR : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_CLEAR_CNF : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_OFFER : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_POLL : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_REQ : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_CNF : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_UPDATE : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_HEARTBEAT : MS_trn_api.h
  • MS_TRN_CTRL_PKT : MS_ltrn_api.h
  • MS_TRN_CTRL_PKT_OPCODE : MS_trn_api.h
  • MS_trn_get_frndship_info() : MS_trn_api.h
  • MS_trn_get_heartbeat_publication() : MS_trn_api.h
  • MS_trn_get_heartbeat_subscription() : MS_trn_api.h
  • MS_trn_get_lpn_polltimeout() : MS_trn_api.h
  • MS_trn_is_valid_lpn_element_address() : MS_trn_api.h
  • MS_trn_is_valid_lpn_subscription_address() : MS_trn_api.h
  • MS_trn_lpn_clear_friendship() : MS_trn_api.h
  • MS_trn_lpn_manage_subscription() : MS_trn_api.h
  • MS_trn_lpn_register_security_update() : MS_trn_api.h
  • MS_trn_lpn_setup_friendship() : MS_trn_api.h
  • MS_trn_lpn_subscrn_list_add : MS_trn_api.h
  • MS_trn_lpn_subscrn_list_remove : MS_trn_api.h
  • MS_TRN_MSG_TYPE : MS_ltrn_api.h
  • MS_trn_register() : MS_trn_api.h
  • MS_trn_send_access_pdu() : MS_trn_api.h
  • MS_trn_send_control_pdu() : MS_trn_api.h
  • MS_trn_set_heartbeat_publication() : MS_trn_api.h
  • MS_trn_set_heartbeat_subscription() : MS_trn_api.h
  • MS_trn_trigger_heartbeat() : MS_trn_api.h
  • MS_UNPACK_LE_1_BYTE : MS_common.h
  • MS_UNSEGMENTED_ACCESS_MSG : MS_ltrn_api.h
  • MS_UNSEGMENTED_CTRL_MSG : MS_ltrn_api.h
  • MS_UNSPECIFIED_ERROR : MS_error.h


EtherMind Mesh SDK (beta): Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- n -

  • NET_IS_VALID_DST_ADDR : MS_net_api.h
  • NET_IS_VALID_SRC_ADDR : MS_net_api.h
  • NET_NTF_CB : MS_net_api.h
  • NETIF_HANDLE : MS_net_api.h


EtherMind Mesh SDK (beta): Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- p -

  • PROV_ALGO_EC_FIPS_P256 : MS_prov_api.h
  • PROV_AUTH_OOB_NONE : MS_prov_api.h
  • PROV_BRR : MS_prov_api.h
  • PROV_BRR_ADV : MS_prov_api.h
  • PROV_CLOSE_REASON_SUCCESS : MS_prov_api.h
  • PROV_ERR_PROHIBITED : MS_prov_api.h
  • PROV_EVT_DEVINPUT_COMPLETE : MS_prov_api.h
  • PROV_EVT_OOB_DISPLAY : MS_prov_api.h
  • PROV_EVT_OOB_ENTRY : MS_prov_api.h
  • PROV_EVT_PROVDATA_INFO : MS_prov_api.h
  • PROV_EVT_PROVDATA_INFO_REQ : MS_prov_api.h
  • PROV_EVT_PROVISIONING_COMPLETE : MS_prov_api.h
  • PROV_EVT_PROVISIONING_SETUP : MS_prov_api.h
  • PROV_EVT_UNPROVISIONED_BEACON : MS_prov_api.h
  • PROV_HANDLE : MS_prov_api.h
  • PROV_HANDLE_INVALID : MS_prov_api.h
  • PROV_IOOB_ACTION_PUSH : MS_prov_api.h
  • PROV_KEY_NETKEY_SIZE : MS_prov_api.h
  • PROV_MASK_ALGO_EC_FIPS_P256 : MS_prov_api.h
  • PROV_MASK_IOOB_ACTION_PUSH : MS_prov_api.h
  • PROV_MASK_OOOB_ACTION_BLINK : MS_prov_api.h
  • PROV_MASK_PUBKEY_OOBINFO : MS_prov_api.h
  • PROV_MASK_STATIC_OOBINFO : MS_prov_api.h
  • PROV_OOB_TYPE_OTHER : MS_prov_api.h
  • PROV_OOOB_ACTION_BLINK : MS_prov_api.h
  • PROV_PCF_CONTINU_FRGMNT : MS_prov_api.h
  • PROV_PCF_CTRL_MSG : MS_prov_api.h
  • PROV_PCF_NUM_FRGMNTS : MS_prov_api.h
  • PROV_PCF_TX_SPECIFIC : MS_prov_api.h
  • PROV_PDU_TYPE_INVITE : MS_prov_api.h
  • PROV_PUBKEY_NO_OOB : MS_prov_api.h
  • PROV_ROLE : MS_prov_api.h
  • PROV_ROLE_DEVICE : MS_prov_api.h
  • PROV_UI_NOTIFY_CB : MS_prov_api.h
  • PROXY_ADDR : MS_net_api.h
  • PROXY_FILTER_TYPE : MS_net_api.h
  • PROXY_NTF_CB : MS_net_api.h


EtherMind Mesh SDK (beta): Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- t -

  • TIMER_ERR_ID : MS_error.h
  • TRN_FRND_CB : MS_trn_api.h
  • TRN_NTF_CB : MS_trn_api.h


EtherMind Mesh SDK (beta): Globals

- m -

  • MS_access_bind_model_app() : MS_access_api.h
  • MS_access_cm_add_appkey() : MS_access_api.h
  • MS_access_cm_add_device_key() : MS_access_api.h
  • MS_access_cm_add_friend_sec_credential() : MS_access_api.h
  • MS_access_cm_add_model_subscription() : MS_access_api.h
  • MS_access_cm_add_update_netkey() : MS_access_api.h
  • MS_access_cm_delete_all_model_subscription() : MS_access_api.h
  • MS_access_cm_delete_friend_sec_credential() : MS_access_api.h
  • MS_access_cm_delete_model_subscription() : MS_access_api.h
  • MS_access_cm_delete_netkey() : MS_access_api.h
  • MS_access_cm_find_subnet() : MS_access_api.h
  • MS_access_cm_get_all_model_subscription_list() : MS_access_api.h
  • MS_access_cm_get_app_key() : MS_access_api.h
  • MS_access_cm_get_appkey_handle() : MS_access_api.h
  • MS_access_cm_get_appkey_index_list() : MS_access_api.h
  • MS_access_cm_get_default_ttl() : MS_access_api.h
  • MS_access_cm_get_device_key() : MS_access_api.h
  • MS_access_cm_get_device_key_handle() : MS_access_api.h
  • MS_access_cm_get_element_count() : MS_access_api.h
  • MS_access_cm_get_features() : MS_access_api.h
  • MS_access_cm_get_features_field() : MS_access_api.h
  • MS_access_cm_get_friendship_role() : MS_access_api.h
  • MS_access_cm_get_iv_index() : MS_access_api.h
  • MS_access_cm_get_iv_index_by_ivi() : MS_access_api.h
  • MS_access_cm_get_key_refresh_phase() : MS_access_api.h
  • MS_access_cm_get_model_app_list() : MS_access_api.h
  • MS_access_cm_get_model_publication() : MS_access_api.h
  • MS_access_cm_get_model_subscription_list() : MS_access_api.h
  • MS_access_cm_get_netkey() : MS_access_api.h
  • MS_access_cm_get_netkey_index_list() : MS_access_api.h
  • MS_access_cm_get_node_identity() : MS_access_api.h
  • MS_access_cm_get_primary_unicast_address() : MS_access_api.h
  • MS_access_cm_get_prov_devices_list() : MS_access_api.h
  • MS_access_cm_get_subnet_beacon_key() : MS_access_api.h
  • MS_access_cm_get_subnet_encryption_key() : MS_access_api.h
  • MS_access_cm_get_subnet_identity_key() : MS_access_api.h
  • MS_access_cm_get_subnet_network_id() : MS_access_api.h
  • MS_access_cm_get_subnet_nid() : MS_access_api.h
  • MS_access_cm_get_subnet_privacy_key() : MS_access_api.h
  • MS_access_cm_get_transmit_state() : MS_access_api.h
  • MS_access_cm_lookup_aid() : MS_access_api.h
  • MS_access_cm_lookup_network_id() : MS_access_api.h
  • MS_access_cm_lookup_nid() : MS_access_api.h
  • MS_access_cm_remove_all_device_keys() : MS_access_api.h
  • MS_access_cm_reset() : MS_access_api.h
  • MS_access_cm_set_default_ttl() : MS_access_api.h
  • MS_access_cm_set_features_field() : MS_access_api.h
  • MS_access_cm_set_friendship_role() : MS_access_api.h
  • MS_access_cm_set_iv_index() : MS_access_api.h
  • MS_access_cm_set_key_refresh_phase() : MS_access_api.h
  • MS_access_cm_set_model_publication() : MS_access_api.h
  • MS_access_cm_set_node_identity() : MS_access_api.h
  • MS_access_cm_set_primary_unicast_address() : MS_access_api.h
  • MS_access_cm_set_prov_data() : MS_access_api.h
  • MS_access_cm_set_transmit_state() : MS_access_api.h
  • MS_access_cm_update_delete_appkey() : MS_access_api.h
  • MS_access_create_node() : MS_access_api.h
  • MS_access_get_composition_data() : MS_access_api.h
  • MS_access_get_element_handle() : MS_access_api.h
  • MS_access_get_model_handle() : MS_access_api.h
  • MS_access_is_fixed_group_addr_to_be_processed() : MS_access_api.h
  • MS_access_is_valid_element_address() : MS_access_api.h
  • MS_access_is_valid_subscription_address() : MS_access_api.h
  • MS_access_publish() : MS_access_api.h
  • MS_access_register_element() : MS_access_api.h
  • MS_access_register_model() : MS_access_api.h
  • MS_access_reply() : MS_access_api.h
  • MS_access_send_pdu() : MS_access_api.h
  • MS_access_unbind_model_app() : MS_access_api.h
  • MS_brr_add_bearer() : MS_brr_api.h
  • MS_brr_bcast_end() : MS_brr_api.h
  • MS_brr_bcast_unprovisioned_beacon() : MS_brr_api.h
  • MS_brr_broadcast_beacon() : MS_brr_api.h
  • MS_brr_get_packet_rssi() : MS_brr_api.h
  • MS_brr_observe_beacon() : MS_brr_api.h
  • MS_brr_register() : MS_brr_api.h
  • MS_brr_register_beacon_handler() : MS_brr_api.h
  • MS_brr_remove_bearer() : MS_brr_api.h
  • MS_brr_send_pdu() : MS_brr_api.h
  • MS_brr_sleep() : MS_brr_api.h
  • MS_brr_start_proxy_adv() : MS_brr_api.h
  • MS_brr_wakeup() : MS_brr_api.h
  • MS_common_get_transition_time_from_ms() : MS_common.h
  • MS_common_start_transition_timer() : MS_common.h
  • MS_common_stop_transition_timer() : MS_common.h
  • MS_config_client_init() : MS_config_api.h
  • MS_config_client_send_reliable_pdu() : MS_config_api.h
  • MS_config_client_set_server() : MS_config_api.h
  • MS_config_server_init() : MS_config_api.h
  • MS_generic_admin_property_server_init() : MS_generic_property_api.h
  • MS_generic_admin_property_server_state_update() : MS_generic_property_api.h
  • MS_generic_battery_client_get_model_handle() : MS_generic_battery_api.h
  • MS_generic_battery_client_init() : MS_generic_battery_api.h
  • MS_generic_battery_client_send_reliable_pdu() : MS_generic_battery_api.h
  • MS_generic_battery_server_init() : MS_generic_battery_api.h
  • MS_generic_battery_server_state_update() : MS_generic_battery_api.h
  • MS_generic_client_property_server_init() : MS_generic_property_api.h
  • MS_generic_client_property_server_state_update() : MS_generic_property_api.h
  • MS_generic_default_transition_time_client_get_model_handle() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_client_init() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_client_send_reliable_pdu() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_server_get_time() : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_server_init() : MS_generic_default_transition_time_api.h
  • MS_generic_level_client_get_model_handle() : MS_generic_level_api.h
  • MS_generic_level_client_init() : MS_generic_level_api.h
  • MS_generic_level_client_send_reliable_pdu() : MS_generic_level_api.h
  • MS_generic_level_server_init() : MS_generic_level_api.h
  • MS_generic_level_server_state_update() : MS_generic_level_api.h
  • MS_generic_location_client_get_model_handle() : MS_generic_location_api.h
  • MS_generic_location_client_init() : MS_generic_location_api.h
  • MS_generic_location_client_send_reliable_pdu() : MS_generic_location_api.h
  • MS_generic_location_server_init() : MS_generic_location_api.h
  • MS_generic_location_server_state_update() : MS_generic_location_api.h
  • MS_generic_location_setup_server_init() : MS_generic_location_api.h
  • MS_generic_location_setup_server_state_update() : MS_generic_location_api.h
  • MS_generic_manufacturer_property_server_init() : MS_generic_property_api.h
  • MS_generic_manufacturer_property_server_state_update() : MS_generic_property_api.h
  • MS_generic_onoff_client_get_model_handle() : MS_generic_onoff_api.h
  • MS_generic_onoff_client_init() : MS_generic_onoff_api.h
  • MS_generic_onoff_client_send_reliable_pdu() : MS_generic_onoff_api.h
  • MS_generic_onoff_server_init() : MS_generic_onoff_api.h
  • MS_generic_onoff_server_state_update() : MS_generic_onoff_api.h
  • MS_generic_power_level_client_get_model_handle() : MS_generic_power_level_api.h
  • MS_generic_power_level_client_init() : MS_generic_power_level_api.h
  • MS_generic_power_level_client_send_reliable_pdu() : MS_generic_power_level_api.h
  • MS_generic_power_level_server_init() : MS_generic_power_level_api.h
  • MS_generic_power_level_server_state_update() : MS_generic_power_level_api.h
  • MS_generic_power_level_setup_server_init() : MS_generic_power_level_api.h
  • MS_generic_power_level_setup_server_state_update() : MS_generic_power_level_api.h
  • MS_generic_power_onoff_client_get_model_handle() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_client_init() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_client_send_reliable_pdu() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_server_init() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_server_state_update() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_setup_server_init() : MS_generic_power_onoff_api.h
  • MS_generic_power_onoff_setup_server_state_update() : MS_generic_power_onoff_api.h
  • MS_generic_property_client_get_model_handle() : MS_generic_property_api.h
  • MS_generic_property_client_init() : MS_generic_property_api.h
  • MS_generic_property_client_send_reliable_pdu() : MS_generic_property_api.h
  • MS_generic_user_property_server_init() : MS_generic_property_api.h
  • MS_generic_user_property_server_state_update() : MS_generic_property_api.h
  • MS_get_version_number() : MS_version.h
  • MS_health_client_get_model_handle() : MS_health_client_api.h
  • MS_health_client_init() : MS_health_client_api.h
  • MS_health_client_send_reliable_pdu() : MS_health_client_api.h
  • MS_health_server_init() : MS_health_server_api.h
  • MS_health_server_report_fault() : MS_health_server_api.h
  • MS_init() : MS_common.h
  • MS_light_ctl_client_get_model_handle() : MS_light_ctl_api.h
  • MS_light_ctl_client_init() : MS_light_ctl_api.h
  • MS_light_ctl_client_send_reliable_pdu() : MS_light_ctl_api.h
  • MS_light_ctl_server_init() : MS_light_ctl_api.h
  • MS_light_ctl_server_state_update() : MS_light_ctl_api.h
  • MS_light_ctl_temperature_server_init() : MS_light_ctl_api.h
  • MS_light_ctl_temperature_server_state_update() : MS_light_ctl_api.h
  • MS_light_hsl_client_get_model_handle() : MS_light_hsl_api.h
  • MS_light_hsl_client_init() : MS_light_hsl_api.h
  • MS_light_hsl_client_send_reliable_pdu() : MS_light_hsl_api.h
  • MS_light_hsl_hue_server_init() : MS_light_hsl_api.h
  • MS_light_hsl_hue_server_state_update() : MS_light_hsl_api.h
  • MS_light_hsl_saturation_server_init() : MS_light_hsl_api.h
  • MS_light_hsl_saturation_server_state_update() : MS_light_hsl_api.h
  • MS_light_hsl_server_init() : MS_light_hsl_api.h
  • MS_light_hsl_server_state_update() : MS_light_hsl_api.h
  • MS_light_lc_client_get_model_handle() : MS_light_lc_api.h
  • MS_light_lc_client_init() : MS_light_lc_api.h
  • MS_light_lc_client_send_reliable_pdu() : MS_light_lc_api.h
  • MS_light_lc_server_init() : MS_light_lc_api.h
  • MS_light_lc_server_state_update() : MS_light_lc_api.h
  • MS_light_lightness_client_get_model_handle() : MS_light_lightness_api.h
  • MS_light_lightness_client_init() : MS_light_lightness_api.h
  • MS_light_lightness_client_send_reliable_pdu() : MS_light_lightness_api.h
  • MS_light_lightness_server_init() : MS_light_lightness_api.h
  • MS_light_lightness_server_state_update() : MS_light_lightness_api.h
  • MS_light_lightness_setup_server_init() : MS_light_lightness_api.h
  • MS_light_lightness_setup_server_state_update() : MS_light_lightness_api.h
  • MS_light_xyl_client_get_model_handle() : MS_light_xyl_api.h
  • MS_light_xyl_client_init() : MS_light_xyl_api.h
  • MS_light_xyl_client_send_reliable_pdu() : MS_light_xyl_api.h
  • MS_light_xyl_server_init() : MS_light_xyl_api.h
  • MS_light_xyl_server_state_update() : MS_light_xyl_api.h
  • MS_ltrn_register() : MS_ltrn_api.h
  • MS_ltrn_send_pdu() : MS_ltrn_api.h
  • MS_net_alloc_seq_num() : MS_net_api.h
  • MS_net_broadcast_secure_beacon() : MS_net_api.h
  • MS_net_get_address_type() : MS_net_api.h
  • MS_net_register() : MS_net_api.h
  • MS_net_send_pdu() : MS_net_api.h
  • MS_prov_abort() : MS_prov_api.h
  • MS_prov_bind() : MS_prov_api.h
  • MS_prov_get_local_public_key() : MS_prov_api.h
  • MS_prov_register() : MS_prov_api.h
  • MS_prov_send_pdu() : MS_prov_api.h
  • MS_prov_set_authval() : MS_prov_api.h
  • MS_prov_setup() : MS_prov_api.h
  • MS_proxy_fetch_state() : MS_net_api.h
  • MS_proxy_register() : MS_net_api.h
  • MS_proxy_server_adv_start() : MS_net_api.h
  • MS_proxy_server_adv_stop() : MS_net_api.h
  • MS_scene_client_get_model_handle() : MS_scene_api.h
  • MS_scene_client_init() : MS_scene_api.h
  • MS_scene_client_send_reliable_pdu() : MS_scene_api.h
  • MS_scene_server_init() : MS_scene_api.h
  • MS_scene_server_state_update() : MS_scene_api.h
  • MS_scheduler_client_get_model_handle() : MS_scheduler_api.h
  • MS_scheduler_client_init() : MS_scheduler_api.h
  • MS_scheduler_client_send_reliable_pdu() : MS_scheduler_api.h
  • MS_scheduler_server_init() : MS_scheduler_api.h
  • MS_scheduler_server_state_update() : MS_scheduler_api.h
  • MS_sensor_client_get_model_handle() : MS_sensor_api.h
  • MS_sensor_client_init() : MS_sensor_api.h
  • MS_sensor_client_send_reliable_pdu() : MS_sensor_api.h
  • MS_sensor_server_init() : MS_sensor_api.h
  • MS_sensor_server_state_update() : MS_sensor_api.h
  • MS_sensor_setup_server_init() : MS_sensor_api.h
  • MS_sensor_setup_server_state_update() : MS_sensor_api.h
  • MS_shutdown() : MS_common.h
  • MS_time_client_get_model_handle() : MS_time_api.h
  • MS_time_client_init() : MS_time_api.h
  • MS_time_client_send_reliable_pdu() : MS_time_api.h
  • MS_time_server_init() : MS_time_api.h
  • MS_time_server_state_update() : MS_time_api.h
  • MS_trn_get_frndship_info() : MS_trn_api.h
  • MS_trn_get_heartbeat_publication() : MS_trn_api.h
  • MS_trn_get_heartbeat_subscription() : MS_trn_api.h
  • MS_trn_get_lpn_polltimeout() : MS_trn_api.h
  • MS_trn_is_valid_lpn_element_address() : MS_trn_api.h
  • MS_trn_is_valid_lpn_subscription_address() : MS_trn_api.h
  • MS_trn_lpn_clear_friendship() : MS_trn_api.h
  • MS_trn_lpn_manage_subscription() : MS_trn_api.h
  • MS_trn_lpn_register_security_update() : MS_trn_api.h
  • MS_trn_lpn_setup_friendship() : MS_trn_api.h
  • MS_trn_register() : MS_trn_api.h
  • MS_trn_send_access_pdu() : MS_trn_api.h
  • MS_trn_send_control_pdu() : MS_trn_api.h
  • MS_trn_set_heartbeat_publication() : MS_trn_api.h
  • MS_trn_set_heartbeat_subscription() : MS_trn_api.h
  • MS_trn_trigger_heartbeat() : MS_trn_api.h


EtherMind Mesh SDK (beta): Globals

- a -

  • API_RESULT : MS_error.h

- b -

  • BRR_BCON_CB : MS_brr_api.h
  • BRR_HANDLE : MS_brr_api.h
  • BRR_NTF_CB : MS_brr_api.h

- l -

  • LPN_HANDLE : MS_ltrn_api.h
  • LTRN_NTF_CB : MS_ltrn_api.h

- m -

  • MS_ACCESS_ADDRESS_HANDLE : MS_access_api.h
  • MS_ACCESS_DEV_KEY_HANDLE : MS_access_api.h
  • MS_ACCESS_ELEMENT_HANDLE : MS_access_api.h
  • MS_ACCESS_MODEL_CB : MS_access_api.h
  • MS_ACCESS_MODEL_HANDLE : MS_access_api.h
  • MS_ACCESS_MODEL_ID_SIG : MS_access_api.h
  • MS_ACCESS_MODEL_ID_VENDOR : MS_access_api.h
  • MS_ACCESS_NODE_ID : MS_access_api.h
  • MS_APPKEY_HANDLE : MS_net_api.h
  • MS_CONFIG_MODEL_CB : MS_config_api.h
  • MS_GENERIC_BATTERY_CLIENT_CB : MS_generic_battery_api.h
  • MS_GENERIC_BATTERY_SERVER_CB : MS_generic_battery_api.h
  • MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB : MS_generic_default_transition_time_api.h
  • MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB : MS_generic_default_transition_time_api.h
  • MS_GENERIC_LEVEL_CLIENT_CB : MS_generic_level_api.h
  • MS_GENERIC_LEVEL_SERVER_CB : MS_generic_level_api.h
  • MS_GENERIC_LOCATION_CLIENT_CB : MS_generic_location_api.h
  • MS_GENERIC_LOCATION_SERVER_CB : MS_generic_location_api.h
  • MS_GENERIC_LOCATION_SETUP_SERVER_CB : MS_generic_location_api.h
  • MS_GENERIC_ONOFF_CLIENT_CB : MS_generic_onoff_api.h
  • MS_GENERIC_ONOFF_SERVER_CB : MS_generic_onoff_api.h
  • MS_GENERIC_POWER_LEVEL_CLIENT_CB : MS_generic_power_level_api.h
  • MS_GENERIC_POWER_LEVEL_SERVER_CB : MS_generic_power_level_api.h
  • MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB : MS_generic_power_level_api.h
  • MS_GENERIC_POWER_ONOFF_CLIENT_CB : MS_generic_power_onoff_api.h
  • MS_GENERIC_POWER_ONOFF_SERVER_CB : MS_generic_power_onoff_api.h
  • MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB : MS_generic_power_onoff_api.h
  • MS_GENERIC_PROPERTY_CLIENT_CB : MS_generic_property_api.h
  • MS_GENERIC_PROPERTY_SERVER_CB : MS_generic_property_api.h
  • MS_HEALTH_CLIENT_CB : MS_health_client_api.h
  • MS_HEALTH_SERVER_CB : MS_health_server_api.h
  • MS_HEALTH_SERVER_SELF_TEST_FN : MS_health_server_api.h
  • MS_LIGHT_CTL_CLIENT_CB : MS_light_ctl_api.h
  • MS_LIGHT_CTL_SERVER_CB : MS_light_ctl_api.h
  • MS_LIGHT_CTL_TEMPERATURE_SERVER_CB : MS_light_ctl_api.h
  • MS_LIGHT_HSL_CLIENT_CB : MS_light_hsl_api.h
  • MS_LIGHT_HSL_HUE_SERVER_CB : MS_light_hsl_api.h
  • MS_LIGHT_HSL_SATURATION_SERVER_CB : MS_light_hsl_api.h
  • MS_LIGHT_HSL_SERVER_CB : MS_light_hsl_api.h
  • MS_LIGHT_LC_CLIENT_CB : MS_light_lc_api.h
  • MS_LIGHT_LC_SERVER_CB : MS_light_lc_api.h
  • MS_LIGHT_LIGHTNESS_CLIENT_CB : MS_light_lightness_api.h
  • MS_LIGHT_LIGHTNESS_SERVER_CB : MS_light_lightness_api.h
  • MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB : MS_light_lightness_api.h
  • MS_LIGHT_XYL_CLIENT_CB : MS_light_xyl_api.h
  • MS_LIGHT_XYL_SERVER_CB : MS_light_xyl_api.h
  • MS_NET_ADDR : MS_net_api.h
  • MS_NET_ADDR_TYPE : MS_net_api.h
  • MS_SCENE_CLIENT_CB : MS_scene_api.h
  • MS_SCENE_SERVER_CB : MS_scene_api.h
  • MS_SCHEDULER_CLIENT_CB : MS_scheduler_api.h
  • MS_SCHEDULER_SERVER_CB : MS_scheduler_api.h
  • MS_SENSOR_CLIENT_CB : MS_sensor_api.h
  • MS_SENSOR_SERVER_CB : MS_sensor_api.h
  • MS_SENSOR_SETUP_SERVER_CB : MS_sensor_api.h
  • MS_SUBNET_HANDLE : MS_net_api.h
  • MS_TIME_CLIENT_CB : MS_time_api.h
  • MS_TIME_SERVER_CB : MS_time_api.h
  • MS_TRN_CTRL_PKT_OPCODE : MS_trn_api.h
  • MS_TRN_MSG_TYPE : MS_ltrn_api.h

- n -

  • NET_NTF_CB : MS_net_api.h
  • NETIF_HANDLE : MS_net_api.h

- p -

  • PROV_BRR : MS_prov_api.h
  • PROV_HANDLE : MS_prov_api.h
  • PROV_ROLE : MS_prov_api.h
  • PROV_UI_NOTIFY_CB : MS_prov_api.h
  • PROXY_ADDR : MS_net_api.h
  • PROXY_FILTER_TYPE : MS_net_api.h
  • PROXY_NTF_CB : MS_net_api.h

- t -

  • TRN_FRND_CB : MS_trn_api.h
  • TRN_NTF_CB : MS_trn_api.h


EtherMind Mesh SDK (beta): Globals

  • BRR_BCON_TTYPE : MS_brr_api.h
  • BRR_TYPE : MS_brr_api.h


EtherMind Mesh SDK (beta): Globals

  • BRR_BCON_COUNT : MS_brr_api.h
  • BRR_COUNT : MS_brr_api.h
  • BRR_TYPE_ADV : MS_brr_api.h
  • BRR_TYPE_BCON : MS_brr_api.h
  • BRR_TYPE_GATT : MS_brr_api.h
  • BRR_TYPE_PB_ADV : MS_brr_api.h
  • BRR_TYPE_PB_GATT : MS_brr_api.h


EtherMind Mesh SDK (beta): Globals

- a -

  • ACCESS_INVALID_DEFAULT_TTL : MS_access_api.h
  • ACCESS_MAX_TTL : MS_access_api.h
  • API_FAILURE : MS_error.h
  • API_SUCCESS : MS_error.h


EtherMind Mesh SDK (beta): Globals

- b -

  • BRR_BCON_PASSIVE : MS_brr_api.h
  • BRR_BROADCAST : MS_brr_api.h
  • BRR_CLIENT_ROLE : MS_brr_api.h
  • BRR_DISABLE : MS_brr_api.h
  • BRR_ERR_ID : MS_error.h
  • BRR_HANDLE_INVALID : MS_brr_api.h
  • BRR_IFACE_DOWN : MS_brr_api.h
  • BRR_MAX_PDU_SIZE : MS_brr_api.h


EtherMind Mesh SDK (beta): Globals

- m -

  • MESH_AD_TYPE_PB_ADV : MS_assigned_numbers.h
  • MESH_CH_PROVISIONING_DATA_IN : MS_assigned_numbers.h
  • MESH_GATT_SAR_COMPLETE : MS_assigned_numbers.h
  • MESH_GATT_TYPE_NETWORK : MS_assigned_numbers.h
  • MESH_MODEL_CONFIG : MS_assigned_numbers.h
  • MESH_PROVISIONING_SERVICE : MS_assigned_numbers.h
  • MESH_PROXY_SERVICE : MS_assigned_numbers.h
  • MS_ACCESS_ADDRESS_INVALID_HANDLE : MS_access_api.h
  • MS_ACCESS_APPKEY_SIZE : MS_access_api.h
  • MS_ACCESS_ASSIGN_ELEMENT : MS_access_api.h
  • MS_ACCESS_CONFIG_APPKEY_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_BEACON_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_BEACON_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_COMPOSITION_DATA_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_DEFAULT_TTL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_DEFAULT_TTL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_FRIEND_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_FRIEND_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_GATT_PROXY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_GATT_PROXY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_APP_BIND_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_APP_UNBIND_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_PUBLICATION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_PUBLICATION_VIRTUAL_ADDRESS_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_ALL_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_OVERWRITE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_OVERWRITE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_ADD_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETKEY_UPDATE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETWORK_TRANSMIT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETWORK_TRANSMIT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_IDENTITY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_IDENTITY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_RESET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_NODE_RESET_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_RELAY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_RELAY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_APP_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_APP_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_APP_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_APP_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_LIST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_DEFAULT_ELEMENT_HANDLE : MS_access_api.h
  • MS_ACCESS_DEFAULT_NODE_ID : MS_access_api.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_BATTERY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_BATTERY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_CLIENT_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_CLIENT_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DELTA_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_DELTA_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MOVE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_MOVE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LAST_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LAST_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_GET_REQ : MS_access_api.h
  • MS_ACCESS_HEALTH_ATTENTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_ATTENTION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_ATTENTION_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_CLEAR_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_CLEAR_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_TEST_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_FAULT_TEST_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_INIT_SIG_MODEL : MS_access_api.h
  • MS_ACCESS_INIT_VENDOR_MODEL : MS_access_api.h
  • MS_ACCESS_INVALID_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_KEY_REFRESH_PHASE_1 : MS_access_api.h
  • MS_ACCESS_KEY_REFRESH_PHASE_2 : MS_access_api.h
  • MS_ACCESS_KEY_REFRESH_PHASE_3 : MS_access_api.h
  • MS_ACCESS_KEY_REFRESH_PHASE_NORMAL : MS_access_api.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_TARGET_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_HSL_TARGET_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LAST_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LAST_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_TARGET_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_LIGHT_XYL_TARGET_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_MAX_PKT_SIZE : MS_access_api.h
  • MS_ACCESS_MODEL_REQ_MSG_T_GET : MS_access_api.h
  • MS_ACCESS_MODEL_REQ_MSG_T_OTHERS : MS_access_api.h
  • MS_ACCESS_MODEL_REQ_MSG_T_SET : MS_access_api.h
  • MS_ACCESS_MODEL_TYPE_SIG : MS_assigned_numbers.h
  • MS_ACCESS_NETKEY_SIZE : MS_access_api.h
  • MS_ACCESS_SCENE_DELETE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_DELETE_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_RECALL_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_RECALL_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_REGISTER_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_STORE_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCENE_STORE_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SCHEDULER_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_CADENCE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_CADENCE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_CADENCE_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_COLUMN_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_COLUMN_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_DESCRIPTOR_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_DESCRIPTOR_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SERIES_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SERIES_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_SET_UNACKNOWLEDGED_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTINGS_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_SETTINGS_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SENSOR_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_SET_REQ : MS_access_api.h
  • MS_ACCESS_TAI_UTC_DELTA_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TAI_UTC_DELTA_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ROLE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ROLE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ROLE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ZONE_GET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ZONE_SET_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_TIME_ZONE_STATUS_OPCODE : MS_assigned_numbers.h
  • MS_ACCESS_VADDR_LABEL_UUID_SIZE : MS_access_api.h
  • MS_BCON_OOB_IND_SIZE : MS_common.h
  • MS_BCON_TYPE_SIZE : MS_common.h
  • MS_BCON_TYPE_UNPRVSNG_DEV : MS_common.h
  • MS_BCON_URI_HASH_SIZE : MS_common.h
  • MS_CANNOT_BIND : MS_error.h
  • MS_CANNOT_REMOVE : MS_error.h
  • MS_CANNOT_SET : MS_error.h
  • MS_CANNOT_UPDATE : MS_error.h
  • MS_COMMON_ERR_ID : MS_error.h
  • MS_config_client_appkey_add : MS_config_api.h
  • MS_config_client_appkey_delete : MS_config_api.h
  • MS_config_client_appkey_get : MS_config_api.h
  • MS_config_client_appkey_update : MS_config_api.h
  • MS_config_client_beacon_get : MS_config_api.h
  • MS_config_client_beacon_set : MS_config_api.h
  • MS_config_client_composition_data_get : MS_config_api.h
  • MS_config_client_default_ttl_get : MS_config_api.h
  • MS_config_client_default_ttl_set : MS_config_api.h
  • MS_config_client_friend_get : MS_config_api.h
  • MS_config_client_friend_set : MS_config_api.h
  • MS_config_client_gatt_proxy_get : MS_config_api.h
  • MS_config_client_gatt_proxy_set : MS_config_api.h
  • MS_config_client_heartbeat_publication_get : MS_config_api.h
  • MS_config_client_heartbeat_publication_set : MS_config_api.h
  • MS_config_client_heartbeat_subscription_get : MS_config_api.h
  • MS_config_client_heartbeat_subscription_set : MS_config_api.h
  • MS_config_client_keyrefresh_phase_get : MS_config_api.h
  • MS_config_client_keyrefresh_phase_set : MS_config_api.h
  • MS_config_client_lpn_polltimeout_get : MS_config_api.h
  • MS_config_client_model_app_bind : MS_config_api.h
  • MS_config_client_model_app_unbind : MS_config_api.h
  • MS_config_client_model_publication_get : MS_config_api.h
  • MS_config_client_model_publication_set : MS_config_api.h
  • MS_config_client_model_publication_vaddr_set : MS_config_api.h
  • MS_config_client_model_subscription_add : MS_config_api.h
  • MS_config_client_model_subscription_delete : MS_config_api.h
  • MS_config_client_model_subscription_delete_all : MS_config_api.h
  • MS_config_client_model_subscription_overwrite : MS_config_api.h
  • MS_config_client_model_subscription_vaddr_add : MS_config_api.h
  • MS_config_client_model_subscription_vaddr_delete : MS_config_api.h
  • MS_config_client_model_subscription_vaddr_overwrite : MS_config_api.h
  • MS_config_client_netkey_add : MS_config_api.h
  • MS_config_client_netkey_delete : MS_config_api.h
  • MS_config_client_netkey_get : MS_config_api.h
  • MS_config_client_netkey_update : MS_config_api.h
  • MS_config_client_network_transmit_get : MS_config_api.h
  • MS_config_client_network_transmit_set : MS_config_api.h
  • MS_config_client_node_identity_get : MS_config_api.h
  • MS_config_client_node_identity_set : MS_config_api.h
  • MS_config_client_node_reset : MS_config_api.h
  • MS_config_client_relay_get : MS_config_api.h
  • MS_config_client_relay_set : MS_config_api.h
  • MS_config_client_sig_model_app_get : MS_config_api.h
  • MS_config_client_sig_model_subscription_get : MS_config_api.h
  • MS_config_client_vendor_model_app_get : MS_config_api.h
  • MS_config_client_vendor_model_subscription_get : MS_config_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_ON : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_PROLONG : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_STANDBY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_ON : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_PROLONG : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_STANDBY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_ACCURACY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KID : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KIU : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPD : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPU : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_ON : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_AUTO : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_MANUAL : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_OCCUPANCY_DELAY : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_PROLONG : MS_generic_property_api.h
  • MS_DEV_PROP_LIGHT_CONTROL_TIME_RUN_ON : MS_generic_property_api.h
  • MS_DEV_PROP_MOTION_SENSED : MS_generic_property_api.h
  • MS_DEV_PROP_PEOPLE_COUNT : MS_generic_property_api.h
  • MS_DEV_PROP_PRESENCE_DETECTED : MS_generic_property_api.h
  • MS_DEV_PROP_PRESENT_AMBIENT_LIGHT_LEVEL : MS_generic_property_api.h
  • MS_DEV_PROP_TIME_SINCE_MOTION_SENSED : MS_generic_property_api.h
  • MS_DEVICE_UUID_SIZE : MS_common.h
  • MS_DISABLE : MS_common.h
  • MS_DISABLE_FRIEND_FEATURE : MS_access_api.h
  • MS_DISABLE_LPN_FEATURE : MS_access_api.h
  • MS_DISABLE_PROXY_FEATURE : MS_access_api.h
  • MS_DISABLE_RELAY_FEATURE : MS_access_api.h
  • MS_ENABLE : MS_common.h
  • MS_ENABLE_FRIEND_FEATURE : MS_access_api.h
  • MS_ENABLE_LPN_FEATURE : MS_access_api.h
  • MS_ENABLE_PROXY_FEATURE : MS_access_api.h
  • MS_ENABLE_RELAY_FEATURE : MS_access_api.h
  • MS_ERR_ID : MS_error.h
  • MS_FEATURE_FRIEND : MS_common.h
  • MS_FEATURE_LPN : MS_common.h
  • MS_FEATURE_NOT_SUPPORTED : MS_error.h
  • MS_FEATURE_PROXY : MS_common.h
  • MS_FEATURE_RELAY : MS_common.h
  • MS_FEATURE_SEC_NET_BEACON : MS_common.h
  • MS_FRND_ROLE_INVALID : MS_common.h
  • MS_FRNDREQ_RSSIFACTOR_OFFSET : MS_trn_api.h
  • MS_FRNDUPD_FLAG_KEYREF_BIT : MS_trn_api.h
  • MS_FRNDUPD_MD_QUEUE_EMPTY : MS_trn_api.h
  • MS_generic_admin_properties_get : MS_generic_property_api.h
  • MS_generic_admin_property_get : MS_generic_property_api.h
  • MS_generic_admin_property_set : MS_generic_property_api.h
  • MS_generic_admin_property_set_unacknowledged : MS_generic_property_api.h
  • MS_generic_battery_get : MS_generic_battery_api.h
  • MS_generic_client_properties_get : MS_generic_property_api.h
  • MS_generic_default_transition_time_get : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_set : MS_generic_default_transition_time_api.h
  • MS_generic_default_transition_time_set_unacknowledged : MS_generic_default_transition_time_api.h
  • MS_generic_delta_set : MS_generic_level_api.h
  • MS_generic_delta_set_unacknowledged : MS_generic_level_api.h
  • MS_generic_level_get : MS_generic_level_api.h
  • MS_generic_level_set : MS_generic_level_api.h
  • MS_generic_level_set_unacknowledged : MS_generic_level_api.h
  • MS_generic_location_global_get : MS_generic_location_api.h
  • MS_generic_location_global_set : MS_generic_location_api.h
  • MS_generic_location_global_set_unacknowledged : MS_generic_location_api.h
  • MS_generic_location_local_get : MS_generic_location_api.h
  • MS_generic_location_local_set : MS_generic_location_api.h
  • MS_generic_location_local_set_unacknowledged : MS_generic_location_api.h
  • MS_generic_manufacturer_properties_get : MS_generic_property_api.h
  • MS_generic_manufacturer_property_get : MS_generic_property_api.h
  • MS_generic_manufacturer_property_set : MS_generic_property_api.h
  • MS_generic_manufacturer_property_set_unacknowledged : MS_generic_property_api.h
  • MS_generic_move_set : MS_generic_level_api.h
  • MS_generic_move_set_unacknowledged : MS_generic_level_api.h
  • MS_generic_onoff_get : MS_generic_onoff_api.h
  • MS_generic_onoff_set : MS_generic_onoff_api.h
  • MS_generic_onoff_set_unacknowledged : MS_generic_onoff_api.h
  • MS_generic_onpowerup_get : MS_generic_power_onoff_api.h
  • MS_generic_onpowerup_set : MS_generic_power_onoff_api.h
  • MS_generic_onpowerup_set_unacknowledged : MS_generic_power_onoff_api.h
  • MS_generic_power_default_get : MS_generic_power_level_api.h
  • MS_generic_power_default_set : MS_generic_power_level_api.h
  • MS_generic_power_default_set_unacknowledged : MS_generic_power_level_api.h
  • MS_generic_power_last_get : MS_generic_power_level_api.h
  • MS_generic_power_level_get : MS_generic_power_level_api.h
  • MS_generic_power_level_set : MS_generic_power_level_api.h
  • MS_generic_power_level_set_unacknowledged : MS_generic_power_level_api.h
  • MS_generic_power_range_get : MS_generic_power_level_api.h
  • MS_generic_power_range_set : MS_generic_power_level_api.h
  • MS_generic_power_range_set_unacknowledged : MS_generic_power_level_api.h
  • MS_GENERIC_PROP_TYPE_ADMIN : MS_generic_property_api.h
  • MS_GENERIC_PROP_TYPE_MANUFACTURER : MS_generic_property_api.h
  • MS_GENERIC_PROP_TYPE_USER : MS_generic_property_api.h
  • MS_GENERIC_USER_ACCESS_PROHIBITED : MS_generic_property_api.h
  • MS_generic_user_properties_get : MS_generic_property_api.h
  • MS_generic_user_property_get : MS_generic_property_api.h
  • MS_generic_user_property_set : MS_generic_property_api.h
  • MS_generic_user_property_set_unacknowledged : MS_generic_property_api.h
  • MS_health_attention_get : MS_health_client_api.h
  • MS_health_attention_set : MS_health_client_api.h
  • MS_health_attention_set_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_FAULT_ACTUATOR_BLOCKED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_ACTUATOR_BLOCKED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_BATTERY_LOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_BATTERY_LOW_WARNING : MS_health_server_api.h
  • MS_health_fault_clear : MS_health_client_api.h
  • MS_health_fault_clear_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_FAULT_CONDENSATION_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_CONDENSATION_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_CONFIGURATION_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_CONFIGURATION_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_DROPPED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_DROPPED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_MOVED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_DEVICE_MOVED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_EMPTY_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_EMPTY_WARNING : MS_health_server_api.h
  • MS_health_fault_get : MS_health_client_api.h
  • MS_HEALTH_FAULT_HOUSING_OPENED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_HOUSING_OPENED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_NO_CHANGE_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_NO_CHANGE_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_HIGH_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_HIGH_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_LOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INPUT_TOO_LOW_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_INTERNAL_BUS_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_INTERNAL_BUS_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_MECHANISM_JAMMED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_MECHANISM_JAMMED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_MEMORY_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_MEMORY_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_NO_FAULT : MS_health_server_api.h
  • MS_HEALTH_FAULT_NO_LOAD_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_NO_LOAD_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERFLOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERFLOW_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERHEAT_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERHEAT_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERLOAD_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_OVERLOAD_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_SELF_TEST_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_SELF_TEST_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_WARNING : MS_health_server_api.h
  • MS_HEALTH_FAULT_TAMPER_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_TAMPER_WARNING : MS_health_server_api.h
  • MS_health_fault_test : MS_health_client_api.h
  • MS_health_fault_test_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_FAULT_VIBRATION_ERROR : MS_health_server_api.h
  • MS_HEALTH_FAULT_VIBRATION_WARNING : MS_health_server_api.h
  • MS_health_period_get : MS_health_client_api.h
  • MS_health_period_set : MS_health_client_api.h
  • MS_health_period_set_unacknowledged : MS_health_client_api.h
  • MS_HEALTH_SERVER_ATTENTION_RESTART : MS_health_server_api.h
  • MS_HEALTH_SERVER_ATTENTION_START : MS_health_server_api.h
  • MS_HEALTH_SERVER_ATTENTION_STOP : MS_health_server_api.h
  • MS_HEARTBEAT_FEATURE_RELAY : MS_trn_api.h
  • MS_INSUFFICIENT_RESOURCES : MS_error.h
  • MS_INVALID_ADDRESS : MS_error.h
  • MS_INVALID_APPKEY_HANDLE : MS_net_api.h
  • MS_INVALID_APPKEY_INDEX : MS_error.h
  • MS_INVALID_BINDING : MS_error.h
  • MS_INVALID_MODEL : MS_error.h
  • MS_INVALID_NETKEY_INDEX : MS_error.h
  • MS_INVALID_PUBLISH_PARAMETER : MS_error.h
  • MS_INVALID_SUBNET_HANDLE : MS_net_api.h
  • MS_IS_GROUP_ADDR : MS_net_api.h
  • MS_IS_UNICAST_ADDR : MS_net_api.h
  • MS_IS_VIRTUAL_ADDR : MS_net_api.h
  • MS_KEY_INDEX_ALREADY_STORED : MS_error.h
  • MS_LABEL_UUID_LENGTH : MS_common.h
  • MS_light_ctl_default_get : MS_light_ctl_api.h
  • MS_light_ctl_default_set : MS_light_ctl_api.h
  • MS_light_ctl_default_set_unacknowledged : MS_light_ctl_api.h
  • MS_light_ctl_get : MS_light_ctl_api.h
  • MS_light_ctl_set : MS_light_ctl_api.h
  • MS_light_ctl_set_unacknowledged : MS_light_ctl_api.h
  • MS_light_ctl_temperature_get : MS_light_ctl_api.h
  • MS_light_ctl_temperature_range_get : MS_light_ctl_api.h
  • MS_light_ctl_temperature_range_set : MS_light_ctl_api.h
  • MS_light_ctl_temperature_range_set_unacknowledged : MS_light_ctl_api.h
  • MS_light_ctl_temperature_set : MS_light_ctl_api.h
  • MS_light_ctl_temperature_set_unacknowledged : MS_light_ctl_api.h
  • MS_light_hsl_default_get : MS_light_hsl_api.h
  • MS_light_hsl_default_set : MS_light_hsl_api.h
  • MS_light_hsl_default_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_get : MS_light_hsl_api.h
  • MS_light_hsl_hue_get : MS_light_hsl_api.h
  • MS_light_hsl_hue_set : MS_light_hsl_api.h
  • MS_light_hsl_hue_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_range_get : MS_light_hsl_api.h
  • MS_light_hsl_range_set : MS_light_hsl_api.h
  • MS_light_hsl_range_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_saturation_get : MS_light_hsl_api.h
  • MS_light_hsl_saturation_set : MS_light_hsl_api.h
  • MS_light_hsl_saturation_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_set : MS_light_hsl_api.h
  • MS_light_hsl_set_unacknowledged : MS_light_hsl_api.h
  • MS_light_hsl_target_get : MS_light_hsl_api.h
  • MS_light_lc_light_onoff_get : MS_light_lc_api.h
  • MS_light_lc_light_onoff_set : MS_light_lc_api.h
  • MS_light_lc_light_onoff_set_unacknowledged : MS_light_lc_api.h
  • MS_light_lc_mode_get : MS_light_lc_api.h
  • MS_light_lc_mode_set : MS_light_lc_api.h
  • MS_light_lc_mode_set_unacknowledged : MS_light_lc_api.h
  • MS_light_lc_om_get : MS_light_lc_api.h
  • MS_light_lc_om_set : MS_light_lc_api.h
  • MS_light_lc_om_set_unacknowledged : MS_light_lc_api.h
  • MS_light_lc_property_get : MS_light_lc_api.h
  • MS_light_lc_property_set : MS_light_lc_api.h
  • MS_light_lc_property_set_unacknowledged : MS_light_lc_api.h
  • MS_light_lightness_default_get : MS_light_lightness_api.h
  • MS_light_lightness_default_set : MS_light_lightness_api.h
  • MS_light_lightness_default_set_unacknowledged : MS_light_lightness_api.h
  • MS_light_lightness_get : MS_light_lightness_api.h
  • MS_light_lightness_last_get : MS_light_lightness_api.h
  • MS_light_lightness_linear_get : MS_light_lightness_api.h
  • MS_light_lightness_linear_set : MS_light_lightness_api.h
  • MS_light_lightness_linear_set_unacknowledged : MS_light_lightness_api.h
  • MS_light_lightness_range_get : MS_light_lightness_api.h
  • MS_light_lightness_range_set : MS_light_lightness_api.h
  • MS_light_lightness_range_set_unacknowledged : MS_light_lightness_api.h
  • MS_light_lightness_set : MS_light_lightness_api.h
  • MS_light_lightness_set_unacknowledged : MS_light_lightness_api.h
  • MS_light_xyl_default_get : MS_light_xyl_api.h
  • MS_light_xyl_default_set : MS_light_xyl_api.h
  • MS_light_xyl_default_set_unacknowledged : MS_light_xyl_api.h
  • MS_light_xyl_get : MS_light_xyl_api.h
  • MS_light_xyl_range_get : MS_light_xyl_api.h
  • MS_light_xyl_range_set : MS_light_xyl_api.h
  • MS_light_xyl_range_set_unacknowledged : MS_light_xyl_api.h
  • MS_light_xyl_set : MS_light_xyl_api.h
  • MS_light_xyl_set_unacknowledged : MS_light_xyl_api.h
  • MS_light_xyl_target_get : MS_light_xyl_api.h
  • MS_MAJOR_VERSION_NUMBER : MS_version.h
  • MS_MIN_FRNDOFFER_DELAY : MS_trn_api.h
  • MS_MINOR_VERSION_NUMBER : MS_version.h
  • MS_MODEL_ID_CONFIG_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_CONFIG_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_ADMIN_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_BATTERY_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_BATTERY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_CLIENT_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LEVEL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LEVEL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LOCATION_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LOCATION_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_LOCATION_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_MANUFACTURER_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_ONOFF_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_ONOFF_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_LEVEL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_LEVEL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_LEVEL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_ONOFF_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_ONOFF_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_POWER_ONOFF_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_PROPERTY_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_GENERIC_USER_PROPERTY_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_HEALTH_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_HEALTH_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_CTL_TEMPERATURE_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_HUE_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_SATURATION_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_HSL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LC_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LC_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LC_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LIGHTNESS_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LIGHTNESS_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_LIGHTNESS_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_XYL_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_XYL_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_LIGHT_XYL_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCENE_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_SCENE_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCENE_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCHEDULER_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_SCHEDULER_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SCHEDULER_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SENSOR_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_SENSOR_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_SENSOR_SETUP_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_TIME_CLIENT : MS_assigned_numbers.h
  • MS_MODEL_ID_TIME_SERVER : MS_assigned_numbers.h
  • MS_MODEL_ID_TIME_SETUP_SERVER : MS_assigned_numbers.h
  • MS_NET_ADDR_ALL_FRIENDS : MS_net_api.h
  • MS_NET_ADDR_ALL_NODES : MS_net_api.h
  • MS_NET_ADDR_ALL_PROXIES : MS_net_api.h
  • MS_NET_ADDR_ALL_RELAYS : MS_net_api.h
  • MS_NET_ADDR_GROUP_BIT_MASK : MS_net_api.h
  • MS_NET_ADDR_GROUP_COMPARE : MS_net_api.h
  • MS_NET_ADDR_TYPE_GROUP : MS_net_api.h
  • MS_NET_ADDR_TYPE_INVALID : MS_net_api.h
  • MS_NET_ADDR_TYPE_UNICAST : MS_net_api.h
  • MS_NET_ADDR_TYPE_VIRTUAL : MS_net_api.h
  • MS_NET_ADDR_UNASSIGNED : MS_net_api.h
  • MS_NET_ADDR_UNICAST_BIT_MASK : MS_net_api.h
  • MS_NET_ADDR_UNICAST_COMPARE : MS_net_api.h
  • MS_NET_ADDR_VIRTUAL_BIT_MASK : MS_net_api.h
  • MS_NET_ADDR_VIRTUAL_COMPARE : MS_net_api.h
  • MS_NET_FEATURE_PROXY : MS_net_api.h
  • MS_NET_FEATURE_RELAY : MS_net_api.h
  • MS_NETWORK_TX_STATE : MS_common.h
  • MS_NONCE_T_NETWORK : MS_assigned_numbers.h
  • MS_NOT_A_SUBSCRIBE_MODEL : MS_error.h
  • MS_NOT_SUPPORTED : MS_common.h
  • MS_PACK_LE_1_BYTE : MS_common.h
  • MS_PRIMARY_SUBNET : MS_net_api.h
  • MS_prov_data : MS_prov_api.h
  • MS_prov_input_authval : MS_prov_api.h
  • MS_prov_setup_device_pbadv : MS_prov_api.h
  • MS_prov_setup_device_pbgatt : MS_prov_api.h
  • MS_prov_setup_provisioner_pbadv : MS_prov_api.h
  • MS_prov_setup_provisioner_pbgatt : MS_prov_api.h
  • MS_prov_start : MS_prov_api.h
  • MS_PROXY_ADD_TO_FILTER_OPCODE : MS_net_api.h
  • MS_proxy_add_to_list : MS_net_api.h
  • MS_PROXY_BLACKLIST_FILTER : MS_net_api.h
  • MS_PROXY_CONNECTED : MS_net_api.h
  • MS_proxy_del_from_list : MS_net_api.h
  • MS_PROXY_DOWN_EVENT : MS_net_api.h
  • MS_PROXY_FILTER_STATUS_OPCODE : MS_net_api.h
  • MS_PROXY_NET_ID_ADV_MODE : MS_net_api.h
  • MS_PROXY_NODE_ID_ADV_MODE : MS_net_api.h
  • MS_PROXY_NULL : MS_net_api.h
  • MS_PROXY_READY : MS_net_api.h
  • MS_PROXY_REM_FROM_FILTER_OPCODE : MS_net_api.h
  • MS_proxy_set_blacklist_filter : MS_net_api.h
  • MS_PROXY_SET_FILTER_OPCODE : MS_net_api.h
  • MS_proxy_set_whitelist_filter : MS_net_api.h
  • MS_PROXY_STATUS_EVENT : MS_net_api.h
  • MS_PROXY_UP_EVENT : MS_net_api.h
  • MS_PROXY_WHITELIST_FILTER : MS_net_api.h
  • MS_RELAY_TX_STATE : MS_common.h
  • MS_scene_delete : MS_scene_api.h
  • MS_scene_delete_unacknowledged : MS_scene_api.h
  • MS_SCENE_EVENT_DELETE : MS_scene_api.h
  • MS_SCENE_EVENT_RECALL_COMPLETE : MS_scene_api.h
  • MS_SCENE_EVENT_RECALL_IMMEDIATE : MS_scene_api.h
  • MS_SCENE_EVENT_RECALL_START : MS_scene_api.h
  • MS_SCENE_EVENT_STORE : MS_scene_api.h
  • MS_scene_get : MS_scene_api.h
  • MS_scene_recall : MS_scene_api.h
  • MS_scene_recall_unacknowledged : MS_scene_api.h
  • MS_scene_register_get : MS_scene_api.h
  • MS_scene_store : MS_scene_api.h
  • MS_scene_store_unacknowledged : MS_scene_api.h
  • MS_scheduler_action_get : MS_scheduler_api.h
  • MS_scheduler_action_set : MS_scheduler_api.h
  • MS_scheduler_action_set_unacknowledged : MS_scheduler_api.h
  • MS_scheduler_get : MS_scheduler_api.h
  • MS_SEGMENTED_ACCESS_MSG : MS_ltrn_api.h
  • MS_SEGMENTED_CTRL_MSG : MS_ltrn_api.h
  • MS_sensor_cadence_get : MS_sensor_api.h
  • MS_sensor_cadence_set : MS_sensor_api.h
  • MS_sensor_cadence_set_unacknowledged : MS_sensor_api.h
  • MS_sensor_column_get : MS_sensor_api.h
  • MS_sensor_descriptor_get : MS_sensor_api.h
  • MS_sensor_get : MS_sensor_api.h
  • MS_sensor_series_get : MS_sensor_api.h
  • MS_sensor_setting_get : MS_sensor_api.h
  • MS_sensor_setting_set : MS_sensor_api.h
  • MS_sensor_setting_set_unacknowledged : MS_sensor_api.h
  • MS_sensor_settings_get : MS_sensor_api.h
  • MS_STATE_GENERIC_ONOFF_T : MS_model_states.h
  • MS_STORAGE_FAILURE : MS_error.h
  • MS_SUB_MINOR_VERSION_NUMBER : MS_version.h
  • MS_tai_utc_delta_get : MS_time_api.h
  • MS_tai_utc_delta_set : MS_time_api.h
  • MS_TEMP_UNABLE_TO_CHANGE_STATE : MS_error.h
  • MS_time_get : MS_time_api.h
  • MS_time_role_get : MS_time_api.h
  • MS_time_role_set : MS_time_api.h
  • MS_time_set : MS_time_api.h
  • MS_time_zone_get : MS_time_api.h
  • MS_time_zone_set : MS_time_api.h
  • MS_TRN_ACCESS_PKT : MS_ltrn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_CLEAR : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_CLEAR_CNF : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_OFFER : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_POLL : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_REQ : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_CNF : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_FRND_UPDATE : MS_trn_api.h
  • MS_TRN_CTRL_OPCODE_HEARTBEAT : MS_trn_api.h
  • MS_TRN_CTRL_PKT : MS_ltrn_api.h
  • MS_trn_lpn_subscrn_list_add : MS_trn_api.h
  • MS_trn_lpn_subscrn_list_remove : MS_trn_api.h
  • MS_UNPACK_LE_1_BYTE : MS_common.h
  • MS_UNSEGMENTED_ACCESS_MSG : MS_ltrn_api.h
  • MS_UNSEGMENTED_CTRL_MSG : MS_ltrn_api.h
  • MS_UNSPECIFIED_ERROR : MS_error.h


EtherMind Mesh SDK (beta): Globals

- n -

  • NET_IS_VALID_DST_ADDR : MS_net_api.h
  • NET_IS_VALID_SRC_ADDR : MS_net_api.h


EtherMind Mesh SDK (beta): Globals

- p -

  • PROV_ALGO_EC_FIPS_P256 : MS_prov_api.h
  • PROV_AUTH_OOB_NONE : MS_prov_api.h
  • PROV_BRR_ADV : MS_prov_api.h
  • PROV_CLOSE_REASON_SUCCESS : MS_prov_api.h
  • PROV_ERR_PROHIBITED : MS_prov_api.h
  • PROV_EVT_DEVINPUT_COMPLETE : MS_prov_api.h
  • PROV_EVT_OOB_DISPLAY : MS_prov_api.h
  • PROV_EVT_OOB_ENTRY : MS_prov_api.h
  • PROV_EVT_PROVDATA_INFO : MS_prov_api.h
  • PROV_EVT_PROVDATA_INFO_REQ : MS_prov_api.h
  • PROV_EVT_PROVISIONING_COMPLETE : MS_prov_api.h
  • PROV_EVT_PROVISIONING_SETUP : MS_prov_api.h
  • PROV_EVT_UNPROVISIONED_BEACON : MS_prov_api.h
  • PROV_HANDLE_INVALID : MS_prov_api.h
  • PROV_IOOB_ACTION_PUSH : MS_prov_api.h
  • PROV_KEY_NETKEY_SIZE : MS_prov_api.h
  • PROV_MASK_ALGO_EC_FIPS_P256 : MS_prov_api.h
  • PROV_MASK_IOOB_ACTION_PUSH : MS_prov_api.h
  • PROV_MASK_OOOB_ACTION_BLINK : MS_prov_api.h
  • PROV_MASK_PUBKEY_OOBINFO : MS_prov_api.h
  • PROV_MASK_STATIC_OOBINFO : MS_prov_api.h
  • PROV_OOB_TYPE_OTHER : MS_prov_api.h
  • PROV_OOOB_ACTION_BLINK : MS_prov_api.h
  • PROV_PCF_CONTINU_FRGMNT : MS_prov_api.h
  • PROV_PCF_CTRL_MSG : MS_prov_api.h
  • PROV_PCF_NUM_FRGMNTS : MS_prov_api.h
  • PROV_PCF_TX_SPECIFIC : MS_prov_api.h
  • PROV_PDU_TYPE_INVITE : MS_prov_api.h
  • PROV_PUBKEY_NO_OOB : MS_prov_api.h
  • PROV_ROLE_DEVICE : MS_prov_api.h


EtherMind Mesh SDK (beta): Globals

- t -

  • TIMER_ERR_ID : MS_error.h


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/ethermind_stack_general_concepts.md Source File

mesh/build/doc/getting_started/ethermind_stack_general_concepts.md
1 # EtherMind Mesh Stack - General Concepts
2
3 ## Conventions
4
5 All exported header files are named as **MS_*.h**
6 - The exported headers may in turn include other header files
7 - applications need not be include these headers directly
8 - All exported API functions are named as **MS_*()**
9 - Similarly all data structures and macros are also prefixed with the name of the associated mesh module
10 - Each module interface has following sub-categories: - Defines (Constants, Data Structures, etc.)
11 - Error Codes (A few error codes maybe exposed by a module in addition to those defined in \ref MS_error.h)
12 - Events (Asynchronous responses and notifications provided by the module to application)
13 - Callback (Callback function to be registered by application/calling module to be notified of asynchronous events)
14
15 ## Non-blocking Architecture
16
17 EtherMind Mesh Stack APIs are non-blocking in nature. When a calling process/task/application calls a BlueLitE Stack API, the stack initiates API processing and control returns back to the calling process/task/application. After API processing completes, the result is passed to application with a callback. This callback is also used to notify the application of asynchronous events.
18
19 ## Error Handling
20
21 All stack API return error codes as \ref API_RESULT - a 2 byte format. The MSB refers to the module returning the error and LSB refers to specific error code in the module. All error codes are documented at \ref MS_ERROR_CODES or header \ref MS_error.h. (See Also: \ref error_code_overview "Error Codes Theory")
22 ### To lookup an error:
23 - Retrieve the MSB and LSB of the error code
24 - Tip: Print the error code in the format: \code printf ("0x%04X", error_code); \endcode
25 - First lookup the module returning the error (MSB) first under \ref ms_error_codes_groups or in header file \ref MS_error.h
26 - Then search for specific error code (LSB) under the specific module error code list
27 - Example: If the error code is \code 0x2312 \endcode MSB 0x23 is under \ref ms_error_codes_groups_protocols group module \ref ACCESS_ERR_ID
28 - Under \ref ms_error_codes_module_hci errors, search for LSB 0x0012, which is \ref ACCESS_PARAMETER_OUTSIDE_RANGE


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/getting_started.md Source File

mesh/build/doc/getting_started/getting_started.md
1 # Getting Started
2
3 - @subpage md_mesh_build_doc_getting_started_mesh_concepts
4 - @subpage md_mesh_build_doc_getting_started_mesh_architecture
5 - @subpage md_mesh_build_doc_getting_started_mesh_provisioning
6 - @subpage md_mesh_build_doc_getting_started_mesh_model
7 - @subpage md_mesh_build_doc_getting_started_ethermind_stack_general_concepts
8 - @subpage md_mesh_build_doc_getting_started_repository_structure
9 - @subpage md_mesh_build_doc_getting_started_mesh_porting
10 - @subpage md_mesh_build_doc_release_notes
11


EtherMind Mesh SDK (beta): Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };
/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };
/* Class not documented with doxygen comments */
class Undocumented { };
/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };
/*! A template class */
template<class T> class Templ { };
/*! Class that is inherited using protected inheritance */
class ProtectedBase { };
/*! Class that is inherited using private inheritance */
class PrivateBase { };
/*! Class that is used by the Inherited class */
class Used { };
/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
protected ProtectedBase,
private PrivateBase,
public Undocumented,
public Templ<int>
{
private:
Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


EtherMind Mesh SDK (beta): Main Page

EtherMind Mesh SDK (beta) Documentation

This document describes the APIs exported by EtherMind Mesh Stack. EtherMind Bluetooth Mesh implementation supports all mandatory and optional features defined by Bluetooth SIG Mesh specification.

This document is intended as Developers' Reference. The reader of this document is expected to be familiar at high-level with Bluetooth Mesh Specifications. The document describes all API in a full configuration stack. Avaiability of APIs in your specific configuration depends on the features, customization and optimizations enabled.

Getting Started

Refer md_mesh_build_doc_getting_started_getting_started.


EtherMind Mesh SDK (beta): mesh/build/doc/mainpage.md Source File

mesh/build/doc/mainpage.md
1 # Introduction
2
3 This document describes the APIs exported by EtherMind Mesh Stack.
4 EtherMind Bluetooth Mesh implementation supports all mandatory and optional features defined by Bluetooth SIG Mesh specification.
5
6 This document is intended as Developers' Reference. The reader of this document is expected to be familiar at high-level with Bluetooth Mesh Specifications.
7 The document describes all API in a full configuration stack. Avaiability of APIs in your specific configuration depends on the features, customization and optimizations enabled.
8
9
10 ## Getting Started
11
12 Refer @subpage md_mesh_build_doc_getting_started_getting_started.
13
14


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/mesh_architecture.md Source File

mesh/build/doc/getting_started/mesh_architecture.md
1 # Bluetooth Mesh - Architecture
2
3 ### Mesh System Architecture
4
5 This section will give an overview of Bluetooth Mesh Architecture, its layers and their responsibilities.
6
7 ![BLE Mesh Architecture Block Diagram](mesh_block_diagram.png)
8
9 Mesh system is dependent on the functionalies exposed by Bluetooth Low Energy (BLE) Stack. This is depicted by a single block for BLE.
10
11 #### Bearer Layer
12 Mesh messages require an underlying communications system for their transmission and receipt. The bearer layer defines how mesh PDUs will be handled by a given communications system. At this time, two bearers are defined and these are called the Advertising Bearer and the GATT Bearer. The Advertising Bearer leverages Bluetooth LE's GAP advertising and scanning features to convey and receive mesh PDUs. The GATT Bearer allows a device which does not support the Advertising Bearer to communicate indirectly with nodes of a mesh network which do, using a protocol known as the Proxy Protocol. The Proxy Protocol is encapsulated within GATT operations involving specially defined GATT characteristics. A mesh Proxy node implements these GATT characteristics and supports the GATT bearer as well as the Advertising Bearer so that it can convert and relay messages between the two types of bearer.
13
14 #### Network Layer
15 The network layer defines the various message address types and a network message format which allows transport layer PDUs to be transported by the bearer layer. It can support multiple bearers, each of which may have multiple network interfaces, including the local interface which is used for communication between elements that are part of the same node. The network layer determines which network interface(s) to output messages over. An input filter is applied to messages arriving from the bearer layer, to determine whether or not they should be delivered to the network layer for further processing. Output messages are subject to an output filter to control whether or not they are dropped or delivered to the bearer layer. The Relay and Proxy features may be implemented by the network layer.
16
17 #### Lower Transport Layer
18 The lower transport layer takes PDUs from the upper transport layer and sends them to the lower transport layer on a peer device. Where required, it performs segmentation and reassembly of PDUs. For longer packets, which will not fit into a single Transport PDU, the lower transport layer will perform segmentation, splitting the PDU into multiple Transport PDUs. The receiving lower transport layer on the other device, will reassemble the segments into a single upper transport layer PDU and pass this up the stack.
19
20 #### Upper Transport Layer
21 The upper transport layer is responsible for the encryption, decryption and authentication of application data passing to and from the access layer. It also has responsibility for transport control messages, which are internally generated and sent between the upper transport layers on different peer nodes. These include messages related to friendship and heartbeats.
22
23 #### Access Layer
24 The access layer is responsible for defining how applications can make use of the upper transport layer.
25 This includes:
26 - Defining the format of application data.
27 - Defining and controlling the encryption and decryption process which is performed in the upper transport layer.
28 - Verifying that data received from the upper transport layer is for the right network and application, before forwarding the data up the stack.
29
30 #### Foundation Models
31 The foundation model layer is responsible for the implementation of those models concerned with the configuration and management of a mesh network.
32
33 #### Models
34 The model layer is concerned with the implementation of Models and as such, the implementation of behaviors, messages, states, state bindings and so on, as defined in one or more model specifications.
35


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/mesh_concepts.md Source File

mesh/build/doc/getting_started/mesh_concepts.md
1 # Bluetooth Mesh - Concepts
2
3 In the following sections we will define the terms and concepts using in Bluetooth Mesh technology.
4
5 ## Devices and Nodes
6 Devices which are part of a mesh network are called nodes and those which are not are called "unprovisioned devices".
7 The process which transforms an unprovisioned device into a node is called "provisioning".
8
9 Provisioning is a secure procedure which results in an unprovisioned device possessing a series of encryption keys and being known to the Provisioner device, typically a tablet or smartphone. One of these keys is called the network key or NetKey for short.
10
11 Securely acquiring a NetKey through the provisioning process is a fundamental first step of Bluetooth Mesh technology.
12
13 ## Elements
14 Some nodes have multiple, constituent parts, each of which can be independently controlled. In Bluetooth mesh terminology, these parts are called elements.
15
16 ## Messages
17 When a node needs to query the status of other nodes or needs to control other nodes in some way, it sends a message of a suitable type. If a node needs to report its status to other nodes, it sends a message. All communication in the mesh network is "messageoriented" and many message types are defined, each with its own, unique opcode.
18
19 Messages fall within one of two broad categories; acknowledged or unacknowledged.
20 Acknowledged messages require a response from nodes that receive them. The response serves two purposes: it confirms that the message it relates to was received, and it returns data relating to the message recipient to the message sender.
21
22 The sender of an acknowledged message may resend the message if it does not receive the expected response(s) and therefore, acknowledged messages must be idempotent. This means that the effect of a given acknowledged message, arriving at a node multiple times, will be the same as it had only been received once.
23
24 Unacknowledged messages do not require a response.
25
26 ## Addresses
27
28 Bluetooth mesh defines three types of addresses. Messages must be sent from and to an address.
29
30 A unicast address uniquely identifies a single element. Unicast addresses are assigned to devices during the provisioning process.
31
32 A virtual address is an address which may be assigned to one or more elements, spanning one or more nodes. It takes the form of a 128-bit UUID value with which any element can be associated and is much like a label. Virtual addresses will likely be preconfigured at the point of manufacture and be used for scenarios such as allowing the easy addressing of all meeting room projectors made by this manufacturer.
33
34 A group address is a multicast address which represents one or more elements. Group addresses are either defined by the Bluetooth Special Interest Group (SIG) and are known as SIG Fixed Group Addresses or are assigned dynamically. 4 SIG Fixed Group Addresses have been defined. These are named All-proxies, All-friends, All-relays and All-nodes.
35
36 It is expected that dynamic group addresses will be established by the user via a configuration application and that they will reflect the physical configuration of a building, such as defining group addresses which correspond to each room in the building.
37
38 ## Publish/Subscribe
39
40 The act of sending a message is known as publishing.
41 Nodes are configured to select messages sent to specific addresses for processing, and this is known as subscribing.
42
43 Typically, messages are addressed to group or virtual addresses. Group and virtual address names will have readily understood meaning to the end user, making them easy and intuitive to use.
44
45 The use of group and virtual addresses with the publish/ subscribe communication model has an additional, substantial benefit in that removing, replacing or adding new nodes to the network does not require reconfiguration of other nodes.
46
47
48 ## State and Properties
49 Elements can be in various conditions and this is represented in Bluetooth mesh by the concept of state values.
50 A state is a value of a certain type, contained within an element. As well as values, States also have associated behaviors and may not be reused in other contexts.
51 As an example, consider a simple light which may either be on or off. Bluetooth mesh defines a state called Generic OnOff. The light would possess this state item and a value of On would correspond to and cause the light to be illuminated whereas a Generic OnOff state value of Off would reflect and cause the light to be switched off.
52
53 Properties are similar to states in that they contain values relating to an element. But they are significantly different to states in other ways.
54 A property provides the context for interpreting a characteristic.
55 To appreciate the significance and use of contexts as they relate to properties, consider for example, the characteristic Temperature 8, an 8-bit temperature state type which has a number of associated properties, including Present Indoor Ambient Temperature and Present Outdoor Ambient Temperature. These two properties allow a sensor to publish sensor readings in a way that allows a receiving client to determine the context the temperature value has, making better sense of its true meaning.
56 Properties are organized into two categories: Manufacturer, which is a read-only category and Admin which allows read-write access.
57
58
59 ## Messages, States and Properties
60 Messages are the mechanism by which operations on the mesh are invoked. Formally, a given message type represents an operation on a state or collection of multiple state values. All messages are of three broad types, reflecting the types of operation which Bluetooth mesh supports. The shorthand for the three types is GET, SET and STATUS.
61
62 GET messages request the value of a given state from one or more nodes. A STATUS message is sent in response to a GET and contains the relevant state value. SET messages change the value of a given state. An acknowledged SET message will result in a STATUS message being returned in response to the SET message whereas an unacknowledged SET message requires no response.
63
64 STATUS messages are sent in response to GET messages, acknowledged SET messages or independently of other messages, perhaps driven by a timer running on the element sending the message, for example.
65
66 Specific states referenced by messages are inferred from the message opcode. Properties on the other hand, are referenced explicitly in generic property related messages using a 16-bit property ID.
67
68 ## State Transitions
69 Changes from one state to another are called state transitions. Transitions may be instantaneous or execute over a period of time called the transition time. A state transition is likely to have an effect on the application layer behavior of a node.
70
71 ## Bound States
72 Relationships may exist between states whereby a change in one triggers a change in the other. Such a relationship is called a state binding. One state may be bound to multiple other states.
73
74 For example, consider a light controlled by a dimmer switch. The light would possess the two states, Generic OnOff and Generic Level with each bound to the other. Reducing the brightness of the light until Generic Level has a value of zero (fully dimmed) results in Generic OnOff transitioning from On to Off.
75
76 ## Models
77 Models pull the preceding concepts together and define some or all of the functionality of an element as it relates to the mesh network. Three categories of model are recognized.
78
79 A server model defines a collection of states, state transitions, state bindings and messages which the element containing the model may send or receive. It also defines behaviors relating to messages, states and state transitions.
80
81 A client model does not define any states. Instead, it defines the messages which it may send or receive in order to GET, SET or acquire the STATUS of states defined in the corresponding server model.
82
83 Control models contain both a server model, allowing communication with other client models and a client model which allows communication with server models.
84
85 ## Provisioning
86 Provisioning is the process by which a device joins the mesh network and becomes a node. It involves several stages, results in various security keys being generated and is itself a secure process.
87
88 The provisioning process progresses through five steps and these are described next.
89
90 ### Beaconing
91 An unprovisioned device indicates its availability to be provisioned by using the <<Mesh Beacon>> AD type in advertising packets. The user might need to start a new device advertising in this way by, for example, pressing a combination of buttons or holding down a button for a certain length of time.
92
93 ### Invitation
94 The Provisioner sends an invitation to the device to be provisioned, in the form of a Provisioning Invite PDU. The Beaconing device responds with information about itself in a Provisioning Capabilities PDU.
95
96 ### Exchanging Public Keys
97 The Provisioner and the device to be provisioned, exchange their public keys, which may be static or ephemeral, either directly or using an out-of-band (OOB) method.
98
99 ### Authentication
100 The device to be provisioned outputs a random, single or multi-digit number to the user in some form, using an action appropriate to its capabilities. For example, it might flash an LED several times. The user enters the digit(s) output by the new device into the Provisioner and a cryptographic exchange takes place between the two devices, involving the random number, to complete the authentication of each of the two devices to the other.
101
102 ### Distribution of the Provisioning Data
103 After authentication has successfully completed, a session key is derived by each of the two devices from their private keys and the exchanged, peer public keys. The session key is then used to secure the subsequent distribution of the data required to complete the provisioning process, including a security key known as the network key (NetKey). After provisioning has completed, the provisioned device possesses the network's NetKey, a mesh security parameter known as the IV Index and a Unicast Address, allocated by the Provisioner. It is now known as a node.
104
105
106 ## Features
107 All nodes can transmit and receive mesh messages but there are a number of optional features which a node may possess, giving it additional, special capabilities. There are four such optional features: the Relay, Proxy, Friend, and the Low Power features.
108
109 A node may support zero or more of these optional features and any supported feature may, at a point in time, be enabled or disabled.
110
111 ### Relay Nodes
112 Relaying is the mechanism by which a message can traverse the entire mesh network, making multiple "hops" between devices by being relayed.
113 Nodes which support the Relay feature, known as Relay nodes, are able to retransmit received messages.
114
115 ### Low Power Nodes and Friend Nodes
116 Some types of node have a limited power source and need to conserve energy as much as possible. Furthermore, devices of this type may be predominantly concerned with sending messages but still have a need to occasionally receive messages.
117
118 Consider a temperature sensor which is powered by a small coin cell battery. It sends a temperature reading once per minute whenever the temperate is above or below configured upper and lower thresholds. If the temperature stays within those thresholds it sends no messages. These behaviors are easily implemented with no particular issues relating to power consumption arising.
119
120 However, the user is also able to send messages to the sensor which change the temperature threshold state values. This is a relatively rare event but the sensor must support it.
121
122 Nodes like the temperature sensor in the example may be designated Low Power nodes (LPNs) and a feature flag in the sensor's configuration data will designate the node as such.
123
124 LPNs work in tandem with another node, one which is not power-constrained (e.g. it has a permanent AC power source). This device is termed a Friend node. The Friend stores messages addressed to the LPN and delivers them to the LPN whenever the LPN polls the Friend node for "waiting messages". The LPN may poll the Friend relatively infrequently so that it can balance its need to conserve power with the timeliness with which it needs to receive and process configuration messages. When it does poll, all messages stored by the Friend are forwarded to the LPN, one after another, with a flag known as MD (More Data) indicating to the LPN whether there are further messages to be sent from the Friend node.
125
126 The relationship between the LPN and the Friend node is known as friendship. Friendship is key to allowing very power constrained nodes which need to receive messages, to function in a Bluetooth mesh network whilst continuing to operate in a power-efficient way.
127
128 ### Proxy Nodes
129 Proxy nodes allow Bluetooth LE devices that do not possess a Bluetooth mesh stack to interact with nodes in a mesh network.
130
131 Proxy nodes expose a GATT interface which Bluetooth LE devices may use to interact with a mesh network. A protocol called the Proxy Protocol, intended to be used with a connection-oriented bearer, such as GATT is defined. GATT devices read and write Proxy Protocol PDUs from within GATT characteristics implemented by the Proxy node. The Proxy node transforms these PDUs to/from mesh PDUs.
132
133 ## Node Configuration
134 Each node supports a standard set of configuration states which are implemented within the standard Configuration Server Model and accessed using the Configuration Client Model. Configuration State data is concerned with the node's capabilities and behavior within the mesh, independently of any specific application or device type behaviors.
135
136 For example, the features supported by a node, whether it is a Proxy node, a Relay node and so on, are indicated by Configuration Server states. The addresses to which a node has subscribed are stored in the Subscription List. The network and subnet keys indicating the networks the node is a member of are listed in the configuration block, as are the application keys held by the mode.
137
138 A series of configuration messages allow the Configuration Client Model and Configuration Server Model to support GET, SET and STATUS operations on the Configuration Server Model states.
139


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/mesh_model.md Source File

mesh/build/doc/getting_started/mesh_model.md
1 # Mesh Model
2
3 ## Introduction
4
5 Models defines typical user scenario, associated states, messages (get, set, status) operate on defined states.
6
7 ## Model and Access Layer
8 Models registers themself with Acess Layer.
9
10 The following diagram illustrate the model hierarchy.
11
12 ![Model Hierarchy](node_hierarchy.png)
13
14 ## Access Layer MSCs
15 ![Access Layer API Usage](blemesh-access-appl.png)
16


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/mesh_porting.md Source File

mesh/build/doc/getting_started/mesh_porting.md
1 # MESH IP Porting #
2
3 ## 1. What are the BLE{GAP} APIs that MESH stack expects from the below Platform/Stack ? ##
4
5 The following table depicts the mapping between the BLE functionality sepcific to the GAP Layer as defined in BT Specification and their corresponding calls
6 to look for in a Bluetooth Low Energy SDK. Support for Advertising bearer is mandatory.
7
8 | SL#| |BLE Functionality|Generic BLE GAP API Calls needed from SDK |Notes (if any) |
9 |:---|:---|:--- |:--- |:--- |
10 | 1 | |Get Local ADDR |`API to get the local BT Device Address` | |
11 | 2 | |Add to WhiteList |`API to add a BT Device Address to WhiteList` | <Optional>Used only for provisioning scenarios, during Development Phase.|
12 | 3 | |ADV | | |
13 | |a |Start |`API to start (Legacy)ADV` | |
14 | |b |Stop |`API to stop (Legacy)ADV ` | |
15 | |c |Update Data |`API to update (Legacy)ADV Data` | |
16 | 4 | |SCAN | | |
17 | |a |Start |`API to start (Legacy)SCAN` | |
18 | |b |Stop |`API to stop (Legacy)SCAN` | |
19 | 5 | |ADV Reports |`Pass on received ADV reports` | |
20 | 6 | |Connection |`API to Initiate LE Connection to Peer` | Required only if GATT bearer to be used. |
21
22 ## 2. What are the BLE{GATT} APIs that MESH stack expects from the below Platform/Stack ? ##
23
24 The following table depicts the mapping between the BLE functionality sepcific to the GATT Layer as defined in BT Specification and their corresponding calls to look for in a Bluetooth Low Energy SDK. Support for GATT bearer is optional. These GATT interfaces are used for proxy feature and also during provisioning over GATT (if required).
25
26 | SL#| |BLE Functionality |Generic BLE GATT API Calls needed from SDK |Notes (if any) |
27 |:---|:---|:--- |:--- |:--- |
28 | 1 | |GATT Client | | |
29 | |a |Service Discovery |`API to Discover all Peer GATT Services` | |
30 | |b |Char Discovery |`API to Discover all Peer GATT Characteristics`| |
31 | |c |CCCD Write |`API to write to Peer CCCD for HVI/HVN` | |
32 | |d |Write Command |`API to send Write Without Response(WWR)` | |
33 | |e |Recv HVI/HVN |`Pass on received HVI/HVN` | |
34 | 2 | |GATT Server | | |
35 | |a |Service Presence |`Have, add, enable or disable a service` | |
36 | |b |Char Presence |`Have, add, enable or disable Characteristics` | |
37 | |c |Send HVI/HVN |`API to send HVI/HVN when CCCD is configured` | |
38 | |d |Recv WWR |`Pass on received WWR` | |
39
40 ## 3. What are the Utility APIs that MESH stack expects from the below Platform/Stack ? ##
41 The following table depicts the list of Utility functionality Interfaces expected to be present in a Bluetooth Low Energy SDK which are to be used by the Mesh Stack.
42
43 | SL#| |Utility Functions|Generic API Calls needed from SDK |Notes (if any) |
44 |:---|:---|:--- |:--- |:--- |
45 | 1 | |Stack ON |`API to Initialize/Start the BLE Stack/System`| Interface to Initialize the Underlying BLE Stack |
46 | 2 | |Stack OFF |`API to Kill/Power Off the BLE Stack/System` | Interface to Shutdown the Underlying BLE Stack |
47 | 3 | |Timer |`MilliSecond Granularity` | |
48 | |a |Start Timer |`API to start a Timer` | Interface to Start a Timer with MilliSecond Granularity |
49 | |b |Stop Timer |`API to stop a Timer` | Interface to Stop a current running Timer |
50 | 4 | |Miscellaneous |`Miscellaneous Requirements` | Storage is required to store supported models/elements related information (publish/subscription list etc.). |
51 | |a |Flash Write |`API to write to Storage` | Interface to fecilitate Flash/NVRAM Write etc. |
52 | |b |Flash Read |`API to read from Storage` | Interface to fecilitate Flash/NVRAM Read etc. |
53 | |c |Debug Support |`Debug Support to divert logs to IO or File` | (Optional) Divert Logs to CONSOLE/IO/File etc. Will help in debugging. |
54 | |d |Serial Interface |`Serial interface support over UART etc.` | (Optional) Can be used for easy demonstration and also for simple test setup. This would help in creating a generic CommandLineInterace[CLI] over which Mesh Stack related commands can be issued. |
55
56 Below is a example of a interface required from the platform to start a Timer[with Millisecond Granularity]:-
57
58 int util_start_timer
59 (
60 /* OUT */ timer_handle * handle,
61 /* IN */ usigned int timeout,
62 /* IN */ void * timer_callback_fn
63 );
64
65 Below is a example of a interface required from the platform to write data to Flash/NVRAM :-
66
67 int flash_nvram_write
68 (
69 /* IN */ void * flash_nvram_memory_identifier_handle,
70 /* IN */ unsigned int flash_nvram_addr,
71 /* IN */ unsigned char * data_to_be_flahsed,
72 /* IN */ unsigned int len_of_data_to_br_flashed
73 );
74 ## 4. What are the BLE{Security} interfaces that MESH stack expects from the below Platform/Stack ? ##
75 The following table depicts the mapping between the BLE functionality sepcific to the Security Toolbox as defined in BT Specification and their corresponding calls to look for in a Bluetooth Low Energy SDK.
76
77 While it is possible to have some of these implementations in software, it is highly recommended that Bluetooth controller/platform provides `Direct Function Call` based interface for the listed security algorithms.
78
79 | SL#| |Security Functionality |Generic BLE Security Interfaces needed from SDK |Notes (if any) |
80 |:---|:---|:--- |:--- |:--- |
81 | 1 | |AES 128 |`AES 128` | |
82 | |a |AES 128 Encrypt |`Interface to encrypt using AES 128` | |
83 | |b |AES 128 Decrypt |`Interface to decrypt using AES 128` | Both Encrypt and Decrypt could be the same interface, *AES 128 Encrypt*|
84 | 2 | |AES CMAC |`AES CMAC Algorithm` | |
85 | |a |CMAC Generation |`Interface for generating MAC of given Len` | |
86 | |b |CMAC Verification |`Interface for verifying MAC of given Len` | Both Generation and Verification can use the same Interface. |
87 | 3 | |AES CCM |`AES CCM Algorithm` | |
88 | |a |CCM Encryption |`Interface for encrypting plain text` | |
89 | |b |CCM Decryption |`Interface for decrypting cipher text` | |
90 | 4 | |ECDH |`ECDH Algorithm` | |
91 | |a |P256 Keypair generate |`Interface to get P256 Public Key` | |
92 | |b |DHKey generate |`Interface to generate DHkey` | |
93 | |c |Set P256 Debug Keys |`Interface to set P256 debug Key pairs` | (Optional) Will help in debugging using Mesh Spec provided sample data and while decoding using Air-Sniffers |
94 | 5 | |Random Number Generator|`Interface to generate N bytes of Random Number`| |
95
96 Below is a example of a interface required by the platform for AES CMAC, one of the security related functionalities :-
97
98 int sec_tbx_example_aes_128_cmac_gen_pl
99 (
100 /* IN */ unsigned char * pdata,
101 /* IN */ unsigned short int datalen,
102 /* IN */ unsigned char * pkey,
103 /* IN */ unsigned short int maclen,
104 /* OUT */ unsigned char * pmac
105 );


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/mesh_provisioning.md Source File

mesh/build/doc/getting_started/mesh_provisioning.md
1 # Mesh Provisioning
2
3 ## Introduction
4
5 Provisioning is the process of adding a new device to the network. During the provisioning
6 process the new device is provided with information called provisioning data required for
7 the device to join and operate in the network.
8 The provisioning data contains a network key and an unique address.
9 Device key is derived from the network key and is used for secure communication between
10 the device (provisionee) and the configuring device (provisioner).
11
12 ## Provisioning procedure
13
14 The following diagrams illustrate the provisioning procedures for various OOB configuration.
15
16 ![Provisioning Procedure - No OOB](blemesh-provisioning-nooobauth.png)
17 ![Provisioning Procedure - Input OOB](blemesh-provisioning-ioobauth.png)
18 ![Provisioning Procedure - Output OOB](blemesh-provisioning-ooobauth.png)
19
20 ## Provisioning state machine
21 ![Provisioner State Machine](prov_provisioner.png)
22 ![Provisionee State Machine](prov_device.png)
23
24


EtherMind Mesh SDK (beta): mesh/export/include/MS_access_api.h Source File

  • mesh
  • export
  • include
MS_access_api.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_ACCESS_API_
15 #define _H_MS_ACCESS_API_
16
17
18 /* --------------------------------------------- Header File Inclusion */
19 /* Transport Layer */
20 #include "MS_trn_api.h"
21
22 /* --------------------------------------------- Global Definitions */
23
48 #define MS_ACCESS_MAX_PKT_SIZE 384
49
50
53 #define MS_ACCESS_VADDR_LABEL_UUID_SIZE 16
54
55 #define MS_ACCESS_NETKEY_SIZE 16
56
57 #define MS_ACCESS_APPKEY_SIZE 16
58
60 #define MS_ACCESS_DEFAULT_NODE_ID 0x00
61
63 #define MS_ACCESS_DEFAULT_ELEMENT_HANDLE 0x00
64
66 #define MS_ACCESS_GET_REQ 0x01
67
69 #define MS_ACCESS_SET_REQ 0x02
70
72 #define ACCESS_INVALID_DEFAULT_TTL 0xFF
73
75 #define ACCESS_MAX_TTL 0x7F
76
79 #define MS_ACCESS_MODEL_REQ_MSG_T_GET 0
80
81 #define MS_ACCESS_MODEL_REQ_MSG_T_SET 1
82
83 #define MS_ACCESS_MODEL_REQ_MSG_T_OTHERS 2
84
87 #define MS_ACCESS_KEY_REFRESH_PHASE_NORMAL 0x00
88
89 #define MS_ACCESS_KEY_REFRESH_PHASE_1 0x01
90
91 #define MS_ACCESS_KEY_REFRESH_PHASE_2 0x02
92
93 #define MS_ACCESS_KEY_REFRESH_PHASE_3 0x03
94
96 #define MS_ACCESS_ADDRESS_INVALID_HANDLE 0xFFFFFFFF
97
118 #define MS_ACCESS_ASSIGN_ELEMENT(pelement, loc) \
119 (pelement)->loc = (loc)
120
122 #define MS_ACCESS_INIT_SIG_MODEL(pmodel, id, eh, cb, num_op, op) \
123 (pmodel)->model_id.type = MS_ACCESS_MODEL_TYPE_SIG; \
124 (pmodel)->model_id.id = (id); \
125 (pmodel)->elem_handle = (eh); \
126 (pmodel)->cb = (cb); \
127 (pmodel)->num_opcodes = (num_op); \
128 (pmodel)->opcodes = (op)
129
131 #define MS_ACCESS_INIT_VENDOR_MODEL(pmodel, id, eh, cb, num_op, op) \
132 (pmodel)->model_id.type = MS_ACCESS_MODEL_TYPE_VENDOR; \
133 (pmodel)->model_id.id = (id); \
134 (pmodel)->elem_handle = (eh); \
135 (pmodel)->cb = (cb); \
136 (pmodel)->num_opcodes = (num_op); \
137 (pmodel)->opcodes = (op)
138
141 /* --------------------------------------------- Data Types/ Structures */
142
144 typedef UINT16 MS_ACCESS_MODEL_HANDLE;
145
146
168 typedef API_RESULT (* MS_ACCESS_MODEL_CB)
169 (
170 MS_ACCESS_MODEL_HANDLE * handle,
171 MS_NET_ADDR saddr,
172 MS_NET_ADDR daddr,
173 MS_SUBNET_HANDLE subnet_handle,
174 MS_APPKEY_HANDLE appkey_handle,
175 UINT32 opcode,
176 UCHAR * data_param,
177 UINT16 data_len
178 ) DECL_REENTRANT;
187 typedef UINT16 MS_ACCESS_MODEL_ID_SIG;
188
190 typedef UINT32 MS_ACCESS_MODEL_ID_VENDOR;
191
193 typedef UINT8 MS_ACCESS_NODE_ID;
194
196 typedef UINT8 MS_ACCESS_ELEMENT_HANDLE;
197
199 typedef UINT32 MS_ACCESS_ADDRESS_HANDLE;
200
202 typedef UINT32 MS_ACCESS_DEV_KEY_HANDLE;
203
205 typedef struct _MS_ACCESS_MODEL_ID
206 {
208 UINT32 id;
209
214 UCHAR type;
215
216 } MS_ACCESS_MODEL_ID;
217
223 typedef struct _MS_ACCESS_MODEL
224 {
226 MS_ACCESS_MODEL_ID model_id;
227
229 MS_ACCESS_ELEMENT_HANDLE elem_handle;
230
235 MS_ACCESS_MODEL_CB cb;
236
238 UINT16 num_opcodes;
239
241 UINT32 * opcodes;
242
243 } MS_ACCESS_MODEL;
244
245
249 typedef struct _MS_ACCESS_ELEMENT_DESC
250 {
252 UINT16 loc;
253
254 } MS_ACCESS_ELEMENT_DESC;
255
259 typedef struct _MS_ACCESS_ADDRESS
260 {
262 UINT8 use_label;
263
265 MS_NET_ADDR addr;
266
268 UINT8 label[MS_LABEL_UUID_LENGTH];
269
270 } MS_ACCESS_ADDRESS;
271
275 typedef struct _MS_ACCESS_PUBLISH_INFO
276 {
278 MS_ACCESS_ADDRESS addr;
279
284 UINT16 appkey_index;
285
287 UINT8 crden_flag;
288
290 UINT8 ttl;
291
293 UINT8 period;
294
296 UINT8 rtx_count;
297
299 UINT8 rtx_interval_steps;
300
302 UINT8 remote;
303
304 } MS_ACCESS_PUBLISH_INFO;
305
310 typedef struct _MS_ACCESS_MODEL_REQ_MSG_CONTEXT
311 {
313 MS_ACCESS_MODEL_HANDLE handle;
314
316 MS_NET_ADDR saddr;
317
319 MS_NET_ADDR daddr;
320
322 MS_SUBNET_HANDLE subnet_handle;
323
325 MS_APPKEY_HANDLE appkey_handle;
326
327 } MS_ACCESS_MODEL_REQ_MSG_CONTEXT;
328
330 typedef struct _MS_ACCESS_MODEL_REQ_MSG_RAW
331 {
333 UINT32 opcode;
334
336 UCHAR * data_param;
337
339 UINT16 data_len;
340
341 } MS_ACCESS_MODEL_REQ_MSG_RAW;
342
344 typedef struct _MS_ACCESS_MODEL_REQ_MSG_T
345 {
347 UINT8 type;
348
350 UINT8 to_be_acked;
351
352 } MS_ACCESS_MODEL_REQ_MSG_T;
353
355 typedef struct _MS_ACCESS_MODEL_STATE_PARAMS
356 {
358 UCHAR state_type;
359
361 void * state;
362
363 }MS_ACCESS_MODEL_STATE_PARAMS;
364
366 typedef struct _MS_ACCESS_MODEL_EXT_PARAMS
367 {
369 UCHAR ext_type;
370
372 void * ext;
373
374 }MS_ACCESS_MODEL_EXT_PARAMS;
375
380 typedef struct _MS_PROV_DEV_ENTRY
381 {
383 MS_NET_ADDR uaddr;
384
386 UCHAR num_elements;
387
388 } MS_PROV_DEV_ENTRY;
389
393 /* --------------------------------------------- Function */
394
401 #ifdef __cplusplus
402 extern "C" {
403 #endif
404
417 API_RESULT MS_access_create_node (/* OUT */ MS_ACCESS_NODE_ID * node_id);
418
436 API_RESULT MS_access_register_element
437 (
438 /* IN */ MS_ACCESS_NODE_ID node_id,
439 /* IN */ MS_ACCESS_ELEMENT_DESC * element,
440 /* OUT */ MS_ACCESS_ELEMENT_HANDLE * element_handle
441 );
442
462 API_RESULT MS_access_register_model
463 (
464 /* IN */ MS_ACCESS_NODE_ID node_id,
465 /* IN */ MS_ACCESS_MODEL * model,
466 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle
467 );
468
480 API_RESULT MS_access_get_element_handle
481 (
482 /* IN */ MS_NET_ADDR elem_addr,
483 /* OUT */ MS_ACCESS_ELEMENT_HANDLE * handle
484 );
485
499 API_RESULT MS_access_get_model_handle
500 (
501 /* IN */ MS_ACCESS_ELEMENT_HANDLE elem_handle,
502 /* IN */ MS_ACCESS_MODEL_ID model_id,
503 /* OUT */ MS_ACCESS_MODEL_HANDLE * handle
504 );
505
529 API_RESULT MS_access_publish
530 (
531 /* IN */ MS_ACCESS_MODEL_HANDLE * handle,
532 /* IN */ UINT32 opcode,
533 /* IN */ UCHAR * data_param,
534 /* IN */ UINT16 data_len,
535 /* IN */ UINT8 reliable
536 );
537
556 API_RESULT MS_access_reply
557 (
558 /* IN */ MS_ACCESS_MODEL_HANDLE * handle,
559 /* IN */ MS_NET_ADDR saddr,
560 /* IN */ MS_NET_ADDR daddr,
561 /* IN */ MS_SUBNET_HANDLE subnet_handle,
562 /* IN */ MS_APPKEY_HANDLE appkey_handle,
563 /* IN */ UINT8 ttl,
564 /* IN */ UINT32 opcode,
565 /* IN */ UCHAR * data_param,
566 /* IN */ UINT16 data_length
567 );
568
586 API_RESULT MS_access_send_pdu
587 (
588 /* IN */ MS_NET_ADDR saddr,
589 /* IN */ MS_NET_ADDR daddr,
590 /* IN */ MS_SUBNET_HANDLE subnet_handle,
591 /* IN */ MS_APPKEY_HANDLE appkey_handle,
592 /* IN */ UINT8 ttl,
593 /* IN */ UINT32 opcode,
594 /* IN */ UCHAR * data_param,
595 /* IN */ UINT16 data_length
596 );
597
599 API_RESULT MS_access_get_composition_data(/* OUT */ MS_BUFFER * buffer);
600
601 /* Configuration Manager related interfaces */
602
611 API_RESULT MS_access_cm_reset(void);
612
623 API_RESULT MS_access_cm_get_element_count
624 (
625 /* OUT */ UINT8 * count
626 );
627
638 API_RESULT MS_access_cm_set_primary_unicast_address
639 (
640 /* IN */ MS_NET_ADDR addr
641 );
642
653 API_RESULT MS_access_cm_get_primary_unicast_address
654 (
655 /* OUT */ MS_NET_ADDR * addr
656 );
657
668 API_RESULT MS_access_cm_set_default_ttl
669 (
670 /* IN */ UINT8 ttl
671 );
672
683 API_RESULT MS_access_cm_get_default_ttl
684 (
685 /* IN */ UINT8 * ttl
686 );
687
699 API_RESULT MS_access_cm_set_iv_index
700 (
701 /* IN */ UINT32 iv_index,
702 /* IN */ UINT8 iv_update_flag
703 );
704
716 API_RESULT MS_access_cm_get_iv_index
717 (
718 /* OUT */ UINT32 * iv_index,
719 /* OUT */ UINT8 * iv_update_flag
720 );
721
735 API_RESULT MS_access_cm_get_iv_index_by_ivi
736 (
737 /* IN */ UINT8 ivi,
738 /* OUT */ UINT32 * iv_index
739 );
740
752 API_RESULT MS_access_cm_set_features_field
753 (
754 /* IN */ UINT8 enable,
755 /* IN */ UINT8 feature
756 );
757
769 API_RESULT MS_access_cm_get_features_field
770 (
771 /* OUT */ UINT8 * enable,
772 /* IN */ UINT8 feature
773 );
774
785 API_RESULT MS_access_cm_get_features
786 (
787 /* OUT */ UINT8 * features
788 );
789
791 #define MS_ENABLE_RELAY_FEATURE() \
792 MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_RELAY)
793
795 #define MS_DISABLE_RELAY_FEATURE() \
796 MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_RELAY)
797
799 #define MS_ENABLE_PROXY_FEATURE() \
800 MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_PROXY)
801
803 #define MS_DISABLE_PROXY_FEATURE() \
804 MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_PROXY)
805
807 #define MS_ENABLE_FRIEND_FEATURE() \
808 MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_FRIEND)
809
811 #define MS_DISABLE_FRIEND_FEATURE() \
812 MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_FRIEND)
813
815 #define MS_ENABLE_LPN_FEATURE() \
816 MS_access_cm_set_features_field(MS_ENABLE, MS_FEATURE_LPN)
817
819 #define MS_DISABLE_LPN_FEATURE() \
820 MS_access_cm_set_features_field(MS_DISABLE, MS_FEATURE_LPN)
821
832 API_RESULT MS_access_cm_get_friendship_role
833 (
834 /* OUT */ UINT8 * frnd_role
835 );
836
837
848 API_RESULT MS_access_cm_set_friendship_role
849 (
850 /* IN */ UINT8 frnd_role
851 );
852
853
867 API_RESULT MS_access_cm_add_device_key
868 (
869 /* IN */ UINT8 * dev_key,
870 /* IN */ MS_NET_ADDR uaddr,
871 /* IN */ UINT8 num_elements
872 );
873
885 API_RESULT MS_access_cm_get_device_key
886 (
887 /* IN */ UINT8 dev_key_index,
888 /* OUT */ UINT8 ** dev_key
889 );
890
899 API_RESULT MS_access_cm_remove_all_device_keys(void);
900
914 API_RESULT MS_access_cm_get_prov_devices_list
915 (
916 /* IN */ MS_PROV_DEV_ENTRY * prov_dev_list,
917 /* INOUT */ UINT16 * num_entries
918 );
919
932 API_RESULT MS_access_cm_get_device_key_handle
933 (
934 /* IN */ MS_NET_ADDR prim_elem_uaddr,
935 /* OUT */ MS_ACCESS_DEV_KEY_HANDLE * handle
936 );
937
950 API_RESULT MS_access_cm_get_app_key
951 (
952 /* IN */ MS_APPKEY_HANDLE appkey_handle,
953 /* OUT */ UINT8 ** app_key,
954 /* OUT */ UINT8 * aid
955 );
956
969 API_RESULT MS_access_cm_add_update_netkey
970 (
971 /* IN */ UINT16 netkey_index,
972 /* IN */ UINT32 opcode,
973 /* IN */ UINT8 * net_key
974 );
975
991 API_RESULT MS_access_cm_add_friend_sec_credential
992 (
993 /* IN */ MS_SUBNET_HANDLE subnet_handle,
994 /* IN */ UINT16 friend_offset,
995 /* IN */ MS_NET_ADDR lpn_addr,
996 /* IN */ MS_NET_ADDR friend_addr,
997 /* IN */ UINT16 lpn_counter,
998 /* IN */ UINT16 friend_counter
999 );
1000
1012 API_RESULT MS_access_cm_delete_friend_sec_credential
1013 (
1014 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1015 /* IN */ UINT16 friend_index
1016 );
1017
1029 API_RESULT MS_access_cm_find_subnet
1030 (
1031 /* IN */ UINT16 netkey_index,
1032 /* OUT */ MS_SUBNET_HANDLE * subnet_handle
1033 );
1034
1045 API_RESULT MS_access_cm_delete_netkey
1046 (
1047 /* IN */ MS_SUBNET_HANDLE subnet_handle
1048 );
1049
1061 API_RESULT MS_access_cm_get_netkey
1062 (
1063 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1064 /* OUT */ UINT8 * net_key
1065 );
1066
1085 API_RESULT MS_access_cm_get_netkey_index_list
1086 (
1087 /* INOUT */ UINT16 * netkey_count,
1088 /* OUT */ UINT16 * netkey_index_list
1089 );
1090
1113 API_RESULT MS_access_cm_lookup_nid
1114 (
1115 /* IN */ UINT8 nid,
1116 /* INOUT */ MS_SUBNET_HANDLE * subnet_handle,
1117 /* OUT */ UINT8 * privacy_key,
1118 /* OUT */ UINT8 * encrypt_key
1119 );
1120
1121
1145 API_RESULT MS_access_cm_lookup_network_id
1146 (
1147 /* IN */ UINT8 * network_id,
1148 /* INOUT */ MS_SUBNET_HANDLE * subnet_handle,
1149 /* OUT */ UINT8 * beacon_key,
1150 /* OUT */ UINT8 * is_new_key
1151 );
1152
1174 API_RESULT MS_access_cm_lookup_aid
1175 (
1176 /* IN */ UINT8 aid,
1177 /* INOUT */ MS_APPKEY_HANDLE * appkey_handle,
1178 /* OUT */ UINT8 * app_key
1179 );
1180
1192 API_RESULT MS_access_cm_set_prov_data
1193 (
1194 /* IN */ PROV_DATA_S * prov_data
1195 );
1196
1208 API_RESULT MS_access_cm_get_subnet_nid
1209 (
1210 /* IN */ MS_SUBNET_HANDLE handle,
1211 /* OUT */ UINT8 * nid
1212 );
1213
1225 API_RESULT MS_access_cm_get_subnet_privacy_key
1226 (
1227 /* IN */ MS_SUBNET_HANDLE handle,
1228 /* OUT */ UINT8 * privacy_key
1229 );
1230
1242 API_RESULT MS_access_cm_get_subnet_network_id
1243 (
1244 /* IN */ MS_SUBNET_HANDLE handle,
1245 /* OUT */ UINT8 * network_id
1246 );
1247
1248
1260 API_RESULT MS_access_cm_get_subnet_beacon_key
1261 (
1262 /* IN */ MS_SUBNET_HANDLE handle,
1263 /* OUT */ UINT8 * beacon_key
1264 );
1265
1277 API_RESULT MS_access_cm_get_subnet_identity_key
1278 (
1279 /* IN */ MS_SUBNET_HANDLE handle,
1280 /* OUT */ UINT8 * identity_key
1281 );
1282
1294 API_RESULT MS_access_cm_get_subnet_encryption_key
1295 (
1296 /* IN */ MS_SUBNET_HANDLE handle,
1297 /* OUT */ UINT8 * encrypt_key
1298 );
1299
1311 API_RESULT MS_access_cm_get_node_identity
1312 (
1313 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1314 /* OUT */ UINT8 * id_state
1315 );
1316
1328 API_RESULT MS_access_cm_set_node_identity
1329 (
1330 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1331 /* INOUT */ UINT8 * id_state
1332 );
1333
1334
1346 API_RESULT MS_access_cm_get_key_refresh_phase
1347 (
1348 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1349 /* OUT */ UINT8 * key_refresh_state
1350 );
1351
1363 API_RESULT MS_access_cm_set_key_refresh_phase
1364 (
1365 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1366 /* IN */ UINT8 * key_refresh_state
1367 );
1368
1380 API_RESULT MS_access_cm_set_transmit_state
1381 (
1382 /* IN */ UINT8 tx_state_type,
1383 /* IN */ UINT8 tx_state
1384 );
1385
1398 API_RESULT MS_access_cm_get_transmit_state
1399 (
1400 /* IN */ UINT8 tx_state_type,
1401 /* OUT */ UINT8 * tx_state
1402 );
1403
1416 API_RESULT MS_access_cm_add_appkey
1417 (
1418 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1419 /* IN */ UINT16 appkey_index,
1420 /* IN */ UINT8 * app_key
1421 );
1422
1436 API_RESULT MS_access_cm_update_delete_appkey
1437 (
1438 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1439 /* IN */ UINT16 appkey_index,
1440 /* IN */ UINT32 opcode,
1441 /* IN */ UINT8 * app_key
1442 );
1443
1457 API_RESULT MS_access_cm_get_appkey_handle
1458 (
1459 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1460 /* IN */ UINT16 appkey_index,
1461 /* IN */ UINT8 * app_key,
1462 /* OUT */ MS_APPKEY_HANDLE * appkey_handle
1463 );
1464
1484 API_RESULT MS_access_cm_get_appkey_index_list
1485 (
1486 /* IN */ MS_SUBNET_HANDLE subnet_handle,
1487 /* INOUT */ UINT16 * appkey_count,
1488 /* OUT */ UINT16 * appkey_index_list
1489 );
1490
1502 API_RESULT MS_access_bind_model_app
1503 (
1504 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1505 /* IN */ UINT16 appkey_index
1506 );
1507
1519 API_RESULT MS_access_unbind_model_app
1520 (
1521 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1522 /* IN */ UINT16 appkey_index
1523 );
1524
1544 API_RESULT MS_access_cm_get_model_app_list
1545 (
1546 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1547 /* INOUT */ UINT16 * appkey_count,
1548 /* OUT */ UINT16 * appkey_index_list
1549 );
1550
1564 API_RESULT MS_access_cm_set_model_publication
1565 (
1566 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1567 /* INOUT */ MS_ACCESS_PUBLISH_INFO * publish_info
1568 );
1569
1581 API_RESULT MS_access_cm_get_model_publication
1582 (
1583 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1584 /* OUT */ MS_ACCESS_PUBLISH_INFO * publish_info
1585 );
1586
1598 API_RESULT MS_access_cm_add_model_subscription
1599 (
1600 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1601 /* IN */ MS_ACCESS_ADDRESS * sub_addr
1602 );
1603
1615 API_RESULT MS_access_cm_delete_model_subscription
1616 (
1617 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1618 /* IN */ MS_ACCESS_ADDRESS * sub_addr
1619 );
1620
1631 API_RESULT MS_access_cm_delete_all_model_subscription
1632 (
1633 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle
1634 );
1635
1653 API_RESULT MS_access_cm_get_model_subscription_list
1654 (
1655 /* IN */ MS_ACCESS_MODEL_HANDLE model_handle,
1656 /* INOUT */ UINT16 * sub_addr_count,
1657 /* OUT */ UINT16 * sub_addr_list
1658 );
1659
1676 API_RESULT MS_access_cm_get_all_model_subscription_list
1677 (
1678 /* INOUT */ UINT16 * sub_addr_count,
1679 /* OUT */ UINT16 * sub_addr_list
1680 );
1681
1693 API_RESULT MS_access_is_valid_element_address
1694 (
1695 /* IN */ MS_NET_ADDR addr
1696 );
1697
1709 API_RESULT MS_access_is_fixed_group_addr_to_be_processed
1710 (
1711 /* IN */ MS_NET_ADDR addr
1712 );
1713
1725 API_RESULT MS_access_is_valid_subscription_address
1726 (
1727 /* IN */ MS_NET_ADDR addr
1728 );
1729
1730 #ifdef __cplusplus
1731 };
1732 #endif
1733
1738 #endif /* _H_MS_ACCESS_API_ */
1739


EtherMind Mesh SDK (beta): mesh/export/include/MS_assigned_numbers.h Source File

  • mesh
  • export
  • include
MS_assigned_numbers.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_ASSIGNED_NUMBERS_
15 #define _H_MS_ASSIGNED_NUMBERS_
16
17 /* --------------------------------- Header File Inclusion */
18
19 /* --------------------------------- Global Definitions */
22 #define MESH_PROVISIONING_SERVICE 0x1827
23
24 #define MESH_PROXY_SERVICE 0x1828
25
27 #define MESH_CH_PROVISIONING_DATA_IN 0x2ADB
28 #define MESH_CH_PROVISIONING_DATA_OUT 0x2ADC
29 #define MESH_CH_PROXY_DATA_IN 0x2ADD
30 #define MESH_CH_PROXY_DATA_OUT 0x2ADE
31
33 #define MESH_AD_TYPE_PB_ADV 0x29
34 #define MESH_AD_TYPE_PKT 0x2A
35 #define MESH_AD_TYPE_BCON 0x2B
36
38 #define MESH_GATT_TYPE_NETWORK 0x00
39 #define MESH_GATT_TYPE_BEACON 0x01
40 #define MESH_GATT_TYPE_PROXY 0x02
41 #define MESH_GATT_TYPE_PROV 0x03
42
44 #define MESH_GATT_SAR_COMPLETE 0x00
45 #define MESH_GATT_SAR_START 0x01
46 #define MESH_GATT_SAR_CONTINUE 0x02
47 #define MESH_GATT_SAR_END 0x03
48
50 #define MESH_MODEL_CONFIG 0x7FB0
51 #define MESH_MODEL_NET_MGMT 0x7FB1
52 #define MESH_MODEL_PROVISIONING 0x7FB2
53 #define MESH_MODEL_PING 0x7FB3
54
56 #define MS_MODEL_ID_CONFIG_SERVER 0x0000
57 #define MS_MODEL_ID_CONFIG_CLIENT 0x0001
58 #define MS_MODEL_ID_HEALTH_SERVER 0x0002
59 #define MS_MODEL_ID_HEALTH_CLIENT 0x0003
60
61 #define MS_MODEL_ID_GENERIC_ONOFF_SERVER 0x1000
62 #define MS_MODEL_ID_GENERIC_ONOFF_CLIENT 0x1001
63
65 #define MS_ACCESS_MODEL_TYPE_SIG 0x00
66 #define MS_ACCESS_MODEL_TYPE_VENDOR 0x01
67
69 #define MS_NONCE_T_NETWORK 0x00
70 #define MS_NONCE_T_APPLICATION 0x01
71 #define MS_NONCE_T_DEVICE 0x02
72 #define MS_NONCE_T_PROXY 0x03
73
77 #define MS_ACCESS_CONFIG_APPKEY_ADD_OPCODE 0x00
78 #define MS_ACCESS_CONFIG_APPKEY_UPDATE_OPCODE 0x01
79 #define MS_ACCESS_CONFIG_COMPOSITION_DATA_STATUS_OPCODE 0x02
80 #define MS_ACCESS_CONFIG_MODEL_PUBLICATION_SET_OPCODE 0x03
81 #define MS_ACCESS_HEALTH_CURRENT_STATUS_OPCODE 0x04
82 #define MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE 0x05
83 #define MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_STATUS_OPCODE 0x06
84
87 #define MS_ACCESS_CONFIG_APPKEY_DELETE_OPCODE 0x8000
88
89 #define MS_ACCESS_CONFIG_APPKEY_GET_OPCODE 0x8001
90
91 #define MS_ACCESS_CONFIG_APPKEY_LIST_OPCODE 0x8002
92
93 #define MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE 0x8003
94
95 #define MS_ACCESS_HEALTH_ATTENTION_GET_OPCODE 0x8004
96
97 #define MS_ACCESS_HEALTH_ATTENTION_SET_OPCODE 0x8005
98
99 #define MS_ACCESS_HEALTH_ATTENTION_SET_UNACKNOWLEDGED_OPCODE 0x8006
100
101 #define MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE 0x8007
102
103 #define MS_ACCESS_CONFIG_COMPOSITION_DATA_GET_OPCODE 0x8008
104
105 #define MS_ACCESS_CONFIG_BEACON_GET_OPCODE 0x8009
106
107 #define MS_ACCESS_CONFIG_BEACON_SET_OPCODE 0x800A
108
109 #define MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE 0x800B
110
111 #define MS_ACCESS_CONFIG_DEFAULT_TTL_GET_OPCODE 0x800C
112
113 #define MS_ACCESS_CONFIG_DEFAULT_TTL_SET_OPCODE 0x800D
114
115 #define MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE 0x800E
116
117 #define MS_ACCESS_CONFIG_FRIEND_GET_OPCODE 0x800F
118
119 #define MS_ACCESS_CONFIG_FRIEND_SET_OPCODE 0x8010
120
121 #define MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE 0x8011
122
123 #define MS_ACCESS_CONFIG_GATT_PROXY_GET_OPCODE 0x8012
124
125 #define MS_ACCESS_CONFIG_GATT_PROXY_SET_OPCODE 0x8013
126
127 #define MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE 0x8014
128
129 #define MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_GET_OPCODE 0x8015
130
131 #define MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_SET_OPCODE 0x8016
132
133 #define MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE 0x8017
134
135 #define MS_ACCESS_CONFIG_MODEL_PUBLICATION_GET_OPCODE 0x8018
136
137 #define MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE 0x8019
138
139 #define MS_ACCESS_CONFIG_MODEL_PUBLICATION_VIRTUAL_ADDRESS_SET_OPCODE 0x801A
140
141 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_ADD_OPCODE 0x801B
142
143 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_OPCODE 0x801C
144
145 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_ALL_OPCODE 0x801D
146
147 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_OVERWRITE_OPCODE 0x801E
148
149 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE 0x801F
150
151 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_ADD_OPCODE 0x8020
152
153 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_DELETE_OPCODE 0x8021
154
155 #define MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_OVERWRITE_OPCODE 0x8022
156
157 #define MS_ACCESS_CONFIG_NETWORK_TRANSMIT_GET_OPCODE 0x8023
158
159 #define MS_ACCESS_CONFIG_NETWORK_TRANSMIT_SET_OPCODE 0x8024
160
161 #define MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE 0x8025
162
163 #define MS_ACCESS_CONFIG_RELAY_GET_OPCODE 0x8026
164
165 #define MS_ACCESS_CONFIG_RELAY_SET_OPCODE 0x8027
166
167 #define MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE 0x8028
168
169 #define MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_GET_OPCODE 0x8029
170
171 #define MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_LIST_OPCODE 0x802A
172
173 #define MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_GET_OPCODE 0x802B
174
175 #define MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_LIST_OPCODE 0x802C
176
177 #define MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_GET_OPCODE 0x802D
178
179 #define MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_STATUS_OPCODE 0x802E
180
181 #define MS_ACCESS_HEALTH_FAULT_CLEAR_OPCODE 0x802F
182
183 #define MS_ACCESS_HEALTH_FAULT_CLEAR_UNACKNOWLEDGED_OPCODE 0x8030
184
185 #define MS_ACCESS_HEALTH_FAULT_GET_OPCODE 0x8031
186
187 #define MS_ACCESS_HEALTH_FAULT_TEST_OPCODE 0x8032
188
189 #define MS_ACCESS_HEALTH_FAULT_TEST_UNACKNOWLEDGED_OPCODE 0x8033
190
191 #define MS_ACCESS_HEALTH_PERIOD_GET_OPCODE 0x8034
192
193 #define MS_ACCESS_HEALTH_PERIOD_SET_OPCODE 0x8035
194
195 #define MS_ACCESS_HEALTH_PERIOD_SET_UNACKNOWLEDGED_OPCODE 0x8036
196
197 #define MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE 0x8037
198
199 #define MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_GET_OPCODE 0x8038
200
201 #define MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_SET_OPCODE 0x8039
202
203 #define MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_GET_OPCODE 0x803A
204
205 #define MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_SET_OPCODE 0x803B
206
207 #define MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE 0x803C
208
209 #define MS_ACCESS_CONFIG_MODEL_APP_BIND_OPCODE 0x803D
210
211 #define MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE 0x803E
212
213 #define MS_ACCESS_CONFIG_MODEL_APP_UNBIND_OPCODE 0x803F
214
215 #define MS_ACCESS_CONFIG_NETKEY_ADD_OPCODE 0x8040
216
217 #define MS_ACCESS_CONFIG_NETKEY_DELETE_OPCODE 0x8041
218
219 #define MS_ACCESS_CONFIG_NETKEY_GET_OPCODE 0x8042
220
221 #define MS_ACCESS_CONFIG_NETKEY_LIST_OPCODE 0x8043
222
223 #define MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE 0x8044
224
225 #define MS_ACCESS_CONFIG_NETKEY_UPDATE_OPCODE 0x8045
226
227 #define MS_ACCESS_CONFIG_NODE_IDENTITY_GET_OPCODE 0x8046
228
229 #define MS_ACCESS_CONFIG_NODE_IDENTITY_SET_OPCODE 0x8047
230
231 #define MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE 0x8048
232
233 #define MS_ACCESS_CONFIG_NODE_RESET_OPCODE 0x8049
234
235 #define MS_ACCESS_CONFIG_NODE_RESET_STATUS_OPCODE 0x804A
236
237 #define MS_ACCESS_CONFIG_SIG_MODEL_APP_GET_OPCODE 0x804B
238
239 #define MS_ACCESS_CONFIG_SIG_MODEL_APP_LIST_OPCODE 0x804C
240
241 #define MS_ACCESS_CONFIG_VENDOR_MODEL_APP_GET_OPCODE 0x804D
242
243 #define MS_ACCESS_CONFIG_VENDOR_MODEL_APP_LIST_OPCODE 0x804E
244
247 #define MS_ACCESS_GENERIC_ONOFF_GET_OPCODE 0x8201
248
249 #define MS_ACCESS_GENERIC_ONOFF_SET_OPCODE 0x8202
250
251 #define MS_ACCESS_GENERIC_ONOFF_SET_UNACKNOWLEDGED_OPCODE 0x8203
252
253 #define MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE 0x8204
254
257 #define MS_ACCESS_GENERIC_LEVEL_GET_OPCODE 0x8205
258
259 #define MS_ACCESS_GENERIC_LEVEL_SET_OPCODE 0x8206
260
261 #define MS_ACCESS_GENERIC_LEVEL_SET_UNACKNOWLEDGED_OPCODE 0x8207
262
263 #define MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE 0x8208
264
265 #define MS_ACCESS_GENERIC_DELTA_SET_OPCODE 0x8209
266
267 #define MS_ACCESS_GENERIC_DELTA_SET_UNACKNOWLEDGED_OPCODE 0x820A
268
269 #define MS_ACCESS_GENERIC_MOVE_SET_OPCODE 0x820B
270
271 #define MS_ACCESS_GENERIC_MOVE_SET_UNACKNOWLEDGED_OPCODE 0x820C
272
275 #define MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_GET_OPCODE 0x820D
276
277 #define MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_OPCODE 0x820E
278
279 #define MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_UNACKNOWLEDGED_OPCODE 0x820F
280
281 #define MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE 0x8210
282
285 #define MS_ACCESS_GENERIC_ONPOWERUP_GET_OPCODE 0x8211
286
287 #define MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE 0x8212
288
291 #define MS_ACCESS_GENERIC_ONPOWERUP_SET_OPCODE 0x8213
292
293 #define MS_ACCESS_GENERIC_ONPOWERUP_SET_UNACKNOWLEDGED_OPCODE 0x8214
294
297 #define MS_ACCESS_GENERIC_POWER_LEVEL_GET_OPCODE 0x8215
298
299 #define MS_ACCESS_GENERIC_POWER_LEVEL_SET_OPCODE 0x8216
300
301 #define MS_ACCESS_GENERIC_POWER_LEVEL_SET_UNACKNOWLEDGED_OPCODE 0x8217
302
303 #define MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE 0x8218
304
305 #define MS_ACCESS_GENERIC_POWER_LAST_GET_OPCODE 0x8219
306
307 #define MS_ACCESS_GENERIC_POWER_LAST_STATUS_OPCODE 0x821A
308
309 #define MS_ACCESS_GENERIC_POWER_DEFAULT_GET_OPCODE 0x821B
310
311 #define MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE 0x821C
312
313 #define MS_ACCESS_GENERIC_POWER_RANGE_GET_OPCODE 0x821D
314
315 #define MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE 0x821E
316
319 #define MS_ACCESS_GENERIC_POWER_DEFAULT_SET_OPCODE 0x821F
320
321 #define MS_ACCESS_GENERIC_POWER_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x8220
322
323 #define MS_ACCESS_GENERIC_POWER_RANGE_SET_OPCODE 0x8221
324
325 #define MS_ACCESS_GENERIC_POWER_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x8222
326
329 #define MS_ACCESS_GENERIC_BATTERY_GET_OPCODE 0x8223
330
331 #define MS_ACCESS_GENERIC_BATTERY_STATUS_OPCODE 0x8224
332
335 #define MS_ACCESS_GENERIC_LOCATION_GLOBAL_GET_OPCODE 0x8225
336
337 #define MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE 0x40
338
339 #define MS_ACCESS_GENERIC_LOCATION_LOCAL_GET_OPCODE 0x8226
340
341 #define MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE 0x8227
342
345 #define MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_OPCODE 0x41
346
347 #define MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_UNACKNOWLEDGED_OPCODE 0x42
348
349 #define MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_OPCODE 0x8228
350
351 #define MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_UNACKNOWLEDGED_OPCODE 0x8229
352
355 #define MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_GET_OPCODE 0x822A
356
357 #define MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_OPCODE 0x43
358
359 #define MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_GET_OPCODE 0x822B
360
361 #define MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_OPCODE 0x44
362
363 #define MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x45
364
365 #define MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE 0x46
366
369 #define MS_ACCESS_GENERIC_ADMIN_PROPERTIES_GET_OPCODE 0x822C
370
371 #define MS_ACCESS_GENERIC_ADMIN_PROPERTIES_STATUS_OPCODE 0x47
372
373 #define MS_ACCESS_GENERIC_ADMIN_PROPERTY_GET_OPCODE 0x822D
374
375 #define MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_OPCODE 0x48
376
377 #define MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x49
378
379 #define MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE 0x4A
380
383 #define MS_ACCESS_GENERIC_USER_PROPERTIES_GET_OPCODE 0x822E
384
385 #define MS_ACCESS_GENERIC_USER_PROPERTIES_STATUS_OPCODE 0x4B
386
387 #define MS_ACCESS_GENERIC_USER_PROPERTY_GET_OPCODE 0x822F
388
389 #define MS_ACCESS_GENERIC_USER_PROPERTY_SET_OPCODE 0x4C
390
391 #define MS_ACCESS_GENERIC_USER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x4D
392
393 #define MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE 0x4E
394
397 #define MS_ACCESS_GENERIC_CLIENT_PROPERTIES_GET_OPCODE 0x4F
398
399 #define MS_ACCESS_GENERIC_CLIENT_PROPERTIES_STATUS_OPCODE 0x50
400
403 #define MS_ACCESS_SENSOR_DESCRIPTOR_GET_OPCODE 0x8230
404
405 #define MS_ACCESS_SENSOR_DESCRIPTOR_STATUS_OPCODE 0x51
406
407 #define MS_ACCESS_SENSOR_GET_OPCODE 0x8231
408
409 #define MS_ACCESS_SENSOR_STATUS_OPCODE 0x52
410
411 #define MS_ACCESS_SENSOR_COLUMN_GET_OPCODE 0x8232
412
413 #define MS_ACCESS_SENSOR_COLUMN_STATUS_OPCODE 0x53
414
415 #define MS_ACCESS_SENSOR_SERIES_GET_OPCODE 0x8233
416
417 #define MS_ACCESS_SENSOR_SERIES_STATUS_OPCODE 0x54
418
421 #define MS_ACCESS_SENSOR_CADENCE_GET_OPCODE 0x8234
422
423 #define MS_ACCESS_SENSOR_CADENCE_SET_OPCODE 0x55
424
425 #define MS_ACCESS_SENSOR_CADENCE_SET_UNACKNOWLEDGED_OPCODE 0x56
426
427 #define MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE 0x57
428
429 #define MS_ACCESS_SENSOR_SETTINGS_GET_OPCODE 0x8235
430
431 #define MS_ACCESS_SENSOR_SETTINGS_STATUS_OPCODE 0x58
432
433 #define MS_ACCESS_SENSOR_SETTING_GET_OPCODE 0x8236
434
435 #define MS_ACCESS_SENSOR_SETTING_SET_OPCODE 0x59
436
437 #define MS_ACCESS_SENSOR_SETTING_SET_UNACKNOWLEDGED_OPCODE 0x5A
438
439 #define MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE 0x5B
440
443 #define MS_ACCESS_TIME_GET_OPCODE 0x8237
444
445 #define MS_ACCESS_TIME_SET_OPCODE 0x5C
446
447 #define MS_ACCESS_TIME_STATUS_OPCODE 0x5D
448
449 #define MS_ACCESS_TIME_ROLE_GET_OPCODE 0x8238
450
451 #define MS_ACCESS_TIME_ROLE_SET_OPCODE 0x8239
452
453 #define MS_ACCESS_TIME_ROLE_STATUS_OPCODE 0x823A
454
455 #define MS_ACCESS_TIME_ZONE_GET_OPCODE 0x823B
456
457 #define MS_ACCESS_TIME_ZONE_SET_OPCODE 0x823C
458
459 #define MS_ACCESS_TIME_ZONE_STATUS_OPCODE 0x823D
460
461 #define MS_ACCESS_TAI_UTC_DELTA_GET_OPCODE 0x823E
462
463 #define MS_ACCESS_TAI_UTC_DELTA_SET_OPCODE 0x823F
464
465 #define MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE 0x8240
466
469 #define MS_ACCESS_SCENE_GET_OPCODE 0x8241
470
471 #define MS_ACCESS_SCENE_RECALL_OPCODE 0x8242
472
473 #define MS_ACCESS_SCENE_RECALL_UNACKNOWLEDGED_OPCODE 0x8243
474
475 #define MS_ACCESS_SCENE_STATUS_OPCODE 0x5E
476
477 #define MS_ACCESS_SCENE_REGISTER_GET_OPCODE 0x8244
478
479 #define MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE 0x8245
480
483 #define MS_ACCESS_SCENE_STORE_OPCODE 0x8246
484
485 #define MS_ACCESS_SCENE_STORE_UNACKNOWLEDGED_OPCODE 0x8247
486
487 #define MS_ACCESS_SCENE_DELETE_OPCODE 0x829E
488
489 #define MS_ACCESS_SCENE_DELETE_UNACKNOWLEDGED_OPCODE 0x829F
490
493 #define MS_ACCESS_SCHEDULER_ACTION_GET_OPCODE 0x8248
494
495 #define MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE 0x5F
496
497 #define MS_ACCESS_SCHEDULER_GET_OPCODE 0x8249
498
499 #define MS_ACCESS_SCHEDULER_STATUS_OPCODE 0x824A
500
503 #define MS_ACCESS_SCHEDULER_ACTION_SET_OPCODE 0x60
504
505 #define MS_ACCESS_SCHEDULER_ACTION_SET_UNACKNOWLEDGED_OPCODE 0x61
506
509 #define MS_ACCESS_LIGHT_LIGHTNESS_GET_OPCODE 0x824B
510
511 #define MS_ACCESS_LIGHT_LIGHTNESS_SET_OPCODE 0x824C
512
513 #define MS_ACCESS_LIGHT_LIGHTNESS_SET_UNACKNOWLEDGED_OPCODE 0x824D
514
515 #define MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE 0x824E
516
517 #define MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_GET_OPCODE 0x824F
518
519 #define MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_OPCODE 0x8250
520
521 #define MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_UNACKNOWLEDGED_OPCODE 0x8251
522
523 #define MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE 0x8252
524
525 #define MS_ACCESS_LIGHT_LIGHTNESS_LAST_GET_OPCODE 0x8253
526
527 #define MS_ACCESS_LIGHT_LIGHTNESS_LAST_STATUS_OPCODE 0x8254
528
529 #define MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_GET_OPCODE 0x8255
530
531 #define MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE 0x8256
532
533 #define MS_ACCESS_LIGHT_LIGHTNESS_RANGE_GET_OPCODE 0x8257
534
535 #define MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE 0x8258
536
539 #define MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_OPCODE 0x8259
540
541 #define MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x825A
542
543 #define MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_OPCODE 0x825B
544
545 #define MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x825C
546
549 #define MS_ACCESS_LIGHT_CTL_GET_OPCODE 0x825D
550
551 #define MS_ACCESS_LIGHT_CTL_SET_OPCODE 0x825E
552
553 #define MS_ACCESS_LIGHT_CTL_SET_UNACKNOWLEDGED_OPCODE 0x825F
554
555 #define MS_ACCESS_LIGHT_CTL_STATUS_OPCODE 0x8260
556
557 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_GET_OPCODE 0x8261
558
559 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_GET_OPCODE 0x8262
560
561 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE 0x8263
562
563 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_OPCODE 0x8264
564
565 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_UNACKNOWLEDGED_OPCODE 0x8265
566
567 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE 0x8266
568
569 #define MS_ACCESS_LIGHT_CTL_DEFAULT_GET_OPCODE 0x8267
570
571 #define MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE 0x8268
572
575 #define MS_ACCESS_LIGHT_CTL_DEFAULT_SET_OPCODE 0x8269
576
577 #define MS_ACCESS_LIGHT_CTL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x826A
578
579 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_OPCODE 0x826B
580
581 #define MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x826C
582
585 #define MS_ACCESS_LIGHT_HSL_GET_OPCODE 0x826D
586
587 #define MS_ACCESS_LIGHT_HSL_HUE_GET_OPCODE 0x826E
588
589 #define MS_ACCESS_LIGHT_HSL_HUE_SET_OPCODE 0x826F
590
591 #define MS_ACCESS_LIGHT_HSL_HUE_SET_UNACKNOWLEDGED_OPCODE 0x8270
592
593 #define MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE 0x8271
594
595 #define MS_ACCESS_LIGHT_HSL_SATURATION_GET_OPCODE 0x8272
596
597 #define MS_ACCESS_LIGHT_HSL_SATURATION_SET_OPCODE 0x8273
598
599 #define MS_ACCESS_LIGHT_HSL_SATURATION_SET_UNACKNOWLEDGED_OPCODE 0x8274
600
601 #define MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE 0x8275
602
603 #define MS_ACCESS_LIGHT_HSL_SET_OPCODE 0x8276
604
605 #define MS_ACCESS_LIGHT_HSL_SET_UNACKNOWLEDGED_OPCODE 0x8277
606
607 #define MS_ACCESS_LIGHT_HSL_STATUS_OPCODE 0x8278
608
609 #define MS_ACCESS_LIGHT_HSL_TARGET_GET_OPCODE 0x8279
610
611 #define MS_ACCESS_LIGHT_HSL_TARGET_STATUS_OPCODE 0x827A
612
613 #define MS_ACCESS_LIGHT_HSL_DEFAULT_GET_OPCODE 0x827B
614
615 #define MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE 0x827C
616
617 #define MS_ACCESS_LIGHT_HSL_RANGE_GET_OPCODE 0x827D
618
619 #define MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE 0x827E
620
623 #define MS_ACCESS_LIGHT_HSL_DEFAULT_SET_OPCODE 0x827F
624
625 #define MS_ACCESS_LIGHT_HSL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x8280
626
627 #define MS_ACCESS_LIGHT_HSL_RANGE_SET_OPCODE 0x8281
628
629 #define MS_ACCESS_LIGHT_HSL_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x8282
630
633 #define MS_ACCESS_LIGHT_XYL_GET_OPCODE 0x8283
634
635 #define MS_ACCESS_LIGHT_XYL_SET_OPCODE 0x8284
636
637 #define MS_ACCESS_LIGHT_XYL_SET_UNACKNOWLEDGED_OPCODE 0x8285
638
639 #define MS_ACCESS_LIGHT_XYL_STATUS_OPCODE 0x8286
640
641 #define MS_ACCESS_LIGHT_XYL_TARGET_GET_OPCODE 0x8287
642
643 #define MS_ACCESS_LIGHT_XYL_TARGET_STATUS_OPCODE 0x8288
644
645 #define MS_ACCESS_LIGHT_XYL_DEFAULT_GET_OPCODE 0x8289
646
647 #define MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE 0x828A
648
649 #define MS_ACCESS_LIGHT_XYL_RANGE_GET_OPCODE 0x828B
650
651 #define MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE 0x828C
652
655 #define MS_ACCESS_LIGHT_XYL_DEFAULT_SET_OPCODE 0x828D
656
657 #define MS_ACCESS_LIGHT_XYL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE 0x828E
658
659 #define MS_ACCESS_LIGHT_XYL_RANGE_SET_OPCODE 0x828F
660
661 #define MS_ACCESS_LIGHT_XYL_RANGE_SET_UNACKNOWLEDGED_OPCODE 0x8290
662
665 #define MS_ACCESS_LIGHT_LC_MODE_GET_OPCODE 0x8291
666
667 #define MS_ACCESS_LIGHT_LC_MODE_SET_OPCODE 0x8292
668
669 #define MS_ACCESS_LIGHT_LC_MODE_SET_UNACKNOWLEDGED_OPCODE 0x8293
670
671 #define MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE 0x8294
672
673 #define MS_ACCESS_LIGHT_LC_OM_GET_OPCODE 0x8295
674
675 #define MS_ACCESS_LIGHT_LC_OM_SET_OPCODE 0x8296
676
677 #define MS_ACCESS_LIGHT_LC_OM_SET_UNACKNOWLEDGED_OPCODE 0x8297
678
679 #define MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE 0x8298
680
681 #define MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_GET_OPCODE 0x8299
682
683 #define MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_OPCODE 0x829A
684
685 #define MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_UNACKNOWLEDGED_OPCODE 0x829B
686
687 #define MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE 0x829C
688
689 #define MS_ACCESS_LIGHT_LC_PROPERTY_GET_OPCODE 0x829D
690
691 #define MS_ACCESS_LIGHT_LC_PROPERTY_SET_OPCODE 0x62
692
693 #define MS_ACCESS_LIGHT_LC_PROPERTY_SET_UNACKNOWLEDGED_OPCODE 0x63
694
695 #define MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE 0x64
696
698 #define MS_ACCESS_INVALID_OPCODE 0xFFFFFFFF
699
700
704 #define MS_MODEL_ID_CONFIG_SERVER 0x0000
705
706 #define MS_MODEL_ID_CONFIG_CLIENT 0x0001
707
708 #define MS_MODEL_ID_HEALTH_SERVER 0x0002
709
710 #define MS_MODEL_ID_HEALTH_CLIENT 0x0003
711
714 #define MS_MODEL_ID_GENERIC_ONOFF_SERVER 0x1000
715
716 #define MS_MODEL_ID_GENERIC_ONOFF_CLIENT 0x1001
717
718 #define MS_MODEL_ID_GENERIC_LEVEL_SERVER 0x1002
719
720 #define MS_MODEL_ID_GENERIC_LEVEL_CLIENT 0x1003
721
722 #define MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_SERVER 0x1004
723
724 #define MS_MODEL_ID_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT 0x1005
725
726 #define MS_MODEL_ID_GENERIC_POWER_ONOFF_SERVER 0x1006
727
728 #define MS_MODEL_ID_GENERIC_POWER_ONOFF_SETUP_SERVER 0x1007
729
730 #define MS_MODEL_ID_GENERIC_POWER_ONOFF_CLIENT 0x1008
731
732 #define MS_MODEL_ID_GENERIC_POWER_LEVEL_SERVER 0x1009
733
734 #define MS_MODEL_ID_GENERIC_POWER_LEVEL_SETUP_SERVER 0x100A
735
736 #define MS_MODEL_ID_GENERIC_POWER_LEVEL_CLIENT 0x100B
737
738 #define MS_MODEL_ID_GENERIC_BATTERY_SERVER 0x100C
739
740 #define MS_MODEL_ID_GENERIC_BATTERY_CLIENT 0x100D
741
742 #define MS_MODEL_ID_GENERIC_LOCATION_SERVER 0x100E
743
744 #define MS_MODEL_ID_GENERIC_LOCATION_SETUP_SERVER 0x100F
745
746 #define MS_MODEL_ID_GENERIC_LOCATION_CLIENT 0x1010
747
748 #define MS_MODEL_ID_GENERIC_ADMIN_PROPERTY_SERVER 0x1011
749
750 #define MS_MODEL_ID_GENERIC_MANUFACTURER_PROPERTY_SERVER 0x1012
751
752 #define MS_MODEL_ID_GENERIC_USER_PROPERTY_SERVER 0x1013
753
754 #define MS_MODEL_ID_GENERIC_CLIENT_PROPERTY_SERVER 0x1014
755
756 #define MS_MODEL_ID_GENERIC_PROPERTY_CLIENT 0x1015
757
760 #define MS_MODEL_ID_SENSOR_SERVER 0x1100
761
762 #define MS_MODEL_ID_SENSOR_SETUP_SERVER 0x1101
763
764 #define MS_MODEL_ID_SENSOR_CLIENT 0x1102
765
768 #define MS_MODEL_ID_TIME_SERVER 0x1200
769
770 #define MS_MODEL_ID_TIME_SETUP_SERVER 0x1201
771
772 #define MS_MODEL_ID_TIME_CLIENT 0x1202
773
774 #define MS_MODEL_ID_SCENE_SERVER 0x1203
775
776 #define MS_MODEL_ID_SCENE_SETUP_SERVER 0x1204
777
778 #define MS_MODEL_ID_SCENE_CLIENT 0x1205
779
780 #define MS_MODEL_ID_SCHEDULER_SERVER 0x1206
781
782 #define MS_MODEL_ID_SCHEDULER_SETUP_SERVER 0x1207
783
784 #define MS_MODEL_ID_SCHEDULER_CLIENT 0x1208
785
788 #define MS_MODEL_ID_LIGHT_LIGHTNESS_SERVER 0x1300
789
790 #define MS_MODEL_ID_LIGHT_LIGHTNESS_SETUP_SERVER 0x1301
791
792 #define MS_MODEL_ID_LIGHT_LIGHTNESS_CLIENT 0x1302
793
794 #define MS_MODEL_ID_LIGHT_CTL_SERVER 0x1303
795
796 #define MS_MODEL_ID_LIGHT_CTL_SETUP_SERVER 0x1304
797
798 #define MS_MODEL_ID_LIGHT_CTL_CLIENT 0x1305
799
800 #define MS_MODEL_ID_LIGHT_CTL_TEMPERATURE_SERVER 0x1306
801
802 #define MS_MODEL_ID_LIGHT_HSL_SERVER 0x1307
803
804 #define MS_MODEL_ID_LIGHT_HSL_SETUP_SERVER 0x1308
805
806 #define MS_MODEL_ID_LIGHT_HSL_CLIENT 0x1309
807
808 #define MS_MODEL_ID_LIGHT_HSL_HUE_SERVER 0x130A
809
810 #define MS_MODEL_ID_LIGHT_HSL_SATURATION_SERVER 0x130B
811
812 #define MS_MODEL_ID_LIGHT_XYL_SERVER 0x130C
813
814 #define MS_MODEL_ID_LIGHT_XYL_SETUP_SERVER 0x130D
815
816 #define MS_MODEL_ID_LIGHT_XYL_CLIENT 0x130E
817
818 #define MS_MODEL_ID_LIGHT_LC_SERVER 0x130F
819
820 #define MS_MODEL_ID_LIGHT_LC_SETUP_SERVER 0x1310
821
822 #define MS_MODEL_ID_LIGHT_LC_CLIENT 0x1311
823
824 #endif /* _H_MS_ASSIGNED_NUMBERS_ */
825


EtherMind Mesh SDK (beta): mesh/export/include/MS_brr_api.h Source File

  • mesh
  • export
  • include
MS_brr_api.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_BRR_API_
15 #define _H_MS_BRR_API_
16
17
18 /* --------------------------------------------- Header File Inclusion */
19 #include "MS_common.h"
20
21 /* --------------------------------------------- Global Definitions */
22
44 #define BRR_HANDLE_INVALID 0xFF
45
47 #define BRR_IFACE_DOWN 0x00
48 #define BRR_IFACE_UP 0x01
49 #define BRR_IFACE_DATA 0x02
50 #define BRR_IFACE_PROXY_DATA 0x03
51
53 #define BRR_BCON_PASSIVE 0x00
54 #define BRR_BCON_ACTIVE 0x01
55
57 #define BRR_BROADCAST 0x00
58 #define BRR_OBSERVE 0x01
59
61 #define BRR_DISABLE 0x00
62 #define BRR_ENABLE 0x01
63
65 #define BRR_MAX_PDU_SIZE 65
66
68 #define BRR_CLIENT_ROLE 0x00
69 #define BRR_SERVER_ROLE 0x01
70 #define BRR_INVALID_ROLE 0xFF
71
92 /* --------------------------------------------- Data Types/ Structures */
93
99 typedef UCHAR BRR_HANDLE;
100
102 typedef enum _BRR_TYPE
103 {
105 BRR_TYPE_BCON,
106
108 BRR_TYPE_ADV,
109
111 BRR_TYPE_PB_ADV,
112
114 BRR_TYPE_GATT,
115
117 BRR_TYPE_PB_GATT,
118
120 BRR_COUNT
121
122 } BRR_TYPE;
123
124 /* GATT Bearer Message Type Masks */
125 #define BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET 6
126 #define BRR_SUBTYPE_GATT_T_MASK (0xC0)
127 #define BRR_SUBTYPE_GATT_NETWORK_T_MASK ((MESH_GATT_TYPE_NETWORK << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
128 #define BRR_SUBTYPE_GATT_BEACON_T_MASK ((MESH_GATT_TYPE_BEACON << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
129 #define BRR_SUBTYPE_GATT_PROXY_T_MASK ((MESH_GATT_TYPE_PROXY << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
130 #define BRR_SUBTYPE_GATT_PROV_T_MASK ((MESH_GATT_TYPE_PROV << BRR_SUBTYPE_GATT_T_MASK_BIT_OFFSET) & (BRR_SUBTYPE_GATT_T_MASK))
131
133 typedef enum _BRR_BCON_TYPE
134 {
135 /* Unprovisioned Device Beacon */
136 BRR_BCON_TYPE_UNPROV_DEVICE,
137
138 /* Dummy placeholder */
139 BRR_BCON_DUMMY,
140
141 /* Secure Network Beacon */
142 BRR_BCON_TYPE_SECURE_NET,
143
144 /* Proxy beacon with Network ID */
145 BRR_BCON_TYPE_PROXY_NETID,
146
147 /* Proxy beacon with Node Identity */
148 BRR_BCON_TYPE_PROXY_NODEID,
149
151 BRR_BCON_COUNT
152
153 } BRR_BCON_TTYPE;
154
161 typedef struct _BRR_BEARER_INFO
162 {
164 MS_BUFFER * binfo;
165
167 API_RESULT (*bearer_send)(BRR_HANDLE *, UCHAR, void *, UINT16);
168
170 void (*bearer_recv)(BRR_HANDLE *, UCHAR *, UINT16, MS_BUFFER * info);
171
173 void (*bearer_sleep)(BRR_HANDLE *);
174
176 void (*bearer_wakeup)(BRR_HANDLE *);
177
178 } BRR_BEARER_INFO;
179
181 typedef struct _BRR_BEACON_INFO
182 {
193 UCHAR action;
194
205 UCHAR type;
206
208 UCHAR * bcon_data;
209
211 UINT16 bcon_datalen;
212
214 MS_BUFFER * uri;
215
216 } BRR_BEACON_INFO;
217
219 typedef struct _BRR_BEARER_CH_INFO
220 {
222 UINT16 mtu;
223
225 UCHAR role;
226
227 }BRR_BEARER_CH_INFO;
228
248 typedef API_RESULT (*BRR_NTF_CB)
249 (
250 BRR_HANDLE * brr_handle,
251 UCHAR brr_event,
252 UCHAR * data_param,
253 UINT16 data_len
254 ) DECL_REENTRANT;
255
265 typedef void (*BRR_BCON_CB)
266 (
267 UCHAR * data_param,
268 UINT16 data_len
269 ) DECL_REENTRANT;
287 /* --------------------------------------------- Function */
288
294 #ifdef __cplusplus
295 extern "C" {
296 #endif
297
314 API_RESULT MS_brr_register
315 (
316 /* IN */ BRR_TYPE brr_type,
317 /* IN */ BRR_NTF_CB brr_cb
318 );
319
336 API_RESULT MS_brr_register_beacon_handler
337 (
338 /* IN */ UCHAR bcon_type,
339 /* IN */ void (*bcon_handler) (UCHAR * data, UINT16 datalen)
340 );
341
362 API_RESULT MS_brr_add_bearer
363 (
364 /* IN */ BRR_TYPE brr_type,
365 /* IN */ BRR_BEARER_INFO * brr_info,
366 /* OUT */ BRR_HANDLE * brr_handle
367 );
368
385 API_RESULT MS_brr_remove_bearer
386 (
387 /* IN */ BRR_TYPE brr_type,
388 /* IN */ BRR_HANDLE * brr_handle
389 );
390
407 API_RESULT MS_brr_observe_beacon
408 (
409 /* IN */ UCHAR bcon_type,
410 /* IN */ UCHAR enable
411 );
412
413
436 API_RESULT MS_brr_bcast_unprovisioned_beacon
437 (
438 /* IN */ UCHAR type,
439 /* IN */ UCHAR * dev_uuid,
440 /* IN */ UINT16 oob_info,
441 /* IN */ MS_BUFFER * uri
442 );
443
444
462 API_RESULT MS_brr_broadcast_beacon
463 (
464 /* IN */ UCHAR type,
465 /* IN */ UCHAR * packet,
466 /* IN */ UINT16 length
467 );
468
494 API_RESULT MS_brr_start_proxy_adv
495 (
496 /* IN */ UCHAR type,
497 /* IN */ UCHAR * data,
498 /* IN */ UINT16 datalen
499 );
500
515 API_RESULT MS_brr_bcast_end
516 (
517 /* IN */ UCHAR bcon,
518 /* IN */ UCHAR type
519 );
520
521
541 API_RESULT MS_brr_send_pdu
542 (
543 /* IN */ BRR_HANDLE * brr_handle,
544 /* IN */ BRR_TYPE brr_type,
545 /* IN */ MS_BUFFER * buffer
546 );
547
560 UCHAR MS_brr_get_packet_rssi(void);
561
572 API_RESULT MS_brr_sleep(void);
573
584 API_RESULT MS_brr_wakeup(void);
585
586 #ifdef __cplusplus
587 };
588 #endif
589
594 #endif /* _H_MS_BRR_API_ */
595


EtherMind Mesh SDK (beta): mesh/export/include/MS_common.h Source File

  • mesh
  • export
  • include
MS_common.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_COMMON_
15 #define _H_MS_COMMON_
16
22 /* -------------------------------------------- Header File Inclusion */
23 /* The EtherMind OS Abstraction */
24 #include "EM_os.h"
25
26 /* The EtherMind Configuration Parameters */
27 #include "MS_features.h"
28
29 /* The EtherMind Tunable Constant */
30 #include "MS_limits.h"
31
32 /* The Bluetooth Assigned Numbers */
33 #include "MS_assigned_numbers.h"
34
35 /* The EtherMind Error Codes */
36 #include "MS_error.h"
37
38 /* The EtherMind Debug Library */
39 #include "EM_debug.h"
40
41 /* For EM_assert() macro */
42 #include "EM_assert.h"
43
44 /* For Status Flag APIs */
45 /* #include "MS_status.h" */
46
47 /* The EtherMind Timer Library */
48 #include "EM_timer.h"
49
50 /* EtherMind Platform Specific Initialization & Shutdown Handlers */
51 #include "MS_common_pl.h"
52
53 /* For Memory (leak, corruption) Testing */
54 #ifdef MEMWATCH
55 #include "memwatch.h"
56 #endif /* MEMWATCH */
57
58 /* TODO: See what should be the order of inclusion */
59 #include "MS_model_states.h"
60
61 /* -------------------------------------------- Global Definitions */
62
68 /* COMMON Debug Macros */
69 #ifndef COMMON_NO_DEBUG
70 #define COMMON_ERR(...) EM_debug_error(MS_MODULE_ID_COMMON, __VA_ARGS__)
71 #else /* COMMON_NO_DEBUG */
72 #define COMMON_ERR EM_debug_null
73 #endif /* COMMON_NO_DEBUG */
74
75 #ifdef COMMON_DEBUG
76
77 #define COMMON_TRC(...) EM_debug_trace(MS_MODULE_ID_COMMON, __VA_ARGS__)
78 #define COMMON_INF(...) EM_debug_info(MS_MODULE_ID_COMMON, __VA_ARGS__)
79
80 #else /* COMMON_DEBUG */
81
82 #define COMMON_TRC EM_debug_null
83 #define COMMON_INF EM_debug_null
84
85 #endif /* COMMON_DEBUG */
86
99 #define MS_STACK_INIT_UNDEFINED 0x00
100 #define MS_STACK_INIT_ETHERMIND_INIT 0x01
101
102 /* Definition for True/False */
103 #ifndef MS_FALSE
104 #define MS_FALSE 0
105 #endif /* MS_FALSE */
106
107 #ifndef MS_TRUE
108 #define MS_TRUE 1
109 #endif /* MS_TRUE */
110
115 /* -------------------------------------------- Macros */
116
144 /* Little Endian Packing Macros */
145 #define MS_PACK_LE_1_BYTE(dst, src) \
146 { \
147 UCHAR val; \
148 val = (UCHAR)(*(src)); \
149 MS_PACK_LE_1_BYTE_VAL((dst), val); \
150 }
151
152 #define MS_PACK_LE_1_BYTE_VAL(dst, src) \
153 *((UCHAR *)(dst) + 0) = src;
154
155 #define MS_PACK_LE_2_BYTE(dst, src) \
156 { \
157 UINT16 val; \
158 val = (UINT16)(*(src)); \
159 MS_PACK_LE_2_BYTE_VAL((dst), val); \
160 }
161
162 #define MS_PACK_LE_2_BYTE_VAL(dst, src) \
163 *((UCHAR *)(dst) + 0) = (UCHAR)(src); \
164 *((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);
165
166 #define MS_PACK_LE_3_BYTE(dst, src) \
167 { \
168 UINT32 val; \
169 val = (UINT32)(*(src)); \
170 MS_PACK_LE_3_BYTE_VAL((dst), val); \
171 }
172
173 #define MS_PACK_LE_3_BYTE_VAL(dst, src) \
174 *((UCHAR *)(dst) + 0) = (UCHAR)(src);\
175 *((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);\
176 *((UCHAR *)(dst) + 2) = (UCHAR)(src >> 16);
177
178 #define MS_PACK_LE_4_BYTE(dst, src) \
179 { \
180 UINT32 val; \
181 val = (UINT32)(*(src)); \
182 MS_PACK_LE_4_BYTE_VAL((dst), val); \
183 }
184
185 #define MS_PACK_LE_4_BYTE_VAL(dst, src) \
186 *((UCHAR *)(dst) + 0) = (UCHAR)(src);\
187 *((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);\
188 *((UCHAR *)(dst) + 2) = (UCHAR)(src >> 16);\
189 *((UCHAR *)(dst) + 3) = (UCHAR)(src >> 24);
190
191 /* TBD: Update based on 64 Bit, 128 Bit Data Types */
192 #define MS_PACK_LE_8_BYTE(dst,val)\
193 EM_mem_copy ((dst), (val), 8)
194
195 #define MS_PACK_LE_16_BYTE(dst,val)\
196 EM_mem_copy ((dst), (val), 16)
197
198 #define MS_PACK_LE_N_BYTE(dst,val,n)\
199 EM_mem_copy ((dst), (val), (n))
200
201 /* Big Endian Packing Macros */
202 #define MS_PACK_BE_1_BYTE(dst, src) \
203 { \
204 UCHAR val; \
205 val = (UCHAR)(*((UCHAR *)(src))); \
206 MS_PACK_BE_1_BYTE_VAL((dst), val); \
207 }
208
209 #define MS_PACK_BE_1_BYTE_VAL(dst, src) \
210 *((UCHAR *)(dst) + 0) = src;
211
212 #define MS_PACK_BE_2_BYTE(dst, src) \
213 { \
214 UINT16 val; \
215 val = (UINT16)(*((UINT16 *)(src))); \
216 MS_PACK_BE_2_BYTE_VAL((dst), val); \
217 }
218
219 #define MS_PACK_BE_2_BYTE_VAL(dst, src) \
220 *((UCHAR *)(dst) + 1) = (UCHAR)(src); \
221 *((UCHAR *)(dst) + 0) = (UCHAR)(src >> 8);
222
223 #define MS_PACK_BE_3_BYTE(dst, src) \
224 { \
225 UINT32 val; \
226 val = (UINT32)(*((UINT32 *)(src))); \
227 MS_PACK_BE_3_BYTE_VAL((dst), val); \
228 }
229
230 #define MS_PACK_BE_3_BYTE_VAL(dst, src) \
231 *((UCHAR *)(dst) + 2) = (UCHAR)(src);\
232 *((UCHAR *)(dst) + 1) = (UCHAR)(src >> 8);\
233 *((UCHAR *)(dst) + 0) = (UCHAR)(src >> 16);
234
235 #define MS_PACK_BE_4_BYTE(dst, src) \
236 { \
237 UINT32 val; \
238 val = (UINT32)(*((UINT32 *)(src))); \
239 MS_PACK_BE_4_BYTE_VAL((dst), val); \
240 }
241
242 #define MS_PACK_BE_4_BYTE_VAL(dst, src) \
243 *((UCHAR *)(dst) + 3) = (UCHAR)(src);\
244 *((UCHAR *)(dst) + 2) = (UCHAR)(src >> 8);\
245 *((UCHAR *)(dst) + 1) = (UCHAR)(src >> 16);\
246 *((UCHAR *)(dst) + 0) = (UCHAR)(src >> 24);
247
248 /* TBD: Update based on 64 Bit, 128 Bit Data Types */
249 #define MS_PACK_BE_8_BYTE(dst,val)\
250 EM_mem_copy ((dst), (val), 8)
251
252 #define MS_PACK_BE_16_BYTE(dst,val)\
253 EM_mem_copy ((dst), (val), 16)
254
255 #define MS_PACK_BE_N_BYTE(dst,val,n)\
256 EM_mem_copy ((dst), (val), (n))
257
258
272 /* Little Endian Unpacking Macros */
273 #define MS_UNPACK_LE_1_BYTE(dst,src)\
274 *((UCHAR *)(dst)) = (UCHAR)(*((UCHAR *)(src)));
275
276 #define MS_UNPACK_LE_2_BYTE(dst,src)\
277 *((UINT16 *)(dst)) = *((src) + 1); \
278 *((UINT16 *)(dst)) = *((UINT16 *)(dst)) << 8; \
279 *((UINT16 *)(dst)) |= *((src) + 0);
280
281 #define MS_UNPACK_LE_3_BYTE(dst,src)\
282 *((UINT32 *)(dst)) = *((src) + 2);\
283 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
284 *((UINT32 *)(dst)) |= *((src) + 1);\
285 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
286 *((UINT32 *)(dst)) |= *((src) + 0);
287
288 #define MS_UNPACK_LE_4_BYTE(dst,src)\
289 *((UINT32 *)(dst)) = *((src) + 3);\
290 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
291 *((UINT32 *)(dst)) |= *((src) + 2);\
292 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
293 *((UINT32 *)(dst)) |= *((src) + 1);\
294 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
295 *((UINT32 *)(dst)) |= *((src) + 0);
296
297 /* TBD: Update based on 64 Bit, 128 Bit Data Types */
298 #define MS_UNPACK_LE_8_BYTE(dst,src)\
299 EM_mem_copy ((dst), (src), 8)
300
301 #define MS_UNPACK_LE_16_BYTE(dst,src)\
302 EM_mem_copy ((dst), (src), 16)
303
304 #define MS_UNPACK_LE_N_BYTE(dst,src,n)\
305 EM_mem_copy ((dst), (src), (n))
306
307 /* Big Endian Unpacking Macros */
308 #define MS_UNPACK_BE_1_BYTE(dst,src)\
309 *((UCHAR *)(dst)) = (UCHAR)(*((UCHAR *)(src)));
310
311 #define MS_UNPACK_BE_2_BYTE(dst,src)\
312 *((UINT16 *)(dst)) = *((src) + 0); \
313 *((UINT16 *)(dst)) = *((UINT16 *)(dst)) << 8; \
314 *((UINT16 *)(dst)) |= *((src) + 1);
315
316 #define MS_UNPACK_BE_3_BYTE(dst,src)\
317 *((UINT32 *)(dst)) = *((src) + 0);\
318 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
319 *((UINT32 *)(dst)) |= *((src) + 1);\
320 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
321 *((UINT32 *)(dst)) |= *((src) + 2);
322
323 #define MS_UNPACK_BE_4_BYTE(dst,src)\
324 *((UINT32 *)(dst)) = *((src) + 0);\
325 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
326 *((UINT32 *)(dst)) |= *((src) + 1);\
327 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
328 *((UINT32 *)(dst)) |= *((src) + 2);\
329 *((UINT32 *)(dst)) = (*((UINT32 *)(dst))) << 8;\
330 *((UINT32 *)(dst)) |= *((src) + 3);
331
332 /* TBD: Update based on 64 Bit, 128 Bit Data Types */
333 #define MS_UNPACK_BE_8_BYTE(dst,src)\
334 EM_mem_copy ((dst), (src), 8)
335
336 #define MS_UNPACK_BE_16_BYTE(dst,src)\
337 EM_mem_copy ((dst), (src), 16)
338
339 #define MS_UNPACK_BE_N_BYTE(dst,src,n)\
340 EM_mem_copy ((dst), (src), (n))
341
342 #ifndef MS_DISABLE_MUTEX
343
344 /* Macro to define a Mutex Variable */
345 #define MS_DEFINE_MUTEX(mutex) EM_thread_mutex_type mutex;
346
347 /* Macro to define a Mutex Variable with a type qualifier */
348 #define MS_DEFINE_MUTEX_TYPE(type, mutex) type EM_thread_mutex_type mutex;
349
350 /* Macro to define a Conditional Variable */
351 #define MS_DEFINE_COND(cond) EM_thread_cond_type cond;
352
353 /* Macro to define a Conditional Variable with a type qualifier */
354 #define MS_DEFINE_COND_TYPE(type, cond) type EM_thread_cond_type cond;
355
356 /*
357 * Macro to Initialize Mutex.
358 * To be used in void function as it returns no error.
359 */
360 #define MS_MUTEX_INIT_VOID(mutex, MODULE) \
361 if (EM_thread_mutex_init(&(mutex), NULL) < 0) \
362 { \
363 EM_debug_error( \
364 MS_MODULE_ID_##MODULE, \
365 "FAILED to Initialize Mutex in " #MODULE ".\n"); \
366 return; \
367 }
368
369 /*
370 * Macro to Initialize Mutex.
371 * It returns an error if mutex initialization fails.
372 */
373 #define MS_MUTEX_INIT(mutex, MODULE) \
374 if (EM_thread_mutex_init(&(mutex), NULL) < 0) \
375 { \
376 EM_debug_error( \
377 MS_MODULE_ID_##MODULE, \
378 "FAILED to Initialize Mutex in " #MODULE ".\n"); \
379 return MODULE##_MUTEX_INIT_FAILED; \
380 }
381
382 /*
383 * Macro to Initialize Conditional Variable.
384 * To be used in void function as it returns no error.
385 */
386 #define MS_COND_INIT_VOID(cond, MODULE) \
387 if (EM_thread_cond_init(&(cond), NULL) < 0) \
388 { \
389 EM_debug_error( \
390 MS_MODULE_ID_##MODULE, \
391 "FAILED to Initialize Conditional Variable in " #MODULE ".\n"); \
392 return; \
393 }
394
395 /*
396 * Macro to Initialize Conditional Variable.
397 * It returns an error if conditional variable initialization fails.
398 */
399 #define MS_COND_INIT(cond, MODULE) \
400 if (EM_thread_cond_init(&(cond), NULL) < 0) \
401 { \
402 EM_debug_error( \
403 MS_MODULE_ID_##MODULE, \
404 "FAILED to Initialize Conditional Variable in " #MODULE ".\n"); \
405 return MODULE##_COND_INIT_FAILED; \
406 }
407
408 /*
409 * Locks the Module Specific Mutex which prevents any global variable being
410 * overwritten by any function. It returns an error if mutex lock fails.
411 */
412 #define MS_MUTEX_LOCK(mutex, MODULE) \
413 if (EM_thread_mutex_lock(&(mutex)) < 0) \
414 { \
415 EM_debug_error( \
416 MS_MODULE_ID_##MODULE, \
417 "FAILED to Lock Mutex in " #MODULE ".\n"); \
418 return MODULE##_MUTEX_LOCK_FAILED; \
419 }
420
421 /*
422 * Locks the Module Specific Mutex which prevents any global variable being
423 * overwritten by any function. To be used in void function as it
424 * returns no error.
425 */
426 #define MS_MUTEX_LOCK_VOID(mutex, MODULE) \
427 if (EM_thread_mutex_lock(&(mutex)) < 0) \
428 { \
429 EM_debug_error( \
430 MS_MODULE_ID_##MODULE, \
431 "FAILED to Lock Mutex in " #MODULE ".\n"); \
432 return; \
433 }
434
435 /*
436 * Locks the Module Specific Mutex which prevents any global variable being
437 * overwritten by any function.
438 * It returns the error 'value' if mutex lock failes.
439 */
440 #define MS_MUTEX_LOCK_RETURN_ON_FAILURE(mutex, MODULE, value) \
441 if (EM_thread_mutex_lock(&(mutex)) < 0) \
442 { \
443 EM_debug_error( \
444 MS_MODULE_ID_##MODULE, \
445 "FAILED to Lock Mutex in " #MODULE ".\n"); \
446 return (value); \
447 }
448
449 /*
450 * Locks the Module Specific Mutex which prevents any global variable being
451 * overwritten by any function. On failure, only an Error is logged.
452 * It can be used from both void and non-void functions.
453 */
454 #define MS_MUTEX_LOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE) \
455 if (EM_thread_mutex_lock(&(mutex)) < 0) \
456 { \
457 EM_debug_error( \
458 MS_MODULE_ID_##MODULE, \
459 "FAILED to Lock Mutex in " #MODULE ".\n"); \
460 }
461
462 /*
463 * Unlocks the Module Specific Mutex which realeses the global variables
464 * to be written into. It returns an error if mutex unlock fails.
465 */
466 #define MS_MUTEX_UNLOCK(mutex, MODULE) \
467 if (EM_thread_mutex_unlock(&(mutex)) < 0) \
468 { \
469 EM_debug_error( \
470 MS_MODULE_ID_##MODULE, \
471 "FAILED to Unlock Mutex in " #MODULE ".\n"); \
472 return MODULE##_MUTEX_UNLOCK_FAILED; \
473 }
474
475 /*
476 * Unlocks the Module Specific Mutex which realeses the global variables
477 * to be written into. To be used in void functions as it returns
478 * no error.
479 */
480 #define MS_MUTEX_UNLOCK_VOID(mutex, MODULE) \
481 if (EM_thread_mutex_unlock(&(mutex)) < 0) \
482 { \
483 EM_debug_error( \
484 MS_MODULE_ID_##MODULE, \
485 "FAILED to Unlock Mutex in " #MODULE ".\n"); \
486 return; \
487 }
488
489 /*
490 * Unlocks the Module Specific Mutex which realeses the global variables
491 * to be written into.
492 * It returns the error 'value' if mutex unlock failes.
493 */
494 #define MS_MUTEX_UNLOCK_RETURN_ON_FAILURE(mutex, MODULE, value) \
495 if (EM_thread_mutex_unlock(&(mutex)) < 0) \
496 { \
497 EM_debug_error( \
498 MS_MODULE_ID_##MODULE, \
499 "FAILED to Unlock Mutex in " #MODULE ".\n"); \
500 return (value); \
501 }
502
503 /*
504 * Unlocks the Module Specific Mutex which realeses the global variables
505 * to be written into. On failure, only Error is logged.
506 * It can be used from both void and non-void functions.
507 */
508 #define MS_MUTEX_UNLOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE) \
509 if (EM_thread_mutex_unlock(&(mutex)) < 0) \
510 { \
511 EM_debug_error( \
512 MS_MODULE_ID_##MODULE, \
513 "FAILED to Unlock Mutex in " #MODULE ".\n"); \
514 }
515
516 #else /* MS_DISABLE_MUTEX */
517
518 /* Macro to define a Mutex Variable */
519 #define MS_DEFINE_MUTEX(mutex)
520
521 /* Macro to define a Mutex Variable with a type qualifier */
522 #define MS_DEFINE_MUTEX_TYPE(type, mutex)
523
524 /* Macro to define a Conditional Variable */
525 #define MS_DEFINE_COND(cond)
526
527 /* Macro to define a Conditional Variable with a type qualifier */
528 #define MS_DEFINE_COND_TYPE(type, cond)
529
530 /*
531 * Macro to Initialize Mutex.
532 * To be used in void function as it returns no error.
533 */
534 #define MS_MUTEX_INIT_VOID(mutex, MODULE)
535
536 /*
537 * Macro to Initialize Mutex.
538 * It returns an error if mutex initialization fails.
539 */
540 #define MS_MUTEX_INIT(mutex, MODULE)
541
542 /*
543 * Macro to Initialize Conditional Variable.
544 * To be used in void function as it returns no error.
545 */
546 #define MS_COND_INIT_VOID(cond, MODULE)
547
548 /*
549 * Macro to Initialize Conditional Variable.
550 * It returns an error if conditional variable initialization fails.
551 */
552 #define MS_COND_INIT(cond, MODULE)
553
554 /*
555 * Locks the Module Specific Mutex which prevents any global variable being
556 * overwritten by any function. It returns an error if mutex lock fails.
557 */
558 #define MS_MUTEX_LOCK(mutex, MODULE)
559
560 /*
561 * Locks the Module Specific Mutex which prevents any global variable being
562 * overwritten by any function. To be used in void function as it
563 * returns no error.
564 */
565 #define MS_MUTEX_LOCK_VOID(mutex, MODULE)
566
567 /*
568 * Locks the Module Specific Mutex which prevents any global variable being
569 * overwritten by any function.
570 * It returns the error 'value' if mutex lock failes.
571 */
572 #define MS_MUTEX_LOCK_RETURN_ON_FAILURE(mutex, MODULE, value)
573
574 /*
575 * Locks the Module Specific Mutex which prevents any global variable being
576 * overwritten by any function. On failure, only an Error is logged.
577 * It can be used from both void and non-void functions.
578 */
579 #define MS_MUTEX_LOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE)
580
581 /*
582 * Unlocks the Module Specific Mutex which realeses the global variables
583 * to be written into. It returns an error if mutex unlock fails.
584 */
585 #define MS_MUTEX_UNLOCK(mutex, MODULE)
586
587 /*
588 * Unlocks the Module Specific Mutex which realeses the global variables
589 * to be written into. To be used in void functions as it returns
590 * no error.
591 */
592 #define MS_MUTEX_UNLOCK_VOID(mutex, MODULE)
593
594 /*
595 * Unlocks the Module Specific Mutex which realeses the global variables
596 * to be written into.
597 * It returns the error 'value' if mutex unlock failes.
598 */
599 #define MS_MUTEX_UNLOCK_RETURN_ON_FAILURE(mutex, MODULE, value)
600
601 /*
602 * Unlocks the Module Specific Mutex which realeses the global variables
603 * to be written into. On failure, only Error is logged.
604 * It can be used from both void and non-void functions.
605 */
606 #define MS_MUTEX_UNLOCK_DONOT_RETURN_ON_FAILURE(mutex, MODULE)
607
608 #endif /* MS_DISABLE_MUTEX */
609
610 /* Abstractions for bit-wise operation */
611 #define MS_EXTRACT_BITNUM(val, bitnum) (((val) >> (bitnum)) & 1)
612 #define MS_SET_BITNUM(val, bitnum) ((val) |= (1 << (bitnum)))
613 #define MS_CLR_BITNUM(val, bitnum) ((val) &= (~(1 << (bitnum))))
614
615 /* Macro to find Minimum and Maximum value */
616 #define MS_GET_MIN(a, b) \
617 (((a) > (b)) ? (b) : (a))
618
619 #define MS_GET_MAX(a, b) \
620 (((a) > (b)) ? (a) : (b))
621
622 /* Unreferenced variable macro to avoid compilation warnings */
623 #define MS_IGNORE_UNUSED_PARAM(v) (void)(v)
624
625 /* Loop for ever */
626 #define MS_LOOP_FOREVER() for(;;)
627
628 #ifdef MS_HAVE_DYNAMIC_CONFIG
629 #define MS_INIT_CONFIG(config) \
630 (config).config_MS_REPLAY_CACHE_SIZE = MS_REPLAY_CACHE_SIZE; \
631 (config).config_MS_DEFAULT_COMPANY_ID = MS_DEFAULT_COMPANY_ID; \
632 (config).config_MS_DEFAULT_PID = MS_DEFAULT_PID; \
633 (config).config_MS_DEFAULT_VID = MS_DEFAULT_VID
634 #else
635 #define MS_INIT_CONFIG(config)
636 #endif /* MS_HAVE_DYNAMIC_CONFIG */
637
638 #define MS_CONFIG_LIMITS(x) (x)
639
640 #define MS_DEFINE_GLOBAL_ARRAY(type, var, s) \
641 type var[(s)]
642
643 #define MS_DECLARE_GLOBAL_ARRAY(type, var, s) \
644 extern type var[(s)]
645
646 #define MS_INIT_GLOBAL_ARRAY(type, var, s, i) \
647 EM_mem_set(var, (i), ((s) * sizeof(type)))
648
649
650 #ifdef MS_HAVE_MODEL_OPCODE_EMPTY_HANDLERS
651 /* Macro to define an empty model Opcode Handler */
652 #define MODEL_OPCODE_HANDLER_EMPTY_DEF(x) \
653 static API_RESULT (x) \
654 ( \
655 MS_ACCESS_MODEL_HANDLE * handle, \
656 MS_NET_ADDR saddr, \
657 MS_NET_ADDR daddr, \
658 MS_SUBNET_HANDLE subnet_handle, \
659 MS_APPKEY_HANDLE appkey_handle, \
660 UINT32 opcode, \
661 UCHAR * data_param, \
662 UINT16 data_len \
663 ) \
664 { \
665 API_RESULT retval; \
666 \
667 MS_IGNORE_UNUSED_PARAM(handle); \
668 MS_IGNORE_UNUSED_PARAM(saddr); \
669 MS_IGNORE_UNUSED_PARAM(daddr); \
670 MS_IGNORE_UNUSED_PARAM(subnet_handle); \
671 MS_IGNORE_UNUSED_PARAM(appkey_handle); \
672 MS_IGNORE_UNUSED_PARAM(opcode); \
673 MS_IGNORE_UNUSED_PARAM(data_param); \
674 MS_IGNORE_UNUSED_PARAM(data_len); \
675 \
676 retval = API_SUCCESS; \
677 \
678 return retval; \
679 }
680
681 /* Callback Handler */
682 #define MODEL_OPCODE_HANDLER_CALL(handler) \
683 (handler) (handle, saddr, daddr, subnet_handle, appkey_handle, opcode, data_param, data_len)
684 #else
685 /* Macro to define an empty model Opcode Handler */
686 #define MODEL_OPCODE_HANDLER_EMPTY_DEF(x)
687
688 /* Callback Handler */
689 #define MODEL_OPCODE_HANDLER_CALL(handler)
690 #endif /* MS_HAVE_MODEL_OPCODE_EMPTY_HANDLERS */
691
692 #define MS_STREAM_REV_ENDIANNESS(s, d, n) \
693 { \
694 UCHAR i; \
695 for (i = 0; i < (n); i++) \
696 { \
697 (d)[(n - 1) - i] = (s)[i]; \
698 } \
699 }
700
708 /*
709 * Module Identifier definitions.
710 * Currently used for runtime debug enable/disable scenario.
711 * In future, this can be used for other purposes as well,
712 * hence these defines are placed under common header file.
713 */
714 /* Page 4 - Bluetooth Protocol Modules */
715 #define MS_MODULE_PAGE_4 0x40000000
716
717 /* Module - Bit Mask */
718 #define MS_MODULE_BIT_MASK_COMMON 0x00000001
719 #define MS_MODULE_BIT_MASK_BRR 0x00000002
720 #define MS_MODULE_BIT_MASK_NET 0x00000004
721 #define MS_MODULE_BIT_MASK_LTRN 0x00000008
722 #define MS_MODULE_BIT_MASK_TRN 0x00000010
723 #define MS_MODULE_BIT_MASK_ACCESS 0x00000020
724 #define MS_MODULE_BIT_MASK_APP 0x00000040
725 #define MS_MODULE_BIT_MASK_STBX 0x00000080
726 #define MS_MODULE_BIT_MASK_CONFIG 0x00000100
727 #define MS_MODULE_BIT_MASK_FSM 0x00000200
728 #define MS_MODULE_BIT_MASK_PROV 0x00000400
729 #define MS_MODULE_BIT_MASK_MESH_MODEL 0x00000800
730
731 /* Module ID */
732 #define MS_MODULE_ID_COMMON (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_COMMON)
733 #define MS_MODULE_ID_BRR (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_BRR)
734 #define MS_MODULE_ID_NET (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_NET)
735 #define MS_MODULE_ID_LTRN (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_LTRN)
736 #define MS_MODULE_ID_TRN (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_TRN)
737 #define MS_MODULE_ID_ACCESS (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_ACCESS)
738 #define MS_MODULE_ID_APP (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_APP)
739 #define MS_MODULE_ID_STBX (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_STBX)
740 #define MS_MODULE_ID_CONFIG (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_CONFIG)
741 #define MS_MODULE_ID_FSM (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_FSM)
742 #define MS_MODULE_ID_PROV (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_PROV)
743 #define MS_MODULE_ID_MESH_MODEL (MS_MODULE_PAGE_4 | MS_MODULE_BIT_MASK_MESH_MODEL)
744
746 #define MS_DEVICE_UUID_SIZE 16
747
749 #define MS_BCON_TYPE_SIZE 1
750
752 #define MS_BCON_OOB_IND_SIZE 2
753
755 #define MS_BCON_URI_HASH_SIZE 4
756
759 #define MS_BCON_TYPE_UNPRVSNG_DEV 0x00
760
761 /* Secure Network Beacon Type */
762 #define MS_BCON_TYPE_SECURE 0x01
763
765 /* Invalid */
766 #define MS_FRND_ROLE_INVALID 0x00
767
768 /* Friend */
769 #define MS_FRND_ROLE_FRIEND 0x01
770
771 /* LPN */
772 #define MS_FRND_ROLE_LPN 0x02
773
775 #define MS_FEATURE_RELAY 0x00
776
777 #define MS_FEATURE_PROXY 0x01
778
779 #define MS_FEATURE_FRIEND 0x02
780
781 #define MS_FEATURE_LPN 0x03
782
784 #define MS_FEATURE_SEC_NET_BEACON 0x04
785
787 #define MS_ENABLE 0x01
788
789 #define MS_DISABLE 0x00
790
795 #define MS_NOT_SUPPORTED 0x02
796
798 #define MS_NETWORK_TX_STATE 0x00
799
800 #define MS_RELAY_TX_STATE 0x01
801
803 #define MS_LABEL_UUID_LENGTH 16
804
807 /* -------------------------------------------- Structures/Data Types */
808
819 typedef struct _MS_BUFFER
820 {
821 /* Payload Pointer */
822 UCHAR * payload;
823
824 /* Payload Length */
825 UINT16 length;
826
827 } MS_BUFFER;
828
833 typedef struct _MS_CONFIG
834 {
836 UINT16 config_MS_REPLAY_CACHE_SIZE;
837
839 UINT16 config_MS_DEFAULT_COMPANY_ID;
840
842 UINT16 config_MS_DEFAULT_PID;
843
845 UINT16 config_MS_DEFAULT_VID;
846
847 } MS_CONFIG;
848
853 /* -------------------------------------------- Function/API Declarations */
854 #ifdef __cplusplus
855 extern "C"{
856 #endif
857
858 #ifdef MS_HAVE_DYNAMIC_CONFIG
859 /* Global Configuration for Mesh Stack */
860 extern MS_CONFIG ms_global_config;
861 #endif /* MS_HAVE_DYNAMIC_CONFIG */
862
893 void MS_init
894 (
895 /* IN */ void * blob
896 );
897
905 API_RESULT MS_shutdown
906 (
907 void
908 );
909
926 API_RESULT MS_common_start_transition_timer
927 (
928 /* IN */ MS_ACCESS_STATE_TRANSITION_TYPE * transition,
929 /* OUT */ UINT16 * transition_time_handle
930 );
931
944 API_RESULT MS_common_stop_transition_timer
945 (
946 /* IN */ UINT16 transition_time_handle
947 );
948
964 API_RESULT MS_common_get_transition_time_from_ms
965 (
966 /* IN */ UINT32 transition_time_in_ms,
967 /* OUT */ UINT8 * transition_time
968 );
969
974 /* Internal Function */
975 API_RESULT ms_common_init_transition_timer(void);
976
981 #ifdef __cplusplus
982 };
983 #endif
984
989 #endif /* _H_MS_COMMON_ */
990


EtherMind Mesh SDK (beta): mesh/export/include/MS_config_api.h Source File

  • mesh
  • export
  • include
MS_config_api.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_CONFIG_API_
15 #define _H_MS_CONFIG_API_
16
17
18 /* --------------------------------------------- Header File Inclusion */
19 /* Access Layer */
20 #include "MS_access_api.h"
21
22
23 /* --------------------------------------------- Global Definitions */
24
74 /* --------------------------------------------- Data Types/ Structures */
75
93 typedef API_RESULT (* MS_CONFIG_MODEL_CB)
94 (
95 MS_ACCESS_MODEL_HANDLE * handle,
96 UINT32 opcode,
97 UCHAR * data_param,
98 UINT16 data_len
99 ) DECL_REENTRANT;
116 typedef struct _ACCESS_CONFIG_BEACON_SET_PARAM
117 {
119 UCHAR beacon;
120
121 } ACCESS_CONFIG_BEACON_SET_PARAM;
122
126 typedef struct _ACCESS_CONFIG_COMPDATA_GET_PARAM
127 {
129 UCHAR page;
130
131 } ACCESS_CONFIG_COMPDATA_GET_PARAM;
132
136 typedef struct _ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM
137 {
139 UCHAR ttl;
140
141 } ACCESS_CONFIG_DEFAULT_TTL_SET_PARAM;
142
146 typedef struct _ACCESS_CONFIG_GATT_PROXY_SET_PARAM
147 {
149 UCHAR proxy;
150
151 } ACCESS_CONFIG_GATT_PROXY_SET_PARAM;
152
156 typedef struct _ACCESS_CONFIG_RELAY_SET_PARAM
157 {
159 UCHAR relay;
160
166 UCHAR relay_rtx_count;
167
172 UCHAR relay_rtx_interval_steps;
173
174 } ACCESS_CONFIG_RELAY_SET_PARAM;
175
179 typedef struct _ACCESS_CONFIG_MODELPUB_GET_PARAM
180 {
182 UINT16 element_address;
183
185 MS_ACCESS_MODEL_ID model;
186
187 } ACCESS_CONFIG_MODELPUB_GET_PARAM;
188
192 typedef struct _ACCESS_CONFIG_MODELPUB_SET_PARAM
193 {
195 UINT16 element_address;
196
198 UINT16 publish_address;
199
204 UINT16 appkey_index;
205
210 UCHAR credential_flag;
211
213 UCHAR publish_ttl;
214
216 UCHAR publish_period;
217
222 UCHAR publish_rtx_count;
223
228 UCHAR publish_rtx_interval_steps;
229
231 MS_ACCESS_MODEL_ID model;
232
233 } ACCESS_CONFIG_MODELPUB_SET_PARAM;
234
238 typedef struct _ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM
239 {
241 UINT16 element_address;
242
244 UCHAR publish_address[MS_ACCESS_VADDR_LABEL_UUID_SIZE];
245
250 UINT16 appkey_index;
251
256 UCHAR credential_flag;
257
259 UCHAR publish_ttl;
260
262 UCHAR publish_period;
263
268 UCHAR publish_rtx_count;
269
274 UCHAR publish_rtx_interval_steps;
275
277 MS_ACCESS_MODEL_ID model;
278
279 } ACCESS_CONFIG_MODELPUB_VADDR_SET_PARAM;
280
284 typedef struct _ACCESS_CONFIG_MODELSUB_ADD_PARAM
285 {
287 UINT16 element_address;
288
290 UINT16 address;
291
293 MS_ACCESS_MODEL_ID model;
294
295 } ACCESS_CONFIG_MODELSUB_ADD_PARAM;
296
300 typedef struct _ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM
301 {
303 UINT16 element_address;
304
306 UCHAR label[MS_ACCESS_VADDR_LABEL_UUID_SIZE];
307
309 MS_ACCESS_MODEL_ID model;
310
311 } ACCESS_CONFIG_MODELSUB_VADDR_ADD_PARAM;
312
316 typedef struct _ACCESS_CONFIG_MODELSUB_DEL_PARAM
317 {
319 UINT16 element_address;
320
322 UINT16 address;
323
325 MS_ACCESS_MODEL_ID model;
326
327 } ACCESS_CONFIG_MODELSUB_DEL_PARAM;
328
332 typedef struct _ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM
333 {
335 UINT16 element_address;
336
338 UCHAR label[MS_ACCESS_VADDR_LABEL_UUID_SIZE];
339
341 MS_ACCESS_MODEL_ID model;
342
343 } ACCESS_CONFIG_MODELSUB_VADDR_DEL_PARAM;
344
348 typedef struct _ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM
349 {
351 UINT16 element_address;
352
354 UINT16 address;
355
357 MS_ACCESS_MODEL_ID model;
358
359 } ACCESS_CONFIG_MODELSUB_OVERWRITE_PARAM;
360
364 typedef struct _ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM
365 {
367 UINT16 element_address;
368
370 UCHAR label[MS_ACCESS_VADDR_LABEL_UUID_SIZE];
371
373 MS_ACCESS_MODEL_ID model;
374
375 } ACCESS_CONFIG_MODELSUB_VADDR_OVERWRITE_PARAM;
376
380 typedef struct _ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM
381 {
383 UINT16 element_address;
384
386 MS_ACCESS_MODEL_ID model;
387
388 } ACCESS_CONFIG_MODELSUB_DELETEALL_PARAM;
389
393 typedef struct _ACCESS_CONFIG_SIGMODELSUB_GET_PARAM
394 {
396 UINT16 element_address;
397
399 MS_ACCESS_MODEL_ID_SIG model_id;
400
401 } ACCESS_CONFIG_SIGMODELSUB_GET_PARAM;
402
406 typedef struct _ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM
407 {
409 UINT16 element_address;
410
412 MS_ACCESS_MODEL_ID_VENDOR model_id;
413
414 } ACCESS_CONFIG_VENDORMODELSUB_GET_PARAM;
415
419 typedef struct _ACCESS_CONFIG_NETKEY_ADD_PARAM
420 {
422 UCHAR netkey[MS_ACCESS_NETKEY_SIZE];
423
425 UINT16 netkey_index;
426
427 } ACCESS_CONFIG_NETKEY_ADD_PARAM;
428
432 typedef struct _ACCESS_CONFIG_NETKEY_UPDATE_PARAM
433 {
435 UCHAR netkey[MS_ACCESS_NETKEY_SIZE];
436
438 UINT16 netkey_index;
439
440 } ACCESS_CONFIG_NETKEY_UPDATE_PARAM;
441
445 typedef struct _ACCESS_CONFIG_NETKEY_DELETE_PARAM
446 {
448 UINT16 netkey_index;
449
450 } ACCESS_CONFIG_NETKEY_DELETE_PARAM;
451
455 typedef struct _ACCESS_CONFIG_APPKEY_ADD_PARAM
456 {
458 UCHAR appkey[MS_ACCESS_APPKEY_SIZE];
459
464 UINT16 netkey_index;
465 UINT16 appkey_index;
466
467 } ACCESS_CONFIG_APPKEY_ADD_PARAM;
468
472 typedef struct _ACCESS_CONFIG_APPKEY_UPDATE_PARAM
473 {
475 UCHAR appkey[MS_ACCESS_APPKEY_SIZE];
476
481 UINT16 netkey_index;
482 UINT16 appkey_index;
483
484 } ACCESS_CONFIG_APPKEY_UPDATE_PARAM;
485
489 typedef struct _ACCESS_CONFIG_APPKEY_DELETE_PARAM
490 {
495 UINT16 netkey_index;
496 UINT16 appkey_index;
497
498 } ACCESS_CONFIG_APPKEY_DELETE_PARAM;
499
503 typedef struct _ACCESS_CONFIG_APPKEY_GET_PARAM
504 {
506 UINT16 netkey_index;
507
508 } ACCESS_CONFIG_APPKEY_GET_PARAM;
509
513 typedef struct _ACCESS_CONFIG_NODEID_GET_PARAM
514 {
516 UINT16 netkey_index;
517
518 } ACCESS_CONFIG_NODEID_GET_PARAM;
519
523 typedef struct _ACCESS_CONFIG_NODEID_SET_PARAM
524 {
526 UINT16 netkey_index;
527
529 UCHAR identity;
530
531 } ACCESS_CONFIG_NODEID_SET_PARAM;
532
536 typedef struct _ACCESS_CONFIG_MODEL_APP_BIND_PARAM
537 {
539 UINT16 element_address;
540
542 UINT16 appkey_index;
543
545 MS_ACCESS_MODEL_ID model;
546
547 } ACCESS_CONFIG_MODEL_APP_BIND_PARAM;
548
552 typedef struct _ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM
553 {
555 UINT16 element_address;
556
558 UINT16 appkey_index;
559
561 MS_ACCESS_MODEL_ID model;
562
563 } ACCESS_CONFIG_MODEL_APP_UNBIND_PARAM;
564
568 typedef struct _ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM
569 {
571 UINT16 element_address;
572
574 MS_ACCESS_MODEL_ID_SIG model_id;
575
576 } ACCESS_CONFIG_SIG_MODEL_APP_GET_PARAM;
577
581 typedef struct _ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM
582 {
584 UINT16 element_address;
585
587 MS_ACCESS_MODEL_ID_VENDOR model_id;
588
589 } ACCESS_CONFIG_VENDOR_MODEL_APP_GET_PARAM;
590
594 typedef struct _ACCESS_CONFIG_FRIEND_SET_PARAM
595 {
597 UCHAR friend;
598
599 } ACCESS_CONFIG_FRIEND_SET_PARAM;
600
604 typedef struct _ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM
605 {
607 UINT16 netkey_index;
608
609 } ACCESS_CONFIG_KEYREFRESH_PHASE_GET_PARAM;
610
614 typedef struct _ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM
615 {
617 UINT16 netkey_index;
618
620 UCHAR transition;
621
622 } ACCESS_CONFIG_KEYREFRESH_PHASE_SET_PARAM;
623
627 typedef struct _ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM
628 {
630 UINT16 destination;
631
633 UCHAR countlog;
634
636 UCHAR periodlog;
637
639 UCHAR ttl;
640
645 UINT16 features;
646
648 UINT16 netkey_index;
649
650 } ACCESS_CONFIG_HEARTBEATPUB_SET_PARAM;
651
655 typedef struct _ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM
656 {
658 UINT16 source;
659
661 UINT16 destination;
662
664 UCHAR periodlog;
665
666 } ACCESS_CONFIG_HEARTBEATSUB_SET_PARAM;
667
671 typedef struct _ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM
672 {
674 UINT16 lpn_address;
675
676 } ACCESS_CONFIG_LPNPOLLTIMEOUT_GET_PARAM;
677
681 typedef struct _ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM
682 {
688 UCHAR net_tx_count;
689
694 UCHAR net_tx_interval_steps;
695
696 } ACCESS_CONFIG_NETWORK_TRANSMIT_SET_PARAM;
697
703 /* --------------------------------------------- Function */
704
735 API_RESULT MS_config_client_init
736 (
737 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
738 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
739 /* IN */ MS_CONFIG_MODEL_CB appl_cb
740 );
741
753 API_RESULT MS_config_client_set_server
754 (
755 /* IN */ MS_NET_ADDR server_addr,
756 /* IN */ UCHAR * dev_key
757 );
758
771 API_RESULT MS_config_client_send_reliable_pdu
772 (
773 /* IN */ UINT32 req_opcode,
774 /* IN */ void * param,
775 /* IN */ UINT32 rsp_opcode
776 );
777
787 #define MS_config_client_beacon_get() \
788 MS_config_client_send_reliable_pdu \
789 (\
790 MS_ACCESS_CONFIG_BEACON_GET_OPCODE,\
791 NULL,\
792 MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE \
793 )
794
807 #define MS_config_client_beacon_set(param)\
808 MS_config_client_send_reliable_pdu \
809 (\
810 MS_ACCESS_CONFIG_BEACON_SET_OPCODE,\
811 (void *)param, \
812 MS_ACCESS_CONFIG_BEACON_STATUS_OPCODE \
813 )
814
827 #define MS_config_client_composition_data_get(param)\
828 MS_config_client_send_reliable_pdu \
829 (\
830 MS_ACCESS_CONFIG_COMPOSITION_DATA_GET_OPCODE,\
831 (void *)param, \
832 MS_ACCESS_CONFIG_COMPOSITION_DATA_STATUS_OPCODE \
833 )
834
844 #define MS_config_client_default_ttl_get()\
845 MS_config_client_send_reliable_pdu \
846 (\
847 MS_ACCESS_CONFIG_DEFAULT_TTL_GET_OPCODE,\
848 NULL, \
849 MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE \
850 )
851
864 #define MS_config_client_default_ttl_set(param)\
865 MS_config_client_send_reliable_pdu \
866 (\
867 MS_ACCESS_CONFIG_DEFAULT_TTL_SET_OPCODE,\
868 (void *)param, \
869 MS_ACCESS_CONFIG_DEFAULT_TTL_STATUS_OPCODE \
870 )
871
881 #define MS_config_client_gatt_proxy_get()\
882 MS_config_client_send_reliable_pdu \
883 (\
884 MS_ACCESS_CONFIG_GATT_PROXY_GET_OPCODE,\
885 NULL, \
886 MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE \
887 )
888
901 #define MS_config_client_gatt_proxy_set(param)\
902 MS_config_client_send_reliable_pdu \
903 (\
904 MS_ACCESS_CONFIG_GATT_PROXY_SET_OPCODE,\
905 (void *)param, \
906 MS_ACCESS_CONFIG_GATT_PROXY_STATUS_OPCODE \
907 )
908
918 #define MS_config_client_relay_get()\
919 MS_config_client_send_reliable_pdu \
920 (\
921 MS_ACCESS_CONFIG_RELAY_GET_OPCODE,\
922 NULL, \
923 MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE \
924 )
925
938 #define MS_config_client_relay_set(param)\
939 MS_config_client_send_reliable_pdu \
940 (\
941 MS_ACCESS_CONFIG_RELAY_SET_OPCODE,\
942 (void *)param, \
943 MS_ACCESS_CONFIG_RELAY_STATUS_OPCODE \
944 )
945
959 #define MS_config_client_model_publication_get(param)\
960 MS_config_client_send_reliable_pdu \
961 (\
962 MS_ACCESS_CONFIG_MODEL_PUBLICATION_GET_OPCODE,\
963 (void *)param, \
964 MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE \
965 )
966
980 #define MS_config_client_model_publication_set(param)\
981 MS_config_client_send_reliable_pdu \
982 (\
983 MS_ACCESS_CONFIG_MODEL_PUBLICATION_SET_OPCODE,\
984 (void *)param, \
985 MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE \
986 )
987
1001 #define MS_config_client_model_publication_vaddr_set(param)\
1002 MS_config_client_send_reliable_pdu \
1003 (\
1004 MS_ACCESS_CONFIG_MODEL_PUBLICATION_VIRTUAL_ADDRESS_SET_OPCODE,\
1005 (void *)param, \
1006 MS_ACCESS_CONFIG_MODEL_PUBLICATION_STATUS_OPCODE \
1007 )
1008
1021 #define MS_config_client_model_subscription_add(param)\
1022 MS_config_client_send_reliable_pdu \
1023 (\
1024 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_ADD_OPCODE,\
1025 (void *)param, \
1026 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
1027 )
1028
1041 #define MS_config_client_model_subscription_vaddr_add(param)\
1042 MS_config_client_send_reliable_pdu \
1043 (\
1044 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_ADD_OPCODE,\
1045 (void *)param, \
1046 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
1047 )
1048
1061 #define MS_config_client_model_subscription_delete(param)\
1062 MS_config_client_send_reliable_pdu \
1063 (\
1064 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_OPCODE,\
1065 (void *)param, \
1066 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
1067 )
1068
1081 #define MS_config_client_model_subscription_vaddr_delete(param)\
1082 MS_config_client_send_reliable_pdu \
1083 (\
1084 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_DELETE_OPCODE,\
1085 (void *)param, \
1086 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
1087 )
1088
1102 #define MS_config_client_model_subscription_overwrite(param)\
1103 MS_config_client_send_reliable_pdu \
1104 (\
1105 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_OVERWRITE_OPCODE,\
1106 (void *)param, \
1107 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
1108 )
1109
1123 #define MS_config_client_model_subscription_vaddr_overwrite(param)\
1124 MS_config_client_send_reliable_pdu \
1125 (\
1126 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_VIRTUAL_ADDRESS_OVERWRITE_OPCODE,\
1127 (void *)param, \
1128 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
1129 )
1130
1143 #define MS_config_client_model_subscription_delete_all(param)\
1144 MS_config_client_send_reliable_pdu \
1145 (\
1146 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_DELETE_ALL_OPCODE,\
1147 (void *)param, \
1148 MS_ACCESS_CONFIG_MODEL_SUBSCRIPTION_STATUS_OPCODE \
1149 )
1150
1164 #define MS_config_client_sig_model_subscription_get(param)\
1165 MS_config_client_send_reliable_pdu \
1166 (\
1167 MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_GET_OPCODE,\
1168 (void *)param, \
1169 MS_ACCESS_CONFIG_SIG_MODEL_SUBSCRIPTION_LIST_OPCODE \
1170 )
1171
1185 #define MS_config_client_vendor_model_subscription_get(param)\
1186 MS_config_client_send_reliable_pdu \
1187 (\
1188 MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_GET_OPCODE,\
1189 (void *)param, \
1190 MS_ACCESS_CONFIG_VENDOR_MODEL_SUBSCRIPTION_LIST_OPCODE \
1191 )
1192
1207 #define MS_config_client_netkey_add(param)\
1208 MS_config_client_send_reliable_pdu \
1209 (\
1210 MS_ACCESS_CONFIG_NETKEY_ADD_OPCODE,\
1211 (void *)param, \
1212 MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE \
1213 )
1214
1229 #define MS_config_client_netkey_update(param)\
1230 MS_config_client_send_reliable_pdu \
1231 (\
1232 MS_ACCESS_CONFIG_NETKEY_UPDATE_OPCODE,\
1233 (void *)param, \
1234 MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE \
1235 )
1236
1249 #define MS_config_client_netkey_delete(param)\
1250 MS_config_client_send_reliable_pdu \
1251 (\
1252 MS_ACCESS_CONFIG_NETKEY_DELETE_OPCODE,\
1253 (void *)param, \
1254 MS_ACCESS_CONFIG_NETKEY_STATUS_OPCODE \
1255 )
1256
1266 #define MS_config_client_netkey_get()\
1267 MS_config_client_send_reliable_pdu \
1268 (\
1269 MS_ACCESS_CONFIG_NETKEY_GET_OPCODE,\
1270 NULL, \
1271 MS_ACCESS_CONFIG_NETKEY_LIST_OPCODE \
1272 )
1273
1289 #define MS_config_client_appkey_add(param)\
1290 MS_config_client_send_reliable_pdu \
1291 (\
1292 MS_ACCESS_CONFIG_APPKEY_ADD_OPCODE,\
1293 (void *)param, \
1294 MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE \
1295 )
1296
1311 #define MS_config_client_appkey_update(param)\
1312 MS_config_client_send_reliable_pdu \
1313 (\
1314 MS_ACCESS_CONFIG_APPKEY_UPDATE_OPCODE,\
1315 (void *)param, \
1316 MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE \
1317 )
1318
1331 #define MS_config_client_appkey_delete(param)\
1332 MS_config_client_send_reliable_pdu \
1333 (\
1334 MS_ACCESS_CONFIG_APPKEY_DELETE_OPCODE,\
1335 (void *)param, \
1336 MS_ACCESS_CONFIG_APPKEY_STATUS_OPCODE \
1337 )
1338
1351 #define MS_config_client_appkey_get(param)\
1352 MS_config_client_send_reliable_pdu \
1353 (\
1354 MS_ACCESS_CONFIG_APPKEY_GET_OPCODE,\
1355 (void *)param, \
1356 MS_ACCESS_CONFIG_APPKEY_LIST_OPCODE \
1357 )
1358
1371 #define MS_config_client_node_identity_get(param)\
1372 MS_config_client_send_reliable_pdu \
1373 (\
1374 MS_ACCESS_CONFIG_NODE_IDENTITY_GET_OPCODE,\
1375 (void *)param, \
1376 MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE \
1377 )
1378
1391 #define MS_config_client_node_identity_set(param)\
1392 MS_config_client_send_reliable_pdu \
1393 (\
1394 MS_ACCESS_CONFIG_NODE_IDENTITY_SET_OPCODE,\
1395 (void *)param, \
1396 MS_ACCESS_CONFIG_NODE_IDENTITY_STATUS_OPCODE \
1397 )
1398
1411 #define MS_config_client_model_app_bind(param)\
1412 MS_config_client_send_reliable_pdu \
1413 (\
1414 MS_ACCESS_CONFIG_MODEL_APP_BIND_OPCODE,\
1415 (void *)param, \
1416 MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE \
1417 )
1418
1431 #define MS_config_client_model_app_unbind(param)\
1432 MS_config_client_send_reliable_pdu \
1433 (\
1434 MS_ACCESS_CONFIG_MODEL_APP_UNBIND_OPCODE,\
1435 (void *)param, \
1436 MS_ACCESS_CONFIG_MODEL_APP_STATUS_OPCODE \
1437 )
1438
1451 #define MS_config_client_sig_model_app_get(param)\
1452 MS_config_client_send_reliable_pdu \
1453 (\
1454 MS_ACCESS_CONFIG_SIG_MODEL_APP_GET_OPCODE,\
1455 (void *)param, \
1456 MS_ACCESS_CONFIG_SIG_MODEL_APP_LIST_OPCODE \
1457 )
1458
1471 #define MS_config_client_vendor_model_app_get(param)\
1472 MS_config_client_send_reliable_pdu \
1473 (\
1474 MS_ACCESS_CONFIG_VENDOR_MODEL_APP_GET_OPCODE,\
1475 (void *)param, \
1476 MS_ACCESS_CONFIG_VENDOR_MODEL_APP_LIST_OPCODE \
1477 )
1478
1488 #define MS_config_client_node_reset()\
1489 MS_config_client_send_reliable_pdu \
1490 (\
1491 MS_ACCESS_CONFIG_NODE_RESET_OPCODE,\
1492 NULL, \
1493 MS_ACCESS_CONFIG_NODE_RESET_STATUS_OPCODE \
1494 )
1495
1505 #define MS_config_client_friend_get()\
1506 MS_config_client_send_reliable_pdu \
1507 (\
1508 MS_ACCESS_CONFIG_FRIEND_GET_OPCODE,\
1509 NULL, \
1510 MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE \
1511 )
1512
1525 #define MS_config_client_friend_set(param)\
1526 MS_config_client_send_reliable_pdu \
1527 (\
1528 MS_ACCESS_CONFIG_FRIEND_SET_OPCODE,\
1529 (void *)param, \
1530 MS_ACCESS_CONFIG_FRIEND_STATUS_OPCODE \
1531 )
1532
1545 #define MS_config_client_keyrefresh_phase_get(param)\
1546 MS_config_client_send_reliable_pdu \
1547 (\
1548 MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_GET_OPCODE,\
1549 (void *)param, \
1550 MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE \
1551 )
1552
1565 #define MS_config_client_keyrefresh_phase_set(param)\
1566 MS_config_client_send_reliable_pdu \
1567 (\
1568 MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_SET_OPCODE,\
1569 (void *)param, \
1570 MS_ACCESS_CONFIG_KEY_REFRESH_PHASE_STATUS_OPCODE \
1571 )
1572
1582 #define MS_config_client_heartbeat_publication_get()\
1583 MS_config_client_send_reliable_pdu \
1584 (\
1585 MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_GET_OPCODE,\
1586 NULL, \
1587 MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_STATUS_OPCODE \
1588 )
1589
1602 #define MS_config_client_heartbeat_publication_set(param)\
1603 MS_config_client_send_reliable_pdu \
1604 (\
1605 MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_SET_OPCODE,\
1606 (void *)param, \
1607 MS_ACCESS_CONFIG_HEARTBEAT_PUBLICATION_STATUS_OPCODE \
1608 )
1609
1619 #define MS_config_client_heartbeat_subscription_get()\
1620 MS_config_client_send_reliable_pdu \
1621 (\
1622 MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_GET_OPCODE,\
1623 NULL, \
1624 MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE \
1625 )
1626
1639 #define MS_config_client_heartbeat_subscription_set(param)\
1640 MS_config_client_send_reliable_pdu \
1641 (\
1642 MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_SET_OPCODE,\
1643 (void *)param, \
1644 MS_ACCESS_CONFIG_HEARTBEAT_SUBSCRIPTION_STATUS_OPCODE \
1645 )
1646
1663 #define MS_config_client_lpn_polltimeout_get(param)\
1664 MS_config_client_send_reliable_pdu \
1665 (\
1666 MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_GET_OPCODE,\
1667 (void *)param, \
1668 MS_ACCESS_CONFIG_LOW_POWER_NODE_POLLTIMEOUT_STATUS_OPCODE \
1669 )
1670
1680 #define MS_config_client_network_transmit_get()\
1681 MS_config_client_send_reliable_pdu \
1682 (\
1683 MS_ACCESS_CONFIG_NETWORK_TRANSMIT_GET_OPCODE,\
1684 NULL, \
1685 MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE \
1686 )
1687
1700 #define MS_config_client_network_transmit_set(param)\
1701 MS_config_client_send_reliable_pdu \
1702 (\
1703 MS_ACCESS_CONFIG_NETWORK_TRANSMIT_SET_OPCODE,\
1704 (void *)param, \
1705 MS_ACCESS_CONFIG_NETWORK_TRANSMIT_STATUS_OPCODE \
1706 )
1707
1732 API_RESULT MS_config_server_init
1733 (
1734 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
1735 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle
1736 );
1737
1744 #endif /* _H_MS_CONFIG_API_ */
1745


EtherMind Mesh SDK (beta): mesh/export/include/MS_error.h Source File

  • mesh
  • export
  • include
MS_error.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_ERROR_
15 #define _H_MS_ERROR_
16
74 #ifndef API_RESULT_DEFINED
75 typedef UINT16 API_RESULT;
76 #define API_RESULT_DEFINED
77 #endif /* API_RESULT_DEFINED */
78
79 /* Definitions of API_SUCCESS & API_FAILURE */
80 #ifdef API_SUCCESS
81 #undef API_SUCCESS
82 #endif /* API_SUCCESS */
83
84 #define API_SUCCESS 0x0000
85
86 #ifdef API_FAILURE
87 #undef API_FAILURE
88 #endif /* API_FAILURE */
89
90 #define API_FAILURE 0xFFFF
91
94 /* ====================== EtherMind Module Error IDs ====================== */
95
108 #define MS_ERR_ID 0x0000
109
121 #define MS_COMMON_ERR_ID 0x1000
122
123 #define TIMER_ERR_ID 0x1200
124
134 #define BRR_ERR_ID 0x2000
135 #define NET_ERR_ID 0x2100
136 #define LTRN_ERR_ID 0x2200
137 #define TRN_ERR_ID 0x2300
138 #define ACCESS_ERR_ID 0x2400
139
140 #define PROV_ERR_ID 0x3000
141
142 #define HEALTH_ERR_ID 0x8000
143
152 /* ================== EtherMind Common Reason Error Codes ================= */
153
164 #define MUTEX_INIT_FAILED 0x0001
165 #define COND_INIT_FAILED 0x0002
166 #define MUTEX_LOCK_FAILED 0x0003
167 #define MUTEX_UNLOCK_FAILED 0x0004
168 #define MEMORY_ALLOCATION_FAILED 0x0005
169
173 /* ======================================= Section 'Mesh' */
183 #define MS_SUCCESS (0x0000 | MS_ERR_ID)
184
185 #define MS_INVALID_ADDRESS (0x0001 | MS_ERR_ID)
186
187 #define MS_INVALID_MODEL (0x0002 | MS_ERR_ID)
188
189 #define MS_INVALID_APPKEY_INDEX (0x0003 | MS_ERR_ID)
190
191 #define MS_INVALID_NETKEY_INDEX (0x0004 | MS_ERR_ID)
192
193 #define MS_INSUFFICIENT_RESOURCES (0x0005 | MS_ERR_ID)
194
195 #define MS_KEY_INDEX_ALREADY_STORED (0x0006 | MS_ERR_ID)
196
197 #define MS_INVALID_PUBLISH_PARAMETER (0x0007 | MS_ERR_ID)
198
199 #define MS_NOT_A_SUBSCRIBE_MODEL (0x0008 | MS_ERR_ID)
200
201 #define MS_STORAGE_FAILURE (0x0009 | MS_ERR_ID)
202
203 #define MS_FEATURE_NOT_SUPPORTED (0x000A | MS_ERR_ID)
204
205 #define MS_CANNOT_UPDATE (0x000B | MS_ERR_ID)
206
207 #define MS_CANNOT_REMOVE (0x000C | MS_ERR_ID)
208
209 #define MS_CANNOT_BIND (0x000D | MS_ERR_ID)
210
211 #define MS_TEMP_UNABLE_TO_CHANGE_STATE (0x000E | MS_ERR_ID)
212
213 #define MS_CANNOT_SET (0x000F | MS_ERR_ID)
214
215 #define MS_UNSPECIFIED_ERROR (0x0010 | MS_ERR_ID)
216
217 #define MS_INVALID_BINDING (0x0011 | MS_ERR_ID)
218
222 /* ===================== EtherMind Module Error Codes ===================== */
223
224 /* ======================================= Section 'Timer' */
235 #define TIMER_MUTEX_INIT_FAILED \
236 (MUTEX_INIT_FAILED | TIMER_ERR_ID)
237 #define TIMER_COND_INIT_FAILED \
238 (COND_INIT_FAILED | TIMER_ERR_ID)
239 #define TIMER_MUTEX_LOCK_FAILED \
240 (MUTEX_LOCK_FAILED | TIMER_ERR_ID)
241 #define TIMER_MUTEX_UNLOCK_FAILED \
242 (MUTEX_UNLOCK_FAILED | TIMER_ERR_ID)
243 #define TIMER_MEMORY_ALLOCATION_FAILED \
244 (MEMORY_ALLOCATION_FAILED | TIMER_ERR_ID)
245
246 #define TIMER_HANDLE_IS_NULL (0x0011 | TIMER_ERR_ID)
247 #define TIMER_CALLBACK_IS_NULL (0x0012 | TIMER_ERR_ID)
248 #define TIMER_QUEUE_EMPTY (0x0013 | TIMER_ERR_ID)
249 #define TIMER_QUEUE_FULL (0x0014 | TIMER_ERR_ID)
250 #define TIMER_ENTITY_SEARCH_FAILED (0x0015 | TIMER_ERR_ID)
251 #define TIMER_NULL_PARAMETER_NOT_ALLOWED (0x0016 | TIMER_ERR_ID)
252 #define TIMER_TIMEOUT_ZERO_NOT_ALLOWED (0x0017 | TIMER_ERR_ID)
253
257 /* ======================================= Section 'Bearer' */
268 #define BRR_MUTEX_INIT_FAILED \
269 (MUTEX_INIT_FAILED | BRR_ERR_ID)
270 #define BRR_COND_INIT_FAILED \
271 (COND_INIT_FAILED | BRR_ERR_ID)
272 #define BRR_MUTEX_LOCK_FAILED \
273 (MUTEX_LOCK_FAILED | BRR_ERR_ID)
274 #define BRR_MUTEX_UNLOCK_FAILED \
275 (MUTEX_UNLOCK_FAILED | BRR_ERR_ID)
276 #define BRR_MEMORY_ALLOCATION_FAILED \
277 (MEMORY_ALLOCATION_FAILED | BRR_ERR_ID)
278
279 #define BRR_INVALID_PARAMETER_VALUE (0x0011 | BRR_ERR_ID)
280 #define BRR_PARAMETER_OUTSIDE_RANGE (0x0012 | BRR_ERR_ID)
281 #define BRR_NULL_PARAMETER_NOT_ALLOWED (0x0013 | BRR_ERR_ID)
282 #define BRR_INTERFACE_NOT_READY (0x0014 | BRR_ERR_ID)
283 #define BRR_API_NOT_SUPPORTED (0x00FF | BRR_ERR_ID)
284
288 /* ======================================= Section 'Network' */
299 #define NET_MUTEX_INIT_FAILED \
300 (MUTEX_INIT_FAILED | NET_ERR_ID)
301 #define NET_COND_INIT_FAILED \
302 (COND_INIT_FAILED | NET_ERR_ID)
303 #define NET_MUTEX_LOCK_FAILED \
304 (MUTEX_LOCK_FAILED | NET_ERR_ID)
305 #define NET_MUTEX_UNLOCK_FAILED \
306 (MUTEX_UNLOCK_FAILED | NET_ERR_ID)
307 #define NET_MEMORY_ALLOCATION_FAILED \
308 (MEMORY_ALLOCATION_FAILED | NET_ERR_ID)
309
310 #define NET_INVALID_PARAMETER_VALUE (0x0011 | NET_ERR_ID)
311 #define NET_PARAMETER_OUTSIDE_RANGE (0x0012 | NET_ERR_ID)
312 #define NET_NULL_PARAMETER_NOT_ALLOWED (0x0013 | NET_ERR_ID)
313 #define NET_TX_QUEUE_FULL (0x0014 | NET_ERR_ID)
314 #define NET_TX_QUEUE_EMPTY (0x0015 | NET_ERR_ID)
315
321 #define NET_INVALID_RX_PKT_FORMAT (0x0016 | NET_ERR_ID)
322 #define NET_RX_LOCAL_SRC_ADDR_PKT (0x0017 | NET_ERR_ID)
323 #define NET_POST_PROCESS_RX_PKT (0x0018 | NET_ERR_ID)
324
325 #define NET_API_NOT_SUPPORTED (0x00FF | NET_ERR_ID)
326
330 /* ======================================= Section 'Lower Transport' */
341 #define LTRN_MUTEX_INIT_FAILED \
342 (MUTEX_INIT_FAILED | LTRN_ERR_ID)
343 #define LTRN_COND_INIT_FAILED \
344 (COND_INIT_FAILED | LTRN_ERR_ID)
345 #define LTRN_MUTEX_LOCK_FAILED \
346 (MUTEX_LOCK_FAILED | LTRN_ERR_ID)
347 #define LTRN_MUTEX_UNLOCK_FAILED \
348 (MUTEX_UNLOCK_FAILED | LTRN_ERR_ID)
349 #define LTRN_MEMORY_ALLOCATION_FAILED \
350 (MEMORY_ALLOCATION_FAILED | LTRN_ERR_ID)
351
352 #define LTRN_INVALID_PARAMETER_VALUE (0x0011 | LTRN_ERR_ID)
353 #define LTRN_PARAMETER_OUTSIDE_RANGE (0x0012 | LTRN_ERR_ID)
354 #define LTRN_NULL_PARAMETER_NOT_ALLOWED (0x0013 | LTRN_ERR_ID)
355 #define LTRN_SAR_CTX_ALLOCATION_FAILED (0x0014 | LTRN_ERR_ID)
356
360 /* ======================================= Section 'Transport' */
371 #define TRN_MUTEX_INIT_FAILED \
372 (MUTEX_INIT_FAILED | TRN_ERR_ID)
373 #define TRN_COND_INIT_FAILED \
374 (COND_INIT_FAILED | TRN_ERR_ID)
375 #define TRN_MUTEX_LOCK_FAILED \
376 (MUTEX_LOCK_FAILED | TRN_ERR_ID)
377 #define TRN_MUTEX_UNLOCK_FAILED \
378 (MUTEX_UNLOCK_FAILED | TRN_ERR_ID)
379 #define TRN_MEMORY_ALLOCATION_FAILED \
380 (MEMORY_ALLOCATION_FAILED | TRN_ERR_ID)
381
382 #define TRN_INVALID_PARAMETER_VALUE (0x0011 | TRN_ERR_ID)
383 #define TRN_PARAMETER_OUTSIDE_RANGE (0x0012 | TRN_ERR_ID)
384 #define TRN_NULL_PARAMETER_NOT_ALLOWED (0x0013 | TRN_ERR_ID)
385 #define TRN_QUEUE_FULL (0x0014 | TRN_ERR_ID)
386 #define TRN_QUEUE_EMPTY (0x0015 | TRN_ERR_ID)
387 #define TRN_INCOMPLETE_PKT_RECEIVED (0x0016 | TRN_ERR_ID)
388
389 #define TRN_API_NOT_SUPPORTED (0x00FF | TRN_ERR_ID)
390
394 /* ======================================= Section 'Access' */
405 #define ACCESS_MUTEX_INIT_FAILED \
406 (MUTEX_INIT_FAILED | ACCESS_ERR_ID)
407 #define ACCESS_COND_INIT_FAILED \
408 (COND_INIT_FAILED | ACCESS_ERR_ID)
409 #define ACCESS_MUTEX_LOCK_FAILED \
410 (MUTEX_LOCK_FAILED | ACCESS_ERR_ID)
411 #define ACCESS_MUTEX_UNLOCK_FAILED \
412 (MUTEX_UNLOCK_FAILED | ACCESS_ERR_ID)
413 #define ACCESS_MEMORY_ALLOCATION_FAILED \
414 (MEMORY_ALLOCATION_FAILED | ACCESS_ERR_ID)
415
416 #define ACCESS_INVALID_PARAMETER_VALUE (0x0011 | ACCESS_ERR_ID)
417 #define ACCESS_PARAMETER_OUTSIDE_RANGE (0x0012 | ACCESS_ERR_ID)
418 #define ACCESS_NULL_PARAMETER_NOT_ALLOWED (0x0013 | ACCESS_ERR_ID)
419
420 #define ACCESS_NO_RESOURCE (0x0020 | ACCESS_ERR_ID)
421 #define ACCESS_NO_MATCH (0x0021 | ACCESS_ERR_ID)
422 #define ACCESS_INVALID_HANDLE (0x0022 | ACCESS_ERR_ID)
423 #define ACCESS_MODEL_ALREADY_REGISTERED (0x0023 | ACCESS_ERR_ID)
424 #define ACCESS_INVALID_SRC_ADDR (0x0024 | ACCESS_ERR_ID)
425 #define ACCESS_DEV_KEY_TABLE_FULL (0x0025 | ACCESS_ERR_ID)
426
427 #define ACCESS_API_NOT_SUPPORTED (0x00FF | ACCESS_ERR_ID)
428
432 /* ======================================= Section 'Provisioning' */
443 #define PROV_MUTEX_INIT_FAILED \
444 (MUTEX_INIT_FAILED | PROV_ERR_ID)
445 #define PROV_COND_INIT_FAILED \
446 (COND_INIT_FAILED | PROV_ERR_ID)
447 #define PROV_MUTEX_LOCK_FAILED \
448 (MUTEX_LOCK_FAILED | PROV_ERR_ID)
449 #define PROV_MUTEX_UNLOCK_FAILED \
450 (MUTEX_UNLOCK_FAILED | PROV_ERR_ID)
451 #define PROV_MEMORY_ALLOCATION_FAILED \
452 (MEMORY_ALLOCATION_FAILED | PROV_ERR_ID)
453
454 #define PROV_INVALID_STATE (0x0011 | PROV_ERR_ID)
455 #define PROV_INVALID_PARAMETER (0x0012 | PROV_ERR_ID)
456 #define PROV_CONTEXT_ALLOC_FAILED (0x0013 | PROV_ERR_ID)
457 #define PROV_CONTEXT_ASSERT_FAILED (0x0014 | PROV_ERR_ID)
458 #define PROV_CONTEXT_LINK_OPEN (0x0015 | PROV_ERR_ID)
459 #define PROV_BEARER_ASSERT_FAILED (0x0016 | PROV_ERR_ID)
460 #define PROV_PROCEDURE_TIMEOUT (0x0017 | PROV_ERR_ID)
461
465 /* ======================================= Section 'Health Server' */
476 #define HEALTH_MUTEX_INIT_FAILED \
477 (MUTEX_INIT_FAILED | HEALTH_ERR_ID)
478 #define HEALTH_COND_INIT_FAILED \
479 (COND_INIT_FAILED | HEALTH_ERR_ID)
480 #define HEALTH_MUTEX_LOCK_FAILED \
481 (MUTEX_LOCK_FAILED | HEALTH_ERR_ID)
482 #define HEALTH_MUTEX_UNLOCK_FAILED \
483 (MUTEX_UNLOCK_FAILED | HEALTH_ERR_ID)
484 #define HEALTH_MEMORY_ALLOCATION_FAILED \
485 (MEMORY_ALLOCATION_FAILED | HEALTH_ERR_ID)
486
487 #define HEALTH_INVALID_STATE (0x0011 | HEALTH_ERR_ID)
488 #define HEALTH_INVALID_PARAMETER (0x0012 | HEALTH_ERR_ID)
489 #define HEALTH_CONTEXT_ALLOC_FAILED (0x0013 | HEALTH_ERR_ID)
490 #define HEALTH_CONTEXT_ASSERT_FAILED (0x0014 | HEALTH_ERR_ID)
491
495 #endif /* _H_MS_ERROR_ */
496


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_battery_api.h Source File

  • mesh
  • export
  • include
MS_generic_battery_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_BATTERY_API_
14 #define _H_MS_GENERIC_BATTERY_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_GENERIC_BATTERY_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_GENERIC_BATTERY_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
93 typedef struct MS_generic_battery_status_struct
94 {
105 UCHAR battery_level;
106
115 UINT32 time_to_discharge;
116
125 UINT32 time_to_charge;
126
137 UCHAR flags;
138
139 } MS_GENERIC_BATTERY_STATUS_STRUCT;
140
145 /* --------------------------------------------- Function */
175 API_RESULT MS_generic_battery_server_init
176 (
177 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
178 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
179 /* IN */ MS_GENERIC_BATTERY_SERVER_CB appl_cb
180 );
181
196 API_RESULT MS_generic_battery_server_state_update
197 (
198 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
199 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
200 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
201 /* IN */ UINT16 remaining_time,
202 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
203 );
230 API_RESULT MS_generic_battery_client_init
231 (
232 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
233 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
234 /* IN */ MS_GENERIC_BATTERY_CLIENT_CB appl_cb
235 );
236
247 API_RESULT MS_generic_battery_client_get_model_handle
248 (
249 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
250 );
251
264 API_RESULT MS_generic_battery_client_send_reliable_pdu
265 (
266 /* IN */ UINT32 req_opcode,
267 /* IN */ void * param,
268 /* IN */ UINT32 rsp_opcode
269 );
270
281 #define MS_generic_battery_get() \
282 MS_generic_battery_client_send_reliable_pdu \
283 (\
284 MS_ACCESS_GENERIC_BATTERY_GET_OPCODE,\
285 NULL,\
286 MS_ACCESS_GENERIC_BATTERY_STATUS_OPCODE\
287 )
288
292 #endif /*_H_MS_GENERIC_BATTERY_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_default_transition_time_api.h Source File

  • mesh
  • export
  • include
MS_generic_default_transition_time_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_DEFAULT_TRANSITION_TIME_API_
14 #define _H_MS_GENERIC_DEFAULT_TRANSITION_TIME_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19 #include "MS_model_states.h"
20
21
22 /* --------------------------------------------- Global Definitions */
32 /* --------------------------------------------- Data Types/ Structures */
52 typedef API_RESULT (* MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB)
53 (
54 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
55 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
56 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
57 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
58 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
59
60 ) DECL_REENTRANT;
61
73 typedef API_RESULT (* MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB)
74 (
75 MS_ACCESS_MODEL_HANDLE * handle,
76 UINT32 opcode,
77 UCHAR * data_param,
78 UINT16 data_len
79 ) DECL_REENTRANT;
103 typedef struct MS_generic_default_transition_time_struct
104 {
116 UCHAR transition_number_of_steps;
117
130 UCHAR transition_step_resolution;
131
132 } MS_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT;
133
138 /* --------------------------------------------- Function */
168 API_RESULT MS_generic_default_transition_time_server_init
169 (
170 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
171 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
172 /* IN */ MS_GENERIC_DEFAULT_TRANSITION_TIME_SERVER_CB appl_cb
173 );
174
185 API_RESULT MS_generic_default_transition_time_server_get_time
186 (
187 /* OUT */ MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT * default_time
188 );
215 API_RESULT MS_generic_default_transition_time_client_init
216 (
217 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
218 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
219 /* IN */ MS_GENERIC_DEFAULT_TRANSITION_TIME_CLIENT_CB appl_cb
220 );
221
232 API_RESULT MS_generic_default_transition_time_client_get_model_handle
233 (
234 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
235 );
236
249 API_RESULT MS_generic_default_transition_time_client_send_reliable_pdu
250 (
251 /* IN */ UINT32 req_opcode,
252 /* IN */ void * param,
253 /* IN */ UINT32 rsp_opcode
254 );
255
269 #define MS_generic_default_transition_time_set(param) \
270 MS_generic_default_transition_time_client_send_reliable_pdu \
271 (\
272 MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_OPCODE,\
273 param,\
274 MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE\
275 )
276
288 #define MS_generic_default_transition_time_set_unacknowledged(param) \
289 MS_generic_default_transition_time_client_send_reliable_pdu \
290 (\
291 MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_SET_UNACKNOWLEDGED_OPCODE,\
292 param,\
293 0xFFFFFFFF\
294 )
295
308 #define MS_generic_default_transition_time_get() \
309 MS_generic_default_transition_time_client_send_reliable_pdu \
310 (\
311 MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_GET_OPCODE,\
312 NULL,\
313 MS_ACCESS_GENERIC_DEFAULT_TRANSITION_TIME_STATUS_OPCODE\
314 )
315
319 #endif /*_H_MS_GENERIC_DEFAULT_TRANSITION_TIME_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_level_api.h Source File

  • mesh
  • export
  • include
MS_generic_level_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_LEVEL_API_
14 #define _H_MS_GENERIC_LEVEL_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_GENERIC_LEVEL_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_GENERIC_LEVEL_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
89 typedef struct MS_generic_level_set_struct
90 {
97 UINT16 level;
98
100 UCHAR tid;
101
113 UCHAR transition_time;
114
116 UCHAR delay;
117
119 UCHAR optional_fields_present;
120
121 } MS_GENERIC_LEVEL_SET_STRUCT;
122
126 typedef struct MS_generic_level_status_struct
127 {
129 UINT16 present_level;
130
132 UINT16 target_level;
133
145 UCHAR remaining_time;
146
148 UCHAR optional_fields_present;
149
150 } MS_GENERIC_LEVEL_STATUS_STRUCT;
151
155 typedef struct MS_generic_delta_set_struct
156 {
158 UINT32 delta_level;
159
161 UCHAR tid;
162
174 UCHAR transition_time;
175
177 UCHAR delay;
178
180 UCHAR optional_fields_present;
181
182 } MS_GENERIC_DELTA_SET_STRUCT;
183
187 typedef struct MS_generic_move_set_struct
188 {
190 UINT16 delta_level;
191
193 UCHAR tid;
194
206 UCHAR transition_time;
207
209 UCHAR delay;
210
212 UCHAR optional_fields_present;
213
214 } MS_GENERIC_MOVE_SET_STRUCT;
215
220 /* --------------------------------------------- Function */
250 API_RESULT MS_generic_level_server_init
251 (
252 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
253 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
254 /* IN */ MS_GENERIC_LEVEL_SERVER_CB appl_cb
255 );
256
271 API_RESULT MS_generic_level_server_state_update
272 (
273 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
274 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
275 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
276 /* IN */ UINT16 remaining_time,
277 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
278 );
305 API_RESULT MS_generic_level_client_init
306 (
307 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
308 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
309 /* IN */ MS_GENERIC_LEVEL_CLIENT_CB appl_cb
310 );
311
322 API_RESULT MS_generic_level_client_get_model_handle
323 (
324 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
325 );
326
339 API_RESULT MS_generic_level_client_send_reliable_pdu
340 (
341 /* IN */ UINT32 req_opcode,
342 /* IN */ void * param,
343 /* IN */ UINT32 rsp_opcode
344 );
345
358 #define MS_generic_level_set(param) \
359 MS_generic_level_client_send_reliable_pdu \
360 (\
361 MS_ACCESS_GENERIC_LEVEL_SET_OPCODE,\
362 param,\
363 MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
364 )
365
379 #define MS_generic_move_set(param) \
380 MS_generic_level_client_send_reliable_pdu \
381 (\
382 MS_ACCESS_GENERIC_MOVE_SET_OPCODE,\
383 param,\
384 MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
385 )
386
397 #define MS_generic_level_get() \
398 MS_generic_level_client_send_reliable_pdu \
399 (\
400 MS_ACCESS_GENERIC_LEVEL_GET_OPCODE,\
401 NULL,\
402 MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
403 )
404
418 #define MS_generic_delta_set(param) \
419 MS_generic_level_client_send_reliable_pdu \
420 (\
421 MS_ACCESS_GENERIC_DELTA_SET_OPCODE,\
422 param,\
423 MS_ACCESS_GENERIC_LEVEL_STATUS_OPCODE\
424 )
425
437 #define MS_generic_delta_set_unacknowledged(param) \
438 MS_generic_level_client_send_reliable_pdu \
439 (\
440 MS_ACCESS_GENERIC_DELTA_SET_UNACKNOWLEDGED_OPCODE,\
441 param,\
442 0xFFFFFFFF\
443 )
444
456 #define MS_generic_level_set_unacknowledged(param) \
457 MS_generic_level_client_send_reliable_pdu \
458 (\
459 MS_ACCESS_GENERIC_LEVEL_SET_UNACKNOWLEDGED_OPCODE,\
460 param,\
461 0xFFFFFFFF\
462 )
463
476 #define MS_generic_move_set_unacknowledged(param) \
477 MS_generic_level_client_send_reliable_pdu \
478 (\
479 MS_ACCESS_GENERIC_MOVE_SET_UNACKNOWLEDGED_OPCODE,\
480 param,\
481 0xFFFFFFFF\
482 )
483
487 #endif /*_H_MS_GENERIC_LEVEL_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_location_api.h Source File

  • mesh
  • export
  • include
MS_generic_location_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_LOCATION_API_
14 #define _H_MS_GENERIC_LOCATION_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_GENERIC_LOCATION_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_GENERIC_LOCATION_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
79
92 typedef API_RESULT (* MS_GENERIC_LOCATION_SETUP_SERVER_CB)
93 (
94 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
95 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
96 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
97 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
98 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
99
100 ) DECL_REENTRANT;
112 typedef struct MS_generic_location_global_struct
113 {
118 UINT32 global_latitude;
119
124 UINT32 global_longitude;
125
137 UINT16 global_altitude;
138
139 } MS_GENERIC_LOCATION_GLOBAL_STRUCT;
140
144 typedef struct MS_generic_location_local_struct
145 {
154 UINT16 local_north;
155
164 UINT16 local_east;
165
176 UINT16 local_altitude;
177
198 UCHAR floor_number;
199
219 UINT16 uncertainty;
220
221 } MS_GENERIC_LOCATION_LOCAL_STRUCT;
222
227 /* --------------------------------------------- Function */
257 API_RESULT MS_generic_location_server_init
258 (
259 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
260 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
261 /* IN */ MS_GENERIC_LOCATION_SERVER_CB appl_cb
262 );
263
278 API_RESULT MS_generic_location_server_state_update
279 (
280 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
281 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
282 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
283 /* IN */ UINT16 remaining_time,
284 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
285 );
286
305 API_RESULT MS_generic_location_setup_server_init
306 (
307 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
308 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
309 /* IN */ MS_GENERIC_LOCATION_SETUP_SERVER_CB appl_cb
310 );
311
326 API_RESULT MS_generic_location_setup_server_state_update
327 (
328 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
329 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
330 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
331 /* IN */ UINT16 remaining_time,
332 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
333 );
360 API_RESULT MS_generic_location_client_init
361 (
362 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
363 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
364 /* IN */ MS_GENERIC_LOCATION_CLIENT_CB appl_cb
365 );
366
377 API_RESULT MS_generic_location_client_get_model_handle
378 (
379 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
380 );
381
394 API_RESULT MS_generic_location_client_send_reliable_pdu
395 (
396 /* IN */ UINT32 req_opcode,
397 /* IN */ void * param,
398 /* IN */ UINT32 rsp_opcode
399 );
400
410 #define MS_generic_location_global_set_unacknowledged(param) \
411 MS_generic_location_client_send_reliable_pdu \
412 (\
413 MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_UNACKNOWLEDGED_OPCODE,\
414 param,\
415 0xFFFFFFFF\
416 )
417
429 #define MS_generic_location_local_get() \
430 MS_generic_location_client_send_reliable_pdu \
431 (\
432 MS_ACCESS_GENERIC_LOCATION_LOCAL_GET_OPCODE,\
433 NULL,\
434 MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE\
435 )
436
449 #define MS_generic_location_local_set(param) \
450 MS_generic_location_client_send_reliable_pdu \
451 (\
452 MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_OPCODE,\
453 param,\
454 MS_ACCESS_GENERIC_LOCATION_LOCAL_STATUS_OPCODE\
455 )
456
468 #define MS_generic_location_global_set(param) \
469 MS_generic_location_client_send_reliable_pdu \
470 (\
471 MS_ACCESS_GENERIC_LOCATION_GLOBAL_SET_OPCODE,\
472 param,\
473 MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE\
474 )
475
487 #define MS_generic_location_global_get() \
488 MS_generic_location_client_send_reliable_pdu \
489 (\
490 MS_ACCESS_GENERIC_LOCATION_GLOBAL_GET_OPCODE,\
491 NULL,\
492 MS_ACCESS_GENERIC_LOCATION_GLOBAL_STATUS_OPCODE\
493 )
494
506 #define MS_generic_location_local_set_unacknowledged(param) \
507 MS_generic_location_client_send_reliable_pdu \
508 (\
509 MS_ACCESS_GENERIC_LOCATION_LOCAL_SET_UNACKNOWLEDGED_OPCODE,\
510 param,\
511 0xFFFFFFFF\
512 )
513
517 #endif /*_H_MS_GENERIC_LOCATION_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_onoff_api.h Source File

  • mesh
  • export
  • include
MS_generic_onoff_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_ONOFF_API_
14 #define _H_MS_GENERIC_ONOFF_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_GENERIC_ONOFF_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_GENERIC_ONOFF_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
89 typedef struct MS_generic_onoff_set_struct
90 {
92 UCHAR onoff;
93
95 UCHAR tid;
96
108 UCHAR transition_time;
109
111 UCHAR delay;
112
114 UCHAR optional_fields_present;
115
116 } MS_GENERIC_ONOFF_SET_STRUCT;
117
121 typedef struct MS_generic_onoff_status_struct
122 {
124 UCHAR present_onoff;
125
127 UCHAR target_onoff;
128
140 UCHAR remaining_time;
141
143 UCHAR optional_fields_present;
144
145 } MS_GENERIC_ONOFF_STATUS_STRUCT;
146
151 /* --------------------------------------------- Function */
181 API_RESULT MS_generic_onoff_server_init
182 (
183 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
184 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
185 /* IN */ MS_GENERIC_ONOFF_SERVER_CB appl_cb
186 );
187
202 API_RESULT MS_generic_onoff_server_state_update
203 (
204 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
205 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
206 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
207 /* IN */ UINT16 remaining_time,
208 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
209 );
236 API_RESULT MS_generic_onoff_client_init
237 (
238 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
239 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
240 /* IN */ MS_GENERIC_ONOFF_CLIENT_CB appl_cb
241 );
242
253 API_RESULT MS_generic_onoff_client_get_model_handle
254 (
255 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
256 );
257
270 API_RESULT MS_generic_onoff_client_send_reliable_pdu
271 (
272 /* IN */ UINT32 req_opcode,
273 /* IN */ void * param,
274 /* IN */ UINT32 rsp_opcode
275 );
276
289 #define MS_generic_onoff_set_unacknowledged(param) \
290 MS_generic_onoff_client_send_reliable_pdu \
291 (\
292 MS_ACCESS_GENERIC_ONOFF_SET_UNACKNOWLEDGED_OPCODE,\
293 param,\
294 0xFFFFFFFF\
295 )
296
309 #define MS_generic_onoff_set(param) \
310 MS_generic_onoff_client_send_reliable_pdu \
311 (\
312 MS_ACCESS_GENERIC_ONOFF_SET_OPCODE,\
313 param,\
314 MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE\
315 )
316
326 #define MS_generic_onoff_get() \
327 MS_generic_onoff_client_send_reliable_pdu \
328 (\
329 MS_ACCESS_GENERIC_ONOFF_GET_OPCODE,\
330 NULL,\
331 MS_ACCESS_GENERIC_ONOFF_STATUS_OPCODE\
332 )
333
337 #endif /*_H_MS_GENERIC_ONOFF_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_power_level_api.h Source File

  • mesh
  • export
  • include
MS_generic_power_level_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_POWER_LEVEL_API_
14 #define _H_MS_GENERIC_POWER_LEVEL_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_GENERIC_POWER_LEVEL_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_GENERIC_POWER_LEVEL_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
79
92 typedef API_RESULT (* MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB)
93 (
94 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
95 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
96 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
97 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
98 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
99
100 ) DECL_REENTRANT;
111 typedef struct MS_generic_power_level_set_struct
112 {
114 UINT16 power;
115
117 UCHAR tid;
118
130 UCHAR transition_time;
131
133 UCHAR delay;
134
136 UCHAR optional_fields_present;
137
138 } MS_GENERIC_POWER_LEVEL_SET_STRUCT;
139
143 typedef struct MS_generic_power_level_status_struct
144 {
146 UINT16 present_power;
147
149 UINT16 target_power;
150
162 UCHAR remaining_time;
163
165 UCHAR optional_fields_present;
166
167 } MS_GENERIC_POWER_LEVEL_STATUS_STRUCT;
168
172 typedef struct MS_generic_power_last_status_struct
173 {
175 UINT16 power;
176
177 } MS_GENERIC_POWER_LAST_STATUS_STRUCT;
178
182 typedef struct MS_generic_power_default_status_struct
183 {
185 UINT16 power;
186
187 } MS_GENERIC_POWER_DEFAULT_STATUS_STRUCT;
188
192 typedef struct MS_generic_power_range_status_struct
193 {
195 UCHAR status;
196
198 UINT16 range_min;
199
201 UINT16 range_max;
202
203 } MS_GENERIC_POWER_RANGE_STATUS_STRUCT;
204
208 typedef struct MS_generic_power_default_set_struct
209 {
211 UINT16 power;
212
213 } MS_GENERIC_POWER_DEFAULT_SET_STRUCT;
214
218 typedef struct MS_generic_power_range_set_struct
219 {
221 UINT16 range_min;
222
224 UINT16 range_max;
225
226 } MS_GENERIC_POWER_RANGE_SET_STRUCT;
231 /* --------------------------------------------- Function */
261 API_RESULT MS_generic_power_level_server_init
262 (
263 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
264 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
265 /* IN */ MS_GENERIC_POWER_LEVEL_SERVER_CB appl_cb
266 );
267
282 API_RESULT MS_generic_power_level_server_state_update
283 (
284 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
285 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
286 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
287 /* IN */ UINT16 remaining_time,
288 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
289 );
290
309 API_RESULT MS_generic_power_level_setup_server_init
310 (
311 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
312 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
313 /* IN */ MS_GENERIC_POWER_LEVEL_SETUP_SERVER_CB appl_cb
314 );
315
330 API_RESULT MS_generic_power_level_setup_server_state_update
331 (
332 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
333 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
334 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
335 /* IN */ UINT16 remaining_time,
336 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
337 );
364 API_RESULT MS_generic_power_level_client_init
365 (
366 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
367 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
368 /* IN */ MS_GENERIC_POWER_LEVEL_CLIENT_CB appl_cb
369 );
370
381 API_RESULT MS_generic_power_level_client_get_model_handle
382 (
383 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
384 );
385
398 API_RESULT MS_generic_power_level_client_send_reliable_pdu
399 (
400 /* IN */ UINT32 req_opcode,
401 /* IN */ void * param,
402 /* IN */ UINT32 rsp_opcode
403 );
404
416 #define MS_generic_power_range_set(param) \
417 MS_generic_power_level_client_send_reliable_pdu \
418 (\
419 MS_ACCESS_GENERIC_POWER_RANGE_SET_OPCODE,\
420 param,\
421 MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE\
422 )
423
435 #define MS_generic_power_level_set(param) \
436 MS_generic_power_level_client_send_reliable_pdu \
437 (\
438 MS_ACCESS_GENERIC_POWER_LEVEL_SET_OPCODE,\
439 param,\
440 MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE\
441 )
442
454 #define MS_generic_power_default_set(param) \
455 MS_generic_power_level_client_send_reliable_pdu \
456 (\
457 MS_ACCESS_GENERIC_POWER_DEFAULT_SET_OPCODE,\
458 param,\
459 MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE\
460 )
461
472 #define MS_generic_power_level_get() \
473 MS_generic_power_level_client_send_reliable_pdu \
474 (\
475 MS_ACCESS_GENERIC_POWER_LEVEL_GET_OPCODE,\
476 NULL,\
477 MS_ACCESS_GENERIC_POWER_LEVEL_STATUS_OPCODE\
478 )
479
490 #define MS_generic_power_default_get() \
491 MS_generic_power_level_client_send_reliable_pdu \
492 (\
493 MS_ACCESS_GENERIC_POWER_DEFAULT_GET_OPCODE,\
494 NULL,\
495 MS_ACCESS_GENERIC_POWER_DEFAULT_STATUS_OPCODE\
496 )
497
508 #define MS_generic_power_last_get() \
509 MS_generic_power_level_client_send_reliable_pdu \
510 (\
511 MS_ACCESS_GENERIC_POWER_LAST_GET_OPCODE,\
512 NULL,\
513 MS_ACCESS_GENERIC_POWER_LAST_STATUS_OPCODE\
514 )
515
526 #define MS_generic_power_range_get() \
527 MS_generic_power_level_client_send_reliable_pdu \
528 (\
529 MS_ACCESS_GENERIC_POWER_RANGE_GET_OPCODE,\
530 NULL,\
531 MS_ACCESS_GENERIC_POWER_RANGE_STATUS_OPCODE\
532 )
533
545 #define MS_generic_power_default_set_unacknowledged(param) \
546 MS_generic_power_level_client_send_reliable_pdu \
547 (\
548 MS_ACCESS_GENERIC_POWER_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
549 param,\
550 0xFFFFFFFF\
551 )
552
564 #define MS_generic_power_level_set_unacknowledged(param) \
565 MS_generic_power_level_client_send_reliable_pdu \
566 (\
567 MS_ACCESS_GENERIC_POWER_LEVEL_SET_UNACKNOWLEDGED_OPCODE,\
568 param,\
569 0xFFFFFFFF\
570 )
571
583 #define MS_generic_power_range_set_unacknowledged(param) \
584 MS_generic_power_level_client_send_reliable_pdu \
585 (\
586 MS_ACCESS_GENERIC_POWER_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
587 param,\
588 0xFFFFFFFF\
589 )
590
594 #endif /* _H_MS_GENERIC_POWER_LEVEL_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_power_onoff_api.h Source File

  • mesh
  • export
  • include
MS_generic_power_onoff_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_POWER_ONOFF_API_
14 #define _H_MS_GENERIC_POWER_ONOFF_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_GENERIC_POWER_ONOFF_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_GENERIC_POWER_ONOFF_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
79
92 typedef API_RESULT (* MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB)
93 (
94 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
95 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
96 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
97 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
98 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
99
100 ) DECL_REENTRANT;
111 typedef struct MS_generic_onpowerup_struct
112 {
124 UCHAR onpowerup;
125
126 } MS_GENERIC_ONPOWERUP_STRUCT;
127
132 /* --------------------------------------------- Function */
162 API_RESULT MS_generic_power_onoff_server_init
163 (
164 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
165 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
166 /* IN */ MS_GENERIC_POWER_ONOFF_SERVER_CB appl_cb
167 );
168
183 API_RESULT MS_generic_power_onoff_server_state_update
184 (
185 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
186 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
187 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
188 /* IN */ UINT16 remaining_time,
189 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
190 );
191
210 API_RESULT MS_generic_power_onoff_setup_server_init
211 (
212 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
213 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
214 /* IN */ MS_GENERIC_POWER_ONOFF_SETUP_SERVER_CB appl_cb
215 );
216
231 API_RESULT MS_generic_power_onoff_setup_server_state_update
232 (
233 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
234 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
235 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
236 /* IN */ UINT16 remaining_time,
237 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
238 );
265 API_RESULT MS_generic_power_onoff_client_init
266 (
267 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
268 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
269 /* IN */ MS_GENERIC_POWER_ONOFF_CLIENT_CB appl_cb
270 );
271
282 API_RESULT MS_generic_power_onoff_client_get_model_handle
283 (
284 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
285 );
286
299 API_RESULT MS_generic_power_onoff_client_send_reliable_pdu
300 (
301 /* IN */ UINT32 req_opcode,
302 /* IN */ void * param,
303 /* IN */ UINT32 rsp_opcode
304 );
305
317 #define MS_generic_onpowerup_set(param) \
318 MS_generic_power_onoff_client_send_reliable_pdu \
319 (\
320 MS_ACCESS_GENERIC_ONPOWERUP_SET_OPCODE,\
321 param,\
322 MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE\
323 )
324
336 #define MS_generic_onpowerup_set_unacknowledged(param) \
337 MS_generic_power_onoff_client_send_reliable_pdu \
338 (\
339 MS_ACCESS_GENERIC_ONPOWERUP_SET_UNACKNOWLEDGED_OPCODE,\
340 param,\
341 0xFFFFFFFF\
342 )
343
354 #define MS_generic_onpowerup_get() \
355 MS_generic_power_onoff_client_send_reliable_pdu \
356 (\
357 MS_ACCESS_GENERIC_ONPOWERUP_GET_OPCODE,\
358 NULL,\
359 MS_ACCESS_GENERIC_ONPOWERUP_STATUS_OPCODE\
360 )
361
365 #endif /* _H_MS_GENERIC_POWER_ONOFF_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_generic_property_api.h Source File

  • mesh
  • export
  • include
MS_generic_property_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_GENERIC_PROPERTY_API_
14 #define _H_MS_GENERIC_PROPERTY_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
30 #define MS_GENERIC_PROP_TYPE_MANUFACTURER 0x00
31
33 #define MS_GENERIC_PROP_TYPE_ADMIN 0x01
34
36 #define MS_GENERIC_PROP_TYPE_USER 0x02
37
39 #define MS_GENERIC_USER_ACCESS_PROHIBITED 0x00
40 #define MS_GENERIC_USER_ACCESS_READ 0x01
41 #define MS_GENERIC_USER_ACCESS_WRITE 0x02
42 #define MS_GENERIC_USER_ACCESS_READ_WRITE 0x03
43
44 #define MS_GENERIC_USER_ACCESS_INVALID_PROPERTY_ID 0xFF
45
47 #define MS_DEV_PROP_LIGHT_CONTROL_TIME_OCCUPANCY_DELAY 0x003A
48
50 #define MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_ON 0x0037
51
53 #define MS_DEV_PROP_LIGHT_CONTROL_TIME_RUN_ON 0x003C
54
56 #define MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE 0x0036
57
59 #define MS_DEV_PROP_LIGHT_CONTROL_TIME_PROLONG 0x003B
60
62 #define MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_AUTO 0x0038
63
65 #define MS_DEV_PROP_LIGHT_CONTROL_TIME_FADE_STANDBY_MANUAL 0x0039
66
68 #define MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_ON 0x002E
69
71 #define MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_PROLONG 0x002F
72
74 #define MS_DEV_PROP_LIGHT_CONTROL_LIGHTNESS_STANDBY 0x0030
75
77 #define MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_ON 0x002B
78
80 #define MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_PROLONG 0x002C
81
83 #define MS_DEV_PROP_LIGHT_CONTROL_AMBIENT_LUXLEVEL_STANDBY 0x002D
84
86 #define MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KIU 0x0033
87
89 #define MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KID 0x0032
90
92 #define MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPU 0x0035
93
95 #define MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_KPD 0x0034
96
98 #define MS_DEV_PROP_LIGHT_CONTROL_REGULATOR_ACCURACY 0x0031
99
101 #define MS_DEV_PROP_MOTION_SENSED 0x0042
102
104 #define MS_DEV_PROP_TIME_SINCE_MOTION_SENSED 0x0068
105
107 #define MS_DEV_PROP_PEOPLE_COUNT 0x004C
108
110 #define MS_DEV_PROP_PRESENCE_DETECTED 0x004D
111
113 #define MS_DEV_PROP_PRESENT_AMBIENT_LIGHT_LEVEL 0x004E
114
115
116 /* --------------------------------------------- Data Types/ Structures */
136 typedef API_RESULT (* MS_GENERIC_PROPERTY_SERVER_CB)
137 (
138 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
139 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
140 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
141 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
142 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
143
144 ) DECL_REENTRANT;
145
157 typedef API_RESULT (* MS_GENERIC_PROPERTY_CLIENT_CB)
158 (
159 MS_ACCESS_MODEL_HANDLE * handle,
160 UINT32 opcode,
161 UCHAR * data_param,
162 UINT16 data_len
163 ) DECL_REENTRANT;
174 typedef struct MS_generic_user_properties_status_struct
175 {
180 UINT16 *user_property_ids;
181
183 UINT16 user_property_ids_count;
184
185 } MS_GENERIC_USER_PROPERTIES_STATUS_STRUCT;
186
190 typedef struct MS_generic_user_property_get_struct
191 {
193 UINT16 user_property_id;
194
195 } MS_GENERIC_USER_PROPERTY_GET_STRUCT;
196
200 typedef struct MS_generic_user_property_set_struct
201 {
203 UINT16 user_property_id;
204
206 UCHAR *user_property_value;
207
208 /* Raw value length for the User Property */
209 UINT16 user_property_value_len;
210
211 } MS_GENERIC_USER_PROPERTY_SET_STRUCT;
212
216 typedef struct MS_generic_user_property_status_struct
217 {
219 UINT16 user_property_id;
220
222 UCHAR user_access;
223
225 UCHAR *user_property_value;
226
228 UINT16 user_property_value_len;
229
231 UCHAR optional_fields_present;
232
233 } MS_GENERIC_USER_PROPERTY_STATUS_STRUCT;
234
238 typedef struct MS_generic_admin_properties_status_struct
239 {
244 UINT16 *admin_property_ids;
245
247 UINT16 admin_property_ids_count;
248
249 } MS_GENERIC_ADMIN_PROPERTIES_STATUS_STRUCT;
250
254 typedef struct MS_generic_admin_property_get_struct
255 {
257 UINT16 admin_property_id;
258
259 } MS_GENERIC_ADMIN_PROPERTY_GET_STRUCT;
260
264 typedef struct MS_generic_admin_property_set_struct
265 {
267 UINT16 admin_property_id;
268
270 UCHAR admin_user_access;
271
273 UCHAR *admin_property_value;
274
276 UINT16 admin_property_value_len;
277
278 } MS_GENERIC_ADMIN_PROPERTY_SET_STRUCT;
279
283 typedef struct MS_generic_admin_property_status_struct
284 {
286 UINT16 admin_property_id;
287
289 UCHAR admin_user_access;
290
292 UCHAR *admin_property_value;
293
295 UINT16 admin_property_value_len;
296
297 } MS_GENERIC_ADMIN_PROPERTY_STATUS_STRUCT;
298
302 typedef struct MS_generic_manufacturer_properties_status_struct
303 {
308 UINT16 *manufacturer_property_ids;
309
311 UINT16 manufacturer_property_ids_count;
312
313 } MS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_STRUCT;
314
318 typedef struct MS_generic_manufacturer_property_get_struct
319 {
321 UINT16 manufacturer_property_id;
322
323 } MS_GENERIC_MANUFACTURER_PROPERTY_GET_STRUCT;
324
328 typedef struct MS_generic_manufacturer_property_set_struct
329 {
331 UINT16 manufacturer_property_id;
332
334 UCHAR manufacturer_user_access;
335
336 } MS_GENERIC_MANUFACTURER_PROPERTY_SET_STRUCT;
337
341 typedef struct MS_generic_manufacturer_property_status_struct
342 {
344 UINT16 manufacturer_property_id;
345
347 UCHAR manufacturer_user_access;
348
350 UCHAR *manufacturer_property_value;
351
353 UINT16 manufacturer_property_value_len;
354
355 } MS_GENERIC_MANUFACTURER_PROPERTY_STATUS_STRUCT;
356
360 typedef struct MS_generic_client_properties_get_struct
361 {
363 UINT16 client_property_id;
364
365 } MS_GENERIC_CLIENT_PROPERTIES_GET_STRUCT;
366
370 typedef struct MS_generic_client_properties_status_struct
371 {
376 UINT16 *client_property_ids;
377
379 UINT16 client_property_ids_count;
380
381 } MS_GENERIC_CLIENT_PROPERTIES_STATUS_STRUCT;
382
387 /* --------------------------------------------- Function */
417 API_RESULT MS_generic_user_property_server_init
418 (
419 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
420 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
421 /* IN */ MS_GENERIC_PROPERTY_SERVER_CB appl_cb
422 );
423
442 API_RESULT MS_generic_admin_property_server_init
443 (
444 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
445 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
446 /* IN */ MS_GENERIC_PROPERTY_SERVER_CB appl_cb
447 );
448
467 API_RESULT MS_generic_manufacturer_property_server_init
468 (
469 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
470 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
471 /* IN */ MS_GENERIC_PROPERTY_SERVER_CB appl_cb
472 );
473
492 API_RESULT MS_generic_client_property_server_init
493 (
494 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
495 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
496 /* IN */ MS_GENERIC_PROPERTY_SERVER_CB appl_cb
497 );
498
513 API_RESULT MS_generic_user_property_server_state_update
514 (
515 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
516 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
517 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
518 /* IN */ UINT16 remaining_time,
519 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
520 );
521
536 API_RESULT MS_generic_admin_property_server_state_update
537 (
538 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
539 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
540 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
541 /* IN */ UINT16 remaining_time,
542 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
543 );
544
559 API_RESULT MS_generic_manufacturer_property_server_state_update
560 (
561 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
562 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
563 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
564 /* IN */ UINT16 remaining_time,
565 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
566 );
567
582 API_RESULT MS_generic_client_property_server_state_update
583 (
584 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
585 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
586 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
587 /* IN */ UINT16 remaining_time,
588 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
589 );
590
617 API_RESULT MS_generic_property_client_init
618 (
619 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
620 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
621 /* IN */ MS_GENERIC_PROPERTY_CLIENT_CB appl_cb
622 );
623
634 API_RESULT MS_generic_property_client_get_model_handle
635 (
636 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
637 );
638
651 API_RESULT MS_generic_property_client_send_reliable_pdu
652 (
653 /* IN */ UINT32 req_opcode,
654 /* IN */ void * param,
655 /* IN */ UINT32 rsp_opcode
656 );
657
668 #define MS_generic_admin_properties_get() \
669 MS_generic_property_client_send_reliable_pdu \
670 (\
671 MS_ACCESS_GENERIC_ADMIN_PROPERTIES_GET_OPCODE,\
672 NULL,\
673 MS_ACCESS_GENERIC_ADMIN_PROPERTIES_STATUS_OPCODE\
674 )
675
687 #define MS_generic_admin_property_set(param) \
688 MS_generic_property_client_send_reliable_pdu \
689 (\
690 MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_OPCODE,\
691 param,\
692 MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE\
693 )
694
706 #define MS_generic_user_property_set(param) \
707 MS_generic_property_client_send_reliable_pdu \
708 (\
709 MS_ACCESS_GENERIC_USER_PROPERTY_SET_OPCODE,\
710 param,\
711 MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE\
712 )
713
725 #define MS_generic_client_properties_get(param) \
726 MS_generic_property_client_send_reliable_pdu \
727 (\
728 MS_ACCESS_GENERIC_CLIENT_PROPERTIES_GET_OPCODE,\
729 param,\
730 MS_ACCESS_GENERIC_CLIENT_PROPERTIES_STATUS_OPCODE\
731 )
732
744 #define MS_generic_manufacturer_property_get(param) \
745 MS_generic_property_client_send_reliable_pdu \
746 (\
747 MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_GET_OPCODE,\
748 param,\
749 MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE\
750 )
751
763 #define MS_generic_user_property_set_unacknowledged(param) \
764 MS_generic_property_client_send_reliable_pdu \
765 (\
766 MS_ACCESS_GENERIC_USER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
767 param,\
768 0xFFFFFFFF\
769 )
770
782 #define MS_generic_manufacturer_property_set(param) \
783 MS_generic_property_client_send_reliable_pdu \
784 (\
785 MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_OPCODE,\
786 param,\
787 MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_STATUS_OPCODE\
788 )
789
801 #define MS_generic_admin_property_set_unacknowledged(param) \
802 MS_generic_property_client_send_reliable_pdu \
803 (\
804 MS_ACCESS_GENERIC_ADMIN_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
805 param,\
806 0xFFFFFFFF\
807 )
808
821 #define MS_generic_manufacturer_properties_get() \
822 MS_generic_property_client_send_reliable_pdu \
823 (\
824 MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_GET_OPCODE,\
825 NULL,\
826 MS_ACCESS_GENERIC_MANUFACTURER_PROPERTIES_STATUS_OPCODE\
827 )
828
840 #define MS_generic_user_property_get(param) \
841 MS_generic_property_client_send_reliable_pdu \
842 (\
843 MS_ACCESS_GENERIC_USER_PROPERTY_GET_OPCODE,\
844 param,\
845 MS_ACCESS_GENERIC_USER_PROPERTY_STATUS_OPCODE\
846 )
847
859 #define MS_generic_admin_property_get(param) \
860 MS_generic_property_client_send_reliable_pdu \
861 (\
862 MS_ACCESS_GENERIC_ADMIN_PROPERTY_GET_OPCODE,\
863 param,\
864 MS_ACCESS_GENERIC_ADMIN_PROPERTY_STATUS_OPCODE\
865 )
866
877 #define MS_generic_manufacturer_property_set_unacknowledged(param) \
878 MS_generic_property_client_send_reliable_pdu \
879 (\
880 MS_ACCESS_GENERIC_MANUFACTURER_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
881 param,\
882 0xFFFFFFFF\
883 )
884
895 #define MS_generic_user_properties_get() \
896 MS_generic_property_client_send_reliable_pdu \
897 (\
898 MS_ACCESS_GENERIC_USER_PROPERTIES_GET_OPCODE,\
899 NULL,\
900 MS_ACCESS_GENERIC_USER_PROPERTIES_STATUS_OPCODE\
901 )
902
906 #endif /*_H_MS_GENERIC_PROPERTY_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_health_client_api.h Source File

  • mesh
  • export
  • include
MS_health_client_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_HEALTH_CLIENT_API_
14 #define _H_MS_HEALTH_CLIENT_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
50 typedef API_RESULT (* MS_HEALTH_CLIENT_CB)
51 (
52 MS_ACCESS_MODEL_HANDLE * handle,
53 UINT32 opcode,
54 UCHAR * data_param,
55 UINT16 data_len
56 ) DECL_REENTRANT;
67 typedef struct MS_health_status_struct
68 {
70 UCHAR test_id;
71
73 UINT16 company_id;
74
76 UCHAR *faultarray;
77
79 UINT16 faultarray_len;
80
81 } MS_HEALTH_STATUS_STRUCT;
82
86 typedef struct MS_health_fault_get_clear_struct
87 {
89 UINT16 company_id;
90
91 } MS_HEALTH_FAULT_GET_CLEAR_STRUCT;
92
96 typedef struct MS_health_fault_test_struct
97 {
99 UCHAR test_id;
100
102 UINT16 company_id;
103
104 } MS_HEALTH_FAULT_TEST_STRUCT;
105
109 typedef struct MS_health_period_struct
110 {
116 UCHAR fastperioddivisor;
117
118 } MS_HEALTH_PERIOD_STRUCT;
119
123 typedef struct MS_health_attention_struct
124 {
126 UCHAR attention;
127
128 } MS_HEALTH_ATTENTION_STRUCT;
129
134 /* --------------------------------------------- Function */
164 API_RESULT MS_health_client_init
165 (
166 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
167 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
168 /* IN */ MS_HEALTH_CLIENT_CB appl_cb
169 );
170
181 API_RESULT MS_health_client_get_model_handle
182 (
183 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
184 );
185
198 API_RESULT MS_health_client_send_reliable_pdu
199 (
200 /* IN */ UINT32 req_opcode,
201 /* IN */ void * param,
202 /* IN */ UINT32 rsp_opcode
203 );
204
217 #define MS_health_period_set_unacknowledged(param) \
218 MS_health_client_send_reliable_pdu \
219 (\
220 MS_ACCESS_HEALTH_PERIOD_SET_UNACKNOWLEDGED_OPCODE,\
221 param,\
222 0xFFFFFFFF\
223 )
224
237 #define MS_health_attention_set(param) \
238 MS_health_client_send_reliable_pdu \
239 (\
240 MS_ACCESS_HEALTH_ATTENTION_SET_OPCODE,\
241 param,\
242 MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE\
243 )
244
257 #define MS_health_fault_clear_unacknowledged(param) \
258 MS_health_client_send_reliable_pdu \
259 (\
260 MS_ACCESS_HEALTH_FAULT_CLEAR_UNACKNOWLEDGED_OPCODE,\
261 param,\
262 0xFFFFFFFF\
263 )
264
277 #define MS_health_attention_set_unacknowledged(param) \
278 MS_health_client_send_reliable_pdu \
279 (\
280 MS_ACCESS_HEALTH_ATTENTION_SET_UNACKNOWLEDGED_OPCODE,\
281 param,\
282 0xFFFFFFFF\
283 )
284
294 #define MS_health_attention_get() \
295 MS_health_client_send_reliable_pdu \
296 (\
297 MS_ACCESS_HEALTH_ATTENTION_GET_OPCODE,\
298 NULL,\
299 MS_ACCESS_HEALTH_ATTENTION_STATUS_OPCODE\
300 )
301
315 #define MS_health_fault_test(param) \
316 MS_health_client_send_reliable_pdu \
317 (\
318 MS_ACCESS_HEALTH_FAULT_TEST_OPCODE,\
319 param,\
320 MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE\
321 )
322
333 #define MS_health_fault_test_unacknowledged(param) \
334 MS_health_client_send_reliable_pdu \
335 (\
336 MS_ACCESS_HEALTH_FAULT_TEST_UNACKNOWLEDGED_OPCODE,\
337 param,\
338 0xFFFFFFFF\
339 )
340
353 #define MS_health_fault_clear(param) \
354 MS_health_client_send_reliable_pdu \
355 (\
356 MS_ACCESS_HEALTH_FAULT_CLEAR_OPCODE,\
357 param,\
358 MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE\
359 )
360
373 #define MS_health_fault_get(param) \
374 MS_health_client_send_reliable_pdu \
375 (\
376 MS_ACCESS_HEALTH_FAULT_GET_OPCODE,\
377 param,\
378 MS_ACCESS_HEALTH_FAULT_STATUS_OPCODE\
379 )
380
390 #define MS_health_period_get() \
391 MS_health_client_send_reliable_pdu \
392 (\
393 MS_ACCESS_HEALTH_PERIOD_GET_OPCODE,\
394 NULL,\
395 MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE\
396 )
397
410 #define MS_health_period_set(param) \
411 MS_health_client_send_reliable_pdu \
412 (\
413 MS_ACCESS_HEALTH_PERIOD_SET_OPCODE,\
414 param,\
415 MS_ACCESS_HEALTH_PERIOD_STATUS_OPCODE\
416 )
417
421 #endif /* _H_MS_HEALTH_CLIENT_API_ */
422


EtherMind Mesh SDK (beta): mesh/export/include/MS_health_server_api.h Source File

  • mesh
  • export
  • include
MS_health_server_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_HEALTH_SERVER_API_
14 #define _H_MS_HEALTH_SERVER_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
30 #define MS_HEALTH_FAULT_NO_FAULT 0x00
31
32 #define MS_HEALTH_FAULT_BATTERY_LOW_WARNING 0x01
33
34 #define MS_HEALTH_FAULT_BATTERY_LOW_ERROR 0x02
35
36 #define MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_WARNING 0x03
37
38 #define MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_LOW_ERROR 0x04
39
40 #define MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_WARNING 0x05
41
42 #define MS_HEALTH_FAULT_SUPPLY_VOLTAGE_TOO_HIGH_ERROR 0x06
43
44 #define MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_WARNING 0x07
45
46 #define MS_HEALTH_FAULT_POWER_SUPPLY_INTERRUPTED_ERROR 0x08
47
48 #define MS_HEALTH_FAULT_NO_LOAD_WARNING 0x09
49
50 #define MS_HEALTH_FAULT_NO_LOAD_ERROR 0x0A
51
52 #define MS_HEALTH_FAULT_OVERLOAD_WARNING 0x0B
53
54 #define MS_HEALTH_FAULT_OVERLOAD_ERROR 0x0C
55
56 #define MS_HEALTH_FAULT_OVERHEAT_WARNING 0x0D
57
58 #define MS_HEALTH_FAULT_OVERHEAT_ERROR 0x0E
59
60 #define MS_HEALTH_FAULT_CONDENSATION_WARNING 0x0F
61
62 #define MS_HEALTH_FAULT_CONDENSATION_ERROR 0x10
63
64 #define MS_HEALTH_FAULT_VIBRATION_WARNING 0x11
65
66 #define MS_HEALTH_FAULT_VIBRATION_ERROR 0x12
67
68 #define MS_HEALTH_FAULT_CONFIGURATION_WARNING 0x13
69
70 #define MS_HEALTH_FAULT_CONFIGURATION_ERROR 0x14
71
72 #define MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_WARNING 0x15
73
74 #define MS_HEALTH_FAULT_ELEMENT_NOT_CALIBRATED_ERROR 0x16
75
76 #define MS_HEALTH_FAULT_MEMORY_WARNING 0x17
77
78 #define MS_HEALTH_FAULT_MEMORY_ERROR 0x18
79
80 #define MS_HEALTH_FAULT_SELF_TEST_WARNING 0x19
81
82 #define MS_HEALTH_FAULT_SELF_TEST_ERROR 0x1A
83
84 #define MS_HEALTH_FAULT_INPUT_TOO_LOW_WARNING 0x1B
85
86 #define MS_HEALTH_FAULT_INPUT_TOO_LOW_ERROR 0x1C
87
88 #define MS_HEALTH_FAULT_INPUT_TOO_HIGH_WARNING 0x1D
89
90 #define MS_HEALTH_FAULT_INPUT_TOO_HIGH_ERROR 0x1E
91
92 #define MS_HEALTH_FAULT_INPUT_NO_CHANGE_WARNING 0x1F
93
94 #define MS_HEALTH_FAULT_INPUT_NO_CHANGE_ERROR 0x20
95
96 #define MS_HEALTH_FAULT_ACTUATOR_BLOCKED_WARNING 0x21
97
98 #define MS_HEALTH_FAULT_ACTUATOR_BLOCKED_ERROR 0x22
99
100 #define MS_HEALTH_FAULT_HOUSING_OPENED_WARNING 0x23
101
102 #define MS_HEALTH_FAULT_HOUSING_OPENED_ERROR 0x24
103
104 #define MS_HEALTH_FAULT_TAMPER_WARNING 0x25
105
106 #define MS_HEALTH_FAULT_TAMPER_ERROR 0x26
107
108 #define MS_HEALTH_FAULT_DEVICE_MOVED_WARNING 0x27
109
110 #define MS_HEALTH_FAULT_DEVICE_MOVED_ERROR 0x28
111
112 #define MS_HEALTH_FAULT_DEVICE_DROPPED_WARNING 0x29
113
114 #define MS_HEALTH_FAULT_DEVICE_DROPPED_ERROR 0x2A
115
116 #define MS_HEALTH_FAULT_OVERFLOW_WARNING 0x2B
117
118 #define MS_HEALTH_FAULT_OVERFLOW_ERROR 0x2C
119
120 #define MS_HEALTH_FAULT_EMPTY_WARNING 0x2D
121
122 #define MS_HEALTH_FAULT_EMPTY_ERROR 0x2E
123
124 #define MS_HEALTH_FAULT_INTERNAL_BUS_WARNING 0x2F
125
126 #define MS_HEALTH_FAULT_INTERNAL_BUS_ERROR 0x30
127
128 #define MS_HEALTH_FAULT_MECHANISM_JAMMED_WARNING 0x31
129
130 #define MS_HEALTH_FAULT_MECHANISM_JAMMED_ERROR 0x32
131
132 /* 0x33 - 0x7F: Reserved for Future Use */
133 /* 0x80 - 0xFF: Vendor Specific Warning / Error */
134
144 #define MS_HEALTH_SERVER_ATTENTION_START 0x01
145
147 #define MS_HEALTH_SERVER_ATTENTION_RESTART 0x02
148
150 #define MS_HEALTH_SERVER_ATTENTION_STOP 0x03
151
155 /* --------------------------------------------- Data Types/ Structures */
168 typedef API_RESULT (* MS_HEALTH_SERVER_CB)
169 (
170 MS_ACCESS_MODEL_HANDLE * handle,
171 UINT8 event_type,
172 UINT8 * event_param,
173 UINT16 param_len
174 ) DECL_REENTRANT;
175
176
180 /* TODO: Add context of the Health Server, so that associated current/registered fault can be updated */
181 typedef void (* MS_HEALTH_SERVER_SELF_TEST_FN)(UINT8 test_id, UINT16 company_id);
182
186 typedef struct _MS_HEALTH_SERVER_SELF_TEST
187 {
189 UINT8 test_id;
190
192 MS_HEALTH_SERVER_SELF_TEST_FN self_test_fn;
193
194 }MS_HEALTH_SERVER_SELF_TEST;
195
196
197 /* --------------------------------------------- Function */
225 API_RESULT MS_health_server_init
226 (
227 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
228 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
229 /* IN */ UINT16 company_id,
230 /* IN */ MS_HEALTH_SERVER_SELF_TEST * self_tests,
231 /* IN */ UINT32 num_self_tests,
232 /* IN */ MS_HEALTH_SERVER_CB appl_cb
233 );
234
255 API_RESULT MS_health_server_report_fault
256 (
257 /* IN */ MS_ACCESS_MODEL_HANDLE * model_handle,
258 /* IN */ UINT8 test_id,
259 /* IN */ UINT16 company_id,
260 /* IN */ UINT8 fault_code
261 );
262
267 API_RESULT MS_health_server_publish_current_status
268 (
269 UCHAR * status,
270 UINT16 length
271 );
276 #endif /*_H_MS_HEALTH_SERVER_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_ctl_api.h Source File

  • mesh
  • export
  • include
MS_light_ctl_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_LIGHT_CTL_API_
14 #define _H_MS_LIGHT_CTL_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_LIGHT_CTL_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
73 typedef API_RESULT (* MS_LIGHT_CTL_TEMPERATURE_SERVER_CB)
74 (
75 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
76 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
77 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
78 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
79 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
80
81 ) DECL_REENTRANT;
82
94 typedef API_RESULT (* MS_LIGHT_CTL_CLIENT_CB)
95 (
96 MS_ACCESS_MODEL_HANDLE * handle,
97 UINT32 opcode,
98 UCHAR * data_param,
99 UINT16 data_len
100 ) DECL_REENTRANT;
111 typedef struct MS_light_ctl_set_struct
112 {
114 UINT16 ctl_lightness;
115
117 UINT16 ctl_temperature;
118
120 UINT16 ctl_delta_uv;
121
123 UCHAR tid;
124
136 UCHAR transition_time;
137
139 UCHAR delay;
140
142 UCHAR optional_fields_present;
143
144 } MS_LIGHT_CTL_SET_STRUCT;
145
149 typedef struct MS_light_ctl_status_struct
150 {
152 UINT16 present_ctl_lightness;
153
155 UINT16 present_ctl_temperature;
156
158 UINT16 target_ctl_lightness;
159
161 UINT16 target_ctl_temperature;
162
174 UCHAR remaining_time;
175
177 UCHAR optional_fields_present;
178
179 } MS_LIGHT_CTL_STATUS_STRUCT;
180
184 typedef struct MS_light_ctl_temperature_set_struct
185 {
187 UINT16 ctl_temperature;
188
190 UINT16 ctl_delta_uv;
191
193 UCHAR tid;
194
206 UCHAR transition_time;
207
209 UCHAR delay;
210
212 UCHAR optional_fields_present;
213
214 } MS_LIGHT_CTL_TEMPERATURE_SET_STRUCT;
215
219 typedef struct MS_light_ctl_temperature_status_struct
220 {
222 UINT16 present_ctl_temperature;
223
225 UINT16 present_ctl_delta_uv;
226
228 UINT16 target_ctl_temperature;
229
231 UINT16 target_ctl_delta_uv;
232
244 UCHAR remaining_time;
245
247 UCHAR optional_fields_present;
248
249 } MS_LIGHT_CTL_TEMPERATURE_STATUS_STRUCT;
250
254 typedef struct MS_light_ctl_default_set_struct
255 {
257 UINT16 lightness;
258
260 UINT16 temperature;
261
263 UINT16 delta_uv;
264
265 } MS_LIGHT_CTL_DEFAULT_SET_STRUCT;
266
270 typedef struct MS_light_ctl_default_status_struct
271 {
273 UINT16 lightness;
274
276 UINT16 temperature;
277
279 UINT16 delta_uv;
280
281 } MS_LIGHT_CTL_DEFAULT_STATUS_STRUCT;
282
286 typedef struct MS_light_ctl_temperature_range_set_struct
287 {
289 UINT16 range_min;
290
292 UINT16 range_max;
293
294 } MS_LIGHT_CTL_TEMPERATURE_RANGE_SET_STRUCT;
295
299 typedef struct MS_light_ctl_temperature_range_status_struct
300 {
302 UCHAR status_code;
303
305 UINT16 range_min;
306
308 UINT16 range_max;
309
310 } MS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_STRUCT;
311
316 /* --------------------------------------------- Function */
351 API_RESULT MS_light_ctl_server_init
352 (
353 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
354 /* INOUT */ MS_ACCESS_MODEL_HANDLE * ctl_model_handle,
355 /* INOUT */ MS_ACCESS_MODEL_HANDLE * ctl_setup_model_handle,
356 /* IN */ MS_LIGHT_CTL_SERVER_CB appl_cb
357 );
358
377 API_RESULT MS_light_ctl_temperature_server_init
378 (
379 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
380 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
381 /* IN */ MS_LIGHT_CTL_TEMPERATURE_SERVER_CB appl_cb
382 );
383
398 API_RESULT MS_light_ctl_server_state_update
399 (
400 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
401 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
402 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
403 /* IN */ UINT16 remaining_time,
404 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
405 );
406
421 API_RESULT MS_light_ctl_temperature_server_state_update
422 (
423 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
424 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
425 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
426 /* IN */ UINT16 remaining_time,
427 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
428 );
429
456 API_RESULT MS_light_ctl_client_init
457 (
458 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
459 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
460 /* IN */ MS_LIGHT_CTL_CLIENT_CB appl_cb
461 );
462
473 API_RESULT MS_light_ctl_client_get_model_handle
474 (
475 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
476 );
477
490 API_RESULT MS_light_ctl_client_send_reliable_pdu
491 (
492 /* IN */ UINT32 req_opcode,
493 /* IN */ void * param,
494 /* IN */ UINT32 rsp_opcode
495 );
496
509 #define MS_light_ctl_set(param) \
510 MS_light_ctl_client_send_reliable_pdu \
511 (\
512 MS_ACCESS_LIGHT_CTL_SET_OPCODE,\
513 param,\
514 MS_ACCESS_LIGHT_CTL_STATUS_OPCODE\
515 )
516
527 #define MS_light_ctl_default_get() \
528 MS_light_ctl_client_send_reliable_pdu \
529 (\
530 MS_ACCESS_LIGHT_CTL_DEFAULT_GET_OPCODE,\
531 NULL,\
532 MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE\
533 )
534
546 #define MS_light_ctl_set_unacknowledged(param) \
547 MS_light_ctl_client_send_reliable_pdu \
548 (\
549 MS_ACCESS_LIGHT_CTL_SET_UNACKNOWLEDGED_OPCODE,\
550 param,\
551 0xFFFFFFFF\
552 )
553
565 #define MS_light_ctl_temperature_range_set_unacknowledged(param) \
566 MS_light_ctl_client_send_reliable_pdu \
567 (\
568 MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
569 param,\
570 0xFFFFFFFF\
571 )
572
584 #define MS_light_ctl_default_set_unacknowledged(param) \
585 MS_light_ctl_client_send_reliable_pdu \
586 (\
587 MS_ACCESS_LIGHT_CTL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
588 param,\
589 0xFFFFFFFF\
590 )
591
602 #define MS_light_ctl_temperature_get() \
603 MS_light_ctl_client_send_reliable_pdu \
604 (\
605 MS_ACCESS_LIGHT_CTL_TEMPERATURE_GET_OPCODE,\
606 NULL,\
607 MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE\
608 )
609
621 #define MS_light_ctl_temperature_range_set(param) \
622 MS_light_ctl_client_send_reliable_pdu \
623 (\
624 MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_SET_OPCODE,\
625 param,\
626 MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE\
627 )
628
639 #define MS_light_ctl_get() \
640 MS_light_ctl_client_send_reliable_pdu \
641 (\
642 MS_ACCESS_LIGHT_CTL_GET_OPCODE,\
643 NULL,\
644 MS_ACCESS_LIGHT_CTL_STATUS_OPCODE\
645 )
646
659 #define MS_light_ctl_default_set(param) \
660 MS_light_ctl_client_send_reliable_pdu \
661 (\
662 MS_ACCESS_LIGHT_CTL_DEFAULT_SET_OPCODE,\
663 param,\
664 MS_ACCESS_LIGHT_CTL_DEFAULT_STATUS_OPCODE\
665 )
666
677 #define MS_light_ctl_temperature_range_get() \
678 MS_light_ctl_client_send_reliable_pdu \
679 (\
680 MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_GET_OPCODE,\
681 NULL,\
682 MS_ACCESS_LIGHT_CTL_TEMPERATURE_RANGE_STATUS_OPCODE\
683 )
684
697 #define MS_light_ctl_temperature_set(param) \
698 MS_light_ctl_client_send_reliable_pdu \
699 (\
700 MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_OPCODE,\
701 param,\
702 MS_ACCESS_LIGHT_CTL_TEMPERATURE_STATUS_OPCODE\
703 )
704
716 #define MS_light_ctl_temperature_set_unacknowledged(param) \
717 MS_light_ctl_client_send_reliable_pdu \
718 (\
719 MS_ACCESS_LIGHT_CTL_TEMPERATURE_SET_UNACKNOWLEDGED_OPCODE,\
720 param,\
721 0xFFFFFFFF\
722 )
723
727 #endif /*_H_MS_LIGHT_CTL_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_hsl_api.h Source File

  • mesh
  • export
  • include
MS_light_hsl_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_LIGHT_HSL_API_
14 #define _H_MS_LIGHT_HSL_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_LIGHT_HSL_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
73 typedef API_RESULT (* MS_LIGHT_HSL_HUE_SERVER_CB)
74 (
75 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
76 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
77 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
78 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
79 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
80
81 ) DECL_REENTRANT;
82
95 typedef API_RESULT (* MS_LIGHT_HSL_SATURATION_SERVER_CB)
96 (
97 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
98 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
99 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
100 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
101 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
102
103 ) DECL_REENTRANT;
104
116 typedef API_RESULT (* MS_LIGHT_HSL_CLIENT_CB)
117 (
118 MS_ACCESS_MODEL_HANDLE * handle,
119 UINT32 opcode,
120 UCHAR * data_param,
121 UINT16 data_len
122 ) DECL_REENTRANT;
133 typedef struct MS_light_hsl_set_struct
134 {
136 UINT16 hsl_lightness;
137
139 UINT16 hsl_hue;
140
142 UINT16 hsl_saturation;
143
145 UCHAR tid;
146
158 UCHAR transition_time;
159
161 UCHAR delay;
162
164 UCHAR optional_fields_present;
165
166 } MS_LIGHT_HSL_SET_STRUCT;
167
171 typedef struct MS_light_hsl_status_struct
172 {
174 UINT16 hsl_lightness;
175
177 UINT16 hsl_hue;
178
180 UINT16 hsl_saturation;
181
193 UCHAR remaining_time;
194
196 UCHAR optional_fields_present;
197
198 } MS_LIGHT_HSL_STATUS_STRUCT;
199
203 typedef struct MS_light_hsl_target_status_struct
204 {
206 UINT16 hsl_lightness_target;
207
209 UINT16 hsl_hue_target;
210
212 UINT16 hsl_saturation_target;
213
225 UCHAR remaining_time;
226
228 UCHAR optional_fields_present;
229
230 } MS_LIGHT_HSL_TARGET_STATUS_STRUCT;
231
235 typedef struct MS_light_hsl_default_set_struct
236 {
238 UINT16 lightness;
239
241 UINT16 hue;
242
244 UINT16 saturation;
245
246 } MS_LIGHT_HSL_DEFAULT_SET_STRUCT;
247
251 typedef struct MS_light_hsl_default_status_struct
252 {
254 UINT16 lightness;
255
257 UINT16 hue;
258
260 UINT16 saturation;
261
262 } MS_LIGHT_HSL_DEFAULT_STATUS_STRUCT;
263
267 typedef struct MS_light_hsl_range_set_struct
268 {
270 UINT16 hue_range_min;
271
273 UINT16 hue_range_max;
274
276 UINT16 saturation_range_min;
277
279 UINT16 saturation_range_max;
280
281 } MS_LIGHT_HSL_RANGE_SET_STRUCT;
282
286 typedef struct MS_light_hsl_range_status_struct
287 {
289 UCHAR status_code;
290
292 UINT16 hue_range_min;
293
295 UINT16 hue_range_max;
296
298 UINT16 saturation_range_min;
299
301 UINT16 saturation_range_max;
302
303 } MS_LIGHT_HSL_RANGE_STATUS_STRUCT;
304
308 typedef struct MS_light_hsl_hue_set_struct
309 {
311 UINT16 hue;
312
314 UCHAR tid;
315
327 UCHAR transition_time;
328
330 UCHAR delay;
331
333 UCHAR optional_fields_present;
334
335 } MS_LIGHT_HSL_HUE_SET_STRUCT;
336
340 typedef struct MS_light_hsl_hue_status_struct
341 {
343 UINT16 present_hue;
344
346 UINT16 target_hue;
347
359 UCHAR remaining_time;
360
362 UCHAR optional_fields_present;
363
364 } MS_LIGHT_HSL_HUE_STATUS_STRUCT;
365
369 typedef struct MS_light_hsl_saturation_set_struct
370 {
372 UINT16 saturation;
373
375 UCHAR tid;
376
388 UCHAR transition_time;
389
391 UCHAR delay;
392
394 UCHAR optional_fields_present;
395
396 } MS_LIGHT_HSL_SATURATION_SET_STRUCT;
397
401 typedef struct MS_light_hsl_saturation_status_struct
402 {
404 UINT16 present_saturation;
405
407 UINT16 target_saturation;
408
420 UCHAR remaining_time;
421
423 UCHAR optional_fields_present;
424
425 } MS_LIGHT_HSL_SATURATION_STATUS_STRUCT;
426
431 /* --------------------------------------------- Function */
466 API_RESULT MS_light_hsl_server_init
467 (
468 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
469 /* INOUT */ MS_ACCESS_MODEL_HANDLE * hsl_model_handle,
470 /* INOUT */ MS_ACCESS_MODEL_HANDLE * hsl_setup_model_handle,
471 /* IN */ MS_LIGHT_HSL_SERVER_CB appl_cb
472 );
473
492 API_RESULT MS_light_hsl_hue_server_init
493 (
494 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
495 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
496 /* IN */ MS_LIGHT_HSL_HUE_SERVER_CB appl_cb
497 );
498
517 API_RESULT MS_light_hsl_saturation_server_init
518 (
519 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
520 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
521 /* IN */ MS_LIGHT_HSL_SATURATION_SERVER_CB appl_cb
522 );
523
538 API_RESULT MS_light_hsl_server_state_update
539 (
540 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
541 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
542 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
543 /* IN */ UINT16 remaining_time,
544 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
545 );
546
561 API_RESULT MS_light_hsl_hue_server_state_update
562 (
563 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
564 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
565 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
566 /* IN */ UINT16 remaining_time,
567 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
568 );
569
584 API_RESULT MS_light_hsl_saturation_server_state_update
585 (
586 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
587 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
588 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
589 /* IN */ UINT16 remaining_time,
590 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
591 );
618 API_RESULT MS_light_hsl_client_init
619 (
620 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
621 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
622 /* IN */ MS_LIGHT_HSL_CLIENT_CB appl_cb
623 );
624
635 API_RESULT MS_light_hsl_client_get_model_handle
636 (
637 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
638 );
639
652 API_RESULT MS_light_hsl_client_send_reliable_pdu
653 (
654 /* IN */ UINT32 req_opcode,
655 /* IN */ void * param,
656 /* IN */ UINT32 rsp_opcode
657 );
658
669 #define MS_light_hsl_hue_get() \
670 MS_light_hsl_client_send_reliable_pdu \
671 (\
672 MS_ACCESS_LIGHT_HSL_HUE_GET_OPCODE,\
673 NULL,\
674 MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE\
675 )
676
689 #define MS_light_hsl_set_unacknowledged(param) \
690 MS_light_hsl_client_send_reliable_pdu \
691 (\
692 MS_ACCESS_LIGHT_HSL_SET_UNACKNOWLEDGED_OPCODE,\
693 param,\
694 0xFFFFFFFF\
695 )
696
707 #define MS_light_hsl_range_get() \
708 MS_light_hsl_client_send_reliable_pdu \
709 (\
710 MS_ACCESS_LIGHT_HSL_RANGE_GET_OPCODE,\
711 NULL,\
712 MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE\
713 )
714
725 #define MS_light_hsl_range_set_unacknowledged(param) \
726 MS_light_hsl_client_send_reliable_pdu \
727 (\
728 MS_ACCESS_LIGHT_HSL_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
729 param,\
730 0xFFFFFFFF\
731 )
732
745 #define MS_light_hsl_default_set(param) \
746 MS_light_hsl_client_send_reliable_pdu \
747 (\
748 MS_ACCESS_LIGHT_HSL_DEFAULT_SET_OPCODE,\
749 param,\
750 MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE\
751 )
752
764 #define MS_light_hsl_saturation_set_unacknowledged(param) \
765 MS_light_hsl_client_send_reliable_pdu \
766 (\
767 MS_ACCESS_LIGHT_HSL_SATURATION_SET_UNACKNOWLEDGED_OPCODE,\
768 param,\
769 0xFFFFFFFF\
770 )
771
783 #define MS_light_hsl_set(param) \
784 MS_light_hsl_client_send_reliable_pdu \
785 (\
786 MS_ACCESS_LIGHT_HSL_SET_OPCODE,\
787 param,\
788 MS_ACCESS_LIGHT_HSL_STATUS_OPCODE\
789 )
790
801 #define MS_light_hsl_saturation_get() \
802 MS_light_hsl_client_send_reliable_pdu \
803 (\
804 MS_ACCESS_LIGHT_HSL_SATURATION_GET_OPCODE,\
805 NULL,\
806 MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE\
807 )
808
820 #define MS_light_hsl_default_get() \
821 MS_light_hsl_client_send_reliable_pdu \
822 (\
823 MS_ACCESS_LIGHT_HSL_DEFAULT_GET_OPCODE,\
824 NULL,\
825 MS_ACCESS_LIGHT_HSL_DEFAULT_STATUS_OPCODE\
826 )
827
839 #define MS_light_hsl_default_set_unacknowledged(param) \
840 MS_light_hsl_client_send_reliable_pdu \
841 (\
842 MS_ACCESS_LIGHT_HSL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
843 param,\
844 0xFFFFFFFF\
845 )
846
858 #define MS_light_hsl_hue_set(param) \
859 MS_light_hsl_client_send_reliable_pdu \
860 (\
861 MS_ACCESS_LIGHT_HSL_HUE_SET_OPCODE,\
862 param,\
863 MS_ACCESS_LIGHT_HSL_HUE_STATUS_OPCODE\
864 )
865
877 #define MS_light_hsl_range_set(param) \
878 MS_light_hsl_client_send_reliable_pdu \
879 (\
880 MS_ACCESS_LIGHT_HSL_RANGE_SET_OPCODE,\
881 param,\
882 MS_ACCESS_LIGHT_HSL_RANGE_STATUS_OPCODE\
883 )
884
896 #define MS_light_hsl_saturation_set(param) \
897 MS_light_hsl_client_send_reliable_pdu \
898 (\
899 MS_ACCESS_LIGHT_HSL_SATURATION_SET_OPCODE,\
900 param,\
901 MS_ACCESS_LIGHT_HSL_SATURATION_STATUS_OPCODE\
902 )
903
915 #define MS_light_hsl_target_get() \
916 MS_light_hsl_client_send_reliable_pdu \
917 (\
918 MS_ACCESS_LIGHT_HSL_TARGET_GET_OPCODE,\
919 NULL,\
920 MS_ACCESS_LIGHT_HSL_TARGET_STATUS_OPCODE\
921 )
922
934 #define MS_light_hsl_hue_set_unacknowledged(param) \
935 MS_light_hsl_client_send_reliable_pdu \
936 (\
937 MS_ACCESS_LIGHT_HSL_HUE_SET_UNACKNOWLEDGED_OPCODE,\
938 param,\
939 0xFFFFFFFF\
940 )
941
952 #define MS_light_hsl_get() \
953 MS_light_hsl_client_send_reliable_pdu \
954 (\
955 MS_ACCESS_LIGHT_HSL_GET_OPCODE,\
956 NULL,\
957 MS_ACCESS_LIGHT_HSL_STATUS_OPCODE\
958 )
959
963 #endif /*_H_MS_LIGHT_HSL_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_lc_api.h Source File

  • mesh
  • export
  • include
MS_light_lc_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_LIGHT_LC_API_
14 #define _H_MS_LIGHT_LC_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_LIGHT_LC_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_LIGHT_LC_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
89 typedef struct MS_light_lc_mode_struct
90 {
92 UCHAR mode;
93
94 } MS_LIGHT_LC_MODE_STRUCT;
95
96 typedef struct MS_light_lc_om_struct
97 {
98 UCHAR mode;
99
100 } MS_LIGHT_LC_OM_STRUCT;
101
105 typedef struct MS_light_lc_light_onoff_set_struct
106 {
108 UCHAR light_onoff;
109
111 UCHAR tid;
112
124 UCHAR transition_time;
125
127 UCHAR delay;
128
130 UCHAR optional_fields_present;
131
132 } MS_LIGHT_LC_LIGHT_ONOFF_SET_STRUCT;
133
137 typedef struct MS_light_lc_light_onoff_status_struct
138 {
140 UCHAR present_light_onoff;
141
143 UCHAR target_light_onoff;
144
156 UCHAR remaining_time;
157
159 UCHAR optional_fields_present;
160
161 } MS_LIGHT_LC_LIGHT_ONOFF_STATUS_STRUCT;
162
166 typedef struct MS_light_lc_property_get_struct
167 {
169 UINT16 light_lc_property_id;
170
171 } MS_LIGHT_LC_PROPERTY_GET_STRUCT;
172
176 typedef struct MS_light_lc_property_set_struct
177 {
179 UINT16 light_lc_property_id;
180
182 UCHAR *light_lc_property_value;
183
185 UINT16 light_lc_property_value_len;
186
187 } MS_LIGHT_LC_PROPERTY_SET_STRUCT;
188
192 typedef struct MS_light_lc_property_status_struct
193 {
195 UINT16 light_lc_property_id;
196
198 UCHAR *light_lc_property_value;
199
201 UINT16 light_lc_property_value_len;
202
203 } MS_LIGHT_LC_PROPERTY_STATUS_STRUCT;
204
209 /* --------------------------------------------- Function */
244 API_RESULT MS_light_lc_server_init
245 (
246 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
247 /* INOUT */ MS_ACCESS_MODEL_HANDLE * lc_model_handle,
248 /* INOUT */ MS_ACCESS_MODEL_HANDLE * lc_setup_model_handle,
249 /* IN */ MS_LIGHT_LC_SERVER_CB appl_cb
250 );
251
266 API_RESULT MS_light_lc_server_state_update
267 (
268 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
269 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
270 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
271 /* IN */ UINT16 remaining_time,
272 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
273 );
300 API_RESULT MS_light_lc_client_init
301 (
302 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
303 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
304 /* IN */ MS_LIGHT_LC_CLIENT_CB appl_cb
305 );
306
317 API_RESULT MS_light_lc_client_get_model_handle
318 (
319 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
320 );
321
334 API_RESULT MS_light_lc_client_send_reliable_pdu
335 (
336 /* IN */ UINT32 req_opcode,
337 /* IN */ void * param,
338 /* IN */ UINT32 rsp_opcode
339 );
340
352 #define MS_light_lc_om_set(param) \
353 MS_light_lc_client_send_reliable_pdu \
354 (\
355 MS_ACCESS_LIGHT_LC_OM_SET_OPCODE,\
356 param,\
357 MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE\
358 )
359
371 #define MS_light_lc_om_set_unacknowledged(param) \
372 MS_light_lc_client_send_reliable_pdu \
373 (\
374 MS_ACCESS_LIGHT_LC_OM_SET_UNACKNOWLEDGED_OPCODE,\
375 param,\
376 0xFFFFFFFF\
377 )
378
390 #define MS_light_lc_property_set_unacknowledged(param) \
391 MS_light_lc_client_send_reliable_pdu \
392 (\
393 MS_ACCESS_LIGHT_LC_PROPERTY_SET_UNACKNOWLEDGED_OPCODE,\
394 param,\
395 0xFFFFFFFF\
396 )
397
409 #define MS_light_lc_property_get(param) \
410 MS_light_lc_client_send_reliable_pdu \
411 (\
412 MS_ACCESS_LIGHT_LC_PROPERTY_GET_OPCODE,\
413 param,\
414 MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE\
415 )
416
428 #define MS_light_lc_mode_set(param) \
429 MS_light_lc_client_send_reliable_pdu \
430 (\
431 MS_ACCESS_LIGHT_LC_MODE_SET_OPCODE,\
432 param,\
433 MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE\
434 )
435
446 #define MS_light_lc_mode_get() \
447 MS_light_lc_client_send_reliable_pdu \
448 (\
449 MS_ACCESS_LIGHT_LC_MODE_GET_OPCODE,\
450 NULL,\
451 MS_ACCESS_LIGHT_LC_MODE_STATUS_OPCODE\
452 )
453
465 #define MS_light_lc_property_set(param) \
466 MS_light_lc_client_send_reliable_pdu \
467 (\
468 MS_ACCESS_LIGHT_LC_PROPERTY_SET_OPCODE,\
469 param,\
470 MS_ACCESS_LIGHT_LC_PROPERTY_STATUS_OPCODE\
471 )
472
483 #define MS_light_lc_om_get() \
484 MS_light_lc_client_send_reliable_pdu \
485 (\
486 MS_ACCESS_LIGHT_LC_OM_GET_OPCODE,\
487 NULL,\
488 MS_ACCESS_LIGHT_LC_OM_STATUS_OPCODE\
489 )
490
502 #define MS_light_lc_light_onoff_set_unacknowledged(param) \
503 MS_light_lc_client_send_reliable_pdu \
504 (\
505 MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_UNACKNOWLEDGED_OPCODE,\
506 param,\
507 0xFFFFFFFF\
508 )
509
520 #define MS_light_lc_light_onoff_get() \
521 MS_light_lc_client_send_reliable_pdu \
522 (\
523 MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_GET_OPCODE,\
524 NULL,\
525 MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE\
526 )
527
539 #define MS_light_lc_light_onoff_set(param) \
540 MS_light_lc_client_send_reliable_pdu \
541 (\
542 MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_SET_OPCODE,\
543 param,\
544 MS_ACCESS_LIGHT_LC_LIGHT_ONOFF_STATUS_OPCODE\
545 )
546
558 #define MS_light_lc_mode_set_unacknowledged(param) \
559 MS_light_lc_client_send_reliable_pdu \
560 (\
561 MS_ACCESS_LIGHT_LC_MODE_SET_UNACKNOWLEDGED_OPCODE,\
562 param,\
563 0xFFFFFFFF\
564 )
565
569 #endif /*_H_MS_LIGHT_LC_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_lightness_api.h Source File

  • mesh
  • export
  • include
MS_light_lightness_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_LIGHT_LIGHTNESS_API_
14 #define _H_MS_LIGHT_LIGHTNESS_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_LIGHT_LIGHTNESS_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
73 typedef API_RESULT (* MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB)
74 (
75 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
76 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
77 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
78 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
79 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
80
81 ) DECL_REENTRANT;
82
94 typedef API_RESULT (* MS_LIGHT_LIGHTNESS_CLIENT_CB)
95 (
96 MS_ACCESS_MODEL_HANDLE * handle,
97 UINT32 opcode,
98 UCHAR * data_param,
99 UINT16 data_len
100 ) DECL_REENTRANT;
111 typedef struct MS_light_lightness_set_struct
112 {
114 UINT16 lightness;
115
117 UCHAR tid;
118
130 UCHAR transition_time;
131
133 UCHAR delay;
134
136 UCHAR optional_fields_present;
137
138 } MS_LIGHT_LIGHTNESS_SET_STRUCT;
139
143 typedef struct MS_light_lightness_status_struct
144 {
146 UINT16 present_lightness;
147
149 UINT16 target_lightness;
150
162 UCHAR remaining_time;
163
165 UCHAR optional_fields_present;
166
167 } MS_LIGHT_LIGHTNESS_STATUS_STRUCT;
168
172 typedef struct MS_light_lightness_linear_set_struct
173 {
175 UINT16 lightness;
176
178 UCHAR tid;
179
191 UCHAR transition_time;
192
194 UCHAR delay;
195
197 UCHAR optional_fields_present;
198
199 } MS_LIGHT_LIGHTNESS_LINEAR_SET_STRUCT;
200
204 typedef struct MS_light_lightness_linear_status_struct
205 {
207 UINT16 present_lightness;
208
210 UINT16 target_lightness;
211
223 UCHAR remaining_time;
224
226 UCHAR optional_fields_present;
227
228 } MS_LIGHT_LIGHTNESS_LINEAR_STATUS_STRUCT;
229
233 typedef struct MS_light_lightness_last_status_struct
234 {
236 UINT16 lightness;
237
238 } MS_LIGHT_LIGHTNESS_LAST_STATUS_STRUCT;
239
243 typedef struct MS_light_lightness_default_set_struct
244 {
246 UINT16 lightness;
247
248 } MS_LIGHT_LIGHTNESS_DEFAULT_SET_STRUCT;
249
253 typedef struct MS_light_lightness_range_set_struct
254 {
256 UINT16 range_min;
257
259 UINT16 range_max;
260
261 } MS_LIGHT_LIGHTNESS_RANGE_SET_STRUCT;
262
266 typedef struct MS_light_lightness_range_status_struct
267 {
269 UCHAR status_code;
270
272 UINT16 range_min;
273
275 UINT16 range_max;
276
277 } MS_LIGHT_LIGHTNESS_RANGE_STATUS_STRUCT;
278
282 typedef struct MS_light_lightness_default_status_struct
283 {
285 UINT16 lightness;
286
287 } MS_LIGHT_LIGHTNESS_DEFAULT_STATUS_STRUCT;
288
289 typedef struct MS_light_lightness_last_or_default_status_struct
290 {
291 UINT16 lightness;
292
293 } MS_LIGHT_LIGHTNESS_LAST_OR_DEFAULT_STATUS_STRUCT;
294
299 /* --------------------------------------------- Function */
329 API_RESULT MS_light_lightness_server_init
330 (
331 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
332 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
333 /* IN */ MS_LIGHT_LIGHTNESS_SERVER_CB appl_cb
334 );
335
354 API_RESULT MS_light_lightness_setup_server_init
355 (
356 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
357 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
358 /* IN */ MS_LIGHT_LIGHTNESS_SETUP_SERVER_CB appl_cb
359 );
360
375 API_RESULT MS_light_lightness_server_state_update
376 (
377 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
378 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
379 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
380 /* IN */ UINT16 remaining_time,
381 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
382 );
383
398 API_RESULT MS_light_lightness_setup_server_state_update
399 (
400 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
401 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
402 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
403 /* IN */ UINT16 remaining_time,
404 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
405 );
432 API_RESULT MS_light_lightness_client_init
433 (
434 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
435 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
436 /* IN */ MS_LIGHT_LIGHTNESS_CLIENT_CB appl_cb
437 );
438
449 API_RESULT MS_light_lightness_client_get_model_handle
450 (
451 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
452 );
453
466 API_RESULT MS_light_lightness_client_send_reliable_pdu
467 (
468 /* IN */ UINT32 req_opcode,
469 /* IN */ void * param,
470 /* IN */ UINT32 rsp_opcode
471 );
472
483 #define MS_light_lightness_range_get() \
484 MS_light_lightness_client_send_reliable_pdu \
485 (\
486 MS_ACCESS_LIGHT_LIGHTNESS_RANGE_GET_OPCODE,\
487 NULL,\
488 MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE\
489 )
490
502 #define MS_light_lightness_linear_set_unacknowledged(param) \
503 MS_light_lightness_client_send_reliable_pdu \
504 (\
505 MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_UNACKNOWLEDGED_OPCODE,\
506 param,\
507 0xFFFFFFFF\
508 )
509
520 #define MS_light_lightness_last_get() \
521 MS_light_lightness_client_send_reliable_pdu \
522 (\
523 MS_ACCESS_LIGHT_LIGHTNESS_LAST_GET_OPCODE,\
524 NULL,\
525 MS_ACCESS_LIGHT_LIGHTNESS_LAST_STATUS_OPCODE\
526 )
527
539 #define MS_light_lightness_range_set_unacknowledged(param) \
540 MS_light_lightness_client_send_reliable_pdu \
541 (\
542 MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
543 param,\
544 0xFFFFFFFF\
545 )
546
558 #define MS_light_lightness_default_set_unacknowledged(param) \
559 MS_light_lightness_client_send_reliable_pdu \
560 (\
561 MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
562 param,\
563 0xFFFFFFFF\
564 )
565
576 #define MS_light_lightness_get() \
577 MS_light_lightness_client_send_reliable_pdu \
578 (\
579 MS_ACCESS_LIGHT_LIGHTNESS_GET_OPCODE,\
580 NULL,\
581 MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE\
582 )
583
595 #define MS_light_lightness_default_set(param) \
596 MS_light_lightness_client_send_reliable_pdu \
597 (\
598 MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_SET_OPCODE,\
599 param,\
600 MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE\
601 )
602
613 #define MS_light_lightness_default_get() \
614 MS_light_lightness_client_send_reliable_pdu \
615 (\
616 MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_GET_OPCODE,\
617 NULL,\
618 MS_ACCESS_LIGHT_LIGHTNESS_DEFAULT_STATUS_OPCODE\
619 )
620
631 #define MS_light_lightness_linear_get() \
632 MS_light_lightness_client_send_reliable_pdu \
633 (\
634 MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_GET_OPCODE,\
635 NULL,\
636 MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE\
637 )
638
650 #define MS_light_lightness_linear_set(param) \
651 MS_light_lightness_client_send_reliable_pdu \
652 (\
653 MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_SET_OPCODE,\
654 param,\
655 MS_ACCESS_LIGHT_LIGHTNESS_LINEAR_STATUS_OPCODE\
656 )
657
669 #define MS_light_lightness_set(param) \
670 MS_light_lightness_client_send_reliable_pdu \
671 (\
672 MS_ACCESS_LIGHT_LIGHTNESS_SET_OPCODE,\
673 param,\
674 MS_ACCESS_LIGHT_LIGHTNESS_STATUS_OPCODE\
675 )
676
688 #define MS_light_lightness_range_set(param) \
689 MS_light_lightness_client_send_reliable_pdu \
690 (\
691 MS_ACCESS_LIGHT_LIGHTNESS_RANGE_SET_OPCODE,\
692 param,\
693 MS_ACCESS_LIGHT_LIGHTNESS_RANGE_STATUS_OPCODE\
694 )
695
707 #define MS_light_lightness_set_unacknowledged(param) \
708 MS_light_lightness_client_send_reliable_pdu \
709 (\
710 MS_ACCESS_LIGHT_LIGHTNESS_SET_UNACKNOWLEDGED_OPCODE,\
711 param,\
712 0xFFFFFFFF\
713 )
714
718 #endif /*_H_MS_LIGHT_LIGHTNESS_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_light_xyl_api.h Source File

  • mesh
  • export
  • include
MS_light_xyl_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_LIGHT_XYL_API_
14 #define _H_MS_LIGHT_XYL_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_LIGHT_XYL_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_LIGHT_XYL_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
89 typedef struct MS_light_xyl_set_struct
90 {
92 UINT16 xyl_lightness;
93
95 UINT16 xyl_x;
96
98 UINT16 xyl_y;
99
101 UCHAR tid;
102
114 UCHAR transition_time;
115
117 UCHAR delay;
118
120 UCHAR optional_fields_present;
121
122 } MS_LIGHT_XYL_SET_STRUCT;
123
127 typedef struct MS_light_xyl_status_struct
128 {
130 UINT16 xyl_lightness;
131
133 UINT16 xyl_x;
134
136 UINT16 xyl_y;
137
149 UCHAR remaining_time;
150
152 UCHAR optional_fields_present;
153
154 } MS_LIGHT_XYL_STATUS_STRUCT;
155
159 typedef struct MS_light_xyl_target_status_struct
160 {
162 UINT16 target_xyl_lightness;
163
165 UINT16 target_xyl_x;
166
168 UINT16 target_xyl_y;
169
181 UCHAR remaining_time;
182
184 UCHAR optional_fields_present;
185
186 } MS_LIGHT_XYL_TARGET_STATUS_STRUCT;
187
191 typedef struct MS_light_xyl_default_set_struct
192 {
194 UINT16 lightness;
195
197 UINT16 xyl_x;
198
200 UINT16 xyl_y;
201
202 } MS_LIGHT_XYL_DEFAULT_SET_STRUCT;
203
207 typedef struct MS_light_xyl_default_status_struct
208 {
210 UINT16 lightness;
211
213 UINT16 xyl_x;
214
216 UINT16 xyl_y;
217
218 } MS_LIGHT_XYL_DEFAULT_STATUS_STRUCT;
219
223 typedef struct MS_light_xyl_range_set_struct
224 {
226 UINT16 xyl_x_range_min;
227
229 UINT16 xyl_x_range_max;
230
232 UINT16 xyl_y_range_min;
233
235 UINT16 xyl_y_range_max;
236
237 } MS_LIGHT_XYL_RANGE_SET_STRUCT;
238
242 typedef struct MS_light_xyl_range_status_struct
243 {
245 UCHAR status_code;
246
248 UINT16 xyl_x_range_min;
249
251 UINT16 xyl_x_range_max;
252
254 UINT16 xyl_y_range_min;
255
257 UINT16 xyl_y_range_max;
258
259 } MS_LIGHT_XYL_RANGE_STATUS_STRUCT;
260
265 /* --------------------------------------------- Function */
300 API_RESULT MS_light_xyl_server_init
301 (
302 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
303 /* INOUT */ MS_ACCESS_MODEL_HANDLE * xyl_model_handle,
304 /* INOUT */ MS_ACCESS_MODEL_HANDLE * xyl_setup_model_handle,
305 /* IN */ MS_LIGHT_XYL_SERVER_CB appl_cb
306 );
307
322 API_RESULT MS_light_xyl_server_state_update
323 (
324 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
325 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
326 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
327 /* IN */ UINT16 remaining_time,
328 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
329 );
356 API_RESULT MS_light_xyl_client_init
357 (
358 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
359 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
360 /* IN */ MS_LIGHT_XYL_CLIENT_CB appl_cb
361 );
362
373 API_RESULT MS_light_xyl_client_get_model_handle
374 (
375 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
376 );
377
390 API_RESULT MS_light_xyl_client_send_reliable_pdu
391 (
392 /* IN */ UINT32 req_opcode,
393 /* IN */ void * param,
394 /* IN */ UINT32 rsp_opcode
395 );
396
408 #define MS_light_xyl_default_set(param) \
409 MS_light_xyl_client_send_reliable_pdu \
410 (\
411 MS_ACCESS_LIGHT_XYL_DEFAULT_SET_OPCODE,\
412 param,\
413 MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE\
414 )
415
428 #define MS_light_xyl_set_unacknowledged(param) \
429 MS_light_xyl_client_send_reliable_pdu \
430 (\
431 MS_ACCESS_LIGHT_XYL_SET_UNACKNOWLEDGED_OPCODE,\
432 param,\
433 0xFFFFFFFF\
434 )
435
446 #define MS_light_xyl_range_get() \
447 MS_light_xyl_client_send_reliable_pdu \
448 (\
449 MS_ACCESS_LIGHT_XYL_RANGE_GET_OPCODE,\
450 NULL,\
451 MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE\
452 )
453
465 #define MS_light_xyl_set(param) \
466 MS_light_xyl_client_send_reliable_pdu \
467 (\
468 MS_ACCESS_LIGHT_XYL_SET_OPCODE,\
469 param,\
470 MS_ACCESS_LIGHT_XYL_STATUS_OPCODE\
471 )
472
483 #define MS_light_xyl_default_get() \
484 MS_light_xyl_client_send_reliable_pdu \
485 (\
486 MS_ACCESS_LIGHT_XYL_DEFAULT_GET_OPCODE,\
487 NULL,\
488 MS_ACCESS_LIGHT_XYL_DEFAULT_STATUS_OPCODE\
489 )
490
502 #define MS_light_xyl_range_set_unacknowledged(param) \
503 MS_light_xyl_client_send_reliable_pdu \
504 (\
505 MS_ACCESS_LIGHT_XYL_RANGE_SET_UNACKNOWLEDGED_OPCODE,\
506 param,\
507 0xFFFFFFFF\
508 )
509
522 #define MS_light_xyl_get() \
523 MS_light_xyl_client_send_reliable_pdu \
524 (\
525 MS_ACCESS_LIGHT_XYL_GET_OPCODE,\
526 NULL,\
527 MS_ACCESS_LIGHT_XYL_STATUS_OPCODE\
528 )
529
542 #define MS_light_xyl_default_set_unacknowledged(param) \
543 MS_light_xyl_client_send_reliable_pdu \
544 (\
545 MS_ACCESS_LIGHT_XYL_DEFAULT_SET_UNACKNOWLEDGED_OPCODE,\
546 param,\
547 0xFFFFFFFF\
548 )
549
560 #define MS_light_xyl_target_get() \
561 MS_light_xyl_client_send_reliable_pdu \
562 (\
563 MS_ACCESS_LIGHT_XYL_TARGET_GET_OPCODE,\
564 NULL,\
565 MS_ACCESS_LIGHT_XYL_TARGET_STATUS_OPCODE\
566 )
567
579 #define MS_light_xyl_range_set(param) \
580 MS_light_xyl_client_send_reliable_pdu \
581 (\
582 MS_ACCESS_LIGHT_XYL_RANGE_SET_OPCODE,\
583 param,\
584 MS_ACCESS_LIGHT_XYL_RANGE_STATUS_OPCODE\
585 )
586
590 #endif /*_H_MS_LIGHT_XYL_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_ltrn_api.h Source File

  • mesh
  • export
  • include
MS_ltrn_api.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_LTRN_API_
15 #define _H_MS_LTRN_API_
16
17
18 /* --------------------------------------------- Header File Inclusion */
19 /* Network API Header File */
20 #include "MS_net_api.h"
21
22 /* --------------------------------------------- Global Definitions */
23
45 #define MS_UNSEGMENTED_ACCESS_MSG 0x00
46
48 #define MS_SEGMENTED_ACCESS_MSG 0x01
49
51 #define MS_UNSEGMENTED_CTRL_MSG 0x02
52
54 #define MS_SEGMENTED_CTRL_MSG 0x03
55
57 typedef UCHAR MS_TRN_MSG_TYPE;
58
60 #define MS_TRN_CTRL_PKT 0x01
61
63 #define MS_TRN_ACCESS_PKT 0x00
64
84 /* --------------------------------------------- Data Types/ Structures */
85
96 typedef UINT8 LPN_HANDLE;
97
98
120 typedef API_RESULT (*LTRN_NTF_CB)
121 (
122 MS_NET_HEADER * net_hdr,
123 MS_SUBNET_HANDLE subnet_handle,
124 UCHAR szmic,
125 UCHAR * data_param,
126 UINT16 data_len
127 ) DECL_REENTRANT;
147 /* --------------------------------------------- Function */
148
154 #ifdef __cplusplus
155 extern "C" {
156 #endif
157
170 API_RESULT MS_ltrn_register
171 (
172 /* IN */ LTRN_NTF_CB ltrn_cb
173 );
174
213 API_RESULT MS_ltrn_send_pdu
214 (
215 /* IN */ MS_NET_ADDR src_addr,
216 /* IN */ MS_NET_ADDR dst_addr,
217 /* IN */ MS_SUBNET_HANDLE subnet_handle,
218 /* IN */ MS_TRN_MSG_TYPE msg_type,
219 /* IN */ UINT8 ttl,
220 /* IN */ UINT8 akf,
221 /* IN */ UINT8 aid,
222 /* IN */ UINT16 seq_zero,
223 /* IN */ UCHAR * buffer,
224 /* IN */ UINT16 buffer_len
225 );
226
227 #ifdef __cplusplus
228 };
229 #endif
230
235 #endif /* _H_MS_LTRN_API_ */
236


EtherMind Mesh SDK (beta): mesh/export/include/MS_model_states.h Source File

  • mesh
  • export
  • include
MS_model_states.h
Go to the documentation of this file.
1
5 /*
6 * Copyright (C) 2017. Mindtree Ltd.
7 * All rights reserved.
8 */
9
10 #ifndef _H_MS_MODEL_STATES_
11 #define _H_MS_MODEL_STATES_
12
13
14 /* --------------------------------------------- Global Definitions */
15
16
17 /* --------------------------------------------- Data Types/ Structures */
19 #define MS_STATE_GENERIC_ONOFF_T 0
20 #define MS_STATE_GENERIC_LEVEL_T 1
21 #define MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_T 2
22 #define MS_STATE_GENERIC_ONPOWERUP_T 3
23 #define MS_STATE_GENERIC_POWER_ACTUAL_T 4
24 #define MS_STATE_GENERIC_POWER_LAST_T 5
25 #define MS_STATE_GENERIC_POWER_DEFAULT_T 6
26 #define MS_STATE_GENERIC_POWER_RANGE_T 7
27 #define MS_STATE_GENERIC_POWER_LEVEL_T 8
28 #define MS_STATE_GENERIC_BATTERY_T 9
29 #define MS_STATE_GENERIC_LOCATION_GLOBAL_T 10
30 #define MS_STATE_GENERIC_LOCATION_LOCAL_T 11
31 #define MS_STATE_GENERIC_LOCATION_T 12
32 #define MS_STATE_GENERIC_USER_PROPERTY_T 13
33 #define MS_STATE_GENERIC_ADMIN_PROPERTY_T 14
34 #define MS_STATE_GENERIC_MANUFACTURER_PROPERTY_T 15
35 #define MS_STATE_GENERIC_PROPERTY_ID_T 16
36 #define MS_STATE_GENERIC_PROPERTY_IDS_T 17
37 #define MS_STATE_SENSOR_PROPERTY_ID_T 18
38 #define MS_STATE_SENSOR_DESCRIPTOR_T 19
39 #define MS_STATE_SENSOR_SETTINGS_T 20
40 #define MS_STATE_SENSOR_SETTING_T 21
41 #define MS_STATE_SENSOR_CADENCE_T 22
42 #define MS_STATE_SENSOR_DATA_T 23
43 #define MS_STATE_SENSOR_SERIES_COLUMN_T 24
44 #define MS_STATE_TIME_T 25
45 #define MS_STATE_TIME_ZONE_T 26
46 #define MS_STATE_TIME_TAI_UTC_DELTA_T 27
47 #define MS_STATE_TIME_ROLE_T 28
48 #define MS_STATE_SCENE_NUMBER_T 29
49 #define MS_STATE_SCENE_STATUS_T 30
50 #define MS_STATE_SCENE_REGISTER_STATUS_T 31
51 #define MS_STATE_SCHEDULER_SCHEDULES_T 32
52 #define MS_STATE_SCHEDULER_ENTRY_INDEX_T 33
53 #define MS_STATE_SCHEDULER_ENTRY_T 34
54 #define MS_STATE_LIGHT_LIGHTNESS_LINEAR_T 35
55 #define MS_STATE_LIGHT_LIGHTNESS_ACTUAL_T 36
56 #define MS_STATE_LIGHT_LIGHTNESS_LAST_T 37
57 #define MS_STATE_LIGHT_LIGHTNESS_DEFAULT_T 38
58 #define MS_STATE_LIGHT_LIGHTNESS_RANGE_T 39
59 #define MS_STATE_LIGHT_LIGHTNESS_T 40
60 #define MS_STATE_LIGHT_CTL_T 41
61 #define MS_STATE_LIGHT_CTL_DEFAULT_T 42
62 #define MS_STATE_LIGHT_CTL_TEMPERATURE_T 43
63 #define MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_T 44
64 #define MS_STATE_LIGHT_HSL_T 45
65 #define MS_STATE_LIGHT_HSL_TARGET_T 46
66 #define MS_STATE_LIGHT_HSL_DEFAULT_T 47
67 #define MS_STATE_LIGHT_HSL_HUE_T 48
68 #define MS_STATE_LIGHT_HSL_SATURATION_T 49
69 #define MS_STATE_LIGHT_HSL_RANGE_T 50
70 #define MS_STATE_LIGHT_XYL_T 51
71 #define MS_STATE_LIGHT_XYL_TARGET_T 52
72 #define MS_STATE_LIGHT_XYL_DEFAULT_T 53
73 #define MS_STATE_LIGHT_XYL_RANGE_T 54
74 #define MS_STATE_LIGHT_LC_MODE_T 55
75 #define MS_STATE_LIGHT_LC_OM_T 56
76 #define MS_STATE_LIGHT_LC_LIGHT_ONOFF_T 57
77 #define MS_STATE_LIGHT_LC_PROPERTY_ID_T 58
78 #define MS_STATE_LIGHT_LC_PROPERTY_T 59
79
80 #define MS_STATE_GENERIC_USER_PROPERTY_IDS_T 60
81 #define MS_STATE_GENERIC_ADMIN_PROPERTY_IDS_T 61
82 #define MS_STATE_GENERIC_MANUFACTURER_PROPERTY_IDS_T 62
83 #define MS_STATE_GENERIC_CLIENT_PROPERTY_IDS_T 63
84
85 #define MS_STATE_SCENE_STORE_T 64
86 #define MS_STATE_SCENE_RECALL_T 65
87 #define MS_STATE_SCENE_DELETE_T 66
88
89 #define MS_STATE_DELTA_LEVEL_T 67
90 #define MS_STATE_MOVE_LEVEL_T 68
91
92 /* Additional supporting structure type defines */
93 #define MS_EXT_TID_AND_TRANSITION_STRUCT_T 128
94 #define MS_EXT_STATUS_STRUCT_T 129
95 #define MS_STATE_SENSOR_SERIES_T 130
96
101 typedef struct MS_state_generic_onoff_struct
102 {
104 UINT8 onoff;
105
107 UINT8 target_onoff;
108
110 UINT8 last_onoff;
111
113 UINT8 tid;
114
119 UINT8 transition_time;
120
122 UINT8 delay;
123
124 } MS_STATE_GENERIC_ONOFF_STRUCT;
125
130 typedef struct MS_state_generic_level_struct
131 {
133 UINT16 level;
134
136 UINT32 delta_level;
137
139 UINT16 move_level;
140
141 /* TID - Used in received path */
142 UINT8 tid;
143
144 /* Optional */
145 /* Transition Time */
146 UINT8 transition_time;
147
148 /* Delay */
149 UINT8 delay;
150
152 UINT16 target_level;
153
154 } MS_STATE_GENERIC_LEVEL_STRUCT;
155
160 typedef struct MS_state_generic_default_transition_time_struct
161 {
163 UCHAR default_transition_number_of_steps;
164
166 UCHAR default_transition_step_resolution;
167 } MS_STATE_GENERIC_DEFAULT_TRANSITION_TIME_STRUCT;
168
173 typedef struct MS_state_generic_onpowerup_struct
174 {
176 UCHAR onpowerup;
177 } MS_STATE_GENERIC_ONPOWERUP_STRUCT;
178
184 typedef struct MS_state_generic_power_actual_struct
185 {
187 UINT16 power_actual;
188
189 /* TID - Used only in request path */
190 UINT8 tid;
191
193 UINT16 power_target;
194
199 UINT8 transition_time;
200
201 /* Delay - Used only in request path */
202 UINT8 delay;
203
204 } MS_STATE_GENERIC_POWER_ACTUAL_STRUCT;
205
210 typedef struct MS_state_generic_power_last_struct
211 {
213 UINT16 power_last;
214 } MS_STATE_GENERIC_POWER_LAST_STRUCT;
215
217 typedef struct MS_state_generic_power_default_struct
218 {
220 UINT16 power_default;
221 } MS_STATE_GENERIC_POWER_DEFAULT_STRUCT;
222
227 typedef struct MS_state_generic_power_range_struct
228 {
230 UINT16 power_range_min;
231
233 UINT16 power_range_max;
234
236 UINT8 status;
237
238 } MS_STATE_GENERIC_POWER_RANGE_STRUCT;
239
245 typedef struct MS_state_generic_power_level_struct
246 {
248 MS_STATE_GENERIC_POWER_ACTUAL_STRUCT generic_power_actual;
249
251 MS_STATE_GENERIC_POWER_LAST_STRUCT generic_power_last;
252
254 MS_STATE_GENERIC_POWER_DEFAULT_STRUCT generic_power_default;
255
257 MS_STATE_GENERIC_POWER_RANGE_STRUCT generic_power_range;
258 } MS_STATE_GENERIC_POWER_LEVEL_STRUCT;
259
264 typedef struct MS_state_generic_battery_struct
265 {
270 UCHAR generic_battery_level;
271
276 UINT32 generic_battery_time_to_discharge;
277
282 UINT32 generic_battery_time_to_charge;
283
288 UCHAR generic_battery_flags;
289 } MS_STATE_GENERIC_BATTERY_STRUCT;
290
292 typedef struct MS_state_generic_location_global_struct
293 {
295 UINT32 global_latitude;
296
298 UINT32 global_longitude;
299
301 UINT16 global_altitude;
302 } MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT;
303
305 typedef struct MS_state_generic_location_local_struct
306 {
308 UINT16 local_north;
309
311 UINT16 local_east;
312
314 UINT16 local_altitude;
315
317 UCHAR floor_number;
318
320 UINT16 uncertainty;
321 } MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT;
322
327 typedef struct MS_state_generic_location_struct
328 {
330 MS_STATE_GENERIC_LOCATION_GLOBAL_STRUCT global_location;
331
333 MS_STATE_GENERIC_LOCATION_LOCAL_STRUCT local_location;
334 } MS_STATE_GENERIC_LOCATION_STRUCT;
335
336
344 typedef struct MS_state_generic_property_struct
345 {
350 UINT16 property_id;
351
353 UINT8 property_type;
354
359 UCHAR access;
360
362 UCHAR * property_value;
363 UINT16 property_value_len;
364
365 } MS_STATE_GENERIC_PROPERTY_STRUCT;
366
367
369 typedef struct MS_state_generic_user_property_struct
370 {
375 UINT16 property_id;
376
381 UCHAR user_access;
382
384 UCHAR * property_value;
385 UINT16 property_value_len;
386 } MS_STATE_GENERIC_USER_PROPERTY_STRUCT;
387
392 typedef struct MS_state_generic_admin_property_struct
393 {
398 UINT16 property_id;
399
404 UCHAR user_access;
405
407 UCHAR * property_value;
408 UINT16 property_value_len;
409 } MS_STATE_GENERIC_ADMIN_PROPERTY_STRUCT;
410
415 typedef struct MS_state_generic_manufacturer_property_struct
416 {
421 UINT16 property_id;
422
427 UCHAR user_access;
428
430 UCHAR * property_value;
431 UINT16 property_value_len;
432 } MS_STATE_GENERIC_MANUFACTURER_PROPERTY_STRUCT;
433
438 typedef struct MS_state_generic_property_id_struct
439 {
444 UINT16 property_id;
445 } MS_STATE_GENERIC_PROPERTY_ID_STRUCT;
446
451 typedef struct MS_state_generic_property_ids_struct
452 {
457 UINT16 *property_ids;
458 UINT16 property_ids_count;
459 } MS_STATE_GENERIC_PROPERTY_IDS_STRUCT;
460
465 typedef struct MS_state_sensor_property_id_struct
466 {
471 UINT16 property_id;
472 } MS_STATE_SENSOR_PROPERTY_ID_STRUCT;
473
475 typedef struct MS_state_sensor_descriptor_struct
476 {
481 UINT16 sensor_property_id;
482
488 UINT16 sensor_positive_tolerance;
489
495 UINT16 sensor_negative_tolerance;
496
501 UCHAR sensor_sampling_function;
502
508 UCHAR sensor_measurement_period;
509
514 UCHAR sensor_update_interval;
515
517 UINT8 status;
518
519 } MS_STATE_SENSOR_DESCRIPTOR_STRUCT;
520
522 typedef struct MS_state_sensor_settings_struct
523 {
525 UINT16 sensor_property_id;
526
528 UINT16 *setting_property_ids;
529 UINT16 setting_property_ids_count;
530
531 } MS_STATE_SENSOR_SETTINGS_STRUCT;
532
534 typedef struct MS_state_sensor_setting_struct
535 {
537 UINT16 sensor_property_id;
538
540 UINT16 sensor_setting_property_id;
541
543 UCHAR sensor_setting_access;
544
546 UCHAR *sensor_setting_raw;
547 UINT16 sensor_setting_raw_len;
548
549 /* Status - used in response path */
550 UINT8 status;
551
552 } MS_STATE_SENSOR_SETTING_STRUCT;
553
555 typedef struct MS_state_sensor_cadence_struct
556 {
558 UINT16 sensor_property_id;
559
561 UCHAR fast_cadence_period_divisor;
562
564 UCHAR status_trigger_type;
565
567 UCHAR *status_trigger_delta_down;
568 UINT16 status_trigger_delta_down_len;
569
571 UCHAR *status_trigger_delta_up;
572 UINT16 status_trigger_delta_up_len;
573
575 UCHAR status_min_interval;
576
578 UCHAR *fast_cadence_low;
579 UINT16 fast_cadence_low_len;
580
582 UCHAR *fast_cadence_high;
583 UINT16 fast_cadence_high_len;
584
586 UINT8 status;
587
588 } MS_STATE_SENSOR_CADENCE_STRUCT;
589
595 typedef struct MS_state_sensor_data_struct
596 {
598 UINT16 property_id_1;
599
604 UCHAR *raw_value_1;
605 UINT16 raw_value_1_len;
606
608 UINT16 property_id_2;
609
614 UCHAR *raw_value_2;
615 UINT16 raw_value_2_len;
616
618 UINT16 property_id_n;
619
624 UCHAR *raw_value_n;
625 UINT16 raw_value_n_len;
626
628 UINT8 status;
629
630 } MS_STATE_SENSOR_DATA_STRUCT;
631
636 typedef struct MS_state_sensor_series_column_struct
637 {
639 UINT16 sensor_property_id;
640
642 UCHAR *sensor_raw_value_x;
643 UINT16 sensor_raw_value_x_len;
644
646 UCHAR *sensor_column_width;
647 UINT16 sensor_column_width_len;
648
650 UCHAR *sensor_raw_value_y;
651 UINT16 sensor_raw_value_y_len;
652
654 UINT8 status;
655
656 } MS_STATE_SENSOR_SERIES_COLUMN_STRUCT;
657
663 typedef struct MS_state_time_struct
664 {
666 UCHAR tai_seconds[5];
667
669 UCHAR subsecond;
670
672 UCHAR uncertainty;
673
680 UCHAR time_authority;
681
683 UINT16 tai_utc_delta;
684
686 UCHAR time_zone_offset;
687 } MS_STATE_TIME_STRUCT;
688
690 typedef struct MS_state_time_zone_struct
691 {
696 UCHAR time_zone_offset_current;
697
699 UCHAR time_zone_offset_new;
700
702 UCHAR tai_of_zone_change[5];
703 } MS_STATE_TIME_ZONE_STRUCT;
704
706 typedef struct MS_state_time_tai_utc_delta_struct
707 {
712 UINT16 tai_utc_delta_current;
713
715 UINT16 tai_utc_delta_new;
716
718 UCHAR padding;
719
721 UCHAR tai_of_delta_change[5];
722 } MS_STATE_TIME_TAI_UTC_DELTA_STRUCT;
723
725 typedef struct MS_state_time_role_struct
726 {
728 UCHAR role;
729 } MS_STATE_TIME_ROLE_STRUCT;
730
732 typedef struct MS_state_scene_number_struct
733 {
735 UINT16 number;
736 } MS_STATE_SCENE_NUMBER_STRUCT;
737
739 typedef struct MS_state_scene_status_struct
740 {
742 UCHAR status_code;
743
745 UINT16 current_scene;
746
748 UINT16 target_scene;
749
750 /* Remaining Time */
751 UINT8 remaining_time;
752
753 } MS_STATE_SCENE_STATUS_STRUCT;
754
756 typedef struct MS_state_scene_register_status_struct
757 {
759 UCHAR status_code;
760
762 UINT16 current_scene;
763
765 UINT16 *scenes;
766 UINT16 scenes_count;
767 } MS_STATE_SCENE_REGISTER_STATUS_STRUCT;
768
770 typedef struct MS_state_scheduler_schedules_struct
771 {
773 UINT16 schedules;
774 } MS_STATE_SCHEDULER_SCHEDULES_STRUCT;
775
777 typedef struct MS_state_scheduler_entry_index_struct
778 {
780 UCHAR index;
781 } MS_STATE_SCHEDULER_ENTRY_INDEX_STRUCT;
782
784 typedef struct MS_state_scheduler_entry_struct
785 {
787 UCHAR index;
788
790 UCHAR year;
791
793 UINT16 month;
794
796 UCHAR day;
797
799 UCHAR hour;
800
802 UCHAR minute;
803
805 UCHAR second;
806
808 UCHAR dayofweek;
809
811 UCHAR action;
812
814 UCHAR transition_time;
815
817 UINT16 scene_number;
818
819 } MS_STATE_SCHEDULER_ENTRY_STRUCT;
820
825 typedef struct MS_state_light_lightness_linear_struct
826 {
828 UINT16 lightness_linear;
829
831 UINT16 lightness_target;
832
834 UINT8 tid;
835
840 UINT8 transition_time;
841
843 UINT8 delay;
844
845 } MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT;
846
851 typedef struct MS_state_light_lightness_actual_struct
852 {
854 UINT16 lightness_actual;
855
857 UINT16 lightness_target;
858
860 UINT8 tid;
861
866 UINT8 transition_time;
867
869 UINT8 delay;
870
871 } MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT;
872
877 typedef struct MS_state_light_lightness_last_struct
878 {
880 UINT16 lightness_last;
881 } MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT;
882
887 typedef struct MS_state_light_lightness_default_struct
888 {
890 UINT16 lightness_default;
891 } MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT;
892
897 typedef struct MS_state_light_lightness_range_struct
898 {
900 UINT16 lightness_range_min;
901
903 UINT16 lightness_range_max;
904 } MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT;
905
911 typedef struct MS_state_light_lightness_struct
912 {
917 MS_STATE_LIGHT_LIGHTNESS_LINEAR_STRUCT light_lightness_linear;
918
923 MS_STATE_LIGHT_LIGHTNESS_ACTUAL_STRUCT light_lightness_actual;
924
929 MS_STATE_LIGHT_LIGHTNESS_LAST_STRUCT light_lightness_last;
930
935 MS_STATE_LIGHT_LIGHTNESS_DEFAULT_STRUCT light_lightness_default;
936
940 MS_STATE_LIGHT_LIGHTNESS_RANGE_STRUCT light_lightness_range;
941
943 UINT8 range_status;
944
945 } MS_STATE_LIGHT_LIGHTNESS_STRUCT;
946
951 typedef struct MS_state_light_ctl_struct
952 {
954 UINT16 ctl_lightness;
955
957 UINT16 target_ctl_lightness;
958
960 UINT16 ctl_temperature;
961
963 UINT16 target_ctl_temperature;
964
966 UINT16 ctl_delta_uv;
967
969 UINT8 tid;
970
975 UINT8 transition_time;
976
978 UINT8 delay;
979
980 } MS_STATE_LIGHT_CTL_STRUCT;
981
986 typedef struct MS_state_light_ctl_default_struct
987 {
989 UINT16 ctl_lightness;
990
992 UINT16 ctl_temperature;
993
995 UINT16 ctl_delta_uv;
996 } MS_STATE_LIGHT_CTL_DEFAULT_STRUCT;
997
1002 typedef struct MS_state_light_ctl_temperature_struct
1003 {
1005 UINT16 ctl_temperature;
1006
1008 UINT16 target_ctl_temperature;
1009
1011 UINT16 ctl_delta_uv;
1012
1014 UINT16 target_ctl_delta_uv;
1015
1017 UINT8 tid;
1018
1023 UINT8 transition_time;
1024
1026 UINT8 delay;
1027
1028 } MS_STATE_LIGHT_CTL_TEMPERATURE_STRUCT;
1029
1034 typedef struct MS_state_light_ctl_temperature_range_struct
1035 {
1037 UINT16 ctl_temperature_range_min;
1038
1040 UINT16 ctl_temperature_range_max;
1041
1043 UINT8 status;
1044
1045 } MS_STATE_LIGHT_CTL_TEMPERATURE_RANGE_STRUCT;
1046
1051 typedef struct MS_state_light_hsl_struct
1052 {
1054 UINT16 hsl_lightness;
1055
1057 UINT16 target_hsl_lightness;
1058
1060 UINT16 hsl_hue;
1061
1063 UINT16 target_hsl_hue;
1064
1066 UINT16 hsl_saturation;
1067
1069 UINT16 target_hsl_saturation;
1070
1072 UINT8 tid;
1073
1078 UINT8 transition_time;
1079
1081 UINT8 delay;
1082
1083 } MS_STATE_LIGHT_HSL_STRUCT;
1084
1089 typedef struct MS_state_light_hsl_target_struct
1090 {
1092 UINT16 hsl_lightness;
1093
1095 UINT16 hsl_hue;
1096
1098 UINT16 hsl_saturation;
1099 } MS_STATE_LIGHT_HSL_TARGET_STRUCT;
1100
1105 typedef struct MS_state_light_hsl_default_struct
1106 {
1108 UINT16 hsl_lightness;
1109
1111 UINT16 hsl_hue;
1112
1114 UINT16 hsl_saturation;
1115 } MS_STATE_LIGHT_HSL_DEFAULT_STRUCT;
1116
1118 typedef struct MS_state_light_hsl_hue_struct
1119 {
1121 UINT16 hsl_hue;
1122 } MS_STATE_LIGHT_HSL_HUE_STRUCT;
1123
1125 typedef struct MS_state_light_hsl_saturation_struct
1126 {
1128 UINT16 hsl_saturation;
1129 } MS_STATE_LIGHT_HSL_SATURATION_STRUCT;
1130
1135 typedef struct MS_state_light_hsl_range_struct
1136 {
1138 UINT16 hue_range_min;
1139
1141 UINT16 hue_range_max;
1142
1147 UINT16 saturation_range_min;
1148
1153 UINT16 saturation_range_max;
1154
1156 UINT8 status;
1157
1158 } MS_STATE_LIGHT_HSL_RANGE_STRUCT;
1159
1164 typedef struct MS_state_light_xyl_struct
1165 {
1167 UINT16 xyl_lightness;
1168
1170 UINT16 target_xyl_lightness;
1171
1173 UINT16 xyl_x;
1174
1176 UINT16 target_xyl_x;
1177
1179 UINT16 xyl_y;
1180
1182 UINT16 target_xyl_y;
1183
1185 UINT8 tid;
1186
1191 UINT8 transition_time;
1192
1194 UINT8 delay;
1195
1196 } MS_STATE_LIGHT_XYL_STRUCT;
1197
1202 typedef struct MS_state_light_xyl_target_struct
1203 {
1205 UINT16 xyl_lightness;
1206
1208 UINT16 xyl_x;
1209
1211 UINT16 xyl_y;
1212 } MS_STATE_LIGHT_XYL_TARGET_STRUCT;
1213
1218 typedef struct MS_state_light_xyl_default_struct
1219 {
1221 UINT16 xyl_lightness;
1222
1224 UINT16 xyl_x;
1225
1227 UINT16 xyl_y;
1228 } MS_STATE_LIGHT_XYL_DEFAULT_STRUCT;
1229
1234 typedef struct MS_state_light_xyl_range_struct
1235 {
1237 UINT16 xyl_x_range_min;
1238
1240 UINT16 xyl_x_range_max;
1241
1243 UINT16 xyl_y_range_min;
1244
1246 UINT16 xyl_y_range_max;
1247
1249 UINT8 status;
1250
1251 } MS_STATE_LIGHT_XYL_RANGE_STRUCT;
1252
1254 typedef struct MS_state_light_lc_mode_struct
1255 {
1257 UCHAR present_mode;
1258
1260 UCHAR target_mode;
1261
1262 } MS_STATE_LIGHT_LC_MODE_STRUCT;
1263
1265 typedef struct MS_state_light_lc_om_struct
1266 {
1268 UCHAR present_mode;
1269
1271 UCHAR target_mode;
1272
1273 } MS_STATE_LIGHT_LC_OM_STRUCT;
1274
1276 typedef struct MS_state_light_lc_light_onoff_struct
1277 {
1279 UCHAR present_light_onoff;
1280
1282 UCHAR target_light_onoff;
1283
1285 UINT8 tid;
1286
1291 UINT8 transition_time;
1292
1294 UINT8 delay;
1295
1296 } MS_STATE_LIGHT_LC_LIGHT_ONOFF_STRUCT;
1297
1299 typedef struct MS_state_light_lc_property_id_struct
1300 {
1302 UINT16 property_id;
1303 } MS_STATE_LIGHT_LC_PROPERTY_ID_STRUCT;
1304
1306 typedef struct MS_state_light_lc_property_struct
1307 {
1309 UINT16 property_id;
1310
1312 UCHAR *property_value;
1313 UINT16 property_value_len;
1314 } MS_STATE_LIGHT_LC_PROPERTY_STRUCT;
1315
1316
1317 /* Additional supporting structure defines */
1318
1333 typedef struct MS_ext_tid_and_transition_struct
1334 {
1335 UCHAR tid;
1336 UCHAR transition_time;
1337 UCHAR delay;
1338 UCHAR optional_fields_present;
1339
1340 } MS_EXT_TID_AND_TRANSITION_STRUCT;
1341
1345 typedef struct MS_ext_status_struct
1346 {
1347 UCHAR status;
1348
1349 } MS_EXT_STATUS_STRUCT;
1350
1351 /* State Transition data structure */
1352 typedef struct _MS_ACCESS_STATE_TRANSITION_TYPE
1353 {
1354 /* Transition Timer */
1355 EM_timer_handle transition_timer_handle;
1356
1357 /* Transition State. Initial/delay/transition */
1358 UINT8 transition_state;
1359
1360 /* Delay */
1361 UINT8 delay;
1362
1363 /* Transition Time */
1364 UINT8 transition_time;
1365
1366 /* Transition Start Callback */
1367 void (* transition_start_cb)(void *);
1368
1369 /* Transition Complete Callback */
1370 void (* transition_complete_cb)(void *);
1371
1372 /* Blob/Context */
1373 void * blob;
1374
1375 }MS_ACCESS_STATE_TRANSITION_TYPE;
1376
1377 /* --------------------------------------------- Function */
1378 #endif /*_H_MS_MODEL_STATES_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_net_api.h Source File

  • mesh
  • export
  • include
MS_net_api.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_NET_API_
15 #define _H_MS_NET_API_
16
17
18 /* --------------------------------------------- Header File Inclusion */
19 /* Bearer Layer */
20 #include "MS_brr_api.h"
21 #include "MS_prov_api.h"
22
23 /* --------------------------------------------- Global Definitions */
24
64 #define MS_NET_ADDR_UNASSIGNED 0x0000
65
66 #define MS_NET_ADDR_TYPE_INVALID 0x00
67
88 #define MS_NET_ADDR_UNICAST_BIT_MASK 0x8000
89
90 #define MS_NET_ADDR_UNICAST_COMPARE 0x0000
91
92 #define MS_NET_ADDR_TYPE_UNICAST 0x01
93
108 #define MS_NET_ADDR_VIRTUAL_BIT_MASK 0xC000
109
110 #define MS_NET_ADDR_VIRTUAL_COMPARE 0x8000
111
112 #define MS_NET_ADDR_TYPE_VIRTUAL 0x02
113
126 #define MS_NET_ADDR_GROUP_BIT_MASK 0xC000
127
128 #define MS_NET_ADDR_GROUP_COMPARE 0xC000
129
130 #define MS_NET_ADDR_TYPE_GROUP 0x03
131
138 #define MS_NET_ADDR_ALL_PROXIES 0xFFFC
139
140 #define MS_NET_ADDR_ALL_FRIENDS 0xFFFD
141
142 #define MS_NET_ADDR_ALL_RELAYS 0xFFFE
143
144 #define MS_NET_ADDR_ALL_NODES 0xFFFF
145
160 #define MS_NET_FEATURE_PROXY 0x00
161
162 #define MS_NET_FEATURE_RELAY 0x01
163
165 #define MS_PRIMARY_SUBNET 0x000
166
168 #define MS_INVALID_SUBNET_HANDLE 0xFFFF
169
171 #define MS_INVALID_APPKEY_HANDLE 0xFFFF
172
182 #define MS_PROXY_WHITELIST_FILTER 0x00
183
184 #define MS_PROXY_BLACKLIST_FILTER 0x01
185
188 #define MS_PROXY_SET_FILTER_OPCODE 0x00
189
190 #define MS_PROXY_ADD_TO_FILTER_OPCODE 0x01
191
192 #define MS_PROXY_REM_FROM_FILTER_OPCODE 0x02
193
194 #define MS_PROXY_FILTER_STATUS_OPCODE 0x03
195
198 #define MS_PROXY_NET_ID_ADV_MODE 0x01
199
200 #define MS_PROXY_NODE_ID_ADV_MODE 0x02
201
215 #define MS_PROXY_UP_EVENT 0x00
216
217 #define MS_PROXY_DOWN_EVENT 0x01
218
219 #define MS_PROXY_STATUS_EVENT 0x02
220
241 #define MS_PROXY_NULL 0x00
242
243 #define MS_PROXY_READY 0x01
244
245 #define MS_PROXY_CONNECTED 0x02
246
258 /* --------------------------------------------- Data Types/ Structures */
259
271 typedef UINT16 MS_NET_ADDR;
272
274 typedef UINT16 MS_SUBNET_HANDLE;
275
277 typedef UINT16 MS_APPKEY_HANDLE;
278
280 typedef UCHAR MS_NET_ADDR_TYPE;
281
283 typedef struct _MS_NET_HEADER
284 {
286 UINT8 ivi;
287
293 UINT8 nid;
294
296 UINT8 ctl;
297
299 UINT8 ttl;
300
302 MS_NET_ADDR saddr;
303
305 MS_NET_ADDR daddr;
306
308 UINT32 seq_num;
309
310 } MS_NET_HEADER;
311
313 typedef UCHAR PROXY_FILTER_TYPE;
314
316 typedef MS_NET_ADDR PROXY_ADDR;
317
319 typedef UINT8 NETIF_HANDLE;
320
349 typedef API_RESULT (*NET_NTF_CB)
350 (
351 MS_NET_HEADER * net_hdr,
352 MS_SUBNET_HANDLE subnet_handle,
353 UCHAR * data_param,
354 UINT16 data_len
355 ) DECL_REENTRANT;
356
368 typedef void (*PROXY_NTF_CB)
369 (
370 NETIF_HANDLE * handle,
371 UCHAR p_evt,
372 UCHAR * data_param,
373 UINT16 data_len
374 ) DECL_REENTRANT;
386 #define MS_IS_UNICAST_ADDR(addr) \
387 (((MS_NET_ADDR_UNASSIGNED != (addr)) && \
388 (MS_NET_ADDR_UNICAST_COMPARE == ((addr) & MS_NET_ADDR_UNICAST_BIT_MASK))) \
389 ? MS_TRUE : MS_FALSE)
390
394 #define MS_IS_VIRTUAL_ADDR(addr) \
395 ((MS_NET_ADDR_VIRTUAL_COMPARE == ((addr) & MS_NET_ADDR_VIRTUAL_BIT_MASK)) \
396 ? MS_TRUE : MS_FALSE)
397
401 #define MS_IS_GROUP_ADDR(addr) \
402 ((MS_NET_ADDR_GROUP_COMPARE == ((addr) & MS_NET_ADDR_GROUP_BIT_MASK)) \
403 ? MS_TRUE : MS_FALSE)
404
408 #define NET_IS_VALID_SRC_ADDR(addr) \
409 MS_IS_UNICAST_ADDR(addr)
410
416 #define NET_IS_VALID_DST_ADDR(addr, ctl) \
417 (((MS_NET_ADDR_UNASSIGNED != (addr)) && \
418 ((0x01 != (ctl)) || (MS_FALSE == MS_IS_VIRTUAL_ADDR(addr)))) \
419 ? MS_TRUE : MS_FALSE)
420
421 #ifdef MS_PROXY_CLIENT
422 /* GATT Proxy Client Related defines */
436 #define MS_proxy_set_whitelist_filter(nh,sh) \
437 MS_proxy_set_filter \
438 ( \
439 (nh), \
440 (sh), \
441 MS_PROXY_WHITELIST_FILTER \
442 );
443
457 #define MS_proxy_set_blacklist_filter(nh,sh) \
458 MS_proxy_set_filter \
459 ( \
460 (nh), \
461 (sh), \
462 MS_PROXY_BLACKLIST_FILTER \
463 );
464
480 #define MS_proxy_add_to_list(nh,sh,a,c) \
481 MS_proxy_filter_op \
482 ( \
483 (nh), \
484 (sh), \
485 MS_PROXY_ADD_TO_FILTER_OPCODE, \
486 (a), \
487 (c) \
488 );
489
505 #define MS_proxy_del_from_list(nh,sh,a,c) \
506 MS_proxy_filter_op \
507 ( \
508 (nh), \
509 (sh), \
510 MS_PROXY_REM_FROM_FILTER_OPCODE, \
511 (a), \
512 (c) \
513 );
514 #endif /* MS_PROXY_CLIENT */
515
516 /* --------------------------------------------- Function */
517
518 #ifdef __cplusplus
519 extern "C" {
520 #endif
521
534 API_RESULT MS_net_register
535 (
536 /* IN */ NET_NTF_CB net_cb
537 );
538
551 API_RESULT MS_net_broadcast_secure_beacon
552 (
553 /* IN */ MS_SUBNET_HANDLE subnet_handle
554 );
555
573 API_RESULT MS_net_send_pdu
574 (
575 /* IN */ MS_NET_HEADER * hdr,
576 /* IN */ MS_SUBNET_HANDLE subnet_handle,
577 /* IN */ MS_BUFFER * buffer
578 );
579
594 MS_NET_ADDR_TYPE MS_net_get_address_type
595 (
596 /* IN */ MS_NET_ADDR addr
597 );
598
611 API_RESULT MS_proxy_register
612 (
613 /* IN */ PROXY_NTF_CB proxy_cb
614 );
615
630 API_RESULT MS_proxy_fetch_state (UCHAR * proxy_state);
631
632 #ifdef MS_PROXY_CLIENT
633
652 API_RESULT MS_proxy_set_filter
653 (
654 /* IN */ NETIF_HANDLE * handle,
655 /* IN */ MS_SUBNET_HANDLE subnet_handle,
656 /* IN */ PROXY_FILTER_TYPE type
657 );
658
677 API_RESULT MS_proxy_filter_op
678 (
679 /* IN */ NETIF_HANDLE * handle,
680 /* IN */ MS_SUBNET_HANDLE subnet_handle,
681 /* IN */ UCHAR opcode,
682 /* IN */ PROXY_ADDR * addr,
683 /* IN */ UINT16 addr_count
684 );
688 #endif /* MS_PROXY_CLIENT */
689
690 /* Function to Start ADV using Proxy */
691 #ifdef MS_PROXY_SERVER
692
709 API_RESULT MS_proxy_server_adv_start
710 (
711 /* IN */ MS_SUBNET_HANDLE subnet_handle,
712 /* IN */ UCHAR proxy_adv_mode
713 );
714
725 API_RESULT MS_proxy_server_adv_stop (void);
726 #endif /* MS_PROXY_SERVER */
727
738 API_RESULT MS_net_alloc_seq_num(/* OUT */ UINT32 * seq_num);
739
740 #ifdef __cplusplus
741 };
742 #endif
743
748 #endif /* _H_MS_NET_API_ */
749


EtherMind Mesh SDK (beta): mesh/export/include/MS_prov_api.h Source File

  • mesh
  • export
  • include
MS_prov_api.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_PROV_API_
15 #define _H_MS_PROV_API_
16
17
18 /* --------------------------------------------- Header File Inclusion */
19 /* Bearer Layer */
20 #include "MS_brr_api.h"
21
22 /* --------------------------------------------- Global Definitions */
23
45 #define PROV_ROLE_DEVICE 0x01
46 #define PROV_ROLE_PROVISIONER 0x02
47
49 #define PROV_BRR_ADV 0x01
50 #define PROV_BRR_GATT 0x02
51
53 #define PROV_PDU_TYPE_INVITE 0x00
54 #define PROV_PDU_TYPE_CAPAB 0x01
55 #define PROV_PDU_TYPE_START 0x02
56 #define PROV_PDU_TYPE_PUBKEY 0x03
57 #define PROV_PDU_TYPE_INPUT_CMPLT 0x04
58 #define PROV_PDU_TYPE_CONF 0x05
59 #define PROV_PDU_TYPE_RAND 0x06
60 #define PROV_PDU_TYPE_DATA 0x07
61 #define PROV_PDU_TYPE_COMPLETE 0x08
62 #define PROV_PDU_TYPE_FAILED 0x09
63
65 #define PROV_ALGO_EC_FIPS_P256 0x00
66
68 #define PROV_PUBKEY_NO_OOB 0x00
69 #define PROV_PUBKEY_OOB 0x01
70
72 #define PROV_AUTH_OOB_NONE 0x00
73 #define PROV_AUTH_OOB_STATIC 0x01
74 #define PROV_AUTH_OOB_OUTPUT 0x02
75 #define PROV_AUTH_OOB_INPUT 0x03
76
78 #define PROV_OOOB_ACTION_BLINK 0x00
79 #define PROV_OOOB_ACTION_BEEP 0x01
80 #define PROV_OOOB_ACTION_VIBRATE 0x02
81 #define PROV_OOOB_ACTION_NUMERIC 0x03
82 #define PROV_OOOB_ACTION_ALPHANUMERIC 0x04
83
85 #define PROV_IOOB_ACTION_PUSH 0x00
86 #define PROV_IOOB_ACTION_TWIST 0x01
87 #define PROV_IOOB_ACTION_NUMERIC 0x02
88 #define PROV_IOOB_ACTION_ALPHANUMERIC 0x03
89
91 #define PROV_MASK_ALGO_EC_FIPS_P256 (1 << 0)
92
94 #define PROV_MASK_PUBKEY_OOBINFO (1 << 0)
95
97 #define PROV_MASK_STATIC_OOBINFO (1 << 0)
98
100 #define PROV_MASK_OOOB_ACTION_BLINK (1 << 0)
101 #define PROV_MASK_OOOB_ACTION_BEEP (1 << 1)
102 #define PROV_MASK_OOOB_ACTION_VIBRATE (1 << 2)
103 #define PROV_MASK_OOOB_ACTION_NUMERIC (1 << 3)
104 #define PROV_MASK_OOOB_ACTION_ALPHANUMERIC (1 << 4)
105
107 #define PROV_MASK_IOOB_ACTION_PUSH (1 << 0)
108 #define PROV_MASK_IOOB_ACTION_TWIST (1 << 1)
109 #define PROV_MASK_IOOB_ACTION_NUMERIC (1 << 2)
110 #define PROV_MASK_IOOB_ACTION_ALPHANUMERIC (1 << 3)
111
119 #define PROV_PCF_NUM_FRGMNTS 0x00
120
122 #define PROV_PCF_CTRL_MSG 0x01
123
125 #define PROV_PCF_CONTINU_FRGMNT 0x02
126
128 #define PROV_PCF_TX_SPECIFIC 0x03
129
138 /* Link Open Request */
139 #define PROV_PB_ADV_OPEN_REQ 0x00
140
141 /* Link Open Confirm */
142 #define PROV_PB_ADV_OPEN_CNF 0x01
143
144 /* Link Close Indication */
145 #define PROV_PB_ADV_CLOSE_IND 0x02
146
155 /* Link Open Indication */
156 #define PROV_PB_GATT_OPEN_IND 0xF1
157
158 /* Link Close Indication */
159 #define PROV_PB_GATT_CLOSE_IND 0xF0
160
170 #define PROV_ERR_PROHIBITED 0x00
171 #define PROV_ERR_INVALID_PDU 0x01
172 #define PROV_ERR_INVALID_FORMAT 0x02
173 #define PROV_ERR_UNEXPECTED_PDU 0x03
174 #define PROV_ERR_CONFIRMATION_FAILED 0x04
175 #define PROV_ERR_OUT_OF_RESOURCES 0x05
176 #define PROV_ERR_DECRYPTION_FAILED 0x06
177 #define PROV_ERR_UNEXPECTED_ERROR 0x07
178 #define PROV_ERR_CANNOT_ASSIGN_ADDRESS 0x08
179
181 #define PROV_CLOSE_REASON_SUCCESS 0x00
182 #define PROV_CLOSE_REASON_TIMEOUT 0x01
183 #define PROV_CLOSE_REASON_FAIL 0x02
184
187 #define PROV_KEY_NETKEY_SIZE 16
188 #define PROV_OOB_VALUE_SIZE 16
189 #define PROV_URI_HASH_SIZE 4
190
192 #define PROV_OOB_TYPE_OTHER (1 << 0)
193 #define PROV_OOB_TYPE_URI (1 << 1)
194 #define PROV_OOB_TYPE_2DMRC (1 << 2)
195 #define PROV_OOB_TYPE_BARCODE (1 << 3)
196 #define PROV_OOB_TYPE_NFC (1 << 4)
197 #define PROV_OOB_TYPE_NUMBER (1 << 5)
198 #define PROV_OOB_TYPE_STRING (1 << 6)
199 #define PROV_OOB_TYPE_ONBOX (1 << 11)
200 #define PROV_OOB_TYPE_INSIDEBOX (1 << 12)
201 #define PROV_OOB_TYPE_ONPIECEOFPAPER (1 << 13)
202 #define PROV_OOB_TYPE_INSIDEMANUAL (1 << 14)
203 #define PROV_OOB_TYPE_ONDEVICE (1 << 15)
204
206 #define PROV_HANDLE_INVALID 0xFF
207
234 #define PROV_EVT_UNPROVISIONED_BEACON 0x01
235
257 #define PROV_EVT_PROVISIONING_SETUP 0x02
258
272 #define PROV_EVT_OOB_DISPLAY 0x03
273
287 #define PROV_EVT_OOB_ENTRY 0x04
288
305 #define PROV_EVT_DEVINPUT_COMPLETE 0x05
306
322 #define PROV_EVT_PROVDATA_INFO_REQ 0x06
323
339 #define PROV_EVT_PROVDATA_INFO 0x07
340
354 #define PROV_EVT_PROVISIONING_COMPLETE 0x08
355
360 /* --------------------------------------------- Structures/Data Types */
361
373 typedef UCHAR PROV_ROLE;
374
376 typedef UCHAR PROV_BRR;
377
379 typedef UCHAR PROV_HANDLE;
380
382 typedef struct _PROV_DEVICE_S
383 {
388 UCHAR uuid[MS_DEVICE_UUID_SIZE];
389
391 UINT16 oob;
392
394 MS_BUFFER * uri;
395
396 } PROV_DEVICE_S;
397
399 typedef struct _PROV_OOB_TYPE_S
400 {
402 UINT16 action;
403
405 UCHAR size;
406
407 } PROV_OOB_TYPE_S;
408
410 typedef struct _PROV_CAPABILITIES_S
411 {
413 UCHAR num_elements;
414
416 UINT16 supp_algorithms;
417
419 UCHAR supp_pubkey;
420
422 UCHAR supp_soob;
423
425 PROV_OOB_TYPE_S ooob;
426
428 PROV_OOB_TYPE_S ioob;
429
430 } PROV_CAPABILITIES_S;
431
433 typedef struct _PROV_METHOD_S
434 {
436 UCHAR algorithm;
437
439 UCHAR pubkey;
440
442 UCHAR auth;
443
445 PROV_OOB_TYPE_S oob;
446
447 } PROV_METHOD_S;
448
450 typedef struct _PROV_DATA_S
451 {
453 UCHAR netkey[PROV_KEY_NETKEY_SIZE];
454
456 UINT16 keyid;
457
469 UCHAR flags;
470
472 UINT32 ivindex;
473
475 UINT16 uaddr;
476
477 } PROV_DATA_S;
478
501 typedef API_RESULT (* PROV_UI_NOTIFY_CB)
502 (
503 PROV_HANDLE * phandle,
504 UCHAR event_type,
505 API_RESULT event_result,
506 void * event_data,
507 UINT16 event_datalen
508 );
509
512 /* --------------------------------------------- Macros */
531 #define MS_prov_setup_device_pbadv(pdev, tmo, phdl) \
532 MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_ADV, (pdev), (tmo), (phdl))
533
545 #define MS_prov_setup_provisioner_pbadv(tmo, phdl) \
546 MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_ADV, NULL, (tmo), (phdl))
547
560 #define MS_prov_setup_device_pbgatt(pdev, tmo, phdl) \
561 MS_prov_setup (PROV_ROLE_DEVICE, PROV_BRR_GATT, (pdev), (tmo), (phdl))
562
574 #define MS_prov_setup_provisioner_pbgatt(tmo, phdl) \
575 MS_prov_setup (PROV_ROLE_PROVISIONER, PROV_BRR_GATT, NULL, (tmo), (phdl))
576
592 #define MS_prov_start(phandle, pmethod) \
593 MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_START, (pmethod), sizeof(PROV_METHOD_S))
594
612 #define MS_prov_input_authval(phandle, pauth, size) \
613 MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_INPUT_CMPLT, (pauth), (size))
614
630 #define MS_prov_data(phandle, pdata) \
631 MS_prov_send_pdu ((phandle), PROV_PDU_TYPE_DATA, (pdata), sizeof (PROV_DATA_S))
632
635 /* --------------------------------------------- API Declarations */
636
643 #ifdef __cplusplus
644 extern "C" {
645 #endif
646
659 API_RESULT MS_prov_register
660 (
661 /* IN */ PROV_CAPABILITIES_S * pcapab,
662 /* IN */ PROV_UI_NOTIFY_CB cb
663 );
664
680 API_RESULT MS_prov_setup
681 (
682 /* IN */ PROV_ROLE role,
683 /* IN */ PROV_BRR bearer,
684 /* IN */ PROV_DEVICE_S * pdevice,
685 /* IN */ UINT16 timeout
686 );
687
705 API_RESULT MS_prov_bind
706 (
707 /* IN */ PROV_BRR bearer,
708 /* IN */ PROV_DEVICE_S * pdevice,
709 /* IN */ UCHAR attention,
710 /* OUT */ PROV_HANDLE * phandle
711 );
712
729 API_RESULT MS_prov_send_pdu
730 (
731 /* IN */ PROV_HANDLE * phandle,
732 /* IN */ UCHAR pdu,
733 /* IN */ void * pdata,
734 /* IN */ UINT16 datalen
735 );
736
750 API_RESULT MS_prov_set_authval
751 (
752 /* IN */ PROV_HANDLE * phandle,
753 /* IN */ void * pdata,
754 /* IN */ UINT16 datalen
755 );
756
770 API_RESULT MS_prov_abort
771 (
772 PROV_HANDLE * phandle,
773 UCHAR reason
774 );
775
789 API_RESULT MS_prov_get_local_public_key
790 (
791 /* OUT */ UCHAR * public_key
792 );
793
794 #ifdef __cplusplus
795 };
796 #endif
797
802 #endif /* _H_MS_PROV_API_ */
803


EtherMind Mesh SDK (beta): mesh/export/include/MS_scene_api.h Source File

  • mesh
  • export
  • include
MS_scene_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_SCENE_API_
14 #define _H_MS_SCENE_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 #define MS_SCENE_EVENT_STORE 0x01
32
34 #define MS_SCENE_EVENT_DELETE 0x02
35
37 #define MS_SCENE_EVENT_RECALL_START 0x03
38
40 #define MS_SCENE_EVENT_RECALL_COMPLETE 0x04
41
43 #define MS_SCENE_EVENT_RECALL_IMMEDIATE 0x05
44
45 /* --------------------------------------------- Data Types/ Structures */
67 typedef void * (* MS_SCENE_SERVER_CB)
68 (
69 MS_ACCESS_MODEL_HANDLE * handle,
70 UINT8 event_type,
71 void * event_param,
72 UINT16 event_length,
73 void * context
74 ) DECL_REENTRANT;
75
87 typedef API_RESULT (* MS_SCENE_CLIENT_CB)
88 (
89 MS_ACCESS_MODEL_HANDLE * handle,
90 UINT32 opcode,
91 UCHAR * data_param,
92 UINT16 data_len
93 ) DECL_REENTRANT;
104 typedef struct MS_scene_recall_struct
105 {
107 UINT16 scene_number;
108
110 UCHAR tid;
111
123 UCHAR transition_time;
124
126 UCHAR delay;
127
129 UCHAR optional_fields_present;
130
131 } MS_SCENE_RECALL_STRUCT;
132
136 typedef struct MS_scene_status_struct
137 {
139 UCHAR status_code;
140
142 UINT16 current_scene;
143
145 UINT16 target_scene;
146
158 UCHAR remaining_time;
159
161 UCHAR optional_fields_present;
162
163 } MS_SCENE_STATUS_STRUCT;
164
168 typedef struct MS_scene_register_status_struct
169 {
171 UCHAR status_code;
172
174 UINT16 current_scene;
175
177 UCHAR *scenes;
178
180 UINT16 scenes_len;
181
182 } MS_SCENE_REGISTER_STATUS_STRUCT;
183
187 typedef struct MS_scene_struct
188 {
190 UINT16 scene_number;
191
192 } MS_SCENE_STRUCT;
193
198 /* --------------------------------------------- Function */
233 API_RESULT MS_scene_server_init
234 (
235 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
236 /* INOUT */ MS_ACCESS_MODEL_HANDLE * scene_model_handle,
237 /* INOUT */ MS_ACCESS_MODEL_HANDLE * scene_setup_model_handle,
238 /* IN */ MS_SCENE_SERVER_CB appl_cb
239 );
240
255 API_RESULT MS_scene_server_state_update
256 (
257 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
258 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
259 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
260 /* IN */ UINT16 remaining_time,
261 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
262 );
289 API_RESULT MS_scene_client_init
290 (
291 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
292 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
293 /* IN */ MS_SCENE_CLIENT_CB appl_cb
294 );
295
306 API_RESULT MS_scene_client_get_model_handle
307 (
308 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
309 );
310
323 API_RESULT MS_scene_client_send_reliable_pdu
324 (
325 /* IN */ UINT32 req_opcode,
326 /* IN */ void * param,
327 /* IN */ UINT32 rsp_opcode
328 );
329
341 #define MS_scene_recall(param) \
342 MS_scene_client_send_reliable_pdu \
343 (\
344 MS_ACCESS_SCENE_RECALL_OPCODE,\
345 param,\
346 MS_ACCESS_SCENE_STATUS_OPCODE\
347 )
348
359 #define MS_scene_recall_unacknowledged(param) \
360 MS_scene_client_send_reliable_pdu \
361 (\
362 MS_ACCESS_SCENE_RECALL_UNACKNOWLEDGED_OPCODE,\
363 param,\
364 0xFFFFFFFF\
365 )
366
378 #define MS_scene_store(param) \
379 MS_scene_client_send_reliable_pdu \
380 (\
381 MS_ACCESS_SCENE_STORE_OPCODE,\
382 param,\
383 MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE\
384 )
385
396 #define MS_scene_delete_unacknowledged(param) \
397 MS_scene_client_send_reliable_pdu \
398 (\
399 MS_ACCESS_SCENE_DELETE_UNACKNOWLEDGED_OPCODE,\
400 param,\
401 0xFFFFFFFF\
402 )
403
414 #define MS_scene_get() \
415 MS_scene_client_send_reliable_pdu \
416 (\
417 MS_ACCESS_SCENE_GET_OPCODE,\
418 NULL,\
419 MS_ACCESS_SCENE_STATUS_OPCODE\
420 )
421
433 #define MS_scene_delete(param) \
434 MS_scene_client_send_reliable_pdu \
435 (\
436 MS_ACCESS_SCENE_DELETE_OPCODE,\
437 param,\
438 MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE\
439 )
440
451 #define MS_scene_store_unacknowledged(param) \
452 MS_scene_client_send_reliable_pdu \
453 (\
454 MS_ACCESS_SCENE_STORE_UNACKNOWLEDGED_OPCODE,\
455 param,\
456 0xFFFFFFFF\
457 )
458
469 #define MS_scene_register_get() \
470 MS_scene_client_send_reliable_pdu \
471 (\
472 MS_ACCESS_SCENE_REGISTER_GET_OPCODE,\
473 NULL,\
474 MS_ACCESS_SCENE_REGISTER_STATUS_OPCODE\
475 )
476
480 #endif /*_H_MS_SCENE_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_scheduler_api.h Source File

  • mesh
  • export
  • include
MS_scheduler_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_SCHEDULER_API_
14 #define _H_MS_SCHEDULER_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_SCHEDULER_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_SCHEDULER_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
89 typedef struct MS_scheduler_status_struct
90 {
92 UINT16 schedules;
93
94 } MS_SCHEDULER_STATUS_STRUCT;
95
99 typedef struct MS_scheduler_action_get_struct
100 {
102 UCHAR index;
103
104 } MS_SCHEDULER_ACTION_GET_STRUCT;
105
111 typedef struct MS_scheduler_action_status_struct
112 {
114 UCHAR index;
115
117 UINT8 year;
118
120 UINT16 month;
121
123 UINT8 day;
124
126 UINT8 hour;
127
129 UINT8 minute;
130
132 UINT8 second;
133
135 UINT8 day_of_week;
136
138 UINT8 action;
139
141 UINT8 transition_time;
142
144 UINT16 scene_number;
145 } MS_SCHEDULER_ACTION_STATUS_STRUCT;
146
150 typedef struct MS_scheduler_action_set_struct
151 {
153 UCHAR index;
154
156 UINT8 year;
157
159 UINT16 month;
160
162 UINT8 day;
163
165 UINT8 hour;
166
168 UINT8 minute;
169
171 UINT8 second;
172
174 UINT8 day_of_week;
175
177 UINT8 action;
178
180 UINT8 transition_time;
181
183 UINT16 scene_number;
184
185 } MS_SCHEDULER_ACTION_SET_STRUCT;
186
191 /* --------------------------------------------- Function */
226 API_RESULT MS_scheduler_server_init
227 (
228 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
229 /* INOUT */ MS_ACCESS_MODEL_HANDLE * scheduler_model_handle,
230 /* INOUT */ MS_ACCESS_MODEL_HANDLE * scheduler_setup_model_handle,
231 /* IN */ MS_SCHEDULER_SERVER_CB appl_cb
232 );
233
248 API_RESULT MS_scheduler_server_state_update
249 (
250 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
251 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
252 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
253 /* IN */ UINT16 remaining_time,
254 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
255 );
282 API_RESULT MS_scheduler_client_init
283 (
284 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
285 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
286 /* IN */ MS_SCHEDULER_CLIENT_CB appl_cb
287 );
288
299 API_RESULT MS_scheduler_client_get_model_handle
300 (
301 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
302 );
303
316 API_RESULT MS_scheduler_client_send_reliable_pdu
317 (
318 /* IN */ UINT32 req_opcode,
319 /* IN */ void * param,
320 /* IN */ UINT32 rsp_opcode
321 );
322
335 #define MS_scheduler_action_set(param) \
336 MS_scheduler_client_send_reliable_pdu \
337 (\
338 MS_ACCESS_SCHEDULER_ACTION_SET_OPCODE,\
339 param,\
340 MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE\
341 )
342
353 #define MS_scheduler_get() \
354 MS_scheduler_client_send_reliable_pdu \
355 (\
356 MS_ACCESS_SCHEDULER_GET_OPCODE,\
357 NULL,\
358 MS_ACCESS_SCHEDULER_STATUS_OPCODE\
359 )
360
372 #define MS_scheduler_action_set_unacknowledged(param) \
373 MS_scheduler_client_send_reliable_pdu \
374 (\
375 MS_ACCESS_SCHEDULER_ACTION_SET_UNACKNOWLEDGED_OPCODE,\
376 param,\
377 0xFFFFFFFF\
378 )
379
393 #define MS_scheduler_action_get(param) \
394 MS_scheduler_client_send_reliable_pdu \
395 (\
396 MS_ACCESS_SCHEDULER_ACTION_GET_OPCODE,\
397 param,\
398 MS_ACCESS_SCHEDULER_ACTION_STATUS_OPCODE\
399 )
400
404 #endif /*_H_MS_SCHEDULER_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_sensor_api.h Source File

  • mesh
  • export
  • include
MS_sensor_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_SENSOR_API_
14 #define _H_MS_SENSOR_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_SENSOR_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
73 typedef API_RESULT (* MS_SENSOR_SETUP_SERVER_CB)
74 (
75 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
76 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
77 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
78 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
79 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
80
81 ) DECL_REENTRANT;
82
94 typedef API_RESULT (* MS_SENSOR_CLIENT_CB)
95 (
96 MS_ACCESS_MODEL_HANDLE * handle,
97 UINT32 opcode,
98 UCHAR * data_param,
99 UINT16 data_len
100 ) DECL_REENTRANT;
111 typedef struct MS_sensor_descriptor_get_struct
112 {
114 UINT16 property_id;
115
117 UCHAR optional_fields_present;
118
119 } MS_SENSOR_DESCRIPTOR_GET_STRUCT;
120
124 typedef struct MS_sensor_descriptor_status_struct
125 {
127 UCHAR * descriptor;
128
130 UCHAR optional_fields_present;
131
132 } MS_SENSOR_DESCRIPTOR_STATUS_STRUCT;
133
137 typedef struct MS_sensor_get_struct
138 {
140 UINT16 property_id;
141
143 UCHAR optional_fields_present;
144
145 } MS_SENSOR_GET_STRUCT;
146
150 typedef struct MS_sensor_status_struct
151 {
153 UCHAR *marshalled_sensor_data;
154
156 UINT16 marshalled_sensor_data_len;
157
159 UCHAR optional_fields_present;
160
161 } MS_SENSOR_STATUS_STRUCT;
162
166 typedef struct MS_sensor_column_get_struct
167 {
169 UINT16 property_id;
170
172 UCHAR *raw_value_x;
173
175 UINT16 raw_value_x_len;
176
177 } MS_SENSOR_COLUMN_GET_STRUCT;
178
179
183 typedef struct MS_sensor_column_status_struct
184 {
186 UINT16 property_id;
187
189 UCHAR *raw_value_x;
190
192 UINT16 raw_value_x_len;
193
195 UCHAR *column_width;
196
198 UINT16 column_width_len;
199
201 UCHAR *raw_value_y;
202
204 UINT16 raw_value_y_len;
205
207 UCHAR optional_fields_present;
208
209 } MS_SENSOR_COLUMN_STATUS_STRUCT;
210
214 typedef struct MS_sensor_series_get_struct
215 {
217 UINT16 property_id;
218
220 UCHAR *raw_value_x1;
221
223 UINT16 raw_value_x1_len;
224
226 UCHAR *raw_value_x2;
227
229 UINT16 raw_value_x2_len;
230
232 UCHAR optional_fields_present;
233
234 } MS_SENSOR_SERIES_GET_STRUCT;
235
239 typedef struct MS_sensor_series_status_struct
240 {
242 UINT16 property_id;
243
245 UCHAR *raw_value_x;
246
248 UINT16 raw_value_x_len;
249
251 UCHAR *column_width;
252
254 UINT16 column_width_len;
255
257 UCHAR *raw_value_y;
258
260 UINT16 raw_value_y_len;
261
262 } MS_SENSOR_SERIES_STATUS_STRUCT;
263
267 typedef struct MS_sensor_cadence_get_struct
268 {
270 UINT16 property_id;
271
272 } MS_SENSOR_CADENCE_GET_STRUCT;
273
277 typedef struct MS_sensor_cadence_set_struct
278 {
280 UINT16 property_id;
281
283 UCHAR fast_cadence_period_divisor;
284
286 UCHAR status_trigger_type;
287
289 UCHAR *status_trigger_delta_down;
290
292 UINT16 status_trigger_delta_down_len;
293
295 UCHAR *status_trigger_delta_up;
296
298 UINT16 status_trigger_delta_up_len;
299
301 UCHAR status_min_interval;
302
304 UCHAR *fast_cadence_low;
305
307 UINT16 fast_cadence_low_len;
308
310 UCHAR *fast_cadence_high;
311
313 UINT16 fast_cadence_high_len;
314
315 } MS_SENSOR_CADENCE_SET_STRUCT;
316
320 typedef struct MS_sensor_cadence_status_struct
321 {
323 UINT16 property_id;
324
326 UCHAR fast_cadence_period_divisor;
327
329 UCHAR status_trigger_type;
330
332 UCHAR *status_trigger_delta_down;
333
335 UINT16 status_trigger_delta_down_len;
336
338 UCHAR *status_trigger_delta_up;
339
341 UINT16 status_trigger_delta_up_len;
342
344 UCHAR status_min_interval;
345
347 UCHAR *fast_cadence_low;
348
350 UINT16 fast_cadence_low_len;
351
353 UCHAR *fast_cadence_high;
354
356 UINT16 fast_cadence_high_len;
357
358 } MS_SENSOR_CADENCE_STATUS_STRUCT;
359
363 typedef struct MS_sensor_settings_get_struct
364 {
366 UINT16 sensor_property_id;
367
368 } MS_SENSOR_SETTINGS_GET_STRUCT;
369
373 typedef struct MS_sensor_settings_status_struct
374 {
376 UINT16 sensor_property_id;
377
382 UINT16 *sensor_setting_property_ids;
383
385 UINT16 sensor_setting_property_ids_count;
386
387 } MS_SENSOR_SETTINGS_STATUS_STRUCT;
388
392 typedef struct MS_sensor_setting_get_struct
393 {
395 UINT16 sensor_property_id;
396
398 UINT16 sensor_setting_property_id;
399
400 } MS_SENSOR_SETTING_GET_STRUCT;
401
405 typedef struct MS_sensor_setting_set_struct
406 {
408 UINT16 sensor_property_id;
409
411 UINT16 sensor_setting_property_id;
412
414 UCHAR *sensor_setting_raw;
415
417 UINT16 sensor_setting_raw_len;
418
419 } MS_SENSOR_SETTING_SET_STRUCT;
420
424 typedef struct MS_sensor_setting_status_struct
425 {
427 UINT16 sensor_property_id;
428
430 UINT16 sensor_setting_property_id;
431
433 UCHAR sensor_setting_access;
434
436 UCHAR *sensor_setting_raw;
437
439 UINT16 sensor_setting_raw_len;
440
442 UCHAR optional_fields_present;
443
444 } MS_SENSOR_SETTING_STATUS_STRUCT;
445
450 /* --------------------------------------------- Function */
480 API_RESULT MS_sensor_server_init
481 (
482 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
483 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
484 /* IN */ MS_SENSOR_SERVER_CB appl_cb
485 );
486
505 API_RESULT MS_sensor_setup_server_init
506 (
507 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
508 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
509 /* IN */ MS_SENSOR_SETUP_SERVER_CB appl_cb
510 );
511
526 API_RESULT MS_sensor_server_state_update
527 (
528 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
529 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
530 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
531 /* IN */ UINT16 remaining_time,
532 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
533 );
534
549 API_RESULT MS_sensor_setup_server_state_update
550 (
551 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
552 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
553 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
554 /* IN */ UINT16 remaining_time,
555 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
556 );
583 API_RESULT MS_sensor_client_init
584 (
585 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
586 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
587 /* IN */ MS_SENSOR_CLIENT_CB appl_cb
588 );
589
600 API_RESULT MS_sensor_client_get_model_handle
601 (
602 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
603 );
604
617 API_RESULT MS_sensor_client_send_reliable_pdu
618 (
619 /* IN */ UINT32 req_opcode,
620 /* IN */ void * param,
621 /* IN */ UINT32 rsp_opcode
622 );
623
635 #define MS_sensor_setting_get(param) \
636 MS_sensor_client_send_reliable_pdu \
637 (\
638 MS_ACCESS_SENSOR_SETTING_GET_OPCODE,\
639 param,\
640 MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE\
641 )
642
654 #define MS_sensor_settings_get(param) \
655 MS_sensor_client_send_reliable_pdu \
656 (\
657 MS_ACCESS_SENSOR_SETTINGS_GET_OPCODE,\
658 param,\
659 MS_ACCESS_SENSOR_SETTINGS_STATUS_OPCODE\
660 )
661
673 #define MS_sensor_series_get(param) \
674 MS_sensor_client_send_reliable_pdu \
675 (\
676 MS_ACCESS_SENSOR_SERIES_GET_OPCODE,\
677 param,\
678 MS_ACCESS_SENSOR_SERIES_STATUS_OPCODE\
679 )
680
692 #define MS_sensor_cadence_get(param) \
693 MS_sensor_client_send_reliable_pdu \
694 (\
695 MS_ACCESS_SENSOR_CADENCE_GET_OPCODE,\
696 param,\
697 MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE\
698 )
699
711 #define MS_sensor_descriptor_get(param) \
712 MS_sensor_client_send_reliable_pdu \
713 (\
714 MS_ACCESS_SENSOR_DESCRIPTOR_GET_OPCODE,\
715 param,\
716 MS_ACCESS_SENSOR_DESCRIPTOR_STATUS_OPCODE\
717 )
718
730 #define MS_sensor_cadence_set(param) \
731 MS_sensor_client_send_reliable_pdu \
732 (\
733 MS_ACCESS_SENSOR_CADENCE_SET_OPCODE,\
734 param,\
735 MS_ACCESS_SENSOR_CADENCE_STATUS_OPCODE\
736 )
737
749 #define MS_sensor_setting_set(param) \
750 MS_sensor_client_send_reliable_pdu \
751 (\
752 MS_ACCESS_SENSOR_SETTING_SET_OPCODE,\
753 param,\
754 MS_ACCESS_SENSOR_SETTING_STATUS_OPCODE\
755 )
756
768 #define MS_sensor_get(param) \
769 MS_sensor_client_send_reliable_pdu \
770 (\
771 MS_ACCESS_SENSOR_GET_OPCODE,\
772 param,\
773 MS_ACCESS_SENSOR_STATUS_OPCODE\
774 )
775
787 #define MS_sensor_column_get(param) \
788 MS_sensor_client_send_reliable_pdu \
789 (\
790 MS_ACCESS_SENSOR_COLUMN_GET_OPCODE,\
791 param,\
792 MS_ACCESS_SENSOR_COLUMN_STATUS_OPCODE\
793 )
794
805 #define MS_sensor_cadence_set_unacknowledged(param) \
806 MS_sensor_client_send_reliable_pdu \
807 (\
808 MS_ACCESS_SENSOR_CADENCE_SET_UNACKNOWLEDGED_OPCODE,\
809 param,\
810 0xFFFFFFFF\
811 )
812
823 #define MS_sensor_setting_set_unacknowledged(param) \
824 MS_sensor_client_send_reliable_pdu \
825 (\
826 MS_ACCESS_SENSOR_SETTING_SET_UNACKNOWLEDGED_OPCODE,\
827 param,\
828 0xFFFFFFFF\
829 )
830
834 #endif /*_H_MS_SENSOR_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_time_api.h Source File

  • mesh
  • export
  • include
MS_time_api.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_TIME_API_
14 #define _H_MS_TIME_API_
15
16
17 /* --------------------------------------------- Header File Inclusion */
18 #include "MS_access_api.h"
19
20
21 /* --------------------------------------------- Global Definitions */
31 /* --------------------------------------------- Data Types/ Structures */
51 typedef API_RESULT (* MS_TIME_SERVER_CB)
52 (
53 MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
54 MS_ACCESS_MODEL_REQ_MSG_RAW * msg_raw,
55 MS_ACCESS_MODEL_REQ_MSG_T * req_type,
56 MS_ACCESS_MODEL_STATE_PARAMS * state_params,
57 MS_ACCESS_MODEL_EXT_PARAMS * ext_params
58
59 ) DECL_REENTRANT;
60
72 typedef API_RESULT (* MS_TIME_CLIENT_CB)
73 (
74 MS_ACCESS_MODEL_HANDLE * handle,
75 UINT32 opcode,
76 UCHAR * data_param,
77 UINT16 data_len
78 ) DECL_REENTRANT;
89 typedef struct MS_time_struct
90 {
92 UCHAR tai_seconds[5];
93
95 UCHAR subsecond;
96
98 UCHAR uncertainty;
99
101 UCHAR time_authority;
102
104 UINT16 tai_utc_delta;
105
107 UCHAR time_zone_offset;
108
109 } MS_TIME_STRUCT;
110
114 typedef struct MS_time_zone_set_struct
115 {
117 UCHAR time_zone_offset_new;
118
120 UCHAR tai_of_zone_change[5];
121
122 } MS_TIME_ZONE_SET_STRUCT;
123
127 typedef struct MS_time_zone_status_struct
128 {
130 UCHAR time_zone_offset_current;
131
133 UCHAR time_zone_offset_new;
134
136 UCHAR tai_of_zone_change[5];
137
138 } MS_TIME_ZONE_STATUS_STRUCT;
139
143 typedef struct MS_tai_utc_delta_set_struct
144 {
146 UINT16 tai_utc_delta_new;
147
149 UCHAR padding;
150
152 UCHAR tai_of_delta_change[5];
153
154 } MS_TAI_UTC_DELTA_SET_STRUCT;
155
159 typedef struct MS_tai_utc_delta_status_struct
160 {
162 UINT16 tai_utc_delta_current;
163
165 UCHAR padding_1;
166
168 UINT16 tai_utc_delta_new;
169
171 UCHAR padding_2;
172
174 UCHAR tai_of_delta_change[5];
175
176 } MS_TAI_UTC_DELTA_STATUS_STRUCT;
177
181 typedef struct MS_time_role_struct
182 {
184 UCHAR time_role;
185
186 } MS_TIME_ROLE_STRUCT;
187
192 /* --------------------------------------------- Function */
227 API_RESULT MS_time_server_init
228 (
229 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
230 /* INOUT */ MS_ACCESS_MODEL_HANDLE * time_model_handle,
231 /* INOUT */ MS_ACCESS_MODEL_HANDLE * time_setup_model_handle,
232 /* IN */ MS_TIME_SERVER_CB appl_cb
233 );
234
249 API_RESULT MS_time_server_state_update
250 (
251 /* IN */ MS_ACCESS_MODEL_REQ_MSG_CONTEXT * ctx,
252 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * current_state_params,
253 /* IN */ MS_ACCESS_MODEL_STATE_PARAMS * target_state_params,
254 /* IN */ UINT16 remaining_time,
255 /* IN */ MS_ACCESS_MODEL_EXT_PARAMS * ext_params
256 );
283 API_RESULT MS_time_client_init
284 (
285 /* IN */ MS_ACCESS_ELEMENT_HANDLE element_handle,
286 /* INOUT */ MS_ACCESS_MODEL_HANDLE * model_handle,
287 /* IN */ MS_TIME_CLIENT_CB appl_cb
288 );
289
300 API_RESULT MS_time_client_get_model_handle
301 (
302 /* OUT */ MS_ACCESS_MODEL_HANDLE * model_handle
303 );
304
317 API_RESULT MS_time_client_send_reliable_pdu
318 (
319 /* IN */ UINT32 req_opcode,
320 /* IN */ void * param,
321 /* IN */ UINT32 rsp_opcode
322 );
323
335 #define MS_time_set(param) \
336 MS_time_client_send_reliable_pdu \
337 (\
338 MS_ACCESS_TIME_SET_OPCODE,\
339 param,\
340 MS_ACCESS_TIME_STATUS_OPCODE\
341 )
342
354 #define MS_time_zone_get() \
355 MS_time_client_send_reliable_pdu \
356 (\
357 MS_ACCESS_TIME_ZONE_GET_OPCODE,\
358 NULL,\
359 MS_ACCESS_TIME_ZONE_STATUS_OPCODE\
360 )
361
372 #define MS_tai_utc_delta_set(param) \
373 MS_time_client_send_reliable_pdu \
374 (\
375 MS_ACCESS_TAI_UTC_DELTA_SET_OPCODE,\
376 param,\
377 MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE\
378 )
379
391 #define MS_time_role_set(param) \
392 MS_time_client_send_reliable_pdu \
393 (\
394 MS_ACCESS_TIME_ROLE_SET_OPCODE,\
395 param,\
396 MS_ACCESS_TIME_ROLE_STATUS_OPCODE\
397 )
398
410 #define MS_tai_utc_delta_get() \
411 MS_time_client_send_reliable_pdu \
412 (\
413 MS_ACCESS_TAI_UTC_DELTA_GET_OPCODE,\
414 NULL,\
415 MS_ACCESS_TAI_UTC_DELTA_STATUS_OPCODE\
416 )
417
428 #define MS_time_zone_set(param) \
429 MS_time_client_send_reliable_pdu \
430 (\
431 MS_ACCESS_TIME_ZONE_SET_OPCODE,\
432 param,\
433 MS_ACCESS_TIME_ZONE_STATUS_OPCODE\
434 )
435
446 #define MS_time_role_get() \
447 MS_time_client_send_reliable_pdu \
448 (\
449 MS_ACCESS_TIME_ROLE_GET_OPCODE,\
450 NULL,\
451 MS_ACCESS_TIME_ROLE_STATUS_OPCODE\
452 )
453
464 #define MS_time_get() \
465 MS_time_client_send_reliable_pdu \
466 (\
467 MS_ACCESS_TIME_GET_OPCODE,\
468 NULL,\
469 MS_ACCESS_TIME_STATUS_OPCODE\
470 )
471
475 #endif /*_H_MS_TIME_API_ */


EtherMind Mesh SDK (beta): mesh/export/include/MS_trn_api.h Source File

  • mesh
  • export
  • include
MS_trn_api.h
Go to the documentation of this file.
1
9 /*
10 * Copyright (C) 2017. Mindtree Ltd.
11 * All rights reserved.
12 */
13
14 #ifndef _H_MS_TRN_API_
15 #define _H_MS_TRN_API_
16
17
18 /* --------------------------------------------- Header File Inclusion */
19 /* Lower Transport Layer */
20 #include "MS_ltrn_api.h"
21
22 /* --------------------------------------------- Global Definitions */
23
54 #define MS_TRN_CTRL_OPCODE_FRND_POLL 0x01
55
60 #define MS_TRN_CTRL_OPCODE_FRND_UPDATE 0x02
61
63 #define MS_TRN_CTRL_OPCODE_FRND_REQ 0x03
64
66 #define MS_TRN_CTRL_OPCODE_FRND_OFFER 0x04
67
72 #define MS_TRN_CTRL_OPCODE_FRND_CLEAR 0x05
73
78 #define MS_TRN_CTRL_OPCODE_FRND_CLEAR_CNF 0x06
79
84 #define MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD 0x07
85
90 #define MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE 0x08
91
93 #define MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_CNF 0x09
94
96 #define MS_TRN_CTRL_OPCODE_HEARTBEAT 0x0A
97
112 #define MS_FRNDUPD_FLAG_KEYREF_BIT 0
113 #define MS_FRNDUPD_FLAG_KEYREF_NOTINPHASE_2 0x00
114 #define MS_FRNDUPD_FLAG_KEYREF_INPHASE_2 0x01
115
116 #define MS_FRNDUPD_FLAG_IVUPDATE_BIT 1
117 #define MS_FRNDUPD_FLAG_IVUPDATE_NORMAL 0x00
118 #define MS_FRNDUPD_FLAG_IVUPDATE_ACTIVE 0x01
119
123 #define MS_FRNDUPD_MD_QUEUE_EMPTY 0x00
124 #define MS_FRNDUPD_MD_QUEUE_NOTEMPTY 0x01
125
129 #define MS_FRNDREQ_RSSIFACTOR_OFFSET 5
130 #define MS_FRNDREQ_RSSIFACTOR_MASK 0x60
131 #define MS_FRNDREQ_RSSIFACTOR_1 0x00
132 #define MS_FRNDREQ_RSSIFACTOR_1_5 0x01
133 #define MS_FRNDREQ_RSSIFACTOR_2 0x02
134 #define MS_FRNDREQ_RSSIFACTOR_2_5 0x03
135
136 #define MS_FRNDREQ_RCVWINFACTOR_OFFSET 3
137 #define MS_FRNDREQ_RCVWINFACTOR_MASK 0x18
138 #define MS_FRNDREQ_RCVWINFACTOR_1 0x00
139 #define MS_FRNDREQ_RCVWINFACTOR_1_5 0x01
140 #define MS_FRNDREQ_RCVWINFACTOR_2 0x02
141 #define MS_FRNDREQ_RCVWINFACTOR_2_5 0x03
142
143 #define MS_FRNDREQ_MINQSIZELOG_OFFSET 0
144 #define MS_FRNDREQ_MINQSIZELOG_MASK 0x07
145 #define MS_FRNDREQ_MINQSIZE_INVALID 0x00
146 #define MS_FRNDREQ_MINQSIZE_2 0x01
147 #define MS_FRNDREQ_MINQSIZE_4 0x02
148 #define MS_FRNDREQ_MINQSIZE_8 0x03
149 #define MS_FRNDREQ_MINQSIZE_16 0x04
150 #define MS_FRNDREQ_MINQSIZE_32 0x05
151 #define MS_FRNDREQ_MINQSIZE_64 0x06
152 #define MS_FRNDREQ_MINQSIZE_128 0x07
153
157 #define MS_HEARTBEAT_FEATURE_RELAY (1 << 0)
158 #define MS_HEARTBEAT_FEATURE_PROXY (1 << 1)
159 #define MS_HEARTBEAT_FEATURE_FRIEND (1 << 2)
160 #define MS_HEARTBEAT_FEATURE_LOWPOWER (1 << 3)
161
163 #define MS_MIN_FRNDOFFER_DELAY 100 /* ms */
164 #define MS_TRN_INITIAL_FRNDPOLL_TIMEOUT 1000 /* ms */
165
174 #define MS_TRN_FRIEND_SETUP_CNF 0x00
175 #define MS_TRN_FRIEND_SUBSCRNLIST_CNF 0x01
176 #define MS_TRN_FRIEND_CLEAR_CNF 0x02
177 #define MS_TRN_FRIEND_TERMINATE_IND 0x03
178
190 /* --------------------------------------------- Data Types/ Structures */
191
225 typedef void (*TRN_NTF_CB)
226 (
227 MS_NET_HEADER * net_hdr,
228 MS_SUBNET_HANDLE subnet_handle,
229 MS_APPKEY_HANDLE appkey_handle,
230 UCHAR * data_param,
231 UINT16 data_len
232 ) DECL_REENTRANT;
233
244 typedef void (*TRN_FRND_CB)
245 (
246 MS_SUBNET_HANDLE subnet_handle,
247 UCHAR event_type,
248 UINT16 status
249 ) DECL_REENTRANT;
250
263 typedef UCHAR MS_TRN_CTRL_PKT_OPCODE;
264
266 typedef struct _MS_TRN_FRIEND_ENTRY
267 {
269 UINT8 fsn;
270
272 MS_NET_ADDR addr;
273
275 UINT8 num_elements;
276
278 MS_NET_ADDR prev_faddr;
279
281 /* UINT32 q; */
282
284 /* UINT32 subscription_list; */
285
286 } MS_TRN_FRIEND_ENTRY;
287
289 typedef struct _MS_TRN_FRND_POLL_PARAM
290 {
295 UINT8 fsn;
296
297 } MS_TRN_FRND_POLL_PARAM;
298
300 typedef struct _MS_TRN_FRND_UPDATE_PARAM
301 {
303 UINT8 flags;
304
306 UINT32 ivi;
307
316 UCHAR md;
317
318 } MS_TRN_FRND_UPDATE_PARAM;
319
321 typedef struct _MS_TRN_FRND_REQ_PARAM
322 {
327 UCHAR criteria;
328
330 UCHAR rx_delay;
331
333 UINT32 poll_to;
334
336 UINT16 prev_addr;
337
339 UCHAR num_elem;
340
342 UINT16 lpn_counter;
343
344 } MS_TRN_FRND_REQ_PARAM;
345
347 typedef struct _MS_TRN_FRND_OFFER_PARAM
348 {
350 UINT8 rx_window;
351
353 UINT8 queue_size;
354
359 UINT8 sublist_size;
360
362 UINT8 rssi;
363
365 UINT16 frnd_counter;
366
367 } MS_TRN_FRND_OFFER_PARAM;
368
370 typedef struct _MS_TRN_FRND_CLEAR_PARAM
371 {
373 UINT16 lpn_addr;
374
376 UINT16 lpn_counter;
377
378 } MS_TRN_FRND_CLEAR_PARAM;
379
381 typedef struct _MS_TRN_FRND_CLEAR_CNF_PARAM
382 {
384 UINT16 lpn_addr;
385
387 UINT16 lpn_counter;
388
389 } MS_TRN_FRND_CLEAR_CNF_PARAM;
390
392 typedef struct _MS_TRN_FRND_MANAGE_PARAM
393 {
395 UINT8 txn_num;
396
403 void * addr_list;
404
410 UINT16 num_addr;
411
413 UINT8 opcode;
414
415 } MS_TRN_FRND_MANAGE_PARAM;
416
418 typedef struct _MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM
419 {
421 UINT8 txn_num;
422
423 } MS_TRN_FRND_SUBSCRN_LIST_CNF_PARAM;
424
426 typedef struct _MS_TRN_HEARTBEAT_PARAM
427 {
429 UINT8 init_ttl;
430
432 UINT16 features;
433
434 } MS_TRN_HEARTBEAT_PARAM;
435
437 typedef struct _MS_TRN_FRNDSHIP_INFO
438 {
439 /* Main subnet handle of the element */
440 MS_SUBNET_HANDLE subnet_handle;
441
442 /* Peer LPN/Friend Address */
443 MS_NET_ADDR addr;
444
445 /* Low Power Node Counter */
446 UINT16 lpn_counter;
447
448 /* Friend Counter - TODO: Should be a global index? */
449 UINT16 frnd_counter;
450
451 } MS_TRN_FRNDSHIP_INFO;
452
453 /* Invalid LPN Handle */
454 #define LPN_HANDLE_INVALID MS_CONFIG_LIMITS(MS_MAX_FRIENDS)
455
457 typedef struct _MS_TRN_HEARTBEAT_PUBLICATION_INFO
458 {
462 MS_NET_ADDR daddr;
463
468 UINT8 count_log;
469
474 UINT8 period_log;
475
479 UINT8 ttl;
480
484 UINT16 features;
485
489 UINT16 netkey_index;
490
491 }MS_TRN_HEARTBEAT_PUBLICATION_INFO;
492
494 typedef struct _MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO
495 {
499 MS_NET_ADDR saddr;
500
504 MS_NET_ADDR daddr;
505
511 UINT8 count_log;
512
517 UINT8 period_log;
518
523 UINT16 min_hops;
524
529 UINT16 max_hops;
530
531 }MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO;
532
540 /* --------------------------------------------- Function */
541
547 #ifdef __cplusplus
548 extern "C" {
549 #endif
550
566 API_RESULT MS_trn_register
567 (
568 /* IN */ TRN_NTF_CB trn_cb,
569 /* IN */ MS_TRN_MSG_TYPE msg_type
570 );
571
572
602 API_RESULT MS_trn_send_access_pdu
603 (
604 /* IN */ MS_NET_ADDR src_addr,
605 /* IN */ MS_NET_ADDR dst_addr,
606 /* IN */ UINT8 * label,
607 /* IN */ MS_SUBNET_HANDLE subnet_handle,
608 /* IN */ MS_APPKEY_HANDLE appkey_handle,
609 /* IN */ UINT8 ttl,
610 /* IN */ void * param
611 );
612
639 API_RESULT MS_trn_send_control_pdu
640 (
641 /* IN */ MS_NET_ADDR src_addr,
642 /* IN */ MS_NET_ADDR dst_addr,
643 /* IN */ MS_SUBNET_HANDLE subnet_handle,
644 /* IN */ UINT8 ttl,
645 /* IN */ MS_TRN_CTRL_PKT_OPCODE ctrl_opcode,
646 /* IN */ void * param
647 );
648
649
681 API_RESULT MS_trn_lpn_setup_friendship
682 (
683 /* IN */ MS_SUBNET_HANDLE subnet_handle,
684 /* IN */ UCHAR criteria,
685 /* IN */ UCHAR rx_delay,
686 /* IN */ UINT32 poll_timeout,
687 /* IN */ UINT32 setup_timeout,
688 /* IN */ TRN_FRND_CB cb
689 );
690
691
701 API_RESULT MS_trn_lpn_clear_friendship(void);
702
703
723 API_RESULT MS_trn_lpn_manage_subscription
724 (
725 UCHAR action,
726 UINT16 * addr_list,
727 UINT16 count
728 );
729
730
746 #define MS_trn_lpn_subscrn_list_add(addr_list, count)\
747 MS_trn_lpn_manage_subscription\
748 (\
749 MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_ADD,\
750 (addr_list),\
751 (count)\
752 );
753
754
770 #define MS_trn_lpn_subscrn_list_remove(addr_list, count)\
771 MS_trn_lpn_manage_subscription\
772 (\
773 MS_TRN_CTRL_OPCODE_FRND_SUBSCRN_LIST_REMOVE,\
774 (addr_list),\
775 (count)\
776 );
777
790 API_RESULT MS_trn_is_valid_lpn_element_address
791 (
792 /* IN */ MS_NET_ADDR addr,
793 /* OUT */ LPN_HANDLE * lpn_handle
794 );
795
809 API_RESULT MS_trn_is_valid_lpn_subscription_address
810 (
811 /* IN */ MS_NET_ADDR addr,
812 /* OUT */ LPN_HANDLE * lpn_handle
813 );
814
828 API_RESULT MS_trn_get_lpn_polltimeout
829 (
830 /* IN */ MS_NET_ADDR lpn_addr,
831 /* OUT */ UINT32 * poll_timeout
832 );
833
847 API_RESULT MS_trn_get_frndship_info
848 (
849 UINT8 role,
850 UINT16 lpn_index,
851 MS_TRN_FRNDSHIP_INFO * node
852 );
853
868 API_RESULT MS_trn_lpn_register_security_update
869 (
870 /* IN */ MS_SUBNET_HANDLE subnet_handle,
871 /* IN */ UCHAR flag,
872 /* IN */ UINT32 ivindex
873 );
874
886 API_RESULT MS_trn_set_heartbeat_publication
887 (
888 /* INOUT */ MS_TRN_HEARTBEAT_PUBLICATION_INFO * info
889 );
890
902 API_RESULT MS_trn_get_heartbeat_publication
903 (
904 /* OUT */ MS_TRN_HEARTBEAT_PUBLICATION_INFO * info
905 );
906
907
919 API_RESULT MS_trn_set_heartbeat_subscription
920 (
921 /* INOUT */ MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO * info
922 );
923
935 API_RESULT MS_trn_get_heartbeat_subscription
936 (
937 /* OUT */ MS_TRN_HEARTBEAT_SUBSCRIPTION_INFO * info
938 );
939
951 API_RESULT MS_trn_trigger_heartbeat (/* IN */ UINT8 change_in_feature_bit);
952
953 #ifdef __cplusplus
954 };
955 #endif
956
961 #endif /* _H_MS_TRN_API_ */
962


EtherMind Mesh SDK (beta): mesh/export/include/MS_version.h Source File

  • mesh
  • export
  • include
MS_version.h
Go to the documentation of this file.
1
8 /*
9 * Copyright (C) 2017. Mindtree Ltd.
10 * All rights reserved.
11 */
12
13 #ifndef _H_MS_VERSION_
14 #define _H_MS_VERSION_
15
16 /* -------------------------------------------- Header File Inclusion */
17 #include "MS_common.h"
18
19 /* -------------------------------------------- Global Definitions */
20
36 #define MS_MAJOR_VERSION_NUMBER 1
37
54 #define MS_MINOR_VERSION_NUMBER 1
55
62 #define MS_SUB_MINOR_VERSION_NUMBER 4
63
64 /* -------------------------------------------- Macros */
65
66 /* -------------------------------------------- Structures/Data Types */
67
69 typedef struct _MS_VERSION_NUMBER
70 {
72 UCHAR major;
73
75 UCHAR minor;
76
78 UCHAR subminor;
79
80 } MS_VERSION_NUMBER;
81
82 /* -------------------------------------------- Function/API Declarations */
83 #ifdef __cplusplus
84 extern "C"{
85 #endif
86
87 #ifdef MS_SUPPORT_STACK_VERSION_INFO
88
101 void MS_get_version_number
102 (
103 /* OUT */ MS_VERSION_NUMBER * version_number
104 );
105 #endif /* MS_SUPPORT_STACK_VERSION_INFO */
106
107 #ifdef __cplusplus
108 };
109 #endif
110
111 #endif /* _H_MS_VERSION_ */
112


EtherMind Mesh SDK (beta): Related Pages

Related Pages
Here is a list of all related documentation pages:
o EtherMind Mesh Stack - General Concepts
o Getting Started
o Bluetooth Mesh - Architecture
o Bluetooth Mesh - Concepts
o Mesh Model
o MESH IP Porting
o Mesh Provisioning
o Repository Structure
\ Release Notes (BLE Mesh)


EtherMind Mesh SDK (beta): mesh/build/doc/release_notes.md Source File

mesh/build/doc/release_notes.md
1 # Release Notes (BLE Mesh)
2
3 ## v0.2.0 (Beta)
4
5 ### Model APIs
6 - Added APIs for various models (Generic, Light etc.)
7
8 ## v0.1.1 (Alpha)
9
10 ### Updated Mesh Porting Section
11 - Added sections for GATT and Security interface requirements.
12 - Edited GAP requirement section to make it more generic, by removing direct mapping with HCI specific interface, as in many environment the Mesh porting layer might have to be mapped to exposed GAP interface, as compared to direct HCI calls.
13
14 ### Corrected .chm view issue observed in some of the systems
15 - Removed reference to embedded javascript in the generated html files causing this observation.


EtherMind Mesh SDK (beta): mesh/build/doc/getting_started/repository_structure.md Source File

mesh/build/doc/getting_started/repository_structure.md
1 # Repository Structure
2
3 EtherMind Mesh repository is organized as follows
4 - `mesh` contains the source code and unit tests for the mesh stack
5 - `mesh/export/include` contains the Mesh API headers for the mesh core stack library
6 - `mesh/private` contains core Mesh implementation
7 - `mesh/build` contains build scripts, makefile for Mesh implementation
8 - `mesh/export/lib` contains libraries used by the mesh stack and examples
9 - `mesh/export/cli` contains Console Interface based applications using the mesh stack
10 - `mesh/export/examples` contains menu based example applications using the mesh stack